Namespaces

ZedGraph Logo ZedGraph Class Library Documentation
Namespaces
Namespaces

Copyright © 2007 John Champion


ZedGraph Namespace

ZedGraph Namespace
Namespaces ► ZedGraph
This namespace contains the entire ZedGraph class library, plus the ZedGraphControl.
Declaration Syntax
C# Visual Basic Visual C++
namespace ZedGraph
Namespace ZedGraph
namespace ZedGraph
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
 | AlignH | Enumeration type for the different horizontal text alignment options
 | AlignP | Enumeration type for the different proximal alignment options
 | AlignV | Enumeration type for the different vertical text alignment options
 | ArrowObj | A class that represents a graphic arrow or line object on the graph. A list of ArrowObj objects is maintained by the GraphObjList collection class.
 | Axis | The Axis class is an abstract base class that encompasses all properties and methods required to define a graph Axis.
 | GraphPane..::AxisChangeEventHandler | A delegate to provide notification through the AxisChangeEvent when AxisChange()() is called.
 | AxisLabel | Class that handles the data associated with text title and its associated font properties. Inherits from Label, and adds IsOmitMag and IsTitleAtCross properties, which are specifically associated with the Axis Title.
 | AxisType | Enumeration type for the various axis types that are available
 | Bar | A class representing all the characteristics of the bar segments that make up a curve on the graph.
 | BarBase | Enumeration type that defines the base axis from which Bar graphs are displayed. The bars can be drawn on any of the four axes (XAxis, X2Axis, YAxis, and Y2Axis).
 | BarItem | Encapsulates a bar type that displays vertical or horizontal bars
 | BarSettings | Class that handles the global settings for bar charts
 | BarType | Enumeration type that defines the available types of BarItem graphs.
 | BasicArrayPointList | A data collection class for ZedGraph, provided as an alternative to PointPairList.
 | Border | A class that encapsulates Border (frame) properties for an object. The Border class is used in a variety of ZedGraph objects to handle the drawing of the Border around the object.
 | BoxObj | A class that represents a bordered and/or filled box (rectangle) object on the graph. A list of BoxObj objects is maintained by the GraphObjList collection class.
 | Chart | Class that handles the properties of the charting area (where the curves are actually drawn), which is bounded by the XAxis, YAxis, and Y2Axis.
 | CollectionPlus | A collection base class containing basic extra functionality to be inherited by CurveList, IPointList, GraphObjList.
 | ColorSymbolRotator | Class used to get the next color/symbol for GraphPane.AddCurve methods.
 | CurveItem..::Comparer | Compares CurveItem's based on the point value at the specified index and for the specified axis. Sort()()
 | ZedGraphControl..::ContextMenuBuilderEventHandler | A delegate that allows subscribing methods to append or modify the context menu.
 | ZedGraphControl..::ContextMenuObjectState | Public enumeration that specifies the type of object present at the Context Menu's mouse location
 | CoordType | Enumeration type for the user-defined coordinate types available. These coordinate types are used the ArrowObj objects and TextObj objects only.
 | CurveItem | This class contains the data and methods for an individual curve within a graph pane. It carries the settings for the curve including the key and item names, colors, symbols and sizes, linetypes, etc.
 | CurveList | A collection class containing a list of CurveItem objects that define the set of curves to be displayed on the graph.
 | DataPoint | A simple storage struct to maintain an individual sampling of data. This only contains two data values in order to reduce to memory load for large datasets. (e.g., no Tag or Z property)
 | DataSourcePointList |
 | DateUnit | Enumeration type for the various axis date and time unit types that are available
 | Chart..::Default | A simple struct that defines the default property values for the Chart class.
 | Scale..::Default | A simple struct that defines the default property values for the Scale class.
 | GasGaugeNeedle..::Default | Specify the default property values for the GasGaugeNeedle class.
 | LineBase..::Default | A simple struct that defines the default property values for the LineBase class.
 | OHLCBar..::Default | A simple struct that defines the default property values for the OHLCBar class.
 | Axis..::Default | A simple struct that defines the default property values for the Axis class.
 | GraphObj..::Default | A simple struct that defines the default property values for the GraphObj class.
 | ArrowObj..::Default | A simple struct that defines the default property values for the ArrowObj class.
 | MinorTic..::Default | A simple struct that defines the default property values for the MinorTic class.
 | MajorTic..::Default | A simple struct that defines the default property values for the MinorTic class.
 | PaneBase..::Default | A simple struct that defines the default property values for the PaneBase class.
 | MasterPane..::Default | A simple struct that defines the default property values for the MasterPane class.
 | GapLabel..::Default | A simple struct that defines the default property values for the GapLabel class.
 | GraphPane..::Default | A simple struct that defines the default property values for the GraphPane class.
 | XAxis..::Default | A simple struct that defines the default property values for the XAxis class.
 | PieItem..::Default | Specify the default property values for the PieItem class.
 | MinorGrid..::Default | A simple struct that defines the default property values for the MinorGrid class.
 | MajorGrid..::Default | A simple struct that defines the default property values for the MajorGrid class.
 | JapaneseCandleStick..::Default | A simple struct that defines the default property values for the JapaneseCandleStick class.
 | Y2Axis..::Default | A simple subclass of the Y2Axis..::Default class that defines the default property values for the Y2Axis class.
 | BoxObj..::Default | A simple struct that defines the default property values for the ArrowObj class.
 | Symbol..::Default | A simple struct that defines the default property values for the Symbol class.
 | X2Axis..::Default | A simple struct that defines the default property values for the X2Axis class.
 | Line..::Default | A simple struct that defines the default property values for the Line class.
 | FontSpec..::Default | A simple struct that defines the default property values for the FontSpec class.
 | Border..::Default | A simple struct that defines the default property values for the Fill class.
 | BarSettings..::Default | A simple struct that defines the default property values for the BarSettings class.
 | Margin..::Default | A simple struct that defines the default property values for the Margin class.
 | Bar..::Default | A simple struct that defines the default property values for the Bar class.
 | HiLowBar..::Default | A simple struct that defines the default property values for the HiLowBar class.
 | GasGaugeRegion..::Default | Specify the default property values for the GasGaugeRegion class.
 | YAxis..::Default | A simple struct that defines the default property values for the YAxis class.
 | Legend..::Default | A simple struct that defines the default property values for the Legend class.
 | Fill..::Default | A simple struct that defines the default property values for the Fill class.
 | ErrorBar..::Default | A simple struct that defines the default property values for the ErrorBar class.
 | TextObj..::Default | A simple struct that defines the default property values for the TextObj class.
 | ImageObj..::Default | A simple struct that defines the default property values for the ImageObj class.
 | EllipseObj | A class that represents a bordered and/or filled ellipse object on the graph. A list of EllipseObj objects is maintained by the GraphObjList collection class. The ellipse is defined as the ellipse that would be contained by the rectangular box as defined by the Location property.
 | ErrorBar | This class handles the drawing of the curve ErrorBar objects. The Error Bars are the vertical lines with a symbol at each end.
 | ErrorBarItem | Encapsulates an "Error Bar" curve type that displays a vertical or horizontal line with a symbol at each end.
 | Fill | A class that encapsulates color-fill properties for an object. The Fill class is used in Rect, Rect, Legend, Bar, and Line objects.
 | FillType | Enumeration type for the various types of fills that can be used with Bar charts.
 | FilteredPointList | An example of an IPointList implementation that stores large datasets, and selectively filters the output data depending on the displayed range.
 | FontSpec | The FontSpec class is a generic font class that maintains the font family, attributes, colors, border and fill modes, font size, and angle information. This class can render text with a variety of alignment options using the AlignH and AlignV parameters in the Draw(Graphics, PaneBase, String, Single, Single, AlignH, AlignV, Single) method.
 | GapLabel | Class that handles the data associated with a text title and its associated font properties. Inherits from Label, and adds the Gap property for use by the Axis and PaneBase objects.
 | GasGaugeNeedle | A class representing a needle on the GasGuage chart GasGaugeNeedles.
 | GasGaugeRegion | A class representing a region on the GasGuage chart GasGaugeRegions.
 | GraphObj | An abstract base class that represents a text object on the graph. A list of GraphObj objects is maintained by the GraphObjList collection class.
 | GraphObjList | A collection class containing a list of TextObj objects to be displayed on the graph.
 | GraphPane | Class GraphPane encapsulates the graph pane, which is all display elements associated with an individual graph.
 | HiLowBar | This class handles the drawing of the curve HiLowBar objects. The Hi-Low Bars are the "floating" bars that have a lower and upper value and appear at each defined point.
 | HiLowBarItem | Encapsulates an "High-Low" Bar curve type that displays a bar in which both the bottom and the top of the bar are set by data valuesfrom the PointPair struct.
 | HSBColor | Hue-Saturation-Brightness Color class to store a color value, and to manage conversions to and from RGB colors in the Color struct.
 | ImageObj | A class that represents an image object on the graph. A list of GraphObj objects is maintained by the GraphObjList collection class.
 | IPointList | An interface to a collection class containing data that define the set of points to be displayed on the curve.
 | IPointListEdit | An interface to a collection class containing data that define the set of points to be displayed on the curve.
 | JapaneseCandleStick | This class handles the drawing of the curve JapaneseCandleStick objects.
 | JapaneseCandleStickItem | Encapsulates a Japanese CandleStick curve type that displays a vertical (or horizontal) line displaying the range of data values at each sample point, plus a filled bar signifying the opening and closing value for the sample.
 | Label | Class that handles the data associated with text title and its associated font properties
 | Legend | This class encapsulates the chart Legend that is displayed in the GraphPane
 | LegendPos | Enumeration type that defines the possible legend locations
 | Line | A class representing all the characteristics of the Line segments that make up a curve on the graph.
 | LineBase | A class that handles the basic attributes of a line segment.
 | LineItem | Encapsulates a curve type that is displayed as a line and/or a set of symbols at each point.
 | LineObj | A class that represents a line segment object on the graph. A list of GraphObj objects is maintained by the GraphObjList collection class.
 | LineType | Enumeration type that defines the available types of LineItem graphs.
 | Link | A class that maintains hyperlink information for a clickable object on the graph.
 | ZedGraphControl..::LinkEventHandler | A delegate that allows notification of clicks on ZedGraph objects that have active links enabled
 | Location | A class than contains information about the position of an object on the graph.
 | MajorGrid | Class that handles the data associated with the major grid lines on the chart. Inherits from MinorGrid.
 | MajorTic | Class that holds the specific properties for the major tics. Inherits from MinorTic.
 | Margin | Class that handles that stores the margin properties for the GraphPane
 | MasterPane | A collection class containing a list of GraphPane objects organized together in some form.
 | MinorGrid | Class that holds the specific properties for the minor grid.
 | MinorTic | Class that holds the specific properties for the minor tics.
 | NoDupePointList | A collection class to maintain a set of samples.
 | OHLCBar | This class handles the drawing of the curve OHLCBar objects.
 | OHLCBarItem | Encapsulates a CandleStick curve type that displays a vertical (or horizontal) line displaying the range of data values at each sample point, plus an starting mark and an ending mark signifying the opening and closing value for the sample.
 | PaneBase | An abstract base class that defines basic functionality for handling a pane. This class is the parent class for MasterPane and GraphPane.
 | PaneLayout | Define the auto layout options for the SetLayout(Graphics, PaneLayout) method.
 | PaneLayoutMgr | internal class to store pane layout details for the MasterPane
 | PaneList | A collection class containing a list of GraphPane objects.
 | PerfDataType | An enum used to specify the X or Y data type of interest -- see XData and YData.
 | PerformanceData | Sample data structure containing a variety of data values, in this case the values are related in that they correspond to the same time value.
 | PieItem | A class representing a pie chart object comprised of one or more PieItems.
 | PieLabelType | Enumeration that determines the type of label that is displayed for each pie slice (see LabelType).
 | PointD | Simple struct that stores X and Y coordinates as doubles.
 | ZedGraphControl..::PointEditHandler | A delegate that receives notification after a point-edit operation is completed.
 | PointPair | A simple point represented by an (X,Y,Z) group of double values.
 | PointPair4 | The basic PointPair class holds three data values (X, Y, Z). This class extends the basic PointPair to contain four data values (X, Y, Z, T).
 | PointPairBase | This is a base class that provides base-level functionality for a data point consisting of an (X,Y) pair of double values.
 | PointPair..::PointPairComparer | Compares points based on their x values. Is setup to be used in an ascending order sort. Sort()()
 | PointPair..::PointPairComparerY | Compares points based on their y values. Is setup to be used in an ascending order sort. Sort()()
 | PointPairCV | A simple instance that stores a data point (X, Y, Z). This differs from a regular PointPair in that it maps the ColorValue property to an independent value. That is, ColorValue and Z are not related (as they are in the PointPair).
 | PointPairList | A collection class containing a list of PointPair objects that define the set of points to be displayed on the curve.
 | ZedGraphControl..::PointValueHandler | A delegate that allows custom formatting of the point value tooltips
 | PolyObj | A class that represents a bordered and/or filled polygon object on the graph. A list of PolyObj objects is maintained by the GraphObjList collection class.
 | RadarPointList | A class containing a set of data values to be plotted as a RadarPlot. This class will effectively convert the data into PointPair objects by converting the polar coordinates to rectangular coordinates
 | RenderModeType | Enum for specifying the type of data to be returned by the ZedGraphWeb Render() method.
 | RollingPointPairList | A class that provides a rolling list of PointPair objects. This is essentially a first-in-first-out (FIFO) queue with a fixed capacity which allows 'rolling' (or oscilloscope like) graphs to be be animated without having the overhead of an ever-growing ArrayList. The queue is constructed with a fixed capacity and new points can be enqueued. When the capacity is reached the oldest (first in) PointPair is overwritten. However, when accessing via IPointList, the PointPair objects are seen in the order in which they were enqeued. RollingPointPairList supports data editing through the IPointListEdit interface. Colin Green with mods by John Champion $Date: 2007/02/18 05:51:54 $
 | Sample | A simple storage class to maintain an individual sampling of data
 | SampleMultiPointList | A sample class that holds an internal collection, and implements the IPointList interface so that it can be used by ZedGraph as curve data.
 | SamplePointList | A collection class to maintain a set of samples
 | SampleType | enumeration used to indicate which type of data will be plotted.
 | Scale | The Scale class is an abstract base class that encompasses the properties and methods associated with a scale of data.
 | Axis..::ScaleFormatHandler | A delegate that allows full custom formatting of the Axis labels
 | ScaleState | A class that captures an Axis scale range.
 | ScaleStateList | A collection class that maintains a list of ScaleState objects, corresponding to the list of Axis objects from YAxisList or Y2AxisList.
 | Axis..::ScaleTitleEventHandler | Allow customization of title based on user preferences.
 | ZedGraphControl..::ScrollDoneHandler | A delegate that allows notification of scroll events.
 | ZedGraphControl..::ScrollProgressHandler | A delegate that allows notification of scroll events.
 | ScrollRange | A simple struct to store minimum and maximum Double type values for the scroll range
 | ScrollRangeList | A collection class containing a list of ScrollRange objects.
 | Selection |
 | SortType | Enumeration type that defines which set of data points - X or Y - is used Sort()() to perform the sort.
 | ZoomState..::StateType | An enumeration that describes whether a given state is the result of a Pan or Zoom operation.
 | StepType | Enumeration type that defines how a curve is drawn. Curves can be drawn as ordinary lines by connecting the points directly, or in a stair-step fashion as a series of discrete, constant values. In a stair step plot, all lines segments are either horizontal or vertical. In a non-step (line) plot, the lines can be any angle.
 | StickItem | Encapsulates a curve type that is displayed as a series of vertical "sticks", one at each defined point.
 | StockPointList | A collection class containing a list of StockPt objects that define the set of points to be displayed on the curve.
 | StockPt | The basic PointPair class holds three data values (X, Y, Z). This class extends the basic PointPair to contain five data values (X, Y, Z, Open, Close).
 | Symbol | This class handles the drawing of the curve Symbol objects. The symbols are the small shapes that appear over each defined point along the curve.
 | SymbolType | Enumeration type for the various symbol shapes that are available
 | TextObj | A class that represents a text object on the graph. A list of GraphObj objects is maintained by the GraphObjList collection class.
 | ValueHandler | A class designed to simplify the process of getting the actual value for the various stacked and regular curve types
 | X2Axis | X2Axis inherits from Axis, and defines the special characteristics of a horizontal axis, specifically located at the top of the Rect of the GraphPane object
 | XAxis | XAxis inherits from Axis, and defines the special characteristics of a horizontal axis, specifically located at the bottom of the Rect of the GraphPane object
 | XDate | This struct encapsulates a date and time value, and handles associated calculations and conversions between various formats.
 | Y2Axis | Y2Axis inherits from Axis, and defines the special characteristics of a vertical axis, specifically located on the right side of the Rect of the GraphPane object
 | Y2AxisList | A collection class containing a list of YAxis objects.
 | YAxis | YAxis inherits from Axis, and defines the special characteristics of a vertical axis, specifically located on the right side of the Rect of the GraphPane object
 | YAxisList | A collection class containing a list of YAxis objects.
 | ZedGraphControl | The ZedGraphControl class provides a UserControl interface to the ZedGraph class library. This allows ZedGraph to be installed as a control in the Visual Studio toolbox. You can use the control by simply dragging it onto a form in the Visual Studio form editor. All graph attributes are accessible via the GraphPane property.
 | ZedGraphException | An exception thrown by ZedGraph. A child class of ApplicationException.
 | ZedGraphControl..::ZedMouseEventHandler | A delegate that allows notification of mouse events on Graph objects.
 | ZedGraphControl..::ZoomEventHandler | A delegate that allows notification of zoom and pan events.
 | ZoomState | A class that captures all the scale range settings for a GraphPane.
 | ZoomStateStack | A LIFO stack of prior ZoomState objects, used to allow zooming out to prior states (of scale range settings).
 | ZOrder | Enumeration that specifies a Z-Order position for GraphObj objects.


AlignH Enumeration

AlignH Enumeration
Namespaces ► ZedGraph ► AlignH
Enumeration type for the different horizontal text alignment options
Declaration Syntax
C# Visual Basic Visual C++
public enum AlignH
Public Enumeration AlignH
public enum class AlignH
Members
Member | Description
Left | Position the text so that its left edge is aligned with the specified X,Y location. Used by the Draw(Graphics, PaneBase, String, Single, Single, AlignH, AlignV, Single) method.
Center | Position the text so that its center is aligned (horizontally) with the specified X,Y location. Used by the Draw(Graphics, PaneBase, String, Single, Single, AlignH, AlignV, Single) method.
Right | Position the text so that its right edge is aligned with the specified X,Y location. Used by the Draw(Graphics, PaneBase, String, Single, Single, AlignH, AlignV, Single) method.
See Also
FontSpec

Copyright © 2007 John Champion

Assembly: ZedGraph (Module: ZedGraph) Version: 5.1.0.621


AlignP Enumeration

AlignP Enumeration
Namespaces ► ZedGraph ► AlignP
Enumeration type for the different proximal alignment options
Declaration Syntax
C# Visual Basic Visual C++
public enum AlignP
Public Enumeration AlignP
public enum class AlignP
Members
Member | Description
Inside | Position the text so that its "inside" edge (the edge that is nearest to the alignment reference point or object) is aligned. Used by the Align method to align text to the axis.
Center | Position the text so that its center is aligned with the reference object or point. Used by the Align method to align text to the axis.
Outside | Position the text so that its right edge (the edge that is farthest from the alignment reference point or object) is aligned. Used by the Align method to align text to the axis.
See Also
FontSpec
Align


AlignV Enumeration

AlignV Enumeration
Namespaces ► ZedGraph ► AlignV
Enumeration type for the different vertical text alignment options
Declaration Syntax
C# Visual Basic Visual C++
public enum AlignV
Public Enumeration AlignV
public enum class AlignV
Members
Member | Description
Top | Position the text so that its top edge is aligned with the specified X,Y location. Used by the Draw(Graphics, PaneBase, String, Single, Single, AlignH, AlignV, Single) method.
Center | Position the text so that its center is aligned (vertically) with the specified X,Y location. Used by the Draw(Graphics, PaneBase, String, Single, Single, AlignH, AlignV, Single) method.
Bottom | Position the text so that its bottom edge is aligned with the specified X,Y location. Used by the Draw(Graphics, PaneBase, String, Single, Single, AlignH, AlignV, Single) method.


ArrowObj Class

ArrowObj Class
Namespaces ► ZedGraph ► ArrowObj
A class that represents a graphic arrow or line object on the graph. A list of ArrowObj objects is maintained by the GraphObjList collection class.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ArrowObj : LineObj, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class ArrowObj _
    Inherits LineObj _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class ArrowObj : public LineObj,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ArrowObjArrowObjNew(Color, Single, Double, Double, Double, Double) | A constructor that allows the position, color, and size of the ArrowObj to be pre-specified.
 | ArrowObjArrowObjNew(Double, Double, Double, Double) | A constructor that allows only the position of the arrow to be pre-specified. All other properties are set to default values
 | ArrowObjArrowObjNew()() | Default constructor -- places the ArrowObj at location (0,0) to (1,1). All other values are defaulted.
 | ArrowObjArrowObjNew(ArrowObj) | The Copy Constructor
 | Clone()() | Typesafe, deep-copy clone method.
 | Draw(Graphics, PaneBase, Single) | Render this object to the specified Graphics device. (Overrides LineObj.Draw(Graphics, PaneBase, Single).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCoords(PaneBase, Graphics, Single, String%, String%) | Determines the shape type and Coords values for this GraphObj (Inherited from LineObj.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides LineObj.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsArrowHead | Determines whether or not to draw an arrowhead
 | IsClippedToChartRect | Gets or sets a value that determines whether or not the rendering of this GraphObj will be clipped to the Rect. (Inherited from GraphObj.)
 | IsInFrontOfData | true if the ZOrder of this object is set to put it in front of the CurveItem data points. (Inherited from GraphObj.)
 | IsVisible | Gets or sets a value that determines if this GraphObj will be visible in the graph. true displays the item, false hides it. (Inherited from GraphObj.)
 | Line | A LineBase class that contains the attributes for drawing this LineObj. (Inherited from LineObj.)
 | Link | Gets or sets the hyperlink information for this GraphObj. (Inherited from GraphObj.)
 | Location | The Location struct that describes the location for this GraphObj. (Inherited from GraphObj.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PointInBox(PointF, PaneBase, Graphics, Single) | Determine if the specified screen point lies inside the bounding box of this LineObj. (Inherited from LineObj.)
 | schema3 | Current schema value that defines the version of the serialized file
 | Size | The size of the arrowhead.
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the GraphObj. ZedGraph does not use this value for any purpose. (Inherited from GraphObj.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ZOrder | Gets or sets a value that determines the z-order "depth" of this item relative to other graphic objects. (Inherited from GraphObj.)
Inheritance Hierarchy
Object
 | GraphObj
 |  | LineObj
 |  |  | ArrowObj


ArrowObj Constructor

ArrowObj Constructor
Namespaces ► ZedGraph ► ArrowObj ► ArrowObjArrowObjNew()()
Constructors for the ArrowObj object
Members
Icon | Member | Description
 | ArrowObjArrowObjNew(Color, Single, Double, Double, Double, Double) | A constructor that allows the position, color, and size of the ArrowObj to be pre-specified.
 | ArrowObjArrowObjNew(Double, Double, Double, Double) | A constructor that allows only the position of the arrow to be pre-specified. All other properties are set to default values
 | ArrowObjArrowObjNew()() | Default constructor -- places the ArrowObj at location (0,0) to (1,1). All other values are defaulted.
 | ArrowObjArrowObjNew(ArrowObj) | The Copy Constructor


ArrowObj Constructor

ArrowObj Constructor
Namespaces ► ZedGraph ► ArrowObj ► ArrowObjArrowObjNew()()
Default constructor -- places the ArrowObj at location (0,0) to (1,1). All other values are defaulted.
Declaration Syntax
C# Visual Basic Visual C++
public ArrowObj()
Public Sub New
public:
ArrowObj ()


ArrowObj Constructor (x1, y1, x2, y2)

ArrowObj Constructor (x1, y1, x2, y2)
Namespaces ► ZedGraph ► ArrowObj ► ArrowObjArrowObjNew(Double, Double, Double, Double)
A constructor that allows only the position of the arrow to be pre-specified. All other properties are set to default values
Declaration Syntax
C# Visual Basic Visual C++
public ArrowObj(
    double x1,
    double y1,
    double x2,
    double y2
)
Public Sub New ( _
    x1 As Double, _
    y1 As Double, _
    x2 As Double, _
    y2 As Double _
)
public:
ArrowObj (
    double x1,
    double y1,
    double x2,
    double y2
)
Parameters
x1 (Double)
The x position of the starting point that defines the ArrowObj. The units of this position are specified by the CoordinateFrame property.
y1 (Double)
The y position of the starting point that defines the ArrowObj. The units of this position are specified by the CoordinateFrame property.
x2 (Double)
The x position of the ending point that defines the ArrowObj. The units of this position are specified by the CoordinateFrame property.
y2 (Double)
The y position of the ending point that defines the ArrowObj. The units of this position are specified by the CoordinateFrame property.


ArrowObj Constructor (color, size, x1, y1, x2, y2)

ArrowObj Constructor (color, size, x1, y1, x2, y2)
Namespaces ► ZedGraph ► ArrowObj ► ArrowObjArrowObjNew(Color, Single, Double, Double, Double, Double)
A constructor that allows the position, color, and size of the ArrowObj to be pre-specified.
Declaration Syntax
C# Visual Basic Visual C++
public ArrowObj(
    Color color,
    float size,
    double x1,
    double y1,
    double x2,
    double y2
)
Public Sub New ( _
    color As Color, _
    size As Single, _
    x1 As Double, _
    y1 As Double, _
    x2 As Double, _
    y2 As Double _
)
public:
ArrowObj (
    Color color,
    float size,
    double x1,
    double y1,
    double x2,
    double y2
)
Parameters
color (Color)
An arbitrary Color specification for the arrow
size (Single)
The size of the arrowhead, measured in points.
x1 (Double)
The x position of the starting point that defines the arrow. The units of this position are specified by the CoordinateFrame property.
y1 (Double)
The y position of the starting point that defines the arrow. The units of this position are specified by the CoordinateFrame property.
x2 (Double)
The x position of the ending point that defines the arrow. The units of this position are specified by the CoordinateFrame property.
y2 (Double)
The y position of the ending point that defines the arrow. The units of this position are specified by the CoordinateFrame property.


ArrowObj Constructor (rhs)

ArrowObj Constructor (rhs)
Namespaces ► ZedGraph ► ArrowObj ► ArrowObjArrowObjNew(ArrowObj)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ArrowObj(
    ArrowObj rhs
)
Public Sub New ( _
    rhs As ArrowObj _
)
public:
ArrowObj (
    ArrowObj^ rhs
)
Parameters
rhs (ArrowObj)
The ArrowObj object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► ArrowObj ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public ArrowObj Clone()
Public Function Clone As ArrowObj
public:
ArrowObj^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, scaleFactor)

Draw Method (g, pane, scaleFactor)
Namespaces ► ZedGraph ► ArrowObj ► Draw(Graphics, PaneBase, Single)
Render this object to the specified Graphics device.
Declaration Syntax
C# Visual Basic Visual C++
public override void Draw(
    Graphics g,
    PaneBase pane,
    float scaleFactor
)
Public Overrides Sub Draw ( _
    g As Graphics, _
    pane As PaneBase, _
    scaleFactor As Single _
)
public:
virtual void Draw (
    Graphics^ g,
    PaneBase^ pane,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Remarks
This method is normally only called by the Draw method of the parent GraphObjList collection object.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► ArrowObj ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsArrowHead Property

IsArrowHead Property
Namespaces ► ZedGraph ► ArrowObj ► IsArrowHead
Determines whether or not to draw an arrowhead
Declaration Syntax
C# Visual Basic Visual C++
public bool IsArrowHead{ get; set;}
Public Property IsArrowHead As Boolean
public:
property bool IsArrowHead {
    bool get ();
    void set (bool value);
}
Value
true to show the arrowhead, false to show the line segment only
See Also
IsArrowHead


schema3 Field

schema3 Field
Namespaces ► ZedGraph ► ArrowObj ► schema3
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema3
Public Const schema3 As Integer
public:
literal int schema3


Size Property

Size Property
Namespaces ► ZedGraph ► ArrowObj ► Size
The size of the arrowhead.
Declaration Syntax
C# Visual Basic Visual C++
public float Size{ get; set;}
Public Property Size As Single
public:
property float Size {
    float get ();
    void set (float value);
}
Value
The size is defined in points (1/72 inch)
Remarks
The display of the arrowhead can be enabled or disabled with the IsArrowHead property.
See Also
Size


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► ArrowObj ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


ArrowObj.Default Structure

ArrowObj..::Default Structure
Namespaces ► ZedGraph ► ArrowObj ► ArrowObj..::Default
A simple struct that defines the default property values for the ArrowObj class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsArrowHead | The default display mode for the ArrowObj item arrowhead (IsArrowHead property). true to show the arrowhead, false to hide it.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Size | The default size for the ArrowObj item arrowhead (Size property). Units are in points (1/72 inch).
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


IsArrowHead Field

IsArrowHead Field
Namespaces ► ZedGraph ► ArrowObj..::Default ► IsArrowHead
The default display mode for the ArrowObj item arrowhead (IsArrowHead property). true to show the arrowhead, false to hide it.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsArrowHead
Public Shared IsArrowHead As Boolean
public:
static bool IsArrowHead


Size Field

Size Field
Namespaces ► ZedGraph ► ArrowObj..::Default ► Size
The default size for the ArrowObj item arrowhead (Size property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float Size
Public Shared Size As Single
public:
static float Size


Axis Class

Axis Class
Namespaces ► ZedGraph ► Axis
The Axis class is an abstract base class that encompasses all properties and methods required to define a graph Axis.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class Axis : ISerializable,
    ICloneable
<SerializableAttribute> _
Public MustInherit Class Axis _
    Implements ISerializable, ICloneable
[SerializableAttribute]
public ref class Axis abstract : ISerializable,
    ICloneable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AxisAxisNew()() | Default constructor for Axis that sets all axis properties to default values as defined in the Axis..::Default class.
 | AxisAxisNew(String) | Constructor for Axis that sets all axis properties to default values as defined in the Axis..::Default class, except for the Title.
 | AxisAxisNew(Axis) | The Copy Constructor.
 | AxisGap | The size of the gap between multiple axes (see YAxisList and Y2AxisList).
 | CalcSpace(Graphics, GraphPane, Single, Single%) | Calculate the space required (pixels) for this Axis object.
 | Color | The color to use for drawing this Axis.
 | Cross | Gets or sets the scale value at which this axis should cross the "other" axis.
 | CrossAuto | Gets or sets a value that determines whether or not the Cross value is set automatically.
 | Draw(Graphics, GraphPane, Single, Single) | Do all rendering associated with this Axis to the specified Graphics device.
 | DrawMinorTics(Graphics, GraphPane, Double, Single, Single, Single) | Draw the minor tic marks as required for this Axis.
 | DrawTitle(Graphics, GraphPane, Single, Single) | Draw the title for this Axis.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCrossAxis(GraphPane) | Gets the "Cross" axis that corresponds to this axis.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAxisSegmentVisible | Gets or sets a property that determines whether or not the axis segment (the line that represents the axis itself) is drawn.
 | IsVisible | This property determines whether or not the Axis is shown.
 | MajorGrid | Gets a reference to the MajorGrid class that contains the properties of the major grid.
 | MajorTic | Gets a reference to the MajorTic class instance for this Axis. This class stores all the major tic settings.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinorGrid | Gets a reference to the MinorGrid class that contains the properties of the minor grid.
 | MinorTic | Gets a reference to the MinorTic class instance for this Axis. This class stores all the minor tic settings.
 | MinSpace | Gets or sets the minimum axis space allocation.
 | ResetAutoScale(GraphPane, Graphics) | Restore the scale ranging to automatic mode, and recalculate the Axis scale ranges
 | Scale | Gets the Scale instance associated with this Axis.
 | ScaleFormatEvent | Subscribe to this event to handle custom formatting of the scale labels.
 | ScaleTitleEvent | Allow customization of the title when the scale is very large Subscribe to this event to handle custom formatting of the scale axis label.
 | schema | Current schema value that defines the version of the serialized file
 | SetMinSpaceBuffer(Graphics, GraphPane, Single, Boolean) | This method will set the MinSpace property for this Axis using the currently required space multiplied by a fraction ().
 | SetTransformMatrix(Graphics, GraphPane, Single) | Setup the Transform Matrix to handle drawing of this Axis
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone.
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the Axis. ZedGraph does not use this value for any purpose.
 | Title | Gets or sets the Label class that contains the title of this Axis.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets or sets the AxisType for this Axis.
Remarks
This class is inherited by the XAxis, YAxis, and Y2Axis classes to define specific characteristics for those types.
Inheritance Hierarchy
Object
 | Axis
 |  | XAxis
 |  | Y2Axis
 |  | X2Axis
 |  | YAxis


Axis Constructor

Axis Constructor
Namespaces ► ZedGraph ► Axis ► AxisAxisNew()()
Members
Icon | Member | Description
 | AxisAxisNew()() | Default constructor for Axis that sets all axis properties to default values as defined in the Axis..::Default class.
 | AxisAxisNew(String) | Constructor for Axis that sets all axis properties to default values as defined in the Axis..::Default class, except for the Title.
 | AxisAxisNew(Axis) | The Copy Constructor.


Axis Constructor

Axis Constructor
Namespaces ► ZedGraph ► Axis ► AxisAxisNew()()
Default constructor for Axis that sets all axis properties to default values as defined in the Axis..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public Axis()
Public Sub New
public:
Axis ()


Axis Constructor (title)

Axis Constructor (title)
Namespaces ► ZedGraph ► Axis ► AxisAxisNew(String)
Constructor for Axis that sets all axis properties to default values as defined in the Axis..::Default class, except for the Title.
Declaration Syntax
C# Visual Basic Visual C++
public Axis(
    string title
)
Public Sub New ( _
    title As String _
)
public:
Axis (
    String^ title
)
Parameters
title (String)
A string containing the axis title


Axis Constructor (rhs)

Axis Constructor (rhs)
Namespaces ► ZedGraph ► Axis ► AxisAxisNew(Axis)
The Copy Constructor.
Declaration Syntax
C# Visual Basic Visual C++
public Axis(
    Axis rhs
)
Public Sub New ( _
    rhs As Axis _
)
public:
Axis (
    Axis^ rhs
)
Parameters
rhs (Axis)
The Axis object from which to copy


AxisGap Property

AxisGap Property
Namespaces ► ZedGraph ► Axis ► AxisGap
The size of the gap between multiple axes (see YAxisList and Y2AxisList).
Declaration Syntax
C# Visual Basic Visual C++
public float AxisGap{ get; set;}
Public Property AxisGap As Single
public:
property float AxisGap {
    float get ();
    void set (float value);
}
Value
The axis gap is measured in points (1/72 inch)
Remarks
This size will be scaled according to the CalcScaleFactor()() for the GraphPane
See Also
AxisGap


CalcSpace Method (g, pane, scaleFactor, fixedSpace)

CalcSpace Method (g, pane, scaleFactor, fixedSpace)
Namespaces ► ZedGraph ► Axis ► CalcSpace(Graphics, GraphPane, Single, Single%)
Calculate the space required (pixels) for this Axis object.
Declaration Syntax
C# Visual Basic Visual C++
public float CalcSpace(
    Graphics g,
    GraphPane pane,
    float scaleFactor,
    out float fixedSpace
)
Public Function CalcSpace ( _
    g As Graphics, _
    pane As GraphPane, _
    scaleFactor As Single, _
    <OutAttribute> ByRef fixedSpace As Single _
) As Single
public:
float CalcSpace (
    Graphics^ g,
    GraphPane^ pane,
    float scaleFactor,
    [OutAttribute] float% fixedSpace
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
fixedSpace (Single %)
The amount of space (pixels) at the edge of the ChartRect that is always required for this axis, even if the axis is shifted by the Cross value.
Return Value
Returns the space, in pixels, required for this axis (between the rect and ChartRect)
Remarks
This is the total space (vertical space for the X axis, horizontal space for the Y axes) required to contain the axis. If Cross is zero, then this space will be the space required between the Rect and the Rect. This method sets the internal values of _tmpSpace()() for use by the CalcChartRect(Graphics) method.


Color Property

Color Property
Namespaces ► ZedGraph ► Axis ► Color
The color to use for drawing this Axis.
Declaration Syntax
C# Visual Basic Visual C++
public Color Color{ get; set;}
Public Property Color As Color
public:
property Color Color {
    Color get ();
    void set (Color value);
}
Value
The color is defined using the Color class
Remarks
This affects only the axis segment (see IsAxisSegmentVisible), since the Title, Scale, MajorTic, MinorTic, MajorGrid, and MinorGrid all have their own color specification.
See Also
Color
IsVisible


Cross Property

Cross Property
Namespaces ► ZedGraph ► Axis ► Cross
Gets or sets the scale value at which this axis should cross the "other" axis.
Declaration Syntax
C# Visual Basic Visual C++
public double Cross{ get; set;}
Public Property Cross As Double
public:
property double Cross {
    double get ();
    void set (double value);
}
Value
The value is defined in user scale units
Remarks
This property allows the axis to be shifted away from its default location. For example, for a graph with an X range from -100 to +100, the Y Axis can be located at the X=0 value rather than the left edge of the ChartRect. This value can be set automatically based on the state of CrossAuto. If this value is set manually, then CrossAuto will also be set to false. The "other" axis is the axis the handles the second dimension for the graph. For the XAxis, the "other" axis is the YAxis. For the YAxis or Y2Axis, the "other" axis is the XAxis.
See Also
Min
Max
MajorStep
CrossAuto


CrossAuto Property

CrossAuto Property
Namespaces ► ZedGraph ► Axis ► CrossAuto
Gets or sets a value that determines whether or not the Cross value is set automatically.
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossAuto{ get; set;}
Public Property CrossAuto As Boolean
public:
property bool CrossAuto {
    bool get ();
    void set (bool value);
}
Value
Set to true to have ZedGraph put the axis in the default location, or false to specify the axis location manually with a Cross value.
See Also
Min
Max
MajorStep
Cross


Draw Method (g, pane, scaleFactor, shiftPos)

Draw Method (g, pane, scaleFactor, shiftPos)
Namespaces ► ZedGraph ► Axis ► Draw(Graphics, GraphPane, Single, Single)
Do all rendering associated with this Axis to the specified Graphics device.
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    GraphPane pane,
    float scaleFactor,
    float shiftPos
)
Public Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    scaleFactor As Single, _
    shiftPos As Single _
)
public:
void Draw (
    Graphics^ g,
    GraphPane^ pane,
    float scaleFactor,
    float shiftPos
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
shiftPos (Single)
The number of pixels to shift to account for non-primary axis position (e.g., the second, third, fourth, etc. YAxis or Y2Axis.
Remarks
This method is normally only called by the Draw method of the parent GraphPane object.


DrawMinorTics Method (g, pane, baseVal, shift, scaleFactor, topPix)

DrawMinorTics Method (g, pane, baseVal, shift, scaleFactor, topPix)
Namespaces ► ZedGraph ► Axis ► DrawMinorTics(Graphics, GraphPane, Double, Single, Single, Single)
Draw the minor tic marks as required for this Axis.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawMinorTics(
    Graphics g,
    GraphPane pane,
    double baseVal,
    float shift,
    float scaleFactor,
    float topPix
)
Public Sub DrawMinorTics ( _
    g As Graphics, _
    pane As GraphPane, _
    baseVal As Double, _
    shift As Single, _
    scaleFactor As Single, _
    topPix As Single _
)
public:
void DrawMinorTics (
    Graphics^ g,
    GraphPane^ pane,
    double baseVal,
    float shift,
    float scaleFactor,
    float topPix
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
baseVal (Double)
The scale value for the first major tic position. This is the reference point for all other tic marks.
shift (Single)
The number of pixels to shift this axis, based on the value of Cross. A positive value is into the ChartRect relative to the default axis position.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
topPix (Single)
The pixel location of the far side of the ChartRect from this axis. This value is the ChartRect.Height for the XAxis, or the ChartRect.Width for the YAxis and Y2Axis.


DrawTitle Method (g, pane, shiftPos, scaleFactor)

DrawTitle Method (g, pane, shiftPos, scaleFactor)
Namespaces ► ZedGraph ► Axis ► DrawTitle(Graphics, GraphPane, Single, Single)
Draw the title for this Axis.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawTitle(
    Graphics g,
    GraphPane pane,
    float shiftPos,
    float scaleFactor
)
Public Sub DrawTitle ( _
    g As Graphics, _
    pane As GraphPane, _
    shiftPos As Single, _
    scaleFactor As Single _
)
public:
void DrawTitle (
    Graphics^ g,
    GraphPane^ pane,
    float shiftPos,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
shiftPos (Single)
The number of pixels to shift this axis, based on the value of Cross. A positive value is into the ChartRect relative to the default axis position.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Remarks
On entry, it is assumed that the graphics transform has been configured so that the origin is at the left side of this axis, and the axis is aligned along the X coordinate direction.


GetCrossAxis Method (pane)

GetCrossAxis Method (pane)
Namespaces ► ZedGraph ► Axis ► GetCrossAxis(GraphPane)
Gets the "Cross" axis that corresponds to this axis.
Declaration Syntax
C# Visual Basic Visual C++
public abstract Axis GetCrossAxis(
    GraphPane pane
)
Public MustOverride Function GetCrossAxis ( _
    pane As GraphPane _
) As Axis
public:
virtual Axis^ GetCrossAxis (
    GraphPane^ pane
) abstract
Parameters
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
Remarks
The cross axis is the axis which determines the of this Axis when the Axis.Cross property is used. The cross axis for any XAxis or X2Axis is always the primary YAxis, and the cross axis for any YAxis or Y2Axis is always the primary XAxis.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► Axis ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsAxisSegmentVisible Property

IsAxisSegmentVisible Property
Namespaces ► ZedGraph ► Axis ► IsAxisSegmentVisible
Gets or sets a property that determines whether or not the axis segment (the line that represents the axis itself) is drawn.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAxisSegmentVisible{ get; set;}
Public Property IsAxisSegmentVisible As Boolean
public:
property bool IsAxisSegmentVisible {
    bool get ();
    void set (bool value);
}
Remarks
Under normal circumstances, this value won't affect the appearance of the display because the Axis segment is overlain by the Axis border (see Border). However, when the border is not visible, or when CrossAuto is set to false, this value will make a difference.


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph ► Axis ► IsVisible
This property determines whether or not the Axis is shown.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
Value
true to show the axis, false to disable all drawing of this axis
Remarks
Note that even if the axis is not visible, it can still be actively used to draw curves on a graph, it will just be invisible to the user
See Also
IsVisible
IsVisible
IsVisible
IsVisible


MajorGrid Property

MajorGrid Property
Namespaces ► ZedGraph ► Axis ► MajorGrid
Gets a reference to the MajorGrid class that contains the properties of the major grid.
Declaration Syntax
C# Visual Basic Visual C++
public MajorGrid MajorGrid{ get;}
Public ReadOnly Property MajorGrid As MajorGrid
public:
property MajorGrid^ MajorGrid {
    MajorGrid^ get ();
}


MajorTic Property

MajorTic Property
Namespaces ► ZedGraph ► Axis ► MajorTic
Gets a reference to the MajorTic class instance for this Axis. This class stores all the major tic settings.
Declaration Syntax
C# Visual Basic Visual C++
public MajorTic MajorTic{ get;}
Public ReadOnly Property MajorTic As MajorTic
public:
property MajorTic^ MajorTic {
    MajorTic^ get ();
}


MinorGrid Property

MinorGrid Property
Namespaces ► ZedGraph ► Axis ► MinorGrid
Gets a reference to the MinorGrid class that contains the properties of the minor grid.
Declaration Syntax
C# Visual Basic Visual C++
public MinorGrid MinorGrid{ get;}
Public ReadOnly Property MinorGrid As MinorGrid
public:
property MinorGrid^ MinorGrid {
    MinorGrid^ get ();
}


MinorTic Property

MinorTic Property
Namespaces ► ZedGraph ► Axis ► MinorTic
Gets a reference to the MinorTic class instance for this Axis. This class stores all the minor tic settings.
Declaration Syntax
C# Visual Basic Visual C++
public MinorTic MinorTic{ get;}
Public ReadOnly Property MinorTic As MinorTic
public:
property MinorTic^ MinorTic {
    MinorTic^ get ();
}


MinSpace Property

MinSpace Property
Namespaces ► ZedGraph ► Axis ► MinSpace
Gets or sets the minimum axis space allocation.
Declaration Syntax
C# Visual Basic Visual C++
public float MinSpace{ get; set;}
Public Property MinSpace As Single
public:
property float MinSpace {
    float get ();
    void set (float value);
}
Remarks
This term, expressed in points (1/72 inch) and scaled according to CalcScaleFactor()() for the GraphPane, determines the minimum amount of space an axis must have between the Chart.Rect and the GraphPane.Rect. This minimum space applies whether IsVisible is true or false.


ResetAutoScale Method (pane, g)

ResetAutoScale Method (pane, g)
Namespaces ► ZedGraph ► Axis ► ResetAutoScale(GraphPane, Graphics)
Restore the scale ranging to automatic mode, and recalculate the Axis scale ranges
Declaration Syntax
C# Visual Basic Visual C++
public void ResetAutoScale(
    GraphPane pane,
    Graphics g
)
Public Sub ResetAutoScale ( _
    pane As GraphPane, _
    g As Graphics _
)
public:
void ResetAutoScale (
    GraphPane^ pane,
    Graphics^ g
)
Parameters
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
See Also
MinAuto
MaxAuto
MajorStepAuto
MagAuto
FormatAuto


Scale Property

Scale Property
Namespaces ► ZedGraph ► Axis ► Scale
Gets the Scale instance associated with this Axis.
Declaration Syntax
C# Visual Basic Visual C++
public Scale Scale{ get;}
Public ReadOnly Property Scale As Scale
public:
property Scale^ Scale {
    Scale^ get ();
}


ScaleFormatEvent Event

ScaleFormatEvent Event
Namespaces ► ZedGraph ► Axis ► ScaleFormatEvent
Subscribe to this event to handle custom formatting of the scale labels.
Declaration Syntax
C# Visual Basic Visual C++
public event Axis.Axis..::ScaleFormatHandler ScaleFormatEvent
Public Event ScaleFormatEvent As Axis..::ScaleFormatHandler
public:
 event Axis..::ScaleFormatHandler^ ScaleFormatEvent {
    void add (Axis..::ScaleFormatHandler^ value);
    void remove (Axis..::ScaleFormatHandler^ value);
}


ScaleTitleEvent Event

ScaleTitleEvent Event
Namespaces ► ZedGraph ► Axis ► ScaleTitleEvent
Allow customization of the title when the scale is very large Subscribe to this event to handle custom formatting of the scale axis label.
Declaration Syntax
C# Visual Basic Visual C++
public event Axis.Axis..::ScaleTitleEventHandler ScaleTitleEvent
Public Event ScaleTitleEvent As Axis..::ScaleTitleEventHandler
public:
 event Axis..::ScaleTitleEventHandler^ ScaleTitleEvent {
    void add (Axis..::ScaleTitleEventHandler^ value);
    void remove (Axis..::ScaleTitleEventHandler^ value);
}


schema Field

schema Field
Namespaces ► ZedGraph ► Axis ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


SetMinSpaceBuffer Method (g, pane, bufferFraction, isGrowOnly)

SetMinSpaceBuffer Method (g, pane, bufferFraction, isGrowOnly)
Namespaces ► ZedGraph ► Axis ► SetMinSpaceBuffer(Graphics, GraphPane, Single, Boolean)
This method will set the MinSpace property for this Axis using the currently required space multiplied by a fraction ().
Declaration Syntax
C# Visual Basic Visual C++
public void SetMinSpaceBuffer(
    Graphics g,
    GraphPane pane,
    float bufferFraction,
    bool isGrowOnly
)
Public Sub SetMinSpaceBuffer ( _
    g As Graphics, _
    pane As GraphPane, _
    bufferFraction As Single, _
    isGrowOnly As Boolean _
)
public:
void SetMinSpaceBuffer (
    Graphics^ g,
    GraphPane^ pane,
    float bufferFraction,
    bool isGrowOnly
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
bufferFraction (Single)
The amount of space to allocate for the axis, expressed as a fraction of the currently required space. For example, a value of 1.2 would allow for 20% extra above the currently required space.
isGrowOnly (Boolean)
If true, then this method will only modify the MinSpace property if the calculated result is more than the current value.
Remarks
The currently required space is calculated using CalcSpace(Graphics, GraphPane, Single, Single%), and is based on current data ranges, font sizes, etc. The "space" is actually the amount of space required to fit the tic marks, scale labels, and axis title.


SetTransformMatrix Method (g, pane, scaleFactor)

SetTransformMatrix Method (g, pane, scaleFactor)
Namespaces ► ZedGraph ► Axis ► SetTransformMatrix(Graphics, GraphPane, Single)
Setup the Transform Matrix to handle drawing of this Axis
Declaration Syntax
C# Visual Basic Visual C++
public abstract void SetTransformMatrix(
    Graphics g,
    GraphPane pane,
    float scaleFactor
)
Public MustOverride Sub SetTransformMatrix ( _
    g As Graphics, _
    pane As GraphPane, _
    scaleFactor As Single _
)
public:
virtual void SetTransformMatrix (
    Graphics^ g,
    GraphPane^ pane,
    float scaleFactor
) abstract
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► Axis ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone.
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object
Remarks
Note that this method must be called with an explicit cast to ICloneable, and that it is inherently virtual. For example:
CopyC#
ParentClass foo = new ChildClass();
ChildClass bar = (ChildClass) ((ICloneable)foo).Clone();
 Assume that ChildClass is inherited from ParentClass. Even though foo is declared with ParentClass, it is actually an instance of ChildClass. Calling the ICloneable implementation of Clone() on foo actually calls ChildClass.Clone() as if it were a virtual function.


Tag Field

Tag Field
Namespaces ► ZedGraph ► Axis ► Tag
A tag object for use by the user. This can be used to store additional information associated with the Axis. ZedGraph does not use this value for any purpose.
Declaration Syntax
C# Visual Basic Visual C++
public Object Tag
Public Tag As Object
public:
Object^ Tag
Remarks
Note that, if you are going to Serialize ZedGraph data, then any type that you store in Tag must be a serializable type (or it will cause an exception).


Title Property

Title Property
Namespaces ► ZedGraph ► Axis ► Title
Gets or sets the Label class that contains the title of this Axis.
Declaration Syntax
C# Visual Basic Visual C++
public AxisLabel Title{ get; set;}
Public Property Title As AxisLabel
public:
property AxisLabel^ Title {
    AxisLabel^ get ();
    void set (AxisLabel^ value);
}
Value
the title is a string value
Remarks
The title normally shows the basis and dimensions of the scale range, such as "Time (Years)". The title is only shown if the IsVisible property is set to true. If the Title text is empty, then no title is shown, and no space is "reserved" for the title on the graph.
See Also
IsOmitMag


Type Property

Type Property
Namespaces ► ZedGraph ► Axis ► Type
Gets or sets the AxisType for this Axis.
Declaration Syntax
C# Visual Basic Visual C++
public AxisType Type{ get; set;}
Public Property Type As AxisType
public:
property AxisType Type {
    AxisType get ();
    void set (AxisType value);
}
Remarks
The type can be either Linear, Log, Date, or Text.
See Also
IsLog
IsText
IsOrdinal
IsDate
IsReverse


Axis.Default Structure

Axis..::Default Structure
Namespaces ► ZedGraph ► Axis ► Axis..::Default
A simple struct that defines the default property values for the Axis class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AxisGap | The default size for the gap between multiple axes (AxisGap property). Units are in points (1/72 inch).
 | BorderColor | The default color for the Axis itself (Color property). This color only affects the the axis border.
 | Color | The default color for the axis segment.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAxisSegmentVisible | The default value for IsAxisSegmentVisible, which determines whether or not the scale segment itself is visible
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinSpace | The default setting for the axis space allocation. This term, expressed in points (1/72 inch) and scaled according to CalcScaleFactor()() for the GraphPane, determines the minimum amount of space an axis must have between the Rect and the Rect. This minimum space applies whether IsVisible is true or false.
 | TitleFillBrush | The default custom brush for filling in the Title text background (see Brush property).
 | TitleFillColor | The default color for filling in the Title text background (see Color property).
 | TitleFillType | The default fill mode for filling in the Title text background (see Type property).
 | TitleFontBold | The default font bold mode for the Axis Title text font specification FontSpec (IsBold property). true for a bold typeface, false otherwise.
 | TitleFontColor | The default font color for the Axis Title text font specification FontSpec (FontColor property).
 | TitleFontFamily | The default font family for the Axis Title text font specification FontSpec (Family property).
 | TitleFontItalic | The default font italic mode for the Axis Title text font specification FontSpec (IsItalic property). true for an italic typeface, false otherwise.
 | TitleFontSize | The default font size for the Axis Title text font specification FontSpec (Size property). Units are in points (1/72 inch).
 | TitleFontUnderline | The default font underline mode for the Axis Title text font specification FontSpec (IsUnderline property). true for an underlined typeface, false otherwise.
 | TitleGap | The default setting for the gap between the scale labels and the axis title.
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | Type | The default setting for the Axis scale axis type (Type property). This value is set as per the AxisType enumeration


AxisGap Field

AxisGap Field
Namespaces ► ZedGraph ► Axis..::Default ► AxisGap
The default size for the gap between multiple axes (AxisGap property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float AxisGap
Public Shared AxisGap As Single
public:
static float AxisGap


BorderColor Field

BorderColor Field
Namespaces ► ZedGraph ► Axis..::Default ► BorderColor
The default color for the Axis itself (Color property). This color only affects the the axis border.
Declaration Syntax
C# Visual Basic Visual C++
public static Color BorderColor
Public Shared BorderColor As Color
public:
static Color BorderColor


Color Field

Color Field
Namespaces ► ZedGraph ► Axis..::Default ► Color
The default color for the axis segment.
Declaration Syntax
C# Visual Basic Visual C++
public static Color Color
Public Shared Color As Color
public:
static Color Color


IsAxisSegmentVisible Field

IsAxisSegmentVisible Field
Namespaces ► ZedGraph ► Axis..::Default ► IsAxisSegmentVisible
The default value for IsAxisSegmentVisible, which determines whether or not the scale segment itself is visible
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsAxisSegmentVisible
Public Shared IsAxisSegmentVisible As Boolean
public:
static bool IsAxisSegmentVisible


MinSpace Field

MinSpace Field
Namespaces ► ZedGraph ► Axis..::Default ► MinSpace
The default setting for the axis space allocation. This term, expressed in points (1/72 inch) and scaled according to CalcScaleFactor()() for the GraphPane, determines the minimum amount of space an axis must have between the Rect and the Rect. This minimum space applies whether IsVisible is true or false.
Declaration Syntax
C# Visual Basic Visual C++
public static float MinSpace
Public Shared MinSpace As Single
public:
static float MinSpace


TitleFillBrush Field

TitleFillBrush Field
Namespaces ► ZedGraph ► Axis..::Default ► TitleFillBrush
The default custom brush for filling in the Title text background (see Brush property).
Declaration Syntax
C# Visual Basic Visual C++
public static Brush TitleFillBrush
Public Shared TitleFillBrush As Brush
public:
static Brush^ TitleFillBrush


TitleFillColor Field

TitleFillColor Field
Namespaces ► ZedGraph ► Axis..::Default ► TitleFillColor
The default color for filling in the Title text background (see Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color TitleFillColor
Public Shared TitleFillColor As Color
public:
static Color TitleFillColor


TitleFillType Field

TitleFillType Field
Namespaces ► ZedGraph ► Axis..::Default ► TitleFillType
The default fill mode for filling in the Title text background (see Type property).
Declaration Syntax
C# Visual Basic Visual C++
public static FillType TitleFillType
Public Shared TitleFillType As FillType
public:
static FillType TitleFillType


TitleFontBold Field

TitleFontBold Field
Namespaces ► ZedGraph ► Axis..::Default ► TitleFontBold
The default font bold mode for the Axis Title text font specification FontSpec (IsBold property). true for a bold typeface, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool TitleFontBold
Public Shared TitleFontBold As Boolean
public:
static bool TitleFontBold


TitleFontColor Field

TitleFontColor Field
Namespaces ► ZedGraph ► Axis..::Default ► TitleFontColor
The default font color for the Axis Title text font specification FontSpec (FontColor property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color TitleFontColor
Public Shared TitleFontColor As Color
public:
static Color TitleFontColor


TitleFontFamily Field

TitleFontFamily Field
Namespaces ► ZedGraph ► Axis..::Default ► TitleFontFamily
The default font family for the Axis Title text font specification FontSpec (Family property).
Declaration Syntax
C# Visual Basic Visual C++
public static string TitleFontFamily
Public Shared TitleFontFamily As String
public:
static String^ TitleFontFamily


TitleFontItalic Field

TitleFontItalic Field
Namespaces ► ZedGraph ► Axis..::Default ► TitleFontItalic
The default font italic mode for the Axis Title text font specification FontSpec (IsItalic property). true for an italic typeface, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool TitleFontItalic
Public Shared TitleFontItalic As Boolean
public:
static bool TitleFontItalic


TitleFontSize Field

TitleFontSize Field
Namespaces ► ZedGraph ► Axis..::Default ► TitleFontSize
The default font size for the Axis Title text font specification FontSpec (Size property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float TitleFontSize
Public Shared TitleFontSize As Single
public:
static float TitleFontSize


TitleFontUnderline Field

TitleFontUnderline Field
Namespaces ► ZedGraph ► Axis..::Default ► TitleFontUnderline
The default font underline mode for the Axis Title text font specification FontSpec (IsUnderline property). true for an underlined typeface, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool TitleFontUnderline
Public Shared TitleFontUnderline As Boolean
public:
static bool TitleFontUnderline


TitleGap Field

TitleGap Field
Namespaces ► ZedGraph ► Axis..::Default ► TitleGap
The default setting for the gap between the scale labels and the axis title.
Declaration Syntax
C# Visual Basic Visual C++
public static float TitleGap
Public Shared TitleGap As Single
public:
static float TitleGap


Type Field

Type Field
Namespaces ► ZedGraph ► Axis..::Default ► Type
The default setting for the Axis scale axis type (Type property). This value is set as per the AxisType enumeration
Declaration Syntax
C# Visual Basic Visual C++
public static AxisType Type
Public Shared Type As AxisType
public:
static AxisType Type


Axis.ScaleFormatHandler Delegate

Axis..::ScaleFormatHandler Delegate
Namespaces ► ZedGraph ► Axis ► Axis..::ScaleFormatHandler
A delegate that allows full custom formatting of the Axis labels
Declaration Syntax
C# Visual Basic Visual C++
public delegate string ScaleFormatHandler(
    GraphPane pane,
    Axis axis,
    double val,
    int index
)
Public Delegate Function ScaleFormatHandler ( _
    pane As GraphPane, _
    axis As Axis, _
    val As Double, _
    index As Integer _
) As String
public delegate String^ ScaleFormatHandler (
    GraphPane^ pane,
    Axis^ axis,
    double val,
    int index
)
Parameters
pane (GraphPane)
The GraphPane for which the label is to be formatted
axis (Axis)
The Scale of interest.
val (Double)
The value to be formatted
index (Int32)
The zero-based index of the label to be formatted
Return Value
A string value representing the label, or null if the ZedGraph should go ahead and generate the label according to the current settings
See Also
ScaleFormatEvent


Axis.ScaleTitleEventHandler Delegate

Axis..::ScaleTitleEventHandler Delegate
Namespaces ► ZedGraph ► Axis ► Axis..::ScaleTitleEventHandler
Allow customization of title based on user preferences.
Declaration Syntax
C# Visual Basic Visual C++
public delegate string ScaleTitleEventHandler(
    Axis axis
)
Public Delegate Function ScaleTitleEventHandler ( _
    axis As Axis _
) As String
public delegate String^ ScaleTitleEventHandler (
    Axis^ axis
)
Parameters
axis (Axis)
The Axis of interest.
Return Value
A string value representing the label, or null if the ZedGraph should go ahead and generate the label according to the current settings. To make the title blank, return "".
See Also
ScaleFormatEvent


AxisLabel Class

AxisLabel Class
Namespaces ► ZedGraph ► AxisLabel
Class that handles the data associated with text title and its associated font properties. Inherits from Label, and adds IsOmitMag and IsTitleAtCross properties, which are specifically associated with the Axis Title.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class AxisLabel : GapLabel, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class AxisLabel _
    Inherits GapLabel _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class AxisLabel : public GapLabel,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AxisLabelAxisLabelNew(String, String, Single, Color, Boolean, Boolean, Boolean) | Constructor to build an AxisLabel from the text and the associated font properties.
 | AxisLabelAxisLabelNew(AxisLabel) | Copy constructor
 | Clone()() | Typesafe, deep-copy clone method.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontSpec | A FontSpec instance representing the font properties for the displayed text. (Inherited from Label.)
 | Gap | Gets or sets the gap factor between this label and the opposing Axis or Chart. (Inherited from GapLabel.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides GapLabel.GetObjectData(SerializationInfo, StreamingContext).)
 | GetScaledGap(Single) | Calculate the size of the Gap based on the FontSpec height, in pixel units and scaled according to . (Inherited from GapLabel.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsOmitMag | Gets or sets the property that controls whether or not the magnitude factor (power of 10) for this scale will be included in the label.
 | IsTitleAtCross | Gets or sets a value that determines whether the Axis title is located at the Cross value or at the normal position (outside the Rect).
 | IsVisible | Gets or sets a boolean value that determines whether or not this label will be displayed. (Inherited from Label.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | schema3 | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Text | The String text to be displayed (Inherited from Label.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Label
 |  | GapLabel
 |  |  | AxisLabel


AxisLabel Constructor

AxisLabel Constructor
Namespaces ► ZedGraph ► AxisLabel ► AxisLabelAxisLabelNew()()
Members
Icon | Member | Description
 | AxisLabelAxisLabelNew(String, String, Single, Color, Boolean, Boolean, Boolean) | Constructor to build an AxisLabel from the text and the associated font properties.
 | AxisLabelAxisLabelNew(AxisLabel) | Copy constructor


AxisLabel Constructor (text, fontFamily, fontSize, color, isBold, isItalic, isUnderline)

AxisLabel Constructor (text, fontFamily, fontSize, color, isBold, isItalic, isUnderline)
Namespaces ► ZedGraph ► AxisLabel ► AxisLabelAxisLabelNew(String, String, Single, Color, Boolean, Boolean, Boolean)
Constructor to build an AxisLabel from the text and the associated font properties.
Declaration Syntax
C# Visual Basic Visual C++
public AxisLabel(
    string text,
    string fontFamily,
    float fontSize,
    Color color,
    bool isBold,
    bool isItalic,
    bool isUnderline
)
Public Sub New ( _
    text As String, _
    fontFamily As String, _
    fontSize As Single, _
    color As Color, _
    isBold As Boolean, _
    isItalic As Boolean, _
    isUnderline As Boolean _
)
public:
AxisLabel (
    String^ text,
    String^ fontFamily,
    float fontSize,
    Color color,
    bool isBold,
    bool isItalic,
    bool isUnderline
)
Parameters
text (String)
The String representing the text to be displayed
fontFamily (String)
The String font family name
fontSize (Single)
The size of the font in points and scaled according to the CalcScaleFactor()() logic.
color (Color)
The Color instance representing the color of the font
isBold (Boolean)
true for a bold font face
isItalic (Boolean)
true for an italic font face
isUnderline (Boolean)
true for an underline font face


AxisLabel Constructor (rhs)

AxisLabel Constructor (rhs)
Namespaces ► ZedGraph ► AxisLabel ► AxisLabelAxisLabelNew(AxisLabel)
Copy constructor
Declaration Syntax
C# Visual Basic Visual C++
public AxisLabel(
    AxisLabel rhs
)
Public Sub New ( _
    rhs As AxisLabel _
)
public:
AxisLabel (
    AxisLabel^ rhs
)
Parameters
rhs (AxisLabel)
the AxisLabel instance to be copied.


Clone Method

Clone Method
Namespaces ► ZedGraph ► AxisLabel ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public AxisLabel Clone()
Public Function Clone As AxisLabel
public:
AxisLabel^ Clone ()
Return Value
A new, independent copy of this class


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► AxisLabel ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsOmitMag Property

IsOmitMag Property
Namespaces ► ZedGraph ► AxisLabel ► IsOmitMag
Gets or sets the property that controls whether or not the magnitude factor (power of 10) for this scale will be included in the label.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOmitMag{ get; set;}
Public Property IsOmitMag As Boolean
public:
property bool IsOmitMag {
    bool get ();
    void set (bool value);
}
Value
true to show the magnitude value, false to hide it
Remarks
For large scale values, a "magnitude" value (power of 10) is automatically used for scaling the graph. This magnitude value is automatically appended to the end of the Axis Title (e.g., "(10^4)") to indicate that a magnitude is in use. This property controls whether or not the magnitude is included in the title. Note that it only affects the axis title; a magnitude value may still be used even if it is not shown in the title.
See Also
Title
Mag
Format


IsTitleAtCross Property

IsTitleAtCross Property
Namespaces ► ZedGraph ► AxisLabel ► IsTitleAtCross
Gets or sets a value that determines whether the Axis title is located at the Cross value or at the normal position (outside the Rect).
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTitleAtCross{ get; set;}
Public Property IsTitleAtCross As Boolean
public:
property bool IsTitleAtCross {
    bool get ();
    void set (bool value);
}
Remarks
This value only applies if CrossAuto is false.


schema3 Field

schema3 Field
Namespaces ► ZedGraph ► AxisLabel ► schema3
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema3
Public Const schema3 As Integer
public:
literal int schema3


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► AxisLabel ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


AxisType Enumeration

AxisType Enumeration
Namespaces ► ZedGraph ► AxisType
Enumeration type for the various axis types that are available
Declaration Syntax
C# Visual Basic Visual C++
public enum AxisType
Public Enumeration AxisType
public enum class AxisType
Members
Member | Description
Linear | An ordinary, cartesian axis
Log | A base 10 log axis
Date | A cartesian axis with calendar dates or times
Text | An ordinal axis with user-defined text labels. An ordinal axis means that all data points are evenly spaced at integral values, and the actual coordinate values for points corresponding to that axis are ignored. That is, if the X axis is an ordinal type, then all X values associated with the curves are ignored.
Ordinal | An ordinal axis with regular numeric labels. An ordinal axis means that all data points are evenly spaced at integral values, and the actual coordinate values for points corresponding to that axis are ignored. That is, if the X axis is an ordinal type, then all X values associated with the curves are ignored.
DateAsOrdinal | An ordinal axis that will have labels formatted with ordinal values corresponding to the number of values in each CurveItem.
LinearAsOrdinal | An ordinal axis that will have labels formatted with values from the actual data values of the first CurveItem in the CurveList.
Exponent | An exponential axis
See Also
Type


Bar Class

Bar Class
Namespaces ► ZedGraph ► Bar
A class representing all the characteristics of the bar segments that make up a curve on the graph.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Bar : ICloneable, ISerializable
<SerializableAttribute> _
Public Class Bar _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class Bar : ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BarBarNew()() | Default constructor that sets all Bar properties to default values as defined in the Bar..::Default class.
 | BarBarNew(Color) | Default constructor that sets the Color as specified, and the remaining Bar properties to default values as defined in the Bar..::Default class. The specified color is only applied to the Color, and the Color will be defaulted.
 | BarBarNew(Bar) | The Copy Constructor
 | Border | The Border object used to draw the border around the Bar.
 | Clone()() | Typesafe, deep-copy clone method.
 | Draw(Graphics, GraphPane, Single, Single, Single, Single, Single, Boolean, Boolean, PointPair) | Draw the Bar to the specified Graphics device at the specified location. This routine draws a single bar.
 | Draw(Graphics, GraphPane, RectangleF, Single, Boolean, Boolean, PointPair) | Draw the Bar to the specified Graphics device at the specified location. This routine draws a single bar.
 | DrawBars(Graphics, GraphPane, CurveItem, Axis, Axis, Single, Int32, Single) | Draw the this Bar to the specified Graphics device as a bar at each defined point. This method is normally only called by the Draw(Graphics, GraphPane, Int32, Single) method of the BarItem object
 | DrawSingleBar(Graphics, GraphPane, CurveItem, Axis, Axis, Int32, Int32, Single, Single) | Draw the specified single bar (an individual "point") of this series to the specified Graphics device. This method is not as efficient as DrawBars(Graphics, GraphPane, CurveItem, Axis, Axis, Single, Int32, Single), which draws the bars for all points. It is intended to be used only for SortedOverlay, which requires special handling of each bar.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Gets or sets the Fill data for this Bar.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | schema | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Bar
 |  | HiLowBar


Bar Constructor

Bar Constructor
Namespaces ► ZedGraph ► Bar ► BarBarNew()()
Members
Icon | Member | Description
 | BarBarNew()() | Default constructor that sets all Bar properties to default values as defined in the Bar..::Default class.
 | BarBarNew(Color) | Default constructor that sets the Color as specified, and the remaining Bar properties to default values as defined in the Bar..::Default class. The specified color is only applied to the Color, and the Color will be defaulted.
 | BarBarNew(Bar) | The Copy Constructor


Bar Constructor

Bar Constructor
Namespaces ► ZedGraph ► Bar ► BarBarNew()()
Default constructor that sets all Bar properties to default values as defined in the Bar..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public Bar()
Public Sub New
public:
Bar ()


Bar Constructor (color)

Bar Constructor (color)
Namespaces ► ZedGraph ► Bar ► BarBarNew(Color)
Default constructor that sets the Color as specified, and the remaining Bar properties to default values as defined in the Bar..::Default class. The specified color is only applied to the Color, and the Color will be defaulted.
Declaration Syntax
C# Visual Basic Visual C++
public Bar(
    Color color
)
Public Sub New ( _
    color As Color _
)
public:
Bar (
    Color color
)
Parameters
color (Color)
A Color value indicating the Color of the Bar.


Bar Constructor (rhs)

Bar Constructor (rhs)
Namespaces ► ZedGraph ► Bar ► BarBarNew(Bar)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public Bar(
    Bar rhs
)
Public Sub New ( _
    rhs As Bar _
)
public:
Bar (
    Bar^ rhs
)
Parameters
rhs (Bar)
The Bar object from which to copy


Border Property

Border Property
Namespaces ► ZedGraph ► Bar ► Border
The Border object used to draw the border around the Bar.
Declaration Syntax
C# Visual Basic Visual C++
public Border Border{ get; set;}
Public Property Border As Border
public:
property Border^ Border {
    Border^ get ();
    void set (Border^ value);
}
See Also
IsBorderVisible
BorderWidth
BorderColor


Clone Method

Clone Method
Namespaces ► ZedGraph ► Bar ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public Bar Clone()
Public Function Clone As Bar
public:
Bar^ Clone ()
Return Value
A new, independent copy of this class


Draw Method

Draw Method
Namespaces ► ZedGraph ► Bar ► Draw()()
Members
Icon | Member | Description
 | Draw(Graphics, GraphPane, Single, Single, Single, Single, Single, Boolean, Boolean, PointPair) | Draw the Bar to the specified Graphics device at the specified location. This routine draws a single bar.
 | Draw(Graphics, GraphPane, RectangleF, Single, Boolean, Boolean, PointPair) | Draw the Bar to the specified Graphics device at the specified location. This routine draws a single bar.


Draw Method (g, pane, rect, scaleFactor, fullFrame, isSelected, dataValue)

Draw Method (g, pane, rect, scaleFactor, fullFrame, isSelected, dataValue)
Namespaces ► ZedGraph ► Bar ► Draw(Graphics, GraphPane, RectangleF, Single, Boolean, Boolean, PointPair)
Draw the Bar to the specified Graphics device at the specified location. This routine draws a single bar.
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    GraphPane pane,
    RectangleF rect,
    float scaleFactor,
    bool fullFrame,
    bool isSelected,
    PointPair dataValue
)
Public Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    rect As RectangleF, _
    scaleFactor As Single, _
    fullFrame As Boolean, _
    isSelected As Boolean, _
    dataValue As PointPair _
)
public:
void Draw (
    Graphics^ g,
    GraphPane^ pane,
    RectangleF rect,
    float scaleFactor,
    bool fullFrame,
    bool isSelected,
    PointPair^ dataValue
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
rect (RectangleF)
The rectangle (pixels) to contain the bar
scaleFactor (Single)
The scaling factor for the features of the graph based on the BaseDimension. This scaling factor is calculated by the CalcScaleFactor()() method. The scale factor represents a linear multiple to be applied to font sizes, symbol sizes, etc.
fullFrame (Boolean)
true to draw the bottom portion of the border around the bar (this is for legend entries)
isSelected (Boolean)
Indicates that the Bar should be drawn with attributes from the Selection class.
dataValue (PointPair)
The data value to be used for a value-based color gradient. This is only applicable for GradientByX, GradientByY or GradientByZ.


Draw Method (g, pane, left, right, top, bottom, scaleFactor, fullFrame, isSelected, dataValue)

Draw Method (g, pane, left, right, top, bottom, scaleFactor, fullFrame, isSelected, dataValue)
Namespaces ► ZedGraph ► Bar ► Draw(Graphics, GraphPane, Single, Single, Single, Single, Single, Boolean, Boolean, PointPair)
Draw the Bar to the specified Graphics device at the specified location. This routine draws a single bar.
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    GraphPane pane,
    float left,
    float right,
    float top,
    float bottom,
    float scaleFactor,
    bool fullFrame,
    bool isSelected,
    PointPair dataValue
)
Public Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    left As Single, _
    right As Single, _
    top As Single, _
    bottom As Single, _
    scaleFactor As Single, _
    fullFrame As Boolean, _
    isSelected As Boolean, _
    dataValue As PointPair _
)
public:
void Draw (
    Graphics^ g,
    GraphPane^ pane,
    float left,
    float right,
    float top,
    float bottom,
    float scaleFactor,
    bool fullFrame,
    bool isSelected,
    PointPair^ dataValue
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
left (Single)
The x position of the left side of the bar in pixel units
right (Single)
The x position of the right side of the bar in pixel units
top (Single)
The y position of the top of the bar in pixel units
bottom (Single)
The y position of the bottom of the bar in pixel units
scaleFactor (Single)
The scaling factor for the features of the graph based on the BaseDimension. This scaling factor is calculated by the CalcScaleFactor()() method. The scale factor represents a linear multiple to be applied to font sizes, symbol sizes, etc.
fullFrame (Boolean)
true to draw the bottom portion of the border around the bar (this is for legend entries)
isSelected (Boolean)
Indicates that the Bar should be drawn with attributes from the Selection class.
dataValue (PointPair)
The data value to be used for a value-based color gradient. This is only applicable for GradientByX, GradientByY or GradientByZ.


DrawBars Method (g, pane, curve, baseAxis, valueAxis, barWidth, pos, scaleFactor)

DrawBars Method (g, pane, curve, baseAxis, valueAxis, barWidth, pos, scaleFactor)
Namespaces ► ZedGraph ► Bar ► DrawBars(Graphics, GraphPane, CurveItem, Axis, Axis, Single, Int32, Single)
Draw the this Bar to the specified Graphics device as a bar at each defined point. This method is normally only called by the Draw(Graphics, GraphPane, Int32, Single) method of the BarItem object
Declaration Syntax
C# Visual Basic Visual C++
public void DrawBars(
    Graphics g,
    GraphPane pane,
    CurveItem curve,
    Axis baseAxis,
    Axis valueAxis,
    float barWidth,
    int pos,
    float scaleFactor
)
Public Sub DrawBars ( _
    g As Graphics, _
    pane As GraphPane, _
    curve As CurveItem, _
    baseAxis As Axis, _
    valueAxis As Axis, _
    barWidth As Single, _
    pos As Integer, _
    scaleFactor As Single _
)
public:
void DrawBars (
    Graphics^ g,
    GraphPane^ pane,
    CurveItem^ curve,
    Axis^ baseAxis,
    Axis^ valueAxis,
    float barWidth,
    int pos,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
curve (CurveItem)
A CurveItem object representing the Bar's to be drawn.
baseAxis (Axis)
The Axis class instance that defines the base (independent) axis for the Bar
valueAxis (Axis)
The Axis class instance that defines the value (dependent) axis for the Bar
barWidth (Single)
The width of each bar, in pixels.
pos (Int32)
The ordinal position of the this bar series (0=first bar, 1=second bar, etc.) in the cluster of bars.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


DrawSingleBar Method (g, pane, curve, baseAxis, valueAxis, pos, index, barWidth, scaleFactor)

DrawSingleBar Method (g, pane, curve, baseAxis, valueAxis, pos, index, barWidth, scaleFactor)
Namespaces ► ZedGraph ► Bar ► DrawSingleBar(Graphics, GraphPane, CurveItem, Axis, Axis, Int32, Int32, Single, Single)
Draw the specified single bar (an individual "point") of this series to the specified Graphics device. This method is not as efficient as DrawBars(Graphics, GraphPane, CurveItem, Axis, Axis, Single, Int32, Single), which draws the bars for all points. It is intended to be used only for SortedOverlay, which requires special handling of each bar.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawSingleBar(
    Graphics g,
    GraphPane pane,
    CurveItem curve,
    Axis baseAxis,
    Axis valueAxis,
    int pos,
    int index,
    float barWidth,
    float scaleFactor
)
Public Sub DrawSingleBar ( _
    g As Graphics, _
    pane As GraphPane, _
    curve As CurveItem, _
    baseAxis As Axis, _
    valueAxis As Axis, _
    pos As Integer, _
    index As Integer, _
    barWidth As Single, _
    scaleFactor As Single _
)
public:
void DrawSingleBar (
    Graphics^ g,
    GraphPane^ pane,
    CurveItem^ curve,
    Axis^ baseAxis,
    Axis^ valueAxis,
    int pos,
    int index,
    float barWidth,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
curve (CurveItem)
A CurveItem object representing the Bar's to be drawn.
baseAxis (Axis)
The Axis class instance that defines the base (independent) axis for the Bar
valueAxis (Axis)
The Axis class instance that defines the value (dependent) axis for the Bar
pos (Int32)
The ordinal position of the this bar series (0=first bar, 1=second bar, etc.) in the cluster of bars.
index (Int32)
The zero-based index number for the single bar to be drawn.
barWidth (Single)
The width of each bar, in pixels.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


Fill Property

Fill Property
Namespaces ► ZedGraph ► Bar ► Fill
Gets or sets the Fill data for this Bar.
Declaration Syntax
C# Visual Basic Visual C++
public Fill Fill{ get; set;}
Public Property Fill As Fill
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► Bar ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


schema Field

schema Field
Namespaces ► ZedGraph ► Bar ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► Bar ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Bar.Default Structure

Bar..::Default Structure
Namespaces ► ZedGraph ► Bar ► Bar..::Default
A simple struct that defines the default property values for the Bar class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BorderColor | The default color for drawing frames around bars (Color property).
 | BorderWidth | The default pen width to be used for drawing the border around the bars (Width property). Units are points.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | FillBrush | The default custom brush for filling in the bars (Brush property).
 | FillColor | The default color for filling in the bars (Color property).
 | FillType | The default fill mode for bars (Type property).
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsBorderVisible | The default border mode for bars (IsVisible property). true to display frames around bars, false otherwise
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


BorderColor Field

BorderColor Field
Namespaces ► ZedGraph ► Bar..::Default ► BorderColor
The default color for drawing frames around bars (Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color BorderColor
Public Shared BorderColor As Color
public:
static Color BorderColor


BorderWidth Field

BorderWidth Field
Namespaces ► ZedGraph ► Bar..::Default ► BorderWidth
The default pen width to be used for drawing the border around the bars (Width property). Units are points.
Declaration Syntax
C# Visual Basic Visual C++
public static float BorderWidth
Public Shared BorderWidth As Single
public:
static float BorderWidth


FillBrush Field

FillBrush Field
Namespaces ► ZedGraph ► Bar..::Default ► FillBrush
The default custom brush for filling in the bars (Brush property).
Declaration Syntax
C# Visual Basic Visual C++
public static Brush FillBrush
Public Shared FillBrush As Brush
public:
static Brush^ FillBrush


FillColor Field

FillColor Field
Namespaces ► ZedGraph ► Bar..::Default ► FillColor
The default color for filling in the bars (Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color FillColor
Public Shared FillColor As Color
public:
static Color FillColor


FillType Field

FillType Field
Namespaces ► ZedGraph ► Bar..::Default ► FillType
The default fill mode for bars (Type property).
Declaration Syntax
C# Visual Basic Visual C++
public static FillType FillType
Public Shared FillType As FillType
public:
static FillType FillType


IsBorderVisible Field

IsBorderVisible Field
Namespaces ► ZedGraph ► Bar..::Default ► IsBorderVisible
The default border mode for bars (IsVisible property). true to display frames around bars, false otherwise
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsBorderVisible
Public Shared IsBorderVisible As Boolean
public:
static bool IsBorderVisible


BarBase Enumeration

BarBase Enumeration
Namespaces ► ZedGraph ► BarBase
Enumeration type that defines the base axis from which Bar graphs are displayed. The bars can be drawn on any of the four axes (XAxis, X2Axis, YAxis, and Y2Axis).
Declaration Syntax
C# Visual Basic Visual C++
public enum BarBase
Public Enumeration BarBase
public enum class BarBase
Members
Member | Description
X | Draw the Bar chart based from the XAxis.
X2 | Draw the Bar chart based from the X2Axis.
Y | Draw the Bar chart based from the YAxis.
Y2 | Draw the Bar chart based from the Y2Axis.
See Also
Base


BarItem Class

BarItem Class
Namespaces ► ZedGraph ► BarItem
Encapsulates a bar type that displays vertical or horizontal bars
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class BarItem : CurveItem, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class BarItem _
    Inherits CurveItem _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class BarItem : public CurveItem,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BarItemBarItemNew(String) | Create a new BarItem, specifying only the legend label for the bar.
 | BarItemBarItemNew(String, array<Double>[](), array<Double>[](), Color) | Create a new BarItem using the specified properties.
 | BarItemBarItemNew(String, IPointList, Color) | Create a new BarItem using the specified properties.
 | BarItemBarItemNew(BarItem) | The Copy Constructor
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve. (Inherited from CurveItem.)
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve. (Inherited from CurveItem.)
 | Bar | Gets a reference to the Bar class defined for this BarItem.
 | BaseAxis(GraphPane) | Returns a reference to the Axis object that is the "base" (independent axis) from which the values are drawn. (Inherited from CurveItem.)
 | Clear()() | Clears the points from this CurveItem. This is the same as CurveItem.Points.Clear(). (Inherited from CurveItem.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The Line/Symbol/Bar color (FillColor for the Bar). This is a common access to Line.Color, Border.Color, and Fill.Color properties for this curve. (Inherited from CurveItem.)
 | CreateBarLabels(GraphPane, Boolean, String) | Create a TextObj for each bar in the GraphPane.
 | CreateBarLabels(GraphPane, Boolean, String, String, Single, Color, Boolean, Boolean, Boolean) | Create a TextObj for each bar in the GraphPane.
 | Draw(Graphics, GraphPane, Int32, Single) | Do all rendering associated with this BarItem to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object. (Overrides CurveItem.Draw(Graphics, GraphPane, Int32, Single).)
 | DrawLegendKey(Graphics, GraphPane, RectangleF, Single) | Draw a legend key entry for this BarItem at the specified location (Overrides CurveItem.DrawLegendKey(Graphics, GraphPane, RectangleF, Single).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarWidth(GraphPane) | Calculate the width of each bar, depending on the actual bar type (Inherited from CurveItem.)
 | GetCoords(GraphPane, Int32, String%) | Determine the coords for the rectangle associated with a specified point for this CurveItem (Overrides CurveItem.GetCoords(GraphPane, Int32, String%).)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides CurveItem.GetObjectData(SerializationInfo, StreamingContext).)
 | GetRange(Double%, Double%, Double%, Double%, Boolean, Boolean, GraphPane) | Go through the list of PointPair data values for this CurveItem and determine the minimum and maximum values in the data. (Inherited from CurveItem.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXAxis(GraphPane) | Get the X Axis instance (either XAxis or X2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxis(GraphPane) | Get the Y Axis instance (either YAxis or Y2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxisIndex(GraphPane) | Get the index of the Y Axis in the YAxis or Y2Axis list to which this CurveItem belongs. (Inherited from CurveItem.)
 | IsBar | Determines whether this CurveItem is a BarItem. This does not include HiLowBarItem's or ErrorBarItem's. (Inherited from CurveItem.)
 | IsLine | Determines whether this CurveItem is a LineItem. (Inherited from CurveItem.)
 | IsOverrideOrdinal | Gets or sets a value which allows you to override the normal ordinal axis behavior. (Inherited from CurveItem.)
 | IsPie | Determines whether this CurveItem is a PieItem. (Inherited from CurveItem.)
 | IsSelectable | Determines whether this CurveItem can be selected in the graph. (Inherited from CurveItem.)
 | IsSelected | Determines whether this CurveItem is selected on the graph. Note that this value changes the curve displayed color, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsVisible | Determines whether this CurveItem is visible on the graph. Note that this value turns the curve display on or off, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsX2Axis | Gets or sets a value that determines which X axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | IsY2Axis | Gets or sets a value that determines which Y axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | Item[([Int32])] | An accessor for the PointPair datum for this CurveItem. Index is the ordinal reference (zero based) of the point. (Inherited from CurveItem.)
 | Label | A Label instance that represents the Legend entry for the this CurveItem object (Inherited from CurveItem.)
 | Link | Gets or sets the hyperlink information for this CurveItem. (Inherited from CurveItem.)
 | MakeUnique()() | Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator) (Inherited from CurveItem.)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator) (Inherited from CurveItem.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NPts | Readonly property that gives the number of points that define this CurveItem object, which is the number of points in the Points data collection. (Inherited from CurveItem.)
 | Points | The IPointList of X,Y point sets that represent this CurveItem. (Inherited from CurveItem.)
 | RemovePoint(Int32) | Removes a single point from this CurveItem. (Inherited from CurveItem.)
 | schema2 | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the CurveItem. ZedGraph does not use this value for any purpose. (Inherited from CurveItem.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValueAxis(GraphPane) | Returns a reference to the Axis object that is the "value" (dependent axis) from which the points are drawn. (Inherited from CurveItem.)
 | YAxisIndex | Gets or sets the index number of the Y Axis to which this CurveItem belongs. (Inherited from CurveItem.)
Remarks
The orientation of the bars depends on the state of Base, and the bars can be stacked or clustered, depending on the state of Type
Inheritance Hierarchy
Object
 | CurveItem
 |  | BarItem


BarItem Constructor

BarItem Constructor
Namespaces ► ZedGraph ► BarItem ► BarItemBarItemNew()()
Members
Icon | Member | Description
 | BarItemBarItemNew(String) | Create a new BarItem, specifying only the legend label for the bar.
 | BarItemBarItemNew(String, array<Double>[](), array<Double>[](), Color) | Create a new BarItem using the specified properties.
 | BarItemBarItemNew(String, IPointList, Color) | Create a new BarItem using the specified properties.
 | BarItemBarItemNew(BarItem) | The Copy Constructor


BarItem Constructor (label)

BarItem Constructor (label)
Namespaces ► ZedGraph ► BarItem ► BarItemBarItemNew(String)
Create a new BarItem, specifying only the legend label for the bar.
Declaration Syntax
C# Visual Basic Visual C++
public BarItem(
    string label
)
Public Sub New ( _
    label As String _
)
public:
BarItem (
    String^ label
)
Parameters
label (String)
The label that will appear in the legend.


BarItem Constructor (label, x, y, color)

BarItem Constructor (label, x, y, color)
Namespaces ► ZedGraph ► BarItem ► BarItemBarItemNew(String, array<Double>[](), array<Double>[](), Color)
Create a new BarItem using the specified properties.
Declaration Syntax
C# Visual Basic Visual C++
public BarItem(
    string label,
    double[] x,
    double[] y,
    Color color
)
Public Sub New ( _
    label As String, _
    x As Double(), _
    y As Double(), _
    color As Color _
)
public:
BarItem (
    String^ label,
    array<double>^ x,
    array<double>^ y,
    Color color
)
Parameters
label (String)
The label that will appear in the legend.
x (array< Double >[]())
An array of double precision values that define the independent (X axis) values for this curve
y (array< Double >[]())
An array of double precision values that define the dependent (Y axis) values for this curve
color (Color)
A Color value that will be applied to the Fill and Border properties.


BarItem Constructor (label, points, color)

BarItem Constructor (label, points, color)
Namespaces ► ZedGraph ► BarItem ► BarItemBarItemNew(String, IPointList, Color)
Create a new BarItem using the specified properties.
Declaration Syntax
C# Visual Basic Visual C++
public BarItem(
    string label,
    IPointList points,
    Color color
)
Public Sub New ( _
    label As String, _
    points As IPointList, _
    color As Color _
)
public:
BarItem (
    String^ label,
    IPointList^ points,
    Color color
)
Parameters
label (String)
The label that will appear in the legend.
points (IPointList)
A IPointList of double precision value pairs that define the X and Y values for this curve
color (Color)
A Color value that will be applied to the Fill and Border properties.


BarItem Constructor (rhs)

BarItem Constructor (rhs)
Namespaces ► ZedGraph ► BarItem ► BarItemBarItemNew(BarItem)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public BarItem(
    BarItem rhs
)
Public Sub New ( _
    rhs As BarItem _
)
public:
BarItem (
    BarItem^ rhs
)
Parameters
rhs (BarItem)
The BarItem object from which to copy


Bar Property

Bar Property
Namespaces ► ZedGraph ► BarItem ► Bar
Gets a reference to the Bar class defined for this BarItem.
Declaration Syntax
C# Visual Basic Visual C++
public Bar Bar{ get;}
Public ReadOnly Property Bar As Bar
public:
property Bar^ Bar {
    Bar^ get ();
}


Clone Method

Clone Method
Namespaces ► ZedGraph ► BarItem ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public BarItem Clone()
Public Function Clone As BarItem
public:
BarItem^ Clone ()
Return Value
A new, independent copy of this class


CreateBarLabels Method

CreateBarLabels Method
Namespaces ► ZedGraph ► BarItem ► CreateBarLabels()()
Members
Icon | Member | Description
 | CreateBarLabels(GraphPane, Boolean, String) | Create a TextObj for each bar in the GraphPane.
 | CreateBarLabels(GraphPane, Boolean, String, String, Single, Color, Boolean, Boolean, Boolean) | Create a TextObj for each bar in the GraphPane.


CreateBarLabels Method (pane, isBarCenter, valueFormat)

CreateBarLabels Method (pane, isBarCenter, valueFormat)
Namespaces ► ZedGraph ► BarItem ► CreateBarLabels(GraphPane, Boolean, String)
Create a TextObj for each bar in the GraphPane.
Declaration Syntax
C# Visual Basic Visual C++
public static void CreateBarLabels(
    GraphPane pane,
    bool isBarCenter,
    string valueFormat
)
Public Shared Sub CreateBarLabels ( _
    pane As GraphPane, _
    isBarCenter As Boolean, _
    valueFormat As String _
)
public:
static void CreateBarLabels (
    GraphPane^ pane,
    bool isBarCenter,
    String^ valueFormat
)
Parameters
pane (GraphPane)
The GraphPane in which to place the text labels.
isBarCenter (Boolean)
true to center the labels inside the bars, false to place the labels just above the top of the bar.
valueFormat (String)
The double.ToString string format to use for creating the labels.
Remarks
This method will go through the bars, create a label that corresponds to the bar value, and place it on the graph depending on user preferences. This works for horizontal or vertical bars in clusters or stacks, but only for BarItem types. This method does not apply to ErrorBarItem or HiLowBarItem objects. Call this method only after calling AxisChange()().


CreateBarLabels Method (pane, isBarCenter, valueFormat, fontFamily, fontSize, fontColor, isBold, isItalic, isUnderline)

CreateBarLabels Method (pane, isBarCenter, valueFormat, fontFamily, fontSize, fontColor, isBold, isItalic, isUnderline)
Namespaces ► ZedGraph ► BarItem ► CreateBarLabels(GraphPane, Boolean, String, String, Single, Color, Boolean, Boolean, Boolean)
Create a TextObj for each bar in the GraphPane.
Declaration Syntax
C# Visual Basic Visual C++
public static void CreateBarLabels(
    GraphPane pane,
    bool isBarCenter,
    string valueFormat,
    string fontFamily,
    float fontSize,
    Color fontColor,
    bool isBold,
    bool isItalic,
    bool isUnderline
)
Public Shared Sub CreateBarLabels ( _
    pane As GraphPane, _
    isBarCenter As Boolean, _
    valueFormat As String, _
    fontFamily As String, _
    fontSize As Single, _
    fontColor As Color, _
    isBold As Boolean, _
    isItalic As Boolean, _
    isUnderline As Boolean _
)
public:
static void CreateBarLabels (
    GraphPane^ pane,
    bool isBarCenter,
    String^ valueFormat,
    String^ fontFamily,
    float fontSize,
    Color fontColor,
    bool isBold,
    bool isItalic,
    bool isUnderline
)
Parameters
pane (GraphPane)
The GraphPane in which to place the text labels.
isBarCenter (Boolean)
true to center the labels inside the bars, false to place the labels just above the top of the bar.
valueFormat (String)
The double.ToString string format to use for creating the labels.
fontFamily (String)
The string name of the font family to use for the labels
fontSize (Single)
The floating point size of the font, in scaled points
fontColor (Color)
The color in which to draw the labels
isBold (Boolean)
true for a bold font type, false otherwise
isItalic (Boolean)
true for an italic font type, false otherwise
isUnderline (Boolean)
true for an underline font type, false otherwise
Remarks
This method will go through the bars, create a label that corresponds to the bar value, and place it on the graph depending on user preferences. This works for horizontal or vertical bars in clusters or stacks, but only for BarItem types. This method does not apply to ErrorBarItem or HiLowBarItem objects. Call this method only after calling AxisChange()().


Draw Method (g, pane, pos, scaleFactor)

Draw Method (g, pane, pos, scaleFactor)
Namespaces ► ZedGraph ► BarItem ► Draw(Graphics, GraphPane, Int32, Single)
Do all rendering associated with this BarItem to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object.
Declaration Syntax
C# Visual Basic Visual C++
public override void Draw(
    Graphics g,
    GraphPane pane,
    int pos,
    float scaleFactor
)
Public Overrides Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    pos As Integer, _
    scaleFactor As Single _
)
public:
virtual void Draw (
    Graphics^ g,
    GraphPane^ pane,
    int pos,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
pos (Int32)
The ordinal position of the current Bar curve.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


DrawLegendKey Method (g, pane, rect, scaleFactor)

DrawLegendKey Method (g, pane, rect, scaleFactor)
Namespaces ► ZedGraph ► BarItem ► DrawLegendKey(Graphics, GraphPane, RectangleF, Single)
Draw a legend key entry for this BarItem at the specified location
Declaration Syntax
C# Visual Basic Visual C++
public override void DrawLegendKey(
    Graphics g,
    GraphPane pane,
    RectangleF rect,
    float scaleFactor
)
Public Overrides Sub DrawLegendKey ( _
    g As Graphics, _
    pane As GraphPane, _
    rect As RectangleF, _
    scaleFactor As Single _
)
public:
virtual void DrawLegendKey (
    Graphics^ g,
    GraphPane^ pane,
    RectangleF rect,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
rect (RectangleF)
The RectangleF struct that specifies the location for the legend key
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


GetCoords Method (pane, i, coords)

GetCoords Method (pane, i, coords)
Namespaces ► ZedGraph ► BarItem ► GetCoords(GraphPane, Int32, String%)
Determine the coords for the rectangle associated with a specified point for this CurveItem
Declaration Syntax
C# Visual Basic Visual C++
public override bool GetCoords(
    GraphPane pane,
    int i,
    out string coords
)
Public Overrides Function GetCoords ( _
    pane As GraphPane, _
    i As Integer, _
    <OutAttribute> ByRef coords As String _
) As Boolean
public:
virtual bool GetCoords (
    GraphPane^ pane,
    int i,
    [OutAttribute] String^% coords
) override
Parameters
pane (GraphPane)
The GraphPane to which this curve belongs
i (Int32)
The index of the point of interest
coords (String %)
A list of coordinates that represents the "rect" for this point (used in an html AREA tag)
Return Value
true if it's a valid point, false otherwise


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► BarItem ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► BarItem ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► BarItem ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


BarSettings Class

BarSettings Class
Namespaces ► ZedGraph ► BarSettings
Class that handles the global settings for bar charts
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class BarSettings : ISerializable
<SerializableAttribute> _
Public Class BarSettings _
    Implements ISerializable
[SerializableAttribute]
public ref class BarSettings : ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BarSettingsBarSettingsNew(GraphPane) | Constructor to build a BarSettings instance from the defaults.
 | BarSettingsBarSettingsNew(BarSettings, GraphPane) | Copy constructor
 | BarBaseAxis()() | Determine the Axis from which the Bar charts are based.
 | Base | Determines the base axis from which Bar graphs will be displayed.
 | CalcClusterScaleWidth()() | Calculate the width of an individual bar cluster on a BarItem graph. This value only applies to bar graphs plotted on non-ordinal X axis types (IsAnyOrdinal is false).
 | ClusterScaleWidth | The width of an individual bar cluster on a Bar graph. This value only applies to bar graphs plotted on non-ordinal X axis types (Linear, Log, and Date.
 | ClusterScaleWidthAuto | Gets or sets a property that determines if the ClusterScaleWidth will be calculated automatically.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetClusterWidth()() | Determine the width, in screen pixel units, of each bar cluster including the cluster gaps and bar gaps.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinBarGap | The minimum space between individual Bars within a cluster, expressed as a fraction of the bar size.
 | MinClusterGap | The minimum space between Bar clusters, expressed as a fraction of the bar size.
 | schema | Current schema value that defines the version of the serialized file
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Determines how the BarItem graphs will be displayed. See the BarType enum for the individual types available.
Inheritance Hierarchy
Object
BarSettings


BarSettings Constructor

BarSettings Constructor
Namespaces ► ZedGraph ► BarSettings ► BarSettingsBarSettingsNew()()
Members
Icon | Member | Description
 | BarSettingsBarSettingsNew(GraphPane) | Constructor to build a BarSettings instance from the defaults.
 | BarSettingsBarSettingsNew(BarSettings, GraphPane) | Copy constructor


BarSettings Constructor (rhs, parentPane)

BarSettings Constructor (rhs, parentPane)
Namespaces ► ZedGraph ► BarSettings ► BarSettingsBarSettingsNew(BarSettings, GraphPane)
Copy constructor
Declaration Syntax
C# Visual Basic Visual C++
public BarSettings(
    BarSettings rhs,
    GraphPane parentPane
)
Public Sub New ( _
    rhs As BarSettings, _
    parentPane As GraphPane _
)
public:
BarSettings (
    BarSettings^ rhs,
    GraphPane^ parentPane
)
Parameters
rhs (BarSettings)
the BarSettings instance to be copied.
parentPane (GraphPane)
The GraphPane that will be the parent of this new BarSettings object.


BarSettings Constructor (parentPane)

BarSettings Constructor (parentPane)
Namespaces ► ZedGraph ► BarSettings ► BarSettingsBarSettingsNew(GraphPane)
Constructor to build a BarSettings instance from the defaults.
Declaration Syntax
C# Visual Basic Visual C++
public BarSettings(
    GraphPane parentPane
)
Public Sub New ( _
    parentPane As GraphPane _
)
public:
BarSettings (
    GraphPane^ parentPane
)
Parameters
parentPane (GraphPane)


BarBaseAxis Method

BarBaseAxis Method
Namespaces ► ZedGraph ► BarSettings ► BarBaseAxis()()
Determine the Axis from which the Bar charts are based.
Declaration Syntax
C# Visual Basic Visual C++
public Axis BarBaseAxis()
Public Function BarBaseAxis As Axis
public:
Axis^ BarBaseAxis ()
Return Value
The Axis class for the axis from which the bars are based
See Also
BarBase
BarSettings
Base
GetClusterWidth(GraphPane)


Base Property

Base Property
Namespaces ► ZedGraph ► BarSettings ► Base
Determines the base axis from which Bar graphs will be displayed.
Declaration Syntax
C# Visual Basic Visual C++
public BarBase Base{ get; set;}
Public Property Base As BarBase
public:
property BarBase Base {
    BarBase get ();
    void set (BarBase value);
}
Remarks
The base axis is the axis from which the bars grow with increasing value. The value is of the enumeration type BarBase.
See Also
Base


CalcClusterScaleWidth Method

CalcClusterScaleWidth Method
Namespaces ► ZedGraph ► BarSettings ► CalcClusterScaleWidth()()
Calculate the width of an individual bar cluster on a BarItem graph. This value only applies to bar graphs plotted on non-ordinal X axis types (IsAnyOrdinal is false).
Declaration Syntax
C# Visual Basic Visual C++
public void CalcClusterScaleWidth()
Public Sub CalcClusterScaleWidth
public:
void CalcClusterScaleWidth ()
Remarks
This value can be calculated automatically if ClusterScaleWidthAuto is set to true. In this case, ClusterScaleWidth will be calculated if Base refers to an Axis of a non-ordinal type (IsAnyOrdinal is false). The ClusterScaleWidth is calculated from the minimum difference found between any two points on the Base Axis for any BarItem in the CurveList. The ClusterScaleWidth is set automatically each time AxisChange()() is called.
See Also
ClusterScaleWidth
ClusterScaleWidthAuto
MinBarGap
MinClusterGap


ClusterScaleWidth Property

ClusterScaleWidth Property
Namespaces ► ZedGraph ► BarSettings ► ClusterScaleWidth
The width of an individual bar cluster on a Bar graph. This value only applies to bar graphs plotted on non-ordinal X axis types (Linear, Log, and Date.
Declaration Syntax
C# Visual Basic Visual C++
public double ClusterScaleWidth{ get; set;}
Public Property ClusterScaleWidth As Double
public:
property double ClusterScaleWidth {
    double get ();
    void set (double value);
}
Remarks
This value can be calculated automatically if ClusterScaleWidthAuto is set to true. In this case, ClusterScaleWidth will be calculated if Base refers to an Axis of a non-ordinal type (IsAnyOrdinal is false). The ClusterScaleWidth is calculated from the minimum difference found between any two points on the Base Axis for any BarItem in the CurveList. The ClusterScaleWidth is set automatically each time AxisChange()() is called. Calculations are done by the CalcClusterScaleWidth()() method.
See Also
ClusterScaleWidth
ClusterScaleWidthAuto
MinBarGap
MinClusterGap


ClusterScaleWidthAuto Property

ClusterScaleWidthAuto Property
Namespaces ► ZedGraph ► BarSettings ► ClusterScaleWidthAuto
Gets or sets a property that determines if the ClusterScaleWidth will be calculated automatically.
Declaration Syntax
C# Visual Basic Visual C++
public bool ClusterScaleWidthAuto{ get; set;}
Public Property ClusterScaleWidthAuto As Boolean
public:
property bool ClusterScaleWidthAuto {
    bool get ();
    void set (bool value);
}
Remarks
true for the ClusterScaleWidth to be calculated automatically based on the available data, false otherwise. This value will be set to false automatically if the ClusterScaleWidth value is changed by the user.
See Also
ClusterScaleWidthAuto
ClusterScaleWidth


GetClusterWidth Method

GetClusterWidth Method
Namespaces ► ZedGraph ► BarSettings ► GetClusterWidth()()
Determine the width, in screen pixel units, of each bar cluster including the cluster gaps and bar gaps.
Declaration Syntax
C# Visual Basic Visual C++
public float GetClusterWidth()
Public Function GetClusterWidth As Single
public:
float GetClusterWidth ()
Return Value
The width of each bar cluster, in pixel units
Remarks
This method calls the GetClusterWidth(GraphPane) method for the base Axis for Bar graphs (the base Axis is assigned by the Base property).
See Also
BarBase
BarSettings
GetClusterWidth(GraphPane)
Type


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► BarSettings ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


MinBarGap Property

MinBarGap Property
Namespaces ► ZedGraph ► BarSettings ► MinBarGap
The minimum space between individual Bars within a cluster, expressed as a fraction of the bar size.
Declaration Syntax
C# Visual Basic Visual C++
public float MinBarGap{ get; set;}
Public Property MinBarGap As Single
public:
property float MinBarGap {
    float get ();
    void set (float value);
}
See Also
MinBarGap
MinClusterGap
ClusterScaleWidth


MinClusterGap Property

MinClusterGap Property
Namespaces ► ZedGraph ► BarSettings ► MinClusterGap
The minimum space between Bar clusters, expressed as a fraction of the bar size.
Declaration Syntax
C# Visual Basic Visual C++
public float MinClusterGap{ get; set;}
Public Property MinClusterGap As Single
public:
property float MinClusterGap {
    float get ();
    void set (float value);
}
See Also
MinClusterGap
MinBarGap
ClusterScaleWidth


schema Field

schema Field
Namespaces ► ZedGraph ► BarSettings ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


Type Property

Type Property
Namespaces ► ZedGraph ► BarSettings ► Type
Determines how the BarItem graphs will be displayed. See the BarType enum for the individual types available.
Declaration Syntax
C# Visual Basic Visual C++
public BarType Type{ get; set;}
Public Property Type As BarType
public:
property BarType Type {
    BarType get ();
    void set (BarType value);
}
See Also
Type


BarSettings.Default Structure

BarSettings..::Default Structure
Namespaces ► ZedGraph ► BarSettings ► BarSettings..::Default
A simple struct that defines the default property values for the BarSettings class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Base | The default value for the Base, which determines the base Axis from which the Bar graphs will be displayed.
 | ClusterScaleWidth | The default width of a bar cluster on a Bar graph. This value only applies to Bar graphs, and only when the Type is Linear, Log or Date. This dimension is expressed in terms of X scale user units.
 | ClusterScaleWidthAuto | The default value for ClusterScaleWidthAuto.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinBarGap | The default dimension gap between each individual bar within a bar cluster on a Bar graph. This dimension is expressed in terms of the normal bar width.
 | MinClusterGap | The default dimension gap between clusters of bars on a Bar graph. This dimension is expressed in terms of the normal bar width.
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | Type | The default value for the Type property, which determines if the bars are drawn overlapping eachother in a "stacked" format, or side-by-side in a "cluster" format. See the BarType for more information.


Base Field

Base Field
Namespaces ► ZedGraph ► BarSettings..::Default ► Base
The default value for the Base, which determines the base Axis from which the Bar graphs will be displayed.
Declaration Syntax
C# Visual Basic Visual C++
public static BarBase Base
Public Shared Base As BarBase
public:
static BarBase Base
See Also
Base


ClusterScaleWidth Field

ClusterScaleWidth Field
Namespaces ► ZedGraph ► BarSettings..::Default ► ClusterScaleWidth
The default width of a bar cluster on a Bar graph. This value only applies to Bar graphs, and only when the Type is Linear, Log or Date. This dimension is expressed in terms of X scale user units.
Declaration Syntax
C# Visual Basic Visual C++
public static double ClusterScaleWidth
Public Shared ClusterScaleWidth As Double
public:
static double ClusterScaleWidth
See Also
MinClusterGap
MinBarGap


ClusterScaleWidthAuto Field

ClusterScaleWidthAuto Field
Namespaces ► ZedGraph ► BarSettings..::Default ► ClusterScaleWidthAuto
The default value for ClusterScaleWidthAuto.
Declaration Syntax
C# Visual Basic Visual C++
public static bool ClusterScaleWidthAuto
Public Shared ClusterScaleWidthAuto As Boolean
public:
static bool ClusterScaleWidthAuto


MinBarGap Field

MinBarGap Field
Namespaces ► ZedGraph ► BarSettings..::Default ► MinBarGap
The default dimension gap between each individual bar within a bar cluster on a Bar graph. This dimension is expressed in terms of the normal bar width.
Declaration Syntax
C# Visual Basic Visual C++
public static float MinBarGap
Public Shared MinBarGap As Single
public:
static float MinBarGap
See Also
MinClusterGap
MinBarGap


MinClusterGap Field

MinClusterGap Field
Namespaces ► ZedGraph ► BarSettings..::Default ► MinClusterGap
The default dimension gap between clusters of bars on a Bar graph. This dimension is expressed in terms of the normal bar width.
Declaration Syntax
C# Visual Basic Visual C++
public static float MinClusterGap
Public Shared MinClusterGap As Single
public:
static float MinClusterGap
See Also
MinBarGap
MinClusterGap


Type Field

Type Field
Namespaces ► ZedGraph ► BarSettings..::Default ► Type
The default value for the Type property, which determines if the bars are drawn overlapping eachother in a "stacked" format, or side-by-side in a "cluster" format. See the BarType for more information.
Declaration Syntax
C# Visual Basic Visual C++
public static BarType Type
Public Shared Type As BarType
public:
static BarType Type
See Also
Type


BarType Enumeration

BarType Enumeration
Namespaces ► ZedGraph ► BarType
Enumeration type that defines the available types of BarItem graphs.
Declaration Syntax
C# Visual Basic Visual C++
public enum BarType
Public Enumeration BarType
public enum class BarType
Members
Member | Description
Cluster | Draw each BarItem side by side in clusters.
ClusterHiLow | Draw each BarItem side by side in clusters, also use the "Z" value from the IPointList to define the bottom of each bar. This is very similar to a HiLowBarItem, except that multiple bars will be automatically clustered, and the bar width is defined according to available space rather than as a fixed width setting.
Overlay | Draw the BarItem bars one on top of the other. The bars will be drawn such that the last bar in the CurveList will be behind all other bars. Note that the bar values are not summed up for the overlay mode. The data values must be summed before being passed to AddBar(String, IPointList, Color). For example, if the first bar of the first BarItem has a value of 100, and the first bar of the second BarItem has a value of 120, then that bar will appear to be 20 units on top of the first bar.
SortedOverlay | Draw the BarItem bars one on top of the other. The bars will be drawn such that the bars are sorted according to the maximum value, with the tallest bar at each point at the back and the shortest bar at the front. This is similar to the Overlay mode, but the bars are sorted at each base value. The data values must be summed before being passed to AddBar(String, IPointList, Color). For example, if the first bar of the first BarItem has a value of 100, and the first bar of the second BarItem has a value of 120, then that bar will appear to be 20 units on top of the first bar.
Stack | Draw the BarItem bars in an additive format so that they stack on top of one another. The value of the last bar drawn will be the sum of the values of all prior bars.
PercentStack | Draw the BarItem bars in a format whereby the height of each represents the percentage of the total each one represents. Negative values are displayed below the zero line as percentages of the absolute total of all values.
See Also
Type


BasicArrayPointList Class

BasicArrayPointList Class
Namespaces ► ZedGraph ► BasicArrayPointList
A data collection class for ZedGraph, provided as an alternative to PointPairList.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class BasicArrayPointList : IPointList,
    ICloneable
<SerializableAttribute> _
Public Class BasicArrayPointList _
    Implements IPointList, ICloneable
[SerializableAttribute]
public ref class BasicArrayPointList : IPointList,
    ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BasicArrayPointListBasicArrayPointListNew(array<Double>[](), array<Double>[]()) | Constructor to initialize the PointPairList from two arrays of type double.
 | BasicArrayPointListBasicArrayPointListNew(BasicArrayPointList) | The Copy Constructor
 | Clone()() | Typesafe, deep-copy clone method.
 | Count | Returns the number of points available in the arrays. Count will be the greater of the lengths of the X and Y arrays.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([Int32])] | Indexer to access the specified PointPair object by its ordinal position in the list.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | x | Instance of an array of x values
 | y | Instance of an array of x values
Remarks
The data storage class for ZedGraph can be any type, so long as it uses the IPointList interface. This class, albeit simple, is a demonstration of implementing the IPointList interface to provide a simple data collection using only two arrays. The IPointList interface can also be used as a layer between ZedGraph and a database, for example.
Inheritance Hierarchy
Object
BasicArrayPointList
See Also
PointPairList
IPointList


BasicArrayPointList Constructor

BasicArrayPointList Constructor
Namespaces ► ZedGraph ► BasicArrayPointList ► BasicArrayPointListBasicArrayPointListNew()()
Members
Icon | Member | Description
 | BasicArrayPointListBasicArrayPointListNew(array<Double>[](), array<Double>[]()) | Constructor to initialize the PointPairList from two arrays of type double.
 | BasicArrayPointListBasicArrayPointListNew(BasicArrayPointList) | The Copy Constructor


BasicArrayPointList Constructor (x, y)

BasicArrayPointList Constructor (x, y)
Namespaces ► ZedGraph ► BasicArrayPointList ► BasicArrayPointListBasicArrayPointListNew(array<Double>[](), array<Double>[]())
Constructor to initialize the PointPairList from two arrays of type double.
Declaration Syntax
C# Visual Basic Visual C++
public BasicArrayPointList(
    double[] x,
    double[] y
)
Public Sub New ( _
    x As Double(), _
    y As Double() _
)
public:
BasicArrayPointList (
    array<double>^ x,
    array<double>^ y
)
Parameters
x (array< Double >[]())
y (array< Double >[]())


BasicArrayPointList Constructor (rhs)

BasicArrayPointList Constructor (rhs)
Namespaces ► ZedGraph ► BasicArrayPointList ► BasicArrayPointListBasicArrayPointListNew(BasicArrayPointList)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public BasicArrayPointList(
    BasicArrayPointList rhs
)
Public Sub New ( _
    rhs As BasicArrayPointList _
)
public:
BasicArrayPointList (
    BasicArrayPointList^ rhs
)
Parameters
rhs (BasicArrayPointList)
The PointPairList from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► BasicArrayPointList ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public BasicArrayPointList Clone()
Public Function Clone As BasicArrayPointList
public:
BasicArrayPointList^ Clone ()
Return Value
A new, independent copy of this class


Count Property

Count Property
Namespaces ► ZedGraph ► BasicArrayPointList ► Count
Returns the number of points available in the arrays. Count will be the greater of the lengths of the X and Y arrays.
Declaration Syntax
C# Visual Basic Visual C++
public int Count{ get;}
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph ► BasicArrayPointList ► Item[([Int32])]
Indexer to access the specified PointPair object by its ordinal position in the list.
Declaration Syntax
C# Visual Basic Visual C++
public PointPair this[
    int index
]{ get; set;}
Public Default Property Item ( _
    index As Integer _
) As PointPair
public:
virtual property PointPair^ default[int index] {
    PointPair^ get (int index) sealed;
    void set (int index, PointPair^ value) sealed;
}
Parameters
index (Int32)
The ordinal position (zero-based) of the PointPair object to be accessed.
Value
A PointPair object reference.
Remarks
Returns Missing for any value of that is outside of its corresponding array bounds.


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► BasicArrayPointList ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


x Field

x Field
Namespaces ► ZedGraph ► BasicArrayPointList ► x
Instance of an array of x values
Declaration Syntax
C# Visual Basic Visual C++
public double[] x
Public x As Double()
public:
array<double>^ x


y Field

y Field
Namespaces ► ZedGraph ► BasicArrayPointList ► y
Instance of an array of x values
Declaration Syntax
C# Visual Basic Visual C++
public double[] y
Public y As Double()
public:
array<double>^ y


Border Class

Border Class
Namespaces ► ZedGraph ► Border
A class that encapsulates Border (frame) properties for an object. The Border class is used in a variety of ZedGraph objects to handle the drawing of the Border around the object.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Border : LineBase, ISerializable,
    ICloneable
<SerializableAttribute> _
Public Class Border _
    Inherits LineBase _
    Implements ISerializable, ICloneable
[SerializableAttribute]
public ref class Border : public LineBase,
    ISerializable, ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BorderBorderNew()() | The default constructor. Initialized to default values.
 | BorderBorderNew(Boolean, Color, Single) | Constructor that specifies the visibility, color and penWidth of the Border.
 | BorderBorderNew(Color, Single) | Constructor that specifies the color and penWidth of the Border.
 | BorderBorderNew(Border) | The Copy Constructor
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The color of the Line. Note that this color value can be overridden if the GradientFill.Type is one of the GradientByX, GradientByY, GradientByZ, and GradientByColorValue types. (Inherited from LineBase.)
 | DashOff | The "Dash Off" mode for drawing the line. (Inherited from LineBase.)
 | DashOn | The "Dash On" mode for drawing the line. (Inherited from LineBase.)
 | Draw(Graphics, PaneBase, Single, RectangleF) | Draw the specified Border (RectangleF) using the properties of this Border object.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides LineBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetPen(PaneBase, Single) | Create a Pen object based on the properties of this LineBase. (Inherited from LineBase.)
 | GetPen(PaneBase, Single, PointPair) | Create a Pen object based on the properties of this LineBase. (Inherited from LineBase.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GradientFill | Gets or sets a custom Fill class. (Inherited from LineBase.)
 | InflateFactor | Gets or sets the amount of inflation to be done on the rectangle before rendering.
 | IsAntiAlias | Gets or sets a value that determines if the lines are drawn using Anti-Aliasing capabilities from the Graphics class. (Inherited from LineBase.)
 | IsVisible | Gets or sets a property that shows or hides the Line. (Inherited from LineBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | schema | Current schema value that defines the version of the serialized file
 | Style | The style of the Line, defined as a DashStyle enum. This allows the line to be solid, dashed, or dotted. (Inherited from LineBase.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Width | The pen width used to draw the Line, in points (1/72 inch) (Inherited from LineBase.)
Inheritance Hierarchy
Object
 | LineBase
 |  | Border


Border Constructor

Border Constructor
Namespaces ► ZedGraph ► Border ► BorderBorderNew()()
Members
Icon | Member | Description
 | BorderBorderNew()() | The default constructor. Initialized to default values.
 | BorderBorderNew(Boolean, Color, Single) | Constructor that specifies the visibility, color and penWidth of the Border.
 | BorderBorderNew(Color, Single) | Constructor that specifies the color and penWidth of the Border.
 | BorderBorderNew(Border) | The Copy Constructor


Border Constructor

Border Constructor
Namespaces ► ZedGraph ► Border ► BorderBorderNew()()
The default constructor. Initialized to default values.
Declaration Syntax
C# Visual Basic Visual C++
public Border()
Public Sub New
public:
Border ()


Border Constructor (isVisible, color, width)

Border Constructor (isVisible, color, width)
Namespaces ► ZedGraph ► Border ► BorderBorderNew(Boolean, Color, Single)
Constructor that specifies the visibility, color and penWidth of the Border.
Declaration Syntax
C# Visual Basic Visual C++
public Border(
    bool isVisible,
    Color color,
    float width
)
Public Sub New ( _
    isVisible As Boolean, _
    color As Color, _
    width As Single _
)
public:
Border (
    bool isVisible,
    Color color,
    float width
)
Parameters
isVisible (Boolean)
Determines whether or not the Border will be drawn.
color (Color)
The color of the Border
width (Single)
The width, in points (1/72 inch), for the Border.


Border Constructor (color, width)

Border Constructor (color, width)
Namespaces ► ZedGraph ► Border ► BorderBorderNew(Color, Single)
Constructor that specifies the color and penWidth of the Border.
Declaration Syntax
C# Visual Basic Visual C++
public Border(
    Color color,
    float width
)
Public Sub New ( _
    color As Color, _
    width As Single _
)
public:
Border (
    Color color,
    float width
)
Parameters
color (Color)
The color of the Border
width (Single)
The width, in points (1/72 inch), for the Border.


Border Constructor (rhs)

Border Constructor (rhs)
Namespaces ► ZedGraph ► Border ► BorderBorderNew(Border)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public Border(
    Border rhs
)
Public Sub New ( _
    rhs As Border _
)
public:
Border (
    Border^ rhs
)
Parameters
rhs (Border)
The Border object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► Border ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public Border Clone()
Public Function Clone As Border
public:
Border^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, scaleFactor, rect)

Draw Method (g, pane, scaleFactor, rect)
Namespaces ► ZedGraph ► Border ► Draw(Graphics, PaneBase, Single, RectangleF)
Draw the specified Border (RectangleF) using the properties of this Border object.
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    PaneBase pane,
    float scaleFactor,
    RectangleF rect
)
Public Sub Draw ( _
    g As Graphics, _
    pane As PaneBase, _
    scaleFactor As Single, _
    rect As RectangleF _
)
public:
void Draw (
    Graphics^ g,
    PaneBase^ pane,
    float scaleFactor,
    RectangleF rect
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor for the features of the graph based on the BaseDimension. This scaling factor is calculated by the CalcScaleFactor()() method. The scale factor represents a linear multiple to be applied to font sizes, symbol sizes, etc.
rect (RectangleF)
A RectangleF struct to be drawn.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► Border ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


InflateFactor Property

InflateFactor Property
Namespaces ► ZedGraph ► Border ► InflateFactor
Gets or sets the amount of inflation to be done on the rectangle before rendering.
Declaration Syntax
C# Visual Basic Visual C++
public float InflateFactor{ get; set;}
Public Property InflateFactor As Single
public:
property float InflateFactor {
    float get ();
    void set (float value);
}
Remarks
This allows the border to be inset or outset relative to the actual rectangle area.


schema Field

schema Field
Namespaces ► ZedGraph ► Border ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► Border ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Border.Default Structure

Border..::Default Structure
Namespaces ► ZedGraph ► Border ► Border..::Default
A simple struct that defines the default property values for the Fill class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | InflateFactor | The default value for InflateFactor, in units of points (1/72 inch).
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


InflateFactor Field

InflateFactor Field
Namespaces ► ZedGraph ► Border..::Default ► InflateFactor
The default value for InflateFactor, in units of points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float InflateFactor
Public Shared InflateFactor As Single
public:
static float InflateFactor
See Also
InflateFactor


BoxObj Class

BoxObj Class
Namespaces ► ZedGraph ► BoxObj
A class that represents a bordered and/or filled box (rectangle) object on the graph. A list of BoxObj objects is maintained by the GraphObjList collection class.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class BoxObj : GraphObj, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class BoxObj _
    Inherits GraphObj _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class BoxObj : public GraphObj,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BoxObjBoxObjNew(Double, Double, Double, Double, Color, Color) | A constructor that allows the position, border color, and solid fill color of the BoxObj to be pre-specified.
 | BoxObjBoxObjNew(Double, Double, Double, Double) | A constructor that allows the position of the BoxObj to be pre-specified. Other properties are defaulted.
 | BoxObjBoxObjNew()() | A default constructor that creates a BoxObj using a location of (0,0), and a width,height of (1,1). Other properties are defaulted.
 | BoxObjBoxObjNew(Double, Double, Double, Double, Color, Color, Color) | A constructor that allows the position, border color, and two-color gradient fill colors of the BoxObj to be pre-specified.
 | BoxObjBoxObjNew(BoxObj) | The Copy Constructor
 | Border | Gets or sets the Border object, which determines the properties of the border around this BoxObj
 | Clone()() | Typesafe, deep-copy clone method.
 | Draw(Graphics, PaneBase, Single) | Render this object to the specified Graphics device. (Overrides GraphObj.Draw(Graphics, PaneBase, Single).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Gets or sets the Fill data for this BoxObj.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCoords(PaneBase, Graphics, Single, String%, String%) | Determines the shape type and Coords values for this GraphObj (Overrides GraphObj.GetCoords(PaneBase, Graphics, Single, String%, String%).)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides GraphObj.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsClippedToChartRect | Gets or sets a value that determines whether or not the rendering of this GraphObj will be clipped to the Rect. (Inherited from GraphObj.)
 | IsInFrontOfData | true if the ZOrder of this object is set to put it in front of the CurveItem data points. (Inherited from GraphObj.)
 | IsVisible | Gets or sets a value that determines if this GraphObj will be visible in the graph. true displays the item, false hides it. (Inherited from GraphObj.)
 | Link | Gets or sets the hyperlink information for this GraphObj. (Inherited from GraphObj.)
 | Location | The Location struct that describes the location for this GraphObj. (Inherited from GraphObj.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PointInBox(PointF, PaneBase, Graphics, Single) | Determine if the specified screen point lies inside the bounding box of this BoxObj. (Overrides GraphObj.PointInBox(PointF, PaneBase, Graphics, Single).)
 | schema2 | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the GraphObj. ZedGraph does not use this value for any purpose. (Inherited from GraphObj.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ZOrder | Gets or sets a value that determines the z-order "depth" of this item relative to other graphic objects. (Inherited from GraphObj.)
Inheritance Hierarchy
Object
 | GraphObj
 |  | BoxObj
 |  |  | EllipseObj
 |  |  | PolyObj


BoxObj Constructor

BoxObj Constructor
Namespaces ► ZedGraph ► BoxObj ► BoxObjBoxObjNew()()
Constructors for the BoxObj object
Members
Icon | Member | Description
 | BoxObjBoxObjNew(Double, Double, Double, Double, Color, Color) | A constructor that allows the position, border color, and solid fill color of the BoxObj to be pre-specified.
 | BoxObjBoxObjNew(Double, Double, Double, Double) | A constructor that allows the position of the BoxObj to be pre-specified. Other properties are defaulted.
 | BoxObjBoxObjNew()() | A default constructor that creates a BoxObj using a location of (0,0), and a width,height of (1,1). Other properties are defaulted.
 | BoxObjBoxObjNew(Double, Double, Double, Double, Color, Color, Color) | A constructor that allows the position, border color, and two-color gradient fill colors of the BoxObj to be pre-specified.
 | BoxObjBoxObjNew(BoxObj) | The Copy Constructor


BoxObj Constructor

BoxObj Constructor
Namespaces ► ZedGraph ► BoxObj ► BoxObjBoxObjNew()()
A default constructor that creates a BoxObj using a location of (0,0), and a width,height of (1,1). Other properties are defaulted.
Declaration Syntax
C# Visual Basic Visual C++
public BoxObj()
Public Sub New
public:
BoxObj ()


BoxObj Constructor (x, y, width, height)

BoxObj Constructor (x, y, width, height)
Namespaces ► ZedGraph ► BoxObj ► BoxObjBoxObjNew(Double, Double, Double, Double)
A constructor that allows the position of the BoxObj to be pre-specified. Other properties are defaulted.
Declaration Syntax
C# Visual Basic Visual C++
public BoxObj(
    double x,
    double y,
    double width,
    double height
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double _
)
public:
BoxObj (
    double x,
    double y,
    double width,
    double height
)
Parameters
x (Double)
The x location for this BoxObj. This will be in units determined by CoordinateFrame.
y (Double)
The y location for this BoxObj. This will be in units determined by CoordinateFrame.
width (Double)
The width of this BoxObj. This will be in units determined by CoordinateFrame.
height (Double)
The height of this BoxObj. This will be in units determined by CoordinateFrame.


BoxObj Constructor (x, y, width, height, borderColor, fillColor)

BoxObj Constructor (x, y, width, height, borderColor, fillColor)
Namespaces ► ZedGraph ► BoxObj ► BoxObjBoxObjNew(Double, Double, Double, Double, Color, Color)
A constructor that allows the position, border color, and solid fill color of the BoxObj to be pre-specified.
Declaration Syntax
C# Visual Basic Visual C++
public BoxObj(
    double x,
    double y,
    double width,
    double height,
    Color borderColor,
    Color fillColor
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    borderColor As Color, _
    fillColor As Color _
)
public:
BoxObj (
    double x,
    double y,
    double width,
    double height,
    Color borderColor,
    Color fillColor
)
Parameters
x (Double)
The x location for this BoxObj. This will be in units determined by CoordinateFrame.
y (Double)
The y location for this BoxObj. This will be in units determined by CoordinateFrame.
width (Double)
The width of this BoxObj. This will be in units determined by CoordinateFrame.
height (Double)
The height of this BoxObj. This will be in units determined by CoordinateFrame.
borderColor (Color)
An arbitrary Color specification for the box border
fillColor (Color)
An arbitrary Color specification for the box fill (will be a solid color fill)


BoxObj Constructor (x, y, width, height, borderColor, fillColor1, fillColor2)

BoxObj Constructor (x, y, width, height, borderColor, fillColor1, fillColor2)
Namespaces ► ZedGraph ► BoxObj ► BoxObjBoxObjNew(Double, Double, Double, Double, Color, Color, Color)
A constructor that allows the position, border color, and two-color gradient fill colors of the BoxObj to be pre-specified.
Declaration Syntax
C# Visual Basic Visual C++
public BoxObj(
    double x,
    double y,
    double width,
    double height,
    Color borderColor,
    Color fillColor1,
    Color fillColor2
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    borderColor As Color, _
    fillColor1 As Color, _
    fillColor2 As Color _
)
public:
BoxObj (
    double x,
    double y,
    double width,
    double height,
    Color borderColor,
    Color fillColor1,
    Color fillColor2
)
Parameters
x (Double)
The x location for this BoxObj. This will be in units determined by CoordinateFrame.
y (Double)
The y location for this BoxObj. This will be in units determined by CoordinateFrame.
width (Double)
The width of this BoxObj. This will be in units determined by CoordinateFrame.
height (Double)
The height of this BoxObj. This will be in units determined by CoordinateFrame.
borderColor (Color)
An arbitrary Color specification for the box border
fillColor1 (Color)
An arbitrary Color specification for the start of the box gradient fill
fillColor2 (Color)
An arbitrary Color specification for the end of the box gradient fill


BoxObj Constructor (rhs)

BoxObj Constructor (rhs)
Namespaces ► ZedGraph ► BoxObj ► BoxObjBoxObjNew(BoxObj)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public BoxObj(
    BoxObj rhs
)
Public Sub New ( _
    rhs As BoxObj _
)
public:
BoxObj (
    BoxObj^ rhs
)
Parameters
rhs (BoxObj)
The BoxObj object from which to copy


Border Property

Border Property
Namespaces ► ZedGraph ► BoxObj ► Border
Gets or sets the Border object, which determines the properties of the border around this BoxObj
Declaration Syntax
C# Visual Basic Visual C++
public Border Border{ get; set;}
Public Property Border As Border
public:
property Border^ Border {
    Border^ get ();
    void set (Border^ value);
}


Clone Method

Clone Method
Namespaces ► ZedGraph ► BoxObj ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public BoxObj Clone()
Public Function Clone As BoxObj
public:
BoxObj^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, scaleFactor)

Draw Method (g, pane, scaleFactor)
Namespaces ► ZedGraph ► BoxObj ► Draw(Graphics, PaneBase, Single)
Render this object to the specified Graphics device.
Declaration Syntax
C# Visual Basic Visual C++
public override void Draw(
    Graphics g,
    PaneBase pane,
    float scaleFactor
)
Public Overrides Sub Draw ( _
    g As Graphics, _
    pane As PaneBase, _
    scaleFactor As Single _
)
public:
virtual void Draw (
    Graphics^ g,
    PaneBase^ pane,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Remarks
This method is normally only called by the Draw method of the parent GraphObjList collection object.


Fill Property

Fill Property
Namespaces ► ZedGraph ► BoxObj ► Fill
Gets or sets the Fill data for this BoxObj.
Declaration Syntax
C# Visual Basic Visual C++
public Fill Fill{ get; set;}
Public Property Fill As Fill
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}


GetCoords Method (pane, g, scaleFactor, shape, coords)

GetCoords Method (pane, g, scaleFactor, shape, coords)
Namespaces ► ZedGraph ► BoxObj ► GetCoords(PaneBase, Graphics, Single, String%, String%)
Determines the shape type and Coords values for this GraphObj
Declaration Syntax
C# Visual Basic Visual C++
public override void GetCoords(
    PaneBase pane,
    Graphics g,
    float scaleFactor,
    out string shape,
    out string coords
)
Public Overrides Sub GetCoords ( _
    pane As PaneBase, _
    g As Graphics, _
    scaleFactor As Single, _
    <OutAttribute> ByRef shape As String, _
    <OutAttribute> ByRef coords As String _
)
public:
virtual void GetCoords (
    PaneBase^ pane,
    Graphics^ g,
    float scaleFactor,
    [OutAttribute] String^% shape,
    [OutAttribute] String^% coords
) override
Parameters
pane (PaneBase)
g (Graphics)
scaleFactor (Single)
shape (String %)
coords (String %)


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► BoxObj ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


PointInBox Method (pt, pane, g, scaleFactor)

PointInBox Method (pt, pane, g, scaleFactor)
Namespaces ► ZedGraph ► BoxObj ► PointInBox(PointF, PaneBase, Graphics, Single)
Determine if the specified screen point lies inside the bounding box of this BoxObj.
Declaration Syntax
C# Visual Basic Visual C++
public override bool PointInBox(
    PointF pt,
    PaneBase pane,
    Graphics g,
    float scaleFactor
)
Public Overrides Function PointInBox ( _
    pt As PointF, _
    pane As PaneBase, _
    g As Graphics, _
    scaleFactor As Single _
) As Boolean
public:
virtual bool PointInBox (
    PointF pt,
    PaneBase^ pane,
    Graphics^ g,
    float scaleFactor
) override
Parameters
pt (PointF)
The screen point, in pixels
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
true if the point lies in the bounding box, false otherwise


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► BoxObj ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► BoxObj ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


BoxObj.Default Structure

BoxObj..::Default Structure
Namespaces ► ZedGraph ► BoxObj ► BoxObj..::Default
A simple struct that defines the default property values for the ArrowObj class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BorderColor | The default color used for the BoxObj border (Color property).
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | FillColor | The default color used for the BoxObj fill (Color property).
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PenWidth | The default pen width used for the BoxObj border (Width property). Units are points (1/72 inch).
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


BorderColor Field

BorderColor Field
Namespaces ► ZedGraph ► BoxObj..::Default ► BorderColor
The default color used for the BoxObj border (Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color BorderColor
Public Shared BorderColor As Color
public:
static Color BorderColor


FillColor Field

FillColor Field
Namespaces ► ZedGraph ► BoxObj..::Default ► FillColor
The default color used for the BoxObj fill (Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color FillColor
Public Shared FillColor As Color
public:
static Color FillColor


PenWidth Field

PenWidth Field
Namespaces ► ZedGraph ► BoxObj..::Default ► PenWidth
The default pen width used for the BoxObj border (Width property). Units are points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float PenWidth
Public Shared PenWidth As Single
public:
static float PenWidth


Chart Class

Chart Class
Namespaces ► ZedGraph ► Chart
Class that handles the properties of the charting area (where the curves are actually drawn), which is bounded by the XAxis, YAxis, and Y2Axis.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Chart : ICloneable, ISerializable
<SerializableAttribute> _
Public Class Chart _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class Chart : ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ChartChartNew()() | Default constructor.
 | ChartChartNew(Chart) | Copy constructor
 | Border | Gets or sets the Border class for drawing the border border around the Chart
 | Clone()() | Typesafe, deep-copy clone method.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Gets or sets the Fill data for this Chart.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsRectAuto | Gets or sets a boolean value that determines whether or not the Rect will be calculated automatically (almost always true).
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Rect | Gets or sets the rectangle that contains the area bounded by the axes (XAxis, YAxis, and Y2Axis). If you set this value manually, then the IsRectAuto value will automatically be set to false.
 | schema | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Chart


Chart Constructor

Chart Constructor
Namespaces ► ZedGraph ► Chart ► ChartChartNew()()
Members
Icon | Member | Description
 | ChartChartNew()() | Default constructor.
 | ChartChartNew(Chart) | Copy constructor


Chart Constructor

Chart Constructor
Namespaces ► ZedGraph ► Chart ► ChartChartNew()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public Chart()
Public Sub New
public:
Chart ()


Chart Constructor (rhs)

Chart Constructor (rhs)
Namespaces ► ZedGraph ► Chart ► ChartChartNew(Chart)
Copy constructor
Declaration Syntax
C# Visual Basic Visual C++
public Chart(
    Chart rhs
)
Public Sub New ( _
    rhs As Chart _
)
public:
Chart (
    Chart^ rhs
)
Parameters
rhs (Chart)
The source Chart to be copied.


Border Property

Border Property
Namespaces ► ZedGraph ► Chart ► Border
Gets or sets the Border class for drawing the border border around the Chart
Declaration Syntax
C# Visual Basic Visual C++
public Border Border{ get; set;}
Public Property Border As Border
public:
property Border^ Border {
    Border^ get ();
    void set (Border^ value);
}
See Also
BorderColor
BorderPenWidth


Clone Method

Clone Method
Namespaces ► ZedGraph ► Chart ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public Chart Clone()
Public Function Clone As Chart
public:
Chart^ Clone ()
Return Value
A new, independent copy of this class


Fill Property

Fill Property
Namespaces ► ZedGraph ► Chart ► Fill
Gets or sets the Fill data for this Chart.
Declaration Syntax
C# Visual Basic Visual C++
public Fill Fill{ get; set;}
Public Property Fill As Fill
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► Chart ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsRectAuto Property

IsRectAuto Property
Namespaces ► ZedGraph ► Chart ► IsRectAuto
Gets or sets a boolean value that determines whether or not the Rect will be calculated automatically (almost always true).
Declaration Syntax
C# Visual Basic Visual C++
public bool IsRectAuto{ get; set;}
Public Property IsRectAuto As Boolean
public:
property bool IsRectAuto {
    bool get ();
    void set (bool value);
}
Value
true to have ZedGraph calculate the ChartRect, false to do it yourself
Remarks
If you have a need to set the ChartRect manually, such as you have multiple graphs on a page and you want to line up the edges perfectly, you can set this value to false. If you set this value to false, you must also manually set the Rect property. You can easily determine the ChartRect that ZedGraph would have calculated by calling the CalcChartRect(Graphics) method, which returns a chart rect sized for the current data range, scale sizes, etc.


Rect Property

Rect Property
Namespaces ► ZedGraph ► Chart ► Rect
Gets or sets the rectangle that contains the area bounded by the axes (XAxis, YAxis, and Y2Axis). If you set this value manually, then the IsRectAuto value will automatically be set to false.
Declaration Syntax
C# Visual Basic Visual C++
public RectangleF Rect{ get; set;}
Public Property Rect As RectangleF
public:
property RectangleF Rect {
    RectangleF get ();
    void set (RectangleF value);
}
Value
The rectangle units are in screen pixels


schema Field

schema Field
Namespaces ► ZedGraph ► Chart ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► Chart ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Chart.Default Structure

Chart..::Default Structure
Namespaces ► ZedGraph ► Chart ► Chart..::Default
A simple struct that defines the default property values for the Chart class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BorderColor | The default color for the Chart border. (Border property).
 | BorderPenWidth | The default pen width for drawing the Chart border (Border property). Units are in points (1/72 inch).
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | FillBrush | The default brush for the Chart background. (Brush property of Fill).
 | FillColor | The default color for the Chart background. (Fill property).
 | FillType | The default FillType for the Chart background. (Type property of Fill).
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsBorderVisible | The default display mode for the Chart border (Border property). true to show the border border, false to omit the border
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


BorderColor Field

BorderColor Field
Namespaces ► ZedGraph ► Chart..::Default ► BorderColor
The default color for the Chart border. (Border property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color BorderColor
Public Shared BorderColor As Color
public:
static Color BorderColor


BorderPenWidth Field

BorderPenWidth Field
Namespaces ► ZedGraph ► Chart..::Default ► BorderPenWidth
The default pen width for drawing the Chart border (Border property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float BorderPenWidth
Public Shared BorderPenWidth As Single
public:
static float BorderPenWidth


FillBrush Field

FillBrush Field
Namespaces ► ZedGraph ► Chart..::Default ► FillBrush
The default brush for the Chart background. (Brush property of Fill).
Declaration Syntax
C# Visual Basic Visual C++
public static Brush FillBrush
Public Shared FillBrush As Brush
public:
static Brush^ FillBrush


FillColor Field

FillColor Field
Namespaces ► ZedGraph ► Chart..::Default ► FillColor
The default color for the Chart background. (Fill property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color FillColor
Public Shared FillColor As Color
public:
static Color FillColor


FillType Field

FillType Field
Namespaces ► ZedGraph ► Chart..::Default ► FillType
The default FillType for the Chart background. (Type property of Fill).
Declaration Syntax
C# Visual Basic Visual C++
public static FillType FillType
Public Shared FillType As FillType
public:
static FillType FillType


IsBorderVisible Field

IsBorderVisible Field
Namespaces ► ZedGraph ► Chart..::Default ► IsBorderVisible
The default display mode for the Chart border (Border property). true to show the border border, false to omit the border
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsBorderVisible
Public Shared IsBorderVisible As Boolean
public:
static bool IsBorderVisible


CollectionPlus Class

CollectionPlus Class
Namespaces ► ZedGraph ► CollectionPlus
A collection base class containing basic extra functionality to be inherited by CurveList, IPointList, GraphObjList.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CollectionPlus : CollectionBase
<SerializableAttribute> _
Public Class CollectionPlus _
    Inherits CollectionBase
[SerializableAttribute]
public ref class CollectionPlus : public CollectionBase
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CollectionPlusCollectionPlusNew()() | Default Constructor
 | Capacity | Gets or sets the number of elements that the CollectionBase can contain. (Inherited from CollectionBase.)
 | Clear()() | Removes all objects from the CollectionBase instance. (Inherited from CollectionBase.)
 | Count | Gets the number of elements contained in the CollectionBase instance. (Inherited from CollectionBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()() | Returns an enumerator that iterates through the CollectionBase instance. (Inherited from CollectionBase.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(Object) | Return the zero-based position index of the specified object in the collection.
 | InnerList | Gets an ArrayList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
 | List | Gets an IList containing the list of elements in the CollectionBase instance. (Inherited from CollectionBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Move(Int32, Int32) | Move the position of the object at the specified index to the new relative position in the list.
 | OnClear()() | Performs additional custom processes when clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
 | OnClearComplete()() | Performs additional custom processes after clearing the contents of the CollectionBase instance. (Inherited from CollectionBase.)
 | OnInsert(Int32, Object) | Performs additional custom processes before inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
 | OnInsertComplete(Int32, Object) | Performs additional custom processes after inserting a new element into the CollectionBase instance. (Inherited from CollectionBase.)
 | OnRemove(Int32, Object) | Performs additional custom processes when removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
 | OnRemoveComplete(Int32, Object) | Performs additional custom processes after removing an element from the CollectionBase instance. (Inherited from CollectionBase.)
 | OnSet(Int32, Object, Object) | Performs additional custom processes before setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
 | OnSetComplete(Int32, Object, Object) | Performs additional custom processes after setting a value in the CollectionBase instance. (Inherited from CollectionBase.)
 | OnValidate(Object) | Performs additional custom processes when validating a value. (Inherited from CollectionBase.)
 | Remove(Int32) | Remove an object from the collection at the specified ordinal location.
 | Remove(Object) | Remove an object from the collection based on an object reference.
 | RemoveAt(Int32) | Removes the element at the specified index of the CollectionBase instance. (Inherited from CollectionBase.)
 | ICollection..::CopyTo(Array, Int32) | (Inherited from CollectionBase.)
 | ICollection..::IsSynchronized | (Inherited from CollectionBase.)
 | ICollection..::SyncRoot | (Inherited from CollectionBase.)
 | IList..::Add(Object) | (Inherited from CollectionBase.)
 | IList..::Contains(Object) | (Inherited from CollectionBase.)
 | IList..::IndexOf(Object) | (Inherited from CollectionBase.)
 | IList..::Insert(Int32, Object) | (Inherited from CollectionBase.)
 | IList..::IsFixedSize | (Inherited from CollectionBase.)
 | IList..::IsReadOnly | (Inherited from CollectionBase.)
 | IList..::Item[([Int32])] | (Inherited from CollectionBase.)
 | IList..::Remove(Object) | (Inherited from CollectionBase.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
The methods in this collection operate on basic Object types. Therefore, in order to make sure that the derived classes remain strongly-typed, there are no Add() or Insert() methods here, and no methods that return an object. Only Remove(), Move(), IndexOf(), etc. methods are included.
Inheritance Hierarchy
Object
 | CollectionBase
 |  | CollectionPlus


CollectionPlus Constructor

CollectionPlus Constructor
Namespaces ► ZedGraph ► CollectionPlus ► CollectionPlusCollectionPlusNew()()
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public CollectionPlus()
Public Sub New
public:
CollectionPlus ()


IndexOf Method (item)

IndexOf Method (item)
Namespaces ► ZedGraph ► CollectionPlus ► IndexOf(Object)
Return the zero-based position index of the specified object in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    Object item
)
Public Function IndexOf ( _
    item As Object _
) As Integer
public:
int IndexOf (
    Object^ item
)
Parameters
item (Object)
A reference to the object that is to be found.
Return Value
The zero-based index of the specified object, or -1 if the object is not in the list
See Also
IndexOf(Object)


Move Method (index, relativePos)

Move Method (index, relativePos)
Namespaces ► ZedGraph ► CollectionPlus ► Move(Int32, Int32)
Move the position of the object at the specified index to the new relative position in the list.
Declaration Syntax
C# Visual Basic Visual C++
public int Move(
    int index,
    int relativePos
)
Public Function Move ( _
    index As Integer, _
    relativePos As Integer _
) As Integer
public:
int Move (
    int index,
    int relativePos
)
Parameters
index (Int32)
The zero-based index of the object to be moved.
relativePos (Int32)
The relative number of positions to move the object. A value of -1 will move the object one position earlier in the list, a value of 1 will move it one position later. To move an item to the beginning of the list, use a large negative value (such as -999). To move it to the end of the list, use a large positive value.
Return Value
The new position for the object, or -1 if the object was not found.
Remarks
For Graphic type objects, this method controls the Z-Order of the items. Objects at the beginning of the list appear in front of objects at the end of the list.


Remove Method

Remove Method
Namespaces ► ZedGraph ► CollectionPlus ► Remove()()
Members
Icon | Member | Description
 | Remove(Int32) | Remove an object from the collection at the specified ordinal location.
 | Remove(Object) | Remove an object from the collection based on an object reference.


Remove Method (index)

Remove Method (index)
Namespaces ► ZedGraph ► CollectionPlus ► Remove(Int32)
Remove an object from the collection at the specified ordinal location.
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    int index
)
Public Sub Remove ( _
    index As Integer _
)
public:
void Remove (
    int index
)
Parameters
index (Int32)
An ordinal position in the list at which the object to be removed is located.
See Also
Remove(Object)


Remove Method (item)

Remove Method (item)
Namespaces ► ZedGraph ► CollectionPlus ► Remove(Object)
Remove an object from the collection based on an object reference.
Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    Object item
)
Public Sub Remove ( _
    item As Object _
)
public:
void Remove (
    Object^ item
)
Parameters
item (Object)
A reference to the object that is to be removed.
See Also
Remove(Object)


ColorSymbolRotator Class

ColorSymbolRotator Class
Namespaces ► ZedGraph ► ColorSymbolRotator
Class used to get the next color/symbol for GraphPane.AddCurve methods.
Declaration Syntax
C# Visual Basic Visual C++
public class ColorSymbolRotator
Public Class ColorSymbolRotator
public ref class ColorSymbolRotator
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ColorSymbolRotatorColorSymbolRotatorNew()() |
 | COLORS | The Colors ColorSymbolRotator rotates through.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NextColor | Retrieves the next color in the rotation Calling this method has the side effect of incrementing the color index. NextSymbol NextColorIndex
 | NextColorIndex | Retrieves the index of the next color to be used. Calling this method has the side effect of incrementing the color index.
 | NextSymbol | Retrieves the next color in the rotation. Calling this method has the side effect of incrementing the symbol index. NextColor NextSymbolIndex
 | NextSymbolIndex | Retrieves the index of the next symbol to be used. Calling this method has the side effect of incrementing the symbol index.
 | StaticInstance | Retrieves the ColorSymbolRotator instance used by the static methods. StaticNextColor StaticNextSymbol
 | StaticNextColor | Retrieves the next color from this class's static ColorSymbolRotator instance StaticInstance StaticNextSymbol
 | StaticNextSymbol | Retrieves the next symbol type from this class's static ColorSymbolRotator instance StaticInstance StaticNextColor
 | SYMBOLS | The SymbolTypes ColorSymbolRotator rotates through.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ColorSymbolRotator


ColorSymbolRotator Constructor

ColorSymbolRotator Constructor
Namespaces ► ZedGraph ► ColorSymbolRotator ► ColorSymbolRotatorColorSymbolRotatorNew()()
Declaration Syntax
C# Visual Basic Visual C++
public ColorSymbolRotator()
Public Sub New
public:
ColorSymbolRotator ()


COLORS Field

COLORS Field
Namespaces ► ZedGraph ► ColorSymbolRotator ► COLORS
The Colors ColorSymbolRotator rotates through.
Declaration Syntax
C# Visual Basic Visual C++
public static readonly Color[] COLORS
Public Shared ReadOnly COLORS As Color()
public:
static initonly array<Color>^ COLORS


NextColor Property

NextColor Property
Namespaces ► ZedGraph ► ColorSymbolRotator ► NextColor
Retrieves the next color in the rotation Calling this method has the side effect of incrementing the color index. NextSymbol NextColorIndex
Declaration Syntax
C# Visual Basic Visual C++
public Color NextColor{ get;}
Public ReadOnly Property NextColor As Color
public:
property Color NextColor {
    Color get ();
}
See Also
NextSymbol
NextColorIndex


NextColorIndex Property

NextColorIndex Property
Namespaces ► ZedGraph ► ColorSymbolRotator ► NextColorIndex
Retrieves the index of the next color to be used. Calling this method has the side effect of incrementing the color index.
Declaration Syntax
C# Visual Basic Visual C++
public int NextColorIndex{ get; set;}
Public Property NextColorIndex As Integer
public:
property int NextColorIndex {
    int get ();
    void set (int value);
}


NextSymbol Property

NextSymbol Property
Namespaces ► ZedGraph ► ColorSymbolRotator ► NextSymbol
Retrieves the next color in the rotation. Calling this method has the side effect of incrementing the symbol index. NextColor NextSymbolIndex
Declaration Syntax
C# Visual Basic Visual C++
public SymbolType NextSymbol{ get;}
Public ReadOnly Property NextSymbol As SymbolType
public:
property SymbolType NextSymbol {
    SymbolType get ();
}
See Also
NextColor
NextSymbolIndex


NextSymbolIndex Property

NextSymbolIndex Property
Namespaces ► ZedGraph ► ColorSymbolRotator ► NextSymbolIndex
Retrieves the index of the next symbol to be used. Calling this method has the side effect of incrementing the symbol index.
Declaration Syntax
C# Visual Basic Visual C++
public int NextSymbolIndex{ get; set;}
Public Property NextSymbolIndex As Integer
public:
property int NextSymbolIndex {
    int get ();
    void set (int value);
}


StaticInstance Property

StaticInstance Property
Namespaces ► ZedGraph ► ColorSymbolRotator ► StaticInstance
Retrieves the ColorSymbolRotator instance used by the static methods. StaticNextColor StaticNextSymbol
Declaration Syntax
C# Visual Basic Visual C++
public static ColorSymbolRotator StaticInstance{ get;}
Public Shared ReadOnly Property StaticInstance As ColorSymbolRotator
public:
static property ColorSymbolRotator^ StaticInstance {
    ColorSymbolRotator^ get ();
}
See Also
StaticNextColor
StaticNextSymbol


StaticNextColor Property

StaticNextColor Property
Namespaces ► ZedGraph ► ColorSymbolRotator ► StaticNextColor
Retrieves the next color from this class's static ColorSymbolRotator instance StaticInstance StaticNextSymbol
Declaration Syntax
C# Visual Basic Visual C++
public static Color StaticNextColor{ get;}
Public Shared ReadOnly Property StaticNextColor As Color
public:
static property Color StaticNextColor {
    Color get ();
}
See Also
StaticInstance
StaticNextSymbol


StaticNextSymbol Property

StaticNextSymbol Property
Namespaces ► ZedGraph ► ColorSymbolRotator ► StaticNextSymbol
Retrieves the next symbol type from this class's static ColorSymbolRotator instance StaticInstance StaticNextColor
Declaration Syntax
C# Visual Basic Visual C++
public static SymbolType StaticNextSymbol{ get;}
Public Shared ReadOnly Property StaticNextSymbol As SymbolType
public:
static property SymbolType StaticNextSymbol {
    SymbolType get ();
}
See Also
StaticInstance
StaticNextColor


SYMBOLS Field

SYMBOLS Field
Namespaces ► ZedGraph ► ColorSymbolRotator ► SYMBOLS
The SymbolTypes ColorSymbolRotator rotates through.
Declaration Syntax
C# Visual Basic Visual C++
public static readonly SymbolType[] SYMBOLS
Public Shared ReadOnly SYMBOLS As SymbolType()
public:
static initonly array<SymbolType>^ SYMBOLS


CoordType Enumeration

CoordType Enumeration
Namespaces ► ZedGraph ► CoordType
Enumeration type for the user-defined coordinate types available. These coordinate types are used the ArrowObj objects and TextObj objects only.
Declaration Syntax
C# Visual Basic Visual C++
public enum CoordType
Public Enumeration CoordType
public enum class CoordType
Members
Member | Description
ChartFraction | Coordinates are specified as a fraction of the Rect. That is, for the X coordinate, 0.0 is at the left edge of the ChartRect and 1.0 is at the right edge of the ChartRect. A value less than zero is left of the ChartRect and a value greater than 1.0 is right of the ChartRect. For the Y coordinate, 0.0 is the top and 1.0 is the bottom.
PaneFraction | Coordinates are specified as a fraction of the Rect. That is, for the X coordinate, 0.0 is at the left edge of the Rect and 1.0 is at the right edge of the Rect. A value less than zero is left of the Rect and a value greater than 1.0 is right of the Rect. For the Y coordinate, 0.0 is the top and 1.0 is the bottom. Note that any value less than zero or greater than 1.0 will be outside the Rect, and therefore clipped.
AxisXYScale | Coordinates are specified according to the user axis scales for the XAxis and YAxis.
AxisXY2Scale | Coordinates are specified according to the user axis scales for the XAxis and Y2Axis.
XChartFractionYPaneFraction | The X coordinate is specified as a fraction of the Rect, and the Y coordinate is specified as a fraction of the Rect.
XPaneFractionYChartFraction | The X coordinate is specified as a fraction of the Rect, and the Y coordinate is specified as a fraction of the Rect.
XScaleYChartFraction | The X coordinate is specified as an X Scale value, and the Y coordinate is specified as a fraction of the Rect.
XChartFractionYScale | The X coordinate is specified as a fraction of the Rect and the Y coordinate is specified as a Y scale value.
XChartFractionY2Scale | The X coordinate is specified as a fraction of the Rect and the Y coordinate is specified as a Y2 scale value.
See Also
CoordinateFrame


CurveItem Class

CurveItem Class
Namespaces ► ZedGraph ► CurveItem
This class contains the data and methods for an individual curve within a graph pane. It carries the settings for the curve including the key and item names, colors, symbols and sizes, linetypes, etc.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class CurveItem : ISerializable,
    ICloneable
<SerializableAttribute> _
Public MustInherit Class CurveItem _
    Implements ISerializable, ICloneable
[SerializableAttribute]
public ref class CurveItem abstract : ISerializable,
    ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CurveItemCurveItemNew(String, array<Double>[](), array<Double>[]()) | CurveItem constructor the pre-specifies the curve label, the x and y data values as a IPointList, the curve type (Bar or Line/Symbol), the Color, and the SymbolType. Other properties of the curve are defaulted to the values in the GraphPane..::Default class.
 | CurveItemCurveItemNew(String, IPointList) | CurveItem constructor the pre-specifies the curve label, the x and y data values as a IPointList, the curve type (Bar or Line/Symbol), the Color, and the SymbolType. Other properties of the curve are defaulted to the values in the GraphPane..::Default class.
 | CurveItemCurveItemNew(String) | CurveItem constructor that specifies the label of the CurveItem. This is the same as CurveItem(label, null, null). CurveItemCurveItemNew(String, array<Double>[](), array<Double>[]())
 | CurveItemCurveItemNew()() |
 | CurveItemCurveItemNew(CurveItem) | The Copy Constructor
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve.
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve.
 | BaseAxis(GraphPane) | Returns a reference to the Axis object that is the "base" (independent axis) from which the values are drawn.
 | Clear()() | Clears the points from this CurveItem. This is the same as CurveItem.Points.Clear().
 | Color | The Line/Symbol/Bar color (FillColor for the Bar). This is a common access to Line.Color, Border.Color, and Fill.Color properties for this curve.
 | Draw(Graphics, GraphPane, Int32, Single) | Do all rendering associated with this CurveItem to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object.
 | DrawLegendKey(Graphics, GraphPane, RectangleF, Single) | Draw a legend key entry for this CurveItem at the specified location. This abstract base method passes through to DrawLegendKey(Graphics, GraphPane, RectangleF, Single) or DrawLegendKey(Graphics, GraphPane, RectangleF, Single) to do the rendering.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarWidth(GraphPane) | Calculate the width of each bar, depending on the actual bar type
 | GetCoords(GraphPane, Int32, String%) | Determine the coords for the rectangle associated with a specified point for this CurveItem
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetRange(Double%, Double%, Double%, Double%, Boolean, Boolean, GraphPane) | Go through the list of PointPair data values for this CurveItem and determine the minimum and maximum values in the data.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXAxis(GraphPane) | Get the X Axis instance (either XAxis or X2Axis) to which this CurveItem belongs.
 | GetYAxis(GraphPane) | Get the Y Axis instance (either YAxis or Y2Axis) to which this CurveItem belongs.
 | GetYAxisIndex(GraphPane) | Get the index of the Y Axis in the YAxis or Y2Axis list to which this CurveItem belongs.
 | IsBar | Determines whether this CurveItem is a BarItem. This does not include HiLowBarItem's or ErrorBarItem's.
 | IsLine | Determines whether this CurveItem is a LineItem.
 | IsOverrideOrdinal | Gets or sets a value which allows you to override the normal ordinal axis behavior.
 | IsPie | Determines whether this CurveItem is a PieItem.
 | IsSelectable | Determines whether this CurveItem can be selected in the graph.
 | IsSelected | Determines whether this CurveItem is selected on the graph. Note that this value changes the curve displayed color, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false.
 | IsVisible | Determines whether this CurveItem is visible on the graph. Note that this value turns the curve display on or off, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false.
 | IsX2Axis | Gets or sets a value that determines which X axis this CurveItem is assigned to.
 | IsY2Axis | Gets or sets a value that determines which Y axis this CurveItem is assigned to.
 | Item[([Int32])] | An accessor for the PointPair datum for this CurveItem. Index is the ordinal reference (zero based) of the point.
 | Label | A Label instance that represents the Legend entry for the this CurveItem object
 | Link | Gets or sets the hyperlink information for this CurveItem.
 | MakeUnique()() | Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NPts | Readonly property that gives the number of points that define this CurveItem object, which is the number of points in the Points data collection.
 | Points | The IPointList of X,Y point sets that represent this CurveItem.
 | RemovePoint(Int32) | Removes a single point from this CurveItem.
 | schema | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone.
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the CurveItem. ZedGraph does not use this value for any purpose.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValueAxis(GraphPane) | Returns a reference to the Axis object that is the "value" (dependent axis) from which the points are drawn.
 | YAxisIndex | Gets or sets the index number of the Y Axis to which this CurveItem belongs.
Inheritance Hierarchy
Object
 | CurveItem
 |  | GasGaugeNeedle
 |  | OHLCBarItem
 |  | LineItem
 |  | HiLowBarItem
 |  | PieItem
 |  | BarItem
 |  | GasGaugeRegion
 |  | JapaneseCandleStickItem
 |  | ErrorBarItem


CurveItem Constructor

CurveItem Constructor
Namespaces ► ZedGraph ► CurveItem ► CurveItemCurveItemNew()()
Members
Icon | Member | Description
 | CurveItemCurveItemNew(String, array<Double>[](), array<Double>[]()) | CurveItem constructor the pre-specifies the curve label, the x and y data values as a IPointList, the curve type (Bar or Line/Symbol), the Color, and the SymbolType. Other properties of the curve are defaulted to the values in the GraphPane..::Default class.
 | CurveItemCurveItemNew(String, IPointList) | CurveItem constructor the pre-specifies the curve label, the x and y data values as a IPointList, the curve type (Bar or Line/Symbol), the Color, and the SymbolType. Other properties of the curve are defaulted to the values in the GraphPane..::Default class.
 | CurveItemCurveItemNew(String) | CurveItem constructor that specifies the label of the CurveItem. This is the same as CurveItem(label, null, null). CurveItemCurveItemNew(String, array<Double>[](), array<Double>[]())
 | CurveItemCurveItemNew()() |
 | CurveItemCurveItemNew(CurveItem) | The Copy Constructor


CurveItem Constructor

CurveItem Constructor
Namespaces ► ZedGraph ► CurveItem ► CurveItemCurveItemNew()()
Declaration Syntax
C# Visual Basic Visual C++
public CurveItem()
Public Sub New
public:
CurveItem ()


CurveItem Constructor (label)

CurveItem Constructor (label)
Namespaces ► ZedGraph ► CurveItem ► CurveItemCurveItemNew(String)
CurveItem constructor that specifies the label of the CurveItem. This is the same as CurveItem(label, null, null). CurveItemCurveItemNew(String, array<Double>[](), array<Double>[]())
Declaration Syntax
C# Visual Basic Visual C++
public CurveItem(
    string label
)
Public Sub New ( _
    label As String _
)
public:
CurveItem (
    String^ label
)
Parameters
label (String)
A string label (legend entry) for this curve
See Also
CurveItemCurveItemNew(String, array<Double>[](), array<Double>[]())


CurveItem Constructor (label, x, y)

CurveItem Constructor (label, x, y)
Namespaces ► ZedGraph ► CurveItem ► CurveItemCurveItemNew(String, array<Double>[](), array<Double>[]())
CurveItem constructor the pre-specifies the curve label, the x and y data values as a IPointList, the curve type (Bar or Line/Symbol), the Color, and the SymbolType. Other properties of the curve are defaulted to the values in the GraphPane..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public CurveItem(
    string label,
    double[] x,
    double[] y
)
Public Sub New ( _
    label As String, _
    x As Double(), _
    y As Double() _
)
public:
CurveItem (
    String^ label,
    array<double>^ x,
    array<double>^ y
)
Parameters
label (String)
A string label (legend entry) for this curve
x (array< Double >[]())
An array of double precision values that define the independent (X axis) values for this curve
y (array< Double >[]())
An array of double precision values that define the dependent (Y axis) values for this curve


CurveItem Constructor (label, points)

CurveItem Constructor (label, points)
Namespaces ► ZedGraph ► CurveItem ► CurveItemCurveItemNew(String, IPointList)
CurveItem constructor the pre-specifies the curve label, the x and y data values as a IPointList, the curve type (Bar or Line/Symbol), the Color, and the SymbolType. Other properties of the curve are defaulted to the values in the GraphPane..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public CurveItem(
    string label,
    IPointList points
)
Public Sub New ( _
    label As String, _
    points As IPointList _
)
public:
CurveItem (
    String^ label,
    IPointList^ points
)
Parameters
label (String)
A string label (legend entry) for this curve
points (IPointList)
A IPointList of double precision value pairs that define the X and Y values for this curve


CurveItem Constructor (rhs)

CurveItem Constructor (rhs)
Namespaces ► ZedGraph ► CurveItem ► CurveItemCurveItemNew(CurveItem)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public CurveItem(
    CurveItem rhs
)
Public Sub New ( _
    rhs As CurveItem _
)
public:
CurveItem (
    CurveItem^ rhs
)
Parameters
rhs (CurveItem)
The CurveItem object from which to copy


AddPoint Method

AddPoint Method
Namespaces ► ZedGraph ► CurveItem ► AddPoint()()
Members
Icon | Member | Description
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve.
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve.


AddPoint Method (x, y)

AddPoint Method (x, y)
Namespaces ► ZedGraph ► CurveItem ► AddPoint(Double, Double)
Add a single x,y coordinate point to the end of the points collection for this curve.
Declaration Syntax
C# Visual Basic Visual C++
public void AddPoint(
    double x,
    double y
)
Public Sub AddPoint ( _
    x As Double, _
    y As Double _
)
public:
void AddPoint (
    double x,
    double y
)
Parameters
x (Double)
The X coordinate value
y (Double)
The Y coordinate value


AddPoint Method (point)

AddPoint Method (point)
Namespaces ► ZedGraph ► CurveItem ► AddPoint(PointPair)
Add a PointPair object to the end of the points collection for this curve.
Declaration Syntax
C# Visual Basic Visual C++
public void AddPoint(
    PointPair point
)
Public Sub AddPoint ( _
    point As PointPair _
)
public:
void AddPoint (
    PointPair^ point
)
Parameters
point (PointPair)
A reference to the PointPair object to be added
Remarks
This method will only work if the IPointList instance reference at Points supports the IPointListEdit interface. Otherwise, it does nothing.


BaseAxis Method (pane)

BaseAxis Method (pane)
Namespaces ► ZedGraph ► CurveItem ► BaseAxis(GraphPane)
Returns a reference to the Axis object that is the "base" (independent axis) from which the values are drawn.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Axis BaseAxis(
    GraphPane pane
)
Public Overridable Function BaseAxis ( _
    pane As GraphPane _
) As Axis
public:
virtual Axis^ BaseAxis (
    GraphPane^ pane
)
Parameters
pane (GraphPane)
Remarks
This property is determined by the value of Base for BarItem, ErrorBarItem, and HiLowBarItem types. It is always the X axis for regular LineItem types. Note that the Base setting can override the IsY2Axis and YAxisIndex settings for bar types (this is because all the bars that are clustered together must share the same base axis).
See Also
BarBase
ValueAxis(GraphPane)


Clear Method

Clear Method
Namespaces ► ZedGraph ► CurveItem ► Clear()()
Clears the points from this CurveItem. This is the same as CurveItem.Points.Clear().
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
void Clear ()
Remarks
This method will only work if the IPointList instance reference at Points supports the IPointListEdit interface. Otherwise, it does nothing.


Color Property

Color Property
Namespaces ► ZedGraph ► CurveItem ► Color
The Line/Symbol/Bar color (FillColor for the Bar). This is a common access to Line.Color, Border.Color, and Fill.Color properties for this curve.
Declaration Syntax
C# Visual Basic Visual C++
public Color Color{ get; set;}
Public Property Color As Color
public:
property Color Color {
    Color get ();
    void set (Color value);
}


Draw Method (g, pane, pos, scaleFactor)

Draw Method (g, pane, pos, scaleFactor)
Namespaces ► ZedGraph ► CurveItem ► Draw(Graphics, GraphPane, Int32, Single)
Do all rendering associated with this CurveItem to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object.
Declaration Syntax
C# Visual Basic Visual C++
public abstract void Draw(
    Graphics g,
    GraphPane pane,
    int pos,
    float scaleFactor
)
Public MustOverride Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    pos As Integer, _
    scaleFactor As Single _
)
public:
virtual void Draw (
    Graphics^ g,
    GraphPane^ pane,
    int pos,
    float scaleFactor
) abstract
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
pos (Int32)
The ordinal position of the current Bar curve.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


DrawLegendKey Method (g, pane, rect, scaleFactor)

DrawLegendKey Method (g, pane, rect, scaleFactor)
Namespaces ► ZedGraph ► CurveItem ► DrawLegendKey(Graphics, GraphPane, RectangleF, Single)
Draw a legend key entry for this CurveItem at the specified location. This abstract base method passes through to DrawLegendKey(Graphics, GraphPane, RectangleF, Single) or DrawLegendKey(Graphics, GraphPane, RectangleF, Single) to do the rendering.
Declaration Syntax
C# Visual Basic Visual C++
public abstract void DrawLegendKey(
    Graphics g,
    GraphPane pane,
    RectangleF rect,
    float scaleFactor
)
Public MustOverride Sub DrawLegendKey ( _
    g As Graphics, _
    pane As GraphPane, _
    rect As RectangleF, _
    scaleFactor As Single _
)
public:
virtual void DrawLegendKey (
    Graphics^ g,
    GraphPane^ pane,
    RectangleF rect,
    float scaleFactor
) abstract
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
rect (RectangleF)
The RectangleF struct that specifies the location for the legend key
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


GetBarWidth Method (pane)

GetBarWidth Method (pane)
Namespaces ► ZedGraph ► CurveItem ► GetBarWidth(GraphPane)
Calculate the width of each bar, depending on the actual bar type
Declaration Syntax
C# Visual Basic Visual C++
public float GetBarWidth(
    GraphPane pane
)
Public Function GetBarWidth ( _
    pane As GraphPane _
) As Single
public:
float GetBarWidth (
    GraphPane^ pane
)
Parameters
pane (GraphPane)
Return Value
The width for an individual bar, in pixel units


GetCoords Method (pane, i, coords)

GetCoords Method (pane, i, coords)
Namespaces ► ZedGraph ► CurveItem ► GetCoords(GraphPane, Int32, String%)
Determine the coords for the rectangle associated with a specified point for this CurveItem
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool GetCoords(
    GraphPane pane,
    int i,
    out string coords
)
Public MustOverride Function GetCoords ( _
    pane As GraphPane, _
    i As Integer, _
    <OutAttribute> ByRef coords As String _
) As Boolean
public:
virtual bool GetCoords (
    GraphPane^ pane,
    int i,
    [OutAttribute] String^% coords
) abstract
Parameters
pane (GraphPane)
The GraphPane to which this curve belongs
i (Int32)
The index of the point of interest
coords (String %)
A list of coordinates that represents the "rect" for this point (used in an html AREA tag)
Return Value
true if it's a valid point, false otherwise


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► CurveItem ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


GetRange Method (xMin, xMax, yMin, yMax, ignoreInitial, isBoundedRanges, pane)

GetRange Method (xMin, xMax, yMin, yMax, ignoreInitial, isBoundedRanges, pane)
Namespaces ► ZedGraph ► CurveItem ► GetRange(Double%, Double%, Double%, Double%, Boolean, Boolean, GraphPane)
Go through the list of PointPair data values for this CurveItem and determine the minimum and maximum values in the data.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetRange(
    out double xMin,
    out double xMax,
    out double yMin,
    out double yMax,
    bool ignoreInitial,
    bool isBoundedRanges,
    GraphPane pane
)
Public Overridable Sub GetRange ( _
    <OutAttribute> ByRef xMin As Double, _
    <OutAttribute> ByRef xMax As Double, _
    <OutAttribute> ByRef yMin As Double, _
    <OutAttribute> ByRef yMax As Double, _
    ignoreInitial As Boolean, _
    isBoundedRanges As Boolean, _
    pane As GraphPane _
)
public:
virtual void GetRange (
    [OutAttribute] double% xMin,
    [OutAttribute] double% xMax,
    [OutAttribute] double% yMin,
    [OutAttribute] double% yMax,
    bool ignoreInitial,
    bool isBoundedRanges,
    GraphPane^ pane
)
Parameters
xMin (Double %)
The minimum X value in the range of data
xMax (Double %)
The maximum X value in the range of data
yMin (Double %)
The minimum Y value in the range of data
yMax (Double %)
The maximum Y value in the range of data
ignoreInitial (Boolean)
ignoreInitial is a boolean value that affects the data range that is considered for the automatic scale ranging (see IsIgnoreInitial). If true, then initial data points where the Y value is zero are not included when automatically determining the scale Min, Max, and MajorStep size. All data after the first non-zero Y value are included.
isBoundedRanges (Boolean)
Determines if the auto-scaled axis ranges will subset the data points based on any manually set scale range values.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
See Also
IsBoundedRanges


GetXAxis Method (pane)

GetXAxis Method (pane)
Namespaces ► ZedGraph ► CurveItem ► GetXAxis(GraphPane)
Get the X Axis instance (either XAxis or X2Axis) to which this CurveItem belongs.
Declaration Syntax
C# Visual Basic Visual C++
public Axis GetXAxis(
    GraphPane pane
)
Public Function GetXAxis ( _
    pane As GraphPane _
) As Axis
public:
Axis^ GetXAxis (
    GraphPane^ pane
)
Parameters
pane (GraphPane)
The GraphPane object to which this curve belongs.
Return Value
Either a XAxis or X2Axis to which this CurveItem belongs.


GetYAxis Method (pane)

GetYAxis Method (pane)
Namespaces ► ZedGraph ► CurveItem ► GetYAxis(GraphPane)
Get the Y Axis instance (either YAxis or Y2Axis) to which this CurveItem belongs.
Declaration Syntax
C# Visual Basic Visual C++
public Axis GetYAxis(
    GraphPane pane
)
Public Function GetYAxis ( _
    pane As GraphPane _
) As Axis
public:
Axis^ GetYAxis (
    GraphPane^ pane
)
Parameters
pane (GraphPane)
The GraphPane object to which this curve belongs.
Return Value
Either a YAxis or Y2Axis to which this CurveItem belongs.
Remarks
This method safely retrieves a Y Axis instance from either the YAxisList or the Y2AxisList using the values of YAxisIndex and IsY2Axis. If the value of YAxisIndex is out of bounds, the default YAxis or Y2Axis is used.


GetYAxisIndex Method (pane)

GetYAxisIndex Method (pane)
Namespaces ► ZedGraph ► CurveItem ► GetYAxisIndex(GraphPane)
Get the index of the Y Axis in the YAxis or Y2Axis list to which this CurveItem belongs.
Declaration Syntax
C# Visual Basic Visual C++
public int GetYAxisIndex(
    GraphPane pane
)
Public Function GetYAxisIndex ( _
    pane As GraphPane _
) As Integer
public:
int GetYAxisIndex (
    GraphPane^ pane
)
Parameters
pane (GraphPane)
The GraphPane object to which this curve belongs.
Return Value
An integer value indicating which index position in the list applies to this CurveItem
Remarks
This method safely retrieves a Y Axis index into either the YAxisList or the Y2AxisList using the values of YAxisIndex and IsY2Axis. If the value of YAxisIndex is out of bounds, the default YAxis or Y2Axis is used, which is index zero.


IsBar Property

IsBar Property
Namespaces ► ZedGraph ► CurveItem ► IsBar
Determines whether this CurveItem is a BarItem. This does not include HiLowBarItem's or ErrorBarItem's.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsBar{ get;}
Public ReadOnly Property IsBar As Boolean
public:
property bool IsBar {
    bool get ();
}
Value
true for a bar chart, or false for a line or pie graph


IsLine Property

IsLine Property
Namespaces ► ZedGraph ► CurveItem ► IsLine
Determines whether this CurveItem is a LineItem.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLine{ get;}
Public ReadOnly Property IsLine As Boolean
public:
property bool IsLine {
    bool get ();
}
Value
true for a line chart, or false for a bar type


IsOverrideOrdinal Property

IsOverrideOrdinal Property
Namespaces ► ZedGraph ► CurveItem ► IsOverrideOrdinal
Gets or sets a value which allows you to override the normal ordinal axis behavior.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOverrideOrdinal{ get; set;}
Public Property IsOverrideOrdinal As Boolean
public:
property bool IsOverrideOrdinal {
    bool get ();
    void set (bool value);
}
Remarks
Normally for an ordinal axis type, the actual data values corresponding to the ordinal axis will be ignored (essentially they are replaced by ordinal values, e.g., 1, 2, 3, etc). If IsOverrideOrdinal is true, then the user data values will be used (even if they don't make sense). Fractional values are allowed, such that a value of 1.5 is between the first and second ordinal position, etc.
See Also
Ordinal
Text


IsPie Property

IsPie Property
Namespaces ► ZedGraph ► CurveItem ► IsPie
Determines whether this CurveItem is a PieItem.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPie{ get;}
Public ReadOnly Property IsPie As Boolean
public:
property bool IsPie {
    bool get ();
}
Value
true for a pie chart, or false for a line or bar graph


IsSelectable Property

IsSelectable Property
Namespaces ► ZedGraph ► CurveItem ► IsSelectable
Determines whether this CurveItem can be selected in the graph.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSelectable{ get; set;}
Public Property IsSelectable As Boolean
public:
property bool IsSelectable {
    bool get ();
    void set (bool value);
}


IsSelected Property

IsSelected Property
Namespaces ► ZedGraph ► CurveItem ► IsSelected
Determines whether this CurveItem is selected on the graph. Note that this value changes the curve displayed color, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSelected{ get; set;}
Public Property IsSelected As Boolean
public:
property bool IsSelected {
    bool get ();
    void set (bool value);
}


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph ► CurveItem ► IsVisible
Determines whether this CurveItem is visible on the graph. Note that this value turns the curve display on or off, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}


IsX2Axis Property

IsX2Axis Property
Namespaces ► ZedGraph ► CurveItem ► IsX2Axis
Gets or sets a value that determines which X axis this CurveItem is assigned to.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsX2Axis{ get; set;}
Public Property IsX2Axis As Boolean
public:
property bool IsX2Axis {
    bool get ();
    void set (bool value);
}
Value
true to assign the curve to the X2Axis, false to assign the curve to the XAxis
Remarks
The XAxis is on the bottom side of the graph and the X2Axis is on the top side. Assignment to an axis determines the scale that is used to draw the curve on the graph.


IsY2Axis Property

IsY2Axis Property
Namespaces ► ZedGraph ► CurveItem ► IsY2Axis
Gets or sets a value that determines which Y axis this CurveItem is assigned to.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsY2Axis{ get; set;}
Public Property IsY2Axis As Boolean
public:
property bool IsY2Axis {
    bool get ();
    void set (bool value);
}
Value
true to assign the curve to the Y2Axis, false to assign the curve to the YAxis
Remarks
The YAxis is on the left side of the graph and the Y2Axis is on the right side. Assignment to an axis determines the scale that is used to draw the curve on the graph. Note that this value is used in combination with the YAxisIndex to determine which of the Y Axes (if there are multiples) this curve belongs to.


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph ► CurveItem ► Item[([Int32])]
An accessor for the PointPair datum for this CurveItem. Index is the ordinal reference (zero based) of the point.
Declaration Syntax
C# Visual Basic Visual C++
public PointPair this[
    int index
]{ get;}
Public ReadOnly Default Property Item ( _
    index As Integer _
) As PointPair
public:
property PointPair^ default[int index] {
    PointPair^ get (int index);
}
Parameters
index (Int32)


Label Property

Label Property
Namespaces ► ZedGraph ► CurveItem ► Label
A Label instance that represents the Legend entry for the this CurveItem object
Declaration Syntax
C# Visual Basic Visual C++
public Label Label{ get; set;}
Public Property Label As Label
public:
property Label^ Label {
    Label^ get ();
    void set (Label^ value);
}


Link Property

Link Property
Namespaces ► ZedGraph ► CurveItem ► Link
Gets or sets the hyperlink information for this CurveItem.
Declaration Syntax
C# Visual Basic Visual C++
public Link Link{ get; set;}
Public Property Link As Link
public:
property Link^ Link {
    Link^ get ();
    void set (Link^ value);
}


MakeUnique Method

MakeUnique Method
Namespaces ► ZedGraph ► CurveItem ► MakeUnique()()
Members
Icon | Member | Description
 | MakeUnique()() | Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator)


MakeUnique Method

MakeUnique Method
Namespaces ► ZedGraph ► CurveItem ► MakeUnique()()
Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator)
Declaration Syntax
C# Visual Basic Visual C++
public void MakeUnique()
Public Sub MakeUnique
public:
void MakeUnique ()
See Also
StaticInstance
ColorSymbolRotator
MakeUnique(ColorSymbolRotator)


MakeUnique Method (rotator)

MakeUnique Method (rotator)
Namespaces ► ZedGraph ► CurveItem ► MakeUnique(ColorSymbolRotator)
Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator)
Declaration Syntax
C# Visual Basic Visual C++
public virtual void MakeUnique(
    ColorSymbolRotator rotator
)
Public Overridable Sub MakeUnique ( _
    rotator As ColorSymbolRotator _
)
public:
virtual void MakeUnique (
    ColorSymbolRotator^ rotator
)
Parameters
rotator (ColorSymbolRotator)
The ColorSymbolRotator that is used to pick the color and symbol for this method call.
See Also
MakeUnique(ColorSymbolRotator)


NPts Property

NPts Property
Namespaces ► ZedGraph ► CurveItem ► NPts
Readonly property that gives the number of points that define this CurveItem object, which is the number of points in the Points data collection.
Declaration Syntax
C# Visual Basic Visual C++
public int NPts{ get;}
Public ReadOnly Property NPts As Integer
public:
property int NPts {
    int get ();
}


Points Property

Points Property
Namespaces ► ZedGraph ► CurveItem ► Points
The IPointList of X,Y point sets that represent this CurveItem.
Declaration Syntax
C# Visual Basic Visual C++
public IPointList Points{ get; set;}
Public Property Points As IPointList
public:
property IPointList^ Points {
    IPointList^ get ();
    void set (IPointList^ value);
}


RemovePoint Method (index)

RemovePoint Method (index)
Namespaces ► ZedGraph ► CurveItem ► RemovePoint(Int32)
Removes a single point from this CurveItem.
Declaration Syntax
C# Visual Basic Visual C++
public void RemovePoint(
    int index
)
Public Sub RemovePoint ( _
    index As Integer _
)
public:
void RemovePoint (
    int index
)
Parameters
index (Int32)
The ordinal position of the point to be removed.
Remarks
This method will only work if the IPointList instance reference at Points supports the IPointListEdit interface. Otherwise, it does nothing.


schema Field

schema Field
Namespaces ► ZedGraph ► CurveItem ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► CurveItem ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone.
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object
Remarks
Note that this method must be called with an explicit cast to ICloneable, and that it is inherently virtual. For example:
CopyC#
ParentClass foo = new ChildClass();
ChildClass bar = (ChildClass) ((ICloneable)foo).Clone();
 Assume that ChildClass is inherited from ParentClass. Even though foo is declared with ParentClass, it is actually an instance of ChildClass. Calling the ICloneable implementation of Clone() on foo actually calls ChildClass.Clone() as if it were a virtual function.


Tag Field

Tag Field
Namespaces ► ZedGraph ► CurveItem ► Tag
A tag object for use by the user. This can be used to store additional information associated with the CurveItem. ZedGraph does not use this value for any purpose.
Declaration Syntax
C# Visual Basic Visual C++
public Object Tag
Public Tag As Object
public:
Object^ Tag
Remarks
Note that, if you are going to Serialize ZedGraph data, then any type that you store in Tag must be a serializable type (or it will cause an exception).


ValueAxis Method (pane)

ValueAxis Method (pane)
Namespaces ► ZedGraph ► CurveItem ► ValueAxis(GraphPane)
Returns a reference to the Axis object that is the "value" (dependent axis) from which the points are drawn.
Declaration Syntax
C# Visual Basic Visual C++
public virtual Axis ValueAxis(
    GraphPane pane
)
Public Overridable Function ValueAxis ( _
    pane As GraphPane _
) As Axis
public:
virtual Axis^ ValueAxis (
    GraphPane^ pane
)
Parameters
pane (GraphPane)
Remarks
This property is determined by the value of Base for BarItem, ErrorBarItem, and HiLowBarItem types. It is always the Y axis for regular LineItem types.
See Also
BarBase
BaseAxis(GraphPane)


YAxisIndex Property

YAxisIndex Property
Namespaces ► ZedGraph ► CurveItem ► YAxisIndex
Gets or sets the index number of the Y Axis to which this CurveItem belongs.
Declaration Syntax
C# Visual Basic Visual C++
public int YAxisIndex{ get; set;}
Public Property YAxisIndex As Integer
public:
property int YAxisIndex {
    int get ();
    void set (int value);
}
Remarks
This value is essentially an index number into the YAxisList or Y2AxisList, depending on the setting of IsY2Axis.


CurveItem.Comparer Class

CurveItem..::Comparer Class
Namespaces ► ZedGraph ► CurveItem ► CurveItem..::Comparer
Compares CurveItem's based on the point value at the specified index and for the specified axis. Sort()()
Declaration Syntax
C# Visual Basic Visual C++
public class Comparer : IComparer<CurveItem>
Public Class Comparer _
    Implements IComparer(Of CurveItem)
public ref class Comparer : IComparer<CurveItem^>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CurveItem..::ComparerCurveItem..::ComparerNew(SortType, Int32) | Constructor for Comparer.
 | Compare(CurveItem, CurveItem) | Compares two CurveItems using the previously specified index value and axis. Sorts in descending order.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CurveItem..::Comparer
See Also
Sort()()


CurveItem.Comparer Constructor (type, index)

CurveItem..::Comparer Constructor (type, index)
Namespaces ► ZedGraph ► CurveItem..::Comparer ► CurveItem..::ComparerCurveItem..::ComparerNew(SortType, Int32)
Constructor for Comparer.
Declaration Syntax
C# Visual Basic Visual C++
public Comparer(
    SortType type,
    int index
)
Public Sub New ( _
    type As SortType, _
    index As Integer _
)
public:
Comparer (
    SortType type,
    int index
)
Parameters
type (SortType)
The axis type on which to sort.
index (Int32)
The index number of the point on which to sort


Compare Method (l, r)

Compare Method (l, r)
Namespaces ► ZedGraph ► CurveItem..::Comparer ► Compare(CurveItem, CurveItem)
Compares two CurveItems using the previously specified index value and axis. Sorts in descending order.
Declaration Syntax
C# Visual Basic Visual C++
public int Compare(
    CurveItem l,
    CurveItem r
)
Public Function Compare ( _
    l As CurveItem, _
    r As CurveItem _
) As Integer
public:
virtual int Compare (
    CurveItem^ l,
    CurveItem^ r
) sealed
Parameters
l (CurveItem)
Curve to the left.
r (CurveItem)
Curve to the right.
Return Value
-1, 0, or 1 depending on l.X's relation to r.X


CurveList Class

CurveList Class
Namespaces ► ZedGraph ► CurveList
A collection class containing a list of CurveItem objects that define the set of curves to be displayed on the graph.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CurveList : List<CurveItem>, ICloneable
<SerializableAttribute> _
Public Class CurveList _
    Inherits List(Of CurveItem) _
    Implements ICloneable
[SerializableAttribute]
public ref class CurveList : public List<CurveItem^>,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CurveListCurveListNew()() | Default constructor for the collection class
 | CurveListCurveListNew(CurveList) | The Copy Constructor
 | Add(T) | Adds an object to the end of the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | AddRange(IEnumerable<(Of <T>)>) | Adds the elements of the specified collection to the end of the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | AsReadOnly()() | Returns a read-only IList<(Of <T>)> wrapper for the current collection. (Inherited from List <(Of < CurveItem >)>.)
 | Backward | Iterate backwards through the CurveList items.
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < CurveItem >)>.)
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of < CurveItem >)>.)
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < CurveItem >)>.)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of < CurveItem >)>.)
 | Clear()() | Removes all elements from the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Contains(T) | Determines whether an element is in the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | ConvertAll<(Of <TOutput>)>(Converter<(Of <T, TOutput>)>) | Converts the elements in the current List<(Of <T>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of < CurveItem >)>.)
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of < CurveItem >)>.)
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < CurveItem >)>.)
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < CurveItem >)>.)
 | Count | Gets the number of elements actually contained in the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | Draw(Graphics, GraphPane, Single) | Render all the CurveItem objects in the list to the specified Graphics device by calling the Draw(Graphics, GraphPane, Int32, Single) member function of each CurveItem object.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <T>)>) | Determines whether the List<(Of <T>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < CurveItem >)>.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | FindAll(Predicate<(Of <T>)>) | Retrieves the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < CurveItem >)>.)
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < CurveItem >)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < CurveItem >)>.)
 | FindLast(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < CurveItem >)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < CurveItem >)>.)
 | ForEach(Action<(Of <T>)>) | Performs the specified action on each element of the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | Forward | Iterate forward through the CurveList items.
 | GetBarItemPos(GraphPane, BarItem) | Find the ordinal position of the specified BarItem within the CurveList. This position only counts types, ignoring all other types.
 | GetEnumerator()() | Returns an enumerator that iterates through the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetRange(Boolean, Boolean, GraphPane) | Go through each CurveItem object in the collection, calling the GetRange(Double%, Double%, Double%, Double%, Boolean, Boolean, GraphPane) member to determine the minimum and maximum values in the Points list of data value pairs. If the curves include a stack bar, handle within the current GetRange method. In the event that no data are available, a default range of min=0.0 and max=1.0 are returned. If the Y axis has a valid data range and the Y2 axis not, then the Y2 range will be a duplicate of the Y range. Vice-versa for the Y2 axis having valid data when the Y axis does not. If any CurveItem in the list has a missing PointPairList, a new empty one will be generated.
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasData()() | Determine if there is any data in any of the CurveItem objects for this graph. This method does not verify valid data, it only checks to see if NPts > 0.
 | IndexOf(String) | Return the zero-based position index of the CurveItem with the specified Label.
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < CurveItem >)>.)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < CurveItem >)>.)
 | IndexOfTag(String) | Return the zero-based position index of the CurveItem with the specified Tag.
 | Insert(Int32, T) | Inserts an element into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < CurveItem >)>.)
 | InsertRange(Int32, IEnumerable<(Of <T>)>) | Inserts the elements of a collection into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < CurveItem >)>.)
 | IsPieOnly | Read only property that determines if all items in the CurveList are Pies.
 | Item[([String])] | Indexer to access the specified CurveItem object by its Label string.
 | Item[([Int32])] | Gets or sets the element at the specified index. (Inherited from List <(Of < CurveItem >)>.)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < CurveItem >)>.)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < CurveItem >)>.)
 | MaxPts | Read only value for the maximum number of points in any of the curves in the list.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Move(Int32, Int32) | Move the position of the object at the specified index to the new relative position in the list.
 | NumBars | Read only property that returns the number of curves in the list that are of type Bar.
 | NumPies | Read only property that returns the number of pie slices in the list (class type is PieItem ).
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | RemoveAll(Predicate<(Of <T>)>) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < CurveItem >)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of < CurveItem >)>.)
 | Sort(SortType, Int32) | Sorts the list according to the point values at the specified index and for the specified axis.
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < CurveItem >)>.)
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < CurveItem >)>.)
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | ICollection<(Of <T>)>..::IsReadOnly | (Inherited from List <(Of < CurveItem >)>.)
 | IEnumerable<(Of <T>)>..::GetEnumerator()() | (Inherited from List <(Of < CurveItem >)>.)
 | ICollection..::CopyTo(Array, Int32) | (Inherited from List <(Of < CurveItem >)>.)
 | ICollection..::IsSynchronized | (Inherited from List <(Of < CurveItem >)>.)
 | ICollection..::SyncRoot | (Inherited from List <(Of < CurveItem >)>.)
 | IEnumerable..::GetEnumerator()() | (Inherited from List <(Of < CurveItem >)>.)
 | IList..::Add(Object) | (Inherited from List <(Of < CurveItem >)>.)
 | IList..::Contains(Object) | (Inherited from List <(Of < CurveItem >)>.)
 | IList..::IndexOf(Object) | (Inherited from List <(Of < CurveItem >)>.)
 | IList..::Insert(Int32, Object) | (Inherited from List <(Of < CurveItem >)>.)
 | IList..::IsFixedSize | (Inherited from List <(Of < CurveItem >)>.)
 | IList..::IsReadOnly | (Inherited from List <(Of < CurveItem >)>.)
 | IList..::Item[([Int32])] | (Inherited from List <(Of < CurveItem >)>.)
 | IList..::Remove(Object) | (Inherited from List <(Of < CurveItem >)>.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToArray()() | Copies the elements of the List<(Of <T>)> to a new array. (Inherited from List <(Of < CurveItem >)>.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()() | Sets the capacity to the actual number of elements in the List<(Of <T>)>, if that number is less than a threshold value. (Inherited from List <(Of < CurveItem >)>.)
 | TrueForAll(Predicate<(Of <T>)>) | Determines whether every element in the List<(Of <T>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of < CurveItem >)>.)
Inheritance Hierarchy
Object
 | List <(Of < CurveItem >)>
 |  | CurveList
 |  |  | Selection


CurveList Constructor

CurveList Constructor
Namespaces ► ZedGraph ► CurveList ► CurveListCurveListNew()()
Members
Icon | Member | Description
 | CurveListCurveListNew()() | Default constructor for the collection class
 | CurveListCurveListNew(CurveList) | The Copy Constructor


CurveList Constructor

CurveList Constructor
Namespaces ► ZedGraph ► CurveList ► CurveListCurveListNew()()
Default constructor for the collection class
Declaration Syntax
C# Visual Basic Visual C++
public CurveList()
Public Sub New
public:
CurveList ()


CurveList Constructor (rhs)

CurveList Constructor (rhs)
Namespaces ► ZedGraph ► CurveList ► CurveListCurveListNew(CurveList)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public CurveList(
    CurveList rhs
)
Public Sub New ( _
    rhs As CurveList _
)
public:
CurveList (
    CurveList^ rhs
)
Parameters
rhs (CurveList)
The XAxis object from which to copy


Backward Property

Backward Property
Namespaces ► ZedGraph ► CurveList ► Backward
Iterate backwards through the CurveList items.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<CurveItem> Backward{ get;}
Public ReadOnly Property Backward As IEnumerable(Of CurveItem)
public:
property IEnumerable<CurveItem^>^ Backward {
    IEnumerable<CurveItem^>^ get ();
}


Clone Method

Clone Method
Namespaces ► ZedGraph ► CurveList ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public CurveList Clone()
Public Function Clone As CurveList
public:
CurveList^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, scaleFactor)

Draw Method (g, pane, scaleFactor)
Namespaces ► ZedGraph ► CurveList ► Draw(Graphics, GraphPane, Single)
Render all the CurveItem objects in the list to the specified Graphics device by calling the Draw(Graphics, GraphPane, Int32, Single) member function of each CurveItem object.
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    GraphPane pane,
    float scaleFactor
)
Public Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    scaleFactor As Single _
)
public:
void Draw (
    Graphics^ g,
    GraphPane^ pane,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


Forward Property

Forward Property
Namespaces ► ZedGraph ► CurveList ► Forward
Iterate forward through the CurveList items.
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<CurveItem> Forward{ get;}
Public ReadOnly Property Forward As IEnumerable(Of CurveItem)
public:
property IEnumerable<CurveItem^>^ Forward {
    IEnumerable<CurveItem^>^ get ();
}


GetBarItemPos Method (pane, barItem)

GetBarItemPos Method (pane, barItem)
Namespaces ► ZedGraph ► CurveList ► GetBarItemPos(GraphPane, BarItem)
Find the ordinal position of the specified BarItem within the CurveList. This position only counts types, ignoring all other types.
Declaration Syntax
C# Visual Basic Visual C++
public int GetBarItemPos(
    GraphPane pane,
    BarItem barItem
)
Public Function GetBarItemPos ( _
    pane As GraphPane, _
    barItem As BarItem _
) As Integer
public:
int GetBarItemPos (
    GraphPane^ pane,
    BarItem^ barItem
)
Parameters
pane (GraphPane)
The GraphPane of interest
barItem (BarItem)
The BarItem for which to search.
Return Value
The ordinal position of the specified bar, or -1 if the bar was not found.


GetRange Method (bIgnoreInitial, isBoundedRanges, pane)

GetRange Method (bIgnoreInitial, isBoundedRanges, pane)
Namespaces ► ZedGraph ► CurveList ► GetRange(Boolean, Boolean, GraphPane)
Go through each CurveItem object in the collection, calling the GetRange(Double%, Double%, Double%, Double%, Boolean, Boolean, GraphPane) member to determine the minimum and maximum values in the Points list of data value pairs. If the curves include a stack bar, handle within the current GetRange method. In the event that no data are available, a default range of min=0.0 and max=1.0 are returned. If the Y axis has a valid data range and the Y2 axis not, then the Y2 range will be a duplicate of the Y range. Vice-versa for the Y2 axis having valid data when the Y axis does not. If any CurveItem in the list has a missing PointPairList, a new empty one will be generated.
Declaration Syntax
C# Visual Basic Visual C++
public void GetRange(
    bool bIgnoreInitial,
    bool isBoundedRanges,
    GraphPane pane
)
Public Sub GetRange ( _
    bIgnoreInitial As Boolean, _
    isBoundedRanges As Boolean, _
    pane As GraphPane _
)
public:
void GetRange (
    bool bIgnoreInitial,
    bool isBoundedRanges,
    GraphPane^ pane
)
Parameters
bIgnoreInitial (Boolean)
ignoreInitial is a boolean value that affects the data range that is considered for the automatic scale ranging (see IsIgnoreInitial). If true, then initial data points where the Y value is zero are not included when automatically determining the scale Min, Max, and MajorStep size. All data after the first non-zero Y value are included.
isBoundedRanges (Boolean)
Determines if the auto-scaled axis ranges will subset the data points based on any manually set scale range values.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
See Also
IsBoundedRanges


HasData Method

HasData Method
Namespaces ► ZedGraph ► CurveList ► HasData()()
Determine if there is any data in any of the CurveItem objects for this graph. This method does not verify valid data, it only checks to see if NPts > 0.
Declaration Syntax
C# Visual Basic Visual C++
public bool HasData()
Public Function HasData As Boolean
public:
bool HasData ()
Return Value
true if there is any data, false otherwise


IndexOf Method (label)

IndexOf Method (label)
Namespaces ► ZedGraph ► CurveList ► IndexOf(String)
Return the zero-based position index of the CurveItem with the specified Label.
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    string label
)
Public Function IndexOf ( _
    label As String _
) As Integer
public:
int IndexOf (
    String^ label
)
Parameters
label (String)
The String label that is in the Label attribute of the item to be found.
Return Value
The zero-based index of the specified CurveItem, or -1 if the CurveItem is not in the list
See Also
IndexOfTag(String)


IndexOfTag Method (tag)

IndexOfTag Method (tag)
Namespaces ► ZedGraph ► CurveList ► IndexOfTag(String)
Return the zero-based position index of the CurveItem with the specified Tag.
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOfTag(
    string tag
)
Public Function IndexOfTag ( _
    tag As String _
) As Integer
public:
int IndexOfTag (
    String^ tag
)
Parameters
tag (String)
The String tag that is in the Tag attribute of the item to be found.
Return Value
The zero-based index of the specified CurveItem, or -1 if the CurveItem is not in the list
Remarks
In order for this method to work, the Tag property must be of type String.


IsPieOnly Property

IsPieOnly Property
Namespaces ► ZedGraph ► CurveList ► IsPieOnly
Read only property that determines if all items in the CurveList are Pies.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPieOnly{ get;}
Public ReadOnly Property IsPieOnly As Boolean
public:
property bool IsPieOnly {
    bool get ();
}


Item Property (label)

Item Property (label)
Namespaces ► ZedGraph ► CurveList ► Item[([String])]
Indexer to access the specified CurveItem object by its Label string.
Declaration Syntax
C# Visual Basic Visual C++
public CurveItem this[
    string label
]{ get;}
Public ReadOnly Default Property Item ( _
    label As String _
) As CurveItem
public:
property CurveItem^ default[String^ label] {
    CurveItem^ get (String^ label);
}
Parameters
label (String)
The string label of the CurveItem object to be accessed.
Value
A CurveItem object reference.


MaxPts Property

MaxPts Property
Namespaces ► ZedGraph ► CurveList ► MaxPts
Read only value for the maximum number of points in any of the curves in the list.
Declaration Syntax
C# Visual Basic Visual C++
public int MaxPts{ get;}
Public ReadOnly Property MaxPts As Integer
public:
property int MaxPts {
    int get ();
}


Move Method (index, relativePos)

Move Method (index, relativePos)
Namespaces ► ZedGraph ► CurveList ► Move(Int32, Int32)
Move the position of the object at the specified index to the new relative position in the list.
Declaration Syntax
C# Visual Basic Visual C++
public int Move(
    int index,
    int relativePos
)
Public Function Move ( _
    index As Integer, _
    relativePos As Integer _
) As Integer
public:
int Move (
    int index,
    int relativePos
)
Parameters
index (Int32)
The zero-based index of the object to be moved.
relativePos (Int32)
The relative number of positions to move the object. A value of -1 will move the object one position earlier in the list, a value of 1 will move it one position later. To move an item to the beginning of the list, use a large negative value (such as -999). To move it to the end of the list, use a large positive value.
Return Value
The new position for the object, or -1 if the object was not found.
Remarks
For Graphic type objects, this method controls the Z-Order of the items. Objects at the beginning of the list appear in front of objects at the end of the list.


NumBars Property

NumBars Property
Namespaces ► ZedGraph ► CurveList ► NumBars
Read only property that returns the number of curves in the list that are of type Bar.
Declaration Syntax
C# Visual Basic Visual C++
public int NumBars{ get;}
Public ReadOnly Property NumBars As Integer
public:
property int NumBars {
    int get ();
}


NumPies Property

NumPies Property
Namespaces ► ZedGraph ► CurveList ► NumPies
Read only property that returns the number of pie slices in the list (class type is PieItem ).
Declaration Syntax
C# Visual Basic Visual C++
public int NumPies{ get;}
Public ReadOnly Property NumPies As Integer
public:
property int NumPies {
    int get ();
}


Sort Method (type, index)

Sort Method (type, index)
Namespaces ► ZedGraph ► CurveList ► Sort(SortType, Int32)
Sorts the list according to the point values at the specified index and for the specified axis.
Declaration Syntax
C# Visual Basic Visual C++
public void Sort(
    SortType type,
    int index
)
Public Sub Sort ( _
    type As SortType, _
    index As Integer _
)
public:
void Sort (
    SortType type,
    int index
)
Parameters
type (SortType)
index (Int32)


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► CurveList ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


DataPoint Structure

DataPoint Structure
Namespaces ► ZedGraph ► DataPoint
A simple storage struct to maintain an individual sampling of data. This only contains two data values in order to reduce to memory load for large datasets. (e.g., no Tag or Z property)
Declaration Syntax
C# Visual Basic Visual C++
public struct DataPoint
Public Structure DataPoint
public value class DataPoint
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | X | The X value for the point, stored as a double type.
 | Y | The Y value for the point, stored as a double type.


X Field

X Field
Namespaces ► ZedGraph ► DataPoint ► X
The X value for the point, stored as a double type.
Declaration Syntax
C# Visual Basic Visual C++
public double X
Public X As Double
public:
double X


Y Field

Y Field
Namespaces ► ZedGraph ► DataPoint ► Y
The Y value for the point, stored as a double type.
Declaration Syntax
C# Visual Basic Visual C++
public double Y
Public Y As Double
public:
double Y


DataSourcePointList Class

DataSourcePointList Class
Namespaces ► ZedGraph ► DataSourcePointList
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DataSourcePointList : IPointList,
    ICloneable
<SerializableAttribute> _
Public Class DataSourcePointList _
    Implements IPointList, ICloneable
[SerializableAttribute]
public ref class DataSourcePointList : IPointList,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DataSourcePointListDataSourcePointListNew()() | Default Constructor
 | DataSourcePointListDataSourcePointListNew(DataSourcePointList) | Constructor to initialize the DataSourcePointList from an existing DataSourcePointList
 | BindingSource | The BindingSource object from which to get the bound data
 | Clone()() | Typesafe, deep-copy clone method.
 | Count | gets the number of points available in the list
 | DataSource | The table or list object from which to extract the data values.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([Int32])] | Indexer to access the specified PointPair object by its ordinal position in the list.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | TagDataMember | The String name of the property or column from which to obtain the tag values for the chart.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | XDataMember | The String name of the property or column from which to obtain the X data values for the chart.
 | YDataMember | The String name of the property or column from which to obtain the Y data values for the chart.
 | ZDataMember | The String name of the property or column from which to obtain the Z data values for the chart.
Inheritance Hierarchy
Object
DataSourcePointList
See Also
IPointList
IPointListEdit


DataSourcePointList Constructor

DataSourcePointList Constructor
Namespaces ► ZedGraph ► DataSourcePointList ► DataSourcePointListDataSourcePointListNew()()
Members
Icon | Member | Description
 | DataSourcePointListDataSourcePointListNew()() | Default Constructor
 | DataSourcePointListDataSourcePointListNew(DataSourcePointList) | Constructor to initialize the DataSourcePointList from an existing DataSourcePointList


DataSourcePointList Constructor

DataSourcePointList Constructor
Namespaces ► ZedGraph ► DataSourcePointList ► DataSourcePointListDataSourcePointListNew()()
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public DataSourcePointList()
Public Sub New
public:
DataSourcePointList ()


DataSourcePointList Constructor (rhs)

DataSourcePointList Constructor (rhs)
Namespaces ► ZedGraph ► DataSourcePointList ► DataSourcePointListDataSourcePointListNew(DataSourcePointList)
Constructor to initialize the DataSourcePointList from an existing DataSourcePointList
Declaration Syntax
C# Visual Basic Visual C++
public DataSourcePointList(
    DataSourcePointList rhs
)
Public Sub New ( _
    rhs As DataSourcePointList _
)
public:
DataSourcePointList (
    DataSourcePointList^ rhs
)
Parameters
rhs (DataSourcePointList)


BindingSource Property

BindingSource Property
Namespaces ► ZedGraph ► DataSourcePointList ► BindingSource
The BindingSource object from which to get the bound data
Declaration Syntax
C# Visual Basic Visual C++
public Object BindingSource{ get;}
Public ReadOnly Property BindingSource As Object
public:
property Object^ BindingSource {
    Object^ get ();
}
Remarks
Typically, you set the DataSource property to a reference to your database, table or list object. The DataMember property would be set to the name of the datatable within the DataSource, if applicable.


Clone Method

Clone Method
Namespaces ► ZedGraph ► DataSourcePointList ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public DataSourcePointList Clone()
Public Function Clone As DataSourcePointList
public:
DataSourcePointList^ Clone ()
Return Value
A new, independent copy of this class


Count Property

Count Property
Namespaces ► ZedGraph ► DataSourcePointList ► Count
gets the number of points available in the list
Declaration Syntax
C# Visual Basic Visual C++
public int Count{ get;}
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}


DataSource Property

DataSource Property
Namespaces ► ZedGraph ► DataSourcePointList ► DataSource
The table or list object from which to extract the data values.
Declaration Syntax
C# Visual Basic Visual C++
public Object DataSource{ get; set;}
Public Property DataSource As Object
public:
property Object^ DataSource {
    Object^ get ();
    void set (Object^ value);
}
Remarks
This property is just an alias for DataSource.


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph ► DataSourcePointList ► Item[([Int32])]
Indexer to access the specified PointPair object by its ordinal position in the list.
Declaration Syntax
C# Visual Basic Visual C++
public PointPair this[
    int index
]{ get;}
Public ReadOnly Default Property Item ( _
    index As Integer _
) As PointPair
public:
virtual property PointPair^ default[int index] {
    PointPair^ get (int index) sealed;
}
Parameters
index (Int32)
The ordinal position (zero-based) of the PointPair object to be accessed.
Value
A PointPair object reference.


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► DataSourcePointList ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


TagDataMember Property

TagDataMember Property
Namespaces ► ZedGraph ► DataSourcePointList ► TagDataMember
The String name of the property or column from which to obtain the tag values for the chart.
Declaration Syntax
C# Visual Basic Visual C++
public string TagDataMember{ get; set;}
Public Property TagDataMember As String
public:
property String^ TagDataMember {
    String^ get ();
    void set (String^ value);
}
Remarks
Set this to null leave the tag values set to null. If this references string data, then the tags may be used as tooltips using the IsShowPointValues option.


XDataMember Property

XDataMember Property
Namespaces ► ZedGraph ► DataSourcePointList ► XDataMember
The String name of the property or column from which to obtain the X data values for the chart.
Declaration Syntax
C# Visual Basic Visual C++
public string XDataMember{ get; set;}
Public Property XDataMember As String
public:
property String^ XDataMember {
    String^ get ();
    void set (String^ value);
}
Remarks
Set this to null leave the X data values set to Missing


YDataMember Property

YDataMember Property
Namespaces ► ZedGraph ► DataSourcePointList ► YDataMember
The String name of the property or column from which to obtain the Y data values for the chart.
Declaration Syntax
C# Visual Basic Visual C++
public string YDataMember{ get; set;}
Public Property YDataMember As String
public:
property String^ YDataMember {
    String^ get ();
    void set (String^ value);
}
Remarks
Set this to null leave the Y data values set to Missing


ZDataMember Property

ZDataMember Property
Namespaces ► ZedGraph ► DataSourcePointList ► ZDataMember
The String name of the property or column from which to obtain the Z data values for the chart.
Declaration Syntax
C# Visual Basic Visual C++
public string ZDataMember{ get; set;}
Public Property ZDataMember As String
public:
property String^ ZDataMember {
    String^ get ();
    void set (String^ value);
}
Remarks
Set this to null leave the Z data values set to Missing


DateUnit Enumeration

DateUnit Enumeration
Namespaces ► ZedGraph ► DateUnit
Enumeration type for the various axis date and time unit types that are available
Declaration Syntax
C# Visual Basic Visual C++
public enum DateUnit
Public Enumeration DateUnit
public enum class DateUnit
Members
Member | Description
Year | Yearly units MajorUnit and MinorUnit
Month | Monthly units MajorUnit and MinorUnit
Day | Daily units MajorUnit and MinorUnit
Hour | Hourly units MajorUnit and MinorUnit
Minute | Minute units MajorUnit and MinorUnit
Second | Second units MajorUnit and MinorUnit
Millisecond | Millisecond units MajorUnit and MinorUnit


EllipseObj Class

EllipseObj Class
Namespaces ► ZedGraph ► EllipseObj
A class that represents a bordered and/or filled ellipse object on the graph. A list of EllipseObj objects is maintained by the GraphObjList collection class. The ellipse is defined as the ellipse that would be contained by the rectangular box as defined by the Location property.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class EllipseObj : BoxObj, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class EllipseObj _
    Inherits BoxObj _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class EllipseObj : public BoxObj,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EllipseObjEllipseObjNew(Double, Double, Double, Double) | A constructor that allows the position and size of the EllipseObj to be pre-specified. Other properties are defaulted.
 | EllipseObjEllipseObjNew()() | A default constructor that places the EllipseObj at location (0,0), with width/height of (1,1). Other properties are defaulted.
 | EllipseObjEllipseObjNew(Double, Double, Double, Double, Color, Color) | A constructor that allows the position, border color, and solid fill color of the EllipseObj to be pre-specified.
 | EllipseObjEllipseObjNew(Double, Double, Double, Double, Color, Color, Color) | A constructor that allows the position, border color, and two-color gradient fill colors of the EllipseObj to be pre-specified.
 | EllipseObjEllipseObjNew(BoxObj) | The Copy Constructor
 | Border | Gets or sets the Border object, which determines the properties of the border around this BoxObj (Inherited from BoxObj.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Draw(Graphics, PaneBase, Single) | Render this object to the specified Graphics device. (Overrides BoxObj.Draw(Graphics, PaneBase, Single).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Gets or sets the Fill data for this BoxObj. (Inherited from BoxObj.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCoords(PaneBase, Graphics, Single, String%, String%) | Determines the shape type and Coords values for this GraphObj (Inherited from BoxObj.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides BoxObj.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsClippedToChartRect | Gets or sets a value that determines whether or not the rendering of this GraphObj will be clipped to the Rect. (Inherited from GraphObj.)
 | IsInFrontOfData | true if the ZOrder of this object is set to put it in front of the CurveItem data points. (Inherited from GraphObj.)
 | IsVisible | Gets or sets a value that determines if this GraphObj will be visible in the graph. true displays the item, false hides it. (Inherited from GraphObj.)
 | Link | Gets or sets the hyperlink information for this GraphObj. (Inherited from GraphObj.)
 | Location | The Location struct that describes the location for this GraphObj. (Inherited from GraphObj.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PointInBox(PointF, PaneBase, Graphics, Single) | Determine if the specified screen point lies inside the bounding box of this BoxObj. (Overrides BoxObj.PointInBox(PointF, PaneBase, Graphics, Single).)
 | schema3 | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the GraphObj. ZedGraph does not use this value for any purpose. (Inherited from GraphObj.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ZOrder | Gets or sets a value that determines the z-order "depth" of this item relative to other graphic objects. (Inherited from GraphObj.)
Inheritance Hierarchy
Object
 | GraphObj
 |  | BoxObj
 |  |  | EllipseObj


EllipseObj Constructor

EllipseObj Constructor
Namespaces ► ZedGraph ► EllipseObj ► EllipseObjEllipseObjNew()()
Constructors for the EllipseObj object
Members
Icon | Member | Description
 | EllipseObjEllipseObjNew(Double, Double, Double, Double) | A constructor that allows the position and size of the EllipseObj to be pre-specified. Other properties are defaulted.
 | EllipseObjEllipseObjNew()() | A default constructor that places the EllipseObj at location (0,0), with width/height of (1,1). Other properties are defaulted.
 | EllipseObjEllipseObjNew(Double, Double, Double, Double, Color, Color) | A constructor that allows the position, border color, and solid fill color of the EllipseObj to be pre-specified.
 | EllipseObjEllipseObjNew(Double, Double, Double, Double, Color, Color, Color) | A constructor that allows the position, border color, and two-color gradient fill colors of the EllipseObj to be pre-specified.
 | EllipseObjEllipseObjNew(BoxObj) | The Copy Constructor


EllipseObj Constructor

EllipseObj Constructor
Namespaces ► ZedGraph ► EllipseObj ► EllipseObjEllipseObjNew()()
A default constructor that places the EllipseObj at location (0,0), with width/height of (1,1). Other properties are defaulted.
Declaration Syntax
C# Visual Basic Visual C++
public EllipseObj()
Public Sub New
public:
EllipseObj ()


EllipseObj Constructor (x, y, width, height)

EllipseObj Constructor (x, y, width, height)
Namespaces ► ZedGraph ► EllipseObj ► EllipseObjEllipseObjNew(Double, Double, Double, Double)
A constructor that allows the position and size of the EllipseObj to be pre-specified. Other properties are defaulted.
Declaration Syntax
C# Visual Basic Visual C++
public EllipseObj(
    double x,
    double y,
    double width,
    double height
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double _
)
public:
EllipseObj (
    double x,
    double y,
    double width,
    double height
)
Parameters
x (Double)
The x location for this BoxObj. This will be in units determined by CoordinateFrame.
y (Double)
The y location for this BoxObj. This will be in units determined by CoordinateFrame.
width (Double)
The width of this BoxObj. This will be in units determined by CoordinateFrame.
height (Double)
The height of this BoxObj. This will be in units determined by CoordinateFrame.


EllipseObj Constructor (x, y, width, height, borderColor, fillColor)

EllipseObj Constructor (x, y, width, height, borderColor, fillColor)
Namespaces ► ZedGraph ► EllipseObj ► EllipseObjEllipseObjNew(Double, Double, Double, Double, Color, Color)
A constructor that allows the position, border color, and solid fill color of the EllipseObj to be pre-specified.
Declaration Syntax
C# Visual Basic Visual C++
public EllipseObj(
    double x,
    double y,
    double width,
    double height,
    Color borderColor,
    Color fillColor
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    borderColor As Color, _
    fillColor As Color _
)
public:
EllipseObj (
    double x,
    double y,
    double width,
    double height,
    Color borderColor,
    Color fillColor
)
Parameters
x (Double)
The x location for this BoxObj. This will be in units determined by CoordinateFrame.
y (Double)
The y location for this BoxObj. This will be in units determined by CoordinateFrame.
width (Double)
The width of this BoxObj. This will be in units determined by CoordinateFrame.
height (Double)
The height of this BoxObj. This will be in units determined by CoordinateFrame.
borderColor (Color)
An arbitrary Color specification for the ellipse border
fillColor (Color)
An arbitrary Color specification for the ellipse fill (will be a solid color fill)


EllipseObj Constructor (x, y, width, height, borderColor, fillColor1, fillColor2)

EllipseObj Constructor (x, y, width, height, borderColor, fillColor1, fillColor2)
Namespaces ► ZedGraph ► EllipseObj ► EllipseObjEllipseObjNew(Double, Double, Double, Double, Color, Color, Color)
A constructor that allows the position, border color, and two-color gradient fill colors of the EllipseObj to be pre-specified.
Declaration Syntax
C# Visual Basic Visual C++
public EllipseObj(
    double x,
    double y,
    double width,
    double height,
    Color borderColor,
    Color fillColor1,
    Color fillColor2
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    borderColor As Color, _
    fillColor1 As Color, _
    fillColor2 As Color _
)
public:
EllipseObj (
    double x,
    double y,
    double width,
    double height,
    Color borderColor,
    Color fillColor1,
    Color fillColor2
)
Parameters
x (Double)
The x location for this BoxObj. This will be in units determined by CoordinateFrame.
y (Double)
The y location for this BoxObj. This will be in units determined by CoordinateFrame.
width (Double)
The width of this BoxObj. This will be in units determined by CoordinateFrame.
height (Double)
The height of this BoxObj. This will be in units determined by CoordinateFrame.
borderColor (Color)
An arbitrary Color specification for the ellipse border
fillColor1 (Color)
An arbitrary Color specification for the start of the ellipse gradient fill
fillColor2 (Color)
An arbitrary Color specification for the end of the ellipse gradient fill


EllipseObj Constructor (rhs)

EllipseObj Constructor (rhs)
Namespaces ► ZedGraph ► EllipseObj ► EllipseObjEllipseObjNew(BoxObj)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public EllipseObj(
    BoxObj rhs
)
Public Sub New ( _
    rhs As BoxObj _
)
public:
EllipseObj (
    BoxObj^ rhs
)
Parameters
rhs (BoxObj)
The EllipseObj object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► EllipseObj ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public EllipseObj Clone()
Public Function Clone As EllipseObj
public:
EllipseObj^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, scaleFactor)

Draw Method (g, pane, scaleFactor)
Namespaces ► ZedGraph ► EllipseObj ► Draw(Graphics, PaneBase, Single)
Render this object to the specified Graphics device.
Declaration Syntax
C# Visual Basic Visual C++
public override void Draw(
    Graphics g,
    PaneBase pane,
    float scaleFactor
)
Public Overrides Sub Draw ( _
    g As Graphics, _
    pane As PaneBase, _
    scaleFactor As Single _
)
public:
virtual void Draw (
    Graphics^ g,
    PaneBase^ pane,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Remarks
This method is normally only called by the Draw method of the parent GraphObjList collection object.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► EllipseObj ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


PointInBox Method (pt, pane, g, scaleFactor)

PointInBox Method (pt, pane, g, scaleFactor)
Namespaces ► ZedGraph ► EllipseObj ► PointInBox(PointF, PaneBase, Graphics, Single)
Determine if the specified screen point lies inside the bounding box of this BoxObj.
Declaration Syntax
C# Visual Basic Visual C++
public override bool PointInBox(
    PointF pt,
    PaneBase pane,
    Graphics g,
    float scaleFactor
)
Public Overrides Function PointInBox ( _
    pt As PointF, _
    pane As PaneBase, _
    g As Graphics, _
    scaleFactor As Single _
) As Boolean
public:
virtual bool PointInBox (
    PointF pt,
    PaneBase^ pane,
    Graphics^ g,
    float scaleFactor
) override
Parameters
pt (PointF)
The screen point, in pixels
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
true if the point lies in the bounding box, false otherwise


schema3 Field

schema3 Field
Namespaces ► ZedGraph ► EllipseObj ► schema3
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema3
Public Const schema3 As Integer
public:
literal int schema3


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► EllipseObj ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


ErrorBar Class

ErrorBar Class
Namespaces ► ZedGraph ► ErrorBar
This class handles the drawing of the curve ErrorBar objects. The Error Bars are the vertical lines with a symbol at each end.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ErrorBar : ICloneable, ISerializable
<SerializableAttribute> _
Public Class ErrorBar _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class ErrorBar : ICloneable,
    ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ErrorBarErrorBarNew()() | Default constructor that sets all ErrorBar properties to default values as defined in the ErrorBar..::Default class.
 | ErrorBarErrorBarNew(Color) | Default constructor that sets the Color as specified, and the remaining ErrorBar properties to default values as defined in the ErrorBar..::Default class.
 | ErrorBarErrorBarNew(ErrorBar) | The Copy Constructor
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | Gets or sets the Color data for this ErrorBar.
 | Draw(Graphics, GraphPane, Boolean, Single, Single, Single, Single, Pen, Boolean, PointPair) | Draw the ErrorBar to the specified Graphics device at the specified location.
 | Draw(Graphics, GraphPane, ErrorBarItem, Axis, Axis, Single) | Draw all the ErrorBar's to the specified Graphics device as a an error bar at each defined point.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible | Gets or sets a property that shows or hides the ErrorBar.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PenWidth | The pen width to be used for drawing error bars Units are points.
 | schema | Current schema value that defines the version of the serialized file
 | Symbol | Contains the symbol element that will be drawn at the top and bottom of the error bar.
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
To draw "I-Beam" bars, the symbol type defaults to HDash, which is just a horizontal line. If BarBase is Y-oriented, then the symbol type should be set to VDash to get the same effect.
Inheritance Hierarchy
Object
ErrorBar


ErrorBar Constructor

ErrorBar Constructor
Namespaces ► ZedGraph ► ErrorBar ► ErrorBarErrorBarNew()()
Members
Icon | Member | Description
 | ErrorBarErrorBarNew()() | Default constructor that sets all ErrorBar properties to default values as defined in the ErrorBar..::Default class.
 | ErrorBarErrorBarNew(Color) | Default constructor that sets the Color as specified, and the remaining ErrorBar properties to default values as defined in the ErrorBar..::Default class.
 | ErrorBarErrorBarNew(ErrorBar) | The Copy Constructor


ErrorBar Constructor

ErrorBar Constructor
Namespaces ► ZedGraph ► ErrorBar ► ErrorBarErrorBarNew()()
Default constructor that sets all ErrorBar properties to default values as defined in the ErrorBar..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public ErrorBar()
Public Sub New
public:
ErrorBar ()


ErrorBar Constructor (color)

ErrorBar Constructor (color)
Namespaces ► ZedGraph ► ErrorBar ► ErrorBarErrorBarNew(Color)
Default constructor that sets the Color as specified, and the remaining ErrorBar properties to default values as defined in the ErrorBar..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public ErrorBar(
    Color color
)
Public Sub New ( _
    color As Color _
)
public:
ErrorBar (
    Color color
)
Parameters
color (Color)
A Color value indicating the color of the symbol


ErrorBar Constructor (rhs)

ErrorBar Constructor (rhs)
Namespaces ► ZedGraph ► ErrorBar ► ErrorBarErrorBarNew(ErrorBar)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ErrorBar(
    ErrorBar rhs
)
Public Sub New ( _
    rhs As ErrorBar _
)
public:
ErrorBar (
    ErrorBar^ rhs
)
Parameters
rhs (ErrorBar)
The ErrorBar object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► ErrorBar ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public ErrorBar Clone()
Public Function Clone As ErrorBar
public:
ErrorBar^ Clone ()
Return Value
A new, independent copy of this class


Color Property

Color Property
Namespaces ► ZedGraph ► ErrorBar ► Color
Gets or sets the Color data for this ErrorBar.
Declaration Syntax
C# Visual Basic Visual C++
public Color Color{ get; set;}
Public Property Color As Color
public:
property Color Color {
    Color get ();
    void set (Color value);
}
Remarks
This property only controls the color of the vertical line. The symbol color is controlled separately in the Symbol property.


Draw Method

Draw Method
Namespaces ► ZedGraph ► ErrorBar ► Draw()()
Members
Icon | Member | Description
 | Draw(Graphics, GraphPane, Boolean, Single, Single, Single, Single, Pen, Boolean, PointPair) | Draw the ErrorBar to the specified Graphics device at the specified location.
 | Draw(Graphics, GraphPane, ErrorBarItem, Axis, Axis, Single) | Draw all the ErrorBar's to the specified Graphics device as a an error bar at each defined point.


Draw Method (g, pane, isXBase, pixBase, pixValue, pixLowValue, scaleFactor, pen, isSelected, dataValue)

Draw Method (g, pane, isXBase, pixBase, pixValue, pixLowValue, scaleFactor, pen, isSelected, dataValue)
Namespaces ► ZedGraph ► ErrorBar ► Draw(Graphics, GraphPane, Boolean, Single, Single, Single, Single, Pen, Boolean, PointPair)
Draw the ErrorBar to the specified Graphics device at the specified location.
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    GraphPane pane,
    bool isXBase,
    float pixBase,
    float pixValue,
    float pixLowValue,
    float scaleFactor,
    Pen pen,
    bool isSelected,
    PointPair dataValue
)
Public Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    isXBase As Boolean, _
    pixBase As Single, _
    pixValue As Single, _
    pixLowValue As Single, _
    scaleFactor As Single, _
    pen As Pen, _
    isSelected As Boolean, _
    dataValue As PointPair _
)
public:
void Draw (
    Graphics^ g,
    GraphPane^ pane,
    bool isXBase,
    float pixBase,
    float pixValue,
    float pixLowValue,
    float scaleFactor,
    Pen^ pen,
    bool isSelected,
    PointPair^ dataValue
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
isXBase (Boolean)
boolean value that indicates if the "base" axis for this ErrorBar is the X axis. True for an XAxis base, false for a YAxis or Y2Axis base.
pixBase (Single)
The independent axis position of the center of the error bar in pixel units
pixValue (Single)
The dependent axis position of the top of the error bar in pixel units
pixLowValue (Single)
The dependent axis position of the bottom of the error bar in pixel units
scaleFactor (Single)
The scaling factor for the features of the graph based on the BaseDimension. This scaling factor is calculated by the CalcScaleFactor()() method. The scale factor represents a linear multiple to be applied to font sizes, symbol sizes, etc.
pen (Pen)
A pen with attributes of Color and PenWidth for this ErrorBar
isSelected (Boolean)
Indicates that the ErrorBar should be drawn with attributes from the Selection class.
dataValue (PointPair)
The data value to be used for a value-based color gradient. This is only applicable for GradientByX, GradientByY or GradientByZ.


Draw Method (g, pane, curve, baseAxis, valueAxis, scaleFactor)

Draw Method (g, pane, curve, baseAxis, valueAxis, scaleFactor)
Namespaces ► ZedGraph ► ErrorBar ► Draw(Graphics, GraphPane, ErrorBarItem, Axis, Axis, Single)
Draw all the ErrorBar's to the specified Graphics device as a an error bar at each defined point.
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    GraphPane pane,
    ErrorBarItem curve,
    Axis baseAxis,
    Axis valueAxis,
    float scaleFactor
)
Public Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    curve As ErrorBarItem, _
    baseAxis As Axis, _
    valueAxis As Axis, _
    scaleFactor As Single _
)
public:
void Draw (
    Graphics^ g,
    GraphPane^ pane,
    ErrorBarItem^ curve,
    Axis^ baseAxis,
    Axis^ valueAxis,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
curve (ErrorBarItem)
A CurveItem object representing the Bar's to be drawn.
baseAxis (Axis)
The Axis class instance that defines the base (independent) axis for the Bar
valueAxis (Axis)
The Axis class instance that defines the value (dependent) axis for the Bar
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► ErrorBar ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph ► ErrorBar ► IsVisible
Gets or sets a property that shows or hides the ErrorBar.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
Value
true to show the error bar, false to hide it
See Also
IsVisible


PenWidth Property

PenWidth Property
Namespaces ► ZedGraph ► ErrorBar ► PenWidth
The pen width to be used for drawing error bars Units are points.
Declaration Syntax
C# Visual Basic Visual C++
public float PenWidth{ get; set;}
Public Property PenWidth As Single
public:
property float PenWidth {
    float get ();
    void set (float value);
}
Remarks
This property only controls the pen width for the vertical line. The pen width for the symbol outline is controlled separately by the Symbol property.


schema Field

schema Field
Namespaces ► ZedGraph ► ErrorBar ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


Symbol Property

Symbol Property
Namespaces ► ZedGraph ► ErrorBar ► Symbol
Contains the symbol element that will be drawn at the top and bottom of the error bar.
Declaration Syntax
C# Visual Basic Visual C++
public Symbol Symbol{ get; set;}
Public Property Symbol As Symbol
public:
property Symbol^ Symbol {
    Symbol^ get ();
    void set (Symbol^ value);
}


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► ErrorBar ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


ErrorBar.Default Structure

ErrorBar..::Default Structure
Namespaces ► ZedGraph ► ErrorBar ► ErrorBar..::Default
A simple struct that defines the default property values for the ErrorBar class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Color | The default color for drawing error bars (Color property).
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible | The default display mode for symbols (IsVisible property). true to display symbols, false to hide them.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PenWidth | The default pen width to be used for drawing error bars (PenWidth property). Units are points.
 | Size | The default size for curve symbols (Size property), in units of points.
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | Type | The default symbol for drawing at the top and bottom of the error bar (see Symbol).


Color Field

Color Field
Namespaces ► ZedGraph ► ErrorBar..::Default ► Color
The default color for drawing error bars (Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color Color
Public Shared Color As Color
public:
static Color Color


IsVisible Field

IsVisible Field
Namespaces ► ZedGraph ► ErrorBar..::Default ► IsVisible
The default display mode for symbols (IsVisible property). true to display symbols, false to hide them.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsVisible
Public Shared IsVisible As Boolean
public:
static bool IsVisible


PenWidth Field

PenWidth Field
Namespaces ► ZedGraph ► ErrorBar..::Default ► PenWidth
The default pen width to be used for drawing error bars (PenWidth property). Units are points.
Declaration Syntax
C# Visual Basic Visual C++
public static float PenWidth
Public Shared PenWidth As Single
public:
static float PenWidth


Size Field

Size Field
Namespaces ► ZedGraph ► ErrorBar..::Default ► Size
The default size for curve symbols (Size property), in units of points.
Declaration Syntax
C# Visual Basic Visual C++
public static float Size
Public Shared Size As Single
public:
static float Size


Type Field

Type Field
Namespaces ► ZedGraph ► ErrorBar..::Default ► Type
The default symbol for drawing at the top and bottom of the error bar (see Symbol).
Declaration Syntax
C# Visual Basic Visual C++
public static SymbolType Type
Public Shared Type As SymbolType
public:
static SymbolType Type


ErrorBarItem Class

ErrorBarItem Class
Namespaces ► ZedGraph ► ErrorBarItem
Encapsulates an "Error Bar" curve type that displays a vertical or horizontal line with a symbol at each end.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ErrorBarItem : CurveItem, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class ErrorBarItem _
    Inherits CurveItem _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class ErrorBarItem : public CurveItem,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ErrorBarItemErrorBarItemNew(String) | Create a new ErrorBarItem, specifying only the legend label.
 | ErrorBarItemErrorBarItemNew(String, array<Double>[](), array<Double>[](), array<Double>[](), Color) | Create a new ErrorBarItem using the specified properties.
 | ErrorBarItemErrorBarItemNew(String, IPointList, Color) | Create a new ErrorBarItem using the specified properties.
 | ErrorBarItemErrorBarItemNew(ErrorBarItem) | The Copy Constructor
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve. (Inherited from CurveItem.)
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve. (Inherited from CurveItem.)
 | Bar | Gets a reference to the ErrorBar class defined for this ErrorBarItem.
 | BaseAxis(GraphPane) | Returns a reference to the Axis object that is the "base" (independent axis) from which the values are drawn. (Inherited from CurveItem.)
 | Clear()() | Clears the points from this CurveItem. This is the same as CurveItem.Points.Clear(). (Inherited from CurveItem.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The Line/Symbol/Bar color (FillColor for the Bar). This is a common access to Line.Color, Border.Color, and Fill.Color properties for this curve. (Inherited from CurveItem.)
 | Draw(Graphics, GraphPane, Int32, Single) | Do all rendering associated with this ErrorBarItem to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object. (Overrides CurveItem.Draw(Graphics, GraphPane, Int32, Single).)
 | DrawLegendKey(Graphics, GraphPane, RectangleF, Single) | Draw a legend key entry for this ErrorBarItem at the specified location (Overrides CurveItem.DrawLegendKey(Graphics, GraphPane, RectangleF, Single).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarWidth(GraphPane) | Calculate the width of each bar, depending on the actual bar type (Inherited from CurveItem.)
 | GetCoords(GraphPane, Int32, String%) | Determine the coords for the rectangle associated with a specified point for this CurveItem (Overrides CurveItem.GetCoords(GraphPane, Int32, String%).)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides CurveItem.GetObjectData(SerializationInfo, StreamingContext).)
 | GetRange(Double%, Double%, Double%, Double%, Boolean, Boolean, GraphPane) | Go through the list of PointPair data values for this CurveItem and determine the minimum and maximum values in the data. (Inherited from CurveItem.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXAxis(GraphPane) | Get the X Axis instance (either XAxis or X2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxis(GraphPane) | Get the Y Axis instance (either YAxis or Y2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxisIndex(GraphPane) | Get the index of the Y Axis in the YAxis or Y2Axis list to which this CurveItem belongs. (Inherited from CurveItem.)
 | IsBar | Determines whether this CurveItem is a BarItem. This does not include HiLowBarItem's or ErrorBarItem's. (Inherited from CurveItem.)
 | IsLine | Determines whether this CurveItem is a LineItem. (Inherited from CurveItem.)
 | IsOverrideOrdinal | Gets or sets a value which allows you to override the normal ordinal axis behavior. (Inherited from CurveItem.)
 | IsPie | Determines whether this CurveItem is a PieItem. (Inherited from CurveItem.)
 | IsSelectable | Determines whether this CurveItem can be selected in the graph. (Inherited from CurveItem.)
 | IsSelected | Determines whether this CurveItem is selected on the graph. Note that this value changes the curve displayed color, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsVisible | Determines whether this CurveItem is visible on the graph. Note that this value turns the curve display on or off, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsX2Axis | Gets or sets a value that determines which X axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | IsY2Axis | Gets or sets a value that determines which Y axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | Item[([Int32])] | An accessor for the PointPair datum for this CurveItem. Index is the ordinal reference (zero based) of the point. (Inherited from CurveItem.)
 | Label | A Label instance that represents the Legend entry for the this CurveItem object (Inherited from CurveItem.)
 | Link | Gets or sets the hyperlink information for this CurveItem. (Inherited from CurveItem.)
 | MakeUnique()() | Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator) (Inherited from CurveItem.)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator) (Inherited from CurveItem.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NPts | Readonly property that gives the number of points that define this CurveItem object, which is the number of points in the Points data collection. (Inherited from CurveItem.)
 | Points | The IPointList of X,Y point sets that represent this CurveItem. (Inherited from CurveItem.)
 | RemovePoint(Int32) | Removes a single point from this CurveItem. (Inherited from CurveItem.)
 | schema2 | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the CurveItem. ZedGraph does not use this value for any purpose. (Inherited from CurveItem.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValueAxis(GraphPane) | Returns a reference to the Axis object that is the "value" (dependent axis) from which the points are drawn. (Inherited from CurveItem.)
 | YAxisIndex | Gets or sets the index number of the Y Axis to which this CurveItem belongs. (Inherited from CurveItem.)
Remarks
The ErrorBarItem type is intended for displaying confidence intervals, candlesticks, stock High-Low charts, etc. It is technically not a bar, since it is drawn as a vertical or horizontal line. The default symbol at each end of the "bar" is HDash, which creates an "I-Beam". For horizontal bars (Y or Y2), you will need to change the symbol to VDash to get horizontal "I-Beams". Since the horizontal segments are actually symbols, their widths are controlled by the symbol size in Symbol, specified in points (1/72nd inch). The position of each "I-Beam" is set according to the PointPair values. The independent axis is assigned with Base, and is a BarBase enum type.
Inheritance Hierarchy
Object
 | CurveItem
 |  | ErrorBarItem


ErrorBarItem Constructor

ErrorBarItem Constructor
Namespaces ► ZedGraph ► ErrorBarItem ► ErrorBarItemErrorBarItemNew()()
Members
Icon | Member | Description
 | ErrorBarItemErrorBarItemNew(String) | Create a new ErrorBarItem, specifying only the legend label.
 | ErrorBarItemErrorBarItemNew(String, array<Double>[](), array<Double>[](), array<Double>[](), Color) | Create a new ErrorBarItem using the specified properties.
 | ErrorBarItemErrorBarItemNew(String, IPointList, Color) | Create a new ErrorBarItem using the specified properties.
 | ErrorBarItemErrorBarItemNew(ErrorBarItem) | The Copy Constructor


ErrorBarItem Constructor (label)

ErrorBarItem Constructor (label)
Namespaces ► ZedGraph ► ErrorBarItem ► ErrorBarItemErrorBarItemNew(String)
Create a new ErrorBarItem, specifying only the legend label.
Declaration Syntax
C# Visual Basic Visual C++
public ErrorBarItem(
    string label
)
Public Sub New ( _
    label As String _
)
public:
ErrorBarItem (
    String^ label
)
Parameters
label (String)
The label that will appear in the legend.


ErrorBarItem Constructor (label, x, y, lowValue, color)

ErrorBarItem Constructor (label, x, y, lowValue, color)
Namespaces ► ZedGraph ► ErrorBarItem ► ErrorBarItemErrorBarItemNew(String, array<Double>[](), array<Double>[](), array<Double>[](), Color)
Create a new ErrorBarItem using the specified properties.
Declaration Syntax
C# Visual Basic Visual C++
public ErrorBarItem(
    string label,
    double[] x,
    double[] y,
    double[] lowValue,
    Color color
)
Public Sub New ( _
    label As String, _
    x As Double(), _
    y As Double(), _
    lowValue As Double(), _
    color As Color _
)
public:
ErrorBarItem (
    String^ label,
    array<double>^ x,
    array<double>^ y,
    array<double>^ lowValue,
    Color color
)
Parameters
label (String)
The label that will appear in the legend.
x (array< Double >[]())
An array of double precision values that define the X axis values for this curve
y (array< Double >[]())
An array of double precision values that define the Y axis values for this curve
lowValue (array< Double >[]())
An array of double precision values that define the lower dependent values for this curve
color (Color)
A Color value that will be applied to the Line properties.


ErrorBarItem Constructor (label, points, color)

ErrorBarItem Constructor (label, points, color)
Namespaces ► ZedGraph ► ErrorBarItem ► ErrorBarItemErrorBarItemNew(String, IPointList, Color)
Create a new ErrorBarItem using the specified properties.
Declaration Syntax
C# Visual Basic Visual C++
public ErrorBarItem(
    string label,
    IPointList points,
    Color color
)
Public Sub New ( _
    label As String, _
    points As IPointList, _
    color As Color _
)
public:
ErrorBarItem (
    String^ label,
    IPointList^ points,
    Color color
)
Parameters
label (String)
The label that will appear in the legend.
points (IPointList)
A IPointList of double precision values that define the X, Y and lower dependent values for this curve
color (Color)
A Color value that will be applied to the Line properties.


ErrorBarItem Constructor (rhs)

ErrorBarItem Constructor (rhs)
Namespaces ► ZedGraph ► ErrorBarItem ► ErrorBarItemErrorBarItemNew(ErrorBarItem)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ErrorBarItem(
    ErrorBarItem rhs
)
Public Sub New ( _
    rhs As ErrorBarItem _
)
public:
ErrorBarItem (
    ErrorBarItem^ rhs
)
Parameters
rhs (ErrorBarItem)
The ErrorBarItem object from which to copy


Bar Property

Bar Property
Namespaces ► ZedGraph ► ErrorBarItem ► Bar
Gets a reference to the ErrorBar class defined for this ErrorBarItem.
Declaration Syntax
C# Visual Basic Visual C++
public ErrorBar Bar{ get;}
Public ReadOnly Property Bar As ErrorBar
public:
property ErrorBar^ Bar {
    ErrorBar^ get ();
}


Clone Method

Clone Method
Namespaces ► ZedGraph ► ErrorBarItem ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public ErrorBarItem Clone()
Public Function Clone As ErrorBarItem
public:
ErrorBarItem^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, pos, scaleFactor)

Draw Method (g, pane, pos, scaleFactor)
Namespaces ► ZedGraph ► ErrorBarItem ► Draw(Graphics, GraphPane, Int32, Single)
Do all rendering associated with this ErrorBarItem to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object.
Declaration Syntax
C# Visual Basic Visual C++
public override void Draw(
    Graphics g,
    GraphPane pane,
    int pos,
    float scaleFactor
)
Public Overrides Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    pos As Integer, _
    scaleFactor As Single _
)
public:
virtual void Draw (
    Graphics^ g,
    GraphPane^ pane,
    int pos,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
pos (Int32)
The ordinal position of the current ErrorBarItem curve.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


DrawLegendKey Method (g, pane, rect, scaleFactor)

DrawLegendKey Method (g, pane, rect, scaleFactor)
Namespaces ► ZedGraph ► ErrorBarItem ► DrawLegendKey(Graphics, GraphPane, RectangleF, Single)
Draw a legend key entry for this ErrorBarItem at the specified location
Declaration Syntax
C# Visual Basic Visual C++
public override void DrawLegendKey(
    Graphics g,
    GraphPane pane,
    RectangleF rect,
    float scaleFactor
)
Public Overrides Sub DrawLegendKey ( _
    g As Graphics, _
    pane As GraphPane, _
    rect As RectangleF, _
    scaleFactor As Single _
)
public:
virtual void DrawLegendKey (
    Graphics^ g,
    GraphPane^ pane,
    RectangleF rect,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
rect (RectangleF)
The RectangleF struct that specifies the location for the legend key
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


GetCoords Method (pane, i, coords)

GetCoords Method (pane, i, coords)
Namespaces ► ZedGraph ► ErrorBarItem ► GetCoords(GraphPane, Int32, String%)
Determine the coords for the rectangle associated with a specified point for this CurveItem
Declaration Syntax
C# Visual Basic Visual C++
public override bool GetCoords(
    GraphPane pane,
    int i,
    out string coords
)
Public Overrides Function GetCoords ( _
    pane As GraphPane, _
    i As Integer, _
    <OutAttribute> ByRef coords As String _
) As Boolean
public:
virtual bool GetCoords (
    GraphPane^ pane,
    int i,
    [OutAttribute] String^% coords
) override
Parameters
pane (GraphPane)
The GraphPane to which this curve belongs
i (Int32)
The index of the point of interest
coords (String %)
A list of coordinates that represents the "rect" for this point (used in an html AREA tag)
Return Value
true if it's a valid point, false otherwise


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► ErrorBarItem ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► ErrorBarItem ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► ErrorBarItem ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Fill Class

Fill Class
Namespaces ► ZedGraph ► Fill
A class that encapsulates color-fill properties for an object. The Fill class is used in Rect, Rect, Legend, Bar, and Line objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Fill : ISerializable, ICloneable
<SerializableAttribute> _
Public Class Fill _
    Implements ISerializable, ICloneable
[SerializableAttribute]
public ref class Fill : ISerializable, ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FillFillNew()() | The default constructor. Initialized to no fill.
 | FillFillNew(Color, Brush, FillType) | Constructor that specifies the color, brush, and type for this fill.
 | FillFillNew(Color) | Constructor that creates a solid color-fill, setting Type to Solid, and setting Color to the specified color value.
 | FillFillNew(Color, Color, Single) | Constructor that creates a linear gradient color-fill, setting Type to Brush using the specified colors and angle.
 | FillFillNew(Color, Color) | Constructor that creates a linear gradient color-fill, setting Type to Brush using the specified colors.
 | FillFillNew(Color, Color, Color) | Constructor that creates a linear gradient color-fill, setting Type to Brush using the specified colors. This gradient fill consists of three colors.
 | FillFillNew(Color, Color, Color, Single) | Constructor that creates a linear gradient color-fill, setting Type to Brush using the specified colors. This gradient fill consists of three colors
 | FillFillNew(ColorBlend) | Constructor that creates a linear gradient multi-color-fill, setting Type to Brush using the specified colors. This gradient fill consists of many colors based on a ColorBlend object. The gradient angle is defaulted to zero.
 | FillFillNew(ColorBlend, Single) | Constructor that creates a linear gradient multi-color-fill, setting Type to Brush using the specified colors. This gradient fill consists of many colors based on a ColorBlend object, drawn at the specified angle (degrees).
 | FillFillNew(array<Color>[]()) | Constructor that creates a linear gradient multi-color-fill, setting Type to Brush using the specified colors. This gradient fill consists of many colors based on an array of Color objects, drawn at an angle of zero (degrees). The array is used to create a ColorBlend object assuming a even linear distribution of the colors across the gradient.
 | FillFillNew(array<Color>[](), Single) | Constructor that creates a linear gradient multi-color-fill, setting Type to Brush using the specified colors. This gradient fill consists of many colors based on an array of Color objects, drawn at the specified angle (degrees). The array is used to create a ColorBlend object assuming a even linear distribution of the colors across the gradient.
 | FillFillNew(array<Color>[](), array<Single>[]()) | Constructor that creates a linear gradient multi-color-fill, setting Type to Brush using the specified colors. This gradient fill consists of many colors based on an array of Color objects, drawn at the an angle of zero (degrees). The array is used to create a ColorBlend object assuming a even linear distribution of the colors across the gradient.
 | FillFillNew(array<Color>[](), array<Single>[](), Single) | Constructor that creates a linear gradient multi-color-fill, setting Type to Brush using the specified colors. This gradient fill consists of many colors based on an array of Color objects, drawn at the specified angle (degrees). The array is used to create a ColorBlend object assuming a even linear distribution of the colors across the gradient.
 | FillFillNew(Image, WrapMode) | Constructor that creates a texture fill, setting Type to Brush and using the specified image.
 | FillFillNew(Brush) | Constructor that creates a Brush fill, using a user-supplied, custom Brush. The brush will be scaled to fit the destination screen object unless you manually change IsScaled to false;
 | FillFillNew(Brush, Boolean) | Constructor that creates a Brush fill, using a user-supplied, custom Brush. The brush will be scaled to fit the destination screen object according to the parameter.
 | FillFillNew(Brush, AlignH, AlignV) | Constructor that creates a Brush fill, using a user-supplied, custom Brush. This constructor will make the brush unscaled (see IsScaled), but it provides and parameters to control alignment of the brush with respect to the filled object.
 | FillFillNew(Fill) | The Copy Constructor
 | AlignH | Determines how the brush will be aligned with the filled object in the horizontal direction. This value is a AlignH enumeration. This field only applies if IsScaled is false.
 | AlignV | Determines how the brush will be aligned with the filled object in the vertical direction. This value is a AlignV enumeration. This field only applies if IsScaled is false.
 | Brush | The custom fill brush. This can be a SolidBrush, a LinearGradientBrush, or a TextureBrush. This property is only applicable if the Type property is set to Brush.
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The fill color. This property is used as a single color to make a solid fill (Type is Solid), or it can be used in combination with White to make a LinearGradientBrush when Type is Brush and Brush is null.
 | Draw(Graphics, RectangleF) | Fill the background of the RectangleF area, using the fill type from this Fill.
 | Draw(Graphics, RectangleF, PointPair) | Fill the background of the RectangleF area, using the fill type from this Fill.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsGradientValueType | Returns a boolean value indicating whether or not this fill is a "Gradient-By-Value" type. This is true for GradientByX, GradientByY, or GradientByZ.
 | IsScaled | Determines if the brush will be scaled to the bounding box of the filled object. If this value is false, then the brush will only be aligned with the filled object based on the AlignH and AlignV properties.
 | IsVisible | This property determines the type of color fill. Returns true if the Type property is either Solid or Brush. If set to true, this property will automatically set the Type to Brush. If set to false, this property will automatically set the Type to None. In order to get a regular solid-color fill, you have to manually set Type to Solid.
 | MakeBrush(RectangleF) | Create a fill brush using current properties. This method will construct a brush based on the settings of Type, Color and Brush. If Type is set to Brush and Brush is null, then a LinearGradientBrush will be created between the colors of White and Color.
 | MakeBrush(RectangleF, PointPair) | Create a fill brush using current properties. This method will construct a brush based on the settings of Type, Color and Brush. If Type is set to Brush and Brush is null, then a LinearGradientBrush will be created between the colors of White and Color.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RangeDefault | The default user-scale value for the gradient-by-value determination. This defines the value that will be used when there is no point value available, or the actual point value is invalid.
 | RangeMax | The maximum user-scale value for the gradient-by-value determination. This defines the user-scale value for the end of the gradient.
 | RangeMin | The minimum user-scale value for the gradient-by-value determination. This defines the user-scale value for the start of the gradient.
 | schema | Current schema value that defines the version of the serialized file
 | SecondaryValueGradientColor | Gets or sets the secondary color for gradientByValue fills.
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Determines the type of fill, which can be either solid color (Solid) or a custom brush (Brush). See Type for more information.
Inheritance Hierarchy
Object
Fill


Fill Constructor

Fill Constructor
Namespaces ► ZedGraph ► Fill ► FillFillNew()()
Members
Icon | Member | Description
 | FillFillNew()() | The default constructor. Initialized to no fill.
 | FillFillNew(Color, Brush, FillType) | Constructor that specifies the color, brush, and type for this fill.
 | FillFillNew(Color) | Constructor that creates a solid color-fill, setting Type to Solid, and setting Color to the specified color value.
 | FillFillNew(Color, Color, Single) | Constructor that creates a linear gradient color-fill, setting Type to Brush using the specified colors and angle.
 | FillFillNew(Color, Color) | Constructor that creates a linear gradient color-fill, setting Type to Brush using the specified colors.
 | FillFillNew(Color, Color, Color) | Constructor that creates a linear gradient color-fill, setting Type to Brush using the specified colors. This gradient fill consists of three colors.
 | FillFillNew(Color, Color, Color, Single) | Constructor that creates a linear gradient color-fill, setting Type to Brush using the specified colors. This gradient fill consists of three colors
 | FillFillNew(ColorBlend) | Constructor that creates a linear gradient multi-color-fill, setting Type to Brush using the specified colors. This gradient fill consists of many colors based on a ColorBlend object. The gradient angle is defaulted to zero.
 | FillFillNew(ColorBlend, Single) | Constructor that creates a linear gradient multi-color-fill, setting Type to Brush using the specified colors. This gradient fill consists of many colors based on a ColorBlend object, drawn at the specified angle (degrees).
 | FillFillNew(array<Color>[]()) | Constructor that creates a linear gradient multi-color-fill, setting Type to Brush using the specified colors. This gradient fill consists of many colors based on an array of Color objects, drawn at an angle of zero (degrees). The array is used to create a ColorBlend object assuming a even linear distribution of the colors across the gradient.
 | FillFillNew(array<Color>[](), Single) | Constructor that creates a linear gradient multi-color-fill, setting Type to Brush using the specified colors. This gradient fill consists of many colors based on an array of Color objects, drawn at the specified angle (degrees). The array is used to create a ColorBlend object assuming a even linear distribution of the colors across the gradient.
 | FillFillNew(array<Color>[](), array<Single>[]()) | Constructor that creates a linear gradient multi-color-fill, setting Type to Brush using the specified colors. This gradient fill consists of many colors based on an array of Color objects, drawn at the an angle of zero (degrees). The array is used to create a ColorBlend object assuming a even linear distribution of the colors across the gradient.
 | FillFillNew(array<Color>[](), array<Single>[](), Single) | Constructor that creates a linear gradient multi-color-fill, setting Type to Brush using the specified colors. This gradient fill consists of many colors based on an array of Color objects, drawn at the specified angle (degrees). The array is used to create a ColorBlend object assuming a even linear distribution of the colors across the gradient.
 | FillFillNew(Image, WrapMode) | Constructor that creates a texture fill, setting Type to Brush and using the specified image.
 | FillFillNew(Brush) | Constructor that creates a Brush fill, using a user-supplied, custom Brush. The brush will be scaled to fit the destination screen object unless you manually change IsScaled to false;
 | FillFillNew(Brush, Boolean) | Constructor that creates a Brush fill, using a user-supplied, custom Brush. The brush will be scaled to fit the destination screen object according to the parameter.
 | FillFillNew(Brush, AlignH, AlignV) | Constructor that creates a Brush fill, using a user-supplied, custom Brush. This constructor will make the brush unscaled (see IsScaled), but it provides and parameters to control alignment of the brush with respect to the filled object.
 | FillFillNew(Fill) | The Copy Constructor


Fill Constructor

Fill Constructor
Namespaces ► ZedGraph ► Fill ► FillFillNew()()
The default constructor. Initialized to no fill.
Declaration Syntax
C# Visual Basic Visual C++
public Fill()
Public Sub New
public:
Fill ()


Fill Constructor (brush)

Fill Constructor (brush)
Namespaces ► ZedGraph ► Fill ► FillFillNew(Brush)
Constructor that creates a Brush fill, using a user-supplied, custom Brush. The brush will be scaled to fit the destination screen object unless you manually change IsScaled to false;
Declaration Syntax
C# Visual Basic Visual C++
public Fill(
    Brush brush
)
Public Sub New ( _
    brush As Brush _
)
public:
Fill (
    Brush^ brush
)
Parameters
brush (Brush)
The Brush to use for fancy fills. Typically, this would be a LinearGradientBrush or a TextureBrush class


Fill Constructor (brush, isScaled)

Fill Constructor (brush, isScaled)
Namespaces ► ZedGraph ► Fill ► FillFillNew(Brush, Boolean)
Constructor that creates a Brush fill, using a user-supplied, custom Brush. The brush will be scaled to fit the destination screen object according to the parameter.
Declaration Syntax
C# Visual Basic Visual C++
public Fill(
    Brush brush,
    bool isScaled
)
Public Sub New ( _
    brush As Brush, _
    isScaled As Boolean _
)
public:
Fill (
    Brush^ brush,
    bool isScaled
)
Parameters
brush (Brush)
The Brush to use for fancy fills. Typically, this would be a LinearGradientBrush or a TextureBrush class
isScaled (Boolean)
Determines if the brush will be scaled to fit the bounding box of the destination object. true to scale it, false to leave it unscaled


Fill Constructor (brush, alignH, alignV)

Fill Constructor (brush, alignH, alignV)
Namespaces ► ZedGraph ► Fill ► FillFillNew(Brush, AlignH, AlignV)
Constructor that creates a Brush fill, using a user-supplied, custom Brush. This constructor will make the brush unscaled (see IsScaled), but it provides and parameters to control alignment of the brush with respect to the filled object.
Declaration Syntax
C# Visual Basic Visual C++
public Fill(
    Brush brush,
    AlignH alignH,
    AlignV alignV
)
Public Sub New ( _
    brush As Brush, _
    alignH As AlignH, _
    alignV As AlignV _
)
public:
Fill (
    Brush^ brush,
    AlignH alignH,
    AlignV alignV
)
Parameters
brush (Brush)
The Brush to use for fancy fills. Typically, this would be a LinearGradientBrush or a TextureBrush class
alignH (AlignH)
Controls the horizontal alignment of the brush within the filled object (see AlignH
alignV (AlignV)
Controls the vertical alignment of the brush within the filled object (see AlignV


Fill Constructor (color)

Fill Constructor (color)
Namespaces ► ZedGraph ► Fill ► FillFillNew(Color)
Constructor that creates a solid color-fill, setting Type to Solid, and setting Color to the specified color value.
Declaration Syntax
C# Visual Basic Visual C++
public Fill(
    Color color
)
Public Sub New ( _
    color As Color _
)
public:
Fill (
    Color color
)
Parameters
color (Color)
The color of the solid fill


Fill Constructor (color, brush, type)

Fill Constructor (color, brush, type)
Namespaces ► ZedGraph ► Fill ► FillFillNew(Color, Brush, FillType)
Constructor that specifies the color, brush, and type for this fill.
Declaration Syntax
C# Visual Basic Visual C++
public Fill(
    Color color,
    Brush brush,
    FillType type
)
Public Sub New ( _
    color As Color, _
    brush As Brush, _
    type As FillType _
)
public:
Fill (
    Color color,
    Brush^ brush,
    FillType type
)
Parameters
color (Color)
The color of the fill for solid fills
brush (Brush)
A custom brush for fills. Can be a SolidBrush, LinearGradientBrush, or TextureBrush.
type (FillType)
The FillType for this fill.


Fill Constructor (color1, color2)

Fill Constructor (color1, color2)
Namespaces ► ZedGraph ► Fill ► FillFillNew(Color, Color)
Constructor that creates a linear gradient color-fill, setting Type to Brush using the specified colors.
Declaration Syntax
C# Visual Basic Visual C++
public Fill(
    Color color1,
    Color color2
)
Public Sub New ( _
    color1 As Color, _
    color2 As Color _
)
public:
Fill (
    Color color1,
    Color color2
)
Parameters
color1 (Color)
The first color for the gradient fill
color2 (Color)
The second color for the gradient fill


Fill Constructor (color1, color2, color3)

Fill Constructor (color1, color2, color3)
Namespaces ► ZedGraph ► Fill ► FillFillNew(Color, Color, Color)
Constructor that creates a linear gradient color-fill, setting Type to Brush using the specified colors. This gradient fill consists of three colors.
Declaration Syntax
C# Visual Basic Visual C++
public Fill(
    Color color1,
    Color color2,
    Color color3
)
Public Sub New ( _
    color1 As Color, _
    color2 As Color, _
    color3 As Color _
)
public:
Fill (
    Color color1,
    Color color2,
    Color color3
)
Parameters
color1 (Color)
The first color for the gradient fill
color2 (Color)
The second color for the gradient fill
color3 (Color)
The third color for the gradient fill


Fill Constructor (color1, color2, color3, angle)

Fill Constructor (color1, color2, color3, angle)
Namespaces ► ZedGraph ► Fill ► FillFillNew(Color, Color, Color, Single)
Constructor that creates a linear gradient color-fill, setting Type to Brush using the specified colors. This gradient fill consists of three colors
Declaration Syntax
C# Visual Basic Visual C++
public Fill(
    Color color1,
    Color color2,
    Color color3,
    float angle
)
Public Sub New ( _
    color1 As Color, _
    color2 As Color, _
    color3 As Color, _
    angle As Single _
)
public:
Fill (
    Color color1,
    Color color2,
    Color color3,
    float angle
)
Parameters
color1 (Color)
The first color for the gradient fill
color2 (Color)
The second color for the gradient fill
color3 (Color)
The third color for the gradient fill
angle (Single)
The angle (degrees) of the gradient fill


Fill Constructor (color1, color2, angle)

Fill Constructor (color1, color2, angle)
Namespaces ► ZedGraph ► Fill ► FillFillNew(Color, Color, Single)
Constructor that creates a linear gradient color-fill, setting Type to Brush using the specified colors and angle.
Declaration Syntax
C# Visual Basic Visual C++
public Fill(
    Color color1,
    Color color2,
    float angle
)
Public Sub New ( _
    color1 As Color, _
    color2 As Color, _
    angle As Single _
)
public:
Fill (
    Color color1,
    Color color2,
    float angle
)
Parameters
color1 (Color)
The first color for the gradient fill
color2 (Color)
The second color for the gradient fill
angle (Single)
The angle (degrees) of the gradient fill


Fill Constructor (colors)

Fill Constructor (colors)
Namespaces ► ZedGraph ► Fill ► FillFillNew(array<Color>[]())
Constructor that creates a linear gradient multi-color-fill, setting Type to Brush using the specified colors. This gradient fill consists of many colors based on an array of Color objects, drawn at an angle of zero (degrees). The array is used to create a ColorBlend object assuming a even linear distribution of the colors across the gradient.
Declaration Syntax
C# Visual Basic Visual C++
public Fill(
    Color[] colors
)
Public Sub New ( _
    colors As Color() _
)
public:
Fill (
    array<Color>^ colors
)
Parameters
colors (array< Color >[]())
The array of Color objects that defines the colors along the gradient.


Fill Constructor (colors, angle)

Fill Constructor (colors, angle)
Namespaces ► ZedGraph ► Fill ► FillFillNew(array<Color>[](), Single)
Constructor that creates a linear gradient multi-color-fill, setting Type to Brush using the specified colors. This gradient fill consists of many colors based on an array of Color objects, drawn at the specified angle (degrees). The array is used to create a ColorBlend object assuming a even linear distribution of the colors across the gradient.
Declaration Syntax
C# Visual Basic Visual C++
public Fill(
    Color[] colors,
    float angle
)
Public Sub New ( _
    colors As Color(), _
    angle As Single _
)
public:
Fill (
    array<Color>^ colors,
    float angle
)
Parameters
colors (array< Color >[]())
The array of Color objects that defines the colors along the gradient.
angle (Single)
The angle (degrees) of the gradient fill


Fill Constructor (colors, positions)

Fill Constructor (colors, positions)
Namespaces ► ZedGraph ► Fill ► FillFillNew(array<Color>[](), array<Single>[]())
Constructor that creates a linear gradient multi-color-fill, setting Type to Brush using the specified colors. This gradient fill consists of many colors based on an array of Color objects, drawn at the an angle of zero (degrees). The array is used to create a ColorBlend object assuming a even linear distribution of the colors across the gradient.
Declaration Syntax
C# Visual Basic Visual C++
public Fill(
    Color[] colors,
    float[] positions
)
Public Sub New ( _
    colors As Color(), _
    positions As Single() _
)
public:
Fill (
    array<Color>^ colors,
    array<float>^ positions
)
Parameters
colors (array< Color >[]())
The array of Color objects that defines the colors along the gradient.
positions (array< Single >[]())
The array of floating point values that defines the color positions along the gradient. Values should range from 0 to 1.


Fill Constructor (colors, positions, angle)

Fill Constructor (colors, positions, angle)
Namespaces ► ZedGraph ► Fill ► FillFillNew(array<Color>[](), array<Single>[](), Single)
Constructor that creates a linear gradient multi-color-fill, setting Type to Brush using the specified colors. This gradient fill consists of many colors based on an array of Color objects, drawn at the specified angle (degrees). The array is used to create a ColorBlend object assuming a even linear distribution of the colors across the gradient.
Declaration Syntax
C# Visual Basic Visual C++
public Fill(
    Color[] colors,
    float[] positions,
    float angle
)
Public Sub New ( _
    colors As Color(), _
    positions As Single(), _
    angle As Single _
)
public:
Fill (
    array<Color>^ colors,
    array<float>^ positions,
    float angle
)
Parameters
colors (array< Color >[]())
The array of Color objects that defines the colors along the gradient.
positions (array< Single >[]())
The array of floating point values that defines the color positions along the gradient. Values should range from 0 to 1.
angle (Single)
The angle (degrees) of the gradient fill


Fill Constructor (blend)

Fill Constructor (blend)
Namespaces ► ZedGraph ► Fill ► FillFillNew(ColorBlend)
Constructor that creates a linear gradient multi-color-fill, setting Type to Brush using the specified colors. This gradient fill consists of many colors based on a ColorBlend object. The gradient angle is defaulted to zero.
Declaration Syntax
C# Visual Basic Visual C++
public Fill(
    ColorBlend blend
)
Public Sub New ( _
    blend As ColorBlend _
)
public:
Fill (
    ColorBlend^ blend
)
Parameters
blend (ColorBlend)
The ColorBlend object that defines the colors and positions along the gradient.


Fill Constructor (blend, angle)

Fill Constructor (blend, angle)
Namespaces ► ZedGraph ► Fill ► FillFillNew(ColorBlend, Single)
Constructor that creates a linear gradient multi-color-fill, setting Type to Brush using the specified colors. This gradient fill consists of many colors based on a ColorBlend object, drawn at the specified angle (degrees).
Declaration Syntax
C# Visual Basic Visual C++
public Fill(
    ColorBlend blend,
    float angle
)
Public Sub New ( _
    blend As ColorBlend, _
    angle As Single _
)
public:
Fill (
    ColorBlend^ blend,
    float angle
)
Parameters
blend (ColorBlend)
The ColorBlend object that defines the colors and positions along the gradient.
angle (Single)
The angle (degrees) of the gradient fill


Fill Constructor (image, wrapMode)

Fill Constructor (image, wrapMode)
Namespaces ► ZedGraph ► Fill ► FillFillNew(Image, WrapMode)
Constructor that creates a texture fill, setting Type to Brush and using the specified image.
Declaration Syntax
C# Visual Basic Visual C++
public Fill(
    Image image,
    WrapMode wrapMode
)
Public Sub New ( _
    image As Image, _
    wrapMode As WrapMode _
)
public:
Fill (
    Image^ image,
    WrapMode wrapMode
)
Parameters
image (Image)
The Image to use for filling
wrapMode (WrapMode)
The WrapMode class that controls the image wrapping properties


Fill Constructor (rhs)

Fill Constructor (rhs)
Namespaces ► ZedGraph ► Fill ► FillFillNew(Fill)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public Fill(
    Fill rhs
)
Public Sub New ( _
    rhs As Fill _
)
public:
Fill (
    Fill^ rhs
)
Parameters
rhs (Fill)
The Fill object from which to copy


AlignH Property

AlignH Property
Namespaces ► ZedGraph ► Fill ► AlignH
Determines how the brush will be aligned with the filled object in the horizontal direction. This value is a AlignH enumeration. This field only applies if IsScaled is false.
Declaration Syntax
C# Visual Basic Visual C++
public AlignH AlignH{ get; set;}
Public Property AlignH As AlignH
public:
property AlignH AlignH {
    AlignH get ();
    void set (AlignH value);
}
See Also
AlignV


AlignV Property

AlignV Property
Namespaces ► ZedGraph ► Fill ► AlignV
Determines how the brush will be aligned with the filled object in the vertical direction. This value is a AlignV enumeration. This field only applies if IsScaled is false.
Declaration Syntax
C# Visual Basic Visual C++
public AlignV AlignV{ get; set;}
Public Property AlignV As AlignV
public:
property AlignV AlignV {
    AlignV get ();
    void set (AlignV value);
}
See Also
AlignH


Brush Property

Brush Property
Namespaces ► ZedGraph ► Fill ► Brush
The custom fill brush. This can be a SolidBrush, a LinearGradientBrush, or a TextureBrush. This property is only applicable if the Type property is set to Brush.
Declaration Syntax
C# Visual Basic Visual C++
public Brush Brush{ get; set;}
Public Property Brush As Brush
public:
property Brush^ Brush {
    Brush^ get ();
    void set (Brush^ value);
}


Clone Method

Clone Method
Namespaces ► ZedGraph ► Fill ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public Fill Clone()
Public Function Clone As Fill
public:
Fill^ Clone ()
Return Value
A new, independent copy of this class


Color Property

Color Property
Namespaces ► ZedGraph ► Fill ► Color
The fill color. This property is used as a single color to make a solid fill (Type is Solid), or it can be used in combination with White to make a LinearGradientBrush when Type is Brush and Brush is null.
Declaration Syntax
C# Visual Basic Visual C++
public Color Color{ get; set;}
Public Property Color As Color
public:
property Color Color {
    Color get ();
    void set (Color value);
}
See Also
Type


Draw Method

Draw Method
Namespaces ► ZedGraph ► Fill ► Draw()()
Members
Icon | Member | Description
 | Draw(Graphics, RectangleF) | Fill the background of the RectangleF area, using the fill type from this Fill.
 | Draw(Graphics, RectangleF, PointPair) | Fill the background of the RectangleF area, using the fill type from this Fill.


Draw Method (g, rect)

Draw Method (g, rect)
Namespaces ► ZedGraph ► Fill ► Draw(Graphics, RectangleF)
Fill the background of the RectangleF area, using the fill type from this Fill.
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    RectangleF rect
)
Public Sub Draw ( _
    g As Graphics, _
    rect As RectangleF _
)
public:
void Draw (
    Graphics^ g,
    RectangleF rect
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
rect (RectangleF)
The RectangleF struct specifying the area to be filled


Draw Method (g, rect, pt)

Draw Method (g, rect, pt)
Namespaces ► ZedGraph ► Fill ► Draw(Graphics, RectangleF, PointPair)
Fill the background of the RectangleF area, using the fill type from this Fill.
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    RectangleF rect,
    PointPair pt
)
Public Sub Draw ( _
    g As Graphics, _
    rect As RectangleF, _
    pt As PointPair _
)
public:
void Draw (
    Graphics^ g,
    RectangleF rect,
    PointPair^ pt
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
rect (RectangleF)
The RectangleF struct specifying the area to be filled
pt (PointPair)
The data value to be used in case it's a GradientByX, GradientByY, or GradientByZ FillType.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► Fill ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsGradientValueType Property

IsGradientValueType Property
Namespaces ► ZedGraph ► Fill ► IsGradientValueType
Returns a boolean value indicating whether or not this fill is a "Gradient-By-Value" type. This is true for GradientByX, GradientByY, or GradientByZ.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsGradientValueType{ get;}
Public ReadOnly Property IsGradientValueType As Boolean
public:
property bool IsGradientValueType {
    bool get ();
}
Value
true if this is a Gradient-by-value type, false otherwise
Remarks
The gradient by value fill method allows the fill color for each point or bar to be based on a value for that point (either X, Y, or Z in the IPointList. For example, assume a Fill class is defined with a linear gradient ranging from Blue to Red and the Type is set to GradientByY. If RangeMin is set to 100.0 and RangeMax is set to 200.0, then a point that has a Y value of 100 or less will be colored blue, a point with a Y value of 200 or more will be colored red, and a point between 100 and 200 will have a color based on a linear scale between blue and red. Note that the fill color is always solid for any given point. You can use the Z value from IPointList along with GradientByZ to color individual points according to some property that is independent of the X,Y point pair.
See Also
GradientByX
GradientByY
GradientByZ


IsScaled Property

IsScaled Property
Namespaces ► ZedGraph ► Fill ► IsScaled
Determines if the brush will be scaled to the bounding box of the filled object. If this value is false, then the brush will only be aligned with the filled object based on the AlignH and AlignV properties.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsScaled{ get; set;}
Public Property IsScaled As Boolean
public:
property bool IsScaled {
    bool get ();
    void set (bool value);
}


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph ► Fill ► IsVisible
This property determines the type of color fill. Returns true if the Type property is either Solid or Brush. If set to true, this property will automatically set the Type to Brush. If set to false, this property will automatically set the Type to None. In order to get a regular solid-color fill, you have to manually set Type to Solid.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
See Also
Color
Brush
Type


MakeBrush Method

MakeBrush Method
Namespaces ► ZedGraph ► Fill ► MakeBrush()()
Members
Icon | Member | Description
 | MakeBrush(RectangleF) | Create a fill brush using current properties. This method will construct a brush based on the settings of Type, Color and Brush. If Type is set to Brush and Brush is null, then a LinearGradientBrush will be created between the colors of White and Color.
 | MakeBrush(RectangleF, PointPair) | Create a fill brush using current properties. This method will construct a brush based on the settings of Type, Color and Brush. If Type is set to Brush and Brush is null, then a LinearGradientBrush will be created between the colors of White and Color.


MakeBrush Method (rect)

MakeBrush Method (rect)
Namespaces ► ZedGraph ► Fill ► MakeBrush(RectangleF)
Create a fill brush using current properties. This method will construct a brush based on the settings of Type, Color and Brush. If Type is set to Brush and Brush is null, then a LinearGradientBrush will be created between the colors of White and Color.
Declaration Syntax
C# Visual Basic Visual C++
public Brush MakeBrush(
    RectangleF rect
)
Public Function MakeBrush ( _
    rect As RectangleF _
) As Brush
public:
Brush^ MakeBrush (
    RectangleF rect
)
Parameters
rect (RectangleF)
A rectangle that bounds the object to be filled. This determines the start and end of the gradient fill.
Return Value
A Brush class representing the fill brush


MakeBrush Method (rect, dataValue)

MakeBrush Method (rect, dataValue)
Namespaces ► ZedGraph ► Fill ► MakeBrush(RectangleF, PointPair)
Create a fill brush using current properties. This method will construct a brush based on the settings of Type, Color and Brush. If Type is set to Brush and Brush is null, then a LinearGradientBrush will be created between the colors of White and Color.
Declaration Syntax
C# Visual Basic Visual C++
public Brush MakeBrush(
    RectangleF rect,
    PointPair dataValue
)
Public Function MakeBrush ( _
    rect As RectangleF, _
    dataValue As PointPair _
) As Brush
public:
Brush^ MakeBrush (
    RectangleF rect,
    PointPair^ dataValue
)
Parameters
rect (RectangleF)
A rectangle that bounds the object to be filled. This determines the start and end of the gradient fill.
dataValue (PointPair)
The data value to be used for a value-based color gradient. This is only applicable for GradientByX, GradientByY or GradientByZ.
Return Value
A Brush class representing the fill brush


RangeDefault Property

RangeDefault Property
Namespaces ► ZedGraph ► Fill ► RangeDefault
The default user-scale value for the gradient-by-value determination. This defines the value that will be used when there is no point value available, or the actual point value is invalid.
Declaration Syntax
C# Visual Basic Visual C++
public double RangeDefault{ get; set;}
Public Property RangeDefault As Double
public:
property double RangeDefault {
    double get ();
    void set (double value);
}
Value
A double value, in user scale unit
Remarks
Note that this value, when defined, will determine the color that is used in the legend. If this value is set to double.MaxValue, then it remains "undefined." In this case, the legend symbols will actually be filled with a color gradient representing the range of colors.
See Also
GradientByX
GradientByY
GradientByZ
IsGradientValueType
RangeMin
RangeMax


RangeMax Property

RangeMax Property
Namespaces ► ZedGraph ► Fill ► RangeMax
The maximum user-scale value for the gradient-by-value determination. This defines the user-scale value for the end of the gradient.
Declaration Syntax
C# Visual Basic Visual C++
public double RangeMax{ get; set;}
Public Property RangeMax As Double
public:
property double RangeMax {
    double get ();
    void set (double value);
}
Value
A double value, in user scale unit
See Also
GradientByX
GradientByY
GradientByZ
IsGradientValueType
RangeMin
RangeDefault


RangeMin Property

RangeMin Property
Namespaces ► ZedGraph ► Fill ► RangeMin
The minimum user-scale value for the gradient-by-value determination. This defines the user-scale value for the start of the gradient.
Declaration Syntax
C# Visual Basic Visual C++
public double RangeMin{ get; set;}
Public Property RangeMin As Double
public:
property double RangeMin {
    double get ();
    void set (double value);
}
Value
A double value, in user scale unit
See Also
GradientByX
GradientByY
GradientByZ
IsGradientValueType
RangeMax
RangeDefault


schema Field

schema Field
Namespaces ► ZedGraph ► Fill ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


SecondaryValueGradientColor Property

SecondaryValueGradientColor Property
Namespaces ► ZedGraph ► Fill ► SecondaryValueGradientColor
Gets or sets the secondary color for gradientByValue fills.
Declaration Syntax
C# Visual Basic Visual C++
public Color SecondaryValueGradientColor{ get; set;}
Public Property SecondaryValueGradientColor As Color
public:
property Color SecondaryValueGradientColor {
    Color get ();
    void set (Color value);
}
Remarks
This property is only applicable if the Type is GradientByX, GradientByY, or GradientByZ. Once the gradient-by-value logic picks a color, a new gradient will be created using the SecondaryValueGradientColor, the resulting gradient-by-value color, and the angle setting for this Fill. Use a value of Color.Empty to have a solid-color Fill resulting from a gradient-by-value FillType.


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► Fill ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Type Property

Type Property
Namespaces ► ZedGraph ► Fill ► Type
Determines the type of fill, which can be either solid color (Solid) or a custom brush (Brush). See Type for more information.
Declaration Syntax
C# Visual Basic Visual C++
public FillType Type{ get; set;}
Public Property Type As FillType
public:
property FillType Type {
    FillType get ();
    void set (FillType value);
}
See Also
Color


Fill.Default Structure

Fill..::Default Structure
Namespaces ► ZedGraph ► Fill ► Fill..::Default
A simple struct that defines the default property values for the Fill class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AlignH | The default horizontal alignment for Brush fills. This is the default value for the AlignH property.
 | AlignV | The default vertical alignment for Brush fills. This is the default value for the AlignV property.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsScaled | The default scaling mode for Brush fills. This is the default value for the IsScaled property.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


AlignH Field

AlignH Field
Namespaces ► ZedGraph ► Fill..::Default ► AlignH
The default horizontal alignment for Brush fills. This is the default value for the AlignH property.
Declaration Syntax
C# Visual Basic Visual C++
public static AlignH AlignH
Public Shared AlignH As AlignH
public:
static AlignH AlignH


AlignV Field

AlignV Field
Namespaces ► ZedGraph ► Fill..::Default ► AlignV
The default vertical alignment for Brush fills. This is the default value for the AlignV property.
Declaration Syntax
C# Visual Basic Visual C++
public static AlignV AlignV
Public Shared AlignV As AlignV
public:
static AlignV AlignV


IsScaled Field

IsScaled Field
Namespaces ► ZedGraph ► Fill..::Default ► IsScaled
The default scaling mode for Brush fills. This is the default value for the IsScaled property.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsScaled
Public Shared IsScaled As Boolean
public:
static bool IsScaled


FillType Enumeration

FillType Enumeration
Namespaces ► ZedGraph ► FillType
Enumeration type for the various types of fills that can be used with Bar charts.
Declaration Syntax
C# Visual Basic Visual C++
public enum FillType
Public Enumeration FillType
public enum class FillType
Members
Member | Description
None | No fill
Solid | A solid fill using SolidBrush
Brush | A custom fill using either LinearGradientBrush or TextureBrush
GradientByX | Fill with a single solid color based on the X value of the data.
GradientByY | Fill with a single solid color based on the Z value of the data.
GradientByZ | Fill with a single solid color based on the Z value of the data.
GradientByColorValue | Fill with a single solid color based on the "ColorValue" property of the data.


FilteredPointList Class

FilteredPointList Class
Namespaces ► ZedGraph ► FilteredPointList
An example of an IPointList implementation that stores large datasets, and selectively filters the output data depending on the displayed range.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FilteredPointList : IPointList,
    ICloneable
<SerializableAttribute> _
Public Class FilteredPointList _
    Implements IPointList, ICloneable
[SerializableAttribute]
public ref class FilteredPointList : IPointList,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FilteredPointListFilteredPointListNew(array<Double>[](), array<Double>[]()) | Constructor to initialize the PointPairList from two arrays of type double.
 | FilteredPointListFilteredPointListNew(FilteredPointList) | The Copy Constructor
 | Clone()() | Deep-copy clone routine
 | Count | Returns the number of points according to the current state of the filter.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsApplyHighLowLogic | Gets or sets a value that determines if the High-Low filtering logic will be applied.
 | Item[([Int32])] | Indexer to access the specified PointPair object by its ordinal position in the list.
 | MaxPts | Gets the desired number of filtered points to output. You can set this value by calling SetBounds(Double, Double, Int32).
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetBounds(Double, Double, Int32) | Set the data bounds to the specified minimum, maximum, and point count. Use values of min=double.MinValue and max=double.MaxValue to get the full range of data. Use maxPts=-1 to not limit the number of points. Call this method anytime the zoom range is changed.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This class will refilter the data points each time SetBounds(Double, Double, Int32) is called. The data are filtered down to MaxPts points, within the data bounds of a minimum and maximum data range. The data are filtered by simply skipping points to achieve the desired total number of points. Input arrays are assumed to be monotonically increasing in X, and evenly spaced in X.
Inheritance Hierarchy
Object
FilteredPointList
See Also
PointPairList
BasicArrayPointList
IPointList
IPointListEdit


FilteredPointList Constructor

FilteredPointList Constructor
Namespaces ► ZedGraph ► FilteredPointList ► FilteredPointListFilteredPointListNew()()
Members
Icon | Member | Description
 | FilteredPointListFilteredPointListNew(array<Double>[](), array<Double>[]()) | Constructor to initialize the PointPairList from two arrays of type double.
 | FilteredPointListFilteredPointListNew(FilteredPointList) | The Copy Constructor


FilteredPointList Constructor (x, y)

FilteredPointList Constructor (x, y)
Namespaces ► ZedGraph ► FilteredPointList ► FilteredPointListFilteredPointListNew(array<Double>[](), array<Double>[]())
Constructor to initialize the PointPairList from two arrays of type double.
Declaration Syntax
C# Visual Basic Visual C++
public FilteredPointList(
    double[] x,
    double[] y
)
Public Sub New ( _
    x As Double(), _
    y As Double() _
)
public:
FilteredPointList (
    array<double>^ x,
    array<double>^ y
)
Parameters
x (array< Double >[]())
y (array< Double >[]())


FilteredPointList Constructor (rhs)

FilteredPointList Constructor (rhs)
Namespaces ► ZedGraph ► FilteredPointList ► FilteredPointListFilteredPointListNew(FilteredPointList)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public FilteredPointList(
    FilteredPointList rhs
)
Public Sub New ( _
    rhs As FilteredPointList _
)
public:
FilteredPointList (
    FilteredPointList^ rhs
)
Parameters
rhs (FilteredPointList)
The FilteredPointList from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► FilteredPointList ► Clone()()
Deep-copy clone routine
Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Clone()
Public Overridable Function Clone As Object
public:
virtual Object^ Clone ()
Return Value
A new, independent copy of the FilteredPointList


Count Property

Count Property
Namespaces ► ZedGraph ► FilteredPointList ► Count
Returns the number of points according to the current state of the filter.
Declaration Syntax
C# Visual Basic Visual C++
public int Count{ get;}
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}


IsApplyHighLowLogic Property

IsApplyHighLowLogic Property
Namespaces ► ZedGraph ► FilteredPointList ► IsApplyHighLowLogic
Gets or sets a value that determines if the High-Low filtering logic will be applied.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsApplyHighLowLogic{ get; set;}
Public Property IsApplyHighLowLogic As Boolean
public:
property bool IsApplyHighLowLogic {
    bool get ();
    void set (bool value);
}
Remarks
The high-low filtering logic alternately takes the highest or lowest Y value within the subrange of points to be skipped. Set this value to true to apply this logic, or false to just use whatever value lies in the middle of the skipped range.


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph ► FilteredPointList ► Item[([Int32])]
Indexer to access the specified PointPair object by its ordinal position in the list.
Declaration Syntax
C# Visual Basic Visual C++
public PointPair this[
    int index
]{ get;}
Public ReadOnly Default Property Item ( _
    index As Integer _
) As PointPair
public:
virtual property PointPair^ default[int index] {
    PointPair^ get (int index) sealed;
}
Parameters
index (Int32)
The ordinal position (zero-based) of the PointPair object to be accessed.
Value
A PointPair object reference.
Remarks
Returns Missing for any value of that is outside of its corresponding array bounds.


MaxPts Property

MaxPts Property
Namespaces ► ZedGraph ► FilteredPointList ► MaxPts
Gets the desired number of filtered points to output. You can set this value by calling SetBounds(Double, Double, Int32).
Declaration Syntax
C# Visual Basic Visual C++
public int MaxPts{ get;}
Public ReadOnly Property MaxPts As Integer
public:
property int MaxPts {
    int get ();
}


SetBounds Method (min, max, maxPts)

SetBounds Method (min, max, maxPts)
Namespaces ► ZedGraph ► FilteredPointList ► SetBounds(Double, Double, Int32)
Set the data bounds to the specified minimum, maximum, and point count. Use values of min=double.MinValue and max=double.MaxValue to get the full range of data. Use maxPts=-1 to not limit the number of points. Call this method anytime the zoom range is changed.
Declaration Syntax
C# Visual Basic Visual C++
public void SetBounds(
    double min,
    double max,
    int maxPts
)
Public Sub SetBounds ( _
    min As Double, _
    max As Double, _
    maxPts As Integer _
)
public:
void SetBounds (
    double min,
    double max,
    int maxPts
)
Parameters
min (Double)
The lower bound for the X data of interest
max (Double)
The upper bound for the X data of interest
maxPts (Int32)
The maximum number of points allowed to be output by the filter


FontSpec Class

FontSpec Class
Namespaces ► ZedGraph ► FontSpec
The FontSpec class is a generic font class that maintains the font family, attributes, colors, border and fill modes, font size, and angle information. This class can render text with a variety of alignment options using the AlignH and AlignV parameters in the Draw(Graphics, PaneBase, String, Single, Single, AlignH, AlignV, Single) method.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FontSpec : ICloneable, ISerializable
<SerializableAttribute> _
Public Class FontSpec _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class FontSpec : ICloneable,
    ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FontSpecFontSpecNew()() | Construct a FontSpec object with default properties.
 | FontSpecFontSpecNew(String, Single, Color, Boolean, Boolean, Boolean) | Construct a FontSpec object with the given properties. All other properties are defaulted according to the values specified in the FontSpec..::Default default class.
 | FontSpecFontSpecNew(String, Single, Color, Boolean, Boolean, Boolean, Color, Brush, FillType) | Construct a FontSpec object with the given properties. All other properties are defaulted according to the values specified in the FontSpec..::Default default class.
 | FontSpecFontSpecNew(FontSpec) | The Copy Constructor
 | Angle | The angle at which this FontSpec object is drawn.
 | Border | Gets or sets the Border class used to draw the border border around this text.
 | BoundingBox(Graphics, String, Single) | Get a SizeF struct representing the width and height of the bounding box for the specified text string, based on the scaled font size.
 | BoundingBox(Graphics, String, Single, SizeF) | Get a SizeF struct representing the width and height of the bounding box for the specified text string, based on the scaled font size.
 | BoundingBoxTenPower(Graphics, String, Single) | Get a SizeF struct representing the width and height of the bounding box for the specified text string, based on the scaled font size.
 | Clone()() | Typesafe, deep-copy clone method.
 | Draw(Graphics, PaneBase, String, Single, Single, AlignH, AlignV, Single) | Render the specified text to the specifed Graphics device. The text, border, and fill options will be rendered as required.
 | Draw(Graphics, PaneBase, String, Single, Single, AlignH, AlignV, Single, SizeF) | Render the specified text to the specifed Graphics device. The text, border, and fill options will be rendered as required.
 | DrawTenPower(Graphics, GraphPane, String, Single, Single, AlignH, AlignV, Single) | Render the specified text to the specifed Graphics device. The text, border, and fill options will be rendered as required. This special case method will show the specified text as a power of 10, using the SuperSize and SuperShift.
 | DropShadowAngle | Gets or sets the offset angle of the drop shadow for this FontSpec.
 | DropShadowColor | Gets or sets the color of the drop shadow for this FontSpec.
 | DropShadowOffset | Gets or sets the offset distance of the drop shadow for this FontSpec.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Family | The font family name for this FontSpec.
 | Fill | Gets or sets the Fill data for this FontSpec, which controls how the background behind the text is filled.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontColor | The color of the font characters for this FontSpec. Note that the border and background colors are set using the Color and Color properties, respectively.
 | GetBox(Graphics, String, Single, Single, AlignH, AlignV, Single, SizeF) | Returns a polygon that defines the bounding box of the text, taking into account alignment and rotation parameters.
 | GetFont(Single) | Get the Font class for the current scaled font.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetHeight(Single) | Get the height of the scaled font
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWidth(Graphics, Single) | Get the average character width of the scaled font. The average width is based on the character 'x'
 | GetWidth(Graphics, String, Single) | Get the total width of the specified text string
 | IsAntiAlias | Gets or sets a value that determines if the FontSpec will be drawn using anti-aliasing logic within GDI+.
 | IsBold | Determines whether this FontSpec is drawn with bold typeface.
 | IsDropShadow | Gets or sets a value that determines if the FontSpec will be displayed with a drop shadow.
 | IsItalic | Determines whether this FontSpec is drawn with italic typeface.
 | IsUnderline | Determines whether this FontSpec is drawn with underlined typeface.
 | MeasureString(Graphics, String, Single) | Get a SizeF struct representing the width and height of the specified text string, based on the scaled font size
 | MeasureString(Graphics, String, Single, SizeF) | Get a SizeF struct representing the width and height of the specified text string, based on the scaled font size, and using the specified SizeF as an outer limit.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PointInBox(PointF, Graphics, String, Single, Single, AlignH, AlignV, Single) | Determines if the specified screen point lies within the bounding box of the text, taking into account alignment and rotation parameters.
 | PointInBox(PointF, Graphics, String, Single, Single, AlignH, AlignV, Single, SizeF) | Determines if the specified screen point lies within the bounding box of the text, taking into account alignment and rotation parameters.
 | schema | Current schema value that defines the version of the serialized file
 | Size | The size of the font for this FontSpec object.
 | StringAlignment | Determines the alignment with which this FontSpec object is drawn. This alignment really only affects multi-line strings.
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FontSpec


FontSpec Constructor

FontSpec Constructor
Namespaces ► ZedGraph ► FontSpec ► FontSpecFontSpecNew()()
Members
Icon | Member | Description
 | FontSpecFontSpecNew()() | Construct a FontSpec object with default properties.
 | FontSpecFontSpecNew(String, Single, Color, Boolean, Boolean, Boolean) | Construct a FontSpec object with the given properties. All other properties are defaulted according to the values specified in the FontSpec..::Default default class.
 | FontSpecFontSpecNew(String, Single, Color, Boolean, Boolean, Boolean, Color, Brush, FillType) | Construct a FontSpec object with the given properties. All other properties are defaulted according to the values specified in the FontSpec..::Default default class.
 | FontSpecFontSpecNew(FontSpec) | The Copy Constructor


FontSpec Constructor

FontSpec Constructor
Namespaces ► ZedGraph ► FontSpec ► FontSpecFontSpecNew()()
Construct a FontSpec object with default properties.
Declaration Syntax
C# Visual Basic Visual C++
public FontSpec()
Public Sub New
public:
FontSpec ()


FontSpec Constructor (family, size, color, isBold, isItalic, isUnderline)

FontSpec Constructor (family, size, color, isBold, isItalic, isUnderline)
Namespaces ► ZedGraph ► FontSpec ► FontSpecFontSpecNew(String, Single, Color, Boolean, Boolean, Boolean)
Construct a FontSpec object with the given properties. All other properties are defaulted according to the values specified in the FontSpec..::Default default class.
Declaration Syntax
C# Visual Basic Visual C++
public FontSpec(
    string family,
    float size,
    Color color,
    bool isBold,
    bool isItalic,
    bool isUnderline
)
Public Sub New ( _
    family As String, _
    size As Single, _
    color As Color, _
    isBold As Boolean, _
    isItalic As Boolean, _
    isUnderline As Boolean _
)
public:
FontSpec (
    String^ family,
    float size,
    Color color,
    bool isBold,
    bool isItalic,
    bool isUnderline
)
Parameters
family (String)
A text string representing the font family (default is "Arial")
size (Single)
A size of the font in points. This size will be scaled based on the ratio of the Rect dimension to the BaseDimension of the GraphPane object.
color (Color)
The color with which to render the font
isBold (Boolean)
true for a bold typeface, false otherwise
isItalic (Boolean)
true for an italic typeface, false otherwise
isUnderline (Boolean)
true for an underlined font, false otherwise


FontSpec Constructor (family, size, color, isBold, isItalic, isUnderline, fillColor, fillBrush, fillType)

FontSpec Constructor (family, size, color, isBold, isItalic, isUnderline, fillColor, fillBrush, fillType)
Namespaces ► ZedGraph ► FontSpec ► FontSpecFontSpecNew(String, Single, Color, Boolean, Boolean, Boolean, Color, Brush, FillType)
Construct a FontSpec object with the given properties. All other properties are defaulted according to the values specified in the FontSpec..::Default default class.
Declaration Syntax
C# Visual Basic Visual C++
public FontSpec(
    string family,
    float size,
    Color color,
    bool isBold,
    bool isItalic,
    bool isUnderline,
    Color fillColor,
    Brush fillBrush,
    FillType fillType
)
Public Sub New ( _
    family As String, _
    size As Single, _
    color As Color, _
    isBold As Boolean, _
    isItalic As Boolean, _
    isUnderline As Boolean, _
    fillColor As Color, _
    fillBrush As Brush, _
    fillType As FillType _
)
public:
FontSpec (
    String^ family,
    float size,
    Color color,
    bool isBold,
    bool isItalic,
    bool isUnderline,
    Color fillColor,
    Brush^ fillBrush,
    FillType fillType
)
Parameters
family (String)
A text string representing the font family (default is "Arial")
size (Single)
A size of the font in points. This size will be scaled based on the ratio of the Rect dimension to the BaseDimension of the GraphPane object.
color (Color)
The color with which to render the font
isBold (Boolean)
true for a bold typeface, false otherwise
isItalic (Boolean)
true for an italic typeface, false otherwise
isUnderline (Boolean)
true for an underlined font, false otherwise
fillColor (Color)
The Color to use for filling in the text background
fillBrush (Brush)
The Brush to use for filling in the text background
fillType (FillType)
The FillType to use for the text background


FontSpec Constructor (rhs)

FontSpec Constructor (rhs)
Namespaces ► ZedGraph ► FontSpec ► FontSpecFontSpecNew(FontSpec)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public FontSpec(
    FontSpec rhs
)
Public Sub New ( _
    rhs As FontSpec _
)
public:
FontSpec (
    FontSpec^ rhs
)
Parameters
rhs (FontSpec)
The FontSpec object from which to copy


Angle Property

Angle Property
Namespaces ► ZedGraph ► FontSpec ► Angle
The angle at which this FontSpec object is drawn.
Declaration Syntax
C# Visual Basic Visual C++
public float Angle{ get; set;}
Public Property Angle As Single
public:
property float Angle {
    float get ();
    void set (float value);
}
Value
The angle of the font, measured in anti-clockwise degrees from horizontal. Negative values are permitted.


Border Property

Border Property
Namespaces ► ZedGraph ► FontSpec ► Border
Gets or sets the Border class used to draw the border border around this text.
Declaration Syntax
C# Visual Basic Visual C++
public Border Border{ get; set;}
Public Property Border As Border
public:
property Border^ Border {
    Border^ get ();
    void set (Border^ value);
}


BoundingBox Method

BoundingBox Method
Namespaces ► ZedGraph ► FontSpec ► BoundingBox()()
Members
Icon | Member | Description
 | BoundingBox(Graphics, String, Single) | Get a SizeF struct representing the width and height of the bounding box for the specified text string, based on the scaled font size.
 | BoundingBox(Graphics, String, Single, SizeF) | Get a SizeF struct representing the width and height of the bounding box for the specified text string, based on the scaled font size.


BoundingBox Method (g, text, scaleFactor)

BoundingBox Method (g, text, scaleFactor)
Namespaces ► ZedGraph ► FontSpec ► BoundingBox(Graphics, String, Single)
Get a SizeF struct representing the width and height of the bounding box for the specified text string, based on the scaled font size.
Declaration Syntax
C# Visual Basic Visual C++
public SizeF BoundingBox(
    Graphics g,
    string text,
    float scaleFactor
)
Public Function BoundingBox ( _
    g As Graphics, _
    text As String, _
    scaleFactor As Single _
) As SizeF
public:
SizeF BoundingBox (
    Graphics^ g,
    String^ text,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
text (String)
The text string for which the width is to be calculated
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
The scaled text dimensions, in pixels, in the form of a SizeF struct
Remarks
This routine differs from MeasureString(Graphics, String, Single) in that it takes into account the rotation angle of the font, and gives the dimensions of the bounding box that encloses the text at the specified angle.


BoundingBox Method (g, text, scaleFactor, layoutArea)

BoundingBox Method (g, text, scaleFactor, layoutArea)
Namespaces ► ZedGraph ► FontSpec ► BoundingBox(Graphics, String, Single, SizeF)
Get a SizeF struct representing the width and height of the bounding box for the specified text string, based on the scaled font size.
Declaration Syntax
C# Visual Basic Visual C++
public SizeF BoundingBox(
    Graphics g,
    string text,
    float scaleFactor,
    SizeF layoutArea
)
Public Function BoundingBox ( _
    g As Graphics, _
    text As String, _
    scaleFactor As Single, _
    layoutArea As SizeF _
) As SizeF
public:
SizeF BoundingBox (
    Graphics^ g,
    String^ text,
    float scaleFactor,
    SizeF layoutArea
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
text (String)
The text string for which the width is to be calculated
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
layoutArea (SizeF)
The limiting area (SizeF) into which the text must fit. The actual rectangle may be smaller than this, but the text will be wrapped to accomodate the area.
Return Value
The scaled text dimensions, in pixels, in the form of a SizeF struct
Remarks
This routine differs from MeasureString(Graphics, String, Single) in that it takes into account the rotation angle of the font, and gives the dimensions of the bounding box that encloses the text at the specified angle.


BoundingBoxTenPower Method (g, text, scaleFactor)

BoundingBoxTenPower Method (g, text, scaleFactor)
Namespaces ► ZedGraph ► FontSpec ► BoundingBoxTenPower(Graphics, String, Single)
Get a SizeF struct representing the width and height of the bounding box for the specified text string, based on the scaled font size.
Declaration Syntax
C# Visual Basic Visual C++
public SizeF BoundingBoxTenPower(
    Graphics g,
    string text,
    float scaleFactor
)
Public Function BoundingBoxTenPower ( _
    g As Graphics, _
    text As String, _
    scaleFactor As Single _
) As SizeF
public:
SizeF BoundingBoxTenPower (
    Graphics^ g,
    String^ text,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
text (String)
The text string for which the width is to be calculated
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
The scaled text dimensions, in pixels, in the form of a SizeF struct
Remarks
This special case method will show the specified string as a power of 10, superscripted and downsized according to the SuperSize and SuperShift. This routine differs from MeasureString(Graphics, String, Single) in that it takes into account the rotation angle of the font, and gives the dimensions of the bounding box that encloses the text at the specified angle.


Clone Method

Clone Method
Namespaces ► ZedGraph ► FontSpec ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public FontSpec Clone()
Public Function Clone As FontSpec
public:
FontSpec^ Clone ()
Return Value
A new, independent copy of this class


Draw Method

Draw Method
Namespaces ► ZedGraph ► FontSpec ► Draw()()
Members
Icon | Member | Description
 | Draw(Graphics, PaneBase, String, Single, Single, AlignH, AlignV, Single) | Render the specified text to the specifed Graphics device. The text, border, and fill options will be rendered as required.
 | Draw(Graphics, PaneBase, String, Single, Single, AlignH, AlignV, Single, SizeF) | Render the specified text to the specifed Graphics device. The text, border, and fill options will be rendered as required.


Draw Method (g, pane, text, x, y, alignH, alignV, scaleFactor)

Draw Method (g, pane, text, x, y, alignH, alignV, scaleFactor)
Namespaces ► ZedGraph ► FontSpec ► Draw(Graphics, PaneBase, String, Single, Single, AlignH, AlignV, Single)
Render the specified text to the specifed Graphics device. The text, border, and fill options will be rendered as required.
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    PaneBase pane,
    string text,
    float x,
    float y,
    AlignH alignH,
    AlignV alignV,
    float scaleFactor
)
Public Sub Draw ( _
    g As Graphics, _
    pane As PaneBase, _
    text As String, _
    x As Single, _
    y As Single, _
    alignH As AlignH, _
    alignV As AlignV, _
    scaleFactor As Single _
)
public:
void Draw (
    Graphics^ g,
    PaneBase^ pane,
    String^ text,
    float x,
    float y,
    AlignH alignH,
    AlignV alignV,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
text (String)
A string value containing the text to be displayed. This can be multiple lines, separated by newline ('\n') characters
x (Single)
The X location to display the text, in screen coordinates, relative to the horizontal (AlignH) alignment parameter alignH
y (Single)
The Y location to display the text, in screen coordinates, relative to the vertical (AlignV alignment parameter alignV
alignH (AlignH)
A horizontal alignment parameter specified using the AlignH enum type
alignV (AlignV)
A vertical alignment parameter specified using the AlignV enum type
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


Draw Method (g, pane, text, x, y, alignH, alignV, scaleFactor, layoutArea)

Draw Method (g, pane, text, x, y, alignH, alignV, scaleFactor, layoutArea)
Namespaces ► ZedGraph ► FontSpec ► Draw(Graphics, PaneBase, String, Single, Single, AlignH, AlignV, Single, SizeF)
Render the specified text to the specifed Graphics device. The text, border, and fill options will be rendered as required.
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    PaneBase pane,
    string text,
    float x,
    float y,
    AlignH alignH,
    AlignV alignV,
    float scaleFactor,
    SizeF layoutArea
)
Public Sub Draw ( _
    g As Graphics, _
    pane As PaneBase, _
    text As String, _
    x As Single, _
    y As Single, _
    alignH As AlignH, _
    alignV As AlignV, _
    scaleFactor As Single, _
    layoutArea As SizeF _
)
public:
void Draw (
    Graphics^ g,
    PaneBase^ pane,
    String^ text,
    float x,
    float y,
    AlignH alignH,
    AlignV alignV,
    float scaleFactor,
    SizeF layoutArea
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
text (String)
A string value containing the text to be displayed. This can be multiple lines, separated by newline ('\n') characters
x (Single)
The X location to display the text, in screen coordinates, relative to the horizontal (AlignH) alignment parameter alignH
y (Single)
The Y location to display the text, in screen coordinates, relative to the vertical (AlignV alignment parameter alignV
alignH (AlignH)
A horizontal alignment parameter specified using the AlignH enum type
alignV (AlignV)
A vertical alignment parameter specified using the AlignV enum type
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
layoutArea (SizeF)
The limiting area (SizeF) into which the text must fit. The actual rectangle may be smaller than this, but the text will be wrapped to accomodate the area.


DrawTenPower Method (g, pane, text, x, y, alignH, alignV, scaleFactor)

DrawTenPower Method (g, pane, text, x, y, alignH, alignV, scaleFactor)
Namespaces ► ZedGraph ► FontSpec ► DrawTenPower(Graphics, GraphPane, String, Single, Single, AlignH, AlignV, Single)
Render the specified text to the specifed Graphics device. The text, border, and fill options will be rendered as required. This special case method will show the specified text as a power of 10, using the SuperSize and SuperShift.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawTenPower(
    Graphics g,
    GraphPane pane,
    string text,
    float x,
    float y,
    AlignH alignH,
    AlignV alignV,
    float scaleFactor
)
Public Sub DrawTenPower ( _
    g As Graphics, _
    pane As GraphPane, _
    text As String, _
    x As Single, _
    y As Single, _
    alignH As AlignH, _
    alignV As AlignV, _
    scaleFactor As Single _
)
public:
void DrawTenPower (
    Graphics^ g,
    GraphPane^ pane,
    String^ text,
    float x,
    float y,
    AlignH alignH,
    AlignV alignV,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
text (String)
A string value containing the text to be displayed. This can be multiple lines, separated by newline ('\n') characters
x (Single)
The X location to display the text, in screen coordinates, relative to the horizontal (AlignH) alignment parameter alignH
y (Single)
The Y location to display the text, in screen coordinates, relative to the vertical (AlignV alignment parameter alignV
alignH (AlignH)
A horizontal alignment parameter specified using the AlignH enum type
alignV (AlignV)
A vertical alignment parameter specified using the AlignV enum type
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


DropShadowAngle Property

DropShadowAngle Property
Namespaces ► ZedGraph ► FontSpec ► DropShadowAngle
Gets or sets the offset angle of the drop shadow for this FontSpec.
Declaration Syntax
C# Visual Basic Visual C++
public float DropShadowAngle{ get; set;}
Public Property DropShadowAngle As Single
public:
property float DropShadowAngle {
    float get ();
    void set (float value);
}
Value
The angle, measured in anti-clockwise degrees from horizontal. Negative values are permitted.
Remarks
This value only applies if IsDropShadow is true.
See Also
IsDropShadow
DropShadowColor
DropShadowOffset


DropShadowColor Property

DropShadowColor Property
Namespaces ► ZedGraph ► FontSpec ► DropShadowColor
Gets or sets the color of the drop shadow for this FontSpec.
Declaration Syntax
C# Visual Basic Visual C++
public Color DropShadowColor{ get; set;}
Public Property DropShadowColor As Color
public:
property Color DropShadowColor {
    Color get ();
    void set (Color value);
}
Remarks
This value only applies if IsDropShadow is true.
See Also
IsDropShadow
DropShadowAngle
DropShadowOffset


DropShadowOffset Property

DropShadowOffset Property
Namespaces ► ZedGraph ► FontSpec ► DropShadowOffset
Gets or sets the offset distance of the drop shadow for this FontSpec.
Declaration Syntax
C# Visual Basic Visual C++
public float DropShadowOffset{ get; set;}
Public Property DropShadowOffset As Single
public:
property float DropShadowOffset {
    float get ();
    void set (float value);
}
Value
The offset distance, measured as a fraction of the scaled font height.
Remarks
This value only applies if IsDropShadow is true.
See Also
IsDropShadow
DropShadowColor
DropShadowAngle


Family Property

Family Property
Namespaces ► ZedGraph ► FontSpec ► Family
The font family name for this FontSpec.
Declaration Syntax
C# Visual Basic Visual C++
public string Family{ get; set;}
Public Property Family As String
public:
property String^ Family {
    String^ get ();
    void set (String^ value);
}
Value
A text string with the font family name, e.g., "Arial"


Fill Property

Fill Property
Namespaces ► ZedGraph ► FontSpec ► Fill
Gets or sets the Fill data for this FontSpec, which controls how the background behind the text is filled.
Declaration Syntax
C# Visual Basic Visual C++
public Fill Fill{ get; set;}
Public Property Fill As Fill
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}


FontColor Property

FontColor Property
Namespaces ► ZedGraph ► FontSpec ► FontColor
The color of the font characters for this FontSpec. Note that the border and background colors are set using the Color and Color properties, respectively.
Declaration Syntax
C# Visual Basic Visual C++
public Color FontColor{ get; set;}
Public Property FontColor As Color
public:
property Color FontColor {
    Color get ();
    void set (Color value);
}
Value
A system Color reference.


GetBox Method (g, text, x, y, alignH, alignV, scaleFactor, layoutArea)

GetBox Method (g, text, x, y, alignH, alignV, scaleFactor, layoutArea)
Namespaces ► ZedGraph ► FontSpec ► GetBox(Graphics, String, Single, Single, AlignH, AlignV, Single, SizeF)
Returns a polygon that defines the bounding box of the text, taking into account alignment and rotation parameters.
Declaration Syntax
C# Visual Basic Visual C++
public PointF[] GetBox(
    Graphics g,
    string text,
    float x,
    float y,
    AlignH alignH,
    AlignV alignV,
    float scaleFactor,
    SizeF layoutArea
)
Public Function GetBox ( _
    g As Graphics, _
    text As String, _
    x As Single, _
    y As Single, _
    alignH As AlignH, _
    alignV As AlignV, _
    scaleFactor As Single, _
    layoutArea As SizeF _
) As PointF()
public:
array<PointF>^ GetBox (
    Graphics^ g,
    String^ text,
    float x,
    float y,
    AlignH alignH,
    AlignV alignV,
    float scaleFactor,
    SizeF layoutArea
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
text (String)
A string value containing the text to be displayed. This can be multiple lines, separated by newline ('\n') characters
x (Single)
The X location to display the text, in screen coordinates, relative to the horizontal (AlignH) alignment parameter alignH
y (Single)
The Y location to display the text, in screen coordinates, relative to the vertical (AlignV alignment parameter alignV
alignH (AlignH)
A horizontal alignment parameter specified using the AlignH enum type
alignV (AlignV)
A vertical alignment parameter specified using the AlignV enum type
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
layoutArea (SizeF)
The limiting area (SizeF) into which the text must fit. The actual rectangle may be smaller than this, but the text will be wrapped to accomodate the area.
Return Value
A polygon of 4 points defining the area of this text


GetFont Method (scaleFactor)

GetFont Method (scaleFactor)
Namespaces ► ZedGraph ► FontSpec ► GetFont(Single)
Get the Font class for the current scaled font.
Declaration Syntax
C# Visual Basic Visual C++
public Font GetFont(
    float scaleFactor
)
Public Function GetFont ( _
    scaleFactor As Single _
) As Font
public:
Font^ GetFont (
    float scaleFactor
)
Parameters
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
Returns a reference to a Font object with a size of _scaledSize()(), and font Family.


GetHeight Method (scaleFactor)

GetHeight Method (scaleFactor)
Namespaces ► ZedGraph ► FontSpec ► GetHeight(Single)
Get the height of the scaled font
Declaration Syntax
C# Visual Basic Visual C++
public float GetHeight(
    float scaleFactor
)
Public Function GetHeight ( _
    scaleFactor As Single _
) As Single
public:
float GetHeight (
    float scaleFactor
)
Parameters
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
The scaled font height, in pixels


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► FontSpec ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


GetWidth Method

GetWidth Method
Namespaces ► ZedGraph ► FontSpec ► GetWidth()()
Members
Icon | Member | Description
 | GetWidth(Graphics, Single) | Get the average character width of the scaled font. The average width is based on the character 'x'
 | GetWidth(Graphics, String, Single) | Get the total width of the specified text string


GetWidth Method (g, scaleFactor)

GetWidth Method (g, scaleFactor)
Namespaces ► ZedGraph ► FontSpec ► GetWidth(Graphics, Single)
Get the average character width of the scaled font. The average width is based on the character 'x'
Declaration Syntax
C# Visual Basic Visual C++
public float GetWidth(
    Graphics g,
    float scaleFactor
)
Public Function GetWidth ( _
    g As Graphics, _
    scaleFactor As Single _
) As Single
public:
float GetWidth (
    Graphics^ g,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
The scaled font width, in pixels


GetWidth Method (g, text, scaleFactor)

GetWidth Method (g, text, scaleFactor)
Namespaces ► ZedGraph ► FontSpec ► GetWidth(Graphics, String, Single)
Get the total width of the specified text string
Declaration Syntax
C# Visual Basic Visual C++
public float GetWidth(
    Graphics g,
    string text,
    float scaleFactor
)
Public Function GetWidth ( _
    g As Graphics, _
    text As String, _
    scaleFactor As Single _
) As Single
public:
float GetWidth (
    Graphics^ g,
    String^ text,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
text (String)
The text string for which the width is to be calculated
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
The scaled text width, in pixels


IsAntiAlias Property

IsAntiAlias Property
Namespaces ► ZedGraph ► FontSpec ► IsAntiAlias
Gets or sets a value that determines if the FontSpec will be drawn using anti-aliasing logic within GDI+.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAntiAlias{ get; set;}
Public Property IsAntiAlias As Boolean
public:
property bool IsAntiAlias {
    bool get ();
    void set (bool value);
}
Remarks
If this property is set to true, it will override the current setting of SmoothingMode by setting the value temporarily to HighQuality. If this property is set to false, the the current setting of SmoothingMode will be left as-is.


IsBold Property

IsBold Property
Namespaces ► ZedGraph ► FontSpec ► IsBold
Determines whether this FontSpec is drawn with bold typeface.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsBold{ get; set;}
Public Property IsBold As Boolean
public:
property bool IsBold {
    bool get ();
    void set (bool value);
}
Value
A boolean value, true for bold, false for normal


IsDropShadow Property

IsDropShadow Property
Namespaces ► ZedGraph ► FontSpec ► IsDropShadow
Gets or sets a value that determines if the FontSpec will be displayed with a drop shadow.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDropShadow{ get; set;}
Public Property IsDropShadow As Boolean
public:
property bool IsDropShadow {
    bool get ();
    void set (bool value);
}
See Also
DropShadowColor
DropShadowAngle
DropShadowOffset


IsItalic Property

IsItalic Property
Namespaces ► ZedGraph ► FontSpec ► IsItalic
Determines whether this FontSpec is drawn with italic typeface.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsItalic{ get; set;}
Public Property IsItalic As Boolean
public:
property bool IsItalic {
    bool get ();
    void set (bool value);
}
Value
A boolean value, true for italic, false for normal


IsUnderline Property

IsUnderline Property
Namespaces ► ZedGraph ► FontSpec ► IsUnderline
Determines whether this FontSpec is drawn with underlined typeface.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUnderline{ get; set;}
Public Property IsUnderline As Boolean
public:
property bool IsUnderline {
    bool get ();
    void set (bool value);
}
Value
A boolean value, true for underline, false for normal


MeasureString Method

MeasureString Method
Namespaces ► ZedGraph ► FontSpec ► MeasureString()()
Members
Icon | Member | Description
 | MeasureString(Graphics, String, Single) | Get a SizeF struct representing the width and height of the specified text string, based on the scaled font size
 | MeasureString(Graphics, String, Single, SizeF) | Get a SizeF struct representing the width and height of the specified text string, based on the scaled font size, and using the specified SizeF as an outer limit.


MeasureString Method (g, text, scaleFactor)

MeasureString Method (g, text, scaleFactor)
Namespaces ► ZedGraph ► FontSpec ► MeasureString(Graphics, String, Single)
Get a SizeF struct representing the width and height of the specified text string, based on the scaled font size
Declaration Syntax
C# Visual Basic Visual C++
public SizeF MeasureString(
    Graphics g,
    string text,
    float scaleFactor
)
Public Function MeasureString ( _
    g As Graphics, _
    text As String, _
    scaleFactor As Single _
) As SizeF
public:
SizeF MeasureString (
    Graphics^ g,
    String^ text,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
text (String)
The text string for which the width is to be calculated
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
The scaled text dimensions, in pixels, in the form of a SizeF struct


MeasureString Method (g, text, scaleFactor, layoutArea)

MeasureString Method (g, text, scaleFactor, layoutArea)
Namespaces ► ZedGraph ► FontSpec ► MeasureString(Graphics, String, Single, SizeF)
Get a SizeF struct representing the width and height of the specified text string, based on the scaled font size, and using the specified SizeF as an outer limit.
Declaration Syntax
C# Visual Basic Visual C++
public SizeF MeasureString(
    Graphics g,
    string text,
    float scaleFactor,
    SizeF layoutArea
)
Public Function MeasureString ( _
    g As Graphics, _
    text As String, _
    scaleFactor As Single, _
    layoutArea As SizeF _
) As SizeF
public:
SizeF MeasureString (
    Graphics^ g,
    String^ text,
    float scaleFactor,
    SizeF layoutArea
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
text (String)
The text string for which the width is to be calculated
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
layoutArea (SizeF)
The limiting area (SizeF) into which the text must fit. The actual rectangle may be smaller than this, but the text will be wrapped to accomodate the area.
Return Value
The scaled text dimensions, in pixels, in the form of a SizeF struct
Remarks
This method will allow the text to wrap as necessary to fit the .


PointInBox Method

PointInBox Method
Namespaces ► ZedGraph ► FontSpec ► PointInBox()()
Members
Icon | Member | Description
 | PointInBox(PointF, Graphics, String, Single, Single, AlignH, AlignV, Single) | Determines if the specified screen point lies within the bounding box of the text, taking into account alignment and rotation parameters.
 | PointInBox(PointF, Graphics, String, Single, Single, AlignH, AlignV, Single, SizeF) | Determines if the specified screen point lies within the bounding box of the text, taking into account alignment and rotation parameters.


PointInBox Method (pt, g, text, x, y, alignH, alignV, scaleFactor)

PointInBox Method (pt, g, text, x, y, alignH, alignV, scaleFactor)
Namespaces ► ZedGraph ► FontSpec ► PointInBox(PointF, Graphics, String, Single, Single, AlignH, AlignV, Single)
Determines if the specified screen point lies within the bounding box of the text, taking into account alignment and rotation parameters.
Declaration Syntax
C# Visual Basic Visual C++
public bool PointInBox(
    PointF pt,
    Graphics g,
    string text,
    float x,
    float y,
    AlignH alignH,
    AlignV alignV,
    float scaleFactor
)
Public Function PointInBox ( _
    pt As PointF, _
    g As Graphics, _
    text As String, _
    x As Single, _
    y As Single, _
    alignH As AlignH, _
    alignV As AlignV, _
    scaleFactor As Single _
) As Boolean
public:
bool PointInBox (
    PointF pt,
    Graphics^ g,
    String^ text,
    float x,
    float y,
    AlignH alignH,
    AlignV alignV,
    float scaleFactor
)
Parameters
pt (PointF)
The screen point, in pixel units
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
text (String)
A string value containing the text to be displayed. This can be multiple lines, separated by newline ('\n') characters
x (Single)
The X location to display the text, in screen coordinates, relative to the horizontal (AlignH) alignment parameter alignH
y (Single)
The Y location to display the text, in screen coordinates, relative to the vertical (AlignV alignment parameter alignV
alignH (AlignH)
A horizontal alignment parameter specified using the AlignH enum type
alignV (AlignV)
A vertical alignment parameter specified using the AlignV enum type
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
true if the point lies within the bounding box, false otherwise


PointInBox Method (pt, g, text, x, y, alignH, alignV, scaleFactor, layoutArea)

PointInBox Method (pt, g, text, x, y, alignH, alignV, scaleFactor, layoutArea)
Namespaces ► ZedGraph ► FontSpec ► PointInBox(PointF, Graphics, String, Single, Single, AlignH, AlignV, Single, SizeF)
Determines if the specified screen point lies within the bounding box of the text, taking into account alignment and rotation parameters.
Declaration Syntax
C# Visual Basic Visual C++
public bool PointInBox(
    PointF pt,
    Graphics g,
    string text,
    float x,
    float y,
    AlignH alignH,
    AlignV alignV,
    float scaleFactor,
    SizeF layoutArea
)
Public Function PointInBox ( _
    pt As PointF, _
    g As Graphics, _
    text As String, _
    x As Single, _
    y As Single, _
    alignH As AlignH, _
    alignV As AlignV, _
    scaleFactor As Single, _
    layoutArea As SizeF _
) As Boolean
public:
bool PointInBox (
    PointF pt,
    Graphics^ g,
    String^ text,
    float x,
    float y,
    AlignH alignH,
    AlignV alignV,
    float scaleFactor,
    SizeF layoutArea
)
Parameters
pt (PointF)
The screen point, in pixel units
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
text (String)
A string value containing the text to be displayed. This can be multiple lines, separated by newline ('\n') characters
x (Single)
The X location to display the text, in screen coordinates, relative to the horizontal (AlignH) alignment parameter alignH
y (Single)
The Y location to display the text, in screen coordinates, relative to the vertical (AlignV alignment parameter alignV
alignH (AlignH)
A horizontal alignment parameter specified using the AlignH enum type
alignV (AlignV)
A vertical alignment parameter specified using the AlignV enum type
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
layoutArea (SizeF)
The limiting area (SizeF) into which the text must fit. The actual rectangle may be smaller than this, but the text will be wrapped to accomodate the area.
Return Value
true if the point lies within the bounding box, false otherwise


schema Field

schema Field
Namespaces ► ZedGraph ► FontSpec ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


Size Property

Size Property
Namespaces ► ZedGraph ► FontSpec ► Size
The size of the font for this FontSpec object.
Declaration Syntax
C# Visual Basic Visual C++
public float Size{ get; set;}
Public Property Size As Single
public:
property float Size {
    float get ();
    void set (float value);
}
Value
The size of the font, measured in points (1/72 inch).


StringAlignment Property

StringAlignment Property
Namespaces ► ZedGraph ► FontSpec ► StringAlignment
Determines the alignment with which this FontSpec object is drawn. This alignment really only affects multi-line strings.
Declaration Syntax
C# Visual Basic Visual C++
public StringAlignment StringAlignment{ get; set;}
Public Property StringAlignment As StringAlignment
public:
property StringAlignment StringAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}
Value
A StringAlignment enumeration.


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► FontSpec ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


FontSpec.Default Structure

FontSpec..::Default Structure
Namespaces ► ZedGraph ► FontSpec ► FontSpec..::Default
A simple struct that defines the default property values for the FontSpec class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DropShadowAngle | Default value for DropShadowAngle, which determines the offset angle of the drop shadow for this FontSpec.
 | DropShadowColor | Default value for DropShadowColor, which determines the color of the drop shadow for this FontSpec.
 | DropShadowOffset | Default value for DropShadowOffset, which determines the offset distance of the drop shadow for this FontSpec.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | FillBrush | The default custom brush for filling in this FontSpec (Brush property).
 | FillColor | The default color for filling in the background of the text block (Color property).
 | FillType | The default fill mode for this FontSpec (Type property).
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAntiAlias | Default value for IsAntiAlias, which determines if anti-aliasing logic is used for this FontSpec.
 | IsDropShadow | Default value for IsDropShadow, which determines if the drop shadow is displayed for this FontSpec.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StringAlignment | Default value for the alignment with which this FontSpec object is drawn. This alignment really only affects multi-line strings.
 | SuperShift | The default shift fraction of the superscript, expressed as a fraction of the superscripted character height. This is the height above the main font (a zero shift means the main font and the superscript font have the tops aligned).
 | SuperSize | The default size fraction of the superscript font, expressed as a fraction of the size of the main font.
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


DropShadowAngle Field

DropShadowAngle Field
Namespaces ► ZedGraph ► FontSpec..::Default ► DropShadowAngle
Default value for DropShadowAngle, which determines the offset angle of the drop shadow for this FontSpec.
Declaration Syntax
C# Visual Basic Visual C++
public static float DropShadowAngle
Public Shared DropShadowAngle As Single
public:
static float DropShadowAngle


DropShadowColor Field

DropShadowColor Field
Namespaces ► ZedGraph ► FontSpec..::Default ► DropShadowColor
Default value for DropShadowColor, which determines the color of the drop shadow for this FontSpec.
Declaration Syntax
C# Visual Basic Visual C++
public static Color DropShadowColor
Public Shared DropShadowColor As Color
public:
static Color DropShadowColor


DropShadowOffset Field

DropShadowOffset Field
Namespaces ► ZedGraph ► FontSpec..::Default ► DropShadowOffset
Default value for DropShadowOffset, which determines the offset distance of the drop shadow for this FontSpec.
Declaration Syntax
C# Visual Basic Visual C++
public static float DropShadowOffset
Public Shared DropShadowOffset As Single
public:
static float DropShadowOffset


FillBrush Field

FillBrush Field
Namespaces ► ZedGraph ► FontSpec..::Default ► FillBrush
The default custom brush for filling in this FontSpec (Brush property).
Declaration Syntax
C# Visual Basic Visual C++
public static Brush FillBrush
Public Shared FillBrush As Brush
public:
static Brush^ FillBrush


FillColor Field

FillColor Field
Namespaces ► ZedGraph ► FontSpec..::Default ► FillColor
The default color for filling in the background of the text block (Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color FillColor
Public Shared FillColor As Color
public:
static Color FillColor


FillType Field

FillType Field
Namespaces ► ZedGraph ► FontSpec..::Default ► FillType
The default fill mode for this FontSpec (Type property).
Declaration Syntax
C# Visual Basic Visual C++
public static FillType FillType
Public Shared FillType As FillType
public:
static FillType FillType


IsAntiAlias Field

IsAntiAlias Field
Namespaces ► ZedGraph ► FontSpec..::Default ► IsAntiAlias
Default value for IsAntiAlias, which determines if anti-aliasing logic is used for this FontSpec.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsAntiAlias
Public Shared IsAntiAlias As Boolean
public:
static bool IsAntiAlias


IsDropShadow Field

IsDropShadow Field
Namespaces ► ZedGraph ► FontSpec..::Default ► IsDropShadow
Default value for IsDropShadow, which determines if the drop shadow is displayed for this FontSpec.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsDropShadow
Public Shared IsDropShadow As Boolean
public:
static bool IsDropShadow


StringAlignment Field

StringAlignment Field
Namespaces ► ZedGraph ► FontSpec..::Default ► StringAlignment
Default value for the alignment with which this FontSpec object is drawn. This alignment really only affects multi-line strings.
Declaration Syntax
C# Visual Basic Visual C++
public static StringAlignment StringAlignment
Public Shared StringAlignment As StringAlignment
public:
static StringAlignment StringAlignment
Value
A StringAlignment enumeration.


SuperShift Field

SuperShift Field
Namespaces ► ZedGraph ► FontSpec..::Default ► SuperShift
The default shift fraction of the superscript, expressed as a fraction of the superscripted character height. This is the height above the main font (a zero shift means the main font and the superscript font have the tops aligned).
Declaration Syntax
C# Visual Basic Visual C++
public static float SuperShift
Public Shared SuperShift As Single
public:
static float SuperShift


SuperSize Field

SuperSize Field
Namespaces ► ZedGraph ► FontSpec..::Default ► SuperSize
The default size fraction of the superscript font, expressed as a fraction of the size of the main font.
Declaration Syntax
C# Visual Basic Visual C++
public static float SuperSize
Public Shared SuperSize As Single
public:
static float SuperSize


GapLabel Class

GapLabel Class
Namespaces ► ZedGraph ► GapLabel
Class that handles the data associated with a text title and its associated font properties. Inherits from Label, and adds the Gap property for use by the Axis and PaneBase objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class GapLabel : Label, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class GapLabel _
    Inherits Label _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class GapLabel : public Label,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GapLabelGapLabelNew(String, String, Single, Color, Boolean, Boolean, Boolean) | Constructor to build a GapLabel from the text and the associated font properties.
 | GapLabelGapLabelNew(GapLabel) | Copy constructor
 | Clone()() | Typesafe, deep-copy clone method.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontSpec | A FontSpec instance representing the font properties for the displayed text. (Inherited from Label.)
 | Gap | Gets or sets the gap factor between this label and the opposing Axis or Chart.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides Label.GetObjectData(SerializationInfo, StreamingContext).)
 | GetScaledGap(Single) | Calculate the size of the Gap based on the FontSpec height, in pixel units and scaled according to .
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible | Gets or sets a boolean value that determines whether or not this label will be displayed. (Inherited from Label.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | schema2 | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Text | The String text to be displayed (Inherited from Label.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Label
 |  | GapLabel
 |  |  | AxisLabel


GapLabel Constructor

GapLabel Constructor
Namespaces ► ZedGraph ► GapLabel ► GapLabelGapLabelNew()()
Members
Icon | Member | Description
 | GapLabelGapLabelNew(String, String, Single, Color, Boolean, Boolean, Boolean) | Constructor to build a GapLabel from the text and the associated font properties.
 | GapLabelGapLabelNew(GapLabel) | Copy constructor


GapLabel Constructor (text, fontFamily, fontSize, color, isBold, isItalic, isUnderline)

GapLabel Constructor (text, fontFamily, fontSize, color, isBold, isItalic, isUnderline)
Namespaces ► ZedGraph ► GapLabel ► GapLabelGapLabelNew(String, String, Single, Color, Boolean, Boolean, Boolean)
Constructor to build a GapLabel from the text and the associated font properties.
Declaration Syntax
C# Visual Basic Visual C++
public GapLabel(
    string text,
    string fontFamily,
    float fontSize,
    Color color,
    bool isBold,
    bool isItalic,
    bool isUnderline
)
Public Sub New ( _
    text As String, _
    fontFamily As String, _
    fontSize As Single, _
    color As Color, _
    isBold As Boolean, _
    isItalic As Boolean, _
    isUnderline As Boolean _
)
public:
GapLabel (
    String^ text,
    String^ fontFamily,
    float fontSize,
    Color color,
    bool isBold,
    bool isItalic,
    bool isUnderline
)
Parameters
text (String)
The String representing the text to be displayed
fontFamily (String)
The String font family name
fontSize (Single)
The size of the font in points and scaled according to the CalcScaleFactor()() logic.
color (Color)
The Color instance representing the color of the font
isBold (Boolean)
true for a bold font face
isItalic (Boolean)
true for an italic font face
isUnderline (Boolean)
true for an underline font face


GapLabel Constructor (rhs)

GapLabel Constructor (rhs)
Namespaces ► ZedGraph ► GapLabel ► GapLabelGapLabelNew(GapLabel)
Copy constructor
Declaration Syntax
C# Visual Basic Visual C++
public GapLabel(
    GapLabel rhs
)
Public Sub New ( _
    rhs As GapLabel _
)
public:
GapLabel (
    GapLabel^ rhs
)
Parameters
rhs (GapLabel)
the AxisLabel instance to be copied.


Clone Method

Clone Method
Namespaces ► ZedGraph ► GapLabel ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public GapLabel Clone()
Public Function Clone As GapLabel
public:
GapLabel^ Clone ()
Return Value
A new, independent copy of this class


Gap Property

Gap Property
Namespaces ► ZedGraph ► GapLabel ► Gap
Gets or sets the gap factor between this label and the opposing Axis or Chart.
Declaration Syntax
C# Visual Basic Visual C++
public float Gap{ get; set;}
Public Property Gap As Single
public:
property float Gap {
    float get ();
    void set (float value);
}
Remarks
This value is expressed as a fraction of the character height for the GapLabel.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► GapLabel ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


GetScaledGap Method (scaleFactor)

GetScaledGap Method (scaleFactor)
Namespaces ► ZedGraph ► GapLabel ► GetScaledGap(Single)
Calculate the size of the Gap based on the FontSpec height, in pixel units and scaled according to .
Declaration Syntax
C# Visual Basic Visual C++
public float GetScaledGap(
    float scaleFactor
)
Public Function GetScaledGap ( _
    scaleFactor As Single _
) As Single
public:
float GetScaledGap (
    float scaleFactor
)
Parameters
scaleFactor (Single)
The scaling factor to be applied


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► GapLabel ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► GapLabel ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


GapLabel.Default Structure

GapLabel..::Default Structure
Namespaces ► ZedGraph ► GapLabel ► GapLabel..::Default
A simple struct that defines the default property values for the GapLabel class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Gap | The default Gap setting.
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


Gap Field

Gap Field
Namespaces ► ZedGraph ► GapLabel..::Default ► Gap
The default Gap setting.
Declaration Syntax
C# Visual Basic Visual C++
public static float Gap
Public Shared Gap As Single
public:
static float Gap


GasGaugeNeedle Class

GasGaugeNeedle Class
Namespaces ► ZedGraph ► GasGaugeNeedle
A class representing a needle on the GasGuage chart GasGaugeNeedles.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class GasGaugeNeedle : CurveItem, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class GasGaugeNeedle _
    Inherits CurveItem _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class GasGaugeNeedle : public CurveItem,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GasGaugeNeedleGasGaugeNeedleNew(String, Double, Color) | Create a new GasGaugeNeedle
 | GasGaugeNeedleGasGaugeNeedleNew(GasGaugeNeedle) | The Copy Constructor
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve. (Inherited from CurveItem.)
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve. (Inherited from CurveItem.)
 | BaseAxis(GraphPane) | Returns a reference to the Axis object that is the "base" (independent axis) from which the values are drawn. (Inherited from CurveItem.)
 | Border | Gets or Sets the Border of this GasGaugeNeedle
 | CalcRectangle(Graphics, GraphPane, Single, RectangleF) | Calculate the RectangleF that will be used to define the bounding rectangle of the GasGaugeNeedle.
 | CalculateGasGaugeParameters(GraphPane) | Calculate the values needed to properly display this GasGaugeNeedle.
 | Clear()() | Clears the points from this CurveItem. This is the same as CurveItem.Points.Clear(). (Inherited from CurveItem.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The Line/Symbol/Bar color (FillColor for the Bar). This is a common access to Line.Color, Border.Color, and Fill.Color properties for this curve. (Inherited from CurveItem.)
 | Draw(Graphics, GraphPane, Int32, Single) | Do all rendering associated with this GasGaugeNeedle item to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object. (Overrides CurveItem.Draw(Graphics, GraphPane, Int32, Single).)
 | DrawLegendKey(Graphics, GraphPane, RectangleF, Single) | Render the label for this GasGaugeNeedle. (Overrides CurveItem.DrawLegendKey(Graphics, GraphPane, RectangleF, Single).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Gets or Sets the Fill of this GasGaugeNeedle
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarWidth(GraphPane) | Calculate the width of each bar, depending on the actual bar type (Inherited from CurveItem.)
 | GetCoords(GraphPane, Int32, String%) | Determine the coords for the rectangle associated with a specified point for this CurveItem (Overrides CurveItem.GetCoords(GraphPane, Int32, String%).)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides CurveItem.GetObjectData(SerializationInfo, StreamingContext).)
 | GetRange(Double%, Double%, Double%, Double%, Boolean, Boolean, GraphPane) | Go through the list of PointPair data values for this CurveItem and determine the minimum and maximum values in the data. (Inherited from CurveItem.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXAxis(GraphPane) | Get the X Axis instance (either XAxis or X2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxis(GraphPane) | Get the Y Axis instance (either YAxis or Y2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxisIndex(GraphPane) | Get the index of the Y Axis in the YAxis or Y2Axis list to which this CurveItem belongs. (Inherited from CurveItem.)
 | IsBar | Determines whether this CurveItem is a BarItem. This does not include HiLowBarItem's or ErrorBarItem's. (Inherited from CurveItem.)
 | IsLine | Determines whether this CurveItem is a LineItem. (Inherited from CurveItem.)
 | IsOverrideOrdinal | Gets or sets a value which allows you to override the normal ordinal axis behavior. (Inherited from CurveItem.)
 | IsPie | Determines whether this CurveItem is a PieItem. (Inherited from CurveItem.)
 | IsSelectable | Determines whether this CurveItem can be selected in the graph. (Inherited from CurveItem.)
 | IsSelected | Determines whether this CurveItem is selected on the graph. Note that this value changes the curve displayed color, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsVisible | Determines whether this CurveItem is visible on the graph. Note that this value turns the curve display on or off, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsX2Axis | Gets or sets a value that determines which X axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | IsY2Axis | Gets or sets a value that determines which Y axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | Item[([Int32])] | An accessor for the PointPair datum for this CurveItem. Index is the ordinal reference (zero based) of the point. (Inherited from CurveItem.)
 | Label | A Label instance that represents the Legend entry for the this CurveItem object (Inherited from CurveItem.)
 | LabelDetail | Gets or Sets the LableDetail of this GasGaugeNeedle
 | Link | Gets or sets the hyperlink information for this CurveItem. (Inherited from CurveItem.)
 | MakeUnique()() | Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator) (Inherited from CurveItem.)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator) (Inherited from CurveItem.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NeedleColor | Gets or Sets the NeedelColor of this GasGaugeNeedle
 | NeedleValue | Gets or Sets the NeedleValue of this GasGaugeNeedle
 | NeedleWidth | Gets or Sets the NeedleWidth of this GasGaugeNeedle
 | NPts | Readonly property that gives the number of points that define this CurveItem object, which is the number of points in the Points data collection. (Inherited from CurveItem.)
 | Points | The IPointList of X,Y point sets that represent this CurveItem. (Inherited from CurveItem.)
 | RemovePoint(Int32) | Removes a single point from this CurveItem. (Inherited from CurveItem.)
 | schema2 | Current schema value that defines the version of the serialized file
 | SlicePath | Gets or Sets the SlicePath of this GasGaugeNeedle
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the CurveItem. ZedGraph does not use this value for any purpose. (Inherited from CurveItem.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValueAxis(GraphPane) | Returns a reference to the Axis object that is the "value" (dependent axis) from which the points are drawn. (Inherited from CurveItem.)
 | YAxisIndex | Gets or sets the index number of the Y Axis to which this CurveItem belongs. (Inherited from CurveItem.)
Inheritance Hierarchy
Object
 | CurveItem
 |  | GasGaugeNeedle


GasGaugeNeedle Constructor

GasGaugeNeedle Constructor
Namespaces ► ZedGraph ► GasGaugeNeedle ► GasGaugeNeedleGasGaugeNeedleNew()()
Members
Icon | Member | Description
 | GasGaugeNeedleGasGaugeNeedleNew(String, Double, Color) | Create a new GasGaugeNeedle
 | GasGaugeNeedleGasGaugeNeedleNew(GasGaugeNeedle) | The Copy Constructor


GasGaugeNeedle Constructor (label, val, color)

GasGaugeNeedle Constructor (label, val, color)
Namespaces ► ZedGraph ► GasGaugeNeedle ► GasGaugeNeedleGasGaugeNeedleNew(String, Double, Color)
Create a new GasGaugeNeedle
Declaration Syntax
C# Visual Basic Visual C++
public GasGaugeNeedle(
    string label,
    double val,
    Color color
)
Public Sub New ( _
    label As String, _
    val As Double, _
    color As Color _
)
public:
GasGaugeNeedle (
    String^ label,
    double val,
    Color color
)
Parameters
label (String)
The value associated with this GasGaugeNeedle instance.
val (Double)
The value of this GasGaugeNeedle.
color (Color)
The display color for this GasGaugeNeedle instance.


GasGaugeNeedle Constructor (ggn)

GasGaugeNeedle Constructor (ggn)
Namespaces ► ZedGraph ► GasGaugeNeedle ► GasGaugeNeedleGasGaugeNeedleNew(GasGaugeNeedle)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public GasGaugeNeedle(
    GasGaugeNeedle ggn
)
Public Sub New ( _
    ggn As GasGaugeNeedle _
)
public:
GasGaugeNeedle (
    GasGaugeNeedle^ ggn
)
Parameters
ggn (GasGaugeNeedle)
The GasGaugeNeedle object from which to copy


Border Property

Border Property
Namespaces ► ZedGraph ► GasGaugeNeedle ► Border
Gets or Sets the Border of this GasGaugeNeedle
Declaration Syntax
C# Visual Basic Visual C++
public Border Border{ get; set;}
Public Property Border As Border
public:
property Border^ Border {
    Border^ get ();
    void set (Border^ value);
}


CalcRectangle Method (g, pane, scaleFactor, chartRect)

CalcRectangle Method (g, pane, scaleFactor, chartRect)
Namespaces ► ZedGraph ► GasGaugeNeedle ► CalcRectangle(Graphics, GraphPane, Single, RectangleF)
Calculate the RectangleF that will be used to define the bounding rectangle of the GasGaugeNeedle.
Declaration Syntax
C# Visual Basic Visual C++
public static RectangleF CalcRectangle(
    Graphics g,
    GraphPane pane,
    float scaleFactor,
    RectangleF chartRect
)
Public Shared Function CalcRectangle ( _
    g As Graphics, _
    pane As GraphPane, _
    scaleFactor As Single, _
    chartRect As RectangleF _
) As RectangleF
public:
static RectangleF CalcRectangle (
    Graphics^ g,
    GraphPane^ pane,
    float scaleFactor,
    RectangleF chartRect
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
chartRect (RectangleF)
The RectangleF (normally the Rect) that bounds this pie.
Return Value
Remarks
This rectangle always lies inside of the Rect, and it is normally a square so that the pie itself is not oval-shaped.


CalculateGasGaugeParameters Method (pane)

CalculateGasGaugeParameters Method (pane)
Namespaces ► ZedGraph ► GasGaugeNeedle ► CalculateGasGaugeParameters(GraphPane)
Calculate the values needed to properly display this GasGaugeNeedle.
Declaration Syntax
C# Visual Basic Visual C++
public static void CalculateGasGaugeParameters(
    GraphPane pane
)
Public Shared Sub CalculateGasGaugeParameters ( _
    pane As GraphPane _
)
public:
static void CalculateGasGaugeParameters (
    GraphPane^ pane
)
Parameters
pane (GraphPane)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.


Clone Method

Clone Method
Namespaces ► ZedGraph ► GasGaugeNeedle ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public GasGaugeNeedle Clone()
Public Function Clone As GasGaugeNeedle
public:
GasGaugeNeedle^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, pos, scaleFactor)

Draw Method (g, pane, pos, scaleFactor)
Namespaces ► ZedGraph ► GasGaugeNeedle ► Draw(Graphics, GraphPane, Int32, Single)
Do all rendering associated with this GasGaugeNeedle item to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object.
Declaration Syntax
C# Visual Basic Visual C++
public override void Draw(
    Graphics g,
    GraphPane pane,
    int pos,
    float scaleFactor
)
Public Overrides Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    pos As Integer, _
    scaleFactor As Single _
)
public:
virtual void Draw (
    Graphics^ g,
    GraphPane^ pane,
    int pos,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
pos (Int32)
Not used for rendering GasGaugeNeedle
scaleFactor (Single)
Not used for rendering GasGaugeNeedle


DrawLegendKey Method (g, pane, rect, scaleFactor)

DrawLegendKey Method (g, pane, rect, scaleFactor)
Namespaces ► ZedGraph ► GasGaugeNeedle ► DrawLegendKey(Graphics, GraphPane, RectangleF, Single)
Render the label for this GasGaugeNeedle.
Declaration Syntax
C# Visual Basic Visual C++
public override void DrawLegendKey(
    Graphics g,
    GraphPane pane,
    RectangleF rect,
    float scaleFactor
)
Public Overrides Sub DrawLegendKey ( _
    g As Graphics, _
    pane As GraphPane, _
    rect As RectangleF, _
    scaleFactor As Single _
)
public:
virtual void DrawLegendKey (
    Graphics^ g,
    GraphPane^ pane,
    RectangleF rect,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
rect (RectangleF)
Bounding rectangle for this GasGaugeNeedle.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


Fill Property

Fill Property
Namespaces ► ZedGraph ► GasGaugeNeedle ► Fill
Gets or Sets the Fill of this GasGaugeNeedle
Declaration Syntax
C# Visual Basic Visual C++
public Fill Fill{ get; set;}
Public Property Fill As Fill
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}


GetCoords Method (pane, i, coords)

GetCoords Method (pane, i, coords)
Namespaces ► ZedGraph ► GasGaugeNeedle ► GetCoords(GraphPane, Int32, String%)
Determine the coords for the rectangle associated with a specified point for this CurveItem
Declaration Syntax
C# Visual Basic Visual C++
public override bool GetCoords(
    GraphPane pane,
    int i,
    out string coords
)
Public Overrides Function GetCoords ( _
    pane As GraphPane, _
    i As Integer, _
    <OutAttribute> ByRef coords As String _
) As Boolean
public:
virtual bool GetCoords (
    GraphPane^ pane,
    int i,
    [OutAttribute] String^% coords
) override
Parameters
pane (GraphPane)
The GraphPane to which this curve belongs
i (Int32)
The index of the point of interest
coords (String %)
A list of coordinates that represents the "rect" for this point (used in an html AREA tag)
Return Value
true if it's a valid point, false otherwise


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► GasGaugeNeedle ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


LabelDetail Property

LabelDetail Property
Namespaces ► ZedGraph ► GasGaugeNeedle ► LabelDetail
Gets or Sets the LableDetail of this GasGaugeNeedle
Declaration Syntax
C# Visual Basic Visual C++
public TextObj LabelDetail{ get; set;}
Public Property LabelDetail As TextObj
public:
property TextObj^ LabelDetail {
    TextObj^ get ();
    void set (TextObj^ value);
}


NeedleColor Property

NeedleColor Property
Namespaces ► ZedGraph ► GasGaugeNeedle ► NeedleColor
Gets or Sets the NeedelColor of this GasGaugeNeedle
Declaration Syntax
C# Visual Basic Visual C++
public Color NeedleColor{ get; set;}
Public Property NeedleColor As Color
public:
property Color NeedleColor {
    Color get ();
    void set (Color value);
}


NeedleValue Property

NeedleValue Property
Namespaces ► ZedGraph ► GasGaugeNeedle ► NeedleValue
Gets or Sets the NeedleValue of this GasGaugeNeedle
Declaration Syntax
C# Visual Basic Visual C++
public double NeedleValue{ get; set;}
Public Property NeedleValue As Double
public:
property double NeedleValue {
    double get ();
    void set (double value);
}


NeedleWidth Property

NeedleWidth Property
Namespaces ► ZedGraph ► GasGaugeNeedle ► NeedleWidth
Gets or Sets the NeedleWidth of this GasGaugeNeedle
Declaration Syntax
C# Visual Basic Visual C++
public float NeedleWidth{ get; set;}
Public Property NeedleWidth As Single
public:
property float NeedleWidth {
    float get ();
    void set (float value);
}


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► GasGaugeNeedle ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


SlicePath Property

SlicePath Property
Namespaces ► ZedGraph ► GasGaugeNeedle ► SlicePath
Gets or Sets the SlicePath of this GasGaugeNeedle
Declaration Syntax
C# Visual Basic Visual C++
public GraphicsPath SlicePath{ get;}
Public ReadOnly Property SlicePath As GraphicsPath
public:
property GraphicsPath^ SlicePath {
    GraphicsPath^ get ();
}


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► GasGaugeNeedle ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


GasGaugeNeedle.Default Structure

GasGaugeNeedle..::Default Structure
Namespaces ► ZedGraph ► GasGaugeNeedle ► GasGaugeNeedle..::Default
Specify the default property values for the GasGaugeNeedle class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BorderColor | The default color for drawing frames around GasGaugeNeedle (Color property).
 | BorderWidth | The default pen width to be used for drawing the border around the GasGaugeNeedle (Width property). Units are points.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | FillBrush | The default custom brush for filling in the GasGaugeNeedle. (Brush property).
 | FillColor | The default color for filling in the GasGaugeNeedle (Color property).
 | FillType | The default fill type for filling the GasGaugeNeedle.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontSize | The default font size for LabelDetail entries (Size property). Units are in points (1/72 inch).
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsBorderVisible | The default border mode for GasGaugeNeedle (IsVisible property). true to display frame around GasGaugeNeedle, false otherwise
 | isVisible | Default value for controlling GasGaugeNeedle display.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NeedleWidth | The default width of the gas gauge needle. Units are points, scaled according to CalcScaleFactor()()
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


BorderColor Field

BorderColor Field
Namespaces ► ZedGraph ► GasGaugeNeedle..::Default ► BorderColor
The default color for drawing frames around GasGaugeNeedle (Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color BorderColor
Public Shared BorderColor As Color
public:
static Color BorderColor


BorderWidth Field

BorderWidth Field
Namespaces ► ZedGraph ► GasGaugeNeedle..::Default ► BorderWidth
The default pen width to be used for drawing the border around the GasGaugeNeedle (Width property). Units are points.
Declaration Syntax
C# Visual Basic Visual C++
public static float BorderWidth
Public Shared BorderWidth As Single
public:
static float BorderWidth


FillBrush Field

FillBrush Field
Namespaces ► ZedGraph ► GasGaugeNeedle..::Default ► FillBrush
The default custom brush for filling in the GasGaugeNeedle. (Brush property).
Declaration Syntax
C# Visual Basic Visual C++
public static Brush FillBrush
Public Shared FillBrush As Brush
public:
static Brush^ FillBrush


FillColor Field

FillColor Field
Namespaces ► ZedGraph ► GasGaugeNeedle..::Default ► FillColor
The default color for filling in the GasGaugeNeedle (Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color FillColor
Public Shared FillColor As Color
public:
static Color FillColor


FillType Field

FillType Field
Namespaces ► ZedGraph ► GasGaugeNeedle..::Default ► FillType
The default fill type for filling the GasGaugeNeedle.
Declaration Syntax
C# Visual Basic Visual C++
public static FillType FillType
Public Shared FillType As FillType
public:
static FillType FillType


FontSize Field

FontSize Field
Namespaces ► ZedGraph ► GasGaugeNeedle..::Default ► FontSize
The default font size for LabelDetail entries (Size property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float FontSize
Public Shared FontSize As Single
public:
static float FontSize


IsBorderVisible Field

IsBorderVisible Field
Namespaces ► ZedGraph ► GasGaugeNeedle..::Default ► IsBorderVisible
The default border mode for GasGaugeNeedle (IsVisible property). true to display frame around GasGaugeNeedle, false otherwise
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsBorderVisible
Public Shared IsBorderVisible As Boolean
public:
static bool IsBorderVisible


isVisible Field

isVisible Field
Namespaces ► ZedGraph ► GasGaugeNeedle..::Default ► isVisible
Default value for controlling GasGaugeNeedle display.
Declaration Syntax
C# Visual Basic Visual C++
public static bool isVisible
Public Shared isVisible As Boolean
public:
static bool isVisible


NeedleWidth Field

NeedleWidth Field
Namespaces ► ZedGraph ► GasGaugeNeedle..::Default ► NeedleWidth
The default width of the gas gauge needle. Units are points, scaled according to CalcScaleFactor()()
Declaration Syntax
C# Visual Basic Visual C++
public static float NeedleWidth
Public Shared NeedleWidth As Single
public:
static float NeedleWidth


GasGaugeRegion Class

GasGaugeRegion Class
Namespaces ► ZedGraph ► GasGaugeRegion
A class representing a region on the GasGuage chart GasGaugeRegions.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class GasGaugeRegion : CurveItem, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class GasGaugeRegion _
    Inherits CurveItem _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class GasGaugeRegion : public CurveItem,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GasGaugeRegionGasGaugeRegionNew(String, Double, Double, Color) | Create a new GasGaugeRegion
 | GasGaugeRegionGasGaugeRegionNew(GasGaugeRegion) | The Copy Constructor
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve. (Inherited from CurveItem.)
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve. (Inherited from CurveItem.)
 | BaseAxis(GraphPane) | Returns a reference to the Axis object that is the "base" (independent axis) from which the values are drawn. (Inherited from CurveItem.)
 | Border | Gets or sets the Border of this GasGaugeRegion
 | CalcRectangle(Graphics, GraphPane, Single, RectangleF) | Calculate the RectangleF that will be used to define the bounding rectangle of the GasGaugeNeedle.
 | CalculateGasGuageParameters(GraphPane) | Calculate the values needed to properly display this GasGaugeRegion.
 | Clear()() | Clears the points from this CurveItem. This is the same as CurveItem.Points.Clear(). (Inherited from CurveItem.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The Line/Symbol/Bar color (FillColor for the Bar). This is a common access to Line.Color, Border.Color, and Fill.Color properties for this curve. (Inherited from CurveItem.)
 | Draw(Graphics, GraphPane, Int32, Single) | Do all rendering associated with this GasGaugeRegion item to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object. (Overrides CurveItem.Draw(Graphics, GraphPane, Int32, Single).)
 | DrawLegendKey(Graphics, GraphPane, RectangleF, Single) | Render the label for this GasGaugeRegion. (Overrides CurveItem.DrawLegendKey(Graphics, GraphPane, RectangleF, Single).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Gets or sets the Fill of this GasGaugeRegion
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarWidth(GraphPane) | Calculate the width of each bar, depending on the actual bar type (Inherited from CurveItem.)
 | GetCoords(GraphPane, Int32, String%) | Determine the coords for the rectangle associated with a specified point for this CurveItem (Overrides CurveItem.GetCoords(GraphPane, Int32, String%).)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides CurveItem.GetObjectData(SerializationInfo, StreamingContext).)
 | GetRange(Double%, Double%, Double%, Double%, Boolean, Boolean, GraphPane) | Go through the list of PointPair data values for this CurveItem and determine the minimum and maximum values in the data. (Inherited from CurveItem.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXAxis(GraphPane) | Get the X Axis instance (either XAxis or X2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxis(GraphPane) | Get the Y Axis instance (either YAxis or Y2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxisIndex(GraphPane) | Get the index of the Y Axis in the YAxis or Y2Axis list to which this CurveItem belongs. (Inherited from CurveItem.)
 | IsBar | Determines whether this CurveItem is a BarItem. This does not include HiLowBarItem's or ErrorBarItem's. (Inherited from CurveItem.)
 | IsLine | Determines whether this CurveItem is a LineItem. (Inherited from CurveItem.)
 | IsOverrideOrdinal | Gets or sets a value which allows you to override the normal ordinal axis behavior. (Inherited from CurveItem.)
 | IsPie | Determines whether this CurveItem is a PieItem. (Inherited from CurveItem.)
 | IsSelectable | Determines whether this CurveItem can be selected in the graph. (Inherited from CurveItem.)
 | IsSelected | Determines whether this CurveItem is selected on the graph. Note that this value changes the curve displayed color, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsVisible | Determines whether this CurveItem is visible on the graph. Note that this value turns the curve display on or off, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsX2Axis | Gets or sets a value that determines which X axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | IsY2Axis | Gets or sets a value that determines which Y axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | Item[([Int32])] | An accessor for the PointPair datum for this CurveItem. Index is the ordinal reference (zero based) of the point. (Inherited from CurveItem.)
 | Label | A Label instance that represents the Legend entry for the this CurveItem object (Inherited from CurveItem.)
 | LabelDetail | Gets or sets the LabelDetail of this GasGaugeRegion
 | Link | Gets or sets the hyperlink information for this CurveItem. (Inherited from CurveItem.)
 | MakeUnique()() | Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator) (Inherited from CurveItem.)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator) (Inherited from CurveItem.)
 | MaxValue | Gets or sets the MaxValue of this GasGaugeRegion
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinValue | Gets or sets the MinValue of this GasGaugeRegion
 | NPts | Readonly property that gives the number of points that define this CurveItem object, which is the number of points in the Points data collection. (Inherited from CurveItem.)
 | Points | The IPointList of X,Y point sets that represent this CurveItem. (Inherited from CurveItem.)
 | RegionColor | Gets or sets the RegionColor of this GasGaugeRegion
 | RemovePoint(Int32) | Removes a single point from this CurveItem. (Inherited from CurveItem.)
 | schema2 | Current schema value that defines the version of the serialized file
 | SlicePath | Gets or sets the SlicePath of this GasGaugeRegion
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the CurveItem. ZedGraph does not use this value for any purpose. (Inherited from CurveItem.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValueAxis(GraphPane) | Returns a reference to the Axis object that is the "value" (dependent axis) from which the points are drawn. (Inherited from CurveItem.)
 | YAxisIndex | Gets or sets the index number of the Y Axis to which this CurveItem belongs. (Inherited from CurveItem.)
Inheritance Hierarchy
Object
 | CurveItem
 |  | GasGaugeRegion


GasGaugeRegion Constructor

GasGaugeRegion Constructor
Namespaces ► ZedGraph ► GasGaugeRegion ► GasGaugeRegionGasGaugeRegionNew()()
Members
Icon | Member | Description
 | GasGaugeRegionGasGaugeRegionNew(String, Double, Double, Color) | Create a new GasGaugeRegion
 | GasGaugeRegionGasGaugeRegionNew(GasGaugeRegion) | The Copy Constructor


GasGaugeRegion Constructor (label, minVal, maxVal, color)

GasGaugeRegion Constructor (label, minVal, maxVal, color)
Namespaces ► ZedGraph ► GasGaugeRegion ► GasGaugeRegionGasGaugeRegionNew(String, Double, Double, Color)
Create a new GasGaugeRegion
Declaration Syntax
C# Visual Basic Visual C++
public GasGaugeRegion(
    string label,
    double minVal,
    double maxVal,
    Color color
)
Public Sub New ( _
    label As String, _
    minVal As Double, _
    maxVal As Double, _
    color As Color _
)
public:
GasGaugeRegion (
    String^ label,
    double minVal,
    double maxVal,
    Color color
)
Parameters
label (String)
The value associated with this GasGaugeRegion instance.
minVal (Double)
The minimum value of this GasGaugeNeedle.
maxVal (Double)
The maximum value of this GasGaugeNeedle.
color (Color)
The display color for this GasGaugeRegion instance.


GasGaugeRegion Constructor (ggr)

GasGaugeRegion Constructor (ggr)
Namespaces ► ZedGraph ► GasGaugeRegion ► GasGaugeRegionGasGaugeRegionNew(GasGaugeRegion)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public GasGaugeRegion(
    GasGaugeRegion ggr
)
Public Sub New ( _
    ggr As GasGaugeRegion _
)
public:
GasGaugeRegion (
    GasGaugeRegion^ ggr
)
Parameters
ggr (GasGaugeRegion)
The GasGaugeRegion object from which to copy


Border Property

Border Property
Namespaces ► ZedGraph ► GasGaugeRegion ► Border
Gets or sets the Border of this GasGaugeRegion
Declaration Syntax
C# Visual Basic Visual C++
public Border Border{ get; set;}
Public Property Border As Border
public:
property Border^ Border {
    Border^ get ();
    void set (Border^ value);
}


CalcRectangle Method (g, pane, scaleFactor, chartRect)

CalcRectangle Method (g, pane, scaleFactor, chartRect)
Namespaces ► ZedGraph ► GasGaugeRegion ► CalcRectangle(Graphics, GraphPane, Single, RectangleF)
Calculate the RectangleF that will be used to define the bounding rectangle of the GasGaugeNeedle.
Declaration Syntax
C# Visual Basic Visual C++
public static RectangleF CalcRectangle(
    Graphics g,
    GraphPane pane,
    float scaleFactor,
    RectangleF chartRect
)
Public Shared Function CalcRectangle ( _
    g As Graphics, _
    pane As GraphPane, _
    scaleFactor As Single, _
    chartRect As RectangleF _
) As RectangleF
public:
static RectangleF CalcRectangle (
    Graphics^ g,
    GraphPane^ pane,
    float scaleFactor,
    RectangleF chartRect
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
chartRect (RectangleF)
The RectangleF (normally the Rect) that bounds this pie.
Return Value
Remarks
This rectangle always lies inside of the Rect, and it is normally a square so that the pie itself is not oval-shaped.


CalculateGasGuageParameters Method (pane)

CalculateGasGuageParameters Method (pane)
Namespaces ► ZedGraph ► GasGaugeRegion ► CalculateGasGuageParameters(GraphPane)
Calculate the values needed to properly display this GasGaugeRegion.
Declaration Syntax
C# Visual Basic Visual C++
public static void CalculateGasGuageParameters(
    GraphPane pane
)
Public Shared Sub CalculateGasGuageParameters ( _
    pane As GraphPane _
)
public:
static void CalculateGasGuageParameters (
    GraphPane^ pane
)
Parameters
pane (GraphPane)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.


Clone Method

Clone Method
Namespaces ► ZedGraph ► GasGaugeRegion ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public GasGaugeRegion Clone()
Public Function Clone As GasGaugeRegion
public:
GasGaugeRegion^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, pos, scaleFactor)

Draw Method (g, pane, pos, scaleFactor)
Namespaces ► ZedGraph ► GasGaugeRegion ► Draw(Graphics, GraphPane, Int32, Single)
Do all rendering associated with this GasGaugeRegion item to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object.
Declaration Syntax
C# Visual Basic Visual C++
public override void Draw(
    Graphics g,
    GraphPane pane,
    int pos,
    float scaleFactor
)
Public Overrides Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    pos As Integer, _
    scaleFactor As Single _
)
public:
virtual void Draw (
    Graphics^ g,
    GraphPane^ pane,
    int pos,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
pos (Int32)
Not used for rendering GasGaugeNeedle
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


DrawLegendKey Method (g, pane, rect, scaleFactor)

DrawLegendKey Method (g, pane, rect, scaleFactor)
Namespaces ► ZedGraph ► GasGaugeRegion ► DrawLegendKey(Graphics, GraphPane, RectangleF, Single)
Render the label for this GasGaugeRegion.
Declaration Syntax
C# Visual Basic Visual C++
public override void DrawLegendKey(
    Graphics g,
    GraphPane pane,
    RectangleF rect,
    float scaleFactor
)
Public Overrides Sub DrawLegendKey ( _
    g As Graphics, _
    pane As GraphPane, _
    rect As RectangleF, _
    scaleFactor As Single _
)
public:
virtual void DrawLegendKey (
    Graphics^ g,
    GraphPane^ pane,
    RectangleF rect,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
rect (RectangleF)
Bounding rectangle for this GasGaugeRegion.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


Fill Property

Fill Property
Namespaces ► ZedGraph ► GasGaugeRegion ► Fill
Gets or sets the Fill of this GasGaugeRegion
Declaration Syntax
C# Visual Basic Visual C++
public Fill Fill{ get; set;}
Public Property Fill As Fill
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}


GetCoords Method (pane, i, coords)

GetCoords Method (pane, i, coords)
Namespaces ► ZedGraph ► GasGaugeRegion ► GetCoords(GraphPane, Int32, String%)
Determine the coords for the rectangle associated with a specified point for this CurveItem
Declaration Syntax
C# Visual Basic Visual C++
public override bool GetCoords(
    GraphPane pane,
    int i,
    out string coords
)
Public Overrides Function GetCoords ( _
    pane As GraphPane, _
    i As Integer, _
    <OutAttribute> ByRef coords As String _
) As Boolean
public:
virtual bool GetCoords (
    GraphPane^ pane,
    int i,
    [OutAttribute] String^% coords
) override
Parameters
pane (GraphPane)
The GraphPane to which this curve belongs
i (Int32)
The index of the point of interest
coords (String %)
A list of coordinates that represents the "rect" for this point (used in an html AREA tag)
Return Value
true if it's a valid point, false otherwise


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► GasGaugeRegion ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


LabelDetail Property

LabelDetail Property
Namespaces ► ZedGraph ► GasGaugeRegion ► LabelDetail
Gets or sets the LabelDetail of this GasGaugeRegion
Declaration Syntax
C# Visual Basic Visual C++
public TextObj LabelDetail{ get; set;}
Public Property LabelDetail As TextObj
public:
property TextObj^ LabelDetail {
    TextObj^ get ();
    void set (TextObj^ value);
}


MaxValue Property

MaxValue Property
Namespaces ► ZedGraph ► GasGaugeRegion ► MaxValue
Gets or sets the MaxValue of this GasGaugeRegion
Declaration Syntax
C# Visual Basic Visual C++
public double MaxValue{ get; set;}
Public Property MaxValue As Double
public:
property double MaxValue {
    double get ();
    void set (double value);
}


MinValue Property

MinValue Property
Namespaces ► ZedGraph ► GasGaugeRegion ► MinValue
Gets or sets the MinValue of this GasGaugeRegion
Declaration Syntax
C# Visual Basic Visual C++
public double MinValue{ get; set;}
Public Property MinValue As Double
public:
property double MinValue {
    double get ();
    void set (double value);
}


RegionColor Property

RegionColor Property
Namespaces ► ZedGraph ► GasGaugeRegion ► RegionColor
Gets or sets the RegionColor of this GasGaugeRegion
Declaration Syntax
C# Visual Basic Visual C++
public Color RegionColor{ get; set;}
Public Property RegionColor As Color
public:
property Color RegionColor {
    Color get ();
    void set (Color value);
}


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► GasGaugeRegion ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


SlicePath Property

SlicePath Property
Namespaces ► ZedGraph ► GasGaugeRegion ► SlicePath
Gets or sets the SlicePath of this GasGaugeRegion
Declaration Syntax
C# Visual Basic Visual C++
public GraphicsPath SlicePath{ get;}
Public ReadOnly Property SlicePath As GraphicsPath
public:
property GraphicsPath^ SlicePath {
    GraphicsPath^ get ();
}


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► GasGaugeRegion ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


GasGaugeRegion.Default Structure

GasGaugeRegion..::Default Structure
Namespaces ► ZedGraph ► GasGaugeRegion ► GasGaugeRegion..::Default
Specify the default property values for the GasGaugeRegion class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BorderColor | The default value for the color of the GasGaugeRegion border
 | BorderWidth | The default border pen width for the GasGaugeRegion
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | FillBrush | The default value for the fill brush of the GasGaugeRegion
 | FillColor | The default value for the color of the GasGaugeRegion fill
 | FillType | The default fill type for the GasGaugeRegion
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontSize | The default value for the font size of the GasGaugeRegion labels.
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsBorderVisible | The default value for the visibility of the GasGaugeRegion border.
 | isVisible | The default value for the visibility of the GasGaugeRegion fill.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


BorderColor Field

BorderColor Field
Namespaces ► ZedGraph ► GasGaugeRegion..::Default ► BorderColor
The default value for the color of the GasGaugeRegion border
Declaration Syntax
C# Visual Basic Visual C++
public static Color BorderColor
Public Shared BorderColor As Color
public:
static Color BorderColor


BorderWidth Field

BorderWidth Field
Namespaces ► ZedGraph ► GasGaugeRegion..::Default ► BorderWidth
The default border pen width for the GasGaugeRegion
Declaration Syntax
C# Visual Basic Visual C++
public static float BorderWidth
Public Shared BorderWidth As Single
public:
static float BorderWidth


FillBrush Field

FillBrush Field
Namespaces ► ZedGraph ► GasGaugeRegion..::Default ► FillBrush
The default value for the fill brush of the GasGaugeRegion
Declaration Syntax
C# Visual Basic Visual C++
public static Brush FillBrush
Public Shared FillBrush As Brush
public:
static Brush^ FillBrush


FillColor Field

FillColor Field
Namespaces ► ZedGraph ► GasGaugeRegion..::Default ► FillColor
The default value for the color of the GasGaugeRegion fill
Declaration Syntax
C# Visual Basic Visual C++
public static Color FillColor
Public Shared FillColor As Color
public:
static Color FillColor


FillType Field

FillType Field
Namespaces ► ZedGraph ► GasGaugeRegion..::Default ► FillType
The default fill type for the GasGaugeRegion
Declaration Syntax
C# Visual Basic Visual C++
public static FillType FillType
Public Shared FillType As FillType
public:
static FillType FillType


FontSize Field

FontSize Field
Namespaces ► ZedGraph ► GasGaugeRegion..::Default ► FontSize
The default value for the font size of the GasGaugeRegion labels.
Declaration Syntax
C# Visual Basic Visual C++
public static float FontSize
Public Shared FontSize As Single
public:
static float FontSize


IsBorderVisible Field

IsBorderVisible Field
Namespaces ► ZedGraph ► GasGaugeRegion..::Default ► IsBorderVisible
The default value for the visibility of the GasGaugeRegion border.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsBorderVisible
Public Shared IsBorderVisible As Boolean
public:
static bool IsBorderVisible


isVisible Field

isVisible Field
Namespaces ► ZedGraph ► GasGaugeRegion..::Default ► isVisible
The default value for the visibility of the GasGaugeRegion fill.
Declaration Syntax
C# Visual Basic Visual C++
public static bool isVisible
Public Shared isVisible As Boolean
public:
static bool isVisible


GraphObj Class

GraphObj Class
Namespaces ► ZedGraph ► GraphObj
An abstract base class that represents a text object on the graph. A list of GraphObj objects is maintained by the GraphObjList collection class.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class GraphObj : ISerializable,
    ICloneable
<SerializableAttribute> _
Public MustInherit Class GraphObj _
    Implements ISerializable, ICloneable
[SerializableAttribute]
public ref class GraphObj abstract : ISerializable,
    ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GraphObjGraphObjNew()() | Default constructor that sets all GraphObj properties to default values as defined in the GraphObj..::Default class.
 | GraphObjGraphObjNew(Double, Double) | Constructor that sets all GraphObj properties to default values as defined in the GraphObj..::Default class.
 | GraphObjGraphObjNew(Double, Double, Double, Double) | Constructor that creates a GraphObj with the specified coordinates and all other properties to defaults as specified in the GraphObj..::Default class..
 | GraphObjGraphObjNew(Double, Double, CoordType) | Constructor that creates a GraphObj with the specified position and CoordType. Other properties are set to default values as defined in the GraphObj..::Default class.
 | GraphObjGraphObjNew(Double, Double, CoordType, AlignH, AlignV) | Constructor that creates a GraphObj with the specified position, CoordType, AlignH, and AlignV. Other properties are set to default values as defined in the GraphObj..::Default class.
 | GraphObjGraphObjNew(Double, Double, Double, Double, CoordType, AlignH, AlignV) | Constructor that creates a GraphObj with the specified position, CoordType, AlignH, and AlignV. Other properties are set to default values as defined in the GraphObj..::Default class.
 | GraphObjGraphObjNew(GraphObj) | The Copy Constructor
 | Draw(Graphics, PaneBase, Single) | Render this GraphObj object to the specified Graphics device.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCoords(PaneBase, Graphics, Single, String%, String%) | Determines the shape type and Coords values for this GraphObj
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsClippedToChartRect | Gets or sets a value that determines whether or not the rendering of this GraphObj will be clipped to the Rect.
 | IsInFrontOfData | true if the ZOrder of this object is set to put it in front of the CurveItem data points.
 | IsVisible | Gets or sets a value that determines if this GraphObj will be visible in the graph. true displays the item, false hides it.
 | Link | Gets or sets the hyperlink information for this GraphObj.
 | Location | The Location struct that describes the location for this GraphObj.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PointInBox(PointF, PaneBase, Graphics, Single) | Determine if the specified screen point lies inside the bounding box of this GraphObj.
 | schema | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone.
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the GraphObj. ZedGraph does not use this value for any purpose.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ZOrder | Gets or sets a value that determines the z-order "depth" of this item relative to other graphic objects.
Inheritance Hierarchy
Object
 | GraphObj
 |  | LineObj
 |  | BoxObj
 |  | TextObj
 |  | ImageObj


GraphObj Constructor

GraphObj Constructor
Namespaces ► ZedGraph ► GraphObj ► GraphObjGraphObjNew()()
Constructors for the GraphObj class.
Members
Icon | Member | Description
 | GraphObjGraphObjNew()() | Default constructor that sets all GraphObj properties to default values as defined in the GraphObj..::Default class.
 | GraphObjGraphObjNew(Double, Double) | Constructor that sets all GraphObj properties to default values as defined in the GraphObj..::Default class.
 | GraphObjGraphObjNew(Double, Double, Double, Double) | Constructor that creates a GraphObj with the specified coordinates and all other properties to defaults as specified in the GraphObj..::Default class..
 | GraphObjGraphObjNew(Double, Double, CoordType) | Constructor that creates a GraphObj with the specified position and CoordType. Other properties are set to default values as defined in the GraphObj..::Default class.
 | GraphObjGraphObjNew(Double, Double, CoordType, AlignH, AlignV) | Constructor that creates a GraphObj with the specified position, CoordType, AlignH, and AlignV. Other properties are set to default values as defined in the GraphObj..::Default class.
 | GraphObjGraphObjNew(Double, Double, Double, Double, CoordType, AlignH, AlignV) | Constructor that creates a GraphObj with the specified position, CoordType, AlignH, and AlignV. Other properties are set to default values as defined in the GraphObj..::Default class.
 | GraphObjGraphObjNew(GraphObj) | The Copy Constructor


GraphObj Constructor

GraphObj Constructor
Namespaces ► ZedGraph ► GraphObj ► GraphObjGraphObjNew()()
Default constructor that sets all GraphObj properties to default values as defined in the GraphObj..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public GraphObj()
Public Sub New
public:
GraphObj ()


GraphObj Constructor (x, y)

GraphObj Constructor (x, y)
Namespaces ► ZedGraph ► GraphObj ► GraphObjGraphObjNew(Double, Double)
Constructor that sets all GraphObj properties to default values as defined in the GraphObj..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public GraphObj(
    double x,
    double y
)
Public Sub New ( _
    x As Double, _
    y As Double _
)
public:
GraphObj (
    double x,
    double y
)
Parameters
x (Double)
The x position of the text. The units of this position are specified by the CoordinateFrame property. The text will be aligned to this position based on the AlignH property.
y (Double)
The y position of the text. The units of this position are specified by the CoordinateFrame property. The text will be aligned to this position based on the AlignV property.


GraphObj Constructor (x, y, x2, y2)

GraphObj Constructor (x, y, x2, y2)
Namespaces ► ZedGraph ► GraphObj ► GraphObjGraphObjNew(Double, Double, Double, Double)
Constructor that creates a GraphObj with the specified coordinates and all other properties to defaults as specified in the GraphObj..::Default class..
Declaration Syntax
C# Visual Basic Visual C++
public GraphObj(
    double x,
    double y,
    double x2,
    double y2
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    x2 As Double, _
    y2 As Double _
)
public:
GraphObj (
    double x,
    double y,
    double x2,
    double y2
)
Parameters
x (Double)
The x position of the item.
y (Double)
The y position of the item.
x2 (Double)
The x2 position of the item.
y2 (Double)
The x2 position of the item.
Remarks
The four coordinates define the starting point and ending point for ArrowObj's, or the topleft and bottomright points for ImageObj's. For GraphObj's that only require one point, the and values will be ignored. The units of the coordinates are specified by the CoordinateFrame property.


GraphObj Constructor (x, y, x2, y2, coordType, alignH, alignV)

GraphObj Constructor (x, y, x2, y2, coordType, alignH, alignV)
Namespaces ► ZedGraph ► GraphObj ► GraphObjGraphObjNew(Double, Double, Double, Double, CoordType, AlignH, AlignV)
Constructor that creates a GraphObj with the specified position, CoordType, AlignH, and AlignV. Other properties are set to default values as defined in the GraphObj..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public GraphObj(
    double x,
    double y,
    double x2,
    double y2,
    CoordType coordType,
    AlignH alignH,
    AlignV alignV
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    x2 As Double, _
    y2 As Double, _
    coordType As CoordType, _
    alignH As AlignH, _
    alignV As AlignV _
)
public:
GraphObj (
    double x,
    double y,
    double x2,
    double y2,
    CoordType coordType,
    AlignH alignH,
    AlignV alignV
)
Parameters
x (Double)
The x position of the item.
y (Double)
The y position of the item.
x2 (Double)
The x2 position of the item.
y2 (Double)
The x2 position of the item.
coordType (CoordType)
The CoordType enum value that indicates what type of coordinate system the x and y parameters are referenced to.
alignH (AlignH)
The AlignH enum that specifies the horizontal alignment of the object with respect to the (x,y) location
alignV (AlignV)
The AlignV enum that specifies the vertical alignment of the object with respect to the (x,y) location
Remarks
The four coordinates define the starting point and ending point for ArrowObj's, or the topleft and bottomright points for ImageObj's. For GraphObj's that only require one point, the and values will be ignored. The units of the coordinates are specified by the CoordinateFrame property.


GraphObj Constructor (x, y, coordType)

GraphObj Constructor (x, y, coordType)
Namespaces ► ZedGraph ► GraphObj ► GraphObjGraphObjNew(Double, Double, CoordType)
Constructor that creates a GraphObj with the specified position and CoordType. Other properties are set to default values as defined in the GraphObj..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public GraphObj(
    double x,
    double y,
    CoordType coordType
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    coordType As CoordType _
)
public:
GraphObj (
    double x,
    double y,
    CoordType coordType
)
Parameters
x (Double)
The x position of the item. The item will be aligned to this position based on the AlignH property.
y (Double)
The y position of the item. The item will be aligned to this position based on the AlignV property.
coordType (CoordType)
The CoordType enum value that indicates what type of coordinate system the x and y parameters are referenced to.
Remarks
The two coordinates define the location point for the object. The units of the coordinates are specified by the CoordinateFrame property.


GraphObj Constructor (x, y, coordType, alignH, alignV)

GraphObj Constructor (x, y, coordType, alignH, alignV)
Namespaces ► ZedGraph ► GraphObj ► GraphObjGraphObjNew(Double, Double, CoordType, AlignH, AlignV)
Constructor that creates a GraphObj with the specified position, CoordType, AlignH, and AlignV. Other properties are set to default values as defined in the GraphObj..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public GraphObj(
    double x,
    double y,
    CoordType coordType,
    AlignH alignH,
    AlignV alignV
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    coordType As CoordType, _
    alignH As AlignH, _
    alignV As AlignV _
)
public:
GraphObj (
    double x,
    double y,
    CoordType coordType,
    AlignH alignH,
    AlignV alignV
)
Parameters
x (Double)
The x position of the item. The item will be aligned to this position based on the AlignH property.
y (Double)
The y position of the text. The units of this position are specified by the CoordinateFrame property. The text will be aligned to this position based on the AlignV property.
coordType (CoordType)
The CoordType enum value that indicates what type of coordinate system the x and y parameters are referenced to.
alignH (AlignH)
The AlignH enum that specifies the horizontal alignment of the object with respect to the (x,y) location
alignV (AlignV)
The AlignV enum that specifies the vertical alignment of the object with respect to the (x,y) location
Remarks
The two coordinates define the location point for the object. The units of the coordinates are specified by the CoordinateFrame property.


GraphObj Constructor (rhs)

GraphObj Constructor (rhs)
Namespaces ► ZedGraph ► GraphObj ► GraphObjGraphObjNew(GraphObj)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public GraphObj(
    GraphObj rhs
)
Public Sub New ( _
    rhs As GraphObj _
)
public:
GraphObj (
    GraphObj^ rhs
)
Parameters
rhs (GraphObj)
The GraphObj object from which to copy


Draw Method (g, pane, scaleFactor)

Draw Method (g, pane, scaleFactor)
Namespaces ► ZedGraph ► GraphObj ► Draw(Graphics, PaneBase, Single)
Render this GraphObj object to the specified Graphics device.
Declaration Syntax
C# Visual Basic Visual C++
public abstract void Draw(
    Graphics g,
    PaneBase pane,
    float scaleFactor
)
Public MustOverride Sub Draw ( _
    g As Graphics, _
    pane As PaneBase, _
    scaleFactor As Single _
)
public:
virtual void Draw (
    Graphics^ g,
    PaneBase^ pane,
    float scaleFactor
) abstract
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent PaneBase object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Remarks
This method is normally only called by the Draw method of the parent GraphObjList collection object.


GetCoords Method (pane, g, scaleFactor, shape, coords)

GetCoords Method (pane, g, scaleFactor, shape, coords)
Namespaces ► ZedGraph ► GraphObj ► GetCoords(PaneBase, Graphics, Single, String%, String%)
Determines the shape type and Coords values for this GraphObj
Declaration Syntax
C# Visual Basic Visual C++
public abstract void GetCoords(
    PaneBase pane,
    Graphics g,
    float scaleFactor,
    out string shape,
    out string coords
)
Public MustOverride Sub GetCoords ( _
    pane As PaneBase, _
    g As Graphics, _
    scaleFactor As Single, _
    <OutAttribute> ByRef shape As String, _
    <OutAttribute> ByRef coords As String _
)
public:
virtual void GetCoords (
    PaneBase^ pane,
    Graphics^ g,
    float scaleFactor,
    [OutAttribute] String^% shape,
    [OutAttribute] String^% coords
) abstract
Parameters
pane (PaneBase)
g (Graphics)
scaleFactor (Single)
shape (String %)
coords (String %)


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► GraphObj ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsClippedToChartRect Property

IsClippedToChartRect Property
Namespaces ► ZedGraph ► GraphObj ► IsClippedToChartRect
Gets or sets a value that determines whether or not the rendering of this GraphObj will be clipped to the Rect.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClippedToChartRect{ get; set;}
Public Property IsClippedToChartRect As Boolean
public:
property bool IsClippedToChartRect {
    bool get ();
    void set (bool value);
}
Value
true to clip the GraphObj to the Rect bounds, false to leave it unclipped.


IsInFrontOfData Property

IsInFrontOfData Property
Namespaces ► ZedGraph ► GraphObj ► IsInFrontOfData
true if the ZOrder of this object is set to put it in front of the CurveItem data points.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInFrontOfData{ get;}
Public ReadOnly Property IsInFrontOfData As Boolean
public:
property bool IsInFrontOfData {
    bool get ();
}


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph ► GraphObj ► IsVisible
Gets or sets a value that determines if this GraphObj will be visible in the graph. true displays the item, false hides it.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}


Link Property

Link Property
Namespaces ► ZedGraph ► GraphObj ► Link
Gets or sets the hyperlink information for this GraphObj.
Declaration Syntax
C# Visual Basic Visual C++
public Link Link{ get; set;}
Public Property Link As Link
public:
property Link^ Link {
    Link^ get ();
    void set (Link^ value);
}


Location Property

Location Property
Namespaces ► ZedGraph ► GraphObj ► Location
The Location struct that describes the location for this GraphObj.
Declaration Syntax
C# Visual Basic Visual C++
public Location Location{ get; set;}
Public Property Location As Location
public:
property Location^ Location {
    Location^ get ();
    void set (Location^ value);
}


PointInBox Method (pt, pane, g, scaleFactor)

PointInBox Method (pt, pane, g, scaleFactor)
Namespaces ► ZedGraph ► GraphObj ► PointInBox(PointF, PaneBase, Graphics, Single)
Determine if the specified screen point lies inside the bounding box of this GraphObj.
Declaration Syntax
C# Visual Basic Visual C++
public virtual bool PointInBox(
    PointF pt,
    PaneBase pane,
    Graphics g,
    float scaleFactor
)
Public Overridable Function PointInBox ( _
    pt As PointF, _
    pane As PaneBase, _
    g As Graphics, _
    scaleFactor As Single _
) As Boolean
public:
virtual bool PointInBox (
    PointF pt,
    PaneBase^ pane,
    Graphics^ g,
    float scaleFactor
)
Parameters
pt (PointF)
The screen point, in pixels
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent PaneBase object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
true if the point lies in the bounding box, false otherwise


schema Field

schema Field
Namespaces ► ZedGraph ► GraphObj ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema
Remarks
schema changed to 2 when isClippedToChartRect was added.


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► GraphObj ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone.
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object
Remarks
Note that this method must be called with an explicit cast to ICloneable, and that it is inherently virtual. For example:
CopyC#
ParentClass foo = new ChildClass();
ChildClass bar = (ChildClass) ((ICloneable)foo).Clone();
 Assume that ChildClass is inherited from ParentClass. Even though foo is declared with ParentClass, it is actually an instance of ChildClass. Calling the ICloneable implementation of Clone() on foo actually calls ChildClass.Clone() as if it were a virtual function.


Tag Field

Tag Field
Namespaces ► ZedGraph ► GraphObj ► Tag
A tag object for use by the user. This can be used to store additional information associated with the GraphObj. ZedGraph does not use this value for any purpose.
Declaration Syntax
C# Visual Basic Visual C++
public Object Tag
Public Tag As Object
public:
Object^ Tag
Remarks
Note that, if you are going to Serialize ZedGraph data, then any type that you store in Tag must be a serializable type (or it will cause an exception).


ZOrder Property

ZOrder Property
Namespaces ► ZedGraph ► GraphObj ► ZOrder
Gets or sets a value that determines the z-order "depth" of this item relative to other graphic objects.
Declaration Syntax
C# Visual Basic Visual C++
public ZOrder ZOrder{ get; set;}
Public Property ZOrder As ZOrder
public:
property ZOrder ZOrder {
    ZOrder get ();
    void set (ZOrder value);
}
Remarks
Note that this controls the z-order with respect to other elements such as CurveItem's, Axis objects, etc. The order of GraphObj objects having the same ZOrder value is controlled by their order in the GraphObjList. The first GraphObj in the list is drawn in front of other GraphObj objects having the same ZOrder value.


GraphObj.Default Structure

GraphObj..::Default Structure
Namespaces ► ZedGraph ► GraphObj ► GraphObj..::Default
A simple struct that defines the default property values for the GraphObj class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AlignH | Default value for the horizontal GraphObj text alignment (Location property). This is specified using the AlignH enum type.
 | AlignV | Default value for the vertical GraphObj text alignment (Location property). This is specified using the AlignV enum type.
 | CoordFrame | The default coordinate system to be used for defining the GraphObj location coordinates (Location property).
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsClippedToChartRect | The default value for IsClippedToChartRect.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


AlignH Field

AlignH Field
Namespaces ► ZedGraph ► GraphObj..::Default ► AlignH
Default value for the horizontal GraphObj text alignment (Location property). This is specified using the AlignH enum type.
Declaration Syntax
C# Visual Basic Visual C++
public static AlignH AlignH
Public Shared AlignH As AlignH
public:
static AlignH AlignH


AlignV Field

AlignV Field
Namespaces ► ZedGraph ► GraphObj..::Default ► AlignV
Default value for the vertical GraphObj text alignment (Location property). This is specified using the AlignV enum type.
Declaration Syntax
C# Visual Basic Visual C++
public static AlignV AlignV
Public Shared AlignV As AlignV
public:
static AlignV AlignV


CoordFrame Field

CoordFrame Field
Namespaces ► ZedGraph ► GraphObj..::Default ► CoordFrame
The default coordinate system to be used for defining the GraphObj location coordinates (Location property).
Declaration Syntax
C# Visual Basic Visual C++
public static CoordType CoordFrame
Public Shared CoordFrame As CoordType
public:
static CoordType CoordFrame
Value
The coordinate system is defined with the CoordType enum


IsClippedToChartRect Field

IsClippedToChartRect Field
Namespaces ► ZedGraph ► GraphObj..::Default ► IsClippedToChartRect
The default value for IsClippedToChartRect.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsClippedToChartRect
Public Shared IsClippedToChartRect As Boolean
public:
static bool IsClippedToChartRect


GraphObjList Class

GraphObjList Class
Namespaces ► ZedGraph ► GraphObjList
A collection class containing a list of TextObj objects to be displayed on the graph.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class GraphObjList : List<GraphObj>, ICloneable
<SerializableAttribute> _
Public Class GraphObjList _
    Inherits List(Of GraphObj) _
    Implements ICloneable
[SerializableAttribute]
public ref class GraphObjList : public List<GraphObj^>,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GraphObjListGraphObjListNew()() | Default constructor for the GraphObjList collection class
 | GraphObjListGraphObjListNew(GraphObjList) | The Copy Constructor
 | Add(T) | Adds an object to the end of the List<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | AddRange(IEnumerable<(Of <T>)>) | Adds the elements of the specified collection to the end of the List<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | AsReadOnly()() | Returns a read-only IList<(Of <T>)> wrapper for the current collection. (Inherited from List <(Of < GraphObj >)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < GraphObj >)>.)
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of < GraphObj >)>.)
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < GraphObj >)>.)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of < GraphObj >)>.)
 | Clear()() | Removes all elements from the List<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Contains(T) | Determines whether an element is in the List<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | ConvertAll<(Of <TOutput>)>(Converter<(Of <T, TOutput>)>) | Converts the elements in the current List<(Of <T>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of < GraphObj >)>.)
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of < GraphObj >)>.)
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < GraphObj >)>.)
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < GraphObj >)>.)
 | Count | Gets the number of elements actually contained in the List<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | Draw(Graphics, PaneBase, Single, ZOrder) | Render text to the specified Graphics device by calling the Draw method of each GraphObj object in the collection.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <T>)>) | Determines whether the List<(Of <T>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < GraphObj >)>.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | FindAll(Predicate<(Of <T>)>) | Retrieves the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < GraphObj >)>.)
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < GraphObj >)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < GraphObj >)>.)
 | FindLast(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < GraphObj >)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < GraphObj >)>.)
 | FindPoint(PointF, PaneBase, Graphics, Single, Int32%) | Determine if a mouse point is within any GraphObj, and if so, return the index number of the the GraphObj.
 | ForEach(Action<(Of <T>)>) | Performs the specified action on each element of the List<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | GetEnumerator()() | Returns an enumerator that iterates through the List<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < GraphObj >)>.)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < GraphObj >)>.)
 | IndexOfTag(String) | Return the zero-based position index of the GraphObj with the specified Tag.
 | Insert(Int32, T) | Inserts an element into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < GraphObj >)>.)
 | InsertRange(Int32, IEnumerable<(Of <T>)>) | Inserts the elements of a collection into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < GraphObj >)>.)
 | Item[([String])] | Indexer to access the specified GraphObj object by its Tag. Note that the Tag must be a String type for this method to work.
 | Item[([Int32])] | Gets or sets the element at the specified index. (Inherited from List <(Of < GraphObj >)>.)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < GraphObj >)>.)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < GraphObj >)>.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Move(Int32, Int32) | Move the position of the object at the specified index to the new relative position in the list.
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | RemoveAll(Predicate<(Of <T>)>) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < GraphObj >)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of < GraphObj >)>.)
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer. (Inherited from List <(Of < GraphObj >)>.)
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < GraphObj >)>.)
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < GraphObj >)>.)
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>. (Inherited from List <(Of < GraphObj >)>.)
 | ICollection<(Of <T>)>..::IsReadOnly | (Inherited from List <(Of < GraphObj >)>.)
 | IEnumerable<(Of <T>)>..::GetEnumerator()() | (Inherited from List <(Of < GraphObj >)>.)
 | ICollection..::CopyTo(Array, Int32) | (Inherited from List <(Of < GraphObj >)>.)
 | ICollection..::IsSynchronized | (Inherited from List <(Of < GraphObj >)>.)
 | ICollection..::SyncRoot | (Inherited from List <(Of < GraphObj >)>.)
 | IEnumerable..::GetEnumerator()() | (Inherited from List <(Of < GraphObj >)>.)
 | IList..::Add(Object) | (Inherited from List <(Of < GraphObj >)>.)
 | IList..::Contains(Object) | (Inherited from List <(Of < GraphObj >)>.)
 | IList..::IndexOf(Object) | (Inherited from List <(Of < GraphObj >)>.)
 | IList..::Insert(Int32, Object) | (Inherited from List <(Of < GraphObj >)>.)
 | IList..::IsFixedSize | (Inherited from List <(Of < GraphObj >)>.)
 | IList..::IsReadOnly | (Inherited from List <(Of < GraphObj >)>.)
 | IList..::Item[([Int32])] | (Inherited from List <(Of < GraphObj >)>.)
 | IList..::Remove(Object) | (Inherited from List <(Of < GraphObj >)>.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToArray()() | Copies the elements of the List<(Of <T>)> to a new array. (Inherited from List <(Of < GraphObj >)>.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()() | Sets the capacity to the actual number of elements in the List<(Of <T>)>, if that number is less than a threshold value. (Inherited from List <(Of < GraphObj >)>.)
 | TrueForAll(Predicate<(Of <T>)>) | Determines whether every element in the List<(Of <T>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of < GraphObj >)>.)
Inheritance Hierarchy
Object
 | List <(Of < GraphObj >)>
 |  | GraphObjList


GraphObjList Constructor

GraphObjList Constructor
Namespaces ► ZedGraph ► GraphObjList ► GraphObjListGraphObjListNew()()
Members
Icon | Member | Description
 | GraphObjListGraphObjListNew()() | Default constructor for the GraphObjList collection class
 | GraphObjListGraphObjListNew(GraphObjList) | The Copy Constructor


GraphObjList Constructor

GraphObjList Constructor
Namespaces ► ZedGraph ► GraphObjList ► GraphObjListGraphObjListNew()()
Default constructor for the GraphObjList collection class
Declaration Syntax
C# Visual Basic Visual C++
public GraphObjList()
Public Sub New
public:
GraphObjList ()


GraphObjList Constructor (rhs)

GraphObjList Constructor (rhs)
Namespaces ► ZedGraph ► GraphObjList ► GraphObjListGraphObjListNew(GraphObjList)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public GraphObjList(
    GraphObjList rhs
)
Public Sub New ( _
    rhs As GraphObjList _
)
public:
GraphObjList (
    GraphObjList^ rhs
)
Parameters
rhs (GraphObjList)
The GraphObjList object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► GraphObjList ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public GraphObjList Clone()
Public Function Clone As GraphObjList
public:
GraphObjList^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, scaleFactor, zOrder)

Draw Method (g, pane, scaleFactor, zOrder)
Namespaces ► ZedGraph ► GraphObjList ► Draw(Graphics, PaneBase, Single, ZOrder)
Render text to the specified Graphics device by calling the Draw method of each GraphObj object in the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    PaneBase pane,
    float scaleFactor,
    ZOrder zOrder
)
Public Sub Draw ( _
    g As Graphics, _
    pane As PaneBase, _
    scaleFactor As Single, _
    zOrder As ZOrder _
)
public:
void Draw (
    Graphics^ g,
    PaneBase^ pane,
    float scaleFactor,
    ZOrder zOrder
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
zOrder (ZOrder)
A ZOrder enumeration that controls the placement of this GraphObj relative to other graphic objects. The order of GraphObj's with the same ZOrder value is control by their order in this GraphObjList.
Remarks
This method is normally only called by the Draw method of the parent GraphPane object.


FindPoint Method (mousePt, pane, g, scaleFactor, index)

FindPoint Method (mousePt, pane, g, scaleFactor, index)
Namespaces ► ZedGraph ► GraphObjList ► FindPoint(PointF, PaneBase, Graphics, Single, Int32%)
Determine if a mouse point is within any GraphObj, and if so, return the index number of the the GraphObj.
Declaration Syntax
C# Visual Basic Visual C++
public bool FindPoint(
    PointF mousePt,
    PaneBase pane,
    Graphics g,
    float scaleFactor,
    out int index
)
Public Function FindPoint ( _
    mousePt As PointF, _
    pane As PaneBase, _
    g As Graphics, _
    scaleFactor As Single, _
    <OutAttribute> ByRef index As Integer _
) As Boolean
public:
bool FindPoint (
    PointF mousePt,
    PaneBase^ pane,
    Graphics^ g,
    float scaleFactor,
    [OutAttribute] int% index
)
Parameters
mousePt (PointF)
The screen point, in pixel coordinates.
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
index (Int32 %)
The index number of the TextObj that is under the mouse point. The TextObj object is accessible via the GraphObjList indexer property.
Return Value
true if the mouse point is within a GraphObj bounding box, false otherwise.
See Also
FindNearestObject(PointF, Graphics, Object%, Int32%)


IndexOfTag Method (tag)

IndexOfTag Method (tag)
Namespaces ► ZedGraph ► GraphObjList ► IndexOfTag(String)
Return the zero-based position index of the GraphObj with the specified Tag.
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOfTag(
    string tag
)
Public Function IndexOfTag ( _
    tag As String _
) As Integer
public:
int IndexOfTag (
    String^ tag
)
Parameters
tag (String)
The String tag that is in the Tag attribute of the item to be found.
Return Value
The zero-based index of the specified GraphObj, or -1 if the GraphObj is not in the list
Remarks
In order for this method to work, the Tag property must be of type String.


Item Property (tag)

Item Property (tag)
Namespaces ► ZedGraph ► GraphObjList ► Item[([String])]
Indexer to access the specified GraphObj object by its Tag. Note that the Tag must be a String type for this method to work.
Declaration Syntax
C# Visual Basic Visual C++
public GraphObj this[
    string tag
]{ get;}
Public ReadOnly Default Property Item ( _
    tag As String _
) As GraphObj
public:
property GraphObj^ default[String^ tag] {
    GraphObj^ get (String^ tag);
}
Parameters
tag (String)
The String type tag to search for.
Value
A GraphObj object reference.
See Also
IndexOfTag(String)


Move Method (index, relativePos)

Move Method (index, relativePos)
Namespaces ► ZedGraph ► GraphObjList ► Move(Int32, Int32)
Move the position of the object at the specified index to the new relative position in the list.
Declaration Syntax
C# Visual Basic Visual C++
public int Move(
    int index,
    int relativePos
)
Public Function Move ( _
    index As Integer, _
    relativePos As Integer _
) As Integer
public:
int Move (
    int index,
    int relativePos
)
Parameters
index (Int32)
The zero-based index of the object to be moved.
relativePos (Int32)
The relative number of positions to move the object. A value of -1 will move the object one position earlier in the list, a value of 1 will move it one position later. To move an item to the beginning of the list, use a large negative value (such as -999). To move it to the end of the list, use a large positive value.
Return Value
The new position for the object, or -1 if the object was not found.
Remarks
For Graphic type objects, this method controls the Z-Order of the items. Objects at the beginning of the list appear in front of objects at the end of the list.


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► GraphObjList ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


GraphPane Class

GraphPane Class
Namespaces ► ZedGraph ► GraphPane
Class GraphPane encapsulates the graph pane, which is all display elements associated with an individual graph.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class GraphPane : PaneBase, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class GraphPane _
    Inherits PaneBase _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class GraphPane : public PaneBase,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GraphPaneGraphPaneNew()() | Default Constructor. Sets the Rect to (0, 0, 500, 375), and sets the Title and Title values to empty strings.
 | GraphPaneGraphPaneNew(RectangleF, String, String, String) | Constructor for the GraphPane object. This routine will initialize all member variables and classes, setting appropriate default values as defined in the GraphPane..::Default class.
 | GraphPaneGraphPaneNew(GraphPane) | The Copy Constructor
 | AddBar(String, IPointList, Color) | Add a bar type curve (CurveItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddBar(String, array<Double>[](), array<Double>[](), Color) | Add a bar type curve (CurveItem object) to the plot with the given data points (double arrays) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddCurve(String, array<Double>[](), array<Double>[](), Color) | Add a curve (CurveItem object) to the plot with the given data points (double arrays) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddCurve(String, IPointList, Color) | Add a curve (CurveItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddCurve(String, array<Double>[](), array<Double>[](), Color, SymbolType) | Add a curve (CurveItem object) to the plot with the given data points (double arrays) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddCurve(String, IPointList, Color, SymbolType) | Add a curve (CurveItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddErrorBar(String, array<Double>[](), array<Double>[](), array<Double>[](), Color) | Add an error bar set (ErrorBarItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddErrorBar(String, IPointList, Color) | Add an error bar set (ErrorBarItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddHiLowBar(String, array<Double>[](), array<Double>[](), array<Double>[](), Color) | Add a "High-Low" bar type curve (HiLowBarItem object) to the plot with the given data points (double arrays) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddHiLowBar(String, IPointList, Color) | Add a hi-low bar type curve (CurveItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddJapaneseCandleStick(String, IPointList) | Add a japanesecandlestick graph (JapaneseCandleStickItem object) to the plot with the given data points (IPointList) and properties.
 | AddOHLCBar(String, IPointList, Color) | Add a candlestick graph (OHLCBarItem object) to the plot with the given data points (IPointList) and properties.
 | AddPieSlice(Double, Color, Double, String) | Add a PieItem to the display.
 | AddPieSlice(Double, Color, Color, Single, Double, String) | Add a PieItem to the display, providing a gradient fill for the pie color.
 | AddPieSlices(array<Double>[](), array<String>[]()) | Creates all the PieItems for a single Pie Chart.
 | AddStick(String, array<Double>[](), array<Double>[](), Color) | Add a stick graph (StickItem object) to the plot with the given data points (double arrays) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddStick(String, IPointList, Color) | Add a stick graph (StickItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddY2Axis(String) | Add a secondary Y2Axis (right side) to the list of axes in the Graph.
 | AddYAxis(String) | Add a secondary YAxis (left side) to the list of axes in the Graph.
 | AxisChange()() | AxisChange causes the axes scale ranges to be recalculated based on the current data range.
 | AxisChange(Graphics) | AxisChange causes the axes scale ranges to be recalculated based on the current data range.
 | AxisChangeEvent | Subscribe to this event to be notified when AxisChange()() is called.
 | BarSettings | Gets the BarSettings instance for this GraphPane, which stores the global properties for bar type charts.
 | BaseDimension | BaseDimension is a double precision value that sets "normal" pane size on which all the settings are based. The BaseDimension is in inches. For example, if the BaseDimension is 8.0 inches and the Title size is 14 points. Then the pane title font will be 14 points high when the Rect is approximately 8.0 inches wide. If the Rect is 4.0 inches wide, the pane title font will be 7 points high. Most features of the graph are scaled in this manner. (Inherited from PaneBase.)
 | Border | Gets or sets the Border class for drawing the border border around the Rect (Inherited from PaneBase.)
 | CalcChartRect(Graphics) | Calculate the Rect based on the Rect.
 | CalcChartRect(Graphics, Single) | Calculate the Rect based on the Rect.
 | CalcClientRect(Graphics, Single) | Calculate the client area rectangle based on the Rect. (Inherited from PaneBase.)
 | CalcScaleFactor()() | Calculate the scaling factor based on the ratio of the current Rect dimensions and the BaseDimension. (Inherited from PaneBase.)
 | Chart | Gets the Chart instance for this GraphPane.
 | Clone()() | Typesafe, deep-copy clone method.
 | CurveList | Gets or sets the list of CurveItem items for this GraphPane
 | Draw(Graphics) | Draw all elements in the GraphPane to the specified graphics device. (Overrides PaneBase.Draw(Graphics).)
 | DrawPaneFrame(Graphics, Single) | Draw the border _border around the Rect area. (Inherited from PaneBase.)
 | DrawTitle(Graphics, Single) | Draw the Title on the graph, centered at the top of the pane. (Inherited from PaneBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Gets or sets the Fill data for the filling the background of the Rect. (Inherited from PaneBase.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindContainedObjects(RectangleF, Graphics, CurveList%) | Find any objects that exist within the specified (screen) rectangle. This method will search through all of the graph objects, such as Axis, Legend, Title, GraphObj, and CurveItem. and see if the objects' bounding boxes are within the specified (screen) rectangle This method returns true if any are found.
 | FindLinkableObject(PointF, Graphics, Single, Object%, Link%, Int32%) | Search through the GraphObjList and CurveList for items that contain active Link objects.
 | FindNearestObject(PointF, Graphics, Object%, Int32%) | Find the object that lies closest to the specified mouse (screen) point.
 | FindNearestPoint(PointF, CurveItem, CurveItem%, Int32%) | Find the data point that lies closest to the specified mouse (screen) point for the specified curve.
 | FindNearestPoint(PointF, CurveItem%, Int32%) | Find the data point that lies closest to the specified mouse (screen) point.
 | FindNearestPoint(PointF, CurveList, CurveItem%, Int32%) | Find the data point that lies closest to the specified mouse (screen) point.
 | GeneralTransform(PointF, CoordType) | Transform a data point from the specified coordinate type (CoordType) to screen coordinates (pixels).
 | GeneralTransform(Double, Double, CoordType) | Transform a data point from the specified coordinate type (CoordType) to screen coordinates (pixels).
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetImage()() | Build a Bitmap object containing the graphical rendering of all the GraphPane objects in this list. (Inherited from PaneBase.)
 | GetImage(Int32, Int32, Single) | Gets an image for the current GraphPane, scaled to the specified size and resolution. (Inherited from PaneBase.)
 | GetMetafile(Int32, Int32) | Gets an enhanced metafile image for the current GraphPane, scaled to the specified size. (Inherited from PaneBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides PaneBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GraphObjList | Gets or sets the list of GraphObj items for this GraphPane (Inherited from PaneBase.)
 | IsAlignGrids | Gets or sets a value that determines if ZedGraph should modify the scale ranges for the Y and Y2 axes such that the number of major steps, and therefore the major grid lines, line up.
 | IsBoundedRanges | Gets or sets a boolean value that determines if the auto-scaled axis ranges will subset the data points based on any manually set scale range values.
 | IsFontsScaled | Determines if the font sizes, tic sizes, gap sizes, etc. will be scaled according to the size of the Rect and the BaseDimension. If this value is set to false, then the font sizes and tic sizes will always be exactly as specified, without any scaling. (Inherited from PaneBase.)
 | IsIgnoreInitial | Gets or sets a boolean value that affects the data range that is considered for the automatic scale ranging.
 | IsIgnoreMissing | Gets or sets a value that determines whether or not initial Missing values will cause the line segments of a curve to be discontinuous.
 | IsPenWidthScaled | Gets or sets the property that controls whether or not pen widths are scaled for this PaneBase. (Inherited from PaneBase.)
 | IsZoomed | Gets a value that indicates whether or not the ZoomStateStack for this GraphPane is empty. Note that this value is only used for the ZedGraphControl.
 | Legend | Accesses the Legend for this PaneBase (Inherited from PaneBase.)
 | LineType | Determines how the LineItem graphs will be displayed. See the LineType enum for the individual types available.
 | Margin | Gets or sets the Margin instance that controls the space between the edge of the Rect and the rendered content of the graph. (Inherited from PaneBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Rect | The rectangle that defines the full area into which all graphics will be rendered. (Inherited from PaneBase.)
 | ReSize(Graphics, RectangleF) | Change the size of the Rect. Override this method to handle resizing the contents as required. (Inherited from PaneBase.)
 | ReverseTransform(PointF, Double%, Double%) | Return the user scale values that correspond to the specified screen coordinate position (pixels). This overload assumes the default XAxis and YAxis.
 | ReverseTransform(PointF, Double%, Double%, Double%, Double%) | Return the user scale values that correspond to the specified screen coordinate position (pixels).
 | ReverseTransform(PointF, Boolean, Boolean, Int32, Double%, Double%) | Return the user scale values that correspond to the specified screen coordinate position (pixels).
 | ReverseTransform(PointF, Double%, Double%, array<Double>[]()%, array<Double>[]()%) | Return the user scale values that correspond to the specified screen coordinate position (pixels) for all y axes.
 | ScaledPenWidth(Single, Single) | Calculate the scaled pen width, taking into account the scaleFactor and the setting of the IsPenWidthScaled property of the pane. (Inherited from PaneBase.)
 | schema2 | Current schema value that defines the version of the serialized file
 | SetMinSpaceBuffer(Graphics, Single, Boolean) | This method will set the MinSpace property for all three axes; XAxis, YAxis, and Y2Axis.
 | ShallowClone()() | Create a shallow, memberwise copy of this class. (Inherited from PaneBase.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | Gets or sets the user-defined tag for this PaneBase. This tag can be any user-defined value. If it is a String type, it can be used as a parameter to the IndexOfTag(String) method. (Inherited from PaneBase.)
 | Title | Gets the Label instance that contains the text and attributes of the title. This text can be multiple lines separated by newline characters ('\n'). (Inherited from PaneBase.)
 | TitleGap | Gets or sets the gap between the bottom of the pane title and the client area of the pane. This is expressed as a fraction of the scaled Title character height. (Inherited from PaneBase.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | X2Axis | Accesses the X2Axis for this graph
 | XAxis | Accesses the XAxis for this graph
 | Y2Axis | Accesses the primary Y2Axis for this graph
 | Y2AxisList | Gets the collection of Y2 axes that belong to this GraphPane.
 | YAxis | Accesses the primary YAxis for this graph
 | YAxisList | Gets the collection of Y axes that belong to this GraphPane.
 | ZoomStack | Gets a reference to the ZoomStateStack for this GraphPane.
Remarks
This class is the outside "wrapper" for the ZedGraph classes, and provides the interface to access the attributes of the graph. You can have multiple graphs in the same document or form, just instantiate multiple GraphPane's.
Inheritance Hierarchy
Object
 | PaneBase
 |  | GraphPane


GraphPane Constructor

GraphPane Constructor
Namespaces ► ZedGraph ► GraphPane ► GraphPaneGraphPaneNew()()
Members
Icon | Member | Description
 | GraphPaneGraphPaneNew()() | Default Constructor. Sets the Rect to (0, 0, 500, 375), and sets the Title and Title values to empty strings.
 | GraphPaneGraphPaneNew(RectangleF, String, String, String) | Constructor for the GraphPane object. This routine will initialize all member variables and classes, setting appropriate default values as defined in the GraphPane..::Default class.
 | GraphPaneGraphPaneNew(GraphPane) | The Copy Constructor


GraphPane Constructor

GraphPane Constructor
Namespaces ► ZedGraph ► GraphPane ► GraphPaneGraphPaneNew()()
Default Constructor. Sets the Rect to (0, 0, 500, 375), and sets the Title and Title values to empty strings.
Declaration Syntax
C# Visual Basic Visual C++
public GraphPane()
Public Sub New
public:
GraphPane ()


GraphPane Constructor (rect, title, xTitle, yTitle)

GraphPane Constructor (rect, title, xTitle, yTitle)
Namespaces ► ZedGraph ► GraphPane ► GraphPaneGraphPaneNew(RectangleF, String, String, String)
Constructor for the GraphPane object. This routine will initialize all member variables and classes, setting appropriate default values as defined in the GraphPane..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public GraphPane(
    RectangleF rect,
    string title,
    string xTitle,
    string yTitle
)
Public Sub New ( _
    rect As RectangleF, _
    title As String, _
    xTitle As String, _
    yTitle As String _
)
public:
GraphPane (
    RectangleF rect,
    String^ title,
    String^ xTitle,
    String^ yTitle
)
Parameters
rect (RectangleF)
A rectangular screen area where the graph is to be displayed. This area can be any size, and can be resize at any time using the Rect property.
title (String)
The Title for this GraphPane
xTitle (String)
The Title for the XAxis
yTitle (String)
The Title for the YAxis


GraphPane Constructor (rhs)

GraphPane Constructor (rhs)
Namespaces ► ZedGraph ► GraphPane ► GraphPaneGraphPaneNew(GraphPane)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public GraphPane(
    GraphPane rhs
)
Public Sub New ( _
    rhs As GraphPane _
)
public:
GraphPane (
    GraphPane^ rhs
)
Parameters
rhs (GraphPane)
The GraphPane object from which to copy


AddBar Method

AddBar Method
Namespaces ► ZedGraph ► GraphPane ► AddBar()()
Members
Icon | Member | Description
 | AddBar(String, IPointList, Color) | Add a bar type curve (CurveItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddBar(String, array<Double>[](), array<Double>[](), Color) | Add a bar type curve (CurveItem object) to the plot with the given data points (double arrays) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.


AddBar Method (label, x, y, color)

AddBar Method (label, x, y, color)
Namespaces ► ZedGraph ► GraphPane ► AddBar(String, array<Double>[](), array<Double>[](), Color)
Add a bar type curve (CurveItem object) to the plot with the given data points (double arrays) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
Declaration Syntax
C# Visual Basic Visual C++
public BarItem AddBar(
    string label,
    double[] x,
    double[] y,
    Color color
)
Public Function AddBar ( _
    label As String, _
    x As Double(), _
    y As Double(), _
    color As Color _
) As BarItem
public:
BarItem^ AddBar (
    String^ label,
    array<double>^ x,
    array<double>^ y,
    Color color
)
Parameters
label (String)
The text label (string) for the curve that will be used as a Legend entry.
x (array< Double >[]())
An array of double precision X values (the independent values) that define the curve.
y (array< Double >[]())
An array of double precision Y values (the dependent values) that define the curve.
color (Color)
The color to used for the bars
Return Value
A CurveItem class for the newly created bar curve. This can then be used to access all of the curve properties that are not defined as arguments to the AddBar(String, array<Double>[](), array<Double>[](), Color) method.


AddBar Method (label, points, color)

AddBar Method (label, points, color)
Namespaces ► ZedGraph ► GraphPane ► AddBar(String, IPointList, Color)
Add a bar type curve (CurveItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
Declaration Syntax
C# Visual Basic Visual C++
public BarItem AddBar(
    string label,
    IPointList points,
    Color color
)
Public Function AddBar ( _
    label As String, _
    points As IPointList, _
    color As Color _
) As BarItem
public:
BarItem^ AddBar (
    String^ label,
    IPointList^ points,
    Color color
)
Parameters
label (String)
The text label (string) for the curve that will be used as a Legend entry.
points (IPointList)
A IPointList of double precision value pairs that define the X and Y values for this curve
color (Color)
The color to used to fill the bars
Return Value
A CurveItem class for the newly created bar curve. This can then be used to access all of the curve properties that are not defined as arguments to the AddBar(String, IPointList, Color) method.


AddCurve Method

AddCurve Method
Namespaces ► ZedGraph ► GraphPane ► AddCurve()()
Members
Icon | Member | Description
 | AddCurve(String, array<Double>[](), array<Double>[](), Color) | Add a curve (CurveItem object) to the plot with the given data points (double arrays) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddCurve(String, IPointList, Color) | Add a curve (CurveItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddCurve(String, array<Double>[](), array<Double>[](), Color, SymbolType) | Add a curve (CurveItem object) to the plot with the given data points (double arrays) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddCurve(String, IPointList, Color, SymbolType) | Add a curve (CurveItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.


AddCurve Method (label, x, y, color)

AddCurve Method (label, x, y, color)
Namespaces ► ZedGraph ► GraphPane ► AddCurve(String, array<Double>[](), array<Double>[](), Color)
Add a curve (CurveItem object) to the plot with the given data points (double arrays) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
Declaration Syntax
C# Visual Basic Visual C++
public LineItem AddCurve(
    string label,
    double[] x,
    double[] y,
    Color color
)
Public Function AddCurve ( _
    label As String, _
    x As Double(), _
    y As Double(), _
    color As Color _
) As LineItem
public:
LineItem^ AddCurve (
    String^ label,
    array<double>^ x,
    array<double>^ y,
    Color color
)
Parameters
label (String)
The text label (string) for the curve that will be used as a Legend entry.
x (array< Double >[]())
An array of double precision X values (the independent values) that define the curve.
y (array< Double >[]())
An array of double precision Y values (the dependent values) that define the curve.
color (Color)
The color to used for the curve line, symbols, etc.
Return Value
A CurveItem class for the newly created curve. This can then be used to access all of the curve properties that are not defined as arguments to the AddCurve(String, array<Double>[](), array<Double>[](), Color) method.


AddCurve Method (label, x, y, color, symbolType)

AddCurve Method (label, x, y, color, symbolType)
Namespaces ► ZedGraph ► GraphPane ► AddCurve(String, array<Double>[](), array<Double>[](), Color, SymbolType)
Add a curve (CurveItem object) to the plot with the given data points (double arrays) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
Declaration Syntax
C# Visual Basic Visual C++
public LineItem AddCurve(
    string label,
    double[] x,
    double[] y,
    Color color,
    SymbolType symbolType
)
Public Function AddCurve ( _
    label As String, _
    x As Double(), _
    y As Double(), _
    color As Color, _
    symbolType As SymbolType _
) As LineItem
public:
LineItem^ AddCurve (
    String^ label,
    array<double>^ x,
    array<double>^ y,
    Color color,
    SymbolType symbolType
)
Parameters
label (String)
The text label (string) for the curve that will be used as a Legend entry.
x (array< Double >[]())
An array of double precision X values (the independent values) that define the curve.
y (array< Double >[]())
An array of double precision Y values (the dependent values) that define the curve.
color (Color)
The color to used for the curve line, symbols, etc.
symbolType (SymbolType)
A symbol type (SymbolType) that will be used for this curve.
Return Value
A CurveItem class for the newly created curve. This can then be used to access all of the curve properties that are not defined as arguments to the AddCurve(String, array<Double>[](), array<Double>[](), Color, SymbolType) method.


AddCurve Method (label, points, color)

AddCurve Method (label, points, color)
Namespaces ► ZedGraph ► GraphPane ► AddCurve(String, IPointList, Color)
Add a curve (CurveItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
Declaration Syntax
C# Visual Basic Visual C++
public LineItem AddCurve(
    string label,
    IPointList points,
    Color color
)
Public Function AddCurve ( _
    label As String, _
    points As IPointList, _
    color As Color _
) As LineItem
public:
LineItem^ AddCurve (
    String^ label,
    IPointList^ points,
    Color color
)
Parameters
label (String)
The text label (string) for the curve that will be used as a Legend entry.
points (IPointList)
A IPointList of double precision value pairs that define the X and Y values for this curve
color (Color)
The color to used for the curve line, symbols, etc.
Return Value
A CurveItem class for the newly created curve. This can then be used to access all of the curve properties that are not defined as arguments to the AddCurve(String, IPointList, Color) method.


AddCurve Method (label, points, color, symbolType)

AddCurve Method (label, points, color, symbolType)
Namespaces ► ZedGraph ► GraphPane ► AddCurve(String, IPointList, Color, SymbolType)
Add a curve (CurveItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
Declaration Syntax
C# Visual Basic Visual C++
public LineItem AddCurve(
    string label,
    IPointList points,
    Color color,
    SymbolType symbolType
)
Public Function AddCurve ( _
    label As String, _
    points As IPointList, _
    color As Color, _
    symbolType As SymbolType _
) As LineItem
public:
LineItem^ AddCurve (
    String^ label,
    IPointList^ points,
    Color color,
    SymbolType symbolType
)
Parameters
label (String)
The text label (string) for the curve that will be used as a Legend entry.
points (IPointList)
A IPointList of double precision value pairs that define the X and Y values for this curve
color (Color)
The color to used for the curve line, symbols, etc.
symbolType (SymbolType)
A symbol type (SymbolType) that will be used for this curve.
Return Value
A CurveItem class for the newly created curve. This can then be used to access all of the curve properties that are not defined as arguments to the AddCurve(String, IPointList, Color, SymbolType) method.


AddErrorBar Method

AddErrorBar Method
Namespaces ► ZedGraph ► GraphPane ► AddErrorBar()()
Members
Icon | Member | Description
 | AddErrorBar(String, array<Double>[](), array<Double>[](), array<Double>[](), Color) | Add an error bar set (ErrorBarItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddErrorBar(String, IPointList, Color) | Add an error bar set (ErrorBarItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.


AddErrorBar Method (label, x, y, baseValue, color)

AddErrorBar Method (label, x, y, baseValue, color)
Namespaces ► ZedGraph ► GraphPane ► AddErrorBar(String, array<Double>[](), array<Double>[](), array<Double>[](), Color)
Add an error bar set (ErrorBarItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
Declaration Syntax
C# Visual Basic Visual C++
public ErrorBarItem AddErrorBar(
    string label,
    double[] x,
    double[] y,
    double[] baseValue,
    Color color
)
Public Function AddErrorBar ( _
    label As String, _
    x As Double(), _
    y As Double(), _
    baseValue As Double(), _
    color As Color _
) As ErrorBarItem
public:
ErrorBarItem^ AddErrorBar (
    String^ label,
    array<double>^ x,
    array<double>^ y,
    array<double>^ baseValue,
    Color color
)
Parameters
label (String)
The text label (string) for the curve that will be used as a Legend entry.
x (array< Double >[]())
An array of double precision X values (the independent values) that define the curve.
y (array< Double >[]())
An array of double precision Y values (the dependent values) that define the curve.
baseValue (array< Double >[]())
An array of double precision values that define the base value (the bottom) of the bars for this curve.
color (Color)
The color to used for the curve line, symbols, etc.
Return Value
An ErrorBarItem class for the newly created curve. This can then be used to access all of the curve properties that are not defined as arguments to the AddErrorBar(String, IPointList, Color) method.


AddErrorBar Method (label, points, color)

AddErrorBar Method (label, points, color)
Namespaces ► ZedGraph ► GraphPane ► AddErrorBar(String, IPointList, Color)
Add an error bar set (ErrorBarItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
Declaration Syntax
C# Visual Basic Visual C++
public ErrorBarItem AddErrorBar(
    string label,
    IPointList points,
    Color color
)
Public Function AddErrorBar ( _
    label As String, _
    points As IPointList, _
    color As Color _
) As ErrorBarItem
public:
ErrorBarItem^ AddErrorBar (
    String^ label,
    IPointList^ points,
    Color color
)
Parameters
label (String)
The text label (string) for the curve that will be used as a Legend entry.
points (IPointList)
A IPointList of double precision value pairs that define the X and Y values for this curve
color (Color)
The color to used for the curve line, symbols, etc.
Return Value
An ErrorBarItem class for the newly created curve. This can then be used to access all of the curve properties that are not defined as arguments to the AddErrorBar(String, IPointList, Color) method.


AddHiLowBar Method

AddHiLowBar Method
Namespaces ► ZedGraph ► GraphPane ► AddHiLowBar()()
Members
Icon | Member | Description
 | AddHiLowBar(String, array<Double>[](), array<Double>[](), array<Double>[](), Color) | Add a "High-Low" bar type curve (HiLowBarItem object) to the plot with the given data points (double arrays) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddHiLowBar(String, IPointList, Color) | Add a hi-low bar type curve (CurveItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.


AddHiLowBar Method (label, x, y, baseVal, color)

AddHiLowBar Method (label, x, y, baseVal, color)
Namespaces ► ZedGraph ► GraphPane ► AddHiLowBar(String, array<Double>[](), array<Double>[](), array<Double>[](), Color)
Add a "High-Low" bar type curve (HiLowBarItem object) to the plot with the given data points (double arrays) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
Declaration Syntax
C# Visual Basic Visual C++
public HiLowBarItem AddHiLowBar(
    string label,
    double[] x,
    double[] y,
    double[] baseVal,
    Color color
)
Public Function AddHiLowBar ( _
    label As String, _
    x As Double(), _
    y As Double(), _
    baseVal As Double(), _
    color As Color _
) As HiLowBarItem
public:
HiLowBarItem^ AddHiLowBar (
    String^ label,
    array<double>^ x,
    array<double>^ y,
    array<double>^ baseVal,
    Color color
)
Parameters
label (String)
The text label (string) for the curve that will be used as a Legend entry.
x (array< Double >[]())
An array of double precision X values (the independent values) that define the curve.
y (array< Double >[]())
An array of double precision Y values (the dependent values) that define the curve.
baseVal (array< Double >[]())
An array of double precision values that define the base value (the bottom) of the bars for this curve.
color (Color)
The color to used for the bars
Return Value
A HiLowBarItem class for the newly created bar curve. This can then be used to access all of the curve properties that are not defined as arguments to the AddHiLowBar(String, array<Double>[](), array<Double>[](), array<Double>[](), Color) method.


AddHiLowBar Method (label, points, color)

AddHiLowBar Method (label, points, color)
Namespaces ► ZedGraph ► GraphPane ► AddHiLowBar(String, IPointList, Color)
Add a hi-low bar type curve (CurveItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
Declaration Syntax
C# Visual Basic Visual C++
public HiLowBarItem AddHiLowBar(
    string label,
    IPointList points,
    Color color
)
Public Function AddHiLowBar ( _
    label As String, _
    points As IPointList, _
    color As Color _
) As HiLowBarItem
public:
HiLowBarItem^ AddHiLowBar (
    String^ label,
    IPointList^ points,
    Color color
)
Parameters
label (String)
The text label (string) for the curve that will be used as a Legend entry.
points (IPointList)
A IPointList of double precision value Trio's that define the X, Y, and lower dependent values for this curve
color (Color)
The color to used to fill the bars
Return Value
A HiLowBarItem class for the newly created bar curve. This can then be used to access all of the curve properties that are not defined as arguments to the AddHiLowBar(String, IPointList, Color) method.


AddJapaneseCandleStick Method (label, points)

AddJapaneseCandleStick Method (label, points)
Namespaces ► ZedGraph ► GraphPane ► AddJapaneseCandleStick(String, IPointList)
Add a japanesecandlestick graph (JapaneseCandleStickItem object) to the plot with the given data points (IPointList) and properties.
Declaration Syntax
C# Visual Basic Visual C++
public JapaneseCandleStickItem AddJapaneseCandleStick(
    string label,
    IPointList points
)
Public Function AddJapaneseCandleStick ( _
    label As String, _
    points As IPointList _
) As JapaneseCandleStickItem
public:
JapaneseCandleStickItem^ AddJapaneseCandleStick (
    String^ label,
    IPointList^ points
)
Parameters
label (String)
The text label (string) for the curve that will be used as a Legend entry.
points (IPointList)
A IPointList of double precision value pairs that define the X and Y values for this curve
Return Value
A CurveItem class for the newly created curve. This can then be used to access all of the curve properties that are not defined as arguments to the AddJapaneseCandleStick(String, IPointList) method.
Remarks
This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method. Note that the IPointList should contain StockPt objects instead of PointPair objects in order to contain all the data values required for this curve type.


AddOHLCBar Method (label, points, color)

AddOHLCBar Method (label, points, color)
Namespaces ► ZedGraph ► GraphPane ► AddOHLCBar(String, IPointList, Color)
Add a candlestick graph (OHLCBarItem object) to the plot with the given data points (IPointList) and properties.
Declaration Syntax
C# Visual Basic Visual C++
public OHLCBarItem AddOHLCBar(
    string label,
    IPointList points,
    Color color
)
Public Function AddOHLCBar ( _
    label As String, _
    points As IPointList, _
    color As Color _
) As OHLCBarItem
public:
OHLCBarItem^ AddOHLCBar (
    String^ label,
    IPointList^ points,
    Color color
)
Parameters
label (String)
The text label (string) for the curve that will be used as a Legend entry.
points (IPointList)
A IPointList of double precision value pairs that define the X and Y values for this curve
color (Color)
The color to used for the curve line, symbols, etc.
Return Value
A CurveItem class for the newly created curve. This can then be used to access all of the curve properties that are not defined as arguments to the AddOHLCBar(String, IPointList, Color) method.
Remarks
This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method. Note that the IPointList should contain StockPt objects instead of PointPair objects in order to contain all the data values required for this curve type.


AddPieSlice Method

AddPieSlice Method
Namespaces ► ZedGraph ► GraphPane ► AddPieSlice()()
Members
Icon | Member | Description
 | AddPieSlice(Double, Color, Double, String) | Add a PieItem to the display.
 | AddPieSlice(Double, Color, Color, Single, Double, String) | Add a PieItem to the display, providing a gradient fill for the pie color.


AddPieSlice Method (value, color, displacement, label)

AddPieSlice Method (value, color, displacement, label)
Namespaces ► ZedGraph ► GraphPane ► AddPieSlice(Double, Color, Double, String)
Add a PieItem to the display.
Declaration Syntax
C# Visual Basic Visual C++
public PieItem AddPieSlice(
    double value,
    Color color,
    double displacement,
    string label
)
Public Function AddPieSlice ( _
    value As Double, _
    color As Color, _
    displacement As Double, _
    label As String _
) As PieItem
public:
PieItem^ AddPieSlice (
    double value,
    Color color,
    double displacement,
    String^ label
)
Parameters
value (Double)
The value associated with this PieItemitem.
color (Color)
The display color for this PieItemitem.
displacement (Double)
The amount this PieItemitem will be displaced from the center of the PieItem.
label (String)
Text label for this PieItem
Return Value
a reference to the PieItem constructed


AddPieSlice Method (value, color1, color2, fillAngle, displacement, label)

AddPieSlice Method (value, color1, color2, fillAngle, displacement, label)
Namespaces ► ZedGraph ► GraphPane ► AddPieSlice(Double, Color, Color, Single, Double, String)
Add a PieItem to the display, providing a gradient fill for the pie color.
Declaration Syntax
C# Visual Basic Visual C++
public PieItem AddPieSlice(
    double value,
    Color color1,
    Color color2,
    float fillAngle,
    double displacement,
    string label
)
Public Function AddPieSlice ( _
    value As Double, _
    color1 As Color, _
    color2 As Color, _
    fillAngle As Single, _
    displacement As Double, _
    label As String _
) As PieItem
public:
PieItem^ AddPieSlice (
    double value,
    Color color1,
    Color color2,
    float fillAngle,
    double displacement,
    String^ label
)
Parameters
value (Double)
The value associated with this PieItem instance.
color1 (Color)
The starting display color for the gradient Fill for this PieItem instance.
color2 (Color)
The ending display color for the gradient Fill for this PieItem instance.
fillAngle (Single)
The angle for the gradient Fill.
displacement (Double)
The amount this PieItem instance will be displaced from the center point.
label (String)
Text label for this PieItem instance.


AddPieSlices Method (values, labels)

AddPieSlices Method (values, labels)
Namespaces ► ZedGraph ► GraphPane ► AddPieSlices(array<Double>[](), array<String>[]())
Creates all the PieItems for a single Pie Chart.
Declaration Syntax
C# Visual Basic Visual C++
public PieItem[] AddPieSlices(
    double[] values,
    string[] labels
)
Public Function AddPieSlices ( _
    values As Double(), _
    labels As String() _
) As PieItem()
public:
array<PieItem^>^ AddPieSlices (
    array<double>^ values,
    array<String^>^ labels
)
Parameters
values (array< Double >[]())
double array containing all Values for a single PieChart.
labels (array< String >[]())
string array containing all Labels for a single PieChart.
Return Value
an array containing references to all PieItems comprising the Pie Chart.


AddStick Method

AddStick Method
Namespaces ► ZedGraph ► GraphPane ► AddStick()()
Members
Icon | Member | Description
 | AddStick(String, array<Double>[](), array<Double>[](), Color) | Add a stick graph (StickItem object) to the plot with the given data points (double arrays) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
 | AddStick(String, IPointList, Color) | Add a stick graph (StickItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.


AddStick Method (label, x, y, color)

AddStick Method (label, x, y, color)
Namespaces ► ZedGraph ► GraphPane ► AddStick(String, array<Double>[](), array<Double>[](), Color)
Add a stick graph (StickItem object) to the plot with the given data points (double arrays) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
Declaration Syntax
C# Visual Basic Visual C++
public StickItem AddStick(
    string label,
    double[] x,
    double[] y,
    Color color
)
Public Function AddStick ( _
    label As String, _
    x As Double(), _
    y As Double(), _
    color As Color _
) As StickItem
public:
StickItem^ AddStick (
    String^ label,
    array<double>^ x,
    array<double>^ y,
    Color color
)
Parameters
label (String)
The text label (string) for the curve that will be used as a Legend entry.
x (array< Double >[]())
An array of double precision X values (the independent values) that define the curve.
y (array< Double >[]())
An array of double precision Y values (the dependent values) that define the curve.
color (Color)
The color to used for the curve line, symbols, etc.
Return Value
A StickItem class for the newly created curve. This can then be used to access all of the curve properties that are not defined as arguments to the AddStick(String, array<Double>[](), array<Double>[](), Color) method.


AddStick Method (label, points, color)

AddStick Method (label, points, color)
Namespaces ► ZedGraph ► GraphPane ► AddStick(String, IPointList, Color)
Add a stick graph (StickItem object) to the plot with the given data points (IPointList) and properties. This is simplified way to add curves without knowledge of the CurveList class. An alternative is to use the CurveList Add() method.
Declaration Syntax
C# Visual Basic Visual C++
public StickItem AddStick(
    string label,
    IPointList points,
    Color color
)
Public Function AddStick ( _
    label As String, _
    points As IPointList, _
    color As Color _
) As StickItem
public:
StickItem^ AddStick (
    String^ label,
    IPointList^ points,
    Color color
)
Parameters
label (String)
The text label (string) for the curve that will be used as a Legend entry.
points (IPointList)
A IPointList of double precision value pairs that define the X and Y values for this curve
color (Color)
The color to used for the curve line, symbols, etc.
Return Value
A CurveItem class for the newly created curve. This can then be used to access all of the curve properties that are not defined as arguments to the AddStick(String, IPointList, Color) method.


AddY2Axis Method (title)

AddY2Axis Method (title)
Namespaces ► ZedGraph ► GraphPane ► AddY2Axis(String)
Add a secondary Y2Axis (right side) to the list of axes in the Graph.
Declaration Syntax
C# Visual Basic Visual C++
public int AddY2Axis(
    string title
)
Public Function AddY2Axis ( _
    title As String _
) As Integer
public:
int AddY2Axis (
    String^ title
)
Parameters
title (String)
The title for the Y2Axis.
Return Value
the ordinal position (index) in the Y2AxisList.
Remarks
Note that the primary Y2Axis is always included by default. This method turns off the MajorTic and MinorTic IsOpposite and IsInside properties by default.


AddYAxis Method (title)

AddYAxis Method (title)
Namespaces ► ZedGraph ► GraphPane ► AddYAxis(String)
Add a secondary YAxis (left side) to the list of axes in the Graph.
Declaration Syntax
C# Visual Basic Visual C++
public int AddYAxis(
    string title
)
Public Function AddYAxis ( _
    title As String _
) As Integer
public:
int AddYAxis (
    String^ title
)
Parameters
title (String)
The title for the YAxis.
Return Value
the ordinal position (index) in the YAxisList.
Remarks
Note that the primary YAxis is always included by default. This method turns off the MajorTic and MinorTic IsOpposite and IsInside properties by default.


AxisChange Method

AxisChange Method
Namespaces ► ZedGraph ► GraphPane ► AxisChange()()
Members
Icon | Member | Description
 | AxisChange()() | AxisChange causes the axes scale ranges to be recalculated based on the current data range.
 | AxisChange(Graphics) | AxisChange causes the axes scale ranges to be recalculated based on the current data range.


AxisChange Method

AxisChange Method
Namespaces ► ZedGraph ► GraphPane ► AxisChange()()
AxisChange causes the axes scale ranges to be recalculated based on the current data range.
Declaration Syntax
C# Visual Basic Visual C++
public void AxisChange()
Public Sub AxisChange
public:
void AxisChange ()
Remarks
There is no obligation to call AxisChange() for manually scaled axes. AxisChange() is only intended to handle auto scaling operations. Call this function anytime you change, add, or remove curve data to insure that the scale range of the axes are appropriate for the data range. This method calculates a scale minimum, maximum, and step size for each axis based on the current curve data. Only the axis attributes (min, max, step) that are set to auto-range (MinAuto, MaxAuto, MajorStepAuto) will be modified. You must call Invalidate()() after calling AxisChange to make sure the display gets updated.
This overload of AxisChange just uses the default Graphics instance for the screen. If you have a Graphics instance available from your Windows Form, you should use the AxisChange(Graphics) overload instead.


AxisChange Method (g)

AxisChange Method (g)
Namespaces ► ZedGraph ► GraphPane ► AxisChange(Graphics)
AxisChange causes the axes scale ranges to be recalculated based on the current data range.
Declaration Syntax
C# Visual Basic Visual C++
public void AxisChange(
    Graphics g
)
Public Sub AxisChange ( _
    g As Graphics _
)
public:
void AxisChange (
    Graphics^ g
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
Remarks
There is no obligation to call AxisChange() for manually scaled axes. AxisChange() is only intended to handle auto scaling operations. Call this function anytime you change, add, or remove curve data to insure that the scale range of the axes are appropriate for the data range. This method calculates a scale minimum, maximum, and step size for each axis based on the current curve data. Only the axis attributes (min, max, step) that are set to auto-range (MinAuto, MaxAuto, MajorStepAuto) will be modified. You must call Invalidate()() after calling AxisChange to make sure the display gets updated.


AxisChangeEvent Event

AxisChangeEvent Event
Namespaces ► ZedGraph ► GraphPane ► AxisChangeEvent
Subscribe to this event to be notified when AxisChange()() is called.
Declaration Syntax
C# Visual Basic Visual C++
public event GraphPane.GraphPane..::AxisChangeEventHandler AxisChangeEvent
Public Event AxisChangeEvent As GraphPane..::AxisChangeEventHandler
public:
 event GraphPane..::AxisChangeEventHandler^ AxisChangeEvent {
    void add (GraphPane..::AxisChangeEventHandler^ value);
    void remove (GraphPane..::AxisChangeEventHandler^ value);
}


BarSettings Property

BarSettings Property
Namespaces ► ZedGraph ► GraphPane ► BarSettings
Gets the BarSettings instance for this GraphPane, which stores the global properties for bar type charts.
Declaration Syntax
C# Visual Basic Visual C++
public BarSettings BarSettings{ get;}
Public ReadOnly Property BarSettings As BarSettings
public:
property BarSettings^ BarSettings {
    BarSettings^ get ();
}


CalcChartRect Method

CalcChartRect Method
Namespaces ► ZedGraph ► GraphPane ► CalcChartRect()()
Members
Icon | Member | Description
 | CalcChartRect(Graphics) | Calculate the Rect based on the Rect.
 | CalcChartRect(Graphics, Single) | Calculate the Rect based on the Rect.


CalcChartRect Method (g)

CalcChartRect Method (g)
Namespaces ► ZedGraph ► GraphPane ► CalcChartRect(Graphics)
Calculate the Rect based on the Rect.
Declaration Syntax
C# Visual Basic Visual C++
public RectangleF CalcChartRect(
    Graphics g
)
Public Function CalcChartRect ( _
    g As Graphics _
) As RectangleF
public:
RectangleF CalcChartRect (
    Graphics^ g
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
Return Value
The calculated chart rect, in pixel coordinates.
Remarks
The ChartRect is the plot area bounded by the axes, and the rect is the total area as specified by the client application.


CalcChartRect Method (g, scaleFactor)

CalcChartRect Method (g, scaleFactor)
Namespaces ► ZedGraph ► GraphPane ► CalcChartRect(Graphics, Single)
Calculate the Rect based on the Rect.
Declaration Syntax
C# Visual Basic Visual C++
public RectangleF CalcChartRect(
    Graphics g,
    float scaleFactor
)
Public Function CalcChartRect ( _
    g As Graphics, _
    scaleFactor As Single _
) As RectangleF
public:
RectangleF CalcChartRect (
    Graphics^ g,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
scaleFactor (Single)
The scaling factor for the features of the graph based on the BaseDimension. This scaling factor is calculated by the CalcScaleFactor()() method. The scale factor represents a linear multiple to be applied to font sizes, symbol sizes, etc.
Return Value
The calculated chart rect, in pixel coordinates.
Remarks
The ChartRect is the plot area bounded by the axes, and the rect is the total area as specified by the client application.


Chart Property

Chart Property
Namespaces ► ZedGraph ► GraphPane ► Chart
Gets the Chart instance for this GraphPane.
Declaration Syntax
C# Visual Basic Visual C++
public Chart Chart{ get;}
Public ReadOnly Property Chart As Chart
public:
property Chart^ Chart {
    Chart^ get ();
}


Clone Method

Clone Method
Namespaces ► ZedGraph ► GraphPane ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public GraphPane Clone()
Public Function Clone As GraphPane
public:
GraphPane^ Clone ()
Return Value
A new, independent copy of this class


CurveList Property

CurveList Property
Namespaces ► ZedGraph ► GraphPane ► CurveList
Gets or sets the list of CurveItem items for this GraphPane
Declaration Syntax
C# Visual Basic Visual C++
public CurveList CurveList{ get; set;}
Public Property CurveList As CurveList
public:
property CurveList^ CurveList {
    CurveList^ get ();
    void set (CurveList^ value);
}
Value
A reference to a CurveList collection object


Draw Method (g)

Draw Method (g)
Namespaces ► ZedGraph ► GraphPane ► Draw(Graphics)
Draw all elements in the GraphPane to the specified graphics device.
Declaration Syntax
C# Visual Basic Visual C++
public override void Draw(
    Graphics g
)
Public Overrides Sub Draw ( _
    g As Graphics _
)
public:
virtual void Draw (
    Graphics^ g
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
Remarks
This method should be part of the Paint() update process. Calling this routine will redraw all features of the graph. No preparation is required other than an instantiated GraphPane object.


FindContainedObjects Method (rectF, g, containedObjs)

FindContainedObjects Method (rectF, g, containedObjs)
Namespaces ► ZedGraph ► GraphPane ► FindContainedObjects(RectangleF, Graphics, CurveList%)
Find any objects that exist within the specified (screen) rectangle. This method will search through all of the graph objects, such as Axis, Legend, Title, GraphObj, and CurveItem. and see if the objects' bounding boxes are within the specified (screen) rectangle This method returns true if any are found.
Declaration Syntax
C# Visual Basic Visual C++
public bool FindContainedObjects(
    RectangleF rectF,
    Graphics g,
    out CurveList containedObjs
)
Public Function FindContainedObjects ( _
    rectF As RectangleF, _
    g As Graphics, _
    <OutAttribute> ByRef containedObjs As CurveList _
) As Boolean
public:
bool FindContainedObjects (
    RectangleF rectF,
    Graphics^ g,
    [OutAttribute] CurveList^% containedObjs
)
Parameters
rectF (RectangleF)
g (Graphics)
containedObjs (CurveList %)


FindLinkableObject Method (mousePt, g, scaleFactor, source, link, index)

FindLinkableObject Method (mousePt, g, scaleFactor, source, link, index)
Namespaces ► ZedGraph ► GraphPane ► FindLinkableObject(PointF, Graphics, Single, Object%, Link%, Int32%)
Search through the GraphObjList and CurveList for items that contain active Link objects.
Declaration Syntax
C# Visual Basic Visual C++
public bool FindLinkableObject(
    PointF mousePt,
    Graphics g,
    float scaleFactor,
    out Object source,
    out Link link,
    out int index
)
Public Function FindLinkableObject ( _
    mousePt As PointF, _
    g As Graphics, _
    scaleFactor As Single, _
    <OutAttribute> ByRef source As Object, _
    <OutAttribute> ByRef link As Link, _
    <OutAttribute> ByRef index As Integer _
) As Boolean
public:
bool FindLinkableObject (
    PointF mousePt,
    Graphics^ g,
    float scaleFactor,
    [OutAttribute] Object^% source,
    [OutAttribute] Link^% link,
    [OutAttribute] int% index
)
Parameters
mousePt (PointF)
The mouse location where the click occurred
g (Graphics)
An appropriate Graphics instance
scaleFactor (Single)
The current scaling factor for drawing operations.
source (Object %)
The clickable object that was found. Typically a type of GraphObj or a type of CurveItem.
link (Link %)
The Link instance that is contained within the object.
index (Int32 %)
An index value, indicating which point was clicked for CurveItem type objects.
Return Value
returns true if a clickable link was found under the , or false otherwise.


FindNearestObject Method (mousePt, g, nearestObj, index)

FindNearestObject Method (mousePt, g, nearestObj, index)
Namespaces ► ZedGraph ► GraphPane ► FindNearestObject(PointF, Graphics, Object%, Int32%)
Find the object that lies closest to the specified mouse (screen) point.
Declaration Syntax
C# Visual Basic Visual C++
public bool FindNearestObject(
    PointF mousePt,
    Graphics g,
    out Object nearestObj,
    out int index
)
Public Function FindNearestObject ( _
    mousePt As PointF, _
    g As Graphics, _
    <OutAttribute> ByRef nearestObj As Object, _
    <OutAttribute> ByRef index As Integer _
) As Boolean
public:
bool FindNearestObject (
    PointF mousePt,
    Graphics^ g,
    [OutAttribute] Object^% nearestObj,
    [OutAttribute] int% index
)
Parameters
mousePt (PointF)
The screen point, in pixel coordinates.
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
nearestObj (Object %)
A reference to the nearest object to the specified screen point. This can be any of Axis, Legend, Title, TextObj, ArrowObj, or CurveItem. Note: If the pane title is selected, then the GraphPane object will be returned.
index (Int32 %)
The index number of the item within the selected object (where applicable). For example, for a CurveItem object, will be the index number of the nearest data point, accessible via CurveItem.Points[index]. index will be -1 if no data points are available.
Return Value
true if an object was found, false otherwise.
Remarks
This method will search through all of the graph objects, such as Axis, Legend, Title, GraphObj, and CurveItem. If the mouse point is within the bounding box of the items (or in the case of ArrowObj and CurveItem, within NearestTol pixels), then the object will be returned. You must check the type of the object to determine what object was selected (for example, "if ( object is Legend ) ..."). The parameter returns the index number of the item within the selected object (such as the point number within a CurveItem object.
See Also
FindNearestObject(PointF, Graphics, Object%, Int32%)


FindNearestPoint Method

FindNearestPoint Method
Namespaces ► ZedGraph ► GraphPane ► FindNearestPoint()()
Members
Icon | Member | Description
 | FindNearestPoint(PointF, CurveItem, CurveItem%, Int32%) | Find the data point that lies closest to the specified mouse (screen) point for the specified curve.
 | FindNearestPoint(PointF, CurveItem%, Int32%) | Find the data point that lies closest to the specified mouse (screen) point.
 | FindNearestPoint(PointF, CurveList, CurveItem%, Int32%) | Find the data point that lies closest to the specified mouse (screen) point.


FindNearestPoint Method (mousePt, targetCurve, nearestCurve, iNearest)

FindNearestPoint Method (mousePt, targetCurve, nearestCurve, iNearest)
Namespaces ► ZedGraph ► GraphPane ► FindNearestPoint(PointF, CurveItem, CurveItem%, Int32%)
Find the data point that lies closest to the specified mouse (screen) point for the specified curve.
Declaration Syntax
C# Visual Basic Visual C++
public bool FindNearestPoint(
    PointF mousePt,
    CurveItem targetCurve,
    out CurveItem nearestCurve,
    out int iNearest
)
Public Function FindNearestPoint ( _
    mousePt As PointF, _
    targetCurve As CurveItem, _
    <OutAttribute> ByRef nearestCurve As CurveItem, _
    <OutAttribute> ByRef iNearest As Integer _
) As Boolean
public:
bool FindNearestPoint (
    PointF mousePt,
    CurveItem^ targetCurve,
    [OutAttribute] CurveItem^% nearestCurve,
    [OutAttribute] int% iNearest
)
Parameters
mousePt (PointF)
The screen point, in pixel coordinates.
targetCurve (CurveItem)
A CurveItem object containing the data points to be searched.
nearestCurve (CurveItem %)
A reference to the CurveItem instance that contains the closest point. nearestCurve will be null if no data points are available.
iNearest (Int32 %)
The index number of the closest point. The actual data vpoint will then be CurveItem.Points[iNearest] . iNearest will be -1 if no data points are available.
Return Value
true if a point was found and that point lies within NearestTol pixels of the screen point, false otherwise.
Remarks
This method will search only through the points for the specified curve to determine which point is nearest the mouse point. It will only consider points that are within NearestTol pixels of the screen point.


FindNearestPoint Method (mousePt, nearestCurve, iNearest)

FindNearestPoint Method (mousePt, nearestCurve, iNearest)
Namespaces ► ZedGraph ► GraphPane ► FindNearestPoint(PointF, CurveItem%, Int32%)
Find the data point that lies closest to the specified mouse (screen) point.
Declaration Syntax
C# Visual Basic Visual C++
public bool FindNearestPoint(
    PointF mousePt,
    out CurveItem nearestCurve,
    out int iNearest
)
Public Function FindNearestPoint ( _
    mousePt As PointF, _
    <OutAttribute> ByRef nearestCurve As CurveItem, _
    <OutAttribute> ByRef iNearest As Integer _
) As Boolean
public:
bool FindNearestPoint (
    PointF mousePt,
    [OutAttribute] CurveItem^% nearestCurve,
    [OutAttribute] int% iNearest
)
Parameters
mousePt (PointF)
The screen point, in pixel coordinates.
nearestCurve (CurveItem %)
A reference to the CurveItem instance that contains the closest point. nearestCurve will be null if no data points are available.
iNearest (Int32 %)
The index number of the closest point. The actual data vpoint will then be CurveItem.Points[iNearest] . iNearest will be -1 if no data points are available.
Return Value
true if a point was found and that point lies within NearestTol pixels of the screen point, false otherwise.
Remarks
This method will search through all curves in CurveList to find which point is nearest. It will only consider points that are within NearestTol pixels of the screen point.


FindNearestPoint Method (mousePt, targetCurveList, nearestCurve, iNearest)

FindNearestPoint Method (mousePt, targetCurveList, nearestCurve, iNearest)
Namespaces ► ZedGraph ► GraphPane ► FindNearestPoint(PointF, CurveList, CurveItem%, Int32%)
Find the data point that lies closest to the specified mouse (screen) point.
Declaration Syntax
C# Visual Basic Visual C++
public bool FindNearestPoint(
    PointF mousePt,
    CurveList targetCurveList,
    out CurveItem nearestCurve,
    out int iNearest
)
Public Function FindNearestPoint ( _
    mousePt As PointF, _
    targetCurveList As CurveList, _
    <OutAttribute> ByRef nearestCurve As CurveItem, _
    <OutAttribute> ByRef iNearest As Integer _
) As Boolean
public:
bool FindNearestPoint (
    PointF mousePt,
    CurveList^ targetCurveList,
    [OutAttribute] CurveItem^% nearestCurve,
    [OutAttribute] int% iNearest
)
Parameters
mousePt (PointF)
The screen point, in pixel coordinates.
targetCurveList (CurveList)
A CurveList object containing a subset of CurveItem's to be searched.
nearestCurve (CurveItem %)
A reference to the CurveItem instance that contains the closest point. nearestCurve will be null if no data points are available.
iNearest (Int32 %)
The index number of the closest point. The actual data vpoint will then be CurveItem.Points[iNearest] . iNearest will be -1 if no data points are available.
Return Value
true if a point was found and that point lies within NearestTol pixels of the screen point, false otherwise.
Remarks
This method will search through the specified list of curves to find which point is nearest. It will only consider points that are within NearestTol pixels of the screen point, and it will only consider CurveItem's that are in targetCurveList.


GeneralTransform Method

GeneralTransform Method
Namespaces ► ZedGraph ► GraphPane ► GeneralTransform()()
Members
Icon | Member | Description
 | GeneralTransform(PointF, CoordType) | Transform a data point from the specified coordinate type (CoordType) to screen coordinates (pixels).
 | GeneralTransform(Double, Double, CoordType) | Transform a data point from the specified coordinate type (CoordType) to screen coordinates (pixels).


GeneralTransform Method (x, y, coord)

GeneralTransform Method (x, y, coord)
Namespaces ► ZedGraph ► GraphPane ► GeneralTransform(Double, Double, CoordType)
Transform a data point from the specified coordinate type (CoordType) to screen coordinates (pixels).
Declaration Syntax
C# Visual Basic Visual C++
public PointF GeneralTransform(
    double x,
    double y,
    CoordType coord
)
Public Function GeneralTransform ( _
    x As Double, _
    y As Double, _
    coord As CoordType _
) As PointF
public:
PointF GeneralTransform (
    double x,
    double y,
    CoordType coord
)
Parameters
x (Double)
The x coordinate that defines the location in user space
y (Double)
The y coordinate that defines the location in user space
coord (CoordType)
A CoordType type that defines the coordinate system in which the X,Y pair is defined.
Return Value
A point in screen coordinates that corresponds to the specified user point.
Remarks
This method implicitly assumes that Rect has already been calculated via AxisChange()() or Draw(Graphics) methods, or the Rect is set manually (see IsRectAuto). Note that this method is more accurate than the GeneralTransform(PointF, CoordType) overload, since it uses double types. This would typically only be significant for Date coordinates.


GeneralTransform Method (ptF, coord)

GeneralTransform Method (ptF, coord)
Namespaces ► ZedGraph ► GraphPane ► GeneralTransform(PointF, CoordType)
Transform a data point from the specified coordinate type (CoordType) to screen coordinates (pixels).
Declaration Syntax
C# Visual Basic Visual C++
public PointF GeneralTransform(
    PointF ptF,
    CoordType coord
)
Public Function GeneralTransform ( _
    ptF As PointF, _
    coord As CoordType _
) As PointF
public:
PointF GeneralTransform (
    PointF ptF,
    CoordType coord
)
Parameters
ptF (PointF)
The X,Y pair that defines the point in user coordinates.
coord (CoordType)
A CoordType type that defines the coordinate system in which the X,Y pair is defined.
Return Value
A point in screen coordinates that corresponds to the specified user point.
Remarks
This method implicitly assumes that Rect has already been calculated via AxisChange()() or Draw(Graphics) methods, or the Rect is set manually (see IsRectAuto).


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► GraphPane ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsAlignGrids Property

IsAlignGrids Property
Namespaces ► ZedGraph ► GraphPane ► IsAlignGrids
Gets or sets a value that determines if ZedGraph should modify the scale ranges for the Y and Y2 axes such that the number of major steps, and therefore the major grid lines, line up.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAlignGrids{ get; set;}
Public Property IsAlignGrids As Boolean
public:
property bool IsAlignGrids {
    bool get ();
    void set (bool value);
}
Remarks
This property affects the way that AxisChange()() selects the scale ranges for the Y and Y2 axes. It applies to the scale ranges of all Y and Y2 axes, but only if the MaxAuto is set to true.


IsBoundedRanges Property

IsBoundedRanges Property
Namespaces ► ZedGraph ► GraphPane ► IsBoundedRanges
Gets or sets a boolean value that determines if the auto-scaled axis ranges will subset the data points based on any manually set scale range values.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsBoundedRanges{ get; set;}
Public Property IsBoundedRanges As Boolean
public:
property bool IsBoundedRanges {
    bool get ();
    void set (bool value);
}
Remarks
The bounds provide a means to subset the data. For example, if all the axes are set to autoscale, then the full range of data are used. But, if the XAxis.Min and XAxis.Max values are manually set, then the Y data range will reflect the Y values within the bounds of XAxis.Min and XAxis.Max. Set to true to subset the data, or false to always include all data points when calculating scale ranges.


IsIgnoreInitial Property

IsIgnoreInitial Property
Namespaces ► ZedGraph ► GraphPane ► IsIgnoreInitial
Gets or sets a boolean value that affects the data range that is considered for the automatic scale ranging.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[BrowsableAttribute(true)]
public bool IsIgnoreInitial{ get; set;}
<BindableAttribute(True)> _
<BrowsableAttribute(True)> _
Public Property IsIgnoreInitial As Boolean
[BindableAttribute(true)]
[BrowsableAttribute(true)]
public:
property bool IsIgnoreInitial {
    bool get ();
    void set (bool value);
}
Remarks
If true, then initial data points where the Y value is zero are not included when automatically determining the scale Min, Max, and MajorStep size. All data after the first non-zero Y value are included.
See Also
IsIgnoreInitial


IsIgnoreMissing Property

IsIgnoreMissing Property
Namespaces ► ZedGraph ► GraphPane ► IsIgnoreMissing
Gets or sets a value that determines whether or not initial Missing values will cause the line segments of a curve to be discontinuous.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsIgnoreMissing{ get; set;}
Public Property IsIgnoreMissing As Boolean
public:
property bool IsIgnoreMissing {
    bool get ();
    void set (bool value);
}
Remarks
If this field is true, then the curves will be plotted as continuous lines as if the Missing values did not exist. Use the public property IsIgnoreMissing to access this value.


IsZoomed Property

IsZoomed Property
Namespaces ► ZedGraph ► GraphPane ► IsZoomed
Gets a value that indicates whether or not the ZoomStateStack for this GraphPane is empty. Note that this value is only used for the ZedGraphControl.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsZoomed{ get;}
Public ReadOnly Property IsZoomed As Boolean
public:
property bool IsZoomed {
    bool get ();
}


LineType Property

LineType Property
Namespaces ► ZedGraph ► GraphPane ► LineType
Determines how the LineItem graphs will be displayed. See the LineType enum for the individual types available.
Declaration Syntax
C# Visual Basic Visual C++
public LineType LineType{ get; set;}
Public Property LineType As LineType
public:
property LineType LineType {
    LineType get ();
    void set (LineType value);
}
See Also
LineType


ReverseTransform Method

ReverseTransform Method
Namespaces ► ZedGraph ► GraphPane ► ReverseTransform()()
Members
Icon | Member | Description
 | ReverseTransform(PointF, Double%, Double%) | Return the user scale values that correspond to the specified screen coordinate position (pixels). This overload assumes the default XAxis and YAxis.
 | ReverseTransform(PointF, Double%, Double%, Double%, Double%) | Return the user scale values that correspond to the specified screen coordinate position (pixels).
 | ReverseTransform(PointF, Boolean, Boolean, Int32, Double%, Double%) | Return the user scale values that correspond to the specified screen coordinate position (pixels).
 | ReverseTransform(PointF, Double%, Double%, array<Double>[]()%, array<Double>[]()%) | Return the user scale values that correspond to the specified screen coordinate position (pixels) for all y axes.


ReverseTransform Method (ptF, isX2Axis, isY2Axis, yAxisIndex, x, y)

ReverseTransform Method (ptF, isX2Axis, isY2Axis, yAxisIndex, x, y)
Namespaces ► ZedGraph ► GraphPane ► ReverseTransform(PointF, Boolean, Boolean, Int32, Double%, Double%)
Return the user scale values that correspond to the specified screen coordinate position (pixels).
Declaration Syntax
C# Visual Basic Visual C++
public void ReverseTransform(
    PointF ptF,
    bool isX2Axis,
    bool isY2Axis,
    int yAxisIndex,
    out double x,
    out double y
)
Public Sub ReverseTransform ( _
    ptF As PointF, _
    isX2Axis As Boolean, _
    isY2Axis As Boolean, _
    yAxisIndex As Integer, _
    <OutAttribute> ByRef x As Double, _
    <OutAttribute> ByRef y As Double _
)
public:
void ReverseTransform (
    PointF ptF,
    bool isX2Axis,
    bool isY2Axis,
    int yAxisIndex,
    [OutAttribute] double% x,
    [OutAttribute] double% y
)
Parameters
ptF (PointF)
The X,Y pair that defines the screen coordinate point of interest
isX2Axis (Boolean)
true to return data that corresponds to an X2Axis, false for an XAxis.
isY2Axis (Boolean)
true to return data that corresponds to a Y2Axis, false for a YAxis.
yAxisIndex (Int32)
The ordinal index of the Y or Y2 axis from which to return data (see YAxisList, Y2AxisList)
x (Double %)
The resultant value in user coordinates from the XAxis
y (Double %)
The resultant value in user coordinates from the primary YAxis
Remarks
This method implicitly assumes that Rect has already been calculated via AxisChange()() or Draw(Graphics) methods, or the Rect is set manually (see IsRectAuto).


ReverseTransform Method (ptF, x, y)

ReverseTransform Method (ptF, x, y)
Namespaces ► ZedGraph ► GraphPane ► ReverseTransform(PointF, Double%, Double%)
Return the user scale values that correspond to the specified screen coordinate position (pixels). This overload assumes the default XAxis and YAxis.
Declaration Syntax
C# Visual Basic Visual C++
public void ReverseTransform(
    PointF ptF,
    out double x,
    out double y
)
Public Sub ReverseTransform ( _
    ptF As PointF, _
    <OutAttribute> ByRef x As Double, _
    <OutAttribute> ByRef y As Double _
)
public:
void ReverseTransform (
    PointF ptF,
    [OutAttribute] double% x,
    [OutAttribute] double% y
)
Parameters
ptF (PointF)
The X,Y pair that defines the screen coordinate point of interest
x (Double %)
The resultant value in user coordinates from the XAxis
y (Double %)
The resultant value in user coordinates from the primary YAxis
Remarks
This method implicitly assumes that Rect has already been calculated via AxisChange()() or Draw(Graphics) methods, or the Rect is set manually (see IsRectAuto).


ReverseTransform Method (ptF, x, x2, y, y2)

ReverseTransform Method (ptF, x, x2, y, y2)
Namespaces ► ZedGraph ► GraphPane ► ReverseTransform(PointF, Double%, Double%, Double%, Double%)
Return the user scale values that correspond to the specified screen coordinate position (pixels).
Declaration Syntax
C# Visual Basic Visual C++
public void ReverseTransform(
    PointF ptF,
    out double x,
    out double x2,
    out double y,
    out double y2
)
Public Sub ReverseTransform ( _
    ptF As PointF, _
    <OutAttribute> ByRef x As Double, _
    <OutAttribute> ByRef x2 As Double, _
    <OutAttribute> ByRef y As Double, _
    <OutAttribute> ByRef y2 As Double _
)
public:
void ReverseTransform (
    PointF ptF,
    [OutAttribute] double% x,
    [OutAttribute] double% x2,
    [OutAttribute] double% y,
    [OutAttribute] double% y2
)
Parameters
ptF (PointF)
The X,Y pair that defines the screen coordinate point of interest
x (Double %)
The resultant value in user coordinates from the XAxis
x2 (Double %)
The resultant value in user coordinates from the X2Axis
y (Double %)
The resultant value in user coordinates from the primary YAxis
y2 (Double %)
The resultant value in user coordinates from the primary Y2Axis
Remarks
This method implicitly assumes that Rect has already been calculated via AxisChange()() or Draw(Graphics) methods, or the Rect is set manually (see IsRectAuto).


ReverseTransform Method (ptF, x, x2, y, y2)

ReverseTransform Method (ptF, x, x2, y, y2)
Namespaces ► ZedGraph ► GraphPane ► ReverseTransform(PointF, Double%, Double%, array<Double>[]()%, array<Double>[]()%)
Return the user scale values that correspond to the specified screen coordinate position (pixels) for all y axes.
Declaration Syntax
C# Visual Basic Visual C++
public void ReverseTransform(
    PointF ptF,
    out double x,
    out double x2,
    out double[] y,
    out double[] y2
)
Public Sub ReverseTransform ( _
    ptF As PointF, _
    <OutAttribute> ByRef x As Double, _
    <OutAttribute> ByRef x2 As Double, _
    <OutAttribute> ByRef y As Double(), _
    <OutAttribute> ByRef y2 As Double() _
)
public:
void ReverseTransform (
    PointF ptF,
    [OutAttribute] double% x,
    [OutAttribute] double% x2,
    [OutAttribute] array<double>^% y,
    [OutAttribute] array<double>^% y2
)
Parameters
ptF (PointF)
The X,Y pair that defines the screen coordinate point of interest
x (Double %)
The resultant value in user coordinates from the XAxis
x2 (Double %)
The resultant value in user coordinates from the X2Axis
y (array< Double >[]()%)
An array of resultant values in user coordinates from the list of YAxis instances. This method allocates the array for you, according to the number of YAxis objects in the list.
y2 (array< Double >[]()%)
An array of resultant values in user coordinates from the list of Y2Axis instances. This method allocates the array for you, according to the number of Y2Axis objects in the list.
Remarks
This method implicitly assumes that Rect has already been calculated via AxisChange()() or Draw(Graphics) methods, or the Rect is set manually (see IsRectAuto).


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► GraphPane ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


SetMinSpaceBuffer Method (g, bufferFraction, isGrowOnly)

SetMinSpaceBuffer Method (g, bufferFraction, isGrowOnly)
Namespaces ► ZedGraph ► GraphPane ► SetMinSpaceBuffer(Graphics, Single, Boolean)
This method will set the MinSpace property for all three axes; XAxis, YAxis, and Y2Axis.
Declaration Syntax
C# Visual Basic Visual C++
public void SetMinSpaceBuffer(
    Graphics g,
    float bufferFraction,
    bool isGrowOnly
)
Public Sub SetMinSpaceBuffer ( _
    g As Graphics, _
    bufferFraction As Single, _
    isGrowOnly As Boolean _
)
public:
void SetMinSpaceBuffer (
    Graphics^ g,
    float bufferFraction,
    bool isGrowOnly
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
bufferFraction (Single)
The amount of space to allocate for the axis, expressed as a fraction of the currently required space. For example, a value of 1.2 would allow for 20% extra above the currently required space.
isGrowOnly (Boolean)
If true, then this method will only modify the MinSpace property if the calculated result is more than the current value.
Remarks
The MinSpace is calculated using the currently required space multiplied by a fraction (). The currently required space is calculated using CalcSpace(Graphics, GraphPane, Single, Single%), and is based on current data ranges, font sizes, etc. The "space" is actually the amount of space required to fit the tic marks, scale labels, and axis title. The calculation is done by calling the SetMinSpaceBuffer(Graphics, GraphPane, Single, Boolean) method for each Axis.


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► GraphPane ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


X2Axis Property

X2Axis Property
Namespaces ► ZedGraph ► GraphPane ► X2Axis
Accesses the X2Axis for this graph
Declaration Syntax
C# Visual Basic Visual C++
public X2Axis X2Axis{ get;}
Public ReadOnly Property X2Axis As X2Axis
public:
property X2Axis^ X2Axis {
    X2Axis^ get ();
}
Value
A reference to a X2Axis object


XAxis Property

XAxis Property
Namespaces ► ZedGraph ► GraphPane ► XAxis
Accesses the XAxis for this graph
Declaration Syntax
C# Visual Basic Visual C++
public XAxis XAxis{ get;}
Public ReadOnly Property XAxis As XAxis
public:
property XAxis^ XAxis {
    XAxis^ get ();
}
Value
A reference to a XAxis object


Y2Axis Property

Y2Axis Property
Namespaces ► ZedGraph ► GraphPane ► Y2Axis
Accesses the primary Y2Axis for this graph
Declaration Syntax
C# Visual Basic Visual C++
public Y2Axis Y2Axis{ get;}
Public ReadOnly Property Y2Axis As Y2Axis
public:
property Y2Axis^ Y2Axis {
    Y2Axis^ get ();
}
Value
A reference to a Y2Axis object
See Also
YAxisList
Y2AxisList


Y2AxisList Property

Y2AxisList Property
Namespaces ► ZedGraph ► GraphPane ► Y2AxisList
Gets the collection of Y2 axes that belong to this GraphPane.
Declaration Syntax
C# Visual Basic Visual C++
public Y2AxisList Y2AxisList{ get;}
Public ReadOnly Property Y2AxisList As Y2AxisList
public:
property Y2AxisList^ Y2AxisList {
    Y2AxisList^ get ();
}


YAxis Property

YAxis Property
Namespaces ► ZedGraph ► GraphPane ► YAxis
Accesses the primary YAxis for this graph
Declaration Syntax
C# Visual Basic Visual C++
public YAxis YAxis{ get;}
Public ReadOnly Property YAxis As YAxis
public:
property YAxis^ YAxis {
    YAxis^ get ();
}
Value
A reference to a YAxis object
See Also
YAxisList
Y2AxisList


YAxisList Property

YAxisList Property
Namespaces ► ZedGraph ► GraphPane ► YAxisList
Gets the collection of Y axes that belong to this GraphPane.
Declaration Syntax
C# Visual Basic Visual C++
public YAxisList YAxisList{ get;}
Public ReadOnly Property YAxisList As YAxisList
public:
property YAxisList^ YAxisList {
    YAxisList^ get ();
}


ZoomStack Property

ZoomStack Property
Namespaces ► ZedGraph ► GraphPane ► ZoomStack
Gets a reference to the ZoomStateStack for this GraphPane.
Declaration Syntax
C# Visual Basic Visual C++
public ZoomStateStack ZoomStack{ get;}
Public ReadOnly Property ZoomStack As ZoomStateStack
public:
property ZoomStateStack^ ZoomStack {
    ZoomStateStack^ get ();
}


GraphPane.AxisChangeEventHandler Delegate

GraphPane..::AxisChangeEventHandler Delegate
Namespaces ► ZedGraph ► GraphPane ► GraphPane..::AxisChangeEventHandler
A delegate to provide notification through the AxisChangeEvent when AxisChange()() is called.
Declaration Syntax
C# Visual Basic Visual C++
public delegate void AxisChangeEventHandler(
    GraphPane pane
)
Public Delegate Sub AxisChangeEventHandler ( _
    pane As GraphPane _
)
public delegate void AxisChangeEventHandler (
    GraphPane^ pane
)
Parameters
pane (GraphPane)
The GraphPane for which AxisChange() has been called.
See Also
AxisChangeEvent


GraphPane.Default Structure

GraphPane..::Default Structure
Namespaces ► ZedGraph ► GraphPane ► GraphPane..::Default
A simple struct that defines the default property values for the GraphPane class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ClusterScaleWidth | The default width of a bar cluster on a Bar graph. This value only applies to Bar graphs, and only when the Type is Linear, Log or Date. This dimension is expressed in terms of X scale user units.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsBoundedRanges | The default settings for the Axis scale bounded ranges option (IsBoundedRanges property). true to have the auto-scale-range code subset the data according to any manually set scale values, false otherwise.
 | IsIgnoreInitial | The default settings for the Axis scale ignore initial zero values option (IsIgnoreInitial property). true to have the auto-scale-range code ignore the initial data points until the first non-zero Y value, false otherwise.
 | LineType | The default value for the LineType property, which determines if the lines are drawn in normal or "stacked" mode. See the LineType for more information.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NearestTol | The tolerance that is applied to the FindNearestPoint(PointF, CurveItem%, Int32%) routine. If a given curve point is within this many pixels of the mousePt, the curve point is considered to be close enough for selection as a nearest point candidate.
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


ClusterScaleWidth Field

ClusterScaleWidth Field
Namespaces ► ZedGraph ► GraphPane..::Default ► ClusterScaleWidth
The default width of a bar cluster on a Bar graph. This value only applies to Bar graphs, and only when the Type is Linear, Log or Date. This dimension is expressed in terms of X scale user units.
Declaration Syntax
C# Visual Basic Visual C++
public static double ClusterScaleWidth
Public Shared ClusterScaleWidth As Double
public:
static double ClusterScaleWidth
See Also
MinClusterGap
MinBarGap


IsBoundedRanges Field

IsBoundedRanges Field
Namespaces ► ZedGraph ► GraphPane..::Default ► IsBoundedRanges
The default settings for the Axis scale bounded ranges option (IsBoundedRanges property). true to have the auto-scale-range code subset the data according to any manually set scale values, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsBoundedRanges
Public Shared IsBoundedRanges As Boolean
public:
static bool IsBoundedRanges


IsIgnoreInitial Field

IsIgnoreInitial Field
Namespaces ► ZedGraph ► GraphPane..::Default ► IsIgnoreInitial
The default settings for the Axis scale ignore initial zero values option (IsIgnoreInitial property). true to have the auto-scale-range code ignore the initial data points until the first non-zero Y value, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsIgnoreInitial
Public Shared IsIgnoreInitial As Boolean
public:
static bool IsIgnoreInitial


LineType Field

LineType Field
Namespaces ► ZedGraph ► GraphPane..::Default ► LineType
The default value for the LineType property, which determines if the lines are drawn in normal or "stacked" mode. See the LineType for more information.
Declaration Syntax
C# Visual Basic Visual C++
public static LineType LineType
Public Shared LineType As LineType
public:
static LineType LineType
See Also
LineType


NearestTol Field

NearestTol Field
Namespaces ► ZedGraph ► GraphPane..::Default ► NearestTol
The tolerance that is applied to the FindNearestPoint(PointF, CurveItem%, Int32%) routine. If a given curve point is within this many pixels of the mousePt, the curve point is considered to be close enough for selection as a nearest point candidate.
Declaration Syntax
C# Visual Basic Visual C++
public static double NearestTol
Public Shared NearestTol As Double
public:
static double NearestTol


HiLowBar Class

HiLowBar Class
Namespaces ► ZedGraph ► HiLowBar
This class handles the drawing of the curve HiLowBar objects. The Hi-Low Bars are the "floating" bars that have a lower and upper value and appear at each defined point.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class HiLowBar : Bar, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class HiLowBar _
    Inherits Bar _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class HiLowBar : public Bar,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HiLowBarHiLowBarNew()() | Default constructor that sets all HiLowBar properties to default values as defined in the Bar..::Default class.
 | HiLowBarHiLowBarNew(Color) | Default constructor that sets the Color as specified, and the remaining HiLowBar properties to default values as defined in the Bar..::Default class. The specified color is only applied to the Color, and the Color will be defaulted.
 | HiLowBarHiLowBarNew(Color, Single) | Default constructor that sets the Color and Size as specified, and the remaining HiLowBar properties to default values as defined in the Bar..::Default class. The specified color is only applied to the Color, and the Color will be defaulted.
 | HiLowBarHiLowBarNew(HiLowBar) | The Copy Constructor
 | Border | The Border object used to draw the border around the Bar. (Inherited from Bar.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Draw(Graphics, GraphPane, Single, Single, Single, Single, Single, Boolean, Boolean, PointPair) | Draw the Bar to the specified Graphics device at the specified location. This routine draws a single bar. (Inherited from Bar.)
 | Draw(Graphics, GraphPane, RectangleF, Single, Boolean, Boolean, PointPair) | Draw the Bar to the specified Graphics device at the specified location. This routine draws a single bar. (Inherited from Bar.)
 | DrawBars(Graphics, GraphPane, CurveItem, Axis, Axis, Single, Int32, Single) | Draw the this Bar to the specified Graphics device as a bar at each defined point. This method is normally only called by the Draw(Graphics, GraphPane, Int32, Single) method of the BarItem object (Inherited from Bar.)
 | DrawSingleBar(Graphics, GraphPane, CurveItem, Axis, Axis, Int32, Int32, Single, Single) | Draw the specified single bar (an individual "point") of this series to the specified Graphics device. This method is not as efficient as DrawBars(Graphics, GraphPane, CurveItem, Axis, Axis, Single, Int32, Single), which draws the bars for all points. It is intended to be used only for SortedOverlay, which requires special handling of each bar. (Inherited from Bar.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Gets or sets the Fill data for this Bar. (Inherited from Bar.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarWidth(GraphPane, Axis, Single) | Returns the width of the bar, in pixels, based on the settings for Size and IsAutoSize.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides Bar.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAutoSize | Determines whether the bar width will be based on the Size value, or it will be based on available space similar to BarItem objects.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | schema2 | Current schema value that defines the version of the serialized file
 | Size | Gets or sets the size of the HiLowBar
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Bar
 |  | HiLowBar


HiLowBar Constructor

HiLowBar Constructor
Namespaces ► ZedGraph ► HiLowBar ► HiLowBarHiLowBarNew()()
Members
Icon | Member | Description
 | HiLowBarHiLowBarNew()() | Default constructor that sets all HiLowBar properties to default values as defined in the Bar..::Default class.
 | HiLowBarHiLowBarNew(Color) | Default constructor that sets the Color as specified, and the remaining HiLowBar properties to default values as defined in the Bar..::Default class. The specified color is only applied to the Color, and the Color will be defaulted.
 | HiLowBarHiLowBarNew(Color, Single) | Default constructor that sets the Color and Size as specified, and the remaining HiLowBar properties to default values as defined in the Bar..::Default class. The specified color is only applied to the Color, and the Color will be defaulted.
 | HiLowBarHiLowBarNew(HiLowBar) | The Copy Constructor


HiLowBar Constructor

HiLowBar Constructor
Namespaces ► ZedGraph ► HiLowBar ► HiLowBarHiLowBarNew()()
Default constructor that sets all HiLowBar properties to default values as defined in the Bar..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public HiLowBar()
Public Sub New
public:
HiLowBar ()


HiLowBar Constructor (color)

HiLowBar Constructor (color)
Namespaces ► ZedGraph ► HiLowBar ► HiLowBarHiLowBarNew(Color)
Default constructor that sets the Color as specified, and the remaining HiLowBar properties to default values as defined in the Bar..::Default class. The specified color is only applied to the Color, and the Color will be defaulted.
Declaration Syntax
C# Visual Basic Visual C++
public HiLowBar(
    Color color
)
Public Sub New ( _
    color As Color _
)
public:
HiLowBar (
    Color color
)
Parameters
color (Color)
A Color value indicating the Color of the Bar.


HiLowBar Constructor (color, size)

HiLowBar Constructor (color, size)
Namespaces ► ZedGraph ► HiLowBar ► HiLowBarHiLowBarNew(Color, Single)
Default constructor that sets the Color and Size as specified, and the remaining HiLowBar properties to default values as defined in the Bar..::Default class. The specified color is only applied to the Color, and the Color will be defaulted.
Declaration Syntax
C# Visual Basic Visual C++
public HiLowBar(
    Color color,
    float size
)
Public Sub New ( _
    color As Color, _
    size As Single _
)
public:
HiLowBar (
    Color color,
    float size
)
Parameters
color (Color)
A Color value indicating the Color of the Bar.
size (Single)
The size (width) of the HiLowBar's, in points (1/72nd inch)


HiLowBar Constructor (rhs)

HiLowBar Constructor (rhs)
Namespaces ► ZedGraph ► HiLowBar ► HiLowBarHiLowBarNew(HiLowBar)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public HiLowBar(
    HiLowBar rhs
)
Public Sub New ( _
    rhs As HiLowBar _
)
public:
HiLowBar (
    HiLowBar^ rhs
)
Parameters
rhs (HiLowBar)
The HiLowBar object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► HiLowBar ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public HiLowBar Clone()
Public Function Clone As HiLowBar
public:
HiLowBar^ Clone ()
Return Value
A new, independent copy of this class


GetBarWidth Method (pane, baseAxis, scaleFactor)

GetBarWidth Method (pane, baseAxis, scaleFactor)
Namespaces ► ZedGraph ► HiLowBar ► GetBarWidth(GraphPane, Axis, Single)
Returns the width of the bar, in pixels, based on the settings for Size and IsAutoSize.
Declaration Syntax
C# Visual Basic Visual C++
public float GetBarWidth(
    GraphPane pane,
    Axis baseAxis,
    float scaleFactor
)
Public Function GetBarWidth ( _
    pane As GraphPane, _
    baseAxis As Axis, _
    scaleFactor As Single _
) As Single
public:
float GetBarWidth (
    GraphPane^ pane,
    Axis^ baseAxis,
    float scaleFactor
)
Parameters
pane (GraphPane)
The parent GraphPane object.
baseAxis (Axis)
The Axis object that represents the bar base (independent axis).
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
The width of each bar, in pixel units


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► HiLowBar ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsAutoSize Property

IsAutoSize Property
Namespaces ► ZedGraph ► HiLowBar ► IsAutoSize
Determines whether the bar width will be based on the Size value, or it will be based on available space similar to BarItem objects.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAutoSize{ get; set;}
Public Property IsAutoSize As Boolean
public:
property bool IsAutoSize {
    bool get ();
    void set (bool value);
}
Remarks
If true, then the value of Size is ignored. If this value is true, then MinClusterGap will be used to determine the total space between each bar. If the base axis is non-ordinal, then ClusterScaleWidth will be active. In this case, you may want to make sure that ClusterScaleWidthAuto is true.


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► HiLowBar ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


Size Property

Size Property
Namespaces ► ZedGraph ► HiLowBar ► Size
Gets or sets the size of the HiLowBar
Declaration Syntax
C# Visual Basic Visual C++
public float Size{ get; set;}
Public Property Size As Single
public:
property float Size {
    float get ();
    void set (float value);
}
Value
Size in points (1/72 inch)
Remarks
The size of the bars can be set by this value, which is then scaled according to the scaleFactor (see CalcScaleFactor()()). Alternatively, if IsAutoSize is true, the bar width will be set according to the maximum available cluster width less the cluster gap (see GetClusterWidth()() and MinClusterGap). That is, if IsAutoSize is true, then the value of Size will be ignored. If you modify the value of Size, then IsAutoSize will be automatically set to false.
See Also
Size


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► HiLowBar ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


HiLowBar.Default Structure

HiLowBar..::Default Structure
Namespaces ► ZedGraph ► HiLowBar ► HiLowBar..::Default
A simple struct that defines the default property values for the HiLowBar class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAutoSize | Default value for the IsAutoSize property.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Size | The default size (width) for the bars (Size property), in units of points.
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


IsAutoSize Field

IsAutoSize Field
Namespaces ► ZedGraph ► HiLowBar..::Default ► IsAutoSize
Default value for the IsAutoSize property.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsAutoSize
Public Shared IsAutoSize As Boolean
public:
static bool IsAutoSize


Size Field

Size Field
Namespaces ► ZedGraph ► HiLowBar..::Default ► Size
The default size (width) for the bars (Size property), in units of points.
Declaration Syntax
C# Visual Basic Visual C++
public static float Size
Public Shared Size As Single
public:
static float Size


HiLowBarItem Class

HiLowBarItem Class
Namespaces ► ZedGraph ► HiLowBarItem
Encapsulates an "High-Low" Bar curve type that displays a bar in which both the bottom and the top of the bar are set by data valuesfrom the PointPair struct.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class HiLowBarItem : CurveItem, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class HiLowBarItem _
    Inherits CurveItem _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class HiLowBarItem : public CurveItem,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HiLowBarItemHiLowBarItemNew(String, array<Double>[](), array<Double>[](), array<Double>[](), Color) | Create a new HiLowBarItem using the specified properties.
 | HiLowBarItemHiLowBarItemNew(String, IPointList, Color) | Create a new HiLowBarItem using the specified properties.
 | HiLowBarItemHiLowBarItemNew(HiLowBarItem) | The Copy Constructor
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve. (Inherited from CurveItem.)
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve. (Inherited from CurveItem.)
 | Bar | Gets a reference to the HiLowBar class defined for this HiLowBarItem.
 | BaseAxis(GraphPane) | Returns a reference to the Axis object that is the "base" (independent axis) from which the values are drawn. (Inherited from CurveItem.)
 | Clear()() | Clears the points from this CurveItem. This is the same as CurveItem.Points.Clear(). (Inherited from CurveItem.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The Line/Symbol/Bar color (FillColor for the Bar). This is a common access to Line.Color, Border.Color, and Fill.Color properties for this curve. (Inherited from CurveItem.)
 | Draw(Graphics, GraphPane, Int32, Single) | Do all rendering associated with this HiLowBarItem to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object. (Overrides CurveItem.Draw(Graphics, GraphPane, Int32, Single).)
 | DrawLegendKey(Graphics, GraphPane, RectangleF, Single) | Draw a legend key entry for this HiLowBarItem at the specified location (Overrides CurveItem.DrawLegendKey(Graphics, GraphPane, RectangleF, Single).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarWidth(GraphPane) | Calculate the width of each bar, depending on the actual bar type (Inherited from CurveItem.)
 | GetCoords(GraphPane, Int32, String%) | Determine the coords for the rectangle associated with a specified point for this CurveItem (Overrides CurveItem.GetCoords(GraphPane, Int32, String%).)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides CurveItem.GetObjectData(SerializationInfo, StreamingContext).)
 | GetRange(Double%, Double%, Double%, Double%, Boolean, Boolean, GraphPane) | Go through the list of PointPair data values for this CurveItem and determine the minimum and maximum values in the data. (Inherited from CurveItem.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXAxis(GraphPane) | Get the X Axis instance (either XAxis or X2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxis(GraphPane) | Get the Y Axis instance (either YAxis or Y2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxisIndex(GraphPane) | Get the index of the Y Axis in the YAxis or Y2Axis list to which this CurveItem belongs. (Inherited from CurveItem.)
 | IsBar | Determines whether this CurveItem is a BarItem. This does not include HiLowBarItem's or ErrorBarItem's. (Inherited from CurveItem.)
 | IsLine | Determines whether this CurveItem is a LineItem. (Inherited from CurveItem.)
 | IsOverrideOrdinal | Gets or sets a value which allows you to override the normal ordinal axis behavior. (Inherited from CurveItem.)
 | IsPie | Determines whether this CurveItem is a PieItem. (Inherited from CurveItem.)
 | IsSelectable | Determines whether this CurveItem can be selected in the graph. (Inherited from CurveItem.)
 | IsSelected | Determines whether this CurveItem is selected on the graph. Note that this value changes the curve displayed color, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsVisible | Determines whether this CurveItem is visible on the graph. Note that this value turns the curve display on or off, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsX2Axis | Gets or sets a value that determines which X axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | IsY2Axis | Gets or sets a value that determines which Y axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | Item[([Int32])] | An accessor for the PointPair datum for this CurveItem. Index is the ordinal reference (zero based) of the point. (Inherited from CurveItem.)
 | Label | A Label instance that represents the Legend entry for the this CurveItem object (Inherited from CurveItem.)
 | Link | Gets or sets the hyperlink information for this CurveItem. (Inherited from CurveItem.)
 | MakeUnique()() | Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator) (Inherited from CurveItem.)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator) (Inherited from CurveItem.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NPts | Readonly property that gives the number of points that define this CurveItem object, which is the number of points in the Points data collection. (Inherited from CurveItem.)
 | Points | The IPointList of X,Y point sets that represent this CurveItem. (Inherited from CurveItem.)
 | RemovePoint(Int32) | Removes a single point from this CurveItem. (Inherited from CurveItem.)
 | schema2 | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the CurveItem. ZedGraph does not use this value for any purpose. (Inherited from CurveItem.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValueAxis(GraphPane) | Returns a reference to the Axis object that is the "value" (dependent axis) from which the points are drawn. (Inherited from CurveItem.)
 | YAxisIndex | Gets or sets the index number of the Y Axis to which this CurveItem belongs. (Inherited from CurveItem.)
Remarks
The HiLowBarItem type is intended for displaying bars that cover a band of data, such as a confidence interval, "waterfall" chart, etc. The width of the bar can be set in two ways. First, Size can be used to set a width in points (1/72nd inch), that is scaled using the regular scalefactor method (see CalcScaleFactor()()). In this manner, the bar widths are set similar to symbol sizes. The other method is to set IsAutoSize to true, which will cause the bars to be scaled just like a BarItem in which only one bar series is present. That is, the bars width will be the width of a cluster less the clustergap (see GetClusterWidth()() and MinClusterGap). The position of each bar is set according to the PointPair values. The independent axis is assigned with Base, and is a BarBase enum type. If Base is set to Y or Y2, then the bars will actually be horizontal, since the X axis becomes the value axis and the Y or Y2 axis becomes the independent axis.
Inheritance Hierarchy
Object
 | CurveItem
 |  | HiLowBarItem


HiLowBarItem Constructor

HiLowBarItem Constructor
Namespaces ► ZedGraph ► HiLowBarItem ► HiLowBarItemHiLowBarItemNew()()
Members
Icon | Member | Description
 | HiLowBarItemHiLowBarItemNew(String, array<Double>[](), array<Double>[](), array<Double>[](), Color) | Create a new HiLowBarItem using the specified properties.
 | HiLowBarItemHiLowBarItemNew(String, IPointList, Color) | Create a new HiLowBarItem using the specified properties.
 | HiLowBarItemHiLowBarItemNew(HiLowBarItem) | The Copy Constructor


HiLowBarItem Constructor (label, x, y, baseVal, color)

HiLowBarItem Constructor (label, x, y, baseVal, color)
Namespaces ► ZedGraph ► HiLowBarItem ► HiLowBarItemHiLowBarItemNew(String, array<Double>[](), array<Double>[](), array<Double>[](), Color)
Create a new HiLowBarItem using the specified properties.
Declaration Syntax
C# Visual Basic Visual C++
public HiLowBarItem(
    string label,
    double[] x,
    double[] y,
    double[] baseVal,
    Color color
)
Public Sub New ( _
    label As String, _
    x As Double(), _
    y As Double(), _
    baseVal As Double(), _
    color As Color _
)
public:
HiLowBarItem (
    String^ label,
    array<double>^ x,
    array<double>^ y,
    array<double>^ baseVal,
    Color color
)
Parameters
label (String)
The label that will appear in the legend.
x (array< Double >[]())
An array of double precision values that define the independent (X axis) values for this curve
y (array< Double >[]())
An array of double precision values that define the dependent (Y axis) values for this curve
baseVal (array< Double >[]())
An array of double precision values that define the base value (the bottom) of the bars for this curve.
color (Color)
A Color value that will be applied to the Fill and Border properties.


HiLowBarItem Constructor (label, points, color)

HiLowBarItem Constructor (label, points, color)
Namespaces ► ZedGraph ► HiLowBarItem ► HiLowBarItemHiLowBarItemNew(String, IPointList, Color)
Create a new HiLowBarItem using the specified properties.
Declaration Syntax
C# Visual Basic Visual C++
public HiLowBarItem(
    string label,
    IPointList points,
    Color color
)
Public Sub New ( _
    label As String, _
    points As IPointList, _
    color As Color _
)
public:
HiLowBarItem (
    String^ label,
    IPointList^ points,
    Color color
)
Parameters
label (String)
The label that will appear in the legend.
points (IPointList)
A IPointList of double precision value trio's that define the X, Y, and lower dependent values for this curve
color (Color)
A Color value that will be applied to the Fill and Border properties.


HiLowBarItem Constructor (rhs)

HiLowBarItem Constructor (rhs)
Namespaces ► ZedGraph ► HiLowBarItem ► HiLowBarItemHiLowBarItemNew(HiLowBarItem)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public HiLowBarItem(
    HiLowBarItem rhs
)
Public Sub New ( _
    rhs As HiLowBarItem _
)
public:
HiLowBarItem (
    HiLowBarItem^ rhs
)
Parameters
rhs (HiLowBarItem)
The HiLowBarItem object from which to copy


Bar Property

Bar Property
Namespaces ► ZedGraph ► HiLowBarItem ► Bar
Gets a reference to the HiLowBar class defined for this HiLowBarItem.
Declaration Syntax
C# Visual Basic Visual C++
public HiLowBar Bar{ get;}
Public ReadOnly Property Bar As HiLowBar
public:
property HiLowBar^ Bar {
    HiLowBar^ get ();
}


Clone Method

Clone Method
Namespaces ► ZedGraph ► HiLowBarItem ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public HiLowBarItem Clone()
Public Function Clone As HiLowBarItem
public:
HiLowBarItem^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, pos, scaleFactor)

Draw Method (g, pane, pos, scaleFactor)
Namespaces ► ZedGraph ► HiLowBarItem ► Draw(Graphics, GraphPane, Int32, Single)
Do all rendering associated with this HiLowBarItem to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object.
Declaration Syntax
C# Visual Basic Visual C++
public override void Draw(
    Graphics g,
    GraphPane pane,
    int pos,
    float scaleFactor
)
Public Overrides Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    pos As Integer, _
    scaleFactor As Single _
)
public:
virtual void Draw (
    Graphics^ g,
    GraphPane^ pane,
    int pos,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
pos (Int32)
The ordinal position of the current ErrorBarItem curve.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


DrawLegendKey Method (g, pane, rect, scaleFactor)

DrawLegendKey Method (g, pane, rect, scaleFactor)
Namespaces ► ZedGraph ► HiLowBarItem ► DrawLegendKey(Graphics, GraphPane, RectangleF, Single)
Draw a legend key entry for this HiLowBarItem at the specified location
Declaration Syntax
C# Visual Basic Visual C++
public override void DrawLegendKey(
    Graphics g,
    GraphPane pane,
    RectangleF rect,
    float scaleFactor
)
Public Overrides Sub DrawLegendKey ( _
    g As Graphics, _
    pane As GraphPane, _
    rect As RectangleF, _
    scaleFactor As Single _
)
public:
virtual void DrawLegendKey (
    Graphics^ g,
    GraphPane^ pane,
    RectangleF rect,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
rect (RectangleF)
The RectangleF struct that specifies the location for the legend key
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


GetCoords Method (pane, i, coords)

GetCoords Method (pane, i, coords)
Namespaces ► ZedGraph ► HiLowBarItem ► GetCoords(GraphPane, Int32, String%)
Determine the coords for the rectangle associated with a specified point for this CurveItem
Declaration Syntax
C# Visual Basic Visual C++
public override bool GetCoords(
    GraphPane pane,
    int i,
    out string coords
)
Public Overrides Function GetCoords ( _
    pane As GraphPane, _
    i As Integer, _
    <OutAttribute> ByRef coords As String _
) As Boolean
public:
virtual bool GetCoords (
    GraphPane^ pane,
    int i,
    [OutAttribute] String^% coords
) override
Parameters
pane (GraphPane)
The GraphPane to which this curve belongs
i (Int32)
The index of the point of interest
coords (String %)
A list of coordinates that represents the "rect" for this point (used in an html AREA tag)
Return Value
true if it's a valid point, false otherwise


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► HiLowBarItem ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► HiLowBarItem ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► HiLowBarItem ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


HSBColor Structure

HSBColor Structure
Namespaces ► ZedGraph ► HSBColor
Hue-Saturation-Brightness Color class to store a color value, and to manage conversions to and from RGB colors in the Color struct.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public struct HSBColor
<SerializableAttribute> _
Public Structure HSBColor
[SerializableAttribute]
public value class HSBColor
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HSBColorHSBColorNew(Int32, Int32, Int32) | Constructor to load an HSBColor struct from hue, saturation and brightness values
 | HSBColorHSBColorNew(Int32, Int32, Int32, Int32) | Constructor to load an HSBColor struct from hue, saturation, brightness, and alpha values
 | HSBColorHSBColorNew(Color) | Constructor to load an HSBColor struct from a system Color struct.
 | A | The alpha value (opacity), ranging from 0 (transparent) to 255 (opaque).
 | B | The brightness value, ranging from 0 (black) to 255 (white).
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromRGB()() | Convert a Color value to an equivalent HSBColor value.
 | FromRGB(Color) | Convert a Color value to an equivalent HSBColor value.
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | H | The color hue value, ranging from 0 to 255.
 | Implicit(HSBColor) | Implicit conversion operator to convert directly from an HSBColor to a Color struct.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | S | The color saturation (intensity) value, ranging from 0 (gray scale) to 255 (most colored).
 | ToRGB(HSBColor) | Convert an HSBColor value to an equivalent Color value.
 | ToRGB()() | Convert this HSBColor value to an equivalent Color value.
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Remarks
This class is based on code from http://www.cs.rit.edu/~ncs/color/ by Eugene Vishnevsky. This struct stores the hue, saturation, brightness, and alpha values internally as Byte values from 0 to 255. The hue represents a fraction of the 360 degrees of color space available. The saturation is the color intensity, where 0 represents gray scale and 255 is the most colored. For the brightness, 0 represents black and 255 represents white.


HSBColor Constructor

HSBColor Constructor
Namespaces ► ZedGraph ► HSBColor ► HSBColorHSBColorNew()()
Members
Icon | Member | Description
 | HSBColorHSBColorNew(Int32, Int32, Int32) | Constructor to load an HSBColor struct from hue, saturation and brightness values
 | HSBColorHSBColorNew(Int32, Int32, Int32, Int32) | Constructor to load an HSBColor struct from hue, saturation, brightness, and alpha values
 | HSBColorHSBColorNew(Color) | Constructor to load an HSBColor struct from a system Color struct.


HSBColor Constructor (color)

HSBColor Constructor (color)
Namespaces ► ZedGraph ► HSBColor ► HSBColorHSBColorNew(Color)
Constructor to load an HSBColor struct from a system Color struct.
Declaration Syntax
C# Visual Basic Visual C++
public HSBColor(
    Color color
)
Public Sub New ( _
    color As Color _
)
public:
HSBColor (
    Color color
)
Parameters
color (Color)
An rgb Color struct containing the equivalent color you want to generate


HSBColor Constructor (h, s, b)

HSBColor Constructor (h, s, b)
Namespaces ► ZedGraph ► HSBColor ► HSBColorHSBColorNew(Int32, Int32, Int32)
Constructor to load an HSBColor struct from hue, saturation and brightness values
Declaration Syntax
C# Visual Basic Visual C++
public HSBColor(
    int h,
    int s,
    int b
)
Public Sub New ( _
    h As Integer, _
    s As Integer, _
    b As Integer _
)
public:
HSBColor (
    int h,
    int s,
    int b
)
Parameters
h (Int32)
The color hue value, ranging from 0 to 255
s (Int32)
The color saturation (intensity) value, ranging from 0 (gray scale) to 255 (most colored)
b (Int32)
The brightness value, ranging from 0 (black) to 255 (white)


HSBColor Constructor (a, h, s, b)

HSBColor Constructor (a, h, s, b)
Namespaces ► ZedGraph ► HSBColor ► HSBColorHSBColorNew(Int32, Int32, Int32, Int32)
Constructor to load an HSBColor struct from hue, saturation, brightness, and alpha values
Declaration Syntax
C# Visual Basic Visual C++
public HSBColor(
    int a,
    int h,
    int s,
    int b
)
Public Sub New ( _
    a As Integer, _
    h As Integer, _
    s As Integer, _
    b As Integer _
)
public:
HSBColor (
    int a,
    int h,
    int s,
    int b
)
Parameters
a (Int32)
The alpha value (opacity), ranging from 0 (transparent) to 255 (opaque)
h (Int32)
The color hue value, ranging from 0 to 255
s (Int32)
The color saturation (intensity) value, ranging from 0 (gray scale) to 255 (most colored)
b (Int32)
The brightness value, ranging from 0 (black) to 255 (white)


A Field

A Field
Namespaces ► ZedGraph ► HSBColor ► A
The alpha value (opacity), ranging from 0 (transparent) to 255 (opaque).
Declaration Syntax
C# Visual Basic Visual C++
public byte A
Public A As Byte
public:
unsigned char A


B Field

B Field
Namespaces ► ZedGraph ► HSBColor ► B
The brightness value, ranging from 0 (black) to 255 (white).
Declaration Syntax
C# Visual Basic Visual C++
public byte B
Public B As Byte
public:
unsigned char B


FromRGB Method

FromRGB Method
Namespaces ► ZedGraph ► HSBColor ► FromRGB()()
Members
Icon | Member | Description
 | FromRGB()() | Convert a Color value to an equivalent HSBColor value.
 | FromRGB(Color) | Convert a Color value to an equivalent HSBColor value.


FromRGB Method

FromRGB Method
Namespaces ► ZedGraph ► HSBColor ► FromRGB()()
Convert a Color value to an equivalent HSBColor value.
Declaration Syntax
C# Visual Basic Visual C++
public HSBColor FromRGB()
Public Function FromRGB As HSBColor
public:
HSBColor FromRGB ()
Return Value
An equivalent HSBColor struct
Remarks
This method is based on code from http://www.cs.rit.edu/~ncs/color/ by Eugene Vishnevsky.


FromRGB Method (rgbColor)

FromRGB Method (rgbColor)
Namespaces ► ZedGraph ► HSBColor ► FromRGB(Color)
Convert a Color value to an equivalent HSBColor value.
Declaration Syntax
C# Visual Basic Visual C++
public static HSBColor FromRGB(
    Color rgbColor
)
Public Shared Function FromRGB ( _
    rgbColor As Color _
) As HSBColor
public:
static HSBColor FromRGB (
    Color rgbColor
)
Parameters
rgbColor (Color)
The Color struct to be converted
Return Value
An equivalent HSBColor struct
Remarks
This method is based on code from http://www.cs.rit.edu/~ncs/color/ by Eugene Vishnevsky.


H Field

H Field
Namespaces ► ZedGraph ► HSBColor ► H
The color hue value, ranging from 0 to 255.
Declaration Syntax
C# Visual Basic Visual C++
public byte H
Public H As Byte
public:
unsigned char H
Remarks
This property is actually a rescaling of the 360 degrees on the color wheel to 255 possible values. Therefore, every 42.5 units is a new sector, with the following convention: red=0, yellow=42.5, green=85, cyan=127.5, blue=170, magenta=212.5


Implicit Operator

Implicit Operator
Namespaces ► ZedGraph ► HSBColor ► Implicit(HSBColor)
Implicit conversion operator to convert directly from an HSBColor to a Color struct.
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator Color (
    HSBColor hsbColor
)
Public Shared Widening Operator CType ( _
    hsbColor As HSBColor _
) As Color
static implicit operator Color  (
    HSBColor hsbColor
)
Parameters
hsbColor (HSBColor)
The HSBColor struct to be converted
Return Value
An equivalent Color struct that can be used in the GDI+ graphics library


S Field

S Field
Namespaces ► ZedGraph ► HSBColor ► S
The color saturation (intensity) value, ranging from 0 (gray scale) to 255 (most colored).
Declaration Syntax
C# Visual Basic Visual C++
public byte S
Public S As Byte
public:
unsigned char S


ToRGB Method

ToRGB Method
Namespaces ► ZedGraph ► HSBColor ► ToRGB()()
Members
Icon | Member | Description
 | ToRGB(HSBColor) | Convert an HSBColor value to an equivalent Color value.
 | ToRGB()() | Convert this HSBColor value to an equivalent Color value.


ToRGB Method

ToRGB Method
Namespaces ► ZedGraph ► HSBColor ► ToRGB()()
Convert this HSBColor value to an equivalent Color value.
Declaration Syntax
C# Visual Basic Visual C++
public Color ToRGB()
Public Function ToRGB As Color
public:
Color ToRGB ()
Return Value
An equivalent Color struct, compatible with the GDI+ library
Remarks
This method is based on code from http://www.cs.rit.edu/~ncs/color/ by Eugene Vishnevsky.


ToRGB Method (hsbColor)

ToRGB Method (hsbColor)
Namespaces ► ZedGraph ► HSBColor ► ToRGB(HSBColor)
Convert an HSBColor value to an equivalent Color value.
Declaration Syntax
C# Visual Basic Visual C++
public static Color ToRGB(
    HSBColor hsbColor
)
Public Shared Function ToRGB ( _
    hsbColor As HSBColor _
) As Color
public:
static Color ToRGB (
    HSBColor hsbColor
)
Parameters
hsbColor (HSBColor)
The HSBColor struct to be converted
Return Value
An equivalent Color struct, compatible with the GDI+ library
Remarks
This method is based on code from http://www.cs.rit.edu/~ncs/color/ by Eugene Vishnevsky.


ImageObj Class

ImageObj Class
Namespaces ► ZedGraph ► ImageObj
A class that represents an image object on the graph. A list of GraphObj objects is maintained by the GraphObjList collection class.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ImageObj : GraphObj, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class ImageObj _
    Inherits GraphObj _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class ImageObj : public GraphObj,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ImageObjImageObjNew()() | A default constructor that places a null Image at a default RectangleF of (0,0,1,1)
 | ImageObjImageObjNew(Image, RectangleF) | A constructor that allows the Image and RectangleF location for the ImageObj to be pre-specified.
 | ImageObjImageObjNew(Image, RectangleF, CoordType, AlignH, AlignV) | A constructor that allows the Image and RectangleF location for the ImageObj to be pre-specified.
 | ImageObjImageObjNew(Image, Double, Double, Double, Double) | A constructor that allows the Image and individual Single coordinate locations for the ImageObj to be pre-specified.
 | ImageObjImageObjNew(ImageObj) | The Copy Constructor
 | Clone()() | Typesafe, deep-copy clone method.
 | Draw(Graphics, PaneBase, Single) | Render this object to the specified Graphics device This method is normally only called by the Draw method of the parent GraphObjList collection object. (Overrides GraphObj.Draw(Graphics, PaneBase, Single).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCoords(PaneBase, Graphics, Single, String%, String%) | Determines the shape type and Coords values for this GraphObj (Overrides GraphObj.GetCoords(PaneBase, Graphics, Single, String%, String%).)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides GraphObj.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Image | The Image object.
 | IsClippedToChartRect | Gets or sets a value that determines whether or not the rendering of this GraphObj will be clipped to the Rect. (Inherited from GraphObj.)
 | IsInFrontOfData | true if the ZOrder of this object is set to put it in front of the CurveItem data points. (Inherited from GraphObj.)
 | IsScaled | Gets or sets a property that determines if the image will be scaled to the output rectangle (see Location).
 | IsVisible | Gets or sets a value that determines if this GraphObj will be visible in the graph. true displays the item, false hides it. (Inherited from GraphObj.)
 | Link | Gets or sets the hyperlink information for this GraphObj. (Inherited from GraphObj.)
 | Location | The Location struct that describes the location for this GraphObj. (Inherited from GraphObj.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PointInBox(PointF, PaneBase, Graphics, Single) | Determine if the specified screen point lies inside the bounding box of this ArrowObj. The bounding box is calculated assuming a distance of NearestTol pixels around the arrow segment. (Overrides GraphObj.PointInBox(PointF, PaneBase, Graphics, Single).)
 | schema2 | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the GraphObj. ZedGraph does not use this value for any purpose. (Inherited from GraphObj.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ZOrder | Gets or sets a value that determines the z-order "depth" of this item relative to other graphic objects. (Inherited from GraphObj.)
Inheritance Hierarchy
Object
 | GraphObj
 |  | ImageObj


ImageObj Constructor

ImageObj Constructor
Namespaces ► ZedGraph ► ImageObj ► ImageObjImageObjNew()()
Constructors for the ImageObj objectConstructors for the ImageObj objectConstructors for the ImageObj object
Members
Icon | Member | Description
 | ImageObjImageObjNew()() | A default constructor that places a null Image at a default RectangleF of (0,0,1,1)
 | ImageObjImageObjNew(Image, RectangleF) | A constructor that allows the Image and RectangleF location for the ImageObj to be pre-specified.
 | ImageObjImageObjNew(Image, RectangleF, CoordType, AlignH, AlignV) | A constructor that allows the Image and RectangleF location for the ImageObj to be pre-specified.
 | ImageObjImageObjNew(Image, Double, Double, Double, Double) | A constructor that allows the Image and individual Single coordinate locations for the ImageObj to be pre-specified.
 | ImageObjImageObjNew(ImageObj) | The Copy Constructor


ImageObj Constructor

ImageObj Constructor
Namespaces ► ZedGraph ► ImageObj ► ImageObjImageObjNew()()
A default constructor that places a null Image at a default RectangleF of (0,0,1,1)
Declaration Syntax
C# Visual Basic Visual C++
public ImageObj()
Public Sub New
public:
ImageObj ()


ImageObj Constructor (image, left, top, width, height)

ImageObj Constructor (image, left, top, width, height)
Namespaces ► ZedGraph ► ImageObj ► ImageObjImageObjNew(Image, Double, Double, Double, Double)
A constructor that allows the Image and individual Single coordinate locations for the ImageObj to be pre-specified.
Declaration Syntax
C# Visual Basic Visual C++
public ImageObj(
    Image image,
    double left,
    double top,
    double width,
    double height
)
Public Sub New ( _
    image As Image, _
    left As Double, _
    top As Double, _
    width As Double, _
    height As Double _
)
public:
ImageObj (
    Image^ image,
    double left,
    double top,
    double width,
    double height
)
Parameters
image (Image)
A Image class that defines the image
left (Double)
The position of the left side of the rectangle that defines the ImageObj location. The units of this position are specified by the CoordinateFrame property.
top (Double)
The position of the top side of the rectangle that defines the ImageObj location. The units of this position are specified by the CoordinateFrame property.
width (Double)
The width of the rectangle that defines the ImageObj location. The units of this position are specified by the CoordinateFrame property.
height (Double)
The height of the rectangle that defines the ImageObj location. The units of this position are specified by the CoordinateFrame property.


ImageObj Constructor (image, rect)

ImageObj Constructor (image, rect)
Namespaces ► ZedGraph ► ImageObj ► ImageObjImageObjNew(Image, RectangleF)
A constructor that allows the Image and RectangleF location for the ImageObj to be pre-specified.
Declaration Syntax
C# Visual Basic Visual C++
public ImageObj(
    Image image,
    RectangleF rect
)
Public Sub New ( _
    image As Image, _
    rect As RectangleF _
)
public:
ImageObj (
    Image^ image,
    RectangleF rect
)
Parameters
image (Image)
A Image class that defines the image
rect (RectangleF)
A RectangleF struct that defines the image location, specifed in units based on the CoordinateFrame property.


ImageObj Constructor (image, rect, coordType, alignH, alignV)

ImageObj Constructor (image, rect, coordType, alignH, alignV)
Namespaces ► ZedGraph ► ImageObj ► ImageObjImageObjNew(Image, RectangleF, CoordType, AlignH, AlignV)
A constructor that allows the Image and RectangleF location for the ImageObj to be pre-specified.
Declaration Syntax
C# Visual Basic Visual C++
public ImageObj(
    Image image,
    RectangleF rect,
    CoordType coordType,
    AlignH alignH,
    AlignV alignV
)
Public Sub New ( _
    image As Image, _
    rect As RectangleF, _
    coordType As CoordType, _
    alignH As AlignH, _
    alignV As AlignV _
)
public:
ImageObj (
    Image^ image,
    RectangleF rect,
    CoordType coordType,
    AlignH alignH,
    AlignV alignV
)
Parameters
image (Image)
A Image class that defines the image
rect (RectangleF)
A RectangleF struct that defines the image location, specifed in units based on the CoordinateFrame property.
coordType (CoordType)
The CoordType enum value that indicates what type of coordinate system the x and y parameters are referenced to.
alignH (AlignH)
The AlignH enum that specifies the horizontal alignment of the object with respect to the (x,y) location
alignV (AlignV)
The AlignV enum that specifies the vertical alignment of the object with respect to the (x,y) location


ImageObj Constructor (rhs)

ImageObj Constructor (rhs)
Namespaces ► ZedGraph ► ImageObj ► ImageObjImageObjNew(ImageObj)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ImageObj(
    ImageObj rhs
)
Public Sub New ( _
    rhs As ImageObj _
)
public:
ImageObj (
    ImageObj^ rhs
)
Parameters
rhs (ImageObj)
The ImageObj object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► ImageObj ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public ImageObj Clone()
Public Function Clone As ImageObj
public:
ImageObj^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, scaleFactor)

Draw Method (g, pane, scaleFactor)
Namespaces ► ZedGraph ► ImageObj ► Draw(Graphics, PaneBase, Single)
Render this object to the specified Graphics device This method is normally only called by the Draw method of the parent GraphObjList collection object.
Declaration Syntax
C# Visual Basic Visual C++
public override void Draw(
    Graphics g,
    PaneBase pane,
    float scaleFactor
)
Public Overrides Sub Draw ( _
    g As Graphics, _
    pane As PaneBase, _
    scaleFactor As Single _
)
public:
virtual void Draw (
    Graphics^ g,
    PaneBase^ pane,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


GetCoords Method (pane, g, scaleFactor, shape, coords)

GetCoords Method (pane, g, scaleFactor, shape, coords)
Namespaces ► ZedGraph ► ImageObj ► GetCoords(PaneBase, Graphics, Single, String%, String%)
Determines the shape type and Coords values for this GraphObj
Declaration Syntax
C# Visual Basic Visual C++
public override void GetCoords(
    PaneBase pane,
    Graphics g,
    float scaleFactor,
    out string shape,
    out string coords
)
Public Overrides Sub GetCoords ( _
    pane As PaneBase, _
    g As Graphics, _
    scaleFactor As Single, _
    <OutAttribute> ByRef shape As String, _
    <OutAttribute> ByRef coords As String _
)
public:
virtual void GetCoords (
    PaneBase^ pane,
    Graphics^ g,
    float scaleFactor,
    [OutAttribute] String^% shape,
    [OutAttribute] String^% coords
) override
Parameters
pane (PaneBase)
g (Graphics)
scaleFactor (Single)
shape (String %)
coords (String %)


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► ImageObj ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


Image Property

Image Property
Namespaces ► ZedGraph ► ImageObj ► Image
The Image object.
Declaration Syntax
C# Visual Basic Visual C++
public Image Image{ get; set;}
Public Property Image As Image
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}
Value
A Image class reference.


IsScaled Property

IsScaled Property
Namespaces ► ZedGraph ► ImageObj ► IsScaled
Gets or sets a property that determines if the image will be scaled to the output rectangle (see Location).
Declaration Syntax
C# Visual Basic Visual C++
public bool IsScaled{ get; set;}
Public Property IsScaled As Boolean
public:
property bool IsScaled {
    bool get ();
    void set (bool value);
}
Value
true to scale the image, false to draw the image unscaled, but clipped to the destination rectangle


PointInBox Method (pt, pane, g, scaleFactor)

PointInBox Method (pt, pane, g, scaleFactor)
Namespaces ► ZedGraph ► ImageObj ► PointInBox(PointF, PaneBase, Graphics, Single)
Determine if the specified screen point lies inside the bounding box of this ArrowObj. The bounding box is calculated assuming a distance of NearestTol pixels around the arrow segment.
Declaration Syntax
C# Visual Basic Visual C++
public override bool PointInBox(
    PointF pt,
    PaneBase pane,
    Graphics g,
    float scaleFactor
)
Public Overrides Function PointInBox ( _
    pt As PointF, _
    pane As PaneBase, _
    g As Graphics, _
    scaleFactor As Single _
) As Boolean
public:
virtual bool PointInBox (
    PointF pt,
    PaneBase^ pane,
    Graphics^ g,
    float scaleFactor
) override
Parameters
pt (PointF)
The screen point, in pixels
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
true if the point lies in the bounding box, false otherwise


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► ImageObj ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► ImageObj ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


ImageObj.Default Structure

ImageObj..::Default Structure
Namespaces ► ZedGraph ► ImageObj ► ImageObj..::Default
A simple struct that defines the default property values for the ImageObj class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsScaled | Default value for the ImageObj IsScaled property.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


IsScaled Field

IsScaled Field
Namespaces ► ZedGraph ► ImageObj..::Default ► IsScaled
Default value for the ImageObj IsScaled property.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsScaled
Public Shared IsScaled As Boolean
public:
static bool IsScaled


IPointList Interface

IPointList Interface
Namespaces ► ZedGraph ► IPointList
An interface to a collection class containing data that define the set of points to be displayed on the curve.
Declaration Syntax
C# Visual Basic Visual C++
public interface IPointList : ICloneable
Public Interface IPointList _
    Implements ICloneable
public interface class IPointList : ICloneable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Clone()() | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
 | Count | Gets the number of points available in the list.
 | Item[([Int32])] | Indexer to access a data point by its ordinal position in the collection.
Remarks
This interface is designed to allow customized data abstraction. The default data collection class is PointPairList, however, you can define your own data collection class using the IPointList interface.
See Also
PointPairList
BasicArrayPointList


Count Property

Count Property
Namespaces ► ZedGraph ► IPointList ► Count
Gets the number of points available in the list.
Declaration Syntax
C# Visual Basic Visual C++
int Count{ get;}
ReadOnly Property Count As Integer
property int Count {
    int get ();
}


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph ► IPointList ► Item[([Int32])]
Indexer to access a data point by its ordinal position in the collection.
Declaration Syntax
C# Visual Basic Visual C++
PointPair this[
    int index
]{ get;}
ReadOnly Default Property Item ( _
    index As Integer _
) As PointPair
property PointPair^ default[int index] {
    PointPair^ get (int index);
}
Parameters
index (Int32)
The ordinal position (zero-based) of the data point to be accessed.
Value
A PointPair object instance.
Remarks
This is the standard interface that ZedGraph uses to access the data. Although you must pass a PointPair here, your internal data storage format can be anything.


IPointListEdit Interface

IPointListEdit Interface
Namespaces ► ZedGraph ► IPointListEdit
An interface to a collection class containing data that define the set of points to be displayed on the curve.
Declaration Syntax
C# Visual Basic Visual C++
public interface IPointListEdit : IPointList,
    ICloneable
Public Interface IPointListEdit _
    Implements IPointList, ICloneable
public interface class IPointListEdit : IPointList,
    ICloneable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(PointPair) | Appends a point to the end of the list. The data are passed in as a PointPair object.
 | Add(Double, Double) | Appends a point to the end of the list. The data are passed in as two Double types.
 | Clear()() | Clears all data points from the list. After calling this method, Count will be zero.
 | Clone()() | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)
 | Count | Gets the number of points available in the list. (Inherited from IPointList.)
 | Item[([Int32])] | Indexer to access a data point by its ordinal position in the collection.
 | Item[([Int32])] | Indexer to access a data point by its ordinal position in the collection. (Inherited from IPointList.)
 | RemoveAt(Int32) | Removes a single data point from the list at the specified ordinal location (zero based).
Remarks
This interface is designed to allow customized data abstraction. The default data collection class is PointPairList, however, you can define your own data collection class using the IPointList interface. This IPointListEdit interface adds the ability to remove and add points to the list, and so is used by the CurveItem class for the AddPoint(Double, Double), RemovePoint(Int32), and Clear()() methods.
See Also
PointPairList
BasicArrayPointList
IPointList
FilteredPointList


Add Method

Add Method
Namespaces ► ZedGraph ► IPointListEdit ► Add()()
Members
Icon | Member | Description
 | Add(PointPair) | Appends a point to the end of the list. The data are passed in as a PointPair object.
 | Add(Double, Double) | Appends a point to the end of the list. The data are passed in as two Double types.


Add Method (x, y)

Add Method (x, y)
Namespaces ► ZedGraph ► IPointListEdit ► Add(Double, Double)
Appends a point to the end of the list. The data are passed in as two Double types.
Declaration Syntax
C# Visual Basic Visual C++
void Add(
    double x,
    double y
)
Sub Add ( _
    x As Double, _
    y As Double _
)
void Add (
    double x,
    double y
)
Parameters
x (Double)
The Double value containing the X data to be added.
y (Double)
The Double value containing the Y data to be added.
Return Value
The ordinal position (zero-based), at which the new point was added.


Add Method (point)

Add Method (point)
Namespaces ► ZedGraph ► IPointListEdit ► Add(PointPair)
Appends a point to the end of the list. The data are passed in as a PointPair object.
Declaration Syntax
C# Visual Basic Visual C++
void Add(
    PointPair point
)
Sub Add ( _
    point As PointPair _
)
void Add (
    PointPair^ point
)
Parameters
point (PointPair)
The PointPair object containing the data to be added.


Clear Method

Clear Method
Namespaces ► ZedGraph ► IPointListEdit ► Clear()()
Clears all data points from the list. After calling this method, Count will be zero.
Declaration Syntax
C# Visual Basic Visual C++
void Clear()
Sub Clear
void Clear ()


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph ► IPointListEdit ► Item[([Int32])]
Indexer to access a data point by its ordinal position in the collection.
Declaration Syntax
C# Visual Basic Visual C++
PointPair this[
    int index
]{ get; set;}
Default Property Item ( _
    index As Integer _
) As PointPair
property PointPair^ default[int index] {
    PointPair^ get (int index);
    void set (int index, PointPair^ value);
}
Parameters
index (Int32)
The ordinal position (zero-based) of the data point to be accessed.
Value
A PointPair object instance.
Remarks
This is the standard interface that ZedGraph uses to access the data. Although you must pass a PointPair here, your internal data storage format can be anything.


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces ► ZedGraph ► IPointListEdit ► RemoveAt(Int32)
Removes a single data point from the list at the specified ordinal location (zero based).
Declaration Syntax
C# Visual Basic Visual C++
void RemoveAt(
    int index
)
Sub RemoveAt ( _
    index As Integer _
)
void RemoveAt (
    int index
)
Parameters
index (Int32)


JapaneseCandleStick Class

JapaneseCandleStick Class
Namespaces ► ZedGraph ► JapaneseCandleStick
This class handles the drawing of the curve JapaneseCandleStick objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class JapaneseCandleStick : OHLCBar, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class JapaneseCandleStick _
    Inherits OHLCBar _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class JapaneseCandleStick : public OHLCBar,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JapaneseCandleStickJapaneseCandleStickNew()() | Default constructor that sets all JapaneseCandleStick properties to default values as defined in the JapaneseCandleStick..::Default class.
 | JapaneseCandleStickJapaneseCandleStickNew(JapaneseCandleStick) | The Copy Constructor
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The color of the Line. Note that this color value can be overridden if the GradientFill.Type is one of the GradientByX, GradientByY, GradientByZ, and GradientByColorValue types. (Inherited from LineBase.)
 | DashOff | The "Dash Off" mode for drawing the line. (Inherited from LineBase.)
 | DashOn | The "Dash On" mode for drawing the line. (Inherited from LineBase.)
 | Draw(Graphics, GraphPane, Boolean, Single, Single, Single, Single, Single, Single, Single, Pen, Fill, Border, PointPair) | Draw the JapaneseCandleStick to the specified Graphics device at the specified location.
 | Draw(Graphics, GraphPane, JapaneseCandleStickItem, Axis, Axis, Single) | Draw all the JapaneseCandleStick's to the specified Graphics device as a candlestick at each defined point.
 | Draw(Graphics, GraphPane, Boolean, Single, Single, Single, Single, Single, Single, Pen) | Draw the OHLCBar to the specified Graphics device at the specified location. (Inherited from OHLCBar.)
 | Draw(Graphics, GraphPane, OHLCBarItem, Axis, Axis, Single) | Draw all the OHLCBar's to the specified Graphics device as a candlestick at each defined point. (Inherited from OHLCBar.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FallingBorder | The Border instance to be used for drawing the border frame of the candlestick "bars" when the Close value is less than the Open value.
 | FallingColor | Gets or sets the Color data for this JapaneseCandleStick when the value of the candlestick is falling.
 | FallingFill | Gets or sets the Fill class that is used to fill the candlestick "bars" when the Close value is less than the Open value.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarWidth(GraphPane, Axis, Single) | Returns the width of the candleStick, in pixels, based on the settings for Size and IsAutoSize. (Inherited from OHLCBar.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides OHLCBar.GetObjectData(SerializationInfo, StreamingContext).)
 | GetPen(PaneBase, Single) | Create a Pen object based on the properties of this LineBase. (Inherited from LineBase.)
 | GetPen(PaneBase, Single, PointPair) | Create a Pen object based on the properties of this LineBase. (Inherited from LineBase.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GradientFill | Gets or sets a custom Fill class. (Inherited from LineBase.)
 | IsAntiAlias | Gets or sets a value that determines if the lines are drawn using Anti-Aliasing capabilities from the Graphics class. (Inherited from LineBase.)
 | IsAutoSize | Gets or sets a value that determines if the Size property will be calculated automatically based on the minimum axis scale step size between bars. (Inherited from OHLCBar.)
 | IsOpenCloseVisible | Gets or sets a property that shows or hides the OHLCBar open/close "wings". (Inherited from OHLCBar.)
 | IsVisible | Gets or sets a property that shows or hides the Line. (Inherited from LineBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RisingBorder | The Border instance to be used for drawing the border frame of the candlestick "bars" when the Close value is greater than the Open value.
 | RisingFill | Gets or sets the Fill class that is used to fill the candlestick "bars" when the Close value is greater than the Open value.
 | schema2 | Current schema value that defines the version of the serialized file
 | Size | Gets or sets the total width to be used for drawing the opening/closing line segments ("wings") of the OHLCBar items. Units are points. (Inherited from OHLCBar.)
 | Style | The style of the Line, defined as a DashStyle enum. This allows the line to be solid, dashed, or dotted. (Inherited from LineBase.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Width | The pen width used to draw the Line, in points (1/72 inch) (Inherited from LineBase.)
Inheritance Hierarchy
Object
 | LineBase
 |  | OHLCBar
 |  |  | JapaneseCandleStick


JapaneseCandleStick Constructor

JapaneseCandleStick Constructor
Namespaces ► ZedGraph ► JapaneseCandleStick ► JapaneseCandleStickJapaneseCandleStickNew()()
Members
Icon | Member | Description
 | JapaneseCandleStickJapaneseCandleStickNew()() | Default constructor that sets all JapaneseCandleStick properties to default values as defined in the JapaneseCandleStick..::Default class.
 | JapaneseCandleStickJapaneseCandleStickNew(JapaneseCandleStick) | The Copy Constructor


JapaneseCandleStick Constructor

JapaneseCandleStick Constructor
Namespaces ► ZedGraph ► JapaneseCandleStick ► JapaneseCandleStickJapaneseCandleStickNew()()
Default constructor that sets all JapaneseCandleStick properties to default values as defined in the JapaneseCandleStick..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public JapaneseCandleStick()
Public Sub New
public:
JapaneseCandleStick ()


JapaneseCandleStick Constructor (rhs)

JapaneseCandleStick Constructor (rhs)
Namespaces ► ZedGraph ► JapaneseCandleStick ► JapaneseCandleStickJapaneseCandleStickNew(JapaneseCandleStick)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public JapaneseCandleStick(
    JapaneseCandleStick rhs
)
Public Sub New ( _
    rhs As JapaneseCandleStick _
)
public:
JapaneseCandleStick (
    JapaneseCandleStick^ rhs
)
Parameters
rhs (JapaneseCandleStick)
The JapaneseCandleStick object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► JapaneseCandleStick ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public JapaneseCandleStick Clone()
Public Function Clone As JapaneseCandleStick
public:
JapaneseCandleStick^ Clone ()
Return Value
A new, independent copy of this class


Draw Method

Draw Method
Namespaces ► ZedGraph ► JapaneseCandleStick ► Draw()()
Members
Icon | Member | Description
 | Draw(Graphics, GraphPane, Boolean, Single, Single, Single, Single, Single, Single, Single, Pen, Fill, Border, PointPair) | Draw the JapaneseCandleStick to the specified Graphics device at the specified location.
 | Draw(Graphics, GraphPane, JapaneseCandleStickItem, Axis, Axis, Single) | Draw all the JapaneseCandleStick's to the specified Graphics device as a candlestick at each defined point.
 | Draw(Graphics, GraphPane, Boolean, Single, Single, Single, Single, Single, Single, Pen) | Draw the OHLCBar to the specified Graphics device at the specified location.
 | Draw(Graphics, GraphPane, OHLCBarItem, Axis, Axis, Single) | Draw all the OHLCBar's to the specified Graphics device as a candlestick at each defined point.


Draw Method (g, pane, isXBase, pixBase, pixHigh, pixLow, pixOpen, pixClose, halfSize, scaleFactor, pen, fill, border, pt)

Draw Method (g, pane, isXBase, pixBase, pixHigh, pixLow, pixOpen, pixClose, halfSize, scaleFactor, pen, fill, border, pt)
Namespaces ► ZedGraph ► JapaneseCandleStick ► Draw(Graphics, GraphPane, Boolean, Single, Single, Single, Single, Single, Single, Single, Pen, Fill, Border, PointPair)
Draw the JapaneseCandleStick to the specified Graphics device at the specified location.
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    GraphPane pane,
    bool isXBase,
    float pixBase,
    float pixHigh,
    float pixLow,
    float pixOpen,
    float pixClose,
    float halfSize,
    float scaleFactor,
    Pen pen,
    Fill fill,
    Border border,
    PointPair pt
)
Public Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    isXBase As Boolean, _
    pixBase As Single, _
    pixHigh As Single, _
    pixLow As Single, _
    pixOpen As Single, _
    pixClose As Single, _
    halfSize As Single, _
    scaleFactor As Single, _
    pen As Pen, _
    fill As Fill, _
    border As Border, _
    pt As PointPair _
)
public:
void Draw (
    Graphics^ g,
    GraphPane^ pane,
    bool isXBase,
    float pixBase,
    float pixHigh,
    float pixLow,
    float pixOpen,
    float pixClose,
    float halfSize,
    float scaleFactor,
    Pen^ pen,
    Fill^ fill,
    Border^ border,
    PointPair^ pt
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
isXBase (Boolean)
boolean value that indicates if the "base" axis for this JapaneseCandleStick is the X axis. True for an XAxis base, false for a YAxis or Y2Axis base.
pixBase (Single)
The independent axis position of the center of the candlestick in pixel units
pixHigh (Single)
The high value position of the candlestick in pixel units
pixLow (Single)
The low value position of the candlestick in pixel units
pixOpen (Single)
The opening value position of the candlestick in pixel units
pixClose (Single)
The closing value position of the candlestick in pixel units
halfSize (Single)
The scaled width of one-half of a bar, in pixels
scaleFactor (Single)
The scaling factor for the features of the graph based on the BaseDimension. This scaling factor is calculated by the CalcScaleFactor()() method. The scale factor represents a linear multiple to be applied to font sizes, symbol sizes, etc.
pen (Pen)
A pen with the Color attribute for this JapaneseCandleStick
fill (Fill)
The Fill instance to be used for filling this JapaneseCandleStick
border (Border)
The Border instance to be used for drawing the border around the JapaneseCandleStick filled box
pt (PointPair)
The PointPair to be used for determining the Fill, just in case it's a GradientByX, GradientByY, or GradientByZ FillType


Draw Method (g, pane, curve, baseAxis, valueAxis, scaleFactor)

Draw Method (g, pane, curve, baseAxis, valueAxis, scaleFactor)
Namespaces ► ZedGraph ► JapaneseCandleStick ► Draw(Graphics, GraphPane, JapaneseCandleStickItem, Axis, Axis, Single)
Draw all the JapaneseCandleStick's to the specified Graphics device as a candlestick at each defined point.
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    GraphPane pane,
    JapaneseCandleStickItem curve,
    Axis baseAxis,
    Axis valueAxis,
    float scaleFactor
)
Public Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    curve As JapaneseCandleStickItem, _
    baseAxis As Axis, _
    valueAxis As Axis, _
    scaleFactor As Single _
)
public:
void Draw (
    Graphics^ g,
    GraphPane^ pane,
    JapaneseCandleStickItem^ curve,
    Axis^ baseAxis,
    Axis^ valueAxis,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
curve (JapaneseCandleStickItem)
A JapaneseCandleStickItem object representing the JapaneseCandleStick's to be drawn.
baseAxis (Axis)
The Axis class instance that defines the base (independent) axis for the JapaneseCandleStick
valueAxis (Axis)
The Axis class instance that defines the value (dependent) axis for the JapaneseCandleStick
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


FallingBorder Property

FallingBorder Property
Namespaces ► ZedGraph ► JapaneseCandleStick ► FallingBorder
The Border instance to be used for drawing the border frame of the candlestick "bars" when the Close value is less than the Open value.
Declaration Syntax
C# Visual Basic Visual C++
public Border FallingBorder{ get; set;}
Public Property FallingBorder As Border
public:
property Border^ FallingBorder {
    Border^ get ();
    void set (Border^ value);
}


FallingColor Property

FallingColor Property
Namespaces ► ZedGraph ► JapaneseCandleStick ► FallingColor
Gets or sets the Color data for this JapaneseCandleStick when the value of the candlestick is falling.
Declaration Syntax
C# Visual Basic Visual C++
public Color FallingColor{ get; set;}
Public Property FallingColor As Color
public:
property Color FallingColor {
    Color get ();
    void set (Color value);
}
Remarks
This property only controls the color of the vertical line when the value is falling. The rising color is controlled by the Color property.


FallingFill Property

FallingFill Property
Namespaces ► ZedGraph ► JapaneseCandleStick ► FallingFill
Gets or sets the Fill class that is used to fill the candlestick "bars" when the Close value is less than the Open value.
Declaration Syntax
C# Visual Basic Visual C++
public Fill FallingFill{ get; set;}
Public Property FallingFill As Fill
public:
property Fill^ FallingFill {
    Fill^ get ();
    void set (Fill^ value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► JapaneseCandleStick ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


RisingBorder Property

RisingBorder Property
Namespaces ► ZedGraph ► JapaneseCandleStick ► RisingBorder
The Border instance to be used for drawing the border frame of the candlestick "bars" when the Close value is greater than the Open value.
Declaration Syntax
C# Visual Basic Visual C++
public Border RisingBorder{ get; set;}
Public Property RisingBorder As Border
public:
property Border^ RisingBorder {
    Border^ get ();
    void set (Border^ value);
}


RisingFill Property

RisingFill Property
Namespaces ► ZedGraph ► JapaneseCandleStick ► RisingFill
Gets or sets the Fill class that is used to fill the candlestick "bars" when the Close value is greater than the Open value.
Declaration Syntax
C# Visual Basic Visual C++
public Fill RisingFill{ get; set;}
Public Property RisingFill As Fill
public:
property Fill^ RisingFill {
    Fill^ get ();
    void set (Fill^ value);
}


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► JapaneseCandleStick ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► JapaneseCandleStick ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


JapaneseCandleStick.Default Structure

JapaneseCandleStick..::Default Structure
Namespaces ► ZedGraph ► JapaneseCandleStick ► JapaneseCandleStick..::Default
A simple struct that defines the default property values for the JapaneseCandleStick class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | FallingBorder | The default color for the border of the falling CandleSticks (FallingBorder property).
 | FallingColor | The default fillcolor for drawing the falling case CandleSticks (FallingFill property).
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RisingBorder | The default color for the border of the rising CandleSticks (RisingBorder property).
 | RisingColor | The default fillcolor for drawing the rising case CandleSticks (RisingFill property).
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


FallingBorder Field

FallingBorder Field
Namespaces ► ZedGraph ► JapaneseCandleStick..::Default ► FallingBorder
The default color for the border of the falling CandleSticks (FallingBorder property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color FallingBorder
Public Shared FallingBorder As Color
public:
static Color FallingBorder


FallingColor Field

FallingColor Field
Namespaces ► ZedGraph ► JapaneseCandleStick..::Default ► FallingColor
The default fillcolor for drawing the falling case CandleSticks (FallingFill property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color FallingColor
Public Shared FallingColor As Color
public:
static Color FallingColor


RisingBorder Field

RisingBorder Field
Namespaces ► ZedGraph ► JapaneseCandleStick..::Default ► RisingBorder
The default color for the border of the rising CandleSticks (RisingBorder property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color RisingBorder
Public Shared RisingBorder As Color
public:
static Color RisingBorder


RisingColor Field

RisingColor Field
Namespaces ► ZedGraph ► JapaneseCandleStick..::Default ► RisingColor
The default fillcolor for drawing the rising case CandleSticks (RisingFill property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color RisingColor
Public Shared RisingColor As Color
public:
static Color RisingColor


JapaneseCandleStickItem Class

JapaneseCandleStickItem Class
Namespaces ► ZedGraph ► JapaneseCandleStickItem
Encapsulates a Japanese CandleStick curve type that displays a vertical (or horizontal) line displaying the range of data values at each sample point, plus a filled bar signifying the opening and closing value for the sample.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class JapaneseCandleStickItem : CurveItem, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class JapaneseCandleStickItem _
    Inherits CurveItem _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class JapaneseCandleStickItem : public CurveItem,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JapaneseCandleStickItemJapaneseCandleStickItemNew(String) | Create a new OHLCBarItem, specifying only the legend label.
 | JapaneseCandleStickItemJapaneseCandleStickItemNew(String, IPointList) | Create a new JapaneseCandleStickItem using the specified properties.
 | JapaneseCandleStickItemJapaneseCandleStickItemNew(JapaneseCandleStickItem) | The Copy Constructor
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve. (Inherited from CurveItem.)
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve. (Inherited from CurveItem.)
 | BaseAxis(GraphPane) | Returns a reference to the Axis object that is the "base" (independent axis) from which the values are drawn. (Inherited from CurveItem.)
 | Clear()() | Clears the points from this CurveItem. This is the same as CurveItem.Points.Clear(). (Inherited from CurveItem.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The Line/Symbol/Bar color (FillColor for the Bar). This is a common access to Line.Color, Border.Color, and Fill.Color properties for this curve. (Inherited from CurveItem.)
 | Draw(Graphics, GraphPane, Int32, Single) | Do all rendering associated with this OHLCBarItem to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object. (Overrides CurveItem.Draw(Graphics, GraphPane, Int32, Single).)
 | DrawLegendKey(Graphics, GraphPane, RectangleF, Single) | Draw a legend key entry for this OHLCBarItem at the specified location (Overrides CurveItem.DrawLegendKey(Graphics, GraphPane, RectangleF, Single).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarWidth(GraphPane) | Calculate the width of each bar, depending on the actual bar type (Inherited from CurveItem.)
 | GetCoords(GraphPane, Int32, String%) | Determine the coords for the rectangle associated with a specified point for this CurveItem (Overrides CurveItem.GetCoords(GraphPane, Int32, String%).)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides CurveItem.GetObjectData(SerializationInfo, StreamingContext).)
 | GetRange(Double%, Double%, Double%, Double%, Boolean, Boolean, GraphPane) | Go through the list of PointPair data values for this CurveItem and determine the minimum and maximum values in the data. (Inherited from CurveItem.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXAxis(GraphPane) | Get the X Axis instance (either XAxis or X2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxis(GraphPane) | Get the Y Axis instance (either YAxis or Y2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxisIndex(GraphPane) | Get the index of the Y Axis in the YAxis or Y2Axis list to which this CurveItem belongs. (Inherited from CurveItem.)
 | IsBar | Determines whether this CurveItem is a BarItem. This does not include HiLowBarItem's or ErrorBarItem's. (Inherited from CurveItem.)
 | IsLine | Determines whether this CurveItem is a LineItem. (Inherited from CurveItem.)
 | IsOverrideOrdinal | Gets or sets a value which allows you to override the normal ordinal axis behavior. (Inherited from CurveItem.)
 | IsPie | Determines whether this CurveItem is a PieItem. (Inherited from CurveItem.)
 | IsSelectable | Determines whether this CurveItem can be selected in the graph. (Inherited from CurveItem.)
 | IsSelected | Determines whether this CurveItem is selected on the graph. Note that this value changes the curve displayed color, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsVisible | Determines whether this CurveItem is visible on the graph. Note that this value turns the curve display on or off, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsX2Axis | Gets or sets a value that determines which X axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | IsY2Axis | Gets or sets a value that determines which Y axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | Item[([Int32])] | An accessor for the PointPair datum for this CurveItem. Index is the ordinal reference (zero based) of the point. (Inherited from CurveItem.)
 | Label | A Label instance that represents the Legend entry for the this CurveItem object (Inherited from CurveItem.)
 | Link | Gets or sets the hyperlink information for this CurveItem. (Inherited from CurveItem.)
 | MakeUnique()() | Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator) (Inherited from CurveItem.)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator) (Inherited from CurveItem.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NPts | Readonly property that gives the number of points that define this CurveItem object, which is the number of points in the Points data collection. (Inherited from CurveItem.)
 | Points | The IPointList of X,Y point sets that represent this CurveItem. (Inherited from CurveItem.)
 | RemovePoint(Int32) | Removes a single point from this CurveItem. (Inherited from CurveItem.)
 | schema2 | Current schema value that defines the version of the serialized file
 | Stick | Gets a reference to the JapaneseCandleStick class defined for this JapaneseCandleStickItem.
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the CurveItem. ZedGraph does not use this value for any purpose. (Inherited from CurveItem.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValueAxis(GraphPane) | Returns a reference to the Axis object that is the "value" (dependent axis) from which the points are drawn. (Inherited from CurveItem.)
 | YAxisIndex | Gets or sets the index number of the Y Axis to which this CurveItem belongs. (Inherited from CurveItem.)
Remarks
For this type to work properly, your IPointList must contain StockPt objects, rather than ordinary PointPair types. This is because the OHLCBarItem type actually displays 5 data values but the PointPair only stores 3 data values. The StockPt stores Date, Close, Open, High, and Low members. For a JapaneseCandleStick chart, the range between opening and closing values is drawn as a filled bar, with the filled color different (RisingFill) for the case of Close higher than Open, and FallingFill for the reverse. The width of the bar is controlled by the Size property, which is specified in points (1/72nd inch), and scaled according to CalcScaleFactor()(). The candlesticks are drawn horizontally or vertically depending on the value of Base, which is a BarBase enum type.
Inheritance Hierarchy
Object
 | CurveItem
 |  | JapaneseCandleStickItem


JapaneseCandleStickItem Constructor

JapaneseCandleStickItem Constructor
Namespaces ► ZedGraph ► JapaneseCandleStickItem ► JapaneseCandleStickItemJapaneseCandleStickItemNew()()
Members
Icon | Member | Description
 | JapaneseCandleStickItemJapaneseCandleStickItemNew(String) | Create a new OHLCBarItem, specifying only the legend label.
 | JapaneseCandleStickItemJapaneseCandleStickItemNew(String, IPointList) | Create a new JapaneseCandleStickItem using the specified properties.
 | JapaneseCandleStickItemJapaneseCandleStickItemNew(JapaneseCandleStickItem) | The Copy Constructor


JapaneseCandleStickItem Constructor (label)

JapaneseCandleStickItem Constructor (label)
Namespaces ► ZedGraph ► JapaneseCandleStickItem ► JapaneseCandleStickItemJapaneseCandleStickItemNew(String)
Create a new OHLCBarItem, specifying only the legend label.
Declaration Syntax
C# Visual Basic Visual C++
public JapaneseCandleStickItem(
    string label
)
Public Sub New ( _
    label As String _
)
public:
JapaneseCandleStickItem (
    String^ label
)
Parameters
label (String)
The label that will appear in the legend.


JapaneseCandleStickItem Constructor (label, points)

JapaneseCandleStickItem Constructor (label, points)
Namespaces ► ZedGraph ► JapaneseCandleStickItem ► JapaneseCandleStickItemJapaneseCandleStickItemNew(String, IPointList)
Create a new JapaneseCandleStickItem using the specified properties.
Declaration Syntax
C# Visual Basic Visual C++
public JapaneseCandleStickItem(
    string label,
    IPointList points
)
Public Sub New ( _
    label As String, _
    points As IPointList _
)
public:
JapaneseCandleStickItem (
    String^ label,
    IPointList^ points
)
Parameters
label (String)
The label that will appear in the legend.
points (IPointList)
An IPointList of double precision values that define the Date, Close, Open, High, and Low values for the curve. Note that this IPointList should contain StockPt items rather than PointPair items.


JapaneseCandleStickItem Constructor (rhs)

JapaneseCandleStickItem Constructor (rhs)
Namespaces ► ZedGraph ► JapaneseCandleStickItem ► JapaneseCandleStickItemJapaneseCandleStickItemNew(JapaneseCandleStickItem)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public JapaneseCandleStickItem(
    JapaneseCandleStickItem rhs
)
Public Sub New ( _
    rhs As JapaneseCandleStickItem _
)
public:
JapaneseCandleStickItem (
    JapaneseCandleStickItem^ rhs
)
Parameters
rhs (JapaneseCandleStickItem)
The JapaneseCandleStickItem object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► JapaneseCandleStickItem ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public JapaneseCandleStickItem Clone()
Public Function Clone As JapaneseCandleStickItem
public:
JapaneseCandleStickItem^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, pos, scaleFactor)

Draw Method (g, pane, pos, scaleFactor)
Namespaces ► ZedGraph ► JapaneseCandleStickItem ► Draw(Graphics, GraphPane, Int32, Single)
Do all rendering associated with this OHLCBarItem to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object.
Declaration Syntax
C# Visual Basic Visual C++
public override void Draw(
    Graphics g,
    GraphPane pane,
    int pos,
    float scaleFactor
)
Public Overrides Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    pos As Integer, _
    scaleFactor As Single _
)
public:
virtual void Draw (
    Graphics^ g,
    GraphPane^ pane,
    int pos,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
pos (Int32)
The ordinal position of the current OHLCBarItem curve.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


DrawLegendKey Method (g, pane, rect, scaleFactor)

DrawLegendKey Method (g, pane, rect, scaleFactor)
Namespaces ► ZedGraph ► JapaneseCandleStickItem ► DrawLegendKey(Graphics, GraphPane, RectangleF, Single)
Draw a legend key entry for this OHLCBarItem at the specified location
Declaration Syntax
C# Visual Basic Visual C++
public override void DrawLegendKey(
    Graphics g,
    GraphPane pane,
    RectangleF rect,
    float scaleFactor
)
Public Overrides Sub DrawLegendKey ( _
    g As Graphics, _
    pane As GraphPane, _
    rect As RectangleF, _
    scaleFactor As Single _
)
public:
virtual void DrawLegendKey (
    Graphics^ g,
    GraphPane^ pane,
    RectangleF rect,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
rect (RectangleF)
The RectangleF struct that specifies the location for the legend key
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


GetCoords Method (pane, i, coords)

GetCoords Method (pane, i, coords)
Namespaces ► ZedGraph ► JapaneseCandleStickItem ► GetCoords(GraphPane, Int32, String%)
Determine the coords for the rectangle associated with a specified point for this CurveItem
Declaration Syntax
C# Visual Basic Visual C++
public override bool GetCoords(
    GraphPane pane,
    int i,
    out string coords
)
Public Overrides Function GetCoords ( _
    pane As GraphPane, _
    i As Integer, _
    <OutAttribute> ByRef coords As String _
) As Boolean
public:
virtual bool GetCoords (
    GraphPane^ pane,
    int i,
    [OutAttribute] String^% coords
) override
Parameters
pane (GraphPane)
The GraphPane to which this curve belongs
i (Int32)
The index of the point of interest
coords (String %)
A list of coordinates that represents the "rect" for this point (used in an html AREA tag)
Return Value
true if it's a valid point, false otherwise


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► JapaneseCandleStickItem ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► JapaneseCandleStickItem ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


Stick Property

Stick Property
Namespaces ► ZedGraph ► JapaneseCandleStickItem ► Stick
Gets a reference to the JapaneseCandleStick class defined for this JapaneseCandleStickItem.
Declaration Syntax
C# Visual Basic Visual C++
public JapaneseCandleStick Stick{ get;}
Public ReadOnly Property Stick As JapaneseCandleStick
public:
property JapaneseCandleStick^ Stick {
    JapaneseCandleStick^ get ();
}


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► JapaneseCandleStickItem ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Label Class

Label Class
Namespaces ► ZedGraph ► Label
Class that handles the data associated with text title and its associated font properties
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Label : ICloneable, ISerializable
<SerializableAttribute> _
Public Class Label _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class Label : ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LabelLabelNew(String, String, Single, Color, Boolean, Boolean, Boolean) | Constructor to build an AxisLabel from the text and the associated font properties.
 | LabelLabelNew(String, FontSpec) | Constructor that builds a Label from a text String and a FontSpec instance.
 | LabelLabelNew(Label) | Copy constructor
 | Clone()() | Typesafe, deep-copy clone method.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontSpec | A FontSpec instance representing the font properties for the displayed text.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible | Gets or sets a boolean value that determines whether or not this label will be displayed.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | schema | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Text | The String text to be displayed
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Label
 |  | GapLabel


Label Constructor

Label Constructor
Namespaces ► ZedGraph ► Label ► LabelLabelNew()()
Members
Icon | Member | Description
 | LabelLabelNew(String, String, Single, Color, Boolean, Boolean, Boolean) | Constructor to build an AxisLabel from the text and the associated font properties.
 | LabelLabelNew(String, FontSpec) | Constructor that builds a Label from a text String and a FontSpec instance.
 | LabelLabelNew(Label) | Copy constructor


Label Constructor (text, fontFamily, fontSize, color, isBold, isItalic, isUnderline)

Label Constructor (text, fontFamily, fontSize, color, isBold, isItalic, isUnderline)
Namespaces ► ZedGraph ► Label ► LabelLabelNew(String, String, Single, Color, Boolean, Boolean, Boolean)
Constructor to build an AxisLabel from the text and the associated font properties.
Declaration Syntax
C# Visual Basic Visual C++
public Label(
    string text,
    string fontFamily,
    float fontSize,
    Color color,
    bool isBold,
    bool isItalic,
    bool isUnderline
)
Public Sub New ( _
    text As String, _
    fontFamily As String, _
    fontSize As Single, _
    color As Color, _
    isBold As Boolean, _
    isItalic As Boolean, _
    isUnderline As Boolean _
)
public:
Label (
    String^ text,
    String^ fontFamily,
    float fontSize,
    Color color,
    bool isBold,
    bool isItalic,
    bool isUnderline
)
Parameters
text (String)
The String representing the text to be displayed
fontFamily (String)
The String font family name
fontSize (Single)
The size of the font in points and scaled according to the CalcScaleFactor()() logic.
color (Color)
The Color instance representing the color of the font
isBold (Boolean)
true for a bold font face
isItalic (Boolean)
true for an italic font face
isUnderline (Boolean)
true for an underline font face


Label Constructor (text, fontSpec)

Label Constructor (text, fontSpec)
Namespaces ► ZedGraph ► Label ► LabelLabelNew(String, FontSpec)
Constructor that builds a Label from a text String and a FontSpec instance.
Declaration Syntax
C# Visual Basic Visual C++
public Label(
    string text,
    FontSpec fontSpec
)
Public Sub New ( _
    text As String, _
    fontSpec As FontSpec _
)
public:
Label (
    String^ text,
    FontSpec^ fontSpec
)
Parameters
text (String)
fontSpec (FontSpec)


Label Constructor (rhs)

Label Constructor (rhs)
Namespaces ► ZedGraph ► Label ► LabelLabelNew(Label)
Copy constructor
Declaration Syntax
C# Visual Basic Visual C++
public Label(
    Label rhs
)
Public Sub New ( _
    rhs As Label _
)
public:
Label (
    Label^ rhs
)
Parameters
rhs (Label)
the Label instance to be copied.


Clone Method

Clone Method
Namespaces ► ZedGraph ► Label ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public Label Clone()
Public Function Clone As Label
public:
Label^ Clone ()
Return Value
A new, independent copy of this class


FontSpec Property

FontSpec Property
Namespaces ► ZedGraph ► Label ► FontSpec
A FontSpec instance representing the font properties for the displayed text.
Declaration Syntax
C# Visual Basic Visual C++
public FontSpec FontSpec{ get; set;}
Public Property FontSpec As FontSpec
public:
property FontSpec^ FontSpec {
    FontSpec^ get ();
    void set (FontSpec^ value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► Label ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph ► Label ► IsVisible
Gets or sets a boolean value that determines whether or not this label will be displayed.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}


schema Field

schema Field
Namespaces ► ZedGraph ► Label ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► Label ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Text Property

Text Property
Namespaces ► ZedGraph ► Label ► Text
The String text to be displayed
Declaration Syntax
C# Visual Basic Visual C++
public string Text{ get; set;}
Public Property Text As String
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}


Legend Class

Legend Class
Namespaces ► ZedGraph ► Legend
This class encapsulates the chart Legend that is displayed in the GraphPane
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Legend : ICloneable, ISerializable
<SerializableAttribute> _
Public Class Legend _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class Legend : ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LegendLegendNew()() | Default constructor that sets all Legend properties to default values as defined in the Legend..::Default class.
 | LegendLegendNew(Legend) | The Copy Constructor
 | Border | The Border class used to draw the border border around this Legend.
 | CalcRect(Graphics, PaneBase, Single, RectangleF%) | Calculate the Legend rectangle (Rect), taking into account the number of required legend entries, and the legend drawing preferences.
 | Clone()() | Typesafe, deep-copy clone method.
 | Draw(Graphics, PaneBase, Single) | Render the Legend to the specified Graphics device.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Gets or sets the Fill data for this Legend background.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindPoint(PointF, PaneBase, Single, Int32%) | Determine if a mouse point is within the legend, and if so, which legend entry (CurveItem) is nearest.
 | FontSpec | Access to the FontSpec class used to render the Legend entries
 | Gap | Gets or sets the gap size between the legend and the Rect.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsHStack | Sets or gets a property that allows the Legend items to stack horizontally in addition to the vertical stacking
 | IsReverse | Gets or sets a value that determines if the legend entries are displayed in normal order (matching the order in the CurveList, or in reverse order.
 | IsShowLegendSymbols | Gets or sets a value that determines whether the line and symbol keys will be displayed in the legend.
 | IsVisible | Gets or sets a property that shows or hides the Legend entirely
 | Location | Gets or sets the Location data for the Legend. This property is only applicable if Position is set to Float.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | Sets or gets the location of the Legend on the GraphPane using the LegendPos enum type
 | Rect | Get the bounding rectangle for the Legend in screen coordinates
 | schema | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Legend


Legend Constructor

Legend Constructor
Namespaces ► ZedGraph ► Legend ► LegendLegendNew()()
Members
Icon | Member | Description
 | LegendLegendNew()() | Default constructor that sets all Legend properties to default values as defined in the Legend..::Default class.
 | LegendLegendNew(Legend) | The Copy Constructor


Legend Constructor

Legend Constructor
Namespaces ► ZedGraph ► Legend ► LegendLegendNew()()
Default constructor that sets all Legend properties to default values as defined in the Legend..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public Legend()
Public Sub New
public:
Legend ()


Legend Constructor (rhs)

Legend Constructor (rhs)
Namespaces ► ZedGraph ► Legend ► LegendLegendNew(Legend)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public Legend(
    Legend rhs
)
Public Sub New ( _
    rhs As Legend _
)
public:
Legend (
    Legend^ rhs
)
Parameters
rhs (Legend)
The XAxis object from which to copy


Border Property

Border Property
Namespaces ► ZedGraph ► Legend ► Border
The Border class used to draw the border border around this Legend.
Declaration Syntax
C# Visual Basic Visual C++
public Border Border{ get; set;}
Public Property Border As Border
public:
property Border^ Border {
    Border^ get ();
    void set (Border^ value);
}


CalcRect Method (g, pane, scaleFactor, tChartRect)

CalcRect Method (g, pane, scaleFactor, tChartRect)
Namespaces ► ZedGraph ► Legend ► CalcRect(Graphics, PaneBase, Single, RectangleF%)
Calculate the Legend rectangle (Rect), taking into account the number of required legend entries, and the legend drawing preferences.
Declaration Syntax
C# Visual Basic Visual C++
public void CalcRect(
    Graphics g,
    PaneBase pane,
    float scaleFactor,
    ref RectangleF tChartRect
)
Public Sub CalcRect ( _
    g As Graphics, _
    pane As PaneBase, _
    scaleFactor As Single, _
    ByRef tChartRect As RectangleF _
)
public:
void CalcRect (
    Graphics^ g,
    PaneBase^ pane,
    float scaleFactor,
    RectangleF% tChartRect
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
tChartRect (RectangleF %)
The rectangle that contains the area bounded by the axes, in pixel units. Rect
Remarks
Adjust the size of the Rect for the parent GraphPane to accomodate the space required by the legend.


Clone Method

Clone Method
Namespaces ► ZedGraph ► Legend ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public Legend Clone()
Public Function Clone As Legend
public:
Legend^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, scaleFactor)

Draw Method (g, pane, scaleFactor)
Namespaces ► ZedGraph ► Legend ► Draw(Graphics, PaneBase, Single)
Render the Legend to the specified Graphics device.
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    PaneBase pane,
    float scaleFactor
)
Public Sub Draw ( _
    g As Graphics, _
    pane As PaneBase, _
    scaleFactor As Single _
)
public:
void Draw (
    Graphics^ g,
    PaneBase^ pane,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Remarks
This method is normally only called by the Draw method of the parent GraphPane object.


Fill Property

Fill Property
Namespaces ► ZedGraph ► Legend ► Fill
Gets or sets the Fill data for this Legend background.
Declaration Syntax
C# Visual Basic Visual C++
public Fill Fill{ get; set;}
Public Property Fill As Fill
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}


FindPoint Method (mousePt, pane, scaleFactor, index)

FindPoint Method (mousePt, pane, scaleFactor, index)
Namespaces ► ZedGraph ► Legend ► FindPoint(PointF, PaneBase, Single, Int32%)
Determine if a mouse point is within the legend, and if so, which legend entry (CurveItem) is nearest.
Declaration Syntax
C# Visual Basic Visual C++
public bool FindPoint(
    PointF mousePt,
    PaneBase pane,
    float scaleFactor,
    out int index
)
Public Function FindPoint ( _
    mousePt As PointF, _
    pane As PaneBase, _
    scaleFactor As Single, _
    <OutAttribute> ByRef index As Integer _
) As Boolean
public:
bool FindPoint (
    PointF mousePt,
    PaneBase^ pane,
    float scaleFactor,
    [OutAttribute] int% index
)
Parameters
mousePt (PointF)
The screen point, in pixel coordinates.
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
index (Int32 %)
The index number of the CurveItem legend entry that is under the mouse point. The CurveItem object is accessible via CurveList[index].
Return Value
true if the mouse point is within the Legend bounding box, false otherwise.
See Also
FindNearestObject(PointF, Graphics, Object%, Int32%)


FontSpec Property

FontSpec Property
Namespaces ► ZedGraph ► Legend ► FontSpec
Access to the FontSpec class used to render the Legend entries
Declaration Syntax
C# Visual Basic Visual C++
public FontSpec FontSpec{ get; set;}
Public Property FontSpec As FontSpec
public:
property FontSpec^ FontSpec {
    FontSpec^ get ();
    void set (FontSpec^ value);
}
Value
A reference to a Legend object
See Also
FontColor
FontBold
FontItalic
FontUnderline
FontFamily
FontSize


Gap Property

Gap Property
Namespaces ► ZedGraph ► Legend ► Gap
Gets or sets the gap size between the legend and the Rect.
Declaration Syntax
C# Visual Basic Visual C++
public float Gap{ get; set;}
Public Property Gap As Single
public:
property float Gap {
    float get ();
    void set (float value);
}
Remarks
This is expressed as a fraction of the largest scaled character height for any of the fonts used in the legend. Each CurveItem in the legend can optionally have its own FontSpec specification.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► Legend ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsHStack Property

IsHStack Property
Namespaces ► ZedGraph ► Legend ► IsHStack
Sets or gets a property that allows the Legend items to stack horizontally in addition to the vertical stacking
Declaration Syntax
C# Visual Basic Visual C++
public bool IsHStack{ get; set;}
Public Property IsHStack As Boolean
public:
property bool IsHStack {
    bool get ();
    void set (bool value);
}
Value
true to allow horizontal stacking, false otherwise
See Also
IsHStack


IsReverse Property

IsReverse Property
Namespaces ► ZedGraph ► Legend ► IsReverse
Gets or sets a value that determines if the legend entries are displayed in normal order (matching the order in the CurveList, or in reverse order.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReverse{ get; set;}
Public Property IsReverse As Boolean
public:
property bool IsReverse {
    bool get ();
    void set (bool value);
}


IsShowLegendSymbols Property

IsShowLegendSymbols Property
Namespaces ► ZedGraph ► Legend ► IsShowLegendSymbols
Gets or sets a value that determines whether the line and symbol keys will be displayed in the legend.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsShowLegendSymbols{ get; set;}
Public Property IsShowLegendSymbols As Boolean
public:
property bool IsShowLegendSymbols {
    bool get ();
    void set (bool value);
}
Remarks
Note: If this value is set to false (so that only the curve label text is displayed with no legend keys), then the color of the font for the legend entry of each curve will automatically be set to match the Color setting for that curve. You can override this behavior by specifying a specific font to be used for each individual curve with the CurveItem.Label.FontSpec property.


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph ► Legend ► IsVisible
Gets or sets a property that shows or hides the Legend entirely
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
Value
true to show the Legend, false to hide it
See Also
IsVisible


Location Property

Location Property
Namespaces ► ZedGraph ► Legend ► Location
Gets or sets the Location data for the Legend. This property is only applicable if Position is set to Float.
Declaration Syntax
C# Visual Basic Visual C++
public Location Location{ get; set;}
Public Property Location As Location
public:
property Location^ Location {
    Location^ get ();
    void set (Location^ value);
}


Position Property

Position Property
Namespaces ► ZedGraph ► Legend ► Position
Sets or gets the location of the Legend on the GraphPane using the LegendPos enum type
Declaration Syntax
C# Visual Basic Visual C++
public LegendPos Position{ get; set;}
Public Property Position As LegendPos
public:
property LegendPos Position {
    LegendPos get ();
    void set (LegendPos value);
}
See Also
Position


Rect Property

Rect Property
Namespaces ► ZedGraph ► Legend ► Rect
Get the bounding rectangle for the Legend in screen coordinates
Declaration Syntax
C# Visual Basic Visual C++
public RectangleF Rect{ get;}
Public ReadOnly Property Rect As RectangleF
public:
property RectangleF Rect {
    RectangleF get ();
}
Value
A screen rectangle in pixel units


schema Field

schema Field
Namespaces ► ZedGraph ► Legend ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► Legend ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Legend.Default Structure

Legend..::Default Structure
Namespaces ► ZedGraph ► Legend ► Legend..::Default
A simple struct that defines the default property values for the Legend class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BorderColor | The default color for the Legend border border. (Color property).
 | BorderWidth | The default pen width for the Legend border border. (Width property). Units are in pixels.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | FillBrush | The default custom brush for filling in this Legend.
 | FillColor | The default color for the Legend background. (Color property). Use of this color depends on the status of the Type property.
 | FillType | The default fill mode for the Legend background.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontBold | The default font bold mode for the Legend entries (IsBold property). true for a bold typeface, false otherwise.
 | FontColor | The default font color for the Legend entries (FontColor property).
 | FontFamily | The default font family for the Legend entries (Family property).
 | FontFillBrush | The default custom brush for filling in the scale text background (see Brush property).
 | FontFillColor | The default color for filling in the scale text background (see Color property).
 | FontFillType | The default fill mode for filling in the scale text background (see Type property).
 | FontItalic | The default font italic mode for the Legend entries (IsItalic property). true for an italic typeface, false otherwise.
 | FontSize | The default font size for the Legend entries (Size property). Units are in points (1/72 inch).
 | FontUnderline | The default font underline mode for the Legend entries (IsUnderline property). true for an underlined typeface, false otherwise.
 | Gap | The default gap size between the legend and the Rect. This is the default value of Gap.
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsBorderVisible | The default border mode for the Legend. (IsVisible property). true to draw a border around the Rect, false otherwise.
 | IsFilled | The default fill mode for the Legend background (Type property). true to fill-in the background with color, false to leave the background transparent.
 | IsHStack | The default horizontal stacking mode for the Legend (IsHStack property). true to allow horizontal legend item stacking, false to allow only vertical legend orientation.
 | IsReverse | Default value for the IsReverse property.
 | IsShowLegendSymbols | Default value for the IsShowLegendSymbols property.
 | IsVisible | The default display mode for the Legend. (IsVisible property). true to show the legend, false to hide it.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | The default location for the Legend on the graph (Location property). This property is defined as a LegendPos enumeration.
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


BorderColor Field

BorderColor Field
Namespaces ► ZedGraph ► Legend..::Default ► BorderColor
The default color for the Legend border border. (Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color BorderColor
Public Shared BorderColor As Color
public:
static Color BorderColor


BorderWidth Field

BorderWidth Field
Namespaces ► ZedGraph ► Legend..::Default ► BorderWidth
The default pen width for the Legend border border. (Width property). Units are in pixels.
Declaration Syntax
C# Visual Basic Visual C++
public static float BorderWidth
Public Shared BorderWidth As Single
public:
static float BorderWidth


FillBrush Field

FillBrush Field
Namespaces ► ZedGraph ► Legend..::Default ► FillBrush
The default custom brush for filling in this Legend.
Declaration Syntax
C# Visual Basic Visual C++
public static Brush FillBrush
Public Shared FillBrush As Brush
public:
static Brush^ FillBrush


FillColor Field

FillColor Field
Namespaces ► ZedGraph ► Legend..::Default ► FillColor
The default color for the Legend background. (Color property). Use of this color depends on the status of the Type property.
Declaration Syntax
C# Visual Basic Visual C++
public static Color FillColor
Public Shared FillColor As Color
public:
static Color FillColor


FillType Field

FillType Field
Namespaces ► ZedGraph ► Legend..::Default ► FillType
The default fill mode for the Legend background.
Declaration Syntax
C# Visual Basic Visual C++
public static FillType FillType
Public Shared FillType As FillType
public:
static FillType FillType


FontBold Field

FontBold Field
Namespaces ► ZedGraph ► Legend..::Default ► FontBold
The default font bold mode for the Legend entries (IsBold property). true for a bold typeface, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool FontBold
Public Shared FontBold As Boolean
public:
static bool FontBold


FontColor Field

FontColor Field
Namespaces ► ZedGraph ► Legend..::Default ► FontColor
The default font color for the Legend entries (FontColor property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color FontColor
Public Shared FontColor As Color
public:
static Color FontColor


FontFamily Field

FontFamily Field
Namespaces ► ZedGraph ► Legend..::Default ► FontFamily
The default font family for the Legend entries (Family property).
Declaration Syntax
C# Visual Basic Visual C++
public static string FontFamily
Public Shared FontFamily As String
public:
static String^ FontFamily


FontFillBrush Field

FontFillBrush Field
Namespaces ► ZedGraph ► Legend..::Default ► FontFillBrush
The default custom brush for filling in the scale text background (see Brush property).
Declaration Syntax
C# Visual Basic Visual C++
public static Brush FontFillBrush
Public Shared FontFillBrush As Brush
public:
static Brush^ FontFillBrush


FontFillColor Field

FontFillColor Field
Namespaces ► ZedGraph ► Legend..::Default ► FontFillColor
The default color for filling in the scale text background (see Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color FontFillColor
Public Shared FontFillColor As Color
public:
static Color FontFillColor


FontFillType Field

FontFillType Field
Namespaces ► ZedGraph ► Legend..::Default ► FontFillType
The default fill mode for filling in the scale text background (see Type property).
Declaration Syntax
C# Visual Basic Visual C++
public static FillType FontFillType
Public Shared FontFillType As FillType
public:
static FillType FontFillType


FontItalic Field

FontItalic Field
Namespaces ► ZedGraph ► Legend..::Default ► FontItalic
The default font italic mode for the Legend entries (IsItalic property). true for an italic typeface, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool FontItalic
Public Shared FontItalic As Boolean
public:
static bool FontItalic


FontSize Field

FontSize Field
Namespaces ► ZedGraph ► Legend..::Default ► FontSize
The default font size for the Legend entries (Size property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float FontSize
Public Shared FontSize As Single
public:
static float FontSize


FontUnderline Field

FontUnderline Field
Namespaces ► ZedGraph ► Legend..::Default ► FontUnderline
The default font underline mode for the Legend entries (IsUnderline property). true for an underlined typeface, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool FontUnderline
Public Shared FontUnderline As Boolean
public:
static bool FontUnderline


Gap Field

Gap Field
Namespaces ► ZedGraph ► Legend..::Default ► Gap
The default gap size between the legend and the Rect. This is the default value of Gap.
Declaration Syntax
C# Visual Basic Visual C++
public static float Gap
Public Shared Gap As Single
public:
static float Gap


IsBorderVisible Field

IsBorderVisible Field
Namespaces ► ZedGraph ► Legend..::Default ► IsBorderVisible
The default border mode for the Legend. (IsVisible property). true to draw a border around the Rect, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsBorderVisible
Public Shared IsBorderVisible As Boolean
public:
static bool IsBorderVisible


IsFilled Field

IsFilled Field
Namespaces ► ZedGraph ► Legend..::Default ► IsFilled
The default fill mode for the Legend background (Type property). true to fill-in the background with color, false to leave the background transparent.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsFilled
Public Shared IsFilled As Boolean
public:
static bool IsFilled


IsHStack Field

IsHStack Field
Namespaces ► ZedGraph ► Legend..::Default ► IsHStack
The default horizontal stacking mode for the Legend (IsHStack property). true to allow horizontal legend item stacking, false to allow only vertical legend orientation.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsHStack
Public Shared IsHStack As Boolean
public:
static bool IsHStack


IsReverse Field

IsReverse Field
Namespaces ► ZedGraph ► Legend..::Default ► IsReverse
Default value for the IsReverse property.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsReverse
Public Shared IsReverse As Boolean
public:
static bool IsReverse


IsShowLegendSymbols Field

IsShowLegendSymbols Field
Namespaces ► ZedGraph ► Legend..::Default ► IsShowLegendSymbols
Default value for the IsShowLegendSymbols property.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsShowLegendSymbols
Public Shared IsShowLegendSymbols As Boolean
public:
static bool IsShowLegendSymbols


IsVisible Field

IsVisible Field
Namespaces ► ZedGraph ► Legend..::Default ► IsVisible
The default display mode for the Legend. (IsVisible property). true to show the legend, false to hide it.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsVisible
Public Shared IsVisible As Boolean
public:
static bool IsVisible


Position Field

Position Field
Namespaces ► ZedGraph ► Legend..::Default ► Position
The default location for the Legend on the graph (Location property). This property is defined as a LegendPos enumeration.
Declaration Syntax
C# Visual Basic Visual C++
public static LegendPos Position
Public Shared Position As LegendPos
public:
static LegendPos Position


LegendPos Enumeration

LegendPos Enumeration
Namespaces ► ZedGraph ► LegendPos
Enumeration type that defines the possible legend locations
Declaration Syntax
C# Visual Basic Visual C++
public enum LegendPos
Public Enumeration LegendPos
public enum class LegendPos
Members
Member | Description
Top | Locate the Legend above the Rect
Left | Locate the Legend on the left side of the Rect
Right | Locate the Legend on the right side of the Rect
Bottom | Locate the Legend below the Rect
InsideTopLeft | Locate the Legend inside the Rect in the top-left corner.
InsideTopRight | Locate the Legend inside the Rect in the top-right corner.
InsideBotLeft | Locate the Legend inside the Rect in the bottom-left corner.
InsideBotRight | Locate the Legend inside the Rect in the bottom-right corner.
Float | Locate the Legend as a floating object above the graph at the location specified by Location.
TopCenter | Locate the Legend centered above the Rect
BottomCenter | Locate the Legend centered below the Rect
TopFlushLeft | Locate the Legend above the Rect, but flush against the left margin of the Rect.
BottomFlushLeft | Locate the Legend below the Rect, but flush against the left margin of the Rect.
See Also
Position


Line Class

Line Class
Namespaces ► ZedGraph ► Line
A class representing all the characteristics of the Line segments that make up a curve on the graph.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Line : LineBase, ICloneable, ISerializable
<SerializableAttribute> _
Public Class Line _
    Inherits LineBase _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class Line : public LineBase,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LineLineNew()() | Default constructor that sets all Line properties to default values as defined in the Line..::Default class.
 | LineLineNew(Color) | Constructor that sets the color property to the specified value, and sets the remaining Line properties to default values as defined in the Line..::Default class.
 | LineLineNew(Line) | The Copy Constructor
 | BuildLowPointsArray(GraphPane, CurveItem, array<PointF>[]()%, Int32%) | Build an array of PointF values (pixel coordinates) that represents the low values for the current curve.
 | BuildPointsArray(GraphPane, CurveItem, array<PointF>[]()%, Int32%) | Build an array of PointF values (pixel coordinates) that represents the current curve. Note that this drawing routine ignores Missing values, but it does not "break" the line to indicate values are missing.
 | Clone()() | Typesafe, deep-copy clone method.
 | CloseCurve(GraphPane, CurveItem, array<PointF>[](), Int32, Double, GraphicsPath) | Close off a GraphicsPath that defines a curve
 | Color | The color of the Line. Note that this color value can be overridden if the GradientFill.Type is one of the GradientByX, GradientByY, GradientByZ, and GradientByColorValue types. (Inherited from LineBase.)
 | DashOff | The "Dash Off" mode for drawing the line. (Inherited from LineBase.)
 | DashOn | The "Dash On" mode for drawing the line. (Inherited from LineBase.)
 | Draw(Graphics, GraphPane, CurveItem, Single) | Do all rendering associated with this Line to the specified Graphics device. This method is normally only called by the Draw method of the parent LineItem object.
 | DrawCurve(Graphics, GraphPane, CurveItem, Single) | Draw the this CurveItem to the specified Graphics device. The format (stair-step or line) of the curve is defined by the StepType property. The routine only draws the line segments; the symbols are drawn by the Draw(Graphics, GraphPane, LineItem, Single, Boolean) method. This method is normally only called by the Draw method of the CurveItem object
 | DrawCurveOriginal(Graphics, GraphPane, CurveItem, Single) | Draw the this CurveItem to the specified Graphics device. The format (stair-step or line) of the curve is defined by the StepType property. The routine only draws the line segments; the symbols are drawn by the Draw(Graphics, GraphPane, LineItem, Single, Boolean) method. This method is normally only called by the Draw method of the CurveItem object
 | DrawSegment(Graphics, GraphPane, Single, Single, Single, Single, Single) | Render a single Line segment to the specified Graphics device.
 | DrawSmoothFilledCurve(Graphics, GraphPane, CurveItem, Single) | Draw the this CurveItem to the specified Graphics device using the specified smoothing property (SmoothTension). The routine draws the line segments and the area fill (if any, see FillType; the symbols are drawn by the Draw(Graphics, GraphPane, LineItem, Single, Boolean) method. This method is normally only called by the Draw method of the CurveItem object. Note that the StepType property is ignored for smooth lines (e.g., when IsSmooth is true).
 | DrawSticks(Graphics, GraphPane, CurveItem, Single) | Render the Line's as vertical sticks (from a StickItem) to the specified Graphics device.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Gets or sets the Fill data for this Line.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides LineBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetPen(PaneBase, Single) | Create a Pen object based on the properties of this LineBase. (Inherited from LineBase.)
 | GetPen(PaneBase, Single, PointPair) | Create a Pen object based on the properties of this LineBase. (Inherited from LineBase.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GradientFill | Gets or sets a custom Fill class. (Inherited from LineBase.)
 | IsAntiAlias | Gets or sets a value that determines if the lines are drawn using Anti-Aliasing capabilities from the Graphics class. (Inherited from LineBase.)
 | IsOptimizedDraw | Gets or sets a boolean value that determines if this Line will be drawn with optimizations enabled.
 | IsSmooth | Gets or sets a property that determines if this Line will be drawn smooth. The "smoothness" is controlled by the SmoothTension property.
 | IsVisible | Gets or sets a property that shows or hides the Line. (Inherited from LineBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | schema | Current schema value that defines the version of the serialized file
 | SmoothTension | Gets or sets a property that determines the smoothing tension for this Line. This property is only used if IsSmooth is true. A tension value 0.0 will just draw ordinary line segments like an unsmoothed line. A tension value of 1.0 will be smooth. Values greater than 1.0 will generally give odd results.
 | StepType | Determines if the CurveItem will be drawn by directly connecting the points from the Points data collection, or if the curve will be a "stair-step" in which the points are connected by a series of horizontal and vertical lines that represent discrete, constant values. Note that the values can be forward oriented ForwardStep (StepType) or rearward oriented RearwardStep. That is, the points are defined at the beginning or end of the constant value for which they apply, respectively. The StepType property is ignored for lines that have IsSmooth set to true.
 | Style | The style of the Line, defined as a DashStyle enum. This allows the line to be solid, dashed, or dotted. (Inherited from LineBase.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Width | The pen width used to draw the Line, in points (1/72 inch) (Inherited from LineBase.)
Inheritance Hierarchy
Object
 | LineBase
 |  | Line


Line Constructor

Line Constructor
Namespaces ► ZedGraph ► Line ► LineLineNew()()
Members
Icon | Member | Description
 | LineLineNew()() | Default constructor that sets all Line properties to default values as defined in the Line..::Default class.
 | LineLineNew(Color) | Constructor that sets the color property to the specified value, and sets the remaining Line properties to default values as defined in the Line..::Default class.
 | LineLineNew(Line) | The Copy Constructor


Line Constructor

Line Constructor
Namespaces ► ZedGraph ► Line ► LineLineNew()()
Default constructor that sets all Line properties to default values as defined in the Line..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public Line()
Public Sub New
public:
Line ()


Line Constructor (color)

Line Constructor (color)
Namespaces ► ZedGraph ► Line ► LineLineNew(Color)
Constructor that sets the color property to the specified value, and sets the remaining Line properties to default values as defined in the Line..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public Line(
    Color color
)
Public Sub New ( _
    color As Color _
)
public:
Line (
    Color color
)
Parameters
color (Color)
The color to assign to this new Line object


Line Constructor (rhs)

Line Constructor (rhs)
Namespaces ► ZedGraph ► Line ► LineLineNew(Line)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public Line(
    Line rhs
)
Public Sub New ( _
    rhs As Line _
)
public:
Line (
    Line^ rhs
)
Parameters
rhs (Line)
The Line object from which to copy


BuildLowPointsArray Method (pane, curve, arrPoints, count)

BuildLowPointsArray Method (pane, curve, arrPoints, count)
Namespaces ► ZedGraph ► Line ► BuildLowPointsArray(GraphPane, CurveItem, array<PointF>[]()%, Int32%)
Build an array of PointF values (pixel coordinates) that represents the low values for the current curve.
Declaration Syntax
C# Visual Basic Visual C++
public bool BuildLowPointsArray(
    GraphPane pane,
    CurveItem curve,
    out PointF[] arrPoints,
    out int count
)
Public Function BuildLowPointsArray ( _
    pane As GraphPane, _
    curve As CurveItem, _
    <OutAttribute> ByRef arrPoints As PointF(), _
    <OutAttribute> ByRef count As Integer _
) As Boolean
public:
bool BuildLowPointsArray (
    GraphPane^ pane,
    CurveItem^ curve,
    [OutAttribute] array<PointF>^% arrPoints,
    [OutAttribute] int% count
)
Parameters
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
curve (CurveItem)
A LineItem representing this curve.
arrPoints (array< PointF >[]()%)
An array of PointF values in pixel coordinates representing the current curve.
count (Int32 %)
The number of points contained in the "arrPoints" parameter.
Return Value
true for a successful points array build, false for data problems
Remarks
Note that this drawing routine ignores Missing values, but it does not "break" the line to indicate values are missing.


BuildPointsArray Method (pane, curve, arrPoints, count)

BuildPointsArray Method (pane, curve, arrPoints, count)
Namespaces ► ZedGraph ► Line ► BuildPointsArray(GraphPane, CurveItem, array<PointF>[]()%, Int32%)
Build an array of PointF values (pixel coordinates) that represents the current curve. Note that this drawing routine ignores Missing values, but it does not "break" the line to indicate values are missing.
Declaration Syntax
C# Visual Basic Visual C++
public bool BuildPointsArray(
    GraphPane pane,
    CurveItem curve,
    out PointF[] arrPoints,
    out int count
)
Public Function BuildPointsArray ( _
    pane As GraphPane, _
    curve As CurveItem, _
    <OutAttribute> ByRef arrPoints As PointF(), _
    <OutAttribute> ByRef count As Integer _
) As Boolean
public:
bool BuildPointsArray (
    GraphPane^ pane,
    CurveItem^ curve,
    [OutAttribute] array<PointF>^% arrPoints,
    [OutAttribute] int% count
)
Parameters
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
curve (CurveItem)
A LineItem representing this curve.
arrPoints (array< PointF >[]()%)
An array of PointF values in pixel coordinates representing the current curve.
count (Int32 %)
The number of points contained in the "arrPoints" parameter.
Return Value
true for a successful points array build, false for data problems


Clone Method

Clone Method
Namespaces ► ZedGraph ► Line ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public Line Clone()
Public Function Clone As Line
public:
Line^ Clone ()
Return Value
A new, independent copy of this class


CloseCurve Method (pane, curve, arrPoints, count, yMin, path)

CloseCurve Method (pane, curve, arrPoints, count, yMin, path)
Namespaces ► ZedGraph ► Line ► CloseCurve(GraphPane, CurveItem, array<PointF>[](), Int32, Double, GraphicsPath)
Close off a GraphicsPath that defines a curve
Declaration Syntax
C# Visual Basic Visual C++
public void CloseCurve(
    GraphPane pane,
    CurveItem curve,
    PointF[] arrPoints,
    int count,
    double yMin,
    GraphicsPath path
)
Public Sub CloseCurve ( _
    pane As GraphPane, _
    curve As CurveItem, _
    arrPoints As PointF(), _
    count As Integer, _
    yMin As Double, _
    path As GraphicsPath _
)
public:
void CloseCurve (
    GraphPane^ pane,
    CurveItem^ curve,
    array<PointF>^ arrPoints,
    int count,
    double yMin,
    GraphicsPath^ path
)
Parameters
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
curve (CurveItem)
A LineItem representing this curve.
arrPoints (array< PointF >[]())
An array of PointF values in screen pixel coordinates representing the current curve.
count (Int32)
The number of points contained in the "arrPoints" parameter.
yMin (Double)
The Y axis value location where the X axis crosses.
path (GraphicsPath)
The GraphicsPath class that represents the curve.


Draw Method (g, pane, curve, scaleFactor)

Draw Method (g, pane, curve, scaleFactor)
Namespaces ► ZedGraph ► Line ► Draw(Graphics, GraphPane, CurveItem, Single)
Do all rendering associated with this Line to the specified Graphics device. This method is normally only called by the Draw method of the parent LineItem object.
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    GraphPane pane,
    CurveItem curve,
    float scaleFactor
)
Public Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    curve As CurveItem, _
    scaleFactor As Single _
)
public:
void Draw (
    Graphics^ g,
    GraphPane^ pane,
    CurveItem^ curve,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
curve (CurveItem)
A LineItem representing this curve.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


DrawCurve Method (g, pane, curve, scaleFactor)

DrawCurve Method (g, pane, curve, scaleFactor)
Namespaces ► ZedGraph ► Line ► DrawCurve(Graphics, GraphPane, CurveItem, Single)
Draw the this CurveItem to the specified Graphics device. The format (stair-step or line) of the curve is defined by the StepType property. The routine only draws the line segments; the symbols are drawn by the Draw(Graphics, GraphPane, LineItem, Single, Boolean) method. This method is normally only called by the Draw method of the CurveItem object
Declaration Syntax
C# Visual Basic Visual C++
public void DrawCurve(
    Graphics g,
    GraphPane pane,
    CurveItem curve,
    float scaleFactor
)
Public Sub DrawCurve ( _
    g As Graphics, _
    pane As GraphPane, _
    curve As CurveItem, _
    scaleFactor As Single _
)
public:
void DrawCurve (
    Graphics^ g,
    GraphPane^ pane,
    CurveItem^ curve,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
curve (CurveItem)
A LineItem representing this curve.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


DrawCurveOriginal Method (g, pane, curve, scaleFactor)

DrawCurveOriginal Method (g, pane, curve, scaleFactor)
Namespaces ► ZedGraph ► Line ► DrawCurveOriginal(Graphics, GraphPane, CurveItem, Single)
Draw the this CurveItem to the specified Graphics device. The format (stair-step or line) of the curve is defined by the StepType property. The routine only draws the line segments; the symbols are drawn by the Draw(Graphics, GraphPane, LineItem, Single, Boolean) method. This method is normally only called by the Draw method of the CurveItem object
Declaration Syntax
C# Visual Basic Visual C++
public void DrawCurveOriginal(
    Graphics g,
    GraphPane pane,
    CurveItem curve,
    float scaleFactor
)
Public Sub DrawCurveOriginal ( _
    g As Graphics, _
    pane As GraphPane, _
    curve As CurveItem, _
    scaleFactor As Single _
)
public:
void DrawCurveOriginal (
    Graphics^ g,
    GraphPane^ pane,
    CurveItem^ curve,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
curve (CurveItem)
A LineItem representing this curve.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


DrawSegment Method (g, pane, x1, y1, x2, y2, scaleFactor)

DrawSegment Method (g, pane, x1, y1, x2, y2, scaleFactor)
Namespaces ► ZedGraph ► Line ► DrawSegment(Graphics, GraphPane, Single, Single, Single, Single, Single)
Render a single Line segment to the specified Graphics device.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawSegment(
    Graphics g,
    GraphPane pane,
    float x1,
    float y1,
    float x2,
    float y2,
    float scaleFactor
)
Public Sub DrawSegment ( _
    g As Graphics, _
    pane As GraphPane, _
    x1 As Single, _
    y1 As Single, _
    x2 As Single, _
    y2 As Single, _
    scaleFactor As Single _
)
public:
void DrawSegment (
    Graphics^ g,
    GraphPane^ pane,
    float x1,
    float y1,
    float x2,
    float y2,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
x1 (Single)
The x position of the starting point that defines the line segment in screen pixel units
y1 (Single)
The y position of the starting point that defines the line segment in screen pixel units
x2 (Single)
The x position of the ending point that defines the line segment in screen pixel units
y2 (Single)
The y position of the ending point that defines the line segment in screen pixel units
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


DrawSmoothFilledCurve Method (g, pane, curve, scaleFactor)

DrawSmoothFilledCurve Method (g, pane, curve, scaleFactor)
Namespaces ► ZedGraph ► Line ► DrawSmoothFilledCurve(Graphics, GraphPane, CurveItem, Single)
Draw the this CurveItem to the specified Graphics device using the specified smoothing property (SmoothTension). The routine draws the line segments and the area fill (if any, see FillType; the symbols are drawn by the Draw(Graphics, GraphPane, LineItem, Single, Boolean) method. This method is normally only called by the Draw method of the CurveItem object. Note that the StepType property is ignored for smooth lines (e.g., when IsSmooth is true).
Declaration Syntax
C# Visual Basic Visual C++
public void DrawSmoothFilledCurve(
    Graphics g,
    GraphPane pane,
    CurveItem curve,
    float scaleFactor
)
Public Sub DrawSmoothFilledCurve ( _
    g As Graphics, _
    pane As GraphPane, _
    curve As CurveItem, _
    scaleFactor As Single _
)
public:
void DrawSmoothFilledCurve (
    Graphics^ g,
    GraphPane^ pane,
    CurveItem^ curve,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
curve (CurveItem)
A LineItem representing this curve.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


DrawSticks Method (g, pane, curve, scaleFactor)

DrawSticks Method (g, pane, curve, scaleFactor)
Namespaces ► ZedGraph ► Line ► DrawSticks(Graphics, GraphPane, CurveItem, Single)
Render the Line's as vertical sticks (from a StickItem) to the specified Graphics device.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawSticks(
    Graphics g,
    GraphPane pane,
    CurveItem curve,
    float scaleFactor
)
Public Sub DrawSticks ( _
    g As Graphics, _
    pane As GraphPane, _
    curve As CurveItem, _
    scaleFactor As Single _
)
public:
void DrawSticks (
    Graphics^ g,
    GraphPane^ pane,
    CurveItem^ curve,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
curve (CurveItem)
A CurveItem representing this curve.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


Fill Property

Fill Property
Namespaces ► ZedGraph ► Line ► Fill
Gets or sets the Fill data for this Line.
Declaration Syntax
C# Visual Basic Visual C++
public Fill Fill{ get; set;}
Public Property Fill As Fill
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► Line ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsOptimizedDraw Property

IsOptimizedDraw Property
Namespaces ► ZedGraph ► Line ► IsOptimizedDraw
Gets or sets a boolean value that determines if this Line will be drawn with optimizations enabled.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOptimizedDraw{ get; set;}
Public Property IsOptimizedDraw As Boolean
public:
property bool IsOptimizedDraw {
    bool get ();
    void set (bool value);
}
Remarks
Normally, the optimizations can be used without a problem, and they are particularly helpful with very large datasets. However, if the data are very discontinuous, then the optimizations can cause drawing artifacts in the form of missing line segments. This is generally very unlikely to happen, so the default value is true.


IsSmooth Property

IsSmooth Property
Namespaces ► ZedGraph ► Line ► IsSmooth
Gets or sets a property that determines if this Line will be drawn smooth. The "smoothness" is controlled by the SmoothTension property.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSmooth{ get; set;}
Public Property IsSmooth As Boolean
public:
property bool IsSmooth {
    bool get ();
    void set (bool value);
}
Value
true to smooth the line, false to just connect the dots with linear segments
See Also
SmoothTension
IsSmooth
SmoothTension


schema Field

schema Field
Namespaces ► ZedGraph ► Line ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


SmoothTension Property

SmoothTension Property
Namespaces ► ZedGraph ► Line ► SmoothTension
Gets or sets a property that determines the smoothing tension for this Line. This property is only used if IsSmooth is true. A tension value 0.0 will just draw ordinary line segments like an unsmoothed line. A tension value of 1.0 will be smooth. Values greater than 1.0 will generally give odd results.
Declaration Syntax
C# Visual Basic Visual C++
public float SmoothTension{ get; set;}
Public Property SmoothTension As Single
public:
property float SmoothTension {
    float get ();
    void set (float value);
}
Value
A floating point value indicating the level of smoothing. 0.0F for no smoothing, 1.0F for lots of smoothing, >1.0 for odd smoothing.
See Also
IsSmooth
IsSmooth
SmoothTension


StepType Property

StepType Property
Namespaces ► ZedGraph ► Line ► StepType
Determines if the CurveItem will be drawn by directly connecting the points from the Points data collection, or if the curve will be a "stair-step" in which the points are connected by a series of horizontal and vertical lines that represent discrete, constant values. Note that the values can be forward oriented ForwardStep (StepType) or rearward oriented RearwardStep. That is, the points are defined at the beginning or end of the constant value for which they apply, respectively. The StepType property is ignored for lines that have IsSmooth set to true.
Declaration Syntax
C# Visual Basic Visual C++
public StepType StepType{ get; set;}
Public Property StepType As StepType
public:
property StepType StepType {
    StepType get ();
    void set (StepType value);
}
Value
StepType enum value
See Also
StepType


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► Line ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Line.Default Structure

Line..::Default Structure
Namespaces ► ZedGraph ► Line ► Line..::Default
A simple struct that defines the default property values for the Line class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon Member Description
Color
The default color for curves (line segments connecting the points). This is the default value for the Color property.

Equals(Object)
Indicates whether this instance and a specified object are equal.
(Inherited from ValueType.)
FillBrush
The default custom brush for filling in the area under the curve (Brush property).

FillColor
The default color for filling in the area under the curve (Color property).

FillType
The default fill mode for the curve (Type property).

Finalize()()
Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
(Inherited from Object.)
GetHashCode()()
Returns the hash code for this instance.
(Inherited from ValueType.)
GetType()()
Gets the Type of the current instance.
(Inherited from Object.)
IsOptimizedDraw
The default value for the IsOptimizedDraw property.

IsSmooth
The default value for the IsSmooth property.

MemberwiseClone()()
Creates a shallow copy of the current Object.
(Inherited from Object.)
SmoothTension
The default value for the SmoothTension property.

StepType
Default value for the curve type property (StepType). This determines if the curve will be drawn by directly connecting the points from the Points data collection, or if the curve will be a "stair-step" in which the points are connected by a series of horizontal and vertical lines that represent discrete, staticant values. Note that the values can be forward oriented
CopyC#
ForwardStep
 (StepType) or rearward oriented
CopyC#
RearwardStep
. That is, the points are defined at the beginning or end of the staticant value for which they apply, respectively.

ToString()()
Returns the fully qualified type name of this instance.
(Inherited from ValueType.)


Color Field

Color Field
Namespaces ► ZedGraph ► Line..::Default ► Color
The default color for curves (line segments connecting the points). This is the default value for the Color property.
Declaration Syntax
C# Visual Basic Visual C++
public static Color Color
Public Shared Color As Color
public:
static Color Color


FillBrush Field

FillBrush Field
Namespaces ► ZedGraph ► Line..::Default ► FillBrush
The default custom brush for filling in the area under the curve (Brush property).
Declaration Syntax
C# Visual Basic Visual C++
public static Brush FillBrush
Public Shared FillBrush As Brush
public:
static Brush^ FillBrush


FillColor Field

FillColor Field
Namespaces ► ZedGraph ► Line..::Default ► FillColor
The default color for filling in the area under the curve (Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color FillColor
Public Shared FillColor As Color
public:
static Color FillColor


FillType Field

FillType Field
Namespaces ► ZedGraph ► Line..::Default ► FillType
The default fill mode for the curve (Type property).
Declaration Syntax
C# Visual Basic Visual C++
public static FillType FillType
Public Shared FillType As FillType
public:
static FillType FillType


IsOptimizedDraw Field

IsOptimizedDraw Field
Namespaces ► ZedGraph ► Line..::Default ► IsOptimizedDraw
The default value for the IsOptimizedDraw property.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsOptimizedDraw
Public Shared IsOptimizedDraw As Boolean
public:
static bool IsOptimizedDraw


IsSmooth Field

IsSmooth Field
Namespaces ► ZedGraph ► Line..::Default ► IsSmooth
The default value for the IsSmooth property.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsSmooth
Public Shared IsSmooth As Boolean
public:
static bool IsSmooth


SmoothTension Field

SmoothTension Field
Namespaces ► ZedGraph ► Line..::Default ► SmoothTension
The default value for the SmoothTension property.
Declaration Syntax
C# Visual Basic Visual C++
public static float SmoothTension
Public Shared SmoothTension As Single
public:
static float SmoothTension


StepType Field

StepType Field
Namespaces ► ZedGraph ► Line..::Default ► StepType
Default value for the curve type property (StepType). This determines if the curve will be drawn by directly connecting the points from the Points data collection, or if the curve will be a "stair-step" in which the points are connected by a series of horizontal and vertical lines that represent discrete, staticant values. Note that the values can be forward oriented
CopyC#
ForwardStep
 (StepType) or rearward oriented
CopyC#
RearwardStep
. That is, the points are defined at the beginning or end of the staticant value for which they apply, respectively.
Declaration Syntax
C# Visual Basic Visual C++
public static StepType StepType
Public Shared StepType As StepType
public:
static StepType StepType
Value
StepType enum value


LineBase Class

LineBase Class
Namespaces ► ZedGraph ► LineBase
A class that handles the basic attributes of a line segment.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LineBase : ICloneable, ISerializable
<SerializableAttribute> _
Public Class LineBase _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class LineBase : ICloneable,
    ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LineBaseLineBaseNew()() | Default constructor that sets all LineBase properties to default values as defined in the LineBase..::Default class.
 | LineBaseLineBaseNew(Color) | Constructor that sets the color property to the specified value, and sets the remaining LineBase properties to default values as defined in the LineBase..::Default class.
 | LineBaseLineBaseNew(LineBase) | The Copy Constructor
 | Color | The color of the Line. Note that this color value can be overridden if the GradientFill.Type is one of the GradientByX, GradientByY, GradientByZ, and GradientByColorValue types.
 | DashOff | The "Dash Off" mode for drawing the line.
 | DashOn | The "Dash On" mode for drawing the line.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetPen(PaneBase, Single) | Create a Pen object based on the properties of this LineBase.
 | GetPen(PaneBase, Single, PointPair) | Create a Pen object based on the properties of this LineBase.
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GradientFill | Gets or sets a custom Fill class.
 | IsAntiAlias | Gets or sets a value that determines if the lines are drawn using Anti-Aliasing capabilities from the Graphics class.
 | IsVisible | Gets or sets a property that shows or hides the Line.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | schema0 | Current schema value that defines the version of the serialized file
 | Style | The style of the Line, defined as a DashStyle enum. This allows the line to be solid, dashed, or dotted.
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Width | The pen width used to draw the Line, in points (1/72 inch)
Remarks
This is the base class for Line and Border classes.
Inheritance Hierarchy
Object
 | LineBase
 |  | OHLCBar
 |  | Line
 |  | Border


LineBase Constructor

LineBase Constructor
Namespaces ► ZedGraph ► LineBase ► LineBaseLineBaseNew()()
Members
Icon | Member | Description
 | LineBaseLineBaseNew()() | Default constructor that sets all LineBase properties to default values as defined in the LineBase..::Default class.
 | LineBaseLineBaseNew(Color) | Constructor that sets the color property to the specified value, and sets the remaining LineBase properties to default values as defined in the LineBase..::Default class.
 | LineBaseLineBaseNew(LineBase) | The Copy Constructor


LineBase Constructor

LineBase Constructor
Namespaces ► ZedGraph ► LineBase ► LineBaseLineBaseNew()()
Default constructor that sets all LineBase properties to default values as defined in the LineBase..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public LineBase()
Public Sub New
public:
LineBase ()


LineBase Constructor (color)

LineBase Constructor (color)
Namespaces ► ZedGraph ► LineBase ► LineBaseLineBaseNew(Color)
Constructor that sets the color property to the specified value, and sets the remaining LineBase properties to default values as defined in the LineBase..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public LineBase(
    Color color
)
Public Sub New ( _
    color As Color _
)
public:
LineBase (
    Color color
)
Parameters
color (Color)
The color to assign to this new Line object


LineBase Constructor (rhs)

LineBase Constructor (rhs)
Namespaces ► ZedGraph ► LineBase ► LineBaseLineBaseNew(LineBase)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public LineBase(
    LineBase rhs
)
Public Sub New ( _
    rhs As LineBase _
)
public:
LineBase (
    LineBase^ rhs
)
Parameters
rhs (LineBase)
The LineBase object from which to copy


Color Property

Color Property
Namespaces ► ZedGraph ► LineBase ► Color
The color of the Line. Note that this color value can be overridden if the GradientFill.Type is one of the GradientByX, GradientByY, GradientByZ, and GradientByColorValue types.
Declaration Syntax
C# Visual Basic Visual C++
public Color Color{ get; set;}
Public Property Color As Color
public:
property Color Color {
    Color get ();
    void set (Color value);
}
See Also
GradientFill


DashOff Property

DashOff Property
Namespaces ► ZedGraph ► LineBase ► DashOff
The "Dash Off" mode for drawing the line.
Declaration Syntax
C# Visual Basic Visual C++
public float DashOff{ get; set;}
Public Property DashOff As Single
public:
property float DashOff {
    float get ();
    void set (float value);
}
Value
The dash off length is defined in points (1/72 inch)
Remarks
This is the distance, in points (1/72 inch), of the spaces between the dash segments that make up the dashed grid lines. This setting is only valid if Style is set to Custom.
See Also
DashOn
IsVisible
DashOff


DashOn Property

DashOn Property
Namespaces ► ZedGraph ► LineBase ► DashOn
The "Dash On" mode for drawing the line.
Declaration Syntax
C# Visual Basic Visual C++
public float DashOn{ get; set;}
Public Property DashOn As Single
public:
property float DashOn {
    float get ();
    void set (float value);
}
Value
The dash on length is defined in points (1/72 inch)
Remarks
This is the distance, in points (1/72 inch), of the dash segments that make up the dashed grid lines. This setting is only valid if Style is set to Custom.
See Also
DashOff
IsVisible
DashOn


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► LineBase ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


GetPen Method

GetPen Method
Namespaces ► ZedGraph ► LineBase ► GetPen()()
Members
Icon | Member | Description
 | GetPen(PaneBase, Single) | Create a Pen object based on the properties of this LineBase.
 | GetPen(PaneBase, Single, PointPair) | Create a Pen object based on the properties of this LineBase.


GetPen Method (pane, scaleFactor)

GetPen Method (pane, scaleFactor)
Namespaces ► ZedGraph ► LineBase ► GetPen(PaneBase, Single)
Create a Pen object based on the properties of this LineBase.
Declaration Syntax
C# Visual Basic Visual C++
public Pen GetPen(
    PaneBase pane,
    float scaleFactor
)
Public Function GetPen ( _
    pane As PaneBase, _
    scaleFactor As Single _
) As Pen
public:
Pen^ GetPen (
    PaneBase^ pane,
    float scaleFactor
)
Parameters
pane (PaneBase)
The owner GraphPane of this LineBase.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
A Pen object with the properties of this LineBase


GetPen Method (pane, scaleFactor, dataValue)

GetPen Method (pane, scaleFactor, dataValue)
Namespaces ► ZedGraph ► LineBase ► GetPen(PaneBase, Single, PointPair)
Create a Pen object based on the properties of this LineBase.
Declaration Syntax
C# Visual Basic Visual C++
public Pen GetPen(
    PaneBase pane,
    float scaleFactor,
    PointPair dataValue
)
Public Function GetPen ( _
    pane As PaneBase, _
    scaleFactor As Single, _
    dataValue As PointPair _
) As Pen
public:
Pen^ GetPen (
    PaneBase^ pane,
    float scaleFactor,
    PointPair^ dataValue
)
Parameters
pane (PaneBase)
The owner GraphPane of this LineBase.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
dataValue (PointPair)
The data value to be used for a value-based color gradient. This is only applicable if GradientFill.Type is one of GradientByX, GradientByY, GradientByZ, or GradientByColorValue.
Return Value
A Pen object with the properties of this LineBase


GradientFill Property

GradientFill Property
Namespaces ► ZedGraph ► LineBase ► GradientFill
Gets or sets a custom Fill class.
Declaration Syntax
C# Visual Basic Visual C++
public Fill GradientFill{ get; set;}
Public Property GradientFill As Fill
public:
property Fill^ GradientFill {
    Fill^ get ();
    void set (Fill^ value);
}
Remarks
This fill is used strictly for GradientByX, GradientByY, GradientByZ, and GradientByColorValue calculations to determine the color of the line. It overrides the Color property if one of the above FillType values are selected.
See Also
Color


IsAntiAlias Property

IsAntiAlias Property
Namespaces ► ZedGraph ► LineBase ► IsAntiAlias
Gets or sets a value that determines if the lines are drawn using Anti-Aliasing capabilities from the Graphics class.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAntiAlias{ get; set;}
Public Property IsAntiAlias As Boolean
public:
property bool IsAntiAlias {
    bool get ();
    void set (bool value);
}
Remarks
If this value is set to true, then the SmoothingMode property will be set to HighQuality only while this Line is drawn. A value of false will leave the value of SmoothingMode unchanged.


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph ► LineBase ► IsVisible
Gets or sets a property that shows or hides the Line.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
Value
true to show the line, false to hide it
See Also
IsVisible


schema0 Field

schema0 Field
Namespaces ► ZedGraph ► LineBase ► schema0
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema0
Public Const schema0 As Integer
public:
literal int schema0


Style Property

Style Property
Namespaces ► ZedGraph ► LineBase ► Style
The style of the Line, defined as a DashStyle enum. This allows the line to be solid, dashed, or dotted.
Declaration Syntax
C# Visual Basic Visual C++
public DashStyle Style{ get; set;}
Public Property Style As DashStyle
public:
property DashStyle Style {
    DashStyle get ();
    void set (DashStyle value);
}
See Also
Style
DashOn
DashOff


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► LineBase ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone.
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object
Remarks
Note that this method must be called with an explicit cast to ICloneable, and that it is inherently virtual. For example:
CopyC#
ParentClass foo = new ChildClass();
ChildClass bar = (ChildClass) ((ICloneable)foo).Clone();
 Assume that ChildClass is inherited from ParentClass. Even though foo is declared with ParentClass, it is actually an instance of ChildClass. Calling the ICloneable implementation of Clone() on foo actually calls ChildClass.Clone() as if it were a virtual function.


Width Property

Width Property
Namespaces ► ZedGraph ► LineBase ► Width
The pen width used to draw the Line, in points (1/72 inch)
Declaration Syntax
C# Visual Basic Visual C++
public float Width{ get; set;}
Public Property Width As Single
public:
property float Width {
    float get ();
    void set (float value);
}
See Also
Width


LineBase.Default Structure

LineBase..::Default Structure
Namespaces ► ZedGraph ► LineBase ► LineBase..::Default
A simple struct that defines the default property values for the LineBase class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Color | The default color for the line. This is the default value for the Color property.
 | DashOff | The default "dash off" size for drawing the the line (DashOff property). Units are in points (1/72 inch).
 | DashOn | The default "dash on" size for drawing the line (DashOn property). Units are in points (1/72 inch).
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAntiAlias | The default value for the IsAntiAlias property.
 | IsVisible | The default mode for displaying line segments (IsVisible property). True to show the line segments, false to hide them.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Style | The default drawing style for line segments (Style property). This is defined with the DashStyle enumeration.
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | Width | The default width for line segments (Width property). Units are points (1/72 inch).


Color Field

Color Field
Namespaces ► ZedGraph ► LineBase..::Default ► Color
The default color for the line. This is the default value for the Color property.
Declaration Syntax
C# Visual Basic Visual C++
public static Color Color
Public Shared Color As Color
public:
static Color Color


DashOff Field

DashOff Field
Namespaces ► ZedGraph ► LineBase..::Default ► DashOff
The default "dash off" size for drawing the the line (DashOff property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float DashOff
Public Shared DashOff As Single
public:
static float DashOff


DashOn Field

DashOn Field
Namespaces ► ZedGraph ► LineBase..::Default ► DashOn
The default "dash on" size for drawing the line (DashOn property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float DashOn
Public Shared DashOn As Single
public:
static float DashOn


IsAntiAlias Field

IsAntiAlias Field
Namespaces ► ZedGraph ► LineBase..::Default ► IsAntiAlias
The default value for the IsAntiAlias property.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsAntiAlias
Public Shared IsAntiAlias As Boolean
public:
static bool IsAntiAlias


IsVisible Field

IsVisible Field
Namespaces ► ZedGraph ► LineBase..::Default ► IsVisible
The default mode for displaying line segments (IsVisible property). True to show the line segments, false to hide them.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsVisible
Public Shared IsVisible As Boolean
public:
static bool IsVisible


Style Field

Style Field
Namespaces ► ZedGraph ► LineBase..::Default ► Style
The default drawing style for line segments (Style property). This is defined with the DashStyle enumeration.
Declaration Syntax
C# Visual Basic Visual C++
public static DashStyle Style
Public Shared Style As DashStyle
public:
static DashStyle Style


Width Field

Width Field
Namespaces ► ZedGraph ► LineBase..::Default ► Width
The default width for line segments (Width property). Units are points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float Width
Public Shared Width As Single
public:
static float Width


LineItem Class

LineItem Class
Namespaces ► ZedGraph ► LineItem
Encapsulates a curve type that is displayed as a line and/or a set of symbols at each point.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LineItem : CurveItem, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class LineItem _
    Inherits CurveItem _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class LineItem : public CurveItem,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LineItemLineItemNew(String) | Create a new LineItem, specifying only the legend Label.
 | LineItemLineItemNew(String, array<Double>[](), array<Double>[](), Color, SymbolType, Single) | Create a new LineItem using the specified properties.
 | LineItemLineItemNew(String, array<Double>[](), array<Double>[](), Color, SymbolType) | Create a new LineItem using the specified properties.
 | LineItemLineItemNew(String, IPointList, Color, SymbolType, Single) | Create a new LineItem using the specified properties.
 | LineItemLineItemNew(String, IPointList, Color, SymbolType) | Create a new LineItem using the specified properties.
 | LineItemLineItemNew(LineItem) | The Copy Constructor
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve. (Inherited from CurveItem.)
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve. (Inherited from CurveItem.)
 | BaseAxis(GraphPane) | Returns a reference to the Axis object that is the "base" (independent axis) from which the values are drawn. (Inherited from CurveItem.)
 | Clear()() | Clears the points from this CurveItem. This is the same as CurveItem.Points.Clear(). (Inherited from CurveItem.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The Line/Symbol/Bar color (FillColor for the Bar). This is a common access to Line.Color, Border.Color, and Fill.Color properties for this curve. (Inherited from CurveItem.)
 | Draw(Graphics, GraphPane, Int32, Single) | Do all rendering associated with this LineItem to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object. (Overrides CurveItem.Draw(Graphics, GraphPane, Int32, Single).)
 | DrawLegendKey(Graphics, GraphPane, RectangleF, Single) | Draw a legend key entry for this LineItem at the specified location (Overrides CurveItem.DrawLegendKey(Graphics, GraphPane, RectangleF, Single).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarWidth(GraphPane) | Calculate the width of each bar, depending on the actual bar type (Inherited from CurveItem.)
 | GetCoords(GraphPane, Int32, String%) | Determine the coords for the rectangle associated with a specified point for this CurveItem (Overrides CurveItem.GetCoords(GraphPane, Int32, String%).)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides CurveItem.GetObjectData(SerializationInfo, StreamingContext).)
 | GetRange(Double%, Double%, Double%, Double%, Boolean, Boolean, GraphPane) | Go through the list of PointPair data values for this CurveItem and determine the minimum and maximum values in the data. (Inherited from CurveItem.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXAxis(GraphPane) | Get the X Axis instance (either XAxis or X2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxis(GraphPane) | Get the Y Axis instance (either YAxis or Y2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxisIndex(GraphPane) | Get the index of the Y Axis in the YAxis or Y2Axis list to which this CurveItem belongs. (Inherited from CurveItem.)
 | IsBar | Determines whether this CurveItem is a BarItem. This does not include HiLowBarItem's or ErrorBarItem's. (Inherited from CurveItem.)
 | IsLine | Determines whether this CurveItem is a LineItem. (Inherited from CurveItem.)
 | IsOverrideOrdinal | Gets or sets a value which allows you to override the normal ordinal axis behavior. (Inherited from CurveItem.)
 | IsPie | Determines whether this CurveItem is a PieItem. (Inherited from CurveItem.)
 | IsSelectable | Determines whether this CurveItem can be selected in the graph. (Inherited from CurveItem.)
 | IsSelected | Determines whether this CurveItem is selected on the graph. Note that this value changes the curve displayed color, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsVisible | Determines whether this CurveItem is visible on the graph. Note that this value turns the curve display on or off, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsX2Axis | Gets or sets a value that determines which X axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | IsY2Axis | Gets or sets a value that determines which Y axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | Item[([Int32])] | An accessor for the PointPair datum for this CurveItem. Index is the ordinal reference (zero based) of the point. (Inherited from CurveItem.)
 | Label | A Label instance that represents the Legend entry for the this CurveItem object (Inherited from CurveItem.)
 | Line | Gets or sets the Line class instance defined for this LineItem.
 | Link | Gets or sets the hyperlink information for this CurveItem. (Inherited from CurveItem.)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this LineItem. This is mainly useful for differentiating a set of new LineItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator) (Overrides CurveItem.MakeUnique(ColorSymbolRotator).)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NPts | Readonly property that gives the number of points that define this CurveItem object, which is the number of points in the Points data collection. (Inherited from CurveItem.)
 | Points | The IPointList of X,Y point sets that represent this CurveItem. (Inherited from CurveItem.)
 | RemovePoint(Int32) | Removes a single point from this CurveItem. (Inherited from CurveItem.)
 | schema2 | Current schema value that defines the version of the serialized file
 | Symbol | Gets or sets the Symbol class instance defined for this LineItem.
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the CurveItem. ZedGraph does not use this value for any purpose. (Inherited from CurveItem.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValueAxis(GraphPane) | Returns a reference to the Axis object that is the "value" (dependent axis) from which the points are drawn. (Inherited from CurveItem.)
 | YAxisIndex | Gets or sets the index number of the Y Axis to which this CurveItem belongs. (Inherited from CurveItem.)
Inheritance Hierarchy
Object
 | CurveItem
 |  | LineItem
 |  |  | StickItem


LineItem Constructor

LineItem Constructor
Namespaces ► ZedGraph ► LineItem ► LineItemLineItemNew()()
Members
Icon | Member | Description
 | LineItemLineItemNew(String) | Create a new LineItem, specifying only the legend Label.
 | LineItemLineItemNew(String, array<Double>[](), array<Double>[](), Color, SymbolType, Single) | Create a new LineItem using the specified properties.
 | LineItemLineItemNew(String, array<Double>[](), array<Double>[](), Color, SymbolType) | Create a new LineItem using the specified properties.
 | LineItemLineItemNew(String, IPointList, Color, SymbolType, Single) | Create a new LineItem using the specified properties.
 | LineItemLineItemNew(String, IPointList, Color, SymbolType) | Create a new LineItem using the specified properties.
 | LineItemLineItemNew(LineItem) | The Copy Constructor


LineItem Constructor (label)

LineItem Constructor (label)
Namespaces ► ZedGraph ► LineItem ► LineItemLineItemNew(String)
Create a new LineItem, specifying only the legend Label.
Declaration Syntax
C# Visual Basic Visual C++
public LineItem(
    string label
)
Public Sub New ( _
    label As String _
)
public:
LineItem (
    String^ label
)
Parameters
label (String)
The _label that will appear in the legend.


LineItem Constructor (label, x, y, color, symbolType)

LineItem Constructor (label, x, y, color, symbolType)
Namespaces ► ZedGraph ► LineItem ► LineItemLineItemNew(String, array<Double>[](), array<Double>[](), Color, SymbolType)
Create a new LineItem using the specified properties.
Declaration Syntax
C# Visual Basic Visual C++
public LineItem(
    string label,
    double[] x,
    double[] y,
    Color color,
    SymbolType symbolType
)
Public Sub New ( _
    label As String, _
    x As Double(), _
    y As Double(), _
    color As Color, _
    symbolType As SymbolType _
)
public:
LineItem (
    String^ label,
    array<double>^ x,
    array<double>^ y,
    Color color,
    SymbolType symbolType
)
Parameters
label (String)
The _label that will appear in the legend.
x (array< Double >[]())
An array of double precision values that define the independent (X axis) values for this curve
y (array< Double >[]())
An array of double precision values that define the dependent (Y axis) values for this curve
color (Color)
A Color value that will be applied to the Line and Symbol properties.
symbolType (SymbolType)
A SymbolType enum specifying the type of symbol to use for this LineItem. Use None to hide the symbols.


LineItem Constructor (label, x, y, color, symbolType, lineWidth)

LineItem Constructor (label, x, y, color, symbolType, lineWidth)
Namespaces ► ZedGraph ► LineItem ► LineItemLineItemNew(String, array<Double>[](), array<Double>[](), Color, SymbolType, Single)
Create a new LineItem using the specified properties.
Declaration Syntax
C# Visual Basic Visual C++
public LineItem(
    string label,
    double[] x,
    double[] y,
    Color color,
    SymbolType symbolType,
    float lineWidth
)
Public Sub New ( _
    label As String, _
    x As Double(), _
    y As Double(), _
    color As Color, _
    symbolType As SymbolType, _
    lineWidth As Single _
)
public:
LineItem (
    String^ label,
    array<double>^ x,
    array<double>^ y,
    Color color,
    SymbolType symbolType,
    float lineWidth
)
Parameters
label (String)
The _label that will appear in the legend.
x (array< Double >[]())
An array of double precision values that define the independent (X axis) values for this curve
y (array< Double >[]())
An array of double precision values that define the dependent (Y axis) values for this curve
color (Color)
A Color value that will be applied to the Line and Symbol properties.
symbolType (SymbolType)
A SymbolType enum specifying the type of symbol to use for this LineItem. Use None to hide the symbols.
lineWidth (Single)
The width (in points) to be used for the Line. This width is scaled based on CalcScaleFactor()(). Use a value of zero to hide the line (see IsVisible).


LineItem Constructor (label, points, color, symbolType)

LineItem Constructor (label, points, color, symbolType)
Namespaces ► ZedGraph ► LineItem ► LineItemLineItemNew(String, IPointList, Color, SymbolType)
Create a new LineItem using the specified properties.
Declaration Syntax
C# Visual Basic Visual C++
public LineItem(
    string label,
    IPointList points,
    Color color,
    SymbolType symbolType
)
Public Sub New ( _
    label As String, _
    points As IPointList, _
    color As Color, _
    symbolType As SymbolType _
)
public:
LineItem (
    String^ label,
    IPointList^ points,
    Color color,
    SymbolType symbolType
)
Parameters
label (String)
The _label that will appear in the legend.
points (IPointList)
A IPointList of double precision value pairs that define the X and Y values for this curve
color (Color)
A Color value that will be applied to the Line and Symbol properties.
symbolType (SymbolType)
A SymbolType enum specifying the type of symbol to use for this LineItem. Use None to hide the symbols.


LineItem Constructor (label, points, color, symbolType, lineWidth)

LineItem Constructor (label, points, color, symbolType, lineWidth)
Namespaces ► ZedGraph ► LineItem ► LineItemLineItemNew(String, IPointList, Color, SymbolType, Single)
Create a new LineItem using the specified properties.
Declaration Syntax
C# Visual Basic Visual C++
public LineItem(
    string label,
    IPointList points,
    Color color,
    SymbolType symbolType,
    float lineWidth
)
Public Sub New ( _
    label As String, _
    points As IPointList, _
    color As Color, _
    symbolType As SymbolType, _
    lineWidth As Single _
)
public:
LineItem (
    String^ label,
    IPointList^ points,
    Color color,
    SymbolType symbolType,
    float lineWidth
)
Parameters
label (String)
The _label that will appear in the legend.
points (IPointList)
A IPointList of double precision value pairs that define the X and Y values for this curve
color (Color)
A Color value that will be applied to the Line and Symbol properties.
symbolType (SymbolType)
A SymbolType enum specifying the type of symbol to use for this LineItem. Use None to hide the symbols.
lineWidth (Single)
The width (in points) to be used for the Line. This width is scaled based on CalcScaleFactor()(). Use a value of zero to hide the line (see IsVisible).


LineItem Constructor (rhs)

LineItem Constructor (rhs)
Namespaces ► ZedGraph ► LineItem ► LineItemLineItemNew(LineItem)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public LineItem(
    LineItem rhs
)
Public Sub New ( _
    rhs As LineItem _
)
public:
LineItem (
    LineItem^ rhs
)
Parameters
rhs (LineItem)
The LineItem object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► LineItem ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public LineItem Clone()
Public Function Clone As LineItem
public:
LineItem^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, pos, scaleFactor)

Draw Method (g, pane, pos, scaleFactor)
Namespaces ► ZedGraph ► LineItem ► Draw(Graphics, GraphPane, Int32, Single)
Do all rendering associated with this LineItem to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object.
Declaration Syntax
C# Visual Basic Visual C++
public override void Draw(
    Graphics g,
    GraphPane pane,
    int pos,
    float scaleFactor
)
Public Overrides Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    pos As Integer, _
    scaleFactor As Single _
)
public:
virtual void Draw (
    Graphics^ g,
    GraphPane^ pane,
    int pos,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
pos (Int32)
The ordinal position of the current Bar curve.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


DrawLegendKey Method (g, pane, rect, scaleFactor)

DrawLegendKey Method (g, pane, rect, scaleFactor)
Namespaces ► ZedGraph ► LineItem ► DrawLegendKey(Graphics, GraphPane, RectangleF, Single)
Draw a legend key entry for this LineItem at the specified location
Declaration Syntax
C# Visual Basic Visual C++
public override void DrawLegendKey(
    Graphics g,
    GraphPane pane,
    RectangleF rect,
    float scaleFactor
)
Public Overrides Sub DrawLegendKey ( _
    g As Graphics, _
    pane As GraphPane, _
    rect As RectangleF, _
    scaleFactor As Single _
)
public:
virtual void DrawLegendKey (
    Graphics^ g,
    GraphPane^ pane,
    RectangleF rect,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
rect (RectangleF)
The RectangleF struct that specifies the location for the legend key
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


GetCoords Method (pane, i, coords)

GetCoords Method (pane, i, coords)
Namespaces ► ZedGraph ► LineItem ► GetCoords(GraphPane, Int32, String%)
Determine the coords for the rectangle associated with a specified point for this CurveItem
Declaration Syntax
C# Visual Basic Visual C++
public override bool GetCoords(
    GraphPane pane,
    int i,
    out string coords
)
Public Overrides Function GetCoords ( _
    pane As GraphPane, _
    i As Integer, _
    <OutAttribute> ByRef coords As String _
) As Boolean
public:
virtual bool GetCoords (
    GraphPane^ pane,
    int i,
    [OutAttribute] String^% coords
) override
Parameters
pane (GraphPane)
The GraphPane to which this curve belongs
i (Int32)
The index of the point of interest
coords (String %)
A list of coordinates that represents the "rect" for this point (used in an html AREA tag)
Return Value
true if it's a valid point, false otherwise


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► LineItem ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


Line Property

Line Property
Namespaces ► ZedGraph ► LineItem ► Line
Gets or sets the Line class instance defined for this LineItem.
Declaration Syntax
C# Visual Basic Visual C++
public Line Line{ get; set;}
Public Property Line As Line
public:
property Line^ Line {
    Line^ get ();
    void set (Line^ value);
}


MakeUnique Method (rotator)

MakeUnique Method (rotator)
Namespaces ► ZedGraph ► LineItem ► MakeUnique(ColorSymbolRotator)
Loads some pseudo unique colors/symbols into this LineItem. This is mainly useful for differentiating a set of new LineItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator)
Declaration Syntax
C# Visual Basic Visual C++
public override void MakeUnique(
    ColorSymbolRotator rotator
)
Public Overrides Sub MakeUnique ( _
    rotator As ColorSymbolRotator _
)
public:
virtual void MakeUnique (
    ColorSymbolRotator^ rotator
) override
Parameters
rotator (ColorSymbolRotator)
The ColorSymbolRotator that is used to pick the color and symbol for this method call.
See Also
MakeUnique(ColorSymbolRotator)


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► LineItem ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


Symbol Property

Symbol Property
Namespaces ► ZedGraph ► LineItem ► Symbol
Gets or sets the Symbol class instance defined for this LineItem.
Declaration Syntax
C# Visual Basic Visual C++
public Symbol Symbol{ get; set;}
Public Property Symbol As Symbol
public:
property Symbol^ Symbol {
    Symbol^ get ();
    void set (Symbol^ value);
}


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► LineItem ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


LineObj Class

LineObj Class
Namespaces ► ZedGraph ► LineObj
A class that represents a line segment object on the graph. A list of GraphObj objects is maintained by the GraphObjList collection class.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LineObj : GraphObj, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class LineObj _
    Inherits GraphObj _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class LineObj : public GraphObj,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LineObjLineObjNew(Color, Double, Double, Double, Double) | A constructor that allows the position, color, and size of the LineObj to be pre-specified.
 | LineObjLineObjNew(Double, Double, Double, Double) | A constructor that allows only the position of the line to be pre-specified. All other properties are set to default values
 | LineObjLineObjNew()() | Default constructor -- places the LineObj at location (0,0) to (1,1). All other values are defaulted.
 | LineObjLineObjNew(LineObj) | The Copy Constructor
 | Clone()() | Typesafe, deep-copy clone method.
 | Draw(Graphics, PaneBase, Single) | Render this object to the specified Graphics device. (Overrides GraphObj.Draw(Graphics, PaneBase, Single).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCoords(PaneBase, Graphics, Single, String%, String%) | Determines the shape type and Coords values for this GraphObj (Overrides GraphObj.GetCoords(PaneBase, Graphics, Single, String%, String%).)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides GraphObj.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsClippedToChartRect | Gets or sets a value that determines whether or not the rendering of this GraphObj will be clipped to the Rect. (Inherited from GraphObj.)
 | IsInFrontOfData | true if the ZOrder of this object is set to put it in front of the CurveItem data points. (Inherited from GraphObj.)
 | IsVisible | Gets or sets a value that determines if this GraphObj will be visible in the graph. true displays the item, false hides it. (Inherited from GraphObj.)
 | Line | A LineBase class that contains the attributes for drawing this LineObj.
 | Link | Gets or sets the hyperlink information for this GraphObj. (Inherited from GraphObj.)
 | Location | The Location struct that describes the location for this GraphObj. (Inherited from GraphObj.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PointInBox(PointF, PaneBase, Graphics, Single) | Determine if the specified screen point lies inside the bounding box of this LineObj. (Overrides GraphObj.PointInBox(PointF, PaneBase, Graphics, Single).)
 | schema2 | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the GraphObj. ZedGraph does not use this value for any purpose. (Inherited from GraphObj.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ZOrder | Gets or sets a value that determines the z-order "depth" of this item relative to other graphic objects. (Inherited from GraphObj.)
Remarks
This should not be confused with the LineItem class, which represents a set of points plotted together as a "curve". The LineObj class is a single line segment, drawn as a "decoration" on the chart.
Inheritance Hierarchy
Object
 | GraphObj
 |  | LineObj
 |  |  | ArrowObj


LineObj Constructor

LineObj Constructor
Namespaces ► ZedGraph ► LineObj ► LineObjLineObjNew()()
Constructors for the LineObj object
Members
Icon | Member | Description
 | LineObjLineObjNew(Color, Double, Double, Double, Double) | A constructor that allows the position, color, and size of the LineObj to be pre-specified.
 | LineObjLineObjNew(Double, Double, Double, Double) | A constructor that allows only the position of the line to be pre-specified. All other properties are set to default values
 | LineObjLineObjNew()() | Default constructor -- places the LineObj at location (0,0) to (1,1). All other values are defaulted.
 | LineObjLineObjNew(LineObj) | The Copy Constructor


LineObj Constructor

LineObj Constructor
Namespaces ► ZedGraph ► LineObj ► LineObjLineObjNew()()
Default constructor -- places the LineObj at location (0,0) to (1,1). All other values are defaulted.
Declaration Syntax
C# Visual Basic Visual C++
public LineObj()
Public Sub New
public:
LineObj ()


LineObj Constructor (x1, y1, x2, y2)

LineObj Constructor (x1, y1, x2, y2)
Namespaces ► ZedGraph ► LineObj ► LineObjLineObjNew(Double, Double, Double, Double)
A constructor that allows only the position of the line to be pre-specified. All other properties are set to default values
Declaration Syntax
C# Visual Basic Visual C++
public LineObj(
    double x1,
    double y1,
    double x2,
    double y2
)
Public Sub New ( _
    x1 As Double, _
    y1 As Double, _
    x2 As Double, _
    y2 As Double _
)
public:
LineObj (
    double x1,
    double y1,
    double x2,
    double y2
)
Parameters
x1 (Double)
The x position of the starting point that defines the LineObj. The units of this position are specified by the CoordinateFrame property.
y1 (Double)
The y position of the starting point that defines the LineObj. The units of this position are specified by the CoordinateFrame property.
x2 (Double)
The x position of the ending point that defines the LineObj. The units of this position are specified by the CoordinateFrame property.
y2 (Double)
The y position of the ending point that defines the LineObj. The units of this position are specified by the CoordinateFrame property.


LineObj Constructor (color, x1, y1, x2, y2)

LineObj Constructor (color, x1, y1, x2, y2)
Namespaces ► ZedGraph ► LineObj ► LineObjLineObjNew(Color, Double, Double, Double, Double)
A constructor that allows the position, color, and size of the LineObj to be pre-specified.
Declaration Syntax
C# Visual Basic Visual C++
public LineObj(
    Color color,
    double x1,
    double y1,
    double x2,
    double y2
)
Public Sub New ( _
    color As Color, _
    x1 As Double, _
    y1 As Double, _
    x2 As Double, _
    y2 As Double _
)
public:
LineObj (
    Color color,
    double x1,
    double y1,
    double x2,
    double y2
)
Parameters
color (Color)
An arbitrary Color specification for the arrow
x1 (Double)
The x position of the starting point that defines the line. The units of this position are specified by the CoordinateFrame property.
y1 (Double)
The y position of the starting point that defines the line. The units of this position are specified by the CoordinateFrame property.
x2 (Double)
The x position of the ending point that defines the line. The units of this position are specified by the CoordinateFrame property.
y2 (Double)
The y position of the ending point that defines the line. The units of this position are specified by the CoordinateFrame property.


LineObj Constructor (rhs)

LineObj Constructor (rhs)
Namespaces ► ZedGraph ► LineObj ► LineObjLineObjNew(LineObj)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public LineObj(
    LineObj rhs
)
Public Sub New ( _
    rhs As LineObj _
)
public:
LineObj (
    LineObj^ rhs
)
Parameters
rhs (LineObj)
The LineObj object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► LineObj ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public LineObj Clone()
Public Function Clone As LineObj
public:
LineObj^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, scaleFactor)

Draw Method (g, pane, scaleFactor)
Namespaces ► ZedGraph ► LineObj ► Draw(Graphics, PaneBase, Single)
Render this object to the specified Graphics device.
Declaration Syntax
C# Visual Basic Visual C++
public override void Draw(
    Graphics g,
    PaneBase pane,
    float scaleFactor
)
Public Overrides Sub Draw ( _
    g As Graphics, _
    pane As PaneBase, _
    scaleFactor As Single _
)
public:
virtual void Draw (
    Graphics^ g,
    PaneBase^ pane,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Remarks
This method is normally only called by the Draw method of the parent GraphObjList collection object.


GetCoords Method (pane, g, scaleFactor, shape, coords)

GetCoords Method (pane, g, scaleFactor, shape, coords)
Namespaces ► ZedGraph ► LineObj ► GetCoords(PaneBase, Graphics, Single, String%, String%)
Determines the shape type and Coords values for this GraphObj
Declaration Syntax
C# Visual Basic Visual C++
public override void GetCoords(
    PaneBase pane,
    Graphics g,
    float scaleFactor,
    out string shape,
    out string coords
)
Public Overrides Sub GetCoords ( _
    pane As PaneBase, _
    g As Graphics, _
    scaleFactor As Single, _
    <OutAttribute> ByRef shape As String, _
    <OutAttribute> ByRef coords As String _
)
public:
virtual void GetCoords (
    PaneBase^ pane,
    Graphics^ g,
    float scaleFactor,
    [OutAttribute] String^% shape,
    [OutAttribute] String^% coords
) override
Parameters
pane (PaneBase)
g (Graphics)
scaleFactor (Single)
shape (String %)
coords (String %)


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► LineObj ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


Line Property

Line Property
Namespaces ► ZedGraph ► LineObj ► Line
A LineBase class that contains the attributes for drawing this LineObj.
Declaration Syntax
C# Visual Basic Visual C++
public LineBase Line{ get; set;}
Public Property Line As LineBase
public:
property LineBase^ Line {
    LineBase^ get ();
    void set (LineBase^ value);
}


PointInBox Method (pt, pane, g, scaleFactor)

PointInBox Method (pt, pane, g, scaleFactor)
Namespaces ► ZedGraph ► LineObj ► PointInBox(PointF, PaneBase, Graphics, Single)
Determine if the specified screen point lies inside the bounding box of this LineObj.
Declaration Syntax
C# Visual Basic Visual C++
public override bool PointInBox(
    PointF pt,
    PaneBase pane,
    Graphics g,
    float scaleFactor
)
Public Overrides Function PointInBox ( _
    pt As PointF, _
    pane As PaneBase, _
    g As Graphics, _
    scaleFactor As Single _
) As Boolean
public:
virtual bool PointInBox (
    PointF pt,
    PaneBase^ pane,
    Graphics^ g,
    float scaleFactor
) override
Parameters
pt (PointF)
The screen point, in pixels
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
true if the point lies in the bounding box, false otherwise
Remarks
The bounding box is calculated assuming a distance of NearestTol pixels around the arrow segment.


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► LineObj ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► LineObj ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


LineType Enumeration

LineType Enumeration
Namespaces ► ZedGraph ► LineType
Enumeration type that defines the available types of LineItem graphs.
Declaration Syntax
C# Visual Basic Visual C++
public enum LineType
Public Enumeration LineType
public enum class LineType
Members
Member | Description
Normal | Draw the lines as normal. Any fill area goes from each line down to the X Axis.
Stack | Draw the lines stacked on top of each other, accumulating values to a total value.
See Also
LineType


Link Class

Link Class
Namespaces ► ZedGraph ► Link
A class that maintains hyperlink information for a clickable object on the graph.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Link : ISerializable, ICloneable
<SerializableAttribute> _
Public Class Link _
    Implements ISerializable, ICloneable
[SerializableAttribute]
public ref class Link : ISerializable, ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LinkLinkNew()() | Default constructor. Set all properties to string.Empty, or null.
 | LinkLinkNew(String, String, String) | Construct a Link instance from a specified title, url, and target.
 | LinkLinkNew(Link) | The Copy Constructor
 | Clone()() | Typesafe, deep-copy clone method.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsActive | Gets a value that indicates if this Link is enabled (see IsEnabled), and that either the Url or the Title is non-null.
 | IsEnabled | Gets or sets a property that determines if this link is active. True to have a clickable link, false to ignore the link.
 | MakeCurveItemUrl(GraphPane, CurveItem, Int32) | Create a URL for a CurveItem that includes the index of the point that was selected.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | schema | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the Link. ZedGraph does not use this value for any purpose.
 | Target | Gets or sets the target string for this link.
 | Title | Gets or sets the title string for this link.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Url | Gets or sets the url string for this link.
Inheritance Hierarchy
Object
Link


Link Constructor

Link Constructor
Namespaces ► ZedGraph ► Link ► LinkLinkNew()()
Members
Icon | Member | Description
 | LinkLinkNew()() | Default constructor. Set all properties to string.Empty, or null.
 | LinkLinkNew(String, String, String) | Construct a Link instance from a specified title, url, and target.
 | LinkLinkNew(Link) | The Copy Constructor


Link Constructor

Link Constructor
Namespaces ► ZedGraph ► Link ► LinkLinkNew()()
Default constructor. Set all properties to string.Empty, or null.
Declaration Syntax
C# Visual Basic Visual C++
public Link()
Public Sub New
public:
Link ()


Link Constructor (title, url, target)

Link Constructor (title, url, target)
Namespaces ► ZedGraph ► Link ► LinkLinkNew(String, String, String)
Construct a Link instance from a specified title, url, and target.
Declaration Syntax
C# Visual Basic Visual C++
public Link(
    string title,
    string url,
    string target
)
Public Sub New ( _
    title As String, _
    url As String, _
    target As String _
)
public:
Link (
    String^ title,
    String^ url,
    String^ target
)
Parameters
title (String)
The title for the link (which shows up in the tooltip).
url (String)
The URL destination for the link.
target (String)
The target for the link (typically "_blank" or "_self").


Link Constructor (rhs)

Link Constructor (rhs)
Namespaces ► ZedGraph ► Link ► LinkLinkNew(Link)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public Link(
    Link rhs
)
Public Sub New ( _
    rhs As Link _
)
public:
Link (
    Link^ rhs
)
Parameters
rhs (Link)
The Link object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► Link ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public Link Clone()
Public Function Clone As Link
public:
Link^ Clone ()
Return Value
A new, independent copy of this class


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► Link ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsActive Property

IsActive Property
Namespaces ► ZedGraph ► Link ► IsActive
Gets a value that indicates if this Link is enabled (see IsEnabled), and that either the Url or the Title is non-null.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsActive{ get;}
Public ReadOnly Property IsActive As Boolean
public:
property bool IsActive {
    bool get ();
}


IsEnabled Property

IsEnabled Property
Namespaces ► ZedGraph ► Link ► IsEnabled
Gets or sets a property that determines if this link is active. True to have a clickable link, false to ignore the link.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEnabled{ get; set;}
Public Property IsEnabled As Boolean
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}


MakeCurveItemUrl Method (pane, curve, index)

MakeCurveItemUrl Method (pane, curve, index)
Namespaces ► ZedGraph ► Link ► MakeCurveItemUrl(GraphPane, CurveItem, Int32)
Create a URL for a CurveItem that includes the index of the point that was selected.
Declaration Syntax
C# Visual Basic Visual C++
public virtual string MakeCurveItemUrl(
    GraphPane pane,
    CurveItem curve,
    int index
)
Public Overridable Function MakeCurveItemUrl ( _
    pane As GraphPane, _
    curve As CurveItem, _
    index As Integer _
) As String
public:
virtual String^ MakeCurveItemUrl (
    GraphPane^ pane,
    CurveItem^ curve,
    int index
)
Parameters
pane (GraphPane)
The GraphPane of interest
curve (CurveItem)
The CurveItem for which to make the url string.
index (Int32)
The zero-based index of the selected point
Return Value
A string containing the url with an index parameter added.
Remarks
An "index" parameter is added to the Url property for this link to indicate which point was selected. Further, if the X or Y axes that correspond to this CurveItem are of Text, then an additional parameter will be added containing the text value that corresponds to the index of the selected point. The XAxis text parameter will be labeled "xtext", and the YAxis text parameter will be labeled "ytext".


schema Field

schema Field
Namespaces ► ZedGraph ► Link ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema
Remarks
schema started with 10 for ZedGraph version 5


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► Link ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Tag Field

Tag Field
Namespaces ► ZedGraph ► Link ► Tag
A tag object for use by the user. This can be used to store additional information associated with the Link. ZedGraph does not use this value for any purpose.
Declaration Syntax
C# Visual Basic Visual C++
public Object Tag
Public Tag As Object
public:
Object^ Tag
Remarks
Note that, if you are going to Serialize ZedGraph data, then any type that you store in Tag must be a serializable type (or it will cause an exception).


Target Property

Target Property
Namespaces ► ZedGraph ► Link ► Target
Gets or sets the target string for this link.
Declaration Syntax
C# Visual Basic Visual C++
public string Target{ get; set;}
Public Property Target As String
public:
property String^ Target {
    String^ get ();
    void set (String^ value);
}
Remarks
This value should be set to a valid target associated with the "Target" property of an html hyperlink. Typically, this would be "_blank" to open a new browser window, or "_self" to open in the current browser.


Title Property

Title Property
Namespaces ► ZedGraph ► Link ► Title
Gets or sets the title string for this link.
Declaration Syntax
C# Visual Basic Visual C++
public string Title{ get; set;}
Public Property Title As String
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
Remarks
For web controls, this title will be shown as a tooltip when the mouse hovers over the area of the object that owns this link. Set the value to Empty()() to have no title.


Url Property

Url Property
Namespaces ► ZedGraph ► Link ► Url
Gets or sets the url string for this link.
Declaration Syntax
C# Visual Basic Visual C++
public string Url{ get; set;}
Public Property Url As String
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}
Remarks
Set this value to Empty()() if you don't want to have a hyperlink associated with the object to which this link belongs.


Location Class

Location Class
Namespaces ► ZedGraph ► Location
A class than contains information about the position of an object on the graph.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Location : ICloneable, ISerializable
<SerializableAttribute> _
Public Class Location _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class Location : ICloneable,
    ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LocationLocationNew()() | Default constructor for the Location class.
 | LocationLocationNew(Double, Double, CoordType) | Constructor for the Location class that specifies the x, y position and the CoordType.
 | LocationLocationNew(Double, Double, CoordType, AlignH, AlignV) | Constructor for the Location class that specifies the x, y position and the CoordType.
 | LocationLocationNew(Double, Double, Double, Double, CoordType, AlignH, AlignV) | Constructor for the Location class that specifies the (x, y), (width, height), and the CoordType.
 | LocationLocationNew(Location) | The Copy Constructor
 | AlignH | A horizontal alignment parameter for this object specified using the AlignH enum type.
 | AlignV | A vertical alignment parameter for this object specified using the AlignV enum type.
 | BottomRight | The bottom-right PointF for this Location.
 | Clone()() | Typesafe, deep-copy clone method.
 | CoordinateFrame | The coordinate system to be used for defining the object position
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Height | The height of the object.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Rect | The RectangleF for this object as defined by the X, Y, Width, and Height properties.
 | schema | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | TopLeft | The top-left PointF for this Location.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Transform(PaneBase) | Transform this Location object to display device coordinates using the properties of the specified GraphPane.
 | Transform(PaneBase, Double, Double, CoordType) | Transform a data point from the specified coordinate type (CoordType) to display device coordinates (pixels).
 | TransformBottomRight(PaneBase) | The PointF for this object as defined by the X2 and Y2 properties.
 | TransformRect(PaneBase) | Transform the RectangleF for this object as defined by the X, Y, Width, and Height properties.
 | TransformTopLeft(PaneBase, Single, Single) | Transform this Location from the coordinate system as specified by CoordinateFrame to the device coordinates of the specified PaneBase object.
 | TransformTopLeft(PaneBase) | The PointF for this object as defined by the X and Y properties.
 | Width | The width of the object.
 | X | The x position of the object.
 | X1 | The x1 position of the object (an alias for the x position).
 | X2 | The x2 position of the object.
 | Y | The y position of the object.
 | Y1 | The y1 position of the object (an alias for the y position).
 | Y2 | The y2 position of the object.
Inheritance Hierarchy
Object
Location


Location Constructor

Location Constructor
Namespaces ► ZedGraph ► Location ► LocationLocationNew()()
Members
Icon | Member | Description
 | LocationLocationNew()() | Default constructor for the Location class.
 | LocationLocationNew(Double, Double, CoordType) | Constructor for the Location class that specifies the x, y position and the CoordType.
 | LocationLocationNew(Double, Double, CoordType, AlignH, AlignV) | Constructor for the Location class that specifies the x, y position and the CoordType.
 | LocationLocationNew(Double, Double, Double, Double, CoordType, AlignH, AlignV) | Constructor for the Location class that specifies the (x, y), (width, height), and the CoordType.
 | LocationLocationNew(Location) | The Copy Constructor


Location Constructor

Location Constructor
Namespaces ► ZedGraph ► Location ► LocationLocationNew()()
Default constructor for the Location class.
Declaration Syntax
C# Visual Basic Visual C++
public Location()
Public Sub New
public:
Location ()


Location Constructor (x, y, width, height, coordType, alignH, alignV)

Location Constructor (x, y, width, height, coordType, alignH, alignV)
Namespaces ► ZedGraph ► Location ► LocationLocationNew(Double, Double, Double, Double, CoordType, AlignH, AlignV)
Constructor for the Location class that specifies the (x, y), (width, height), and the CoordType.
Declaration Syntax
C# Visual Basic Visual C++
public Location(
    double x,
    double y,
    double width,
    double height,
    CoordType coordType,
    AlignH alignH,
    AlignV alignV
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    width As Double, _
    height As Double, _
    coordType As CoordType, _
    alignH As AlignH, _
    alignV As AlignV _
)
public:
Location (
    double x,
    double y,
    double width,
    double height,
    CoordType coordType,
    AlignH alignH,
    AlignV alignV
)
Parameters
x (Double)
The x position, specified in units of .
y (Double)
The y position, specified in units of .
width (Double)
The width, specified in units of .
height (Double)
The height, specified in units of .
coordType (CoordType)
The CoordType enum that specifies the units for and
alignH (AlignH)
The AlignH enum that specifies the horizontal alignment of the object with respect to the (x,y) location
alignV (AlignV)
The AlignV enum that specifies the vertical alignment of the object with respect to the (x,y) location
Remarks
The (x,y) position corresponds to the starting position, the (x2, y2) coorresponds to the ending position (typically used for ArrowObj's).


Location Constructor (x, y, coordType)

Location Constructor (x, y, coordType)
Namespaces ► ZedGraph ► Location ► LocationLocationNew(Double, Double, CoordType)
Constructor for the Location class that specifies the x, y position and the CoordType.
Declaration Syntax
C# Visual Basic Visual C++
public Location(
    double x,
    double y,
    CoordType coordType
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    coordType As CoordType _
)
public:
Location (
    double x,
    double y,
    CoordType coordType
)
Parameters
x (Double)
The x position, specified in units of .
y (Double)
The y position, specified in units of .
coordType (CoordType)
The CoordType enum that specifies the units for and
Remarks
The (x,y) position corresponds to the top-left corner;


Location Constructor (x, y, coordType, alignH, alignV)

Location Constructor (x, y, coordType, alignH, alignV)
Namespaces ► ZedGraph ► Location ► LocationLocationNew(Double, Double, CoordType, AlignH, AlignV)
Constructor for the Location class that specifies the x, y position and the CoordType.
Declaration Syntax
C# Visual Basic Visual C++
public Location(
    double x,
    double y,
    CoordType coordType,
    AlignH alignH,
    AlignV alignV
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    coordType As CoordType, _
    alignH As AlignH, _
    alignV As AlignV _
)
public:
Location (
    double x,
    double y,
    CoordType coordType,
    AlignH alignH,
    AlignV alignV
)
Parameters
x (Double)
The x position, specified in units of .
y (Double)
The y position, specified in units of .
coordType (CoordType)
The CoordType enum that specifies the units for and
alignH (AlignH)
The AlignH enum that specifies the horizontal alignment of the object with respect to the (x,y) location
alignV (AlignV)
The AlignV enum that specifies the vertical alignment of the object with respect to the (x,y) location
Remarks
The (x,y) position corresponds to the top-left corner;


Location Constructor (rhs)

Location Constructor (rhs)
Namespaces ► ZedGraph ► Location ► LocationLocationNew(Location)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public Location(
    Location rhs
)
Public Sub New ( _
    rhs As Location _
)
public:
Location (
    Location^ rhs
)
Parameters
rhs (Location)
The Location object from which to copy


AlignH Property

AlignH Property
Namespaces ► ZedGraph ► Location ► AlignH
A horizontal alignment parameter for this object specified using the AlignH enum type.
Declaration Syntax
C# Visual Basic Visual C++
public AlignH AlignH{ get; set;}
Public Property AlignH As AlignH
public:
property AlignH AlignH {
    AlignH get ();
    void set (AlignH value);
}


AlignV Property

AlignV Property
Namespaces ► ZedGraph ► Location ► AlignV
A vertical alignment parameter for this object specified using the AlignV enum type.
Declaration Syntax
C# Visual Basic Visual C++
public AlignV AlignV{ get; set;}
Public Property AlignV As AlignV
public:
property AlignV AlignV {
    AlignV get ();
    void set (AlignV value);
}


BottomRight Property

BottomRight Property
Namespaces ► ZedGraph ► Location ► BottomRight
The bottom-right PointF for this Location.
Declaration Syntax
C# Visual Basic Visual C++
public PointF BottomRight{ get;}
Public ReadOnly Property BottomRight As PointF
public:
property PointF BottomRight {
    PointF get ();
}
Value
A PointF in CoordinateFrame units.
Remarks
Note that this method reduces the precision of the location coordinates from double precision to single precision. In some cases, such as Date, it may affect the resolution of the point location.


Clone Method

Clone Method
Namespaces ► ZedGraph ► Location ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public Location Clone()
Public Function Clone As Location
public:
Location^ Clone ()
Return Value
A new, independent copy of this class


CoordinateFrame Property

CoordinateFrame Property
Namespaces ► ZedGraph ► Location ► CoordinateFrame
The coordinate system to be used for defining the object position
Declaration Syntax
C# Visual Basic Visual C++
public CoordType CoordinateFrame{ get; set;}
Public Property CoordinateFrame As CoordType
public:
property CoordType CoordinateFrame {
    CoordType get ();
    void set (CoordType value);
}
Value
The coordinate system is defined with the CoordType enum


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► Location ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


Height Property

Height Property
Namespaces ► ZedGraph ► Location ► Height
The height of the object.
Declaration Syntax
C# Visual Basic Visual C++
public double Height{ get; set;}
Public Property Height As Double
public:
property double Height {
    double get ();
    void set (double value);
}
Remarks
The units of this position are specified by the CoordinateFrame property.


Rect Property

Rect Property
Namespaces ► ZedGraph ► Location ► Rect
The RectangleF for this object as defined by the X, Y, Width, and Height properties.
Declaration Syntax
C# Visual Basic Visual C++
public RectangleF Rect{ get; set;}
Public Property Rect As RectangleF
public:
property RectangleF Rect {
    RectangleF get ();
    void set (RectangleF value);
}
Value
A RectangleF in CoordinateFrame units.
Remarks
Note that this method reduces the precision of the location coordinates from double precision to single precision. In some cases, such as Date, it may affect the resolution of the point location.


schema Field

schema Field
Namespaces ► ZedGraph ► Location ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► Location ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


TopLeft Property

TopLeft Property
Namespaces ► ZedGraph ► Location ► TopLeft
The top-left PointF for this Location.
Declaration Syntax
C# Visual Basic Visual C++
public PointF TopLeft{ get; set;}
Public Property TopLeft As PointF
public:
property PointF TopLeft {
    PointF get ();
    void set (PointF value);
}
Value
A PointF in CoordinateFrame units.
Remarks
Note that this method reduces the precision of the location coordinates from double precision to single precision. In some cases, such as Date, it may affect the resolution of the point location.


Transform Method

Transform Method
Namespaces ► ZedGraph ► Location ► Transform()()
Members
Icon | Member | Description
 | Transform(PaneBase) | Transform this Location object to display device coordinates using the properties of the specified GraphPane.
 | Transform(PaneBase, Double, Double, CoordType) | Transform a data point from the specified coordinate type (CoordType) to display device coordinates (pixels).


Transform Method (pane)

Transform Method (pane)
Namespaces ► ZedGraph ► Location ► Transform(PaneBase)
Transform this Location object to display device coordinates using the properties of the specified GraphPane.
Declaration Syntax
C# Visual Basic Visual C++
public PointF Transform(
    PaneBase pane
)
Public Function Transform ( _
    pane As PaneBase _
) As PointF
public:
PointF Transform (
    PaneBase^ pane
)
Parameters
pane (PaneBase)
A reference to the PaneBase object that contains the Axis classes which will be used for the transform.
Return Value
A point in display device coordinates that corresponds to the specified user point.


Transform Method (pane, x, y, coord)

Transform Method (pane, x, y, coord)
Namespaces ► ZedGraph ► Location ► Transform(PaneBase, Double, Double, CoordType)
Transform a data point from the specified coordinate type (CoordType) to display device coordinates (pixels).
Declaration Syntax
C# Visual Basic Visual C++
public static PointF Transform(
    PaneBase pane,
    double x,
    double y,
    CoordType coord
)
Public Shared Function Transform ( _
    pane As PaneBase, _
    x As Double, _
    y As Double, _
    coord As CoordType _
) As PointF
public:
static PointF Transform (
    PaneBase^ pane,
    double x,
    double y,
    CoordType coord
)
Parameters
pane (PaneBase)
A reference to the PaneBase object that contains the Axis classes which will be used for the transform.
x (Double)
The x coordinate that defines the point in user space.
y (Double)
The y coordinate that defines the point in user space.
coord (CoordType)
A CoordType type that defines the coordinate system in which the X,Y pair is defined.
Return Value
A point in display device coordinates that corresponds to the specified user point.
Remarks
If is not of type GraphPane, then only the PaneFraction transformation is available.


TransformBottomRight Method (pane)

TransformBottomRight Method (pane)
Namespaces ► ZedGraph ► Location ► TransformBottomRight(PaneBase)
The PointF for this object as defined by the X2 and Y2 properties.
Declaration Syntax
C# Visual Basic Visual C++
public PointF TransformBottomRight(
    PaneBase pane
)
Public Function TransformBottomRight ( _
    pane As PaneBase _
) As PointF
public:
PointF TransformBottomRight (
    PaneBase^ pane
)
Parameters
pane (PaneBase)
Value
A PointF in pixel units.
Remarks
This method transforms the location to output device pixel units. The AlignH and AlignV properties are ignored for this transformation (see TransformTopLeft(PaneBase, Single, Single)).


TransformRect Method (pane)

TransformRect Method (pane)
Namespaces ► ZedGraph ► Location ► TransformRect(PaneBase)
Transform the RectangleF for this object as defined by the X, Y, Width, and Height properties.
Declaration Syntax
C# Visual Basic Visual C++
public RectangleF TransformRect(
    PaneBase pane
)
Public Function TransformRect ( _
    pane As PaneBase _
) As RectangleF
public:
RectangleF TransformRect (
    PaneBase^ pane
)
Parameters
pane (PaneBase)
Value
A RectangleF in pixel units.
Remarks
This method transforms the location to output device pixel units. The AlignH and AlignV properties are honored in this transformation.


TransformTopLeft Method

TransformTopLeft Method
Namespaces ► ZedGraph ► Location ► TransformTopLeft()()
Members
Icon | Member | Description
 | TransformTopLeft(PaneBase, Single, Single) | Transform this Location from the coordinate system as specified by CoordinateFrame to the device coordinates of the specified PaneBase object.
 | TransformTopLeft(PaneBase) | The PointF for this object as defined by the X and Y properties.


TransformTopLeft Method (pane)

TransformTopLeft Method (pane)
Namespaces ► ZedGraph ► Location ► TransformTopLeft(PaneBase)
The PointF for this object as defined by the X and Y properties.
Declaration Syntax
C# Visual Basic Visual C++
public PointF TransformTopLeft(
    PaneBase pane
)
Public Function TransformTopLeft ( _
    pane As PaneBase _
) As PointF
public:
PointF TransformTopLeft (
    PaneBase^ pane
)
Parameters
pane (PaneBase)
Value
A PointF in pixel units.
Remarks
This method transforms the location to output device pixel units. The AlignH and AlignV properties are ignored for this transformation (see TransformTopLeft(PaneBase, Single, Single)).


TransformTopLeft Method (pane, width, height)

TransformTopLeft Method (pane, width, height)
Namespaces ► ZedGraph ► Location ► TransformTopLeft(PaneBase, Single, Single)
Transform this Location from the coordinate system as specified by CoordinateFrame to the device coordinates of the specified PaneBase object.
Declaration Syntax
C# Visual Basic Visual C++
public PointF TransformTopLeft(
    PaneBase pane,
    float width,
    float height
)
Public Function TransformTopLeft ( _
    pane As PaneBase, _
    width As Single, _
    height As Single _
) As PointF
public:
PointF TransformTopLeft (
    PaneBase^ pane,
    float width,
    float height
)
Parameters
pane (PaneBase)
A reference to the PaneBase object that contains the Axis classes which will be used for the transform.
width (Single)
The width of the object in device pixels
height (Single)
The height of the object in device pixels
Return Value
The top-left corner of the object
Remarks
The returned PointF struct represents the top-left corner of the object that honors the Location properties. The AlignH and AlignV properties are honored in this transformation.


Width Property

Width Property
Namespaces ► ZedGraph ► Location ► Width
The width of the object.
Declaration Syntax
C# Visual Basic Visual C++
public double Width{ get; set;}
Public Property Width As Double
public:
property double Width {
    double get ();
    void set (double value);
}
Remarks
The units of this position are specified by the CoordinateFrame property.


X Property

X Property
Namespaces ► ZedGraph ► Location ► X
The x position of the object.
Declaration Syntax
C# Visual Basic Visual C++
public double X{ get; set;}
Public Property X As Double
public:
property double X {
    double get ();
    void set (double value);
}
Remarks
The units of this position are specified by the CoordinateFrame property. The object will be aligned to this position based on the AlignH property.


X1 Property

X1 Property
Namespaces ► ZedGraph ► Location ► X1
The x1 position of the object (an alias for the x position).
Declaration Syntax
C# Visual Basic Visual C++
public double X1{ get; set;}
Public Property X1 As Double
public:
property double X1 {
    double get ();
    void set (double value);
}
Remarks
The units of this position are specified by the CoordinateFrame property. The object will be aligned to this position based on the AlignH property.


X2 Property

X2 Property
Namespaces ► ZedGraph ► Location ► X2
The x2 position of the object.
Declaration Syntax
C# Visual Basic Visual C++
public double X2{ get;}
Public ReadOnly Property X2 As Double
public:
property double X2 {
    double get ();
}
Remarks
The units of this position are specified by the CoordinateFrame property. The object will be aligned to this position based on the AlignH property. This position is only used for objects such as ArrowObj, where it makes sense to have a second coordinate. Note that the X2 position is stored internally as a Width offset from X.


Y Property

Y Property
Namespaces ► ZedGraph ► Location ► Y
The y position of the object.
Declaration Syntax
C# Visual Basic Visual C++
public double Y{ get; set;}
Public Property Y As Double
public:
property double Y {
    double get ();
    void set (double value);
}
Remarks
The units of this position are specified by the CoordinateFrame property. The object will be aligned to this position based on the AlignV property.


Y1 Property

Y1 Property
Namespaces ► ZedGraph ► Location ► Y1
The y1 position of the object (an alias for the y position).
Declaration Syntax
C# Visual Basic Visual C++
public double Y1{ get; set;}
Public Property Y1 As Double
public:
property double Y1 {
    double get ();
    void set (double value);
}
Remarks
The units of this position are specified by the CoordinateFrame property. The object will be aligned to this position based on the AlignV property.


Y2 Property

Y2 Property
Namespaces ► ZedGraph ► Location ► Y2
The y2 position of the object.
Declaration Syntax
C# Visual Basic Visual C++
public double Y2{ get;}
Public ReadOnly Property Y2 As Double
public:
property double Y2 {
    double get ();
}
Remarks
The units of this position are specified by the CoordinateFrame property. The object will be aligned to this position based on the AlignV property. This position is only used for objects such as ArrowObj, where it makes sense to have a second coordinate. Note that the Y2 position is stored internally as a Height offset from Y.


MajorGrid Class

MajorGrid Class
Namespaces ► ZedGraph ► MajorGrid
Class that handles the data associated with the major grid lines on the chart. Inherits from MinorGrid.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MajorGrid : MinorGrid, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class MajorGrid _
    Inherits MinorGrid _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class MajorGrid : public MinorGrid,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MajorGridMajorGridNew()() | Default constructor
 | MajorGridMajorGridNew(MajorGrid) | Copy constructor
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The color to use for drawing this Axis grid. (Inherited from MinorGrid.)
 | DashOff | The "Dash Off" mode for drawing the grid. (Inherited from MinorGrid.)
 | DashOn | The "Dash On" mode for drawing the grid. (Inherited from MinorGrid.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides MinorGrid.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible | Gets or sets a value that determines if the major Axis gridlines (at each labeled value) will be visible (Inherited from MinorGrid.)
 | IsZeroLine | Gets or sets a boolean value that determines if a line will be drawn at the zero value for the axis.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PenWidth | The pen width used for drawing the grid lines. (Inherited from MinorGrid.)
 | schema2 | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | MinorGrid
 |  | MajorGrid


MajorGrid Constructor

MajorGrid Constructor
Namespaces ► ZedGraph ► MajorGrid ► MajorGridMajorGridNew()()
Members
Icon | Member | Description
 | MajorGridMajorGridNew()() | Default constructor
 | MajorGridMajorGridNew(MajorGrid) | Copy constructor


MajorGrid Constructor

MajorGrid Constructor
Namespaces ► ZedGraph ► MajorGrid ► MajorGridMajorGridNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public MajorGrid()
Public Sub New
public:
MajorGrid ()


MajorGrid Constructor (rhs)

MajorGrid Constructor (rhs)
Namespaces ► ZedGraph ► MajorGrid ► MajorGridMajorGridNew(MajorGrid)
Copy constructor
Declaration Syntax
C# Visual Basic Visual C++
public MajorGrid(
    MajorGrid rhs
)
Public Sub New ( _
    rhs As MajorGrid _
)
public:
MajorGrid (
    MajorGrid^ rhs
)
Parameters
rhs (MajorGrid)
The source MajorGrid to be copied.


Clone Method

Clone Method
Namespaces ► ZedGraph ► MajorGrid ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public MajorGrid Clone()
Public Function Clone As MajorGrid
public:
MajorGrid^ Clone ()
Return Value
A new, independent copy of this class


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► MajorGrid ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsZeroLine Property

IsZeroLine Property
Namespaces ► ZedGraph ► MajorGrid ► IsZeroLine
Gets or sets a boolean value that determines if a line will be drawn at the zero value for the axis.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsZeroLine{ get; set;}
Public Property IsZeroLine As Boolean
public:
property bool IsZeroLine {
    bool get ();
    void set (bool value);
}
Value
true to show the zero line, false otherwise
Remarks
The zero line is a line that divides the negative values from the positive values. The default is set according to IsZeroLine, IsZeroLine, IsZeroLine,


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► MajorGrid ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► MajorGrid ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


MajorGrid.Default Structure

MajorGrid..::Default Structure
Namespaces ► ZedGraph ► MajorGrid ► MajorGrid..::Default
A simple struct that defines the default property values for the MajorGrid class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Color | The default color for the Axis grid lines (Color property). This color only affects the grid lines.
 | DashOff | The default "dash off" size for drawing the Axis grid (DashOff property). Units are in points (1/72 inch).
 | DashOn | The default "dash on" size for drawing the Axis grid (DashOn property). Units are in points (1/72 inch).
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible | The default display mode for the Axis grid lines (IsVisible property). true to show the grid lines, false to hide them.
 | IsZeroLine | The default boolean value that determines if a line will be drawn at the zero value for the axis.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PenWidth | The default pen width for drawing the Axis grid (PenWidth property). Units are in points (1/72 inch).
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


Color Field

Color Field
Namespaces ► ZedGraph ► MajorGrid..::Default ► Color
The default color for the Axis grid lines (Color property). This color only affects the grid lines.
Declaration Syntax
C# Visual Basic Visual C++
public static Color Color
Public Shared Color As Color
public:
static Color Color


DashOff Field

DashOff Field
Namespaces ► ZedGraph ► MajorGrid..::Default ► DashOff
The default "dash off" size for drawing the Axis grid (DashOff property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float DashOff
Public Shared DashOff As Single
public:
static float DashOff


DashOn Field

DashOn Field
Namespaces ► ZedGraph ► MajorGrid..::Default ► DashOn
The default "dash on" size for drawing the Axis grid (DashOn property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float DashOn
Public Shared DashOn As Single
public:
static float DashOn


IsVisible Field

IsVisible Field
Namespaces ► ZedGraph ► MajorGrid..::Default ► IsVisible
The default display mode for the Axis grid lines (IsVisible property). true to show the grid lines, false to hide them.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsVisible
Public Shared IsVisible As Boolean
public:
static bool IsVisible


IsZeroLine Field

IsZeroLine Field
Namespaces ► ZedGraph ► MajorGrid..::Default ► IsZeroLine
The default boolean value that determines if a line will be drawn at the zero value for the axis.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsZeroLine
Public Shared IsZeroLine As Boolean
public:
static bool IsZeroLine
Value
true to show the zero line, false otherwise
Remarks
The zero line is a line that divides the negative values from the positive values. The default is set according to IsZeroLine, IsZeroLine, IsZeroLine,


PenWidth Field

PenWidth Field
Namespaces ► ZedGraph ► MajorGrid..::Default ► PenWidth
The default pen width for drawing the Axis grid (PenWidth property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float PenWidth
Public Shared PenWidth As Single
public:
static float PenWidth


MajorTic Class

MajorTic Class
Namespaces ► ZedGraph ► MajorTic
Class that holds the specific properties for the major tics. Inherits from MinorTic.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MajorTic : MinorTic, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class MajorTic _
    Inherits MinorTic _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class MajorTic : public MinorTic,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MajorTicMajorTicNew()() | Default constructor for MajorTic.
 | MajorTicMajorTicNew(MajorTic) | Copy constructor.
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The color to use for drawing the tics of this class instance (Inherited from MinorTic.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides MinorTic.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAllTics | This is convenience property sets the status of all the different tic properties in this instance to the same value. true to activate all tics, false to clear all tics. (Inherited from MinorTic.)
 | IsBetweenLabels | Gets or sets a property that determines whether or not the major tics will be drawn inbetween the labels, rather than right at the labels.
 | IsCrossInside | Gets or sets the display mode for the Axis major inside "cross" tic marks. (Inherited from MinorTic.)
 | IsCrossOutside | Gets or sets the display mode for the Axis major outside "cross" tic marks. (Inherited from MinorTic.)
 | IsInside | Gets or sets a property that determines whether or not the major inside tic marks are shown. (Inherited from MinorTic.)
 | IsOpposite | Gets or sets a property that determines whether or not the major opposite tic marks are shown. (Inherited from MinorTic.)
 | IsOutside | Gets or sets a property that determines whether or not the minor outside tic marks are shown. (Inherited from MinorTic.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PenWidth | Gets or sets the pen width to be used when drawing the tic marks for this Axis (Inherited from MinorTic.)
 | ScaledTic(Single) | Calculate the scaled tic size for this Axis (Inherited from MinorTic.)
 | schema2 | Current schema value that defines the version of the serialized file
 | Size | The length of the major tic marks. (Inherited from MinorTic.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | MinorTic
 |  | MajorTic


MajorTic Constructor

MajorTic Constructor
Namespaces ► ZedGraph ► MajorTic ► MajorTicMajorTicNew()()
Members
Icon | Member | Description
 | MajorTicMajorTicNew()() | Default constructor for MajorTic.
 | MajorTicMajorTicNew(MajorTic) | Copy constructor.


MajorTic Constructor

MajorTic Constructor
Namespaces ► ZedGraph ► MajorTic ► MajorTicMajorTicNew()()
Default constructor for MajorTic.
Declaration Syntax
C# Visual Basic Visual C++
public MajorTic()
Public Sub New
public:
MajorTic ()


MajorTic Constructor (rhs)

MajorTic Constructor (rhs)
Namespaces ► ZedGraph ► MajorTic ► MajorTicMajorTicNew(MajorTic)
Copy constructor.
Declaration Syntax
C# Visual Basic Visual C++
public MajorTic(
    MajorTic rhs
)
Public Sub New ( _
    rhs As MajorTic _
)
public:
MajorTic (
    MajorTic^ rhs
)
Parameters
rhs (MajorTic)
The MajorTic that is to be copied.


Clone Method

Clone Method
Namespaces ► ZedGraph ► MajorTic ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public MajorTic Clone()
Public Function Clone As MajorTic
public:
MajorTic^ Clone ()
Return Value
A new, independent copy of this class


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► MajorTic ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsBetweenLabels Property

IsBetweenLabels Property
Namespaces ► ZedGraph ► MajorTic ► IsBetweenLabels
Gets or sets a property that determines whether or not the major tics will be drawn inbetween the labels, rather than right at the labels.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsBetweenLabels{ get; set;}
Public Property IsBetweenLabels As Boolean
public:
property bool IsBetweenLabels {
    bool get ();
    void set (bool value);
}
Value
true to place the text between the labels for text axes, false otherwise
Remarks
Note that this setting is only applicable if Type = Text.
See Also
IsOutside
IsInside
IsOpposite
IsCrossOutside
IsCrossInside


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► MajorTic ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► MajorTic ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


MajorTic.Default Structure

MajorTic..::Default Structure
Namespaces ► ZedGraph ► MajorTic ► MajorTic..::Default
A simple struct that defines the default property values for the MinorTic class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Color | The default color for major tics (Color property).
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsCrossInside | The default display mode for the Axis major inside "cross" tic marks (IsCrossInside property).
 | IsCrossOutside | The default display mode for the Axis major outside "cross" tic marks (IsCrossOutside property).
 | IsInside | The display mode for the Axis major inside tic marks (IsInside property). The major tic spacing is controlled by MajorStep.
 | IsOpposite | The display mode for the Axis major opposite tic marks (IsOpposite property). The major tic spacing is controlled by MajorStep.
 | IsOutside | The display mode for the Axis major outside tic marks (IsOutside property). The major tic spacing is controlled by MajorStep.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PenWidth | The default pen width for drawing the Axis tic marks. (PenWidth property). Units are in points (1/72 inch).
 | Size | The default size for the Axis tic marks. (Size property). Units are in points (1/72 inch).
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


Color Field

Color Field
Namespaces ► ZedGraph ► MajorTic..::Default ► Color
The default color for major tics (Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color Color
Public Shared Color As Color
public:
static Color Color


IsCrossInside Field

IsCrossInside Field
Namespaces ► ZedGraph ► MajorTic..::Default ► IsCrossInside
The default display mode for the Axis major inside "cross" tic marks (IsCrossInside property).
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsCrossInside
Public Shared IsCrossInside As Boolean
public:
static bool IsCrossInside
Value
true to show the major cross tic marks, false otherwise
Remarks
The "cross" tics are a special, additional set of tic marks that always appear on the actual axis, even if it has been shifted due to the Cross setting. The other tic marks are always fixed to the edges of the Rect. The cross tics are normally not displayed, since, if CrossAuto is true, they will exactly overlay the "normal" and "inside" tics. If CrossAuto is false, then you will most likely want to enable the cross tics. The major tic spacing is controlled by MajorStep.


IsCrossOutside Field

IsCrossOutside Field
Namespaces ► ZedGraph ► MajorTic..::Default ► IsCrossOutside
The default display mode for the Axis major outside "cross" tic marks (IsCrossOutside property).
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsCrossOutside
Public Shared IsCrossOutside As Boolean
public:
static bool IsCrossOutside
Value
true to show the major cross tic marks, false otherwise
Remarks
The "cross" tics are a special, additional set of tic marks that always appear on the actual axis, even if it has been shifted due to the Cross setting. The other tic marks are always fixed to the edges of the Rect. The cross tics are normally not displayed, since, if CrossAuto is true, they will exactly overlay the "normal" and "inside" tics. If CrossAuto is false, then you will most likely want to enable the cross tics. The major tic spacing is controlled by MajorStep.


IsInside Field

IsInside Field
Namespaces ► ZedGraph ► MajorTic..::Default ► IsInside
The display mode for the Axis major inside tic marks (IsInside property). The major tic spacing is controlled by MajorStep.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsInside
Public Shared IsInside As Boolean
public:
static bool IsInside
Value
true to show the major tic marks (inside the axis), false otherwise


IsOpposite Field

IsOpposite Field
Namespaces ► ZedGraph ► MajorTic..::Default ► IsOpposite
The display mode for the Axis major opposite tic marks (IsOpposite property). The major tic spacing is controlled by MajorStep.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsOpposite
Public Shared IsOpposite As Boolean
public:
static bool IsOpposite
Value
true to show the major tic marks (inside the axis on the opposite side), false otherwise


IsOutside Field

IsOutside Field
Namespaces ► ZedGraph ► MajorTic..::Default ► IsOutside
The display mode for the Axis major outside tic marks (IsOutside property). The major tic spacing is controlled by MajorStep.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsOutside
Public Shared IsOutside As Boolean
public:
static bool IsOutside
Value
true to show the major tic marks (outside the axis), false otherwise


PenWidth Field

PenWidth Field
Namespaces ► ZedGraph ► MajorTic..::Default ► PenWidth
The default pen width for drawing the Axis tic marks. (PenWidth property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float PenWidth
Public Shared PenWidth As Single
public:
static float PenWidth


Size Field

Size Field
Namespaces ► ZedGraph ► MajorTic..::Default ► Size
The default size for the Axis tic marks. (Size property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float Size
Public Shared Size As Single
public:
static float Size


Margin Class

Margin Class
Namespaces ► ZedGraph ► Margin
Class that handles that stores the margin properties for the GraphPane
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Margin : ICloneable, ISerializable
<SerializableAttribute> _
Public Class Margin _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class Margin : ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MarginMarginNew()() | Constructor to build a Margin from the default values.
 | MarginMarginNew(Margin) | Copy constructor
 | All | Concurrently sets all outer margin values to a single value.
 | Bottom | Gets or sets a float value that determines the margin area between the bottom edge of the Rect rectangle and the features of the graph.
 | Clone()() | Typesafe, deep-copy clone method.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Left | Gets or sets a float value that determines the margin area between the left edge of the Rect rectangle and the features of the graph.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Right | Gets or sets a float value that determines the margin area between the right edge of the Rect rectangle and the features of the graph.
 | schema | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Top | Gets or sets a float value that determines the margin area between the top edge of the Rect rectangle and the features of the graph.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Margin


Margin Constructor

Margin Constructor
Namespaces ► ZedGraph ► Margin ► MarginMarginNew()()
Members
Icon | Member | Description
 | MarginMarginNew()() | Constructor to build a Margin from the default values.
 | MarginMarginNew(Margin) | Copy constructor


Margin Constructor

Margin Constructor
Namespaces ► ZedGraph ► Margin ► MarginMarginNew()()
Constructor to build a Margin from the default values.
Declaration Syntax
C# Visual Basic Visual C++
public Margin()
Public Sub New
public:
Margin ()


Margin Constructor (rhs)

Margin Constructor (rhs)
Namespaces ► ZedGraph ► Margin ► MarginMarginNew(Margin)
Copy constructor
Declaration Syntax
C# Visual Basic Visual C++
public Margin(
    Margin rhs
)
Public Sub New ( _
    rhs As Margin _
)
public:
Margin (
    Margin^ rhs
)
Parameters
rhs (Margin)
the Margin instance to be copied.


All Property

All Property
Namespaces ► ZedGraph ► Margin ► All
Concurrently sets all outer margin values to a single value.
Declaration Syntax
C# Visual Basic Visual C++
public float All{ set;}
Public WriteOnly Property All As Single
public:
property float All {
    void set (float value);
}
Value
This value is in units of points (1/72 inch), and is scaled linearly with the graph size.
See Also
IsFontsScaled
Bottom
Left
Right
Top


Bottom Property

Bottom Property
Namespaces ► ZedGraph ► Margin ► Bottom
Gets or sets a float value that determines the margin area between the bottom edge of the Rect rectangle and the features of the graph.
Declaration Syntax
C# Visual Basic Visual C++
public float Bottom{ get; set;}
Public Property Bottom As Single
public:
property float Bottom {
    float get ();
    void set (float value);
}
Value
This value is in units of points (1/72 inch), and is scaled linearly with the graph size.
See Also
Bottom
IsFontsScaled
Left
Right
Top


Clone Method

Clone Method
Namespaces ► ZedGraph ► Margin ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public Margin Clone()
Public Function Clone As Margin
public:
Margin^ Clone ()
Return Value
A new, independent copy of this class


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► Margin ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


Left Property

Left Property
Namespaces ► ZedGraph ► Margin ► Left
Gets or sets a float value that determines the margin area between the left edge of the Rect rectangle and the features of the graph.
Declaration Syntax
C# Visual Basic Visual C++
public float Left{ get; set;}
Public Property Left As Single
public:
property float Left {
    float get ();
    void set (float value);
}
Value
This value is in units of points (1/72 inch), and is scaled linearly with the graph size.
See Also
Left
IsFontsScaled
Right
Top
Bottom


Right Property

Right Property
Namespaces ► ZedGraph ► Margin ► Right
Gets or sets a float value that determines the margin area between the right edge of the Rect rectangle and the features of the graph.
Declaration Syntax
C# Visual Basic Visual C++
public float Right{ get; set;}
Public Property Right As Single
public:
property float Right {
    float get ();
    void set (float value);
}
Value
This value is in units of points (1/72 inch), and is scaled linearly with the graph size.
See Also
Right
IsFontsScaled
Left
Top
Bottom


schema Field

schema Field
Namespaces ► ZedGraph ► Margin ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► Margin ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Top Property

Top Property
Namespaces ► ZedGraph ► Margin ► Top
Gets or sets a float value that determines the margin area between the top edge of the Rect rectangle and the features of the graph.
Declaration Syntax
C# Visual Basic Visual C++
public float Top{ get; set;}
Public Property Top As Single
public:
property float Top {
    float get ();
    void set (float value);
}
Value
This value is in units of points (1/72 inch), and is scaled linearly with the graph size.
See Also
Top
IsFontsScaled
Left
Right
Bottom


Margin.Default Class

Margin..::Default Class
Namespaces ► ZedGraph ► Margin ► Margin..::Default
A simple struct that defines the default property values for the Margin class.
Declaration Syntax
C# Visual Basic Visual C++
public class Default
Public Class Default
public ref class Default
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Margin..::DefaultMargin..::DefaultNew()() |
 | Bottom | The default value for the Bottom property, which is the size of the space on the bottom side of the Rect.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Left | The default value for the Left property, which is the size of the space on the left side of the Rect.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Right | The default value for the Right property, which is the size of the space on the right side of the Rect.
 | Top | The default value for the Top property, which is the size of the space on the top side of the Rect.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Margin..::Default


Margin.Default Constructor

Margin..::Default Constructor
Namespaces ► ZedGraph ► Margin..::Default ► Margin..::DefaultMargin..::DefaultNew()()
Declaration Syntax
C# Visual Basic Visual C++
public Default()
Public Sub New
public:
Default ()


Bottom Field

Bottom Field
Namespaces ► ZedGraph ► Margin..::Default ► Bottom
The default value for the Bottom property, which is the size of the space on the bottom side of the Rect.
Declaration Syntax
C# Visual Basic Visual C++
public static float Bottom
Public Shared Bottom As Single
public:
static float Bottom
Value
Units are points (1/72 inch)


Left Field

Left Field
Namespaces ► ZedGraph ► Margin..::Default ► Left
The default value for the Left property, which is the size of the space on the left side of the Rect.
Declaration Syntax
C# Visual Basic Visual C++
public static float Left
Public Shared Left As Single
public:
static float Left
Value
Units are points (1/72 inch)


Right Field

Right Field
Namespaces ► ZedGraph ► Margin..::Default ► Right
The default value for the Right property, which is the size of the space on the right side of the Rect.
Declaration Syntax
C# Visual Basic Visual C++
public static float Right
Public Shared Right As Single
public:
static float Right
Value
Units are points (1/72 inch)


Top Field

Top Field
Namespaces ► ZedGraph ► Margin..::Default ► Top
The default value for the Top property, which is the size of the space on the top side of the Rect.
Declaration Syntax
C# Visual Basic Visual C++
public static float Top
Public Shared Top As Single
public:
static float Top
Value
Units are points (1/72 inch)


MasterPane Class

MasterPane Class
Namespaces ► ZedGraph ► MasterPane
A collection class containing a list of GraphPane objects organized together in some form.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MasterPane : PaneBase, ICloneable,
    ISerializable, IDeserializationCallback
<SerializableAttribute> _
Public Class MasterPane _
    Inherits PaneBase _
    Implements ICloneable, ISerializable, IDeserializationCallback
[SerializableAttribute]
public ref class MasterPane : public PaneBase,
    ICloneable, ISerializable, IDeserializationCallback
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MasterPaneMasterPaneNew()() | Default constructor for the class. Sets the Rect to (0, 0, 500, 375).
 | MasterPaneMasterPaneNew(String, RectangleF) | Default constructor for the class. Specifies the Title of the MasterPane, and the size of the Rect.
 | MasterPaneMasterPaneNew(MasterPane) | The Copy Constructor - Make a deep-copy clone of this class instance.
 | Add(GraphPane) | Add a GraphPane object to the PaneList collection at the end of the list.
 | AxisChange()() | Call AxisChange()() for all GraphPane objects in the PaneList list.
 | AxisChange(Graphics) | Call AxisChange()() for all GraphPane objects in the PaneList list.
 | BaseDimension | BaseDimension is a double precision value that sets "normal" pane size on which all the settings are based. The BaseDimension is in inches. For example, if the BaseDimension is 8.0 inches and the Title size is 14 points. Then the pane title font will be 14 points high when the Rect is approximately 8.0 inches wide. If the Rect is 4.0 inches wide, the pane title font will be 7 points high. Most features of the graph are scaled in this manner. (Inherited from PaneBase.)
 | Border | Gets or sets the Border class for drawing the border border around the Rect (Inherited from PaneBase.)
 | CalcClientRect(Graphics, Single) | Calculate the client area rectangle based on the Rect. (Inherited from PaneBase.)
 | CalcScaleFactor()() | Calculate the scaling factor based on the ratio of the current Rect dimensions and the BaseDimension. (Inherited from PaneBase.)
 | Clone()() | Typesafe, deep-copy clone method.
 | CommonScaleFactor()() | Method that forces the scale factor calculations (via CalcScaleFactor()()), to give a common scale factor for all GraphPane objects in the PaneList.
 | DoLayout(Graphics) | Modify the GraphPane Rect sizes of each GraphPane such that they fit within the MasterPane in a pre-configured layout.
 | Draw(Graphics) | Render all the GraphPane objects in the PaneList to the specified graphics device. (Overrides PaneBase.Draw(Graphics).)
 | DrawPaneFrame(Graphics, Single) | Draw the border _border around the Rect area. (Inherited from PaneBase.)
 | DrawTitle(Graphics, Single) | Draw the Title on the graph, centered at the top of the pane. (Inherited from PaneBase.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Gets or sets the Fill data for the filling the background of the Rect. (Inherited from PaneBase.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindChartRect(PointF) | Find the GraphPane within the PaneList that contains the within its Rect.
 | FindNearestPaneObject(PointF, Graphics, GraphPane%, Object%, Int32%) | Find the pane and the object within that pane that lies closest to the specified mouse (screen) point.
 | FindPane(PointF) | Find the GraphPane within the PaneList that contains the within its Rect.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetImage()() | Build a Bitmap object containing the graphical rendering of all the GraphPane objects in this list. (Inherited from PaneBase.)
 | GetImage(Int32, Int32, Single) | Gets an image for the current GraphPane, scaled to the specified size and resolution. (Inherited from PaneBase.)
 | GetMetafile(Int32, Int32) | Gets an enhanced metafile image for the current GraphPane, scaled to the specified size. (Inherited from PaneBase.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides PaneBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GraphObjList | Gets or sets the list of GraphObj items for this GraphPane (Inherited from PaneBase.)
 | InnerPaneGap | Gets or sets the size of the margin between adjacent GraphPane objects.
 | IsCommonScaleFactor | Gets or sets a value that determines if the DoLayout(Graphics) method will automatically set the BaseDimension of each GraphPane in the PaneList such that the scale factors have the same value.
 | IsFontsScaled | Determines if the font sizes, tic sizes, gap sizes, etc. will be scaled according to the size of the Rect and the BaseDimension. If this value is set to false, then the font sizes and tic sizes will always be exactly as specified, without any scaling. (Inherited from PaneBase.)
 | IsPenWidthScaled | Gets or sets the property that controls whether or not pen widths are scaled for this PaneBase. (Inherited from PaneBase.)
 | IsUniformLegendEntries | Gets or set the value of the IsUniformLegendEntries
 | Item[([Int32])] | Indexer to access the specified GraphPane object from PaneList by its ordinal position in the list.
 | Item[([String])] | Indexer to access the specified GraphPane object from PaneList by its Title string.
 | Legend | Accesses the Legend for this PaneBase (Inherited from PaneBase.)
 | Margin | Gets or sets the Margin instance that controls the space between the edge of the Rect and the rendered content of the graph. (Inherited from PaneBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnDeserialization(Object) | Respond to the callback when the MasterPane objects are fully initialized.
 | PaneList | Gets or sets the PaneList collection instance that holds the list of GraphPane objects that are included in this MasterPane.
 | Rect | The rectangle that defines the full area into which all graphics will be rendered. (Inherited from PaneBase.)
 | ReSize(Graphics) | Redo the layout using the current size of the Rect, and also handle resizing the contents by calling DoLayout(Graphics).
 | ReSize(Graphics, RectangleF) | Change the size of the Rect, and also handle resizing the contents by calling DoLayout(Graphics). (Overrides PaneBase.ReSize(Graphics, RectangleF).)
 | ScaledPenWidth(Single, Single) | Calculate the scaled pen width, taking into account the scaleFactor and the setting of the IsPenWidthScaled property of the pane. (Inherited from PaneBase.)
 | schema2 | Current schema value that defines the version of the serialized file
 | SetLayout(Graphics, PaneLayout) | Automatically set all of the GraphPane Rect's in the list to a pre-defined layout configuration from a PaneLayout enumeration.
 | SetLayout(Graphics, Int32, Int32) | Automatically set all of the GraphPane Rect's in the list to a reasonable configuration.
 | SetLayout(Graphics, Boolean, array<Int32>[]()) | Automatically set all of the GraphPane Rect's in the list to the specified configuration.
 | SetLayout(Graphics, Boolean, array<Int32>[](), array<Single>[]()) | Automatically set all of the GraphPane Rect's in the list to the specified configuration.
 | ShallowClone()() | Create a shallow, memberwise copy of this class. (Inherited from PaneBase.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()() to make a deep copy.
 | Tag | Gets or sets the user-defined tag for this PaneBase. This tag can be any user-defined value. If it is a String type, it can be used as a parameter to the IndexOfTag(String) method. (Inherited from PaneBase.)
 | Title | Gets the Label instance that contains the text and attributes of the title. This text can be multiple lines separated by newline characters ('\n'). (Inherited from PaneBase.)
 | TitleGap | Gets or sets the gap between the bottom of the pane title and the client area of the pane. This is expressed as a fraction of the scaled Title character height. (Inherited from PaneBase.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PaneBase
 |  | MasterPane


MasterPane Constructor

MasterPane Constructor
Namespaces ► ZedGraph ► MasterPane ► MasterPaneMasterPaneNew()()
Members
Icon | Member | Description
 | MasterPaneMasterPaneNew()() | Default constructor for the class. Sets the Rect to (0, 0, 500, 375).
 | MasterPaneMasterPaneNew(String, RectangleF) | Default constructor for the class. Specifies the Title of the MasterPane, and the size of the Rect.
 | MasterPaneMasterPaneNew(MasterPane) | The Copy Constructor - Make a deep-copy clone of this class instance.


MasterPane Constructor

MasterPane Constructor
Namespaces ► ZedGraph ► MasterPane ► MasterPaneMasterPaneNew()()
Default constructor for the class. Sets the Rect to (0, 0, 500, 375).
Declaration Syntax
C# Visual Basic Visual C++
public MasterPane()
Public Sub New
public:
MasterPane ()


MasterPane Constructor (title, paneRect)

MasterPane Constructor (title, paneRect)
Namespaces ► ZedGraph ► MasterPane ► MasterPaneMasterPaneNew(String, RectangleF)
Default constructor for the class. Specifies the Title of the MasterPane, and the size of the Rect.
Declaration Syntax
C# Visual Basic Visual C++
public MasterPane(
    string title,
    RectangleF paneRect
)
Public Sub New ( _
    title As String, _
    paneRect As RectangleF _
)
public:
MasterPane (
    String^ title,
    RectangleF paneRect
)
Parameters
title (String)
paneRect (RectangleF)


MasterPane Constructor (rhs)

MasterPane Constructor (rhs)
Namespaces ► ZedGraph ► MasterPane ► MasterPaneMasterPaneNew(MasterPane)
The Copy Constructor - Make a deep-copy clone of this class instance.
Declaration Syntax
C# Visual Basic Visual C++
public MasterPane(
    MasterPane rhs
)
Public Sub New ( _
    rhs As MasterPane _
)
public:
MasterPane (
    MasterPane^ rhs
)
Parameters
rhs (MasterPane)
The MasterPane object from which to copy


Add Method (pane)

Add Method (pane)
Namespaces ► ZedGraph ► MasterPane ► Add(GraphPane)
Add a GraphPane object to the PaneList collection at the end of the list.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    GraphPane pane
)
Public Sub Add ( _
    pane As GraphPane _
)
public:
void Add (
    GraphPane^ pane
)
Parameters
pane (GraphPane)
A reference to the GraphPane object to be added
See Also
Add(Object)


AxisChange Method

AxisChange Method
Namespaces ► ZedGraph ► MasterPane ► AxisChange()()
Members
Icon | Member | Description
 | AxisChange()() | Call AxisChange()() for all GraphPane objects in the PaneList list.
 | AxisChange(Graphics) | Call AxisChange()() for all GraphPane objects in the PaneList list.


AxisChange Method

AxisChange Method
Namespaces ► ZedGraph ► MasterPane ► AxisChange()()
Call AxisChange()() for all GraphPane objects in the PaneList list.
Declaration Syntax
C# Visual Basic Visual C++
public void AxisChange()
Public Sub AxisChange
public:
void AxisChange ()
Remarks
This overload of AxisChange just uses the default Graphics instance for the screen. If you have a Graphics instance available from your Windows Form, you should use the AxisChange(Graphics) overload instead.


AxisChange Method (g)

AxisChange Method (g)
Namespaces ► ZedGraph ► MasterPane ► AxisChange(Graphics)
Call AxisChange()() for all GraphPane objects in the PaneList list.
Declaration Syntax
C# Visual Basic Visual C++
public void AxisChange(
    Graphics g
)
Public Sub AxisChange ( _
    g As Graphics _
)
public:
void AxisChange (
    Graphics^ g
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.


Clone Method

Clone Method
Namespaces ► ZedGraph ► MasterPane ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public MasterPane Clone()
Public Function Clone As MasterPane
public:
MasterPane^ Clone ()
Return Value
A new, independent copy of this class


CommonScaleFactor Method

CommonScaleFactor Method
Namespaces ► ZedGraph ► MasterPane ► CommonScaleFactor()()
Method that forces the scale factor calculations (via CalcScaleFactor()()), to give a common scale factor for all GraphPane objects in the PaneList.
Declaration Syntax
C# Visual Basic Visual C++
public void CommonScaleFactor()
Public Sub CommonScaleFactor
public:
void CommonScaleFactor ()
Remarks
This will make it such that a given font size will result in the same output font size for all GraphPane's. Note that this does not make the scale factor for the GraphPane's the same as that of the MasterPane.
See Also
IsCommonScaleFactor


DoLayout Method (g)

DoLayout Method (g)
Namespaces ► ZedGraph ► MasterPane ► DoLayout(Graphics)
Modify the GraphPane Rect sizes of each GraphPane such that they fit within the MasterPane in a pre-configured layout.
Declaration Syntax
C# Visual Basic Visual C++
public void DoLayout(
    Graphics g
)
Public Sub DoLayout ( _
    g As Graphics _
)
public:
void DoLayout (
    Graphics^ g
)
Parameters
g (Graphics)
Remarks
The SetLayout(Graphics, PaneLayout) method (and overloads) is used for setting the layout configuration.
See Also
SetLayout(Graphics, PaneLayout)
SetLayout(Graphics, Int32, Int32)
SetLayout(Graphics, Boolean, array<Int32>[]())
SetLayout(Graphics, Boolean, array<Int32>[](), array<Single>[]())


Draw Method (g)

Draw Method (g)
Namespaces ► ZedGraph ► MasterPane ► Draw(Graphics)
Render all the GraphPane objects in the PaneList to the specified graphics device.
Declaration Syntax
C# Visual Basic Visual C++
public override void Draw(
    Graphics g
)
Public Overrides Sub Draw ( _
    g As Graphics _
)
public:
virtual void Draw (
    Graphics^ g
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
Remarks
This method should be part of the Paint() update process. Calling this routine will redraw all features of all the GraphPane items. No preparation is required other than instantiated GraphPane objects that have been added to the list with the Add(GraphPane) method.


FindChartRect Method (mousePt)

FindChartRect Method (mousePt)
Namespaces ► ZedGraph ► MasterPane ► FindChartRect(PointF)
Find the GraphPane within the PaneList that contains the within its Rect.
Declaration Syntax
C# Visual Basic Visual C++
public GraphPane FindChartRect(
    PointF mousePt
)
Public Function FindChartRect ( _
    mousePt As PointF _
) As GraphPane
public:
GraphPane^ FindChartRect (
    PointF mousePt
)
Parameters
mousePt (PointF)
The mouse point location where you want to search
Return Value
A GraphPane object that contains the mouse point, or null if no GraphPane was found.


FindNearestPaneObject Method (mousePt, g, pane, nearestObj, index)

FindNearestPaneObject Method (mousePt, g, pane, nearestObj, index)
Namespaces ► ZedGraph ► MasterPane ► FindNearestPaneObject(PointF, Graphics, GraphPane%, Object%, Int32%)
Find the pane and the object within that pane that lies closest to the specified mouse (screen) point.
Declaration Syntax
C# Visual Basic Visual C++
public bool FindNearestPaneObject(
    PointF mousePt,
    Graphics g,
    out GraphPane pane,
    out Object nearestObj,
    out int index
)
Public Function FindNearestPaneObject ( _
    mousePt As PointF, _
    g As Graphics, _
    <OutAttribute> ByRef pane As GraphPane, _
    <OutAttribute> ByRef nearestObj As Object, _
    <OutAttribute> ByRef index As Integer _
) As Boolean
public:
bool FindNearestPaneObject (
    PointF mousePt,
    Graphics^ g,
    [OutAttribute] GraphPane^% pane,
    [OutAttribute] Object^% nearestObj,
    [OutAttribute] int% index
)
Parameters
mousePt (PointF)
The screen point, in pixel coordinates.
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane %)
A reference to the GraphPane object that was clicked.
nearestObj (Object %)
A reference to the nearest object to the specified screen point. This can be any of Axis, Legend, Title, TextObj, ArrowObj, or CurveItem. Note: If the pane title is selected, then the GraphPane object will be returned.
index (Int32 %)
The index number of the item within the selected object (where applicable). For example, for a CurveItem object, will be the index number of the nearest data point, accessible via CurveItem.Points[index]. index will be -1 if no data points are available.
Return Value
true if a GraphPane was found, false otherwise.
Remarks
This method first finds the GraphPane within the list that contains the specified mouse point. It then calls the FindNearestObject(PointF, Graphics, Object%, Int32%) method to determine which object, if any, was clicked. With the exception of the , all the parameters in this method are identical to those in the FindNearestObject(PointF, Graphics, Object%, Int32%) method. If the mouse point lies within the Rect of any GraphPane item, then that pane will be returned (otherwise it will be null). Further, within the selected pane, if the mouse point is within the bounding box of any of the items (or in the case of ArrowObj and CurveItem, within NearestTol pixels), then the object will be returned. You must check the type of the object to determine what object was selected (for example, "if ( object is Legend ) ..."). The parameter returns the index number of the item within the selected object (such as the point number within a CurveItem object.
See Also
FindNearestObject(PointF, Graphics, Object%, Int32%)


FindPane Method (mousePt)

FindPane Method (mousePt)
Namespaces ► ZedGraph ► MasterPane ► FindPane(PointF)
Find the GraphPane within the PaneList that contains the within its Rect.
Declaration Syntax
C# Visual Basic Visual C++
public GraphPane FindPane(
    PointF mousePt
)
Public Function FindPane ( _
    mousePt As PointF _
) As GraphPane
public:
GraphPane^ FindPane (
    PointF mousePt
)
Parameters
mousePt (PointF)
The mouse point location where you want to search
Return Value
A GraphPane object that contains the mouse point, or null if no GraphPane was found.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► MasterPane ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


InnerPaneGap Property

InnerPaneGap Property
Namespaces ► ZedGraph ► MasterPane ► InnerPaneGap
Gets or sets the size of the margin between adjacent GraphPane objects.
Declaration Syntax
C# Visual Basic Visual C++
public float InnerPaneGap{ get; set;}
Public Property InnerPaneGap As Single
public:
property float InnerPaneGap {
    float get ();
    void set (float value);
}
Value
The value is in points (1/72nd inch).
Remarks
This property is scaled according to CalcScaleFactor()(), based on BaseDimension. The default value comes from InnerPaneGap.


IsCommonScaleFactor Property

IsCommonScaleFactor Property
Namespaces ► ZedGraph ► MasterPane ► IsCommonScaleFactor
Gets or sets a value that determines if the DoLayout(Graphics) method will automatically set the BaseDimension of each GraphPane in the PaneList such that the scale factors have the same value.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCommonScaleFactor{ get; set;}
Public Property IsCommonScaleFactor As Boolean
public:
property bool IsCommonScaleFactor {
    bool get ();
    void set (bool value);
}
Remarks
The scale factors, calculated by CalcScaleFactor()(), determine scaled font sizes, tic lengths, etc. This function will insure that for multiple graphpanes, a certain specified font size will be the same for all the panes.
See Also
SetLayout(Graphics, PaneLayout)
SetLayout(Graphics, Int32, Int32)
SetLayout(Graphics, Boolean, array<Int32>[]())
SetLayout(Graphics, Boolean, array<Int32>[](), array<Single>[]())
ReSize(Graphics, RectangleF)


IsUniformLegendEntries Property

IsUniformLegendEntries Property
Namespaces ► ZedGraph ► MasterPane ► IsUniformLegendEntries
Gets or set the value of the IsUniformLegendEntries
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUniformLegendEntries{ get; set;}
Public Property IsUniformLegendEntries As Boolean
public:
property bool IsUniformLegendEntries {
    bool get ();
    void set (bool value);
}


Item Property

Item Property
Namespaces ► ZedGraph ► MasterPane ► Item
Members
Icon | Member | Description
 | Item[([Int32])] | Indexer to access the specified GraphPane object from PaneList by its ordinal position in the list.
 | Item[([String])] | Indexer to access the specified GraphPane object from PaneList by its Title string.


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph ► MasterPane ► Item[([Int32])]
Indexer to access the specified GraphPane object from PaneList by its ordinal position in the list.
Declaration Syntax
C# Visual Basic Visual C++
public GraphPane this[
    int index
]{ get; set;}
Public Default Property Item ( _
    index As Integer _
) As GraphPane
public:
property GraphPane^ default[int index] {
    GraphPane^ get (int index);
    void set (int index, GraphPane^ value);
}
Parameters
index (Int32)
The ordinal position (zero-based) of the GraphPane object to be accessed.
Value
A GraphPane object reference.


Item Property (title)

Item Property (title)
Namespaces ► ZedGraph ► MasterPane ► Item[([String])]
Indexer to access the specified GraphPane object from PaneList by its Title string.
Declaration Syntax
C# Visual Basic Visual C++
public GraphPane this[
    string title
]{ get;}
Public ReadOnly Default Property Item ( _
    title As String _
) As GraphPane
public:
property GraphPane^ default[String^ title] {
    GraphPane^ get (String^ title);
}
Parameters
title (String)
The string title of the GraphPane object to be accessed.
Value
A GraphPane object reference.


OnDeserialization Method (sender)

OnDeserialization Method (sender)
Namespaces ► ZedGraph ► MasterPane ► OnDeserialization(Object)
Respond to the callback when the MasterPane objects are fully initialized.
Declaration Syntax
C# Visual Basic Visual C++
public void OnDeserialization(
    Object sender
)
Public Sub OnDeserialization ( _
    sender As Object _
)
public:
virtual void OnDeserialization (
    Object^ sender
) sealed
Parameters
sender (Object)


PaneList Property

PaneList Property
Namespaces ► ZedGraph ► MasterPane ► PaneList
Gets or sets the PaneList collection instance that holds the list of GraphPane objects that are included in this MasterPane.
Declaration Syntax
C# Visual Basic Visual C++
public PaneList PaneList{ get; set;}
Public Property PaneList As PaneList
public:
property PaneList^ PaneList {
    PaneList^ get ();
    void set (PaneList^ value);
}
See Also
Add(GraphPane)
Item[([Int32])]


ReSize Method

ReSize Method
Namespaces ► ZedGraph ► MasterPane ► ReSize()()
Members
Icon | Member | Description
 | ReSize(Graphics) | Redo the layout using the current size of the Rect, and also handle resizing the contents by calling DoLayout(Graphics).
 | ReSize(Graphics, RectangleF) | Change the size of the Rect, and also handle resizing the contents by calling DoLayout(Graphics). (Overrides PaneBase.ReSize(Graphics, RectangleF).)


ReSize Method (g)

ReSize Method (g)
Namespaces ► ZedGraph ► MasterPane ► ReSize(Graphics)
Redo the layout using the current size of the Rect, and also handle resizing the contents by calling DoLayout(Graphics).
Declaration Syntax
C# Visual Basic Visual C++
public void ReSize(
    Graphics g
)
Public Sub ReSize ( _
    g As Graphics _
)
public:
void ReSize (
    Graphics^ g
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
Remarks
This method will use the pane layout that was specified by a call to SetLayout(Graphics, PaneLayout). If SetLayout(Graphics, PaneLayout) has not previously been called, it will default to PaneLayout.
See Also
SetLayout(Graphics, PaneLayout)
SetLayout(Graphics, Int32, Int32)
SetLayout(Graphics, Boolean, array<Int32>[]())
SetLayout(Graphics, Boolean, array<Int32>[](), array<Single>[]())


ReSize Method (g, rect)

ReSize Method (g, rect)
Namespaces ► ZedGraph ► MasterPane ► ReSize(Graphics, RectangleF)
Change the size of the Rect, and also handle resizing the contents by calling DoLayout(Graphics).
Declaration Syntax
C# Visual Basic Visual C++
public override void ReSize(
    Graphics g,
    RectangleF rect
)
Public Overrides Sub ReSize ( _
    g As Graphics, _
    rect As RectangleF _
)
public:
virtual void ReSize (
    Graphics^ g,
    RectangleF rect
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
rect (RectangleF)
Remarks
This method will use the pane layout that was specified by a call to SetLayout(Graphics, PaneLayout). If SetLayout(Graphics, PaneLayout) has not previously been called, it will default to PaneLayout.
See Also
SetLayout(Graphics, PaneLayout)
SetLayout(Graphics, Int32, Int32)
SetLayout(Graphics, Boolean, array<Int32>[]())
SetLayout(Graphics, Boolean, array<Int32>[](), array<Single>[]())


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► MasterPane ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


SetLayout Method

SetLayout Method
Namespaces ► ZedGraph ► MasterPane ► SetLayout()()
The SetLayout() methods setup the desired layout of the GraphPane objects within a MasterPane. These functions do not make any changes, they merely set the parameters so that future calls to ReSize(Graphics, RectangleF) or DoLayout(Graphics) will use the desired layout.

The layout options include a set of "canned" layouts provided by the PaneLayout enumeration, options to just set a specific number of rows and columns of panes (and all pane sizes are the same), and more customized options of specifying the number or rows in each column or the number of columns in each row, along with proportional values that determine the size of each individual column or row.
Members
Icon | Member | Description
 | SetLayout(Graphics, PaneLayout) | Automatically set all of the GraphPane Rect's in the list to a pre-defined layout configuration from a PaneLayout enumeration.
 | SetLayout(Graphics, Int32, Int32) | Automatically set all of the GraphPane Rect's in the list to a reasonable configuration.
 | SetLayout(Graphics, Boolean, array<Int32>[]()) | Automatically set all of the GraphPane Rect's in the list to the specified configuration.
 | SetLayout(Graphics, Boolean, array<Int32>[](), array<Single>[]()) | Automatically set all of the GraphPane Rect's in the list to the specified configuration.


SetLayout Method (g, isColumnSpecified, countList)

SetLayout Method (g, isColumnSpecified, countList)
Namespaces ► ZedGraph ► MasterPane ► SetLayout(Graphics, Boolean, array<Int32>[]())
Automatically set all of the GraphPane Rect's in the list to the specified configuration.
Declaration Syntax
C# Visual Basic Visual C++
public void SetLayout(
    Graphics g,
    bool isColumnSpecified,
    int[] countList
)
Public Sub SetLayout ( _
    g As Graphics, _
    isColumnSpecified As Boolean, _
    countList As Integer() _
)
public:
void SetLayout (
    Graphics^ g,
    bool isColumnSpecified,
    array<int>^ countList
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally created with a call to the CreateGraphics() method of the Control or Form.
isColumnSpecified (Boolean)
Specifies whether the number of columns in each row, or the number of rows in each column will be specified. A value of true indicates the number of columns in each row are specified in .
countList (array< Int32 >[]())
An integer array specifying either the number of columns in each row or the number of rows in each column, depending on the value of .
Remarks
This method specifies the number of rows in each column, or the number of columns in each row, allowing for irregular layouts. Overloads are available that provide other layout options.
See Also
SetLayout(Graphics, PaneLayout)
SetLayout(Graphics, Int32, Int32)
SetLayout(Graphics, Boolean, array<Int32>[](), array<Single>[]())


SetLayout Method (g, isColumnSpecified, countList, proportion)

SetLayout Method (g, isColumnSpecified, countList, proportion)
Namespaces ► ZedGraph ► MasterPane ► SetLayout(Graphics, Boolean, array<Int32>[](), array<Single>[]())
Automatically set all of the GraphPane Rect's in the list to the specified configuration.
Declaration Syntax
C# Visual Basic Visual C++
public void SetLayout(
    Graphics g,
    bool isColumnSpecified,
    int[] countList,
    float[] proportion
)
Public Sub SetLayout ( _
    g As Graphics, _
    isColumnSpecified As Boolean, _
    countList As Integer(), _
    proportion As Single() _
)
public:
void SetLayout (
    Graphics^ g,
    bool isColumnSpecified,
    array<int>^ countList,
    array<float>^ proportion
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally created with a call to the CreateGraphics() method of the Control or Form.
isColumnSpecified (Boolean)
Specifies whether the number of columns in each row, or the number of rows in each column will be specified. A value of true indicates the number of columns in each row are specified in .
countList (array< Int32 >[]())
An integer array specifying either the number of columns in each row or the number of rows in each column, depending on the value of .
proportion (array< Single >[]())
An array of float values specifying proportional sizes for each row or column. Note that these proportions apply to the non-specified dimension -- that is, if is true, then these proportions apply to the row heights, and if is false, then these proportions apply to the column widths. The values in this array are arbitrary floats -- the dimension of any given row or column is that particular proportional value divided by the sum of all the values. For example, let be true, and is an array with values of { 1.0, 2.0, 3.0 }. The sum of those values is 6.0. Therefore, the first row is 1/6th of the available height, the second row is 2/6th's of the available height, and the third row is 3/6th's of the available height.
Remarks
This method specifies the number of panes in each row or column, allowing for irregular layouts.
Remarks
This method specifies the number of rows in each column, or the number of columns in each row, allowing for irregular layouts. Additionally, a parameter is provided that allows varying column or row sizes. Overloads for SetLayout() are available that provide other layout options.
See Also
SetLayout(Graphics, PaneLayout)
SetLayout(Graphics, Int32, Int32)
SetLayout(Graphics, Boolean, array<Int32>[]())


SetLayout Method (g, rows, columns)

SetLayout Method (g, rows, columns)
Namespaces ► ZedGraph ► MasterPane ► SetLayout(Graphics, Int32, Int32)
Automatically set all of the GraphPane Rect's in the list to a reasonable configuration.
Declaration Syntax
C# Visual Basic Visual C++
public void SetLayout(
    Graphics g,
    int rows,
    int columns
)
Public Sub SetLayout ( _
    g As Graphics, _
    rows As Integer, _
    columns As Integer _
)
public:
void SetLayout (
    Graphics^ g,
    int rows,
    int columns
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally created with a call to the CreateGraphics() method of the Control or Form.
rows (Int32)
The number of rows of GraphPane objects to include in the layout
columns (Int32)
The number of columns of GraphPane objects to include in the layout
Remarks
This method explicitly specifies the number of rows and columns to use in the layout, and all GraphPane objects will have the same size. Overloads are available that provide other layout options
See Also
SetLayout(Graphics, PaneLayout)
SetLayout(Graphics, Boolean, array<Int32>[]())
SetLayout(Graphics, Boolean, array<Int32>[](), array<Single>[]())


SetLayout Method (g, paneLayout)

SetLayout Method (g, paneLayout)
Namespaces ► ZedGraph ► MasterPane ► SetLayout(Graphics, PaneLayout)
Automatically set all of the GraphPane Rect's in the list to a pre-defined layout configuration from a PaneLayout enumeration.
Declaration Syntax
C# Visual Basic Visual C++
public void SetLayout(
    Graphics g,
    PaneLayout paneLayout
)
Public Sub SetLayout ( _
    g As Graphics, _
    paneLayout As PaneLayout _
)
public:
void SetLayout (
    Graphics^ g,
    PaneLayout paneLayout
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally created with a call to the CreateGraphics() method of the Control or Form.
paneLayout (PaneLayout)
A PaneLayout enumeration that describes how the panes should be laid out within the Rect.
Remarks
This method uses a PaneLayout enumeration to describe the type of layout to be used. Overloads are available that provide other layout options
See Also
SetLayout(Graphics, Int32, Int32)
SetLayout(Graphics, Boolean, array<Int32>[]())
SetLayout(Graphics, Boolean, array<Int32>[](), array<Single>[]())


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► MasterPane ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()() to make a deep copy.
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


MasterPane.Default Structure

MasterPane..::Default Structure
Namespaces ► ZedGraph ► MasterPane ► MasterPane..::Default
A simple struct that defines the default property values for the MasterPane class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerPaneGap | The default value for the InnerPaneGap property. This is the size of the margin between adjacent GraphPane objects, in units of points (1/72 inch).
 | IsCommonScaleFactor | The default value for the IsCommonScaleFactor property.
 | IsShowLegend | The default value for the IsVisible property for the MasterPane class.
 | IsUniformLegendEntries | The default value for the IsUniformLegendEntries property.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PaneLayout | The default pane layout for DoLayout(Graphics) method calls.
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


InnerPaneGap Field

InnerPaneGap Field
Namespaces ► ZedGraph ► MasterPane..::Default ► InnerPaneGap
The default value for the InnerPaneGap property. This is the size of the margin between adjacent GraphPane objects, in units of points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float InnerPaneGap
Public Shared InnerPaneGap As Single
public:
static float InnerPaneGap
See Also
InnerPaneGap


IsCommonScaleFactor Field

IsCommonScaleFactor Field
Namespaces ► ZedGraph ► MasterPane..::Default ► IsCommonScaleFactor
The default value for the IsCommonScaleFactor property.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsCommonScaleFactor
Public Shared IsCommonScaleFactor As Boolean
public:
static bool IsCommonScaleFactor


IsShowLegend Field

IsShowLegend Field
Namespaces ► ZedGraph ► MasterPane..::Default ► IsShowLegend
The default value for the IsVisible property for the MasterPane class.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsShowLegend
Public Shared IsShowLegend As Boolean
public:
static bool IsShowLegend


IsUniformLegendEntries Field

IsUniformLegendEntries Field
Namespaces ► ZedGraph ► MasterPane..::Default ► IsUniformLegendEntries
The default value for the IsUniformLegendEntries property.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsUniformLegendEntries
Public Shared IsUniformLegendEntries As Boolean
public:
static bool IsUniformLegendEntries


PaneLayout Field

PaneLayout Field
Namespaces ► ZedGraph ► MasterPane..::Default ► PaneLayout
The default pane layout for DoLayout(Graphics) method calls.
Declaration Syntax
C# Visual Basic Visual C++
public static PaneLayout PaneLayout
Public Shared PaneLayout As PaneLayout
public:
static PaneLayout PaneLayout
See Also
SetLayout(Graphics, PaneLayout)
SetLayout(Graphics, Int32, Int32)
SetLayout(Graphics, Boolean, array<Int32>[]())
SetLayout(Graphics, Boolean, array<Int32>[](), array<Single>[]())
ReSize(Graphics, RectangleF)


MinorGrid Class

MinorGrid Class
Namespaces ► ZedGraph ► MinorGrid
Class that holds the specific properties for the minor grid.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MinorGrid : ICloneable, ISerializable
<SerializableAttribute> _
Public Class MinorGrid _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class MinorGrid : ICloneable,
    ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MinorGridMinorGridNew()() | Default constructor
 | MinorGridMinorGridNew(MinorGrid) | Copy constructor
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The color to use for drawing this Axis grid.
 | DashOff | The "Dash Off" mode for drawing the grid.
 | DashOn | The "Dash On" mode for drawing the grid.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible | Gets or sets a value that determines if the major Axis gridlines (at each labeled value) will be visible
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PenWidth | The pen width used for drawing the grid lines.
 | schema | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | MinorGrid
 |  | MajorGrid


MinorGrid Constructor

MinorGrid Constructor
Namespaces ► ZedGraph ► MinorGrid ► MinorGridMinorGridNew()()
Members
Icon | Member | Description
 | MinorGridMinorGridNew()() | Default constructor
 | MinorGridMinorGridNew(MinorGrid) | Copy constructor


MinorGrid Constructor

MinorGrid Constructor
Namespaces ► ZedGraph ► MinorGrid ► MinorGridMinorGridNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public MinorGrid()
Public Sub New
public:
MinorGrid ()


MinorGrid Constructor (rhs)

MinorGrid Constructor (rhs)
Namespaces ► ZedGraph ► MinorGrid ► MinorGridMinorGridNew(MinorGrid)
Copy constructor
Declaration Syntax
C# Visual Basic Visual C++
public MinorGrid(
    MinorGrid rhs
)
Public Sub New ( _
    rhs As MinorGrid _
)
public:
MinorGrid (
    MinorGrid^ rhs
)
Parameters
rhs (MinorGrid)
The source MinorGrid to be copied.


Clone Method

Clone Method
Namespaces ► ZedGraph ► MinorGrid ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public MinorGrid Clone()
Public Function Clone As MinorGrid
public:
MinorGrid^ Clone ()
Return Value
A new, independent copy of this class


Color Property

Color Property
Namespaces ► ZedGraph ► MinorGrid ► Color
The color to use for drawing this Axis grid.
Declaration Syntax
C# Visual Basic Visual C++
public Color Color{ get; set;}
Public Property Color As Color
public:
property Color Color {
    Color get ();
    void set (Color value);
}
Value
The color is defined using the Color class
See Also
Color
PenWidth


DashOff Property

DashOff Property
Namespaces ► ZedGraph ► MinorGrid ► DashOff
The "Dash Off" mode for drawing the grid.
Declaration Syntax
C# Visual Basic Visual C++
public float DashOff{ get; set;}
Public Property DashOff As Single
public:
property float DashOff {
    float get ();
    void set (float value);
}
Value
The dash off length is defined in points (1/72 inch)
Remarks
This is the distance, in points (1/72 inch), of the spaces between the dash segments that make up the dashed grid lines.
See Also
DashOn
IsVisible
DashOff


DashOn Property

DashOn Property
Namespaces ► ZedGraph ► MinorGrid ► DashOn
The "Dash On" mode for drawing the grid.
Declaration Syntax
C# Visual Basic Visual C++
public float DashOn{ get; set;}
Public Property DashOn As Single
public:
property float DashOn {
    float get ();
    void set (float value);
}
Value
The dash on length is defined in points (1/72 inch)
Remarks
This is the distance, in points (1/72 inch), of the dash segments that make up the dashed grid lines.
See Also
DashOff
IsVisible
DashOn


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► MinorGrid ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph ► MinorGrid ► IsVisible
Gets or sets a value that determines if the major Axis gridlines (at each labeled value) will be visible
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
Value
true to show the gridlines, false otherwise
See Also
Default.IsShowGrid
Color
PenWidth
DashOn
DashOff
IsVisible


PenWidth Property

PenWidth Property
Namespaces ► ZedGraph ► MinorGrid ► PenWidth
The pen width used for drawing the grid lines.
Declaration Syntax
C# Visual Basic Visual C++
public float PenWidth{ get; set;}
Public Property PenWidth As Single
public:
property float PenWidth {
    float get ();
    void set (float value);
}
Value
The grid pen width is defined in points (1/72 inch)
See Also
IsVisible
PenWidth
Color


schema Field

schema Field
Namespaces ► ZedGraph ► MinorGrid ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► MinorGrid ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


MinorGrid.Default Structure

MinorGrid..::Default Structure
Namespaces ► ZedGraph ► MinorGrid ► MinorGrid..::Default
A simple struct that defines the default property values for the MinorGrid class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Color | The default color for the Axis minor grid lines (Color property). This color only affects the minor grid lines.
 | DashOff | The default "dash off" size for drawing the Axis minor grid (DashOff property). Units are in points (1/72 inch).
 | DashOn | The default "dash on" size for drawing the Axis minor grid (DashOn property). Units are in points (1/72 inch).
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible | The default display mode for the Axis minor grid lines (IsVisible property). true to show the minor grid lines, false to hide them.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PenWidth | The default pen width for drawing the Axis minor grid (PenWidth property). Units are in points (1/72 inch).
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


Color Field

Color Field
Namespaces ► ZedGraph ► MinorGrid..::Default ► Color
The default color for the Axis minor grid lines (Color property). This color only affects the minor grid lines.
Declaration Syntax
C# Visual Basic Visual C++
public static Color Color
Public Shared Color As Color
public:
static Color Color


DashOff Field

DashOff Field
Namespaces ► ZedGraph ► MinorGrid..::Default ► DashOff
The default "dash off" size for drawing the Axis minor grid (DashOff property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float DashOff
Public Shared DashOff As Single
public:
static float DashOff


DashOn Field

DashOn Field
Namespaces ► ZedGraph ► MinorGrid..::Default ► DashOn
The default "dash on" size for drawing the Axis minor grid (DashOn property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float DashOn
Public Shared DashOn As Single
public:
static float DashOn


IsVisible Field

IsVisible Field
Namespaces ► ZedGraph ► MinorGrid..::Default ► IsVisible
The default display mode for the Axis minor grid lines (IsVisible property). true to show the minor grid lines, false to hide them.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsVisible
Public Shared IsVisible As Boolean
public:
static bool IsVisible


PenWidth Field

PenWidth Field
Namespaces ► ZedGraph ► MinorGrid..::Default ► PenWidth
The default pen width for drawing the Axis minor grid (PenWidth property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float PenWidth
Public Shared PenWidth As Single
public:
static float PenWidth


MinorTic Class

MinorTic Class
Namespaces ► ZedGraph ► MinorTic
Class that holds the specific properties for the minor tics.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MinorTic : ICloneable, ISerializable
<SerializableAttribute> _
Public Class MinorTic _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class MinorTic : ICloneable,
    ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MinorTicMinorTicNew()() | Default Constructor
 | MinorTicMinorTicNew(MinorTic) | Copy constructor.
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The color to use for drawing the tics of this class instance
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAllTics | This is convenience property sets the status of all the different tic properties in this instance to the same value. true to activate all tics, false to clear all tics.
 | IsCrossInside | Gets or sets the display mode for the Axis major inside "cross" tic marks.
 | IsCrossOutside | Gets or sets the display mode for the Axis major outside "cross" tic marks.
 | IsInside | Gets or sets a property that determines whether or not the major inside tic marks are shown.
 | IsOpposite | Gets or sets a property that determines whether or not the major opposite tic marks are shown.
 | IsOutside | Gets or sets a property that determines whether or not the minor outside tic marks are shown.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PenWidth | Gets or sets the pen width to be used when drawing the tic marks for this Axis
 | ScaledTic(Single) | Calculate the scaled tic size for this Axis
 | schema | Current schema value that defines the version of the serialized file
 | Size | The length of the major tic marks.
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | MinorTic
 |  | MajorTic


MinorTic Constructor

MinorTic Constructor
Namespaces ► ZedGraph ► MinorTic ► MinorTicMinorTicNew()()
Members
Icon | Member | Description
 | MinorTicMinorTicNew()() | Default Constructor
 | MinorTicMinorTicNew(MinorTic) | Copy constructor.


MinorTic Constructor

MinorTic Constructor
Namespaces ► ZedGraph ► MinorTic ► MinorTicMinorTicNew()()
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public MinorTic()
Public Sub New
public:
MinorTic ()


MinorTic Constructor (rhs)

MinorTic Constructor (rhs)
Namespaces ► ZedGraph ► MinorTic ► MinorTicMinorTicNew(MinorTic)
Copy constructor.
Declaration Syntax
C# Visual Basic Visual C++
public MinorTic(
    MinorTic rhs
)
Public Sub New ( _
    rhs As MinorTic _
)
public:
MinorTic (
    MinorTic^ rhs
)
Parameters
rhs (MinorTic)
The MinorTic that is to be copied.


Clone Method

Clone Method
Namespaces ► ZedGraph ► MinorTic ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public MinorTic Clone()
Public Function Clone As MinorTic
public:
MinorTic^ Clone ()
Return Value
A new, independent copy of this class


Color Property

Color Property
Namespaces ► ZedGraph ► MinorTic ► Color
The color to use for drawing the tics of this class instance
Declaration Syntax
C# Visual Basic Visual C++
public Color Color{ get; set;}
Public Property Color As Color
public:
property Color Color {
    Color get ();
    void set (Color value);
}
Value
The color is defined using the Color class
See Also
Color
IsOutside
IsVisible


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► MinorTic ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsAllTics Property

IsAllTics Property
Namespaces ► ZedGraph ► MinorTic ► IsAllTics
This is convenience property sets the status of all the different tic properties in this instance to the same value. true to activate all tics, false to clear all tics.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAllTics{ set;}
Public WriteOnly Property IsAllTics As Boolean
public:
property bool IsAllTics {
    void set (bool value);
}
Remarks
This setting does not persist. That is, you can clear all the tics with IsAllTics = false, then activate them individually (example: IsOutside = true).
See Also
IsOutside
IsInside
IsOpposite
IsCrossInside
IsCrossOutside


IsCrossInside Property

IsCrossInside Property
Namespaces ► ZedGraph ► MinorTic ► IsCrossInside
Gets or sets the display mode for the Axis major inside "cross" tic marks.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCrossInside{ get; set;}
Public Property IsCrossInside As Boolean
public:
property bool IsCrossInside {
    bool get ();
    void set (bool value);
}
Value
true to show the major cross tic marks, false otherwise
Remarks
The "cross" tics are a special, additional set of tic marks that always appear on the actual axis, even if it has been shifted due to the Cross setting. The other tic marks are always fixed to the edges of the Rect. The cross tics are normally not displayed, since, if CrossAuto is true, they will exactly overlay the "normal" and "inside" tics. If CrossAuto is false, then you will most likely want to enable the cross tics. The major tic spacing is controlled by MajorStep.


IsCrossOutside Property

IsCrossOutside Property
Namespaces ► ZedGraph ► MinorTic ► IsCrossOutside
Gets or sets the display mode for the Axis major outside "cross" tic marks.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCrossOutside{ get; set;}
Public Property IsCrossOutside As Boolean
public:
property bool IsCrossOutside {
    bool get ();
    void set (bool value);
}
Value
true to show the major cross tic marks, false otherwise
Remarks
The "cross" tics are a special, additional set of tic marks that always appear on the actual axis, even if it has been shifted due to the Cross setting. The other tic marks are always fixed to the edges of the Rect. The cross tics are normally not displayed, since, if CrossAuto is true, they will exactly overlay the "normal" and "inside" tics. If CrossAuto is false, then you will most likely want to enable the cross tics. The major tic spacing is controlled by MajorStep.


IsInside Property

IsInside Property
Namespaces ► ZedGraph ► MinorTic ► IsInside
Gets or sets a property that determines whether or not the major inside tic marks are shown.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInside{ get; set;}
Public Property IsInside As Boolean
public:
property bool IsInside {
    bool get ();
    void set (bool value);
}
Value
true to show the major inside tic marks, false otherwise
Remarks
These are the tic marks on the inside of the Axis border. The major tic spacing is controlled by MajorStep.
See Also
IsInside
IsOutside
IsInside
IsOpposite
IsCrossInside
IsCrossOutside


IsOpposite Property

IsOpposite Property
Namespaces ► ZedGraph ► MinorTic ► IsOpposite
Gets or sets a property that determines whether or not the major opposite tic marks are shown.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOpposite{ get; set;}
Public Property IsOpposite As Boolean
public:
property bool IsOpposite {
    bool get ();
    void set (bool value);
}
Value
true to show the major opposite tic marks, false otherwise
Remarks
These are the tic marks on the inside of the Axis border on the opposite side from the axis. The major tic spacing is controlled by MajorStep.
See Also
IsOpposite
IsOutside
IsInside
IsOpposite
IsCrossInside
IsCrossOutside


IsOutside Property

IsOutside Property
Namespaces ► ZedGraph ► MinorTic ► IsOutside
Gets or sets a property that determines whether or not the minor outside tic marks are shown.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOutside{ get; set;}
Public Property IsOutside As Boolean
public:
property bool IsOutside {
    bool get ();
    void set (bool value);
}
Value
true to show the minor outside tic marks, false otherwise
Remarks
These are the tic marks on the outside of the Axis border. The minor tic spacing is controlled by MinorStep.
See Also
IsOutside
IsOutside
IsInside
IsOpposite
IsCrossInside
IsCrossOutside


PenWidth Property

PenWidth Property
Namespaces ► ZedGraph ► MinorTic ► PenWidth
Gets or sets the pen width to be used when drawing the tic marks for this Axis
Declaration Syntax
C# Visual Basic Visual C++
public float PenWidth{ get; set;}
Public Property PenWidth As Single
public:
property float PenWidth {
    float get ();
    void set (float value);
}
Value
The pen width is defined in points (1/72 inch)
See Also
PenWidth
IsOutside
Color


ScaledTic Method (scaleFactor)

ScaledTic Method (scaleFactor)
Namespaces ► ZedGraph ► MinorTic ► ScaledTic(Single)
Calculate the scaled tic size for this Axis
Declaration Syntax
C# Visual Basic Visual C++
public float ScaledTic(
    float scaleFactor
)
Public Function ScaledTic ( _
    scaleFactor As Single _
) As Single
public:
float ScaledTic (
    float scaleFactor
)
Parameters
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
The scaled tic size, in points (1/72 inch)
See Also
Size
FontSpec
CalcScaleFactor()()


schema Field

schema Field
Namespaces ► ZedGraph ► MinorTic ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


Size Property

Size Property
Namespaces ► ZedGraph ► MinorTic ► Size
The length of the major tic marks.
Declaration Syntax
C# Visual Basic Visual C++
public float Size{ get; set;}
Public Property Size As Single
public:
property float Size {
    float get ();
    void set (float value);
}
Value
The tic size is measured in points (1/72 inch)
Remarks
This length will be scaled according to the CalcScaleFactor()() for the GraphPane
See Also
Size
IsOutside
IsVisible
Color


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► MinorTic ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


MinorTic.Default Structure

MinorTic..::Default Structure
Namespaces ► ZedGraph ► MinorTic ► MinorTic..::Default
A simple struct that defines the default property values for the MinorTic class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Color | The default color for minor tics (Color property).
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsCrossInside | The default display mode for the Axis minor inside "cross" tic marks (IsCrossInside property).
 | IsCrossOutside | The default display mode for the Axis minor outside "cross" tic marks (IsCrossOutside property).
 | IsInside | The display mode for the Axis minor inside tic marks (IsInside property). The minor tic spacing is controlled by MinorStep.
 | IsOpposite | The display mode for the Axis minor opposite tic marks (IsOpposite property). The minor tic spacing is controlled by MinorStep.
 | IsOutside | The display mode for the Axis minor outside tic marks (IsOutside property). The minor tic spacing is controlled by MinorStep.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PenWidth | The default pen width for drawing the Axis tic marks. (PenWidth property). Units are in points (1/72 inch).
 | Size | The default size for the Axis minor tic marks. (Size property). Units are in points (1/72 inch).
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


Color Field

Color Field
Namespaces ► ZedGraph ► MinorTic..::Default ► Color
The default color for minor tics (Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color Color
Public Shared Color As Color
public:
static Color Color


IsCrossInside Field

IsCrossInside Field
Namespaces ► ZedGraph ► MinorTic..::Default ► IsCrossInside
The default display mode for the Axis minor inside "cross" tic marks (IsCrossInside property).
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsCrossInside
Public Shared IsCrossInside As Boolean
public:
static bool IsCrossInside
Value
true to show the major cross tic marks, false otherwise
Remarks
The "cross" tics are a special, additional set of tic marks that always appear on the actual axis, even if it has been shifted due to the Cross setting. The other tic marks are always fixed to the edges of the Rect. The cross tics are normally not displayed, since, if CrossAuto is true, they will exactly overlay the "normal" and "inside" tics. If CrossAuto is false, then you will most likely want to enable the cross tics. The major tic spacing is controlled by MinorStep.


IsCrossOutside Field

IsCrossOutside Field
Namespaces ► ZedGraph ► MinorTic..::Default ► IsCrossOutside
The default display mode for the Axis minor outside "cross" tic marks (IsCrossOutside property).
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsCrossOutside
Public Shared IsCrossOutside As Boolean
public:
static bool IsCrossOutside
Value
true to show the major cross tic marks, false otherwise
Remarks
The "cross" tics are a special, additional set of tic marks that always appear on the actual axis, even if it has been shifted due to the Cross setting. The other tic marks are always fixed to the edges of the Rect. The cross tics are normally not displayed, since, if CrossAuto is true, they will exactly overlay the "normal" and "inside" tics. If CrossAuto is false, then you will most likely want to enable the cross tics. The minor tic spacing is controlled by MinorStep.


IsInside Field

IsInside Field
Namespaces ► ZedGraph ► MinorTic..::Default ► IsInside
The display mode for the Axis minor inside tic marks (IsInside property). The minor tic spacing is controlled by MinorStep.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsInside
Public Shared IsInside As Boolean
public:
static bool IsInside
Value
true to show the minor tic marks (inside the axis), false otherwise


IsOpposite Field

IsOpposite Field
Namespaces ► ZedGraph ► MinorTic..::Default ► IsOpposite
The display mode for the Axis minor opposite tic marks (IsOpposite property). The minor tic spacing is controlled by MinorStep.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsOpposite
Public Shared IsOpposite As Boolean
public:
static bool IsOpposite
Value
true to show the minor tic marks (inside the axis on the opposite side), false otherwise


IsOutside Field

IsOutside Field
Namespaces ► ZedGraph ► MinorTic..::Default ► IsOutside
The display mode for the Axis minor outside tic marks (IsOutside property). The minor tic spacing is controlled by MinorStep.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsOutside
Public Shared IsOutside As Boolean
public:
static bool IsOutside
Value
true to show the minor tic marks (outside the axis), false otherwise


PenWidth Field

PenWidth Field
Namespaces ► ZedGraph ► MinorTic..::Default ► PenWidth
The default pen width for drawing the Axis tic marks. (PenWidth property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float PenWidth
Public Shared PenWidth As Single
public:
static float PenWidth


Size Field

Size Field
Namespaces ► ZedGraph ► MinorTic..::Default ► Size
The default size for the Axis minor tic marks. (Size property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float Size
Public Shared Size As Single
public:
static float Size


NoDupePointList Class

NoDupePointList Class
Namespaces ► ZedGraph ► NoDupePointList
A collection class to maintain a set of samples.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class NoDupePointList : List<DataPoint>, IPointListEdit,
    IPointList, ICloneable
<SerializableAttribute> _
Public Class NoDupePointList _
    Inherits List(Of DataPoint) _
    Implements IPointListEdit, IPointList, ICloneable
[SerializableAttribute]
public ref class NoDupePointList : public List<DataPoint>,
    IPointListEdit, IPointList, ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NoDupePointListNoDupePointListNew()() | default constructor
 | NoDupePointListNoDupePointListNew(NoDupePointList) | copy constructor -- this returns a copy of the structure, but it does not duplicate the data (it just keeps a reference to the original)
 | Add(PointPair) | Append a data point to the collection
 | Add(Double, Double) | Append a point to the collection
 | Add(T) | Adds an object to the end of the List<(Of <T>)>. (Inherited from List <(Of < DataPoint >)>.)
 | AddRange(IEnumerable<(Of <T>)>) | Adds the elements of the specified collection to the end of the List<(Of <T>)>. (Inherited from List <(Of < DataPoint >)>.)
 | AsReadOnly()() | Returns a read-only IList<(Of <T>)> wrapper for the current collection. (Inherited from List <(Of < DataPoint >)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < DataPoint >)>.)
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of < DataPoint >)>.)
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < DataPoint >)>.)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of < DataPoint >)>.)
 | Clear()() | Removes all elements from the List<(Of <T>)>. (Inherited from List <(Of < DataPoint >)>.)
 | ClearFilter()() | Clears any filtering previously done by a call to FilterData(GraphPane, Axis, Axis). After calling this method, all data points will be visible, and Count will be equal to TotalCount.
 | Clone()() | typesafe clone method
 | Contains(T) | Determines whether an element is in the List<(Of <T>)>. (Inherited from List <(Of < DataPoint >)>.)
 | ConvertAll<(Of <TOutput>)>(Converter<(Of <T, TOutput>)>) | Converts the elements in the current List<(Of <T>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of < DataPoint >)>.)
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of < DataPoint >)>.)
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < DataPoint >)>.)
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < DataPoint >)>.)
 | Count | Gets the number of active samples in the collection. This is the number of samples that are non-duplicates. See the TotalCount property to get the total number of samples in the list.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <T>)>) | Determines whether the List<(Of <T>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < DataPoint >)>.)
 | FilterData(GraphPane, Axis, Axis) | Go through the collection, and hide (filter out) any points that fall on the same pixel location as a previously included point.
 | FilterMode | Gets or sets a value that determines how close a point must be to a prior neighbor in order to be filtered out.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < DataPoint >)>.)
 | FindAll(Predicate<(Of <T>)>) | Retrieves the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < DataPoint >)>.)
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < DataPoint >)>.)
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < DataPoint >)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < DataPoint >)>.)
 | FindLast(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < DataPoint >)>.)
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < DataPoint >)>.)
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < DataPoint >)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < DataPoint >)>.)
 | ForEach(Action<(Of <T>)>) | Performs the specified action on each element of the List<(Of <T>)>. (Inherited from List <(Of < DataPoint >)>.)
 | GetEnumerator()() | Returns an enumerator that iterates through the List<(Of <T>)>. (Inherited from List <(Of < DataPoint >)>.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <T>)>. (Inherited from List <(Of < DataPoint >)>.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < DataPoint >)>.)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < DataPoint >)>.)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < DataPoint >)>.)
 | Insert(Int32, T) | Inserts an element into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < DataPoint >)>.)
 | InsertRange(Int32, IEnumerable<(Of <T>)>) | Inserts the elements of a collection into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < DataPoint >)>.)
 | IsFiltered | Gets a value indicating whether or not the data have been filtered. If the data have not been filtered, then Count will be equal to TotalCount.
 | Item[([Int32])] | Indexer: get the DataPoint instance at the specified ordinal position in the list
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < DataPoint >)>.)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < DataPoint >)>.)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < DataPoint >)>.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <T>)>. (Inherited from List <(Of < DataPoint >)>.)
 | RemoveAll(Predicate<(Of <T>)>) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < DataPoint >)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <T>)>. (Inherited from List <(Of < DataPoint >)>.)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <T>)>. (Inherited from List <(Of < DataPoint >)>.)
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>. (Inherited from List <(Of < DataPoint >)>.)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of < DataPoint >)>.)
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer. (Inherited from List <(Of < DataPoint >)>.)
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < DataPoint >)>.)
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < DataPoint >)>.)
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>. (Inherited from List <(Of < DataPoint >)>.)
 | ICollection<(Of <T>)>..::IsReadOnly | (Inherited from List <(Of < DataPoint >)>.)
 | IEnumerable<(Of <T>)>..::GetEnumerator()() | (Inherited from List <(Of < DataPoint >)>.)
 | ICollection..::CopyTo(Array, Int32) | (Inherited from List <(Of < DataPoint >)>.)
 | ICollection..::IsSynchronized | (Inherited from List <(Of < DataPoint >)>.)
 | ICollection..::SyncRoot | (Inherited from List <(Of < DataPoint >)>.)
 | IEnumerable..::GetEnumerator()() | (Inherited from List <(Of < DataPoint >)>.)
 | IList..::Add(Object) | (Inherited from List <(Of < DataPoint >)>.)
 | IList..::Contains(Object) | (Inherited from List <(Of < DataPoint >)>.)
 | IList..::IndexOf(Object) | (Inherited from List <(Of < DataPoint >)>.)
 | IList..::Insert(Int32, Object) | (Inherited from List <(Of < DataPoint >)>.)
 | IList..::IsFixedSize | (Inherited from List <(Of < DataPoint >)>.)
 | IList..::IsReadOnly | (Inherited from List <(Of < DataPoint >)>.)
 | IList..::Item[([Int32])] | (Inherited from List <(Of < DataPoint >)>.)
 | IList..::Remove(Object) | (Inherited from List <(Of < DataPoint >)>.)
 | ICloneable..::Clone()() |
 | ToArray()() | Copies the elements of the List<(Of <T>)> to a new array. (Inherited from List <(Of < DataPoint >)>.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalCount | Gets the total number of samples in the collection. See the Count property to get the number of active (non-duplicate) samples in the list.
 | TrimExcess()() | Sets the capacity to the actual number of elements in the List<(Of <T>)>, if that number is less than a threshold value. (Inherited from List <(Of < DataPoint >)>.)
 | TrueForAll(Predicate<(Of <T>)>) | Determines whether every element in the List<(Of <T>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of < DataPoint >)>.)
Remarks
This type, intended for very large datasets, will reduce the number of points displayed by eliminating individual points that overlay (at the same pixel location) on the graph. Note that this type probably does not make sense for line plots, but is intended primarily for scatter plots.
Inheritance Hierarchy
Object
 | List <(Of < DataPoint >)>
 |  | NoDupePointList


NoDupePointList Constructor

NoDupePointList Constructor
Namespaces ► ZedGraph ► NoDupePointList ► NoDupePointListNoDupePointListNew()()
Members
Icon | Member | Description
 | NoDupePointListNoDupePointListNew()() | default constructor
 | NoDupePointListNoDupePointListNew(NoDupePointList) | copy constructor -- this returns a copy of the structure, but it does not duplicate the data (it just keeps a reference to the original)


NoDupePointList Constructor

NoDupePointList Constructor
Namespaces ► ZedGraph ► NoDupePointList ► NoDupePointListNoDupePointListNew()()
default constructor
Declaration Syntax
C# Visual Basic Visual C++
public NoDupePointList()
Public Sub New
public:
NoDupePointList ()


NoDupePointList Constructor (rhs)

NoDupePointList Constructor (rhs)
Namespaces ► ZedGraph ► NoDupePointList ► NoDupePointListNoDupePointListNew(NoDupePointList)
copy constructor -- this returns a copy of the structure, but it does not duplicate the data (it just keeps a reference to the original)
Declaration Syntax
C# Visual Basic Visual C++
public NoDupePointList(
    NoDupePointList rhs
)
Public Sub New ( _
    rhs As NoDupePointList _
)
public:
NoDupePointList (
    NoDupePointList^ rhs
)
Parameters
rhs (NoDupePointList)
The NoDupePointList to be copied


Add Method

Add Method
Namespaces ► ZedGraph ► NoDupePointList ► Add()()
Members
Icon | Member | Description
 | Add(PointPair) | Append a data point to the collection
 | Add(Double, Double) | Append a point to the collection
 | Add(T) | Adds an object to the end of the List<(Of <T>)>.


Add Method (x, y)

Add Method (x, y)
Namespaces ► ZedGraph ► NoDupePointList ► Add(Double, Double)
Append a point to the collection
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    double x,
    double y
)
Public Sub Add ( _
    x As Double, _
    y As Double _
)
public:
virtual void Add (
    double x,
    double y
) sealed
Parameters
x (Double)
The x value of the point to append
y (Double)
The y value of the point to append


Add Method (pt)

Add Method (pt)
Namespaces ► ZedGraph ► NoDupePointList ► Add(PointPair)
Append a data point to the collection
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    PointPair pt
)
Public Sub Add ( _
    pt As PointPair _
)
public:
virtual void Add (
    PointPair^ pt
) sealed
Parameters
pt (PointPair)
The PointPair value to append


ClearFilter Method

ClearFilter Method
Namespaces ► ZedGraph ► NoDupePointList ► ClearFilter()()
Clears any filtering previously done by a call to FilterData(GraphPane, Axis, Axis). After calling this method, all data points will be visible, and Count will be equal to TotalCount.
Declaration Syntax
C# Visual Basic Visual C++
public void ClearFilter()
Public Sub ClearFilter
public:
void ClearFilter ()


Clone Method

Clone Method
Namespaces ► ZedGraph ► NoDupePointList ► Clone()()
typesafe clone method
Declaration Syntax
C# Visual Basic Visual C++
public NoDupePointList Clone()
Public Function Clone As NoDupePointList
public:
NoDupePointList^ Clone ()
Return Value
A new cloned NoDupePointList. This returns a copy of the structure, but it does not duplicate the data (it just keeps a reference to the original)


Count Property

Count Property
Namespaces ► ZedGraph ► NoDupePointList ► Count
Gets the number of active samples in the collection. This is the number of samples that are non-duplicates. See the TotalCount property to get the total number of samples in the list.
Declaration Syntax
C# Visual Basic Visual C++
public int Count{ get;}
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}


FilterData Method (pane, xAxis, yAxis)

FilterData Method (pane, xAxis, yAxis)
Namespaces ► ZedGraph ► NoDupePointList ► FilterData(GraphPane, Axis, Axis)
Go through the collection, and hide (filter out) any points that fall on the same pixel location as a previously included point.
Declaration Syntax
C# Visual Basic Visual C++
public void FilterData(
    GraphPane pane,
    Axis xAxis,
    Axis yAxis
)
Public Sub FilterData ( _
    pane As GraphPane, _
    xAxis As Axis, _
    yAxis As Axis _
)
public:
void FilterData (
    GraphPane^ pane,
    Axis^ xAxis,
    Axis^ yAxis
)
Parameters
pane (GraphPane)
The GraphPane into which the data will be plotted.
xAxis (Axis)
The Axis class to be used in the X direction for plotting these data. This can be an XAxis or a X2Axis.
yAxis (Axis)
The Axis class to be used in the Y direction for plotting these data. This can be a YAxis or a Y2Axis, and can be a primary or secondary axis (if multiple Y or Y2 axes are being used).
Remarks
This method does not delete any points, it just temporarily hides them until the next call to FilterData(GraphPane, Axis, Axis) or ClearFilter()(). You should call FilterData(GraphPane, Axis, Axis) once your collection of points has been constructed. You may need to call FilterData(GraphPane, Axis, Axis) again if you add points, or if the chart rect changes size (by resizing, printing, image save, etc.), or if the scale range changes. You must call AxisChange()() before calling this method so that the GraphPane.Chart.Rect and the scale ranges are valid. This method is not valid for ordinal axes (but ordinal axes don't make sense for very large datasets anyway).


FilterMode Property

FilterMode Property
Namespaces ► ZedGraph ► NoDupePointList ► FilterMode
Gets or sets a value that determines how close a point must be to a prior neighbor in order to be filtered out.
Declaration Syntax
C# Visual Basic Visual C++
public int FilterMode{ get; set;}
Public Property FilterMode As Integer
public:
property int FilterMode {
    int get ();
    void set (int value);
}
Remarks
A value of 0 indicates that subsequent points must coincide exactly at the same pixel location. A value of 1 or more indicates that number of pixels distance from a prior point that will cause a new point to be filtered out. For example, a value of 2 means that, once a particular pixel location is taken, any subsequent point that lies within 2 pixels of that location will be filtered out.


IsFiltered Property

IsFiltered Property
Namespaces ► ZedGraph ► NoDupePointList ► IsFiltered
Gets a value indicating whether or not the data have been filtered. If the data have not been filtered, then Count will be equal to TotalCount.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFiltered{ get;}
Public ReadOnly Property IsFiltered As Boolean
public:
property bool IsFiltered {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph ► NoDupePointList ► Item[([Int32])]
Indexer: get the DataPoint instance at the specified ordinal position in the list
Declaration Syntax
C# Visual Basic Visual C++
public PointPair this[
    int index
]{ get; set;}
Public Default Property Item ( _
    index As Integer _
) As PointPair
public:
virtual property PointPair^ default[int index] {
    PointPair^ get (int index) sealed;
    void set (int index, PointPair^ value) sealed;
}
Parameters
index (Int32)
The ordinal position in the list of points
Return Value
Returns a PointPair instance. The Z and Tag properties will be defaulted to Missing and null, respectively.
Remarks
This method will throw an exception if the index is out of range. This can happen if the index is less than the number of filtered values, or if data points are removed from a filtered dataset with updating the filter (by calling FilterData(GraphPane, Axis, Axis)).


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► NoDupePointList ► ICloneable..::Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone


TotalCount Property

TotalCount Property
Namespaces ► ZedGraph ► NoDupePointList ► TotalCount
Gets the total number of samples in the collection. See the Count property to get the number of active (non-duplicate) samples in the list.
Declaration Syntax
C# Visual Basic Visual C++
public int TotalCount{ get;}
Public ReadOnly Property TotalCount As Integer
public:
property int TotalCount {
    int get ();
}


OHLCBar Class

OHLCBar Class
Namespaces ► ZedGraph ► OHLCBar
This class handles the drawing of the curve OHLCBar objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class OHLCBar : LineBase, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class OHLCBar _
    Inherits LineBase _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class OHLCBar : public LineBase,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OHLCBarOHLCBarNew()() | Default constructor that sets all OHLCBar properties to default values as defined in the OHLCBar..::Default class.
 | OHLCBarOHLCBarNew(Color) | Default constructor that sets the Color as specified, and the remaining OHLCBar properties to default values as defined in the OHLCBar..::Default class.
 | OHLCBarOHLCBarNew(OHLCBar) | The Copy Constructor
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The color of the Line. Note that this color value can be overridden if the GradientFill.Type is one of the GradientByX, GradientByY, GradientByZ, and GradientByColorValue types. (Inherited from LineBase.)
 | DashOff | The "Dash Off" mode for drawing the line. (Inherited from LineBase.)
 | DashOn | The "Dash On" mode for drawing the line. (Inherited from LineBase.)
 | Draw(Graphics, GraphPane, Boolean, Single, Single, Single, Single, Single, Single, Pen) | Draw the OHLCBar to the specified Graphics device at the specified location.
 | Draw(Graphics, GraphPane, OHLCBarItem, Axis, Axis, Single) | Draw all the OHLCBar's to the specified Graphics device as a candlestick at each defined point.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarWidth(GraphPane, Axis, Single) | Returns the width of the candleStick, in pixels, based on the settings for Size and IsAutoSize.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides LineBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetPen(PaneBase, Single) | Create a Pen object based on the properties of this LineBase. (Inherited from LineBase.)
 | GetPen(PaneBase, Single, PointPair) | Create a Pen object based on the properties of this LineBase. (Inherited from LineBase.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GradientFill | Gets or sets a custom Fill class. (Inherited from LineBase.)
 | IsAntiAlias | Gets or sets a value that determines if the lines are drawn using Anti-Aliasing capabilities from the Graphics class. (Inherited from LineBase.)
 | IsAutoSize | Gets or sets a value that determines if the Size property will be calculated automatically based on the minimum axis scale step size between bars.
 | IsOpenCloseVisible | Gets or sets a property that shows or hides the OHLCBar open/close "wings".
 | IsVisible | Gets or sets a property that shows or hides the Line. (Inherited from LineBase.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | schema | Current schema value that defines the version of the serialized file
 | Size | Gets or sets the total width to be used for drawing the opening/closing line segments ("wings") of the OHLCBar items. Units are points.
 | Style | The style of the Line, defined as a DashStyle enum. This allows the line to be solid, dashed, or dotted. (Inherited from LineBase.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Width | The pen width used to draw the Line, in points (1/72 inch) (Inherited from LineBase.)
Inheritance Hierarchy
Object
 | LineBase
 |  | OHLCBar
 |  |  | JapaneseCandleStick


OHLCBar Constructor

OHLCBar Constructor
Namespaces ► ZedGraph ► OHLCBar ► OHLCBarOHLCBarNew()()
Members
Icon | Member | Description
 | OHLCBarOHLCBarNew()() | Default constructor that sets all OHLCBar properties to default values as defined in the OHLCBar..::Default class.
 | OHLCBarOHLCBarNew(Color) | Default constructor that sets the Color as specified, and the remaining OHLCBar properties to default values as defined in the OHLCBar..::Default class.
 | OHLCBarOHLCBarNew(OHLCBar) | The Copy Constructor


OHLCBar Constructor

OHLCBar Constructor
Namespaces ► ZedGraph ► OHLCBar ► OHLCBarOHLCBarNew()()
Default constructor that sets all OHLCBar properties to default values as defined in the OHLCBar..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public OHLCBar()
Public Sub New
public:
OHLCBar ()


OHLCBar Constructor (color)

OHLCBar Constructor (color)
Namespaces ► ZedGraph ► OHLCBar ► OHLCBarOHLCBarNew(Color)
Default constructor that sets the Color as specified, and the remaining OHLCBar properties to default values as defined in the OHLCBar..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public OHLCBar(
    Color color
)
Public Sub New ( _
    color As Color _
)
public:
OHLCBar (
    Color color
)
Parameters
color (Color)
A Color value indicating the color of the symbol


OHLCBar Constructor (rhs)

OHLCBar Constructor (rhs)
Namespaces ► ZedGraph ► OHLCBar ► OHLCBarOHLCBarNew(OHLCBar)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public OHLCBar(
    OHLCBar rhs
)
Public Sub New ( _
    rhs As OHLCBar _
)
public:
OHLCBar (
    OHLCBar^ rhs
)
Parameters
rhs (OHLCBar)
The OHLCBar object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► OHLCBar ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public OHLCBar Clone()
Public Function Clone As OHLCBar
public:
OHLCBar^ Clone ()
Return Value
A new, independent copy of this class


Draw Method

Draw Method
Namespaces ► ZedGraph ► OHLCBar ► Draw()()
Members
Icon | Member | Description
 | Draw(Graphics, GraphPane, Boolean, Single, Single, Single, Single, Single, Single, Pen) | Draw the OHLCBar to the specified Graphics device at the specified location.
 | Draw(Graphics, GraphPane, OHLCBarItem, Axis, Axis, Single) | Draw all the OHLCBar's to the specified Graphics device as a candlestick at each defined point.


Draw Method (g, pane, isXBase, pixBase, pixHigh, pixLow, pixOpen, pixClose, halfSize, pen)

Draw Method (g, pane, isXBase, pixBase, pixHigh, pixLow, pixOpen, pixClose, halfSize, pen)
Namespaces ► ZedGraph ► OHLCBar ► Draw(Graphics, GraphPane, Boolean, Single, Single, Single, Single, Single, Single, Pen)
Draw the OHLCBar to the specified Graphics device at the specified location.
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    GraphPane pane,
    bool isXBase,
    float pixBase,
    float pixHigh,
    float pixLow,
    float pixOpen,
    float pixClose,
    float halfSize,
    Pen pen
)
Public Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    isXBase As Boolean, _
    pixBase As Single, _
    pixHigh As Single, _
    pixLow As Single, _
    pixOpen As Single, _
    pixClose As Single, _
    halfSize As Single, _
    pen As Pen _
)
public:
void Draw (
    Graphics^ g,
    GraphPane^ pane,
    bool isXBase,
    float pixBase,
    float pixHigh,
    float pixLow,
    float pixOpen,
    float pixClose,
    float halfSize,
    Pen^ pen
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
isXBase (Boolean)
boolean value that indicates if the "base" axis for this OHLCBar is the X axis. True for an XAxis base, false for a YAxis or Y2Axis base.
pixBase (Single)
The independent axis position of the center of the candlestick in pixel units
pixHigh (Single)
The dependent axis position of the top of the candlestick in pixel units
pixLow (Single)
The dependent axis position of the bottom of the candlestick in pixel units
pixOpen (Single)
The dependent axis position of the opening value of the candlestick in pixel units
pixClose (Single)
The dependent axis position of the closing value of the candlestick in pixel units
halfSize (Single)
The scaled width of the candlesticks, pixels
pen (Pen)
A pen with attributes of Color and Width for this OHLCBar


Draw Method (g, pane, curve, baseAxis, valueAxis, scaleFactor)

Draw Method (g, pane, curve, baseAxis, valueAxis, scaleFactor)
Namespaces ► ZedGraph ► OHLCBar ► Draw(Graphics, GraphPane, OHLCBarItem, Axis, Axis, Single)
Draw all the OHLCBar's to the specified Graphics device as a candlestick at each defined point.
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    GraphPane pane,
    OHLCBarItem curve,
    Axis baseAxis,
    Axis valueAxis,
    float scaleFactor
)
Public Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    curve As OHLCBarItem, _
    baseAxis As Axis, _
    valueAxis As Axis, _
    scaleFactor As Single _
)
public:
void Draw (
    Graphics^ g,
    GraphPane^ pane,
    OHLCBarItem^ curve,
    Axis^ baseAxis,
    Axis^ valueAxis,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
curve (OHLCBarItem)
A OHLCBarItem object representing the OHLCBar's to be drawn.
baseAxis (Axis)
The Axis class instance that defines the base (independent) axis for the OHLCBar
valueAxis (Axis)
The Axis class instance that defines the value (dependent) axis for the OHLCBar
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


GetBarWidth Method (pane, baseAxis, scaleFactor)

GetBarWidth Method (pane, baseAxis, scaleFactor)
Namespaces ► ZedGraph ► OHLCBar ► GetBarWidth(GraphPane, Axis, Single)
Returns the width of the candleStick, in pixels, based on the settings for Size and IsAutoSize.
Declaration Syntax
C# Visual Basic Visual C++
public float GetBarWidth(
    GraphPane pane,
    Axis baseAxis,
    float scaleFactor
)
Public Function GetBarWidth ( _
    pane As GraphPane, _
    baseAxis As Axis, _
    scaleFactor As Single _
) As Single
public:
float GetBarWidth (
    GraphPane^ pane,
    Axis^ baseAxis,
    float scaleFactor
)
Parameters
pane (GraphPane)
The parent GraphPane object.
baseAxis (Axis)
The Axis object that represents the bar base (independent axis).
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
The width of each bar, in pixel units


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► OHLCBar ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsAutoSize Property

IsAutoSize Property
Namespaces ► ZedGraph ► OHLCBar ► IsAutoSize
Gets or sets a value that determines if the Size property will be calculated automatically based on the minimum axis scale step size between bars.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAutoSize{ get; set;}
Public Property IsAutoSize As Boolean
public:
property bool IsAutoSize {
    bool get ();
    void set (bool value);
}


IsOpenCloseVisible Property

IsOpenCloseVisible Property
Namespaces ► ZedGraph ► OHLCBar ► IsOpenCloseVisible
Gets or sets a property that shows or hides the OHLCBar open/close "wings".
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOpenCloseVisible{ get; set;}
Public Property IsOpenCloseVisible As Boolean
public:
property bool IsOpenCloseVisible {
    bool get ();
    void set (bool value);
}
Value
true to show the CandleStick wings, false to hide them
See Also
IsOpenCloseVisible


schema Field

schema Field
Namespaces ► ZedGraph ► OHLCBar ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


Size Property

Size Property
Namespaces ► ZedGraph ► OHLCBar ► Size
Gets or sets the total width to be used for drawing the opening/closing line segments ("wings") of the OHLCBar items. Units are points.
Declaration Syntax
C# Visual Basic Visual C++
public float Size{ get; set;}
Public Property Size As Single
public:
property float Size {
    float get ();
    void set (float value);
}
Value
Size in points (1/72 inch)
Remarks
The size of the candlesticks can be set by this value, which is then scaled according to the scaleFactor (see CalcScaleFactor()()). Alternatively, if IsAutoSize is true, the bar width will be set according to the maximum available cluster width less the cluster gap (see GetClusterWidth()() and MinClusterGap). That is, if IsAutoSize is true, then the value of Size will be ignored. If you modify the value of Size, then IsAutoSize will be automatically set to false.
See Also
Size


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► OHLCBar ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


OHLCBar.Default Structure

OHLCBar..::Default Structure
Namespaces ► ZedGraph ► OHLCBar ► OHLCBar..::Default
A simple struct that defines the default property values for the OHLCBar class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAutoSize | The default value for the IsAutoSize property.
 | IsOpenCloseVisible | The default display mode for symbols (IsOpenCloseVisible property). true to display symbols, false to hide them.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Size | The default width for the candlesticks (see Size), in units of points.
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


IsAutoSize Field

IsAutoSize Field
Namespaces ► ZedGraph ► OHLCBar..::Default ► IsAutoSize
The default value for the IsAutoSize property.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsAutoSize
Public Shared IsAutoSize As Boolean
public:
static bool IsAutoSize


IsOpenCloseVisible Field

IsOpenCloseVisible Field
Namespaces ► ZedGraph ► OHLCBar..::Default ► IsOpenCloseVisible
The default display mode for symbols (IsOpenCloseVisible property). true to display symbols, false to hide them.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsOpenCloseVisible
Public Shared IsOpenCloseVisible As Boolean
public:
static bool IsOpenCloseVisible


Size Field

Size Field
Namespaces ► ZedGraph ► OHLCBar..::Default ► Size
The default width for the candlesticks (see Size), in units of points.
Declaration Syntax
C# Visual Basic Visual C++
public static float Size
Public Shared Size As Single
public:
static float Size


OHLCBarItem Class

OHLCBarItem Class
Namespaces ► ZedGraph ► OHLCBarItem
Encapsulates a CandleStick curve type that displays a vertical (or horizontal) line displaying the range of data values at each sample point, plus an starting mark and an ending mark signifying the opening and closing value for the sample.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class OHLCBarItem : CurveItem, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class OHLCBarItem _
    Inherits CurveItem _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class OHLCBarItem : public CurveItem,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OHLCBarItemOHLCBarItemNew(String) | Create a new OHLCBarItem, specifying only the legend label.
 | OHLCBarItemOHLCBarItemNew(String, IPointList, Color) | Create a new OHLCBarItem using the specified properties.
 | OHLCBarItemOHLCBarItemNew(OHLCBarItem) | The Copy Constructor
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve. (Inherited from CurveItem.)
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve. (Inherited from CurveItem.)
 | Bar | Gets a reference to the OHLCBar class defined for this OHLCBarItem.
 | BaseAxis(GraphPane) | Returns a reference to the Axis object that is the "base" (independent axis) from which the values are drawn. (Inherited from CurveItem.)
 | Clear()() | Clears the points from this CurveItem. This is the same as CurveItem.Points.Clear(). (Inherited from CurveItem.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The Line/Symbol/Bar color (FillColor for the Bar). This is a common access to Line.Color, Border.Color, and Fill.Color properties for this curve. (Inherited from CurveItem.)
 | Draw(Graphics, GraphPane, Int32, Single) | Do all rendering associated with this OHLCBarItem to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object. (Overrides CurveItem.Draw(Graphics, GraphPane, Int32, Single).)
 | DrawLegendKey(Graphics, GraphPane, RectangleF, Single) | Draw a legend key entry for this OHLCBarItem at the specified location (Overrides CurveItem.DrawLegendKey(Graphics, GraphPane, RectangleF, Single).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarWidth(GraphPane) | Calculate the width of each bar, depending on the actual bar type (Inherited from CurveItem.)
 | GetCoords(GraphPane, Int32, String%) | Determine the coords for the rectangle associated with a specified point for this CurveItem (Overrides CurveItem.GetCoords(GraphPane, Int32, String%).)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides CurveItem.GetObjectData(SerializationInfo, StreamingContext).)
 | GetRange(Double%, Double%, Double%, Double%, Boolean, Boolean, GraphPane) | Go through the list of PointPair data values for this CurveItem and determine the minimum and maximum values in the data. (Inherited from CurveItem.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXAxis(GraphPane) | Get the X Axis instance (either XAxis or X2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxis(GraphPane) | Get the Y Axis instance (either YAxis or Y2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxisIndex(GraphPane) | Get the index of the Y Axis in the YAxis or Y2Axis list to which this CurveItem belongs. (Inherited from CurveItem.)
 | IsBar | Determines whether this CurveItem is a BarItem. This does not include HiLowBarItem's or ErrorBarItem's. (Inherited from CurveItem.)
 | IsLine | Determines whether this CurveItem is a LineItem. (Inherited from CurveItem.)
 | IsOverrideOrdinal | Gets or sets a value which allows you to override the normal ordinal axis behavior. (Inherited from CurveItem.)
 | IsPie | Determines whether this CurveItem is a PieItem. (Inherited from CurveItem.)
 | IsSelectable | Determines whether this CurveItem can be selected in the graph. (Inherited from CurveItem.)
 | IsSelected | Determines whether this CurveItem is selected on the graph. Note that this value changes the curve displayed color, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsVisible | Determines whether this CurveItem is visible on the graph. Note that this value turns the curve display on or off, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsX2Axis | Gets or sets a value that determines which X axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | IsY2Axis | Gets or sets a value that determines which Y axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | Item[([Int32])] | An accessor for the PointPair datum for this CurveItem. Index is the ordinal reference (zero based) of the point. (Inherited from CurveItem.)
 | Label | A Label instance that represents the Legend entry for the this CurveItem object (Inherited from CurveItem.)
 | Link | Gets or sets the hyperlink information for this CurveItem. (Inherited from CurveItem.)
 | MakeUnique()() | Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator) (Inherited from CurveItem.)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator) (Inherited from CurveItem.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NPts | Readonly property that gives the number of points that define this CurveItem object, which is the number of points in the Points data collection. (Inherited from CurveItem.)
 | Points | The IPointList of X,Y point sets that represent this CurveItem. (Inherited from CurveItem.)
 | RemovePoint(Int32) | Removes a single point from this CurveItem. (Inherited from CurveItem.)
 | schema2 | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the CurveItem. ZedGraph does not use this value for any purpose. (Inherited from CurveItem.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValueAxis(GraphPane) | Returns a reference to the Axis object that is the "value" (dependent axis) from which the points are drawn. (Inherited from CurveItem.)
 | YAxisIndex | Gets or sets the index number of the Y Axis to which this CurveItem belongs. (Inherited from CurveItem.)
Remarks
For this type to work properly, your IPointList must contain StockPt objects, rather than ordinary PointPair types. This is because the OHLCBarItem type actually displays 5 data values but the PointPair only stores 3 data values. The StockPt stores Date, Close, Open, High, and Low members. For a vertical CandleStick chart, the opening value is drawn as a horizontal line segment to the left of the vertical range bar, and the closing value is a horizontal line segment to the right. The total length of these two line segments is controlled by the Size property, which is specified in points (1/72nd inch), and scaled according to CalcScaleFactor()(). The candlesticks are drawn horizontally or vertically depending on the value of Base, which is a BarBase enum type.
Inheritance Hierarchy
Object
 | CurveItem
 |  | OHLCBarItem


OHLCBarItem Constructor

OHLCBarItem Constructor
Namespaces ► ZedGraph ► OHLCBarItem ► OHLCBarItemOHLCBarItemNew()()
Members
Icon | Member | Description
 | OHLCBarItemOHLCBarItemNew(String) | Create a new OHLCBarItem, specifying only the legend label.
 | OHLCBarItemOHLCBarItemNew(String, IPointList, Color) | Create a new OHLCBarItem using the specified properties.
 | OHLCBarItemOHLCBarItemNew(OHLCBarItem) | The Copy Constructor


OHLCBarItem Constructor (label)

OHLCBarItem Constructor (label)
Namespaces ► ZedGraph ► OHLCBarItem ► OHLCBarItemOHLCBarItemNew(String)
Create a new OHLCBarItem, specifying only the legend label.
Declaration Syntax
C# Visual Basic Visual C++
public OHLCBarItem(
    string label
)
Public Sub New ( _
    label As String _
)
public:
OHLCBarItem (
    String^ label
)
Parameters
label (String)
The label that will appear in the legend.


OHLCBarItem Constructor (label, points, color)

OHLCBarItem Constructor (label, points, color)
Namespaces ► ZedGraph ► OHLCBarItem ► OHLCBarItemOHLCBarItemNew(String, IPointList, Color)
Create a new OHLCBarItem using the specified properties.
Declaration Syntax
C# Visual Basic Visual C++
public OHLCBarItem(
    string label,
    IPointList points,
    Color color
)
Public Sub New ( _
    label As String, _
    points As IPointList, _
    color As Color _
)
public:
OHLCBarItem (
    String^ label,
    IPointList^ points,
    Color color
)
Parameters
label (String)
The _label that will appear in the legend.
points (IPointList)
An IPointList of double precision values that define the Date, Close, Open, High, and Low values for the curve. Note that this IPointList should contain StockPt items rather than PointPair items.
color (Color)
The Color to use for drawing the candlesticks.


OHLCBarItem Constructor (rhs)

OHLCBarItem Constructor (rhs)
Namespaces ► ZedGraph ► OHLCBarItem ► OHLCBarItemOHLCBarItemNew(OHLCBarItem)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public OHLCBarItem(
    OHLCBarItem rhs
)
Public Sub New ( _
    rhs As OHLCBarItem _
)
public:
OHLCBarItem (
    OHLCBarItem^ rhs
)
Parameters
rhs (OHLCBarItem)
The OHLCBarItem object from which to copy


Bar Property

Bar Property
Namespaces ► ZedGraph ► OHLCBarItem ► Bar
Gets a reference to the OHLCBar class defined for this OHLCBarItem.
Declaration Syntax
C# Visual Basic Visual C++
public OHLCBar Bar{ get;}
Public ReadOnly Property Bar As OHLCBar
public:
property OHLCBar^ Bar {
    OHLCBar^ get ();
}


Clone Method

Clone Method
Namespaces ► ZedGraph ► OHLCBarItem ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public OHLCBarItem Clone()
Public Function Clone As OHLCBarItem
public:
OHLCBarItem^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, pos, scaleFactor)

Draw Method (g, pane, pos, scaleFactor)
Namespaces ► ZedGraph ► OHLCBarItem ► Draw(Graphics, GraphPane, Int32, Single)
Do all rendering associated with this OHLCBarItem to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object.
Declaration Syntax
C# Visual Basic Visual C++
public override void Draw(
    Graphics g,
    GraphPane pane,
    int pos,
    float scaleFactor
)
Public Overrides Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    pos As Integer, _
    scaleFactor As Single _
)
public:
virtual void Draw (
    Graphics^ g,
    GraphPane^ pane,
    int pos,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
pos (Int32)
The ordinal position of the current OHLCBarItem curve.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


DrawLegendKey Method (g, pane, rect, scaleFactor)

DrawLegendKey Method (g, pane, rect, scaleFactor)
Namespaces ► ZedGraph ► OHLCBarItem ► DrawLegendKey(Graphics, GraphPane, RectangleF, Single)
Draw a legend key entry for this OHLCBarItem at the specified location
Declaration Syntax
C# Visual Basic Visual C++
public override void DrawLegendKey(
    Graphics g,
    GraphPane pane,
    RectangleF rect,
    float scaleFactor
)
Public Overrides Sub DrawLegendKey ( _
    g As Graphics, _
    pane As GraphPane, _
    rect As RectangleF, _
    scaleFactor As Single _
)
public:
virtual void DrawLegendKey (
    Graphics^ g,
    GraphPane^ pane,
    RectangleF rect,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
rect (RectangleF)
The RectangleF struct that specifies the location for the legend key
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


GetCoords Method (pane, i, coords)

GetCoords Method (pane, i, coords)
Namespaces ► ZedGraph ► OHLCBarItem ► GetCoords(GraphPane, Int32, String%)
Determine the coords for the rectangle associated with a specified point for this CurveItem
Declaration Syntax
C# Visual Basic Visual C++
public override bool GetCoords(
    GraphPane pane,
    int i,
    out string coords
)
Public Overrides Function GetCoords ( _
    pane As GraphPane, _
    i As Integer, _
    <OutAttribute> ByRef coords As String _
) As Boolean
public:
virtual bool GetCoords (
    GraphPane^ pane,
    int i,
    [OutAttribute] String^% coords
) override
Parameters
pane (GraphPane)
The GraphPane to which this curve belongs
i (Int32)
The index of the point of interest
coords (String %)
A list of coordinates that represents the "rect" for this point (used in an html AREA tag)
Return Value
true if it's a valid point, false otherwise


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► OHLCBarItem ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► OHLCBarItem ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► OHLCBarItem ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


PaneBase Class

PaneBase Class
Namespaces ► ZedGraph ► PaneBase
An abstract base class that defines basic functionality for handling a pane. This class is the parent class for MasterPane and GraphPane.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class PaneBase : ICloneable
Public MustInherit Class PaneBase _
    Implements ICloneable
public ref class PaneBase abstract : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaneBasePaneBaseNew()() | Default constructor for the PaneBase class. Leaves the Rect empty.
 | PaneBasePaneBaseNew(String, RectangleF) | Default constructor for the PaneBase class. Specifies the Title of the PaneBase, and the size of the Rect.
 | PaneBasePaneBaseNew(PaneBase) | The Copy Constructor
 | BaseDimension | BaseDimension is a double precision value that sets "normal" pane size on which all the settings are based. The BaseDimension is in inches. For example, if the BaseDimension is 8.0 inches and the Title size is 14 points. Then the pane title font will be 14 points high when the Rect is approximately 8.0 inches wide. If the Rect is 4.0 inches wide, the pane title font will be 7 points high. Most features of the graph are scaled in this manner.
 | Border | Gets or sets the Border class for drawing the border border around the Rect
 | CalcClientRect(Graphics, Single) | Calculate the client area rectangle based on the Rect.
 | CalcScaleFactor()() | Calculate the scaling factor based on the ratio of the current Rect dimensions and the BaseDimension.
 | Draw(Graphics) | Do all rendering associated with this PaneBase to the specified Graphics device. This abstract method is implemented by the child classes.
 | DrawPaneFrame(Graphics, Single) | Draw the border _border around the Rect area.
 | DrawTitle(Graphics, Single) | Draw the Title on the graph, centered at the top of the pane.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Gets or sets the Fill data for the filling the background of the Rect.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetImage()() | Build a Bitmap object containing the graphical rendering of all the GraphPane objects in this list.
 | GetImage(Int32, Int32, Single) | Gets an image for the current GraphPane, scaled to the specified size and resolution.
 | GetMetafile(Int32, Int32) | Gets an enhanced metafile image for the current GraphPane, scaled to the specified size.
 | GetMetafile()() | Gets an enhanced metafile image for the current GraphPane.
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GraphObjList | Gets or sets the list of GraphObj items for this GraphPane
 | IsFontsScaled | Determines if the font sizes, tic sizes, gap sizes, etc. will be scaled according to the size of the Rect and the BaseDimension. If this value is set to false, then the font sizes and tic sizes will always be exactly as specified, without any scaling.
 | IsPenWidthScaled | Gets or sets the property that controls whether or not pen widths are scaled for this PaneBase.
 | Legend | Accesses the Legend for this PaneBase
 | Margin | Gets or sets the Margin instance that controls the space between the edge of the Rect and the rendered content of the graph.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Rect | The rectangle that defines the full area into which all graphics will be rendered.
 | ReSize(Graphics, RectangleF) | Change the size of the Rect. Override this method to handle resizing the contents as required.
 | ScaledPenWidth(Single, Single) | Calculate the scaled pen width, taking into account the scaleFactor and the setting of the IsPenWidthScaled property of the pane.
 | schema | Current schema value that defines the version of the serialized file
 | ShallowClone()() | Create a shallow, memberwise copy of this class.
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone
 | Tag | Gets or sets the user-defined tag for this PaneBase. This tag can be any user-defined value. If it is a String type, it can be used as a parameter to the IndexOfTag(String) method.
 | Title | Gets the Label instance that contains the text and attributes of the title. This text can be multiple lines separated by newline characters ('\n').
 | TitleGap | Gets or sets the gap between the bottom of the pane title and the client area of the pane. This is expressed as a fraction of the scaled Title character height.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PaneBase
 |  | MasterPane
 |  | GraphPane


PaneBase Constructor

PaneBase Constructor
Namespaces ► ZedGraph ► PaneBase ► PaneBasePaneBaseNew()()
Members
Icon | Member | Description
 | PaneBasePaneBaseNew()() | Default constructor for the PaneBase class. Leaves the Rect empty.
 | PaneBasePaneBaseNew(String, RectangleF) | Default constructor for the PaneBase class. Specifies the Title of the PaneBase, and the size of the Rect.
 | PaneBasePaneBaseNew(PaneBase) | The Copy Constructor


PaneBase Constructor

PaneBase Constructor
Namespaces ► ZedGraph ► PaneBase ► PaneBasePaneBaseNew()()
Default constructor for the PaneBase class. Leaves the Rect empty.
Declaration Syntax
C# Visual Basic Visual C++
public PaneBase()
Public Sub New
public:
PaneBase ()


PaneBase Constructor (title, paneRect)

PaneBase Constructor (title, paneRect)
Namespaces ► ZedGraph ► PaneBase ► PaneBasePaneBaseNew(String, RectangleF)
Default constructor for the PaneBase class. Specifies the Title of the PaneBase, and the size of the Rect.
Declaration Syntax
C# Visual Basic Visual C++
public PaneBase(
    string title,
    RectangleF paneRect
)
Public Sub New ( _
    title As String, _
    paneRect As RectangleF _
)
public:
PaneBase (
    String^ title,
    RectangleF paneRect
)
Parameters
title (String)
paneRect (RectangleF)


PaneBase Constructor (rhs)

PaneBase Constructor (rhs)
Namespaces ► ZedGraph ► PaneBase ► PaneBasePaneBaseNew(PaneBase)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public PaneBase(
    PaneBase rhs
)
Public Sub New ( _
    rhs As PaneBase _
)
public:
PaneBase (
    PaneBase^ rhs
)
Parameters
rhs (PaneBase)
The PaneBase object from which to copy


BaseDimension Property

BaseDimension Property
Namespaces ► ZedGraph ► PaneBase ► BaseDimension
BaseDimension is a double precision value that sets "normal" pane size on which all the settings are based. The BaseDimension is in inches. For example, if the BaseDimension is 8.0 inches and the Title size is 14 points. Then the pane title font will be 14 points high when the Rect is approximately 8.0 inches wide. If the Rect is 4.0 inches wide, the pane title font will be 7 points high. Most features of the graph are scaled in this manner.
Declaration Syntax
C# Visual Basic Visual C++
public float BaseDimension{ get; set;}
Public Property BaseDimension As Single
public:
property float BaseDimension {
    float get ();
    void set (float value);
}
Value
The base dimension reference for the Rect, in inches
See Also
BaseDimension
IsFontsScaled
CalcScaleFactor()()


Border Property

Border Property
Namespaces ► ZedGraph ► PaneBase ► Border
Gets or sets the Border class for drawing the border border around the Rect
Declaration Syntax
C# Visual Basic Visual C++
public Border Border{ get; set;}
Public Property Border As Border
public:
property Border^ Border {
    Border^ get ();
    void set (Border^ value);
}
See Also
BorderColor
BorderPenWidth


CalcClientRect Method (g, scaleFactor)

CalcClientRect Method (g, scaleFactor)
Namespaces ► ZedGraph ► PaneBase ► CalcClientRect(Graphics, Single)
Calculate the client area rectangle based on the Rect.
Declaration Syntax
C# Visual Basic Visual C++
public RectangleF CalcClientRect(
    Graphics g,
    float scaleFactor
)
Public Function CalcClientRect ( _
    g As Graphics, _
    scaleFactor As Single _
) As RectangleF
public:
RectangleF CalcClientRect (
    Graphics^ g,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
scaleFactor (Single)
The scaling factor for the features of the graph based on the BaseDimension. This scaling factor is calculated by the CalcScaleFactor()() method. The scale factor represents a linear multiple to be applied to font sizes, symbol sizes, etc.
Return Value
The calculated chart rect, in pixel coordinates.
Remarks
The client rectangle is the actual area available for GraphPane or MasterPane items after taking out space for the margins and the title. This method does not take out the area required for the Legend. To do so, you must separately call CalcRect(Graphics, PaneBase, Single, RectangleF%).


CalcScaleFactor Method

CalcScaleFactor Method
Namespaces ► ZedGraph ► PaneBase ► CalcScaleFactor()()
Calculate the scaling factor based on the ratio of the current Rect dimensions and the BaseDimension.
Declaration Syntax
C# Visual Basic Visual C++
public float CalcScaleFactor()
Public Function CalcScaleFactor As Single
public:
float CalcScaleFactor ()
Return Value
A Single value representing the scaling factor to use for the rendering calculations.
Remarks
This scaling factor is used to proportionally scale the features of the MasterPane so that small graphs don't have huge fonts, and vice versa. The scale factor represents a linear multiple to be applied to font sizes, symbol sizes, tic sizes, gap sizes, pen widths, etc. The units of the scale factor are "World Pixels" per "Standard Point". If any object size, in points, is multiplied by this scale factor, the result is the size, in pixels, that the object should be drawn using the standard GDI+ drawing instructions. A "Standard Point" is a dimension based on points (1/72nd inch) assuming that the Rect size matches the BaseDimension. Note that "World Pixels" will still be transformed by the GDI+ transform matrices to result in "Output Device Pixels", but "World Pixels" are the reference basis for the drawing commands.
See Also
BaseDimension


Draw Method (g)

Draw Method (g)
Namespaces ► ZedGraph ► PaneBase ► Draw(Graphics)
Do all rendering associated with this PaneBase to the specified Graphics device. This abstract method is implemented by the child classes.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void Draw(
    Graphics g
)
Public Overridable Sub Draw ( _
    g As Graphics _
)
public:
virtual void Draw (
    Graphics^ g
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.


DrawPaneFrame Method (g, scaleFactor)

DrawPaneFrame Method (g, scaleFactor)
Namespaces ► ZedGraph ► PaneBase ► DrawPaneFrame(Graphics, Single)
Draw the border _border around the Rect area.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawPaneFrame(
    Graphics g,
    float scaleFactor
)
Public Sub DrawPaneFrame ( _
    g As Graphics, _
    scaleFactor As Single _
)
public:
void DrawPaneFrame (
    Graphics^ g,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
scaleFactor (Single)
The scaling factor for the features of the graph based on the BaseDimension. This scaling factor is calculated by the CalcScaleFactor()() method. The scale factor represents a linear multiple to be applied to font sizes, symbol sizes, etc.


DrawTitle Method (g, scaleFactor)

DrawTitle Method (g, scaleFactor)
Namespaces ► ZedGraph ► PaneBase ► DrawTitle(Graphics, Single)
Draw the Title on the graph, centered at the top of the pane.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawTitle(
    Graphics g,
    float scaleFactor
)
Public Sub DrawTitle ( _
    g As Graphics, _
    scaleFactor As Single _
)
public:
void DrawTitle (
    Graphics^ g,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
scaleFactor (Single)
The scaling factor for the features of the graph based on the BaseDimension. This scaling factor is calculated by the CalcScaleFactor()() method. The scale factor represents a linear multiple to be applied to font sizes, symbol sizes, etc.


Fill Property

Fill Property
Namespaces ► ZedGraph ► PaneBase ► Fill
Gets or sets the Fill data for the filling the background of the Rect.
Declaration Syntax
C# Visual Basic Visual C++
public Fill Fill{ get; set;}
Public Property Fill As Fill
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}


GetImage Method

GetImage Method
Namespaces ► ZedGraph ► PaneBase ► GetImage()()
Members
Icon | Member | Description
 | GetImage()() | Build a Bitmap object containing the graphical rendering of all the GraphPane objects in this list.
 | GetImage(Int32, Int32, Single) | Gets an image for the current GraphPane, scaled to the specified size and resolution.


GetImage Method

GetImage Method
Namespaces ► ZedGraph ► PaneBase ► GetImage()()
Build a Bitmap object containing the graphical rendering of all the GraphPane objects in this list.
Declaration Syntax
C# Visual Basic Visual C++
public Bitmap GetImage()
Public Function GetImage As Bitmap
public:
Bitmap^ GetImage ()
Value
A Bitmap object rendered with the current graph.
See Also
GetImage(Int32, Int32, Single)
GetMetafile()()
GetMetafile(Int32, Int32)


GetImage Method (width, height, dpi)

GetImage Method (width, height, dpi)
Namespaces ► ZedGraph ► PaneBase ► GetImage(Int32, Int32, Single)
Gets an image for the current GraphPane, scaled to the specified size and resolution.
Declaration Syntax
C# Visual Basic Visual C++
public Bitmap GetImage(
    int width,
    int height,
    float dpi
)
Public Function GetImage ( _
    width As Integer, _
    height As Integer, _
    dpi As Single _
) As Bitmap
public:
Bitmap^ GetImage (
    int width,
    int height,
    float dpi
)
Parameters
width (Int32)
The scaled width of the bitmap in pixels
height (Int32)
The scaled height of the bitmap in pixels
dpi (Single)
The resolution of the bitmap, in dots per inch
See Also
GetImage()()
GetMetafile()()
GetMetafile(Int32, Int32)
Bitmap


GetMetafile Method

GetMetafile Method
Namespaces ► ZedGraph ► PaneBase ► GetMetafile()()
Members
Icon | Member | Description
 | GetMetafile(Int32, Int32) | Gets an enhanced metafile image for the current GraphPane, scaled to the specified size.
 | GetMetafile()() | Gets an enhanced metafile image for the current GraphPane.


GetMetafile Method

GetMetafile Method
Namespaces ► ZedGraph ► PaneBase ► GetMetafile()()
Gets an enhanced metafile image for the current GraphPane.
Declaration Syntax
C# Visual Basic Visual C++
public Metafile GetMetafile()
Public Function GetMetafile As Metafile
public:
Metafile^ GetMetafile ()
See Also
GetImage()()
GetImage(Int32, Int32, Single)
GetMetafile(Int32, Int32)


GetMetafile Method (width, height)

GetMetafile Method (width, height)
Namespaces ► ZedGraph ► PaneBase ► GetMetafile(Int32, Int32)
Gets an enhanced metafile image for the current GraphPane, scaled to the specified size.
Declaration Syntax
C# Visual Basic Visual C++
public Metafile GetMetafile(
    int width,
    int height
)
Public Function GetMetafile ( _
    width As Integer, _
    height As Integer _
) As Metafile
public:
Metafile^ GetMetafile (
    int width,
    int height
)
Parameters
width (Int32)
The "effective" scaled width of the bitmap in pixels
height (Int32)
The "effective" scaled height of the bitmap in pixels
Remarks
By definition, a Metafile is a vector drawing, and therefore scaling should not matter. However, this method is provided because certain options in Zedgraph, such as IsFontsScaled are affected by the size of the expected image.
See Also
GetImage()()
GetImage(Int32, Int32, Single)
GetMetafile()()


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► PaneBase ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


GraphObjList Property

GraphObjList Property
Namespaces ► ZedGraph ► PaneBase ► GraphObjList
Gets or sets the list of GraphObj items for this GraphPane
Declaration Syntax
C# Visual Basic Visual C++
public GraphObjList GraphObjList{ get; set;}
Public Property GraphObjList As GraphObjList
public:
property GraphObjList^ GraphObjList {
    GraphObjList^ get ();
    void set (GraphObjList^ value);
}
Value
A reference to a GraphObjList collection object


IsFontsScaled Property

IsFontsScaled Property
Namespaces ► ZedGraph ► PaneBase ► IsFontsScaled
Determines if the font sizes, tic sizes, gap sizes, etc. will be scaled according to the size of the Rect and the BaseDimension. If this value is set to false, then the font sizes and tic sizes will always be exactly as specified, without any scaling.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsFontsScaled{ get; set;}
Public Property IsFontsScaled As Boolean
public:
property bool IsFontsScaled {
    bool get ();
    void set (bool value);
}
Value
True to have the fonts and tics scaled, false to have them constant
See Also
CalcScaleFactor()()


IsPenWidthScaled Property

IsPenWidthScaled Property
Namespaces ► ZedGraph ► PaneBase ► IsPenWidthScaled
Gets or sets the property that controls whether or not pen widths are scaled for this PaneBase.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPenWidthScaled{ get; set;}
Public Property IsPenWidthScaled As Boolean
public:
property bool IsPenWidthScaled {
    bool get ();
    void set (bool value);
}
Value
true to scale the pen widths according to the size of the graph, false otherwise.
Remarks
This value is only applicable if IsFontsScaled is true. If IsFontsScaled is false, then no scaling will be done, regardless of the value of IsPenWidthScaled. Note that scaling the pen widths can cause "artifacts" to appear at typical screen resolutions. This occurs because of roundoff differences; in some cases the pen width may round to 1 pixel wide and in another it may round to 2 pixels wide. The result is typically undesirable. Therefore, this option defaults to false. This option is primarily useful for high resolution output, such as printer output or high resolution bitmaps (from GetImage(Int32, Int32, Single)) where it is desirable to have the pen width be consistent with the screen image.
See Also
IsFontsScaled
CalcScaleFactor()()


Legend Property

Legend Property
Namespaces ► ZedGraph ► PaneBase ► Legend
Accesses the Legend for this PaneBase
Declaration Syntax
C# Visual Basic Visual C++
public Legend Legend{ get;}
Public ReadOnly Property Legend As Legend
public:
property Legend^ Legend {
    Legend^ get ();
}
Value
A reference to a Legend object


Margin Property

Margin Property
Namespaces ► ZedGraph ► PaneBase ► Margin
Gets or sets the Margin instance that controls the space between the edge of the Rect and the rendered content of the graph.
Declaration Syntax
C# Visual Basic Visual C++
public Margin Margin{ get; set;}
Public Property Margin As Margin
public:
property Margin^ Margin {
    Margin^ get ();
    void set (Margin^ value);
}


Rect Property

Rect Property
Namespaces ► ZedGraph ► PaneBase ► Rect
The rectangle that defines the full area into which all graphics will be rendered.
Declaration Syntax
C# Visual Basic Visual C++
public RectangleF Rect{ get; set;}
Public Property Rect As RectangleF
public:
property RectangleF Rect {
    RectangleF get ();
    void set (RectangleF value);
}
Value
Units are pixels.
Remarks
Note that this rectangle has x, y, width, and height. Most of the GDI+ graphic primitive actually draw one pixel beyond those dimensions. For example, for a rectangle of ( X=0, Y=0, Width=100, Height=100 ), GDI+ would draw into pixels 0 through 100, which is actually 101 pixels. For the ZedGraph Rect, a Width of 100 pixels means that pixels 0 through 99 are used
See Also
ReSize(Graphics, RectangleF)


ReSize Method (g, rect)

ReSize Method (g, rect)
Namespaces ► ZedGraph ► PaneBase ► ReSize(Graphics, RectangleF)
Change the size of the Rect. Override this method to handle resizing the contents as required.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void ReSize(
    Graphics g,
    RectangleF rect
)
Public Overridable Sub ReSize ( _
    g As Graphics, _
    rect As RectangleF _
)
public:
virtual void ReSize (
    Graphics^ g,
    RectangleF rect
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
rect (RectangleF)
The new size for the Rect.


ScaledPenWidth Method (penWidth, scaleFactor)

ScaledPenWidth Method (penWidth, scaleFactor)
Namespaces ► ZedGraph ► PaneBase ► ScaledPenWidth(Single, Single)
Calculate the scaled pen width, taking into account the scaleFactor and the setting of the IsPenWidthScaled property of the pane.
Declaration Syntax
C# Visual Basic Visual C++
public float ScaledPenWidth(
    float penWidth,
    float scaleFactor
)
Public Function ScaledPenWidth ( _
    penWidth As Single, _
    scaleFactor As Single _
) As Single
public:
float ScaledPenWidth (
    float penWidth,
    float scaleFactor
)
Parameters
penWidth (Single)
The pen width, in points (1/72 inch)
scaleFactor (Single)
The scaling factor for the features of the graph based on the BaseDimension. This scaling factor is calculated by the CalcScaleFactor()() method. The scale factor represents a linear multiple to be applied to font sizes, symbol sizes, etc.
Return Value
The scaled pen width, in world pixels


schema Field

schema Field
Namespaces ► ZedGraph ► PaneBase ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


ShallowClone Method

ShallowClone Method
Namespaces ► ZedGraph ► PaneBase ► ShallowClone()()
Create a shallow, memberwise copy of this class.
Declaration Syntax
C# Visual Basic Visual C++
public PaneBase ShallowClone()
Public Function ShallowClone As PaneBase
public:
PaneBase^ ShallowClone ()
Return Value
a new copy of the class
Remarks
Note that this method uses MemberWiseClone, which will copy all members (shallow) including those of classes derived from this class.


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► PaneBase ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object
Remarks
Note that this method must be called with an explicit cast to ICloneable, and that it is inherently virtual. For example:
CopyC#
ParentClass foo = new ChildClass();
ChildClass bar = (ChildClass) ((ICloneable)foo).Clone();
 Assume that ChildClass is inherited from ParentClass. Even though foo is declared with ParentClass, it is actually an instance of ChildClass. Calling the ICloneable implementation of Clone() on foo actually calls ChildClass.Clone() as if it were a virtual function.


Tag Property

Tag Property
Namespaces ► ZedGraph ► PaneBase ► Tag
Gets or sets the user-defined tag for this PaneBase. This tag can be any user-defined value. If it is a String type, it can be used as a parameter to the IndexOfTag(String) method.
Declaration Syntax
C# Visual Basic Visual C++
public Object Tag{ get; set;}
Public Property Tag As Object
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}
Remarks
Note that, if you are going to Serialize ZedGraph data, then any type that you store in Tag must be a serializable type (or it will cause an exception).


Title Property

Title Property
Namespaces ► ZedGraph ► PaneBase ► Title
Gets the Label instance that contains the text and attributes of the title. This text can be multiple lines separated by newline characters ('\n').
Declaration Syntax
C# Visual Basic Visual C++
public Label Title{ get;}
Public ReadOnly Property Title As Label
public:
property Label^ Title {
    Label^ get ();
}
See Also
FontSpec
FontColor
FontBold
FontItalic
FontUnderline
FontFamily
FontSize


TitleGap Property

TitleGap Property
Namespaces ► ZedGraph ► PaneBase ► TitleGap
Gets or sets the gap between the bottom of the pane title and the client area of the pane. This is expressed as a fraction of the scaled Title character height.
Declaration Syntax
C# Visual Basic Visual C++
public float TitleGap{ get; set;}
Public Property TitleGap As Single
public:
property float TitleGap {
    float get ();
    void set (float value);
}


PaneBase.Default Structure

PaneBase..::Default Structure
Namespaces ► ZedGraph ► PaneBase ► PaneBase..::Default
A simple struct that defines the default property values for the PaneBase class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BaseDimension | The default dimension of the Rect, which defines a normal sized plot. This dimension is used to scale the fonts, symbols, etc. according to the actual size of the Rect.
 | BorderColor | The default color for the PaneBase border. (Border property).
 | BorderPenWidth | The default pen width for the PaneBase border. (Border property). Units are in points (1/72 inch).
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | FillColor | The default color for the Rect background. (Fill property).
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontBold | The default font bold mode for the Title (IsBold property). true for a bold typeface, false otherwise.
 | FontColor | The default font color for the Title (FontColor property).
 | FontFamily | The default font family for the title (Title property).
 | FontItalic | The default font italic mode for the Title (IsItalic property). true for an italic typeface, false otherwise.
 | FontSize | The default font size (points) for the Title (Size property).
 | FontUnderline | The default font underline mode for the Title (IsUnderline property). true for an underlined typeface, false otherwise.
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsBorderVisible | The default border mode for the PaneBase. (Border property). true to draw a border around the Rect, false otherwise.
 | IsFontsScaled | The default setting for the IsFontsScaled option. true to have all fonts scaled according to BaseDimension, false otherwise.
 | IsPenWidthScaled | The default setting for the IsPenWidthScaled option. true to have all pen widths scaled according to BaseDimension, false otherwise.
 | IsShowTitle | The default display mode for the title at the top of the pane (Title IsVisible property). true to display a title, false otherwise.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TitleGap | The default value for the TitleGap property, expressed as a fraction of the scaled Title character height.
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


BaseDimension Field

BaseDimension Field
Namespaces ► ZedGraph ► PaneBase..::Default ► BaseDimension
The default dimension of the Rect, which defines a normal sized plot. This dimension is used to scale the fonts, symbols, etc. according to the actual size of the Rect.
Declaration Syntax
C# Visual Basic Visual C++
public static float BaseDimension
Public Shared BaseDimension As Single
public:
static float BaseDimension
See Also
CalcScaleFactor()()


BorderColor Field

BorderColor Field
Namespaces ► ZedGraph ► PaneBase..::Default ► BorderColor
The default color for the PaneBase border. (Border property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color BorderColor
Public Shared BorderColor As Color
public:
static Color BorderColor


BorderPenWidth Field

BorderPenWidth Field
Namespaces ► ZedGraph ► PaneBase..::Default ► BorderPenWidth
The default pen width for the PaneBase border. (Border property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float BorderPenWidth
Public Shared BorderPenWidth As Single
public:
static float BorderPenWidth


FillColor Field

FillColor Field
Namespaces ► ZedGraph ► PaneBase..::Default ► FillColor
The default color for the Rect background. (Fill property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color FillColor
Public Shared FillColor As Color
public:
static Color FillColor


FontBold Field

FontBold Field
Namespaces ► ZedGraph ► PaneBase..::Default ► FontBold
The default font bold mode for the Title (IsBold property). true for a bold typeface, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool FontBold
Public Shared FontBold As Boolean
public:
static bool FontBold


FontColor Field

FontColor Field
Namespaces ► ZedGraph ► PaneBase..::Default ► FontColor
The default font color for the Title (FontColor property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color FontColor
Public Shared FontColor As Color
public:
static Color FontColor


FontFamily Field

FontFamily Field
Namespaces ► ZedGraph ► PaneBase..::Default ► FontFamily
The default font family for the title (Title property).
Declaration Syntax
C# Visual Basic Visual C++
public static string FontFamily
Public Shared FontFamily As String
public:
static String^ FontFamily


FontItalic Field

FontItalic Field
Namespaces ► ZedGraph ► PaneBase..::Default ► FontItalic
The default font italic mode for the Title (IsItalic property). true for an italic typeface, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool FontItalic
Public Shared FontItalic As Boolean
public:
static bool FontItalic


FontSize Field

FontSize Field
Namespaces ► ZedGraph ► PaneBase..::Default ► FontSize
The default font size (points) for the Title (Size property).
Declaration Syntax
C# Visual Basic Visual C++
public static float FontSize
Public Shared FontSize As Single
public:
static float FontSize


FontUnderline Field

FontUnderline Field
Namespaces ► ZedGraph ► PaneBase..::Default ► FontUnderline
The default font underline mode for the Title (IsUnderline property). true for an underlined typeface, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool FontUnderline
Public Shared FontUnderline As Boolean
public:
static bool FontUnderline


IsBorderVisible Field

IsBorderVisible Field
Namespaces ► ZedGraph ► PaneBase..::Default ► IsBorderVisible
The default border mode for the PaneBase. (Border property). true to draw a border around the Rect, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsBorderVisible
Public Shared IsBorderVisible As Boolean
public:
static bool IsBorderVisible


IsFontsScaled Field

IsFontsScaled Field
Namespaces ► ZedGraph ► PaneBase..::Default ► IsFontsScaled
The default setting for the IsFontsScaled option. true to have all fonts scaled according to BaseDimension, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsFontsScaled
Public Shared IsFontsScaled As Boolean
public:
static bool IsFontsScaled
See Also
CalcScaleFactor()()


IsPenWidthScaled Field

IsPenWidthScaled Field
Namespaces ► ZedGraph ► PaneBase..::Default ► IsPenWidthScaled
The default setting for the IsPenWidthScaled option. true to have all pen widths scaled according to BaseDimension, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsPenWidthScaled
Public Shared IsPenWidthScaled As Boolean
public:
static bool IsPenWidthScaled
See Also
CalcScaleFactor()()


IsShowTitle Field

IsShowTitle Field
Namespaces ► ZedGraph ► PaneBase..::Default ► IsShowTitle
The default display mode for the title at the top of the pane (Title IsVisible property). true to display a title, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsShowTitle
Public Shared IsShowTitle As Boolean
public:
static bool IsShowTitle


TitleGap Field

TitleGap Field
Namespaces ► ZedGraph ► PaneBase..::Default ► TitleGap
The default value for the TitleGap property, expressed as a fraction of the scaled Title character height.
Declaration Syntax
C# Visual Basic Visual C++
public static float TitleGap
Public Shared TitleGap As Single
public:
static float TitleGap


PaneLayout Enumeration

PaneLayout Enumeration
Namespaces ► ZedGraph ► PaneLayout
Define the auto layout options for the SetLayout(Graphics, PaneLayout) method.
Declaration Syntax
C# Visual Basic Visual C++
public enum PaneLayout
Public Enumeration PaneLayout
public enum class PaneLayout
Members
Member | Description
ForceSquare | Layout the GraphPane's so they are in a square grid (always 2x2, 3x3, 4x4), leaving blank spaces as required.
SquareColPreferred | Layout the GraphPane's so they are in a general square (2x2, 3x3, etc.), but use extra columns when necessary (row x column = 1x2, 2x3, 3x4, etc.) depending on the total number of panes required.
SquareRowPreferred | Layout the GraphPane's so they are in a general square (2x2, 3x3, etc.), but use extra rows when necessary (2x1, 3x2, 4x3, etc.) depending on the total number of panes required.
SingleRow | Layout the GraphPane's in a single row
SingleColumn | Layout the GraphPane's in a single column
ExplicitCol12 | Layout the GraphPane's with an explicit number of columns: The first row has 1 column and the second row has 2 columns for a total of 3 panes.
ExplicitCol21 | Layout the GraphPane's with an explicit number of columns: The first row has 2 columns and the second row has 1 column for a total of 3 panes.
ExplicitCol23 | Layout the GraphPane's with an explicit number of columns: The first row has 2 columns and the second row has 3 columns for a total of 5 panes.
ExplicitCol32 | Layout the GraphPane's with an explicit number of columns: The first row has 3 columns and the second row has 2 columns for a total of 5 panes.
ExplicitRow12 | Layout the GraphPane's with an explicit number of rows: The first column has 1 row and the second column has 2 rows for a total of 3 panes.
ExplicitRow21 | Layout the GraphPane's with an explicit number of rows: The first column has 2 rows and the second column has 1 row for a total of 3 panes.
ExplicitRow23 | Layout the GraphPane's with an explicit number of rows: The first column has 2 rows and the second column has 3 rows for a total of 5 panes.
ExplicitRow32 | Layout the GraphPane's with an explicit number of rows: The first column has 3 rows and the second column has 2 rows for a total of 5 panes.


PaneLayoutMgr Class

PaneLayoutMgr Class
Namespaces ► ZedGraph ► PaneLayoutMgr
internal class to store pane layout details for the MasterPane
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PaneLayoutMgr : ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class PaneLayoutMgr _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class PaneLayoutMgr : ICloneable,
    ISerializable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PaneLayoutMgrPaneLayoutMgrNew(SerializationInfo, StreamingContext) | Constructor for deserializing objects
 | Clone()() | Typesafe, deep-copy clone method.
 | DoLayout(Graphics, MasterPane) | Modify the GraphPane Rect sizes of each GraphPane such that they fit within the MasterPane in a pre-configured layout.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetLayout(PaneLayout) | Automatically set all of the GraphPane Rect's in the list to a pre-defined layout configuration from a PaneLayout enumeration.
 | SetLayout(Int32, Int32) | Automatically set all of the GraphPane Rect's in the list to a reasonable configuration.
 | SetLayout(Boolean, array<Int32>[]()) | Automatically set all of the GraphPane Rect's in the list to the specified configuration.
 | SetLayout(Boolean, array<Int32>[](), array<Single>[]()) | Automatically set all of the GraphPane Rect's in the list to the specified configuration.
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PaneLayoutMgr


PaneLayoutMgr Constructor (info, context)

PaneLayoutMgr Constructor (info, context)
Namespaces ► ZedGraph ► PaneLayoutMgr ► PaneLayoutMgrPaneLayoutMgrNew(SerializationInfo, StreamingContext)
Constructor for deserializing objects
Declaration Syntax
C# Visual Basic Visual C++
public PaneLayoutMgr(
    SerializationInfo info,
    StreamingContext context
)
Public Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
PaneLayoutMgr (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


Clone Method

Clone Method
Namespaces ► ZedGraph ► PaneLayoutMgr ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public PaneLayoutMgr Clone()
Public Function Clone As PaneLayoutMgr
public:
PaneLayoutMgr^ Clone ()
Return Value
A new, independent copy of this class


DoLayout Method (g, master)

DoLayout Method (g, master)
Namespaces ► ZedGraph ► PaneLayoutMgr ► DoLayout(Graphics, MasterPane)
Modify the GraphPane Rect sizes of each GraphPane such that they fit within the MasterPane in a pre-configured layout.
Declaration Syntax
C# Visual Basic Visual C++
public void DoLayout(
    Graphics g,
    MasterPane master
)
Public Sub DoLayout ( _
    g As Graphics, _
    master As MasterPane _
)
public:
void DoLayout (
    Graphics^ g,
    MasterPane^ master
)
Parameters
g (Graphics)
A Graphics instance to be used for font sizing, etc. in determining the layout configuration.
master (MasterPane)
The MasterPane instance which is to be resized.
Remarks
The SetLayout(PaneLayout) method (and overloads) is used for setting the layout configuration.
See Also
SetLayout(PaneLayout)
SetLayout(Int32, Int32)
SetLayout(Boolean, array<Int32>[]())
SetLayout(Boolean, array<Int32>[](), array<Single>[]())


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► PaneLayoutMgr ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


SetLayout Method

SetLayout Method
Namespaces ► ZedGraph ► PaneLayoutMgr ► SetLayout()()
The SetLayout() methods setup the desired layout of the GraphPane objects within a MasterPane. These functions do not make any changes, they merely set the parameters so that future calls to ReSize(Graphics, RectangleF) or DoLayout(Graphics, MasterPane) will use the desired layout.

The layout options include a set of "canned" layouts provided by the PaneLayout enumeration, options to just set a specific number of rows and columns of panes (and all pane sizes are the same), and more customized options of specifying the number or rows in each column or the number of columns in each row, along with proportional values that determine the size of each individual column or row.
Members
Icon | Member | Description
 | SetLayout(PaneLayout) | Automatically set all of the GraphPane Rect's in the list to a pre-defined layout configuration from a PaneLayout enumeration.
 | SetLayout(Int32, Int32) | Automatically set all of the GraphPane Rect's in the list to a reasonable configuration.
 | SetLayout(Boolean, array<Int32>[]()) | Automatically set all of the GraphPane Rect's in the list to the specified configuration.
 | SetLayout(Boolean, array<Int32>[](), array<Single>[]()) | Automatically set all of the GraphPane Rect's in the list to the specified configuration.


SetLayout Method (isColumnSpecified, countList)

SetLayout Method (isColumnSpecified, countList)
Namespaces ► ZedGraph ► PaneLayoutMgr ► SetLayout(Boolean, array<Int32>[]())
Automatically set all of the GraphPane Rect's in the list to the specified configuration.
Declaration Syntax
C# Visual Basic Visual C++
public void SetLayout(
    bool isColumnSpecified,
    int[] countList
)
Public Sub SetLayout ( _
    isColumnSpecified As Boolean, _
    countList As Integer() _
)
public:
void SetLayout (
    bool isColumnSpecified,
    array<int>^ countList
)
Parameters
isColumnSpecified (Boolean)
Specifies whether the number of columns in each row, or the number of rows in each column will be specified. A value of true indicates the number of columns in each row are specified in .
countList (array< Int32 >[]())
An integer array specifying either the number of columns in each row or the number of rows in each column, depending on the value of .
Remarks
This method specifies the number of rows in each column, or the number of columns in each row, allowing for irregular layouts. Overloads are available that provide other layout options.
See Also
SetLayout(PaneLayout)
SetLayout(Int32, Int32)
SetLayout(Boolean, array<Int32>[](), array<Single>[]())


SetLayout Method (isColumnSpecified, countList, proportion)

SetLayout Method (isColumnSpecified, countList, proportion)
Namespaces ► ZedGraph ► PaneLayoutMgr ► SetLayout(Boolean, array<Int32>[](), array<Single>[]())
Automatically set all of the GraphPane Rect's in the list to the specified configuration.
Declaration Syntax
C# Visual Basic Visual C++
public void SetLayout(
    bool isColumnSpecified,
    int[] countList,
    float[] proportion
)
Public Sub SetLayout ( _
    isColumnSpecified As Boolean, _
    countList As Integer(), _
    proportion As Single() _
)
public:
void SetLayout (
    bool isColumnSpecified,
    array<int>^ countList,
    array<float>^ proportion
)
Parameters
isColumnSpecified (Boolean)
Specifies whether the number of columns in each row, or the number of rows in each column will be specified. A value of true indicates the number of columns in each row are specified in .
countList (array< Int32 >[]())
An integer array specifying either the number of columns in each row or the number of rows in each column, depending on the value of .
proportion (array< Single >[]())
An array of float values specifying proportional sizes for each row or column. Note that these proportions apply to the non-specified dimension -- that is, if is true, then these proportions apply to the row heights, and if is false, then these proportions apply to the column widths. The values in this array are arbitrary floats -- the dimension of any given row or column is that particular proportional value divided by the sum of all the values. For example, let be true, and is an array with values of { 1.0, 2.0, 3.0 }. The sum of those values is 6.0. Therefore, the first row is 1/6th of the available height, the second row is 2/6th's of the available height, and the third row is 3/6th's of the available height.
Remarks
This method specifies the number of panes in each row or column, allowing for irregular layouts.
Remarks
This method specifies the number of rows in each column, or the number of columns in each row, allowing for irregular layouts. Additionally, a parameter is provided that allows varying column or row sizes. Overloads for SetLayout() are available that provide other layout options.
See Also
SetLayout(PaneLayout)
SetLayout(Int32, Int32)
SetLayout(Boolean, array<Int32>[]())


SetLayout Method (rows, columns)

SetLayout Method (rows, columns)
Namespaces ► ZedGraph ► PaneLayoutMgr ► SetLayout(Int32, Int32)
Automatically set all of the GraphPane Rect's in the list to a reasonable configuration.
Declaration Syntax
C# Visual Basic Visual C++
public void SetLayout(
    int rows,
    int columns
)
Public Sub SetLayout ( _
    rows As Integer, _
    columns As Integer _
)
public:
void SetLayout (
    int rows,
    int columns
)
Parameters
rows (Int32)
The number of rows of GraphPane objects to include in the layout
columns (Int32)
The number of columns of GraphPane objects to include in the layout
Remarks
This method explicitly specifies the number of rows and columns to use in the layout, and all GraphPane objects will have the same size. Overloads are available that provide other layout options
See Also
SetLayout(PaneLayout)
SetLayout(Boolean, array<Int32>[]())
SetLayout(Boolean, array<Int32>[](), array<Single>[]())


SetLayout Method (paneLayout)

SetLayout Method (paneLayout)
Namespaces ► ZedGraph ► PaneLayoutMgr ► SetLayout(PaneLayout)
Automatically set all of the GraphPane Rect's in the list to a pre-defined layout configuration from a PaneLayout enumeration.
Declaration Syntax
C# Visual Basic Visual C++
public void SetLayout(
    PaneLayout paneLayout
)
Public Sub SetLayout ( _
    paneLayout As PaneLayout _
)
public:
void SetLayout (
    PaneLayout paneLayout
)
Parameters
paneLayout (PaneLayout)
A PaneLayout enumeration that describes how the panes should be laid out within the Rect.
Remarks
This method uses a PaneLayout enumeration to describe the type of layout to be used. Overloads are available that provide other layout options
See Also
SetLayout(Int32, Int32)
SetLayout(Boolean, array<Int32>[]())
SetLayout(Boolean, array<Int32>[](), array<Single>[]())


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► PaneLayoutMgr ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


PaneList Class

PaneList Class
Namespaces ► ZedGraph ► PaneList
A collection class containing a list of GraphPane objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PaneList : List<GraphPane>, ICloneable
<SerializableAttribute> _
Public Class PaneList _
    Inherits List(Of GraphPane) _
    Implements ICloneable
[SerializableAttribute]
public ref class PaneList : public List<GraphPane^>,
    ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaneListPaneListNew()() | Default constructor for the collection class.
 | PaneListPaneListNew(PaneList) | The Copy Constructor
 | Add(T) | Adds an object to the end of the List<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | AddRange(IEnumerable<(Of <T>)>) | Adds the elements of the specified collection to the end of the List<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | AsReadOnly()() | Returns a read-only IList<(Of <T>)> wrapper for the current collection. (Inherited from List <(Of < GraphPane >)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < GraphPane >)>.)
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of < GraphPane >)>.)
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < GraphPane >)>.)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of < GraphPane >)>.)
 | Clear()() | Removes all elements from the List<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Contains(T) | Determines whether an element is in the List<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | ConvertAll<(Of <TOutput>)>(Converter<(Of <T, TOutput>)>) | Converts the elements in the current List<(Of <T>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of < GraphPane >)>.)
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of < GraphPane >)>.)
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < GraphPane >)>.)
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < GraphPane >)>.)
 | Count | Gets the number of elements actually contained in the List<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <T>)>) | Determines whether the List<(Of <T>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < GraphPane >)>.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | FindAll(Predicate<(Of <T>)>) | Retrieves the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < GraphPane >)>.)
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < GraphPane >)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < GraphPane >)>.)
 | FindLast(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < GraphPane >)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < GraphPane >)>.)
 | ForEach(Action<(Of <T>)>) | Performs the specified action on each element of the List<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | GetEnumerator()() | Returns an enumerator that iterates through the List<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(String) | Return the zero-based position index of the GraphPane with the specified Title.
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < GraphPane >)>.)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < GraphPane >)>.)
 | IndexOfTag(String) | Return the zero-based position index of the GraphPane with the specified Tag.
 | Insert(Int32, T) | Inserts an element into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < GraphPane >)>.)
 | InsertRange(Int32, IEnumerable<(Of <T>)>) | Inserts the elements of a collection into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < GraphPane >)>.)
 | Item[([String])] | Indexer to access the specified GraphPane object by its Title string.
 | Item[([Int32])] | Gets or sets the element at the specified index. (Inherited from List <(Of < GraphPane >)>.)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < GraphPane >)>.)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < GraphPane >)>.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | RemoveAll(Predicate<(Of <T>)>) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < GraphPane >)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of < GraphPane >)>.)
 | schema | Current schema value that defines the version of the serialized file
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer. (Inherited from List <(Of < GraphPane >)>.)
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < GraphPane >)>.)
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < GraphPane >)>.)
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>. (Inherited from List <(Of < GraphPane >)>.)
 | ICollection<(Of <T>)>..::IsReadOnly | (Inherited from List <(Of < GraphPane >)>.)
 | IEnumerable<(Of <T>)>..::GetEnumerator()() | (Inherited from List <(Of < GraphPane >)>.)
 | ICollection..::CopyTo(Array, Int32) | (Inherited from List <(Of < GraphPane >)>.)
 | ICollection..::IsSynchronized | (Inherited from List <(Of < GraphPane >)>.)
 | ICollection..::SyncRoot | (Inherited from List <(Of < GraphPane >)>.)
 | IEnumerable..::GetEnumerator()() | (Inherited from List <(Of < GraphPane >)>.)
 | IList..::Add(Object) | (Inherited from List <(Of < GraphPane >)>.)
 | IList..::Contains(Object) | (Inherited from List <(Of < GraphPane >)>.)
 | IList..::IndexOf(Object) | (Inherited from List <(Of < GraphPane >)>.)
 | IList..::Insert(Int32, Object) | (Inherited from List <(Of < GraphPane >)>.)
 | IList..::IsFixedSize | (Inherited from List <(Of < GraphPane >)>.)
 | IList..::IsReadOnly | (Inherited from List <(Of < GraphPane >)>.)
 | IList..::Item[([Int32])] | (Inherited from List <(Of < GraphPane >)>.)
 | IList..::Remove(Object) | (Inherited from List <(Of < GraphPane >)>.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToArray()() | Copies the elements of the List<(Of <T>)> to a new array. (Inherited from List <(Of < GraphPane >)>.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()() | Sets the capacity to the actual number of elements in the List<(Of <T>)>, if that number is less than a threshold value. (Inherited from List <(Of < GraphPane >)>.)
 | TrueForAll(Predicate<(Of <T>)>) | Determines whether every element in the List<(Of <T>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of < GraphPane >)>.)
Inheritance Hierarchy
Object
 | List <(Of < GraphPane >)>
 |  | PaneList


PaneList Constructor

PaneList Constructor
Namespaces ► ZedGraph ► PaneList ► PaneListPaneListNew()()
Members
Icon | Member | Description
 | PaneListPaneListNew()() | Default constructor for the collection class.
 | PaneListPaneListNew(PaneList) | The Copy Constructor


PaneList Constructor

PaneList Constructor
Namespaces ► ZedGraph ► PaneList ► PaneListPaneListNew()()
Default constructor for the collection class.
Declaration Syntax
C# Visual Basic Visual C++
public PaneList()
Public Sub New
public:
PaneList ()


PaneList Constructor (rhs)

PaneList Constructor (rhs)
Namespaces ► ZedGraph ► PaneList ► PaneListPaneListNew(PaneList)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public PaneList(
    PaneList rhs
)
Public Sub New ( _
    rhs As PaneList _
)
public:
PaneList (
    PaneList^ rhs
)
Parameters
rhs (PaneList)
The PaneList object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► PaneList ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public PaneList Clone()
Public Function Clone As PaneList
public:
PaneList^ Clone ()
Return Value
A new, independent copy of this class


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► PaneList ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IndexOf Method (title)

IndexOf Method (title)
Namespaces ► ZedGraph ► PaneList ► IndexOf(String)
Return the zero-based position index of the GraphPane with the specified Title.
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    string title
)
Public Function IndexOf ( _
    title As String _
) As Integer
public:
int IndexOf (
    String^ title
)
Parameters
title (String)
The String label that is in the Title attribute of the item to be found.
Return Value
The zero-based index of the specified GraphPane, or -1 if the Title was not found in the list
Remarks
The comparison of titles is not case sensitive, but it must include all characters including punctuation, spaces, etc.
See Also
IndexOfTag(String)


IndexOfTag Method (tagStr)

IndexOfTag Method (tagStr)
Namespaces ► ZedGraph ► PaneList ► IndexOfTag(String)
Return the zero-based position index of the GraphPane with the specified Tag.
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOfTag(
    string tagStr
)
Public Function IndexOfTag ( _
    tagStr As String _
) As Integer
public:
int IndexOfTag (
    String^ tagStr
)
Parameters
tagStr (String)
The String tag that is in the Tag attribute of the item to be found.
Return Value
The zero-based index of the specified GraphPane, or -1 if the Tag string is not in the list
Remarks
In order for this method to work, the Tag property must be of type String.


Item Property (title)

Item Property (title)
Namespaces ► ZedGraph ► PaneList ► Item[([String])]
Indexer to access the specified GraphPane object by its Title string.
Declaration Syntax
C# Visual Basic Visual C++
public GraphPane this[
    string title
]{ get;}
Public ReadOnly Default Property Item ( _
    title As String _
) As GraphPane
public:
property GraphPane^ default[String^ title] {
    GraphPane^ get (String^ title);
}
Parameters
title (String)
The string title of the GraphPane object to be accessed.
Value
A GraphPane object reference.


schema Field

schema Field
Namespaces ► ZedGraph ► PaneList ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► PaneList ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


PerfDataType Enumeration

PerfDataType Enumeration
Namespaces ► ZedGraph ► PerfDataType
An enum used to specify the X or Y data type of interest -- see XData and YData.
Declaration Syntax
C# Visual Basic Visual C++
public enum PerfDataType
Public Enumeration PerfDataType
public enum class PerfDataType
Members
Member | Description
Time | The time (seconds) at which these data are measured
Distance | The distance traveled, meters
Velocity | The instantaneous velocity, meters per second
Acceleration | The instantaneous acceleration, meters per second squared


PerformanceData Class

PerformanceData Class
Namespaces ► ZedGraph ► PerformanceData
Sample data structure containing a variety of data values, in this case the values are related in that they correspond to the same time value.
Declaration Syntax
C# Visual Basic Visual C++
public class PerformanceData
Public Class PerformanceData
public ref class PerformanceData
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PerformanceDataPerformanceDataNew(Double, Double, Double, Double) | Constructor that specifies each data value in the PerformanceData struct
 | acceleration | The instantaneous acceleration, meters per second squared
 | distance | The distance traveled, meters
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([PerfDataType])] | Gets or sets the data value as specified by the PerfDataType enum
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | time | The time (seconds) at which these data are measured
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | velocity | The instantaneous velocity, meters per second
Inheritance Hierarchy
Object
PerformanceData


PerformanceData Constructor (time, distance, velocity, acceleration)

PerformanceData Constructor (time, distance, velocity, acceleration)
Namespaces ► ZedGraph ► PerformanceData ► PerformanceDataPerformanceDataNew(Double, Double, Double, Double)
Constructor that specifies each data value in the PerformanceData struct
Declaration Syntax
C# Visual Basic Visual C++
public PerformanceData(
    double time,
    double distance,
    double velocity,
    double acceleration
)
Public Sub New ( _
    time As Double, _
    distance As Double, _
    velocity As Double, _
    acceleration As Double _
)
public:
PerformanceData (
    double time,
    double distance,
    double velocity,
    double acceleration
)
Parameters
time (Double)
The time (seconds) at which these data are measured
distance (Double)
The distance traveled, meters
velocity (Double)
The instantaneous velocity, meters per second
acceleration (Double)
The instantaneous acceleration, meters per second squared


acceleration Field

acceleration Field
Namespaces ► ZedGraph ► PerformanceData ► acceleration
The instantaneous acceleration, meters per second squared
Declaration Syntax
C# Visual Basic Visual C++
public double acceleration
Public acceleration As Double
public:
double acceleration


distance Field

distance Field
Namespaces ► ZedGraph ► PerformanceData ► distance
The distance traveled, meters
Declaration Syntax
C# Visual Basic Visual C++
public double distance
Public distance As Double
public:
double distance


Item Property (type)

Item Property (type)
Namespaces ► ZedGraph ► PerformanceData ► Item[([PerfDataType])]
Gets or sets the data value as specified by the PerfDataType enum
Declaration Syntax
C# Visual Basic Visual C++
public double this[
    PerfDataType type
]{ get; set;}
Public Default Property Item ( _
    type As PerfDataType _
) As Double
public:
property double default[PerfDataType type] {
    double get (PerfDataType type);
    void set (PerfDataType type, double value);
}
Parameters
type (PerfDataType)
The required data value type


time Field

time Field
Namespaces ► ZedGraph ► PerformanceData ► time
The time (seconds) at which these data are measured
Declaration Syntax
C# Visual Basic Visual C++
public double time
Public time As Double
public:
double time


velocity Field

velocity Field
Namespaces ► ZedGraph ► PerformanceData ► velocity
The instantaneous velocity, meters per second
Declaration Syntax
C# Visual Basic Visual C++
public double velocity
Public velocity As Double
public:
double velocity


PieItem Class

PieItem Class
Namespaces ► ZedGraph ► PieItem
A class representing a pie chart object comprised of one or more PieItems.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PieItem : CurveItem, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class PieItem _
    Inherits CurveItem _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class PieItem : public CurveItem,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PieItemPieItemNew(Double, Color, Color, Single, Double, String) | Create a new PieItem, providing a gradient fill for the pie color.
 | PieItemPieItemNew(Double, Color, Double, String) | Create a new PieItem.
 | PieItemPieItemNew(Double, String) | Create a new PieItem.
 | PieItemPieItemNew(PieItem) | The Copy Constructor
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve. (Inherited from CurveItem.)
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve. (Inherited from CurveItem.)
 | BaseAxis(GraphPane) | Returns a reference to the Axis object that is the "base" (independent axis) from which the values are drawn. (Inherited from CurveItem.)
 | Border | Gets or sets the Border object so as to be able to modify its properties.
 | CalcPieRect(Graphics, GraphPane, Single, RectangleF) | Calculate the RectangleF that will be used to define the bounding rectangle of the Pie.
 | Clear()() | Clears the points from this CurveItem. This is the same as CurveItem.Points.Clear(). (Inherited from CurveItem.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The Line/Symbol/Bar color (FillColor for the Bar). This is a common access to Line.Color, Border.Color, and Fill.Color properties for this curve. (Inherited from CurveItem.)
 | DesignLabel(Graphics, GraphPane, RectangleF, Single) | This method collects all the data relative to rendering this PieItem's label.
 | Displacement | Gets or sets the a value which determines the amount, if any, of this PieItem displacement.
 | Draw(Graphics, GraphPane, Int32, Single) | Do all rendering associated with this PieItem item to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object. (Overrides CurveItem.Draw(Graphics, GraphPane, Int32, Single).)
 | DrawLabel(Graphics, GraphPane, RectangleF, Single) | Render the label for this PieItem.
 | DrawLegendKey(Graphics, GraphPane, RectangleF, Single) | Draw a legend key entry for this PieItem at the specified location (Overrides CurveItem.DrawLegendKey(Graphics, GraphPane, RectangleF, Single).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Gets or sets the Fill object which is used to fill the pie slice with color.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarWidth(GraphPane) | Calculate the width of each bar, depending on the actual bar type (Inherited from CurveItem.)
 | GetCoords(GraphPane, Int32, String%) | Determine the coords for the rectangle associated with a specified point for this CurveItem (Overrides CurveItem.GetCoords(GraphPane, Int32, String%).)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides CurveItem.GetObjectData(SerializationInfo, StreamingContext).)
 | GetRange(Double%, Double%, Double%, Double%, Boolean, Boolean, GraphPane) | Go through the list of PointPair data values for this CurveItem and determine the minimum and maximum values in the data. (Inherited from CurveItem.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXAxis(GraphPane) | Get the X Axis instance (either XAxis or X2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxis(GraphPane) | Get the Y Axis instance (either YAxis or Y2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxisIndex(GraphPane) | Get the index of the Y Axis in the YAxis or Y2Axis list to which this CurveItem belongs. (Inherited from CurveItem.)
 | IsBar | Determines whether this CurveItem is a BarItem. This does not include HiLowBarItem's or ErrorBarItem's. (Inherited from CurveItem.)
 | IsLine | Determines whether this CurveItem is a LineItem. (Inherited from CurveItem.)
 | IsOverrideOrdinal | Gets or sets a value which allows you to override the normal ordinal axis behavior. (Inherited from CurveItem.)
 | IsPie | Determines whether this CurveItem is a PieItem. (Inherited from CurveItem.)
 | IsSelectable | Determines whether this CurveItem can be selected in the graph. (Inherited from CurveItem.)
 | IsSelected | Determines whether this CurveItem is selected on the graph. Note that this value changes the curve displayed color, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsVisible | Determines whether this CurveItem is visible on the graph. Note that this value turns the curve display on or off, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsX2Axis | Gets or sets a value that determines which X axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | IsY2Axis | Gets or sets a value that determines which Y axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | Item[([Int32])] | An accessor for the PointPair datum for this CurveItem. Index is the ordinal reference (zero based) of the point. (Inherited from CurveItem.)
 | Label | A Label instance that represents the Legend entry for the this CurveItem object (Inherited from CurveItem.)
 | LabelDetail | Gets or sets the TextObj to be used for displaying this PieItem's label.
 | LabelType | Gets or sets the PieLabelType to be used in displaying PieItem labels.
 | Link | Gets or sets the hyperlink information for this CurveItem. (Inherited from CurveItem.)
 | MakeUnique()() | Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator) (Inherited from CurveItem.)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator) (Inherited from CurveItem.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NPts | Readonly property that gives the number of points that define this CurveItem object, which is the number of points in the Points data collection. (Inherited from CurveItem.)
 | PercentDecimalDigits | Gets or sets the number of decimal digits to be displayed in a PieItem percent label.
 | Points | The IPointList of X,Y point sets that represent this CurveItem. (Inherited from CurveItem.)
 | RemovePoint(Int32) | Removes a single point from this CurveItem. (Inherited from CurveItem.)
 | schema2 | Current schema value that defines the version of the serialized file
 | SlicePath | Gets a path representing this PieItem
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the CurveItem. ZedGraph does not use this value for any purpose. (Inherited from CurveItem.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Gets or sets the value of this PieItem. Minimum value is 0.
 | ValueAxis(GraphPane) | Returns a reference to the Axis object that is the "value" (dependent axis) from which the points are drawn. (Inherited from CurveItem.)
 | ValueDecimalDigits | Gets or sets the number of decimal digits to be displayed in a PieItem value label.
 | YAxisIndex | Gets or sets the index number of the Y Axis to which this CurveItem belongs. (Inherited from CurveItem.)
Inheritance Hierarchy
Object
 | CurveItem
 |  | PieItem


PieItem Constructor

PieItem Constructor
Namespaces ► ZedGraph ► PieItem ► PieItemPieItemNew()()
Members
Icon | Member | Description
 | PieItemPieItemNew(Double, Color, Color, Single, Double, String) | Create a new PieItem, providing a gradient fill for the pie color.
 | PieItemPieItemNew(Double, Color, Double, String) | Create a new PieItem.
 | PieItemPieItemNew(Double, String) | Create a new PieItem.
 | PieItemPieItemNew(PieItem) | The Copy Constructor


PieItem Constructor (pieValue, color, displacement, label)

PieItem Constructor (pieValue, color, displacement, label)
Namespaces ► ZedGraph ► PieItem ► PieItemPieItemNew(Double, Color, Double, String)
Create a new PieItem.
Declaration Syntax
C# Visual Basic Visual C++
public PieItem(
    double pieValue,
    Color color,
    double displacement,
    string label
)
Public Sub New ( _
    pieValue As Double, _
    color As Color, _
    displacement As Double, _
    label As String _
)
public:
PieItem (
    double pieValue,
    Color color,
    double displacement,
    String^ label
)
Parameters
pieValue (Double)
The value associated with this PieItem instance.
color (Color)
The display color for this PieItem instance.
displacement (Double)
The amount this PieItem instance will be displaced from the center point.
label (String)
Text label for this PieItem instance.


PieItem Constructor (pieValue, color1, color2, fillAngle, displacement, label)

PieItem Constructor (pieValue, color1, color2, fillAngle, displacement, label)
Namespaces ► ZedGraph ► PieItem ► PieItemPieItemNew(Double, Color, Color, Single, Double, String)
Create a new PieItem, providing a gradient fill for the pie color.
Declaration Syntax
C# Visual Basic Visual C++
public PieItem(
    double pieValue,
    Color color1,
    Color color2,
    float fillAngle,
    double displacement,
    string label
)
Public Sub New ( _
    pieValue As Double, _
    color1 As Color, _
    color2 As Color, _
    fillAngle As Single, _
    displacement As Double, _
    label As String _
)
public:
PieItem (
    double pieValue,
    Color color1,
    Color color2,
    float fillAngle,
    double displacement,
    String^ label
)
Parameters
pieValue (Double)
The value associated with this PieItem instance.
color1 (Color)
The starting display color for the gradient Fill for this PieItem instance.
color2 (Color)
The ending display color for the gradient Fill for this PieItem instance.
fillAngle (Single)
The angle for the gradient Fill.
displacement (Double)
The amount this PieItem instance will be displaced from the center point.
label (String)
Text label for this PieItem instance.


PieItem Constructor (pieValue, label)

PieItem Constructor (pieValue, label)
Namespaces ► ZedGraph ► PieItem ► PieItemPieItemNew(Double, String)
Create a new PieItem.
Declaration Syntax
C# Visual Basic Visual C++
public PieItem(
    double pieValue,
    string label
)
Public Sub New ( _
    pieValue As Double, _
    label As String _
)
public:
PieItem (
    double pieValue,
    String^ label
)
Parameters
pieValue (Double)
The value associated with this PieItem instance.
label (String)
Text label for this PieItem instance


PieItem Constructor (rhs)

PieItem Constructor (rhs)
Namespaces ► ZedGraph ► PieItem ► PieItemPieItemNew(PieItem)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public PieItem(
    PieItem rhs
)
Public Sub New ( _
    rhs As PieItem _
)
public:
PieItem (
    PieItem^ rhs
)
Parameters
rhs (PieItem)
The PieItem object from which to copy


Border Property

Border Property
Namespaces ► ZedGraph ► PieItem ► Border
Gets or sets the Border object so as to be able to modify its properties.
Declaration Syntax
C# Visual Basic Visual C++
public Border Border{ get; set;}
Public Property Border As Border
public:
property Border^ Border {
    Border^ get ();
    void set (Border^ value);
}


CalcPieRect Method (g, pane, scaleFactor, chartRect)

CalcPieRect Method (g, pane, scaleFactor, chartRect)
Namespaces ► ZedGraph ► PieItem ► CalcPieRect(Graphics, GraphPane, Single, RectangleF)
Calculate the RectangleF that will be used to define the bounding rectangle of the Pie.
Declaration Syntax
C# Visual Basic Visual C++
public static RectangleF CalcPieRect(
    Graphics g,
    GraphPane pane,
    float scaleFactor,
    RectangleF chartRect
)
Public Shared Function CalcPieRect ( _
    g As Graphics, _
    pane As GraphPane, _
    scaleFactor As Single, _
    chartRect As RectangleF _
) As RectangleF
public:
static RectangleF CalcPieRect (
    Graphics^ g,
    GraphPane^ pane,
    float scaleFactor,
    RectangleF chartRect
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
chartRect (RectangleF)
The RectangleF (normally the Rect) that bounds this pie.
Return Value
Remarks
This rectangle always lies inside of the Rect, and it is normally a square so that the pie itself is not oval-shaped.


Clone Method

Clone Method
Namespaces ► ZedGraph ► PieItem ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public PieItem Clone()
Public Function Clone As PieItem
public:
PieItem^ Clone ()
Return Value
A new, independent copy of this class


DesignLabel Method (g, pane, rect, scaleFactor)

DesignLabel Method (g, pane, rect, scaleFactor)
Namespaces ► ZedGraph ► PieItem ► DesignLabel(Graphics, GraphPane, RectangleF, Single)
This method collects all the data relative to rendering this PieItem's label.
Declaration Syntax
C# Visual Basic Visual C++
public void DesignLabel(
    Graphics g,
    GraphPane pane,
    RectangleF rect,
    float scaleFactor
)
Public Sub DesignLabel ( _
    g As Graphics, _
    pane As GraphPane, _
    rect As RectangleF, _
    scaleFactor As Single _
)
public:
void DesignLabel (
    Graphics^ g,
    GraphPane^ pane,
    RectangleF rect,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
rect (RectangleF)
The rectangle used for rendering this PieItem
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


Displacement Property

Displacement Property
Namespaces ► ZedGraph ► PieItem ► Displacement
Gets or sets the a value which determines the amount, if any, of this PieItem displacement.
Declaration Syntax
C# Visual Basic Visual C++
public double Displacement{ get; set;}
Public Property Displacement As Double
public:
property double Displacement {
    double get ();
    void set (double value);
}


Draw Method (g, pane, pos, scaleFactor)

Draw Method (g, pane, pos, scaleFactor)
Namespaces ► ZedGraph ► PieItem ► Draw(Graphics, GraphPane, Int32, Single)
Do all rendering associated with this PieItem item to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object.
Declaration Syntax
C# Visual Basic Visual C++
public override void Draw(
    Graphics g,
    GraphPane pane,
    int pos,
    float scaleFactor
)
Public Overrides Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    pos As Integer, _
    scaleFactor As Single _
)
public:
virtual void Draw (
    Graphics^ g,
    GraphPane^ pane,
    int pos,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
pos (Int32)
Not used for rendering Pies
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


DrawLabel Method (g, pane, rect, scaleFactor)

DrawLabel Method (g, pane, rect, scaleFactor)
Namespaces ► ZedGraph ► PieItem ► DrawLabel(Graphics, GraphPane, RectangleF, Single)
Render the label for this PieItem.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawLabel(
    Graphics g,
    GraphPane pane,
    RectangleF rect,
    float scaleFactor
)
Public Sub DrawLabel ( _
    g As Graphics, _
    pane As GraphPane, _
    rect As RectangleF, _
    scaleFactor As Single _
)
public:
void DrawLabel (
    Graphics^ g,
    GraphPane^ pane,
    RectangleF rect,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
rect (RectangleF)
Bounding rectangle for this PieItem.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


DrawLegendKey Method (g, pane, rect, scaleFactor)

DrawLegendKey Method (g, pane, rect, scaleFactor)
Namespaces ► ZedGraph ► PieItem ► DrawLegendKey(Graphics, GraphPane, RectangleF, Single)
Draw a legend key entry for this PieItem at the specified location
Declaration Syntax
C# Visual Basic Visual C++
public override void DrawLegendKey(
    Graphics g,
    GraphPane pane,
    RectangleF rect,
    float scaleFactor
)
Public Overrides Sub DrawLegendKey ( _
    g As Graphics, _
    pane As GraphPane, _
    rect As RectangleF, _
    scaleFactor As Single _
)
public:
virtual void DrawLegendKey (
    Graphics^ g,
    GraphPane^ pane,
    RectangleF rect,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
rect (RectangleF)
The RectangleF struct that specifies the location for the legend key
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


Fill Property

Fill Property
Namespaces ► ZedGraph ► PieItem ► Fill
Gets or sets the Fill object which is used to fill the pie slice with color.
Declaration Syntax
C# Visual Basic Visual C++
public Fill Fill{ get; set;}
Public Property Fill As Fill
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}


GetCoords Method (pane, i, coords)

GetCoords Method (pane, i, coords)
Namespaces ► ZedGraph ► PieItem ► GetCoords(GraphPane, Int32, String%)
Determine the coords for the rectangle associated with a specified point for this CurveItem
Declaration Syntax
C# Visual Basic Visual C++
public override bool GetCoords(
    GraphPane pane,
    int i,
    out string coords
)
Public Overrides Function GetCoords ( _
    pane As GraphPane, _
    i As Integer, _
    <OutAttribute> ByRef coords As String _
) As Boolean
public:
virtual bool GetCoords (
    GraphPane^ pane,
    int i,
    [OutAttribute] String^% coords
) override
Parameters
pane (GraphPane)
The GraphPane to which this curve belongs
i (Int32)
The index of the point of interest
coords (String %)
A list of coordinates that represents the "rect" for this point (used in an html AREA tag)
Return Value
true if it's a valid point, false otherwise


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► PieItem ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


LabelDetail Property

LabelDetail Property
Namespaces ► ZedGraph ► PieItem ► LabelDetail
Gets or sets the TextObj to be used for displaying this PieItem's label.
Declaration Syntax
C# Visual Basic Visual C++
public TextObj LabelDetail{ get; set;}
Public Property LabelDetail As TextObj
public:
property TextObj^ LabelDetail {
    TextObj^ get ();
    void set (TextObj^ value);
}


LabelType Property

LabelType Property
Namespaces ► ZedGraph ► PieItem ► LabelType
Gets or sets the PieLabelType to be used in displaying PieItem labels.
Declaration Syntax
C# Visual Basic Visual C++
public PieLabelType LabelType{ get; set;}
Public Property LabelType As PieLabelType
public:
property PieLabelType LabelType {
    PieLabelType get ();
    void set (PieLabelType value);
}


PercentDecimalDigits Property

PercentDecimalDigits Property
Namespaces ► ZedGraph ► PieItem ► PercentDecimalDigits
Gets or sets the number of decimal digits to be displayed in a PieItem percent label.
Declaration Syntax
C# Visual Basic Visual C++
public int PercentDecimalDigits{ get; set;}
Public Property PercentDecimalDigits As Integer
public:
property int PercentDecimalDigits {
    int get ();
    void set (int value);
}


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► PieItem ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


SlicePath Property

SlicePath Property
Namespaces ► ZedGraph ► PieItem ► SlicePath
Gets a path representing this PieItem
Declaration Syntax
C# Visual Basic Visual C++
public GraphicsPath SlicePath{ get;}
Public ReadOnly Property SlicePath As GraphicsPath
public:
property GraphicsPath^ SlicePath {
    GraphicsPath^ get ();
}


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► PieItem ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Value Property

Value Property
Namespaces ► ZedGraph ► PieItem ► Value
Gets or sets the value of this PieItem. Minimum value is 0.
Declaration Syntax
C# Visual Basic Visual C++
public double Value{ get; set;}
Public Property Value As Double
public:
property double Value {
    double get ();
    void set (double value);
}


ValueDecimalDigits Property

ValueDecimalDigits Property
Namespaces ► ZedGraph ► PieItem ► ValueDecimalDigits
Gets or sets the number of decimal digits to be displayed in a PieItem value label.
Declaration Syntax
C# Visual Basic Visual C++
public int ValueDecimalDigits{ get; set;}
Public Property ValueDecimalDigits As Integer
public:
property int ValueDecimalDigits {
    int get ();
    void set (int value);
}


PieItem.Default Structure

PieItem..::Default Structure
Namespaces ► ZedGraph ► PieItem ► PieItem..::Default
Specify the default property values for the PieItem class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BorderColor | The default color for drawing frames around PieItem (Color property).
 | BorderWidth | The default pen width to be used for drawing the border around the PieItem (Width property). Units are points.
 | Displacement | Default PieItem displacement.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | FillBrush | The default custom brush for filling in the PieItem. (Brush property).
 | FillColor | The default color for filling in the PieItem (Color property).
 | FillType | The default fill mode for this PieItem (Type property).
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontSize | The default font size for LabelDetail entries (Size property). Units are in points (1/72 inch).
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsBorderVisible | The default border mode for PieItem (IsVisible property). true to display frame around PieItem, false otherwise
 | isVisible | Default value for controlling PieItem display.
 | LabelType | Default value for LabelType.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PercentDecimalDigits | Default value for the number of decimal digits to be displayed where LabelType contains a percent.
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | ValueDecimalDigits | Default value for the number of decimal digits to be displayed when LabelType contains a value.


BorderColor Field

BorderColor Field
Namespaces ► ZedGraph ► PieItem..::Default ► BorderColor
The default color for drawing frames around PieItem (Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color BorderColor
Public Shared BorderColor As Color
public:
static Color BorderColor


BorderWidth Field

BorderWidth Field
Namespaces ► ZedGraph ► PieItem..::Default ► BorderWidth
The default pen width to be used for drawing the border around the PieItem (Width property). Units are points.
Declaration Syntax
C# Visual Basic Visual C++
public static float BorderWidth
Public Shared BorderWidth As Single
public:
static float BorderWidth


Displacement Field

Displacement Field
Namespaces ► ZedGraph ► PieItem..::Default ► Displacement
Default PieItem displacement.
Declaration Syntax
C# Visual Basic Visual C++
public static double Displacement
Public Shared Displacement As Double
public:
static double Displacement


FillBrush Field

FillBrush Field
Namespaces ► ZedGraph ► PieItem..::Default ► FillBrush
The default custom brush for filling in the PieItem. (Brush property).
Declaration Syntax
C# Visual Basic Visual C++
public static Brush FillBrush
Public Shared FillBrush As Brush
public:
static Brush^ FillBrush


FillColor Field

FillColor Field
Namespaces ► ZedGraph ► PieItem..::Default ► FillColor
The default color for filling in the PieItem (Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color FillColor
Public Shared FillColor As Color
public:
static Color FillColor


FillType Field

FillType Field
Namespaces ► ZedGraph ► PieItem..::Default ► FillType
The default fill mode for this PieItem (Type property).
Declaration Syntax
C# Visual Basic Visual C++
public static FillType FillType
Public Shared FillType As FillType
public:
static FillType FillType


FontSize Field

FontSize Field
Namespaces ► ZedGraph ► PieItem..::Default ► FontSize
The default font size for LabelDetail entries (Size property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float FontSize
Public Shared FontSize As Single
public:
static float FontSize


IsBorderVisible Field

IsBorderVisible Field
Namespaces ► ZedGraph ► PieItem..::Default ► IsBorderVisible
The default border mode for PieItem (IsVisible property). true to display frame around PieItem, false otherwise
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsBorderVisible
Public Shared IsBorderVisible As Boolean
public:
static bool IsBorderVisible


isVisible Field

isVisible Field
Namespaces ► ZedGraph ► PieItem..::Default ► isVisible
Default value for controlling PieItem display.
Declaration Syntax
C# Visual Basic Visual C++
public static bool isVisible
Public Shared isVisible As Boolean
public:
static bool isVisible


LabelType Field

LabelType Field
Namespaces ► ZedGraph ► PieItem..::Default ► LabelType
Default value for LabelType.
Declaration Syntax
C# Visual Basic Visual C++
public static PieLabelType LabelType
Public Shared LabelType As PieLabelType
public:
static PieLabelType LabelType


PercentDecimalDigits Field

PercentDecimalDigits Field
Namespaces ► ZedGraph ► PieItem..::Default ► PercentDecimalDigits
Default value for the number of decimal digits to be displayed where LabelType contains a percent.
Declaration Syntax
C# Visual Basic Visual C++
public static int PercentDecimalDigits
Public Shared PercentDecimalDigits As Integer
public:
static int PercentDecimalDigits


ValueDecimalDigits Field

ValueDecimalDigits Field
Namespaces ► ZedGraph ► PieItem..::Default ► ValueDecimalDigits
Default value for the number of decimal digits to be displayed when LabelType contains a value.
Declaration Syntax
C# Visual Basic Visual C++
public static int ValueDecimalDigits
Public Shared ValueDecimalDigits As Integer
public:
static int ValueDecimalDigits


PieLabelType Enumeration

PieLabelType Enumeration
Namespaces ► ZedGraph ► PieLabelType
Enumeration that determines the type of label that is displayed for each pie slice (see LabelType).
Declaration Syntax
C# Visual Basic Visual C++
public enum PieLabelType
Public Enumeration PieLabelType
public enum class PieLabelType
Members
Member | Description
Name_Value | Displays Label and Value for a slice in a Pie Chart.
Name_Percent | Displays Label and Value (as % of total) for a slice in a Pie Chart.
Name_Value_Percent | Displays a Label containing the Value both as an absolute number and as percentage of the total.
Value | Displays Value for a slice in a Pie Chart.
Percent | Displays Value (as % of total) for a slice in a Pie Chart.
Name | Displays Label for a slice in a Pie Chart.
None | No label displayed.


PointD Structure

PointD Structure
Namespaces ► ZedGraph ► PointD
Simple struct that stores X and Y coordinates as doubles.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public struct PointD
<SerializableAttribute> _
Public Structure PointD
[SerializableAttribute]
public value class PointD
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PointDPointDNew(Double, Double) | Construct a PointD object from two double values.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | X | The X coordinate
 | Y | The Y coordinate


PointD Constructor (x, y)

PointD Constructor (x, y)
Namespaces ► ZedGraph ► PointD ► PointDPointDNew(Double, Double)
Construct a PointD object from two double values.
Declaration Syntax
C# Visual Basic Visual C++
public PointD(
    double x,
    double y
)
Public Sub New ( _
    x As Double, _
    y As Double _
)
public:
PointD (
    double x,
    double y
)
Parameters
x (Double)
The X coordinate
y (Double)
The Y coordinate


X Field

X Field
Namespaces ► ZedGraph ► PointD ► X
The X coordinate
Declaration Syntax
C# Visual Basic Visual C++
public double X
Public X As Double
public:
double X


Y Field

Y Field
Namespaces ► ZedGraph ► PointD ► Y
The Y coordinate
Declaration Syntax
C# Visual Basic Visual C++
public double Y
Public Y As Double
public:
double Y


PointPair Class

PointPair Class
Namespaces ► ZedGraph ► PointPair
A simple point represented by an (X,Y,Z) group of double values.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PointPair : PointPairBase, ISerializable,
    ICloneable
<SerializableAttribute> _
Public Class PointPair _
    Inherits PointPairBase _
    Implements ISerializable, ICloneable
[SerializableAttribute]
public ref class PointPair : public PointPairBase,
    ISerializable, ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PointPairPointPairNew()() | Default Constructor
 | PointPairPointPairNew(Double, Double) | Creates a point pair with the specified X and Y.
 | PointPairPointPairNew(Double, Double, String) | Creates a point pair with the specified X, Y, and label (Tag).
 | PointPairPointPairNew(Double, Double, Double) | Creates a point pair with the specified X, Y, and base value.
 | PointPairPointPairNew(Double, Double, Double, String) | Creates a point pair with the specified X, Y, base value, and string label (Tag).
 | PointPairPointPairNew(Double, Double, Double, Object) | Creates a point pair with the specified X, Y, base value, and (Tag).
 | PointPairPointPairNew(PointF) | Creates a point pair from the specified PointF struct.
 | PointPairPointPairNew(PointPair) | The PointPair copy constructor.
 | Clone()() | Typesafe, deep-copy clone method.
 | ColorValue | The ColorValue property is just an alias for the Z property.
 | Equals(Object) | Compare two PointPair objects for equality. To be equal, X, Y, and Z must be exactly the same between the two objects. (Overrides PointPairBase.Equals(Object).)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Return the HashCode from the base class. (Overrides PointPairBase.GetHashCode()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides PointPairBase.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsInvalid | Readonly value that determines if either the X or the Y coordinate in this PointPair is an invalid (not plotable) value. It is considered invalid if it is missing (equal to System.Double.Max), Infinity, or NaN. (Inherited from PointPairBase.)
 | IsInvalid3D | Readonly value that determines if either the X, Y, or Z coordinate in this PointPair is an invalid (not plotable) value. It is considered invalid if it is missing (equal to System.Double.Max), Infinity, or NaN.
 | IsMissing | Readonly value that determines if either the X or the Y coordinate in this PointPair is a missing value. (Inherited from PointPairBase.)
 | LowValue | The "low" value for this point (lower dependent-axis value). This is really just an alias for Z.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | schema2 | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the PointPair. ZedGraph never modifies this value, but if it is a String type, it may be displayed in a ToolTip within the ZedGraphControl object.
 | ToString(Boolean) | Format this PointPair value using the default format. Example: "( 12.345, -16.876 )". The two double values are formatted with the "g" format type.
 | ToString(String, Boolean) | Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". If is true, then the third "Z" coordinate is also shown.
 | ToString(String, String, String) | Format this PointPair value using different general format strings for the X, Y, and Z values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )".
 | ToString(String) | Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". (Inherited from PointPairBase.)
 | ToString(String, String) | Format this PointPair value using different general format strings for the X and Y values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". The Z value is not displayed (see ToString(String, String, String)). (Inherited from PointPairBase.)
 | X | This PointPair's X coordinate (Inherited from PointPairBase.)
 | Y | This PointPair's Y coordinate (Inherited from PointPairBase.)
 | Z | This PointPair's Z coordinate. Also used for the lower value (dependent axis) for HiLowBarItem and ErrorBarItem charts.
Inheritance Hierarchy
Object
 | PointPairBase
 |  | PointPair
 |  |  | PointPair4
 |  |  | StockPt
 |  |  | PointPairCV


PointPair Constructor

PointPair Constructor
Namespaces ► ZedGraph ► PointPair ► PointPairPointPairNew()()
Members
Icon | Member | Description
 | PointPairPointPairNew()() | Default Constructor
 | PointPairPointPairNew(Double, Double) | Creates a point pair with the specified X and Y.
 | PointPairPointPairNew(Double, Double, String) | Creates a point pair with the specified X, Y, and label (Tag).
 | PointPairPointPairNew(Double, Double, Double) | Creates a point pair with the specified X, Y, and base value.
 | PointPairPointPairNew(Double, Double, Double, String) | Creates a point pair with the specified X, Y, base value, and string label (Tag).
 | PointPairPointPairNew(Double, Double, Double, Object) | Creates a point pair with the specified X, Y, base value, and (Tag).
 | PointPairPointPairNew(PointF) | Creates a point pair from the specified PointF struct.
 | PointPairPointPairNew(PointPair) | The PointPair copy constructor.


PointPair Constructor

PointPair Constructor
Namespaces ► ZedGraph ► PointPair ► PointPairPointPairNew()()
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public PointPair()
Public Sub New
public:
PointPair ()


PointPair Constructor (x, y)

PointPair Constructor (x, y)
Namespaces ► ZedGraph ► PointPair ► PointPairPointPairNew(Double, Double)
Creates a point pair with the specified X and Y.
Declaration Syntax
C# Visual Basic Visual C++
public PointPair(
    double x,
    double y
)
Public Sub New ( _
    x As Double, _
    y As Double _
)
public:
PointPair (
    double x,
    double y
)
Parameters
x (Double)
This pair's x coordinate.
y (Double)
This pair's y coordinate.


PointPair Constructor (x, y, z)

PointPair Constructor (x, y, z)
Namespaces ► ZedGraph ► PointPair ► PointPairPointPairNew(Double, Double, Double)
Creates a point pair with the specified X, Y, and base value.
Declaration Syntax
C# Visual Basic Visual C++
public PointPair(
    double x,
    double y,
    double z
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    z As Double _
)
public:
PointPair (
    double x,
    double y,
    double z
)
Parameters
x (Double)
This pair's x coordinate.
y (Double)
This pair's y coordinate.
z (Double)
This pair's z or lower dependent coordinate.


PointPair Constructor (x, y, z, tag)

PointPair Constructor (x, y, z, tag)
Namespaces ► ZedGraph ► PointPair ► PointPairPointPairNew(Double, Double, Double, Object)
Creates a point pair with the specified X, Y, base value, and (Tag).
Declaration Syntax
C# Visual Basic Visual C++
public PointPair(
    double x,
    double y,
    double z,
    Object tag
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    z As Double, _
    tag As Object _
)
public:
PointPair (
    double x,
    double y,
    double z,
    Object^ tag
)
Parameters
x (Double)
This pair's x coordinate.
y (Double)
This pair's y coordinate.
z (Double)
This pair's z or lower dependent coordinate.
tag (Object)
This pair's Tag property


PointPair Constructor (x, y, z, label)

PointPair Constructor (x, y, z, label)
Namespaces ► ZedGraph ► PointPair ► PointPairPointPairNew(Double, Double, Double, String)
Creates a point pair with the specified X, Y, base value, and string label (Tag).
Declaration Syntax
C# Visual Basic Visual C++
public PointPair(
    double x,
    double y,
    double z,
    string label
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    z As Double, _
    label As String _
)
public:
PointPair (
    double x,
    double y,
    double z,
    String^ label
)
Parameters
x (Double)
This pair's x coordinate.
y (Double)
This pair's y coordinate.
z (Double)
This pair's z or lower dependent coordinate.
label (String)
This pair's string label (Tag)


PointPair Constructor (x, y, label)

PointPair Constructor (x, y, label)
Namespaces ► ZedGraph ► PointPair ► PointPairPointPairNew(Double, Double, String)
Creates a point pair with the specified X, Y, and label (Tag).
Declaration Syntax
C# Visual Basic Visual C++
public PointPair(
    double x,
    double y,
    string label
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    label As String _
)
public:
PointPair (
    double x,
    double y,
    String^ label
)
Parameters
x (Double)
This pair's x coordinate.
y (Double)
This pair's y coordinate.
label (String)
This pair's string label (Tag)


PointPair Constructor (pt)

PointPair Constructor (pt)
Namespaces ► ZedGraph ► PointPair ► PointPairPointPairNew(PointF)
Creates a point pair from the specified PointF struct.
Declaration Syntax
C# Visual Basic Visual C++
public PointPair(
    PointF pt
)
Public Sub New ( _
    pt As PointF _
)
public:
PointPair (
    PointF pt
)
Parameters
pt (PointF)
The PointF struct from which to get the new PointPair values.


PointPair Constructor (rhs)

PointPair Constructor (rhs)
Namespaces ► ZedGraph ► PointPair ► PointPairPointPairNew(PointPair)
The PointPair copy constructor.
Declaration Syntax
C# Visual Basic Visual C++
public PointPair(
    PointPair rhs
)
Public Sub New ( _
    rhs As PointPair _
)
public:
PointPair (
    PointPair^ rhs
)
Parameters
rhs (PointPair)
The basis for the copy.


Clone Method

Clone Method
Namespaces ► ZedGraph ► PointPair ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public PointPair Clone()
Public Function Clone As PointPair
public:
PointPair^ Clone ()
Return Value
A new, independent copy of this class


ColorValue Property

ColorValue Property
Namespaces ► ZedGraph ► PointPair ► ColorValue
The ColorValue property is just an alias for the Z property.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double ColorValue{ get; set;}
Public Overridable Property ColorValue As Double
public:
virtual property double ColorValue {
    double get ();
    void set (double value);
}
Remarks
For other types, such as the StockPt, the StockPt can be mapped to a unique value. This is used with the GradientByColorValue option.


Equals Method (obj)

Equals Method (obj)
Namespaces ► ZedGraph ► PointPair ► Equals(Object)
Compare two PointPair objects for equality. To be equal, X, Y, and Z must be exactly the same between the two objects.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals (
    Object^ obj
) override
Parameters
obj (Object)
The PointPair object to be compared with.
Return Value
true if the PointPair objects are equal, false otherwise


GetHashCode Method

GetHashCode Method
Namespaces ► ZedGraph ► PointPair ► GetHashCode()()
Return the HashCode from the base class.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode () override
Return Value


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► PointPair ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsInvalid3D Property

IsInvalid3D Property
Namespaces ► ZedGraph ► PointPair ► IsInvalid3D
Readonly value that determines if either the X, Y, or Z coordinate in this PointPair is an invalid (not plotable) value. It is considered invalid if it is missing (equal to System.Double.Max), Infinity, or NaN.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInvalid3D{ get;}
Public ReadOnly Property IsInvalid3D As Boolean
public:
property bool IsInvalid3D {
    bool get ();
}
Return Value
true if any value is invalid


LowValue Property

LowValue Property
Namespaces ► ZedGraph ► PointPair ► LowValue
The "low" value for this point (lower dependent-axis value). This is really just an alias for Z.
Declaration Syntax
C# Visual Basic Visual C++
public double LowValue{ get; set;}
Public Property LowValue As Double
public:
property double LowValue {
    double get ();
    void set (double value);
}
Value
The lower dependent value for this PointPair.


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► PointPair ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► PointPair ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Tag Field

Tag Field
Namespaces ► ZedGraph ► PointPair ► Tag
A tag object for use by the user. This can be used to store additional information associated with the PointPair. ZedGraph never modifies this value, but if it is a String type, it may be displayed in a ToolTip within the ZedGraphControl object.
Declaration Syntax
C# Visual Basic Visual C++
public Object Tag
Public Tag As Object
public:
Object^ Tag
Remarks
Note that, if you are going to Serialize ZedGraph data, then any type that you store in Tag must be a serializable type (or it will cause an exception).


ToString Method

ToString Method
Namespaces ► ZedGraph ► PointPair ► ToString()()
Members
Icon | Member | Description
 | ToString(Boolean) | Format this PointPair value using the default format. Example: "( 12.345, -16.876 )". The two double values are formatted with the "g" format type.
 | ToString(String, Boolean) | Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". If is true, then the third "Z" coordinate is also shown.
 | ToString(String, String, String) | Format this PointPair value using different general format strings for the X, Y, and Z values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )".
 | ToString(String) | Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )".
 | ToString(String, String) | Format this PointPair value using different general format strings for the X and Y values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". The Z value is not displayed (see ToString(String, String, String)).


ToString Method (isShowZ)

ToString Method (isShowZ)
Namespaces ► ZedGraph ► PointPair ► ToString(Boolean)
Format this PointPair value using the default format. Example: "( 12.345, -16.876 )". The two double values are formatted with the "g" format type.
Declaration Syntax
C# Visual Basic Visual C++
public virtual string ToString(
    bool isShowZ
)
Public Overridable Function ToString ( _
    isShowZ As Boolean _
) As String
public:
virtual String^ ToString (
    bool isShowZ
)
Parameters
isShowZ (Boolean)
true to show the third "Z" or low dependent value coordinate
Return Value
A string representation of the PointPair


ToString Method (format, isShowZ)

ToString Method (format, isShowZ)
Namespaces ► ZedGraph ► PointPair ► ToString(String, Boolean)
Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". If is true, then the third "Z" coordinate is also shown.
Declaration Syntax
C# Visual Basic Visual C++
public virtual string ToString(
    string format,
    bool isShowZ
)
Public Overridable Function ToString ( _
    format As String, _
    isShowZ As Boolean _
) As String
public:
virtual String^ ToString (
    String^ format,
    bool isShowZ
)
Parameters
format (String)
A format string that will be used to format each of the two double type values (see ToString()()).
isShowZ (Boolean)
true to show the third "Z" or low dependent value coordinate
Return Value
A string representation of the PointPair


ToString Method (formatX, formatY, formatZ)

ToString Method (formatX, formatY, formatZ)
Namespaces ► ZedGraph ► PointPair ► ToString(String, String, String)
Format this PointPair value using different general format strings for the X, Y, and Z values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )".
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string formatX,
    string formatY,
    string formatZ
)
Public Function ToString ( _
    formatX As String, _
    formatY As String, _
    formatZ As String _
) As String
public:
String^ ToString (
    String^ formatX,
    String^ formatY,
    String^ formatZ
)
Parameters
formatX (String)
A format string that will be used to format the X double type value (see ToString()()).
formatY (String)
A format string that will be used to format the Y double type value (see ToString()()).
formatZ (String)
A format string that will be used to format the Z double type value (see ToString()()).
Return Value
A string representation of the PointPair


Z Field

Z Field
Namespaces ► ZedGraph ► PointPair ► Z
This PointPair's Z coordinate. Also used for the lower value (dependent axis) for HiLowBarItem and ErrorBarItem charts.
Declaration Syntax
C# Visual Basic Visual C++
public double Z
Public Z As Double
public:
double Z


PointPair.PointPairComparer Class

PointPair..::PointPairComparer Class
Namespaces ► ZedGraph ► PointPair ► PointPair..::PointPairComparer
Compares points based on their x values. Is setup to be used in an ascending order sort. Sort()()
Declaration Syntax
C# Visual Basic Visual C++
public class PointPairComparer : IComparer<PointPair>
Public Class PointPairComparer _
    Implements IComparer(Of PointPair)
public ref class PointPairComparer : IComparer<PointPair^>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PointPair..::PointPairComparerPointPair..::PointPairComparerNew(SortType) | Constructor for PointPairComparer.
 | Compare(PointPair, PointPair) | Compares two PointPairs.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PointPair..::PointPairComparer
See Also
Sort()()


PointPair.PointPairComparer Constructor (type)

PointPair..::PointPairComparer Constructor (type)
Namespaces ► ZedGraph ► PointPair..::PointPairComparer ► PointPair..::PointPairComparerPointPair..::PointPairComparerNew(SortType)
Constructor for PointPairComparer.
Declaration Syntax
C# Visual Basic Visual C++
public PointPairComparer(
    SortType type
)
Public Sub New ( _
    type As SortType _
)
public:
PointPairComparer (
    SortType type
)
Parameters
type (SortType)
The axis type on which to sort.


Compare Method (l, r)

Compare Method (l, r)
Namespaces ► ZedGraph ► PointPair..::PointPairComparer ► Compare(PointPair, PointPair)
Compares two PointPairs.
Declaration Syntax
C# Visual Basic Visual C++
public int Compare(
    PointPair l,
    PointPair r
)
Public Function Compare ( _
    l As PointPair, _
    r As PointPair _
) As Integer
public:
virtual int Compare (
    PointPair^ l,
    PointPair^ r
) sealed
Parameters
l (PointPair)
Point to the left.
r (PointPair)
Point to the right.
Return Value
-1, 0, or 1 depending on l.X's relation to r.X


PointPair.PointPairComparerY Class

PointPair..::PointPairComparerY Class
Namespaces ► ZedGraph ► PointPair ► PointPair..::PointPairComparerY
Compares points based on their y values. Is setup to be used in an ascending order sort. Sort()()
Declaration Syntax
C# Visual Basic Visual C++
public class PointPairComparerY : IComparer<PointPair>
Public Class PointPairComparerY _
    Implements IComparer(Of PointPair)
public ref class PointPairComparerY : IComparer<PointPair^>
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PointPair..::PointPairComparerYPointPair..::PointPairComparerYNew()() |
 | Compare(PointPair, PointPair) | Compares two PointPairs.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PointPair..::PointPairComparerY
See Also
Sort()()


PointPair.PointPairComparerY Constructor

PointPair..::PointPairComparerY Constructor
Namespaces ► ZedGraph ► PointPair..::PointPairComparerY ► PointPair..::PointPairComparerYPointPair..::PointPairComparerYNew()()
Declaration Syntax
C# Visual Basic Visual C++
public PointPairComparerY()
Public Sub New
public:
PointPairComparerY ()


Compare Method (l, r)

Compare Method (l, r)
Namespaces ► ZedGraph ► PointPair..::PointPairComparerY ► Compare(PointPair, PointPair)
Compares two PointPairs.
Declaration Syntax
C# Visual Basic Visual C++
public int Compare(
    PointPair l,
    PointPair r
)
Public Function Compare ( _
    l As PointPair, _
    r As PointPair _
) As Integer
public:
virtual int Compare (
    PointPair^ l,
    PointPair^ r
) sealed
Parameters
l (PointPair)
Point to the left.
r (PointPair)
Point to the right.
Return Value
-1, 0, or 1 depending on l.Y's relation to r.Y


PointPair4 Class

PointPair4 Class
Namespaces ► ZedGraph ► PointPair4
The basic PointPair class holds three data values (X, Y, Z). This class extends the basic PointPair to contain four data values (X, Y, Z, T).
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PointPair4 : PointPair, ISerializable
<SerializableAttribute> _
Public Class PointPair4 _
    Inherits PointPair _
    Implements ISerializable
[SerializableAttribute]
public ref class PointPair4 : public PointPair,
    ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PointPair4PointPair4New()() | Default Constructor
 | PointPair4PointPair4New(Double, Double, Double, Double) | Creates a point pair with the specified X, Y, Z, and T value.
 | PointPair4PointPair4New(Double, Double, Double, Double, String) | Creates a point pair with the specified X, Y, base value, and label (Tag).
 | PointPair4PointPair4New(PointPair4) | The PointPair4 copy constructor.
 | Clone()() | Typesafe, deep-copy clone method. (Inherited from PointPair.)
 | ColorValue | The ColorValue property is just an alias for the Z property. (Inherited from PointPair.)
 | Equals(Object) | Compare two PointPair objects for equality. To be equal, X, Y, and Z must be exactly the same between the two objects. (Inherited from PointPair.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Return the HashCode from the base class. (Inherited from PointPair.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides PointPair.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsInvalid | Readonly value that determines if either the X or the Y coordinate in this PointPair is an invalid (not plotable) value. It is considered invalid if it is missing (equal to System.Double.Max), Infinity, or NaN. (Inherited from PointPairBase.)
 | IsInvalid3D | Readonly value that determines if either the X, Y, or Z coordinate in this PointPair is an invalid (not plotable) value. It is considered invalid if it is missing (equal to System.Double.Max), Infinity, or NaN. (Inherited from PointPair.)
 | IsInvalid4D | Readonly value that determines if either the X, Y, Z, or T coordinate in this PointPair4 is an invalid (not plotable) value. It is considered invalid if it is missing (equal to System.Double.Max), Infinity, or NaN.
 | IsMissing | Readonly value that determines if either the X or the Y coordinate in this PointPair is a missing value. (Inherited from PointPairBase.)
 | LowValue | The "low" value for this point (lower dependent-axis value). This is really just an alias for Z. (Inherited from PointPair.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | schema3 | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()() (Inherited from PointPair.)
 | T | This PointPair4's T coordinate.
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the PointPair. ZedGraph never modifies this value, but if it is a String type, it may be displayed in a ToolTip within the ZedGraphControl object. (Inherited from PointPair.)
 | ToString(Boolean) | Format this PointPair4 value using the default format. Example: "( 12.345, -16.876 )". The two double values are formatted with the "g" format type.
 | ToString(String, Boolean) | Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". If is true, then the third "Z" coordinate is also shown.
 | ToString(String, String, String, String) | Format this PointPair value using different general format strings for the X, Y, and Z values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )".
 | ToString(String, String, String) | Format this PointPair value using different general format strings for the X, Y, and Z values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". (Inherited from PointPair.)
 | ToString(String) | Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". (Inherited from PointPairBase.)
 | ToString(String, String) | Format this PointPair value using different general format strings for the X and Y values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". The Z value is not displayed (see ToString(String, String, String)). (Inherited from PointPairBase.)
 | X | This PointPair's X coordinate (Inherited from PointPairBase.)
 | Y | This PointPair's Y coordinate (Inherited from PointPairBase.)
 | Z | This PointPair's Z coordinate. Also used for the lower value (dependent axis) for HiLowBarItem and ErrorBarItem charts. (Inherited from PointPair.)
Inheritance Hierarchy
Object
 | PointPairBase
 |  | PointPair
 |  |  | PointPair4


PointPair4 Constructor

PointPair4 Constructor
Namespaces ► ZedGraph ► PointPair4 ► PointPair4PointPair4New()()
Members
Icon | Member | Description
 | PointPair4PointPair4New()() | Default Constructor
 | PointPair4PointPair4New(Double, Double, Double, Double) | Creates a point pair with the specified X, Y, Z, and T value.
 | PointPair4PointPair4New(Double, Double, Double, Double, String) | Creates a point pair with the specified X, Y, base value, and label (Tag).
 | PointPair4PointPair4New(PointPair4) | The PointPair4 copy constructor.


PointPair4 Constructor

PointPair4 Constructor
Namespaces ► ZedGraph ► PointPair4 ► PointPair4PointPair4New()()
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public PointPair4()
Public Sub New
public:
PointPair4 ()


PointPair4 Constructor (x, y, z, t)

PointPair4 Constructor (x, y, z, t)
Namespaces ► ZedGraph ► PointPair4 ► PointPair4PointPair4New(Double, Double, Double, Double)
Creates a point pair with the specified X, Y, Z, and T value.
Declaration Syntax
C# Visual Basic Visual C++
public PointPair4(
    double x,
    double y,
    double z,
    double t
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    z As Double, _
    t As Double _
)
public:
PointPair4 (
    double x,
    double y,
    double z,
    double t
)
Parameters
x (Double)
This pair's x coordinate.
y (Double)
This pair's y coordinate.
z (Double)
This pair's z coordinate.
t (Double)
This pair's t coordinate.


PointPair4 Constructor (x, y, z, t, label)

PointPair4 Constructor (x, y, z, t, label)
Namespaces ► ZedGraph ► PointPair4 ► PointPair4PointPair4New(Double, Double, Double, Double, String)
Creates a point pair with the specified X, Y, base value, and label (Tag).
Declaration Syntax
C# Visual Basic Visual C++
public PointPair4(
    double x,
    double y,
    double z,
    double t,
    string label
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    z As Double, _
    t As Double, _
    label As String _
)
public:
PointPair4 (
    double x,
    double y,
    double z,
    double t,
    String^ label
)
Parameters
x (Double)
This pair's x coordinate.
y (Double)
This pair's y coordinate.
z (Double)
This pair's z coordinate.
t (Double)
This pair's t coordinate.
label (String)
This pair's string label (Tag)


PointPair4 Constructor (rhs)

PointPair4 Constructor (rhs)
Namespaces ► ZedGraph ► PointPair4 ► PointPair4PointPair4New(PointPair4)
The PointPair4 copy constructor.
Declaration Syntax
C# Visual Basic Visual C++
public PointPair4(
    PointPair4 rhs
)
Public Sub New ( _
    rhs As PointPair4 _
)
public:
PointPair4 (
    PointPair4^ rhs
)
Parameters
rhs (PointPair4)
The basis for the copy.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► PointPair4 ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsInvalid4D Property

IsInvalid4D Property
Namespaces ► ZedGraph ► PointPair4 ► IsInvalid4D
Readonly value that determines if either the X, Y, Z, or T coordinate in this PointPair4 is an invalid (not plotable) value. It is considered invalid if it is missing (equal to System.Double.Max), Infinity, or NaN.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInvalid4D{ get;}
Public ReadOnly Property IsInvalid4D As Boolean
public:
property bool IsInvalid4D {
    bool get ();
}
Return Value
true if any value is invalid


schema3 Field

schema3 Field
Namespaces ► ZedGraph ► PointPair4 ► schema3
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema3
Public Const schema3 As Integer
public:
literal int schema3


T Field

T Field
Namespaces ► ZedGraph ► PointPair4 ► T
This PointPair4's T coordinate.
Declaration Syntax
C# Visual Basic Visual C++
public double T
Public T As Double
public:
double T


ToString Method

ToString Method
Namespaces ► ZedGraph ► PointPair4 ► ToString()()
Members
Icon | Member | Description
 | ToString(Boolean) | Format this PointPair4 value using the default format. Example: "( 12.345, -16.876 )". The two double values are formatted with the "g" format type.
 | ToString(String, Boolean) | Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". If is true, then the third "Z" coordinate is also shown.
 | ToString(String, String, String, String) | Format this PointPair value using different general format strings for the X, Y, and Z values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )".
 | ToString(String, String, String) | Format this PointPair value using different general format strings for the X, Y, and Z values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )".
 | ToString(String) | Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )".
 | ToString(String, String) | Format this PointPair value using different general format strings for the X and Y values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". The Z value is not displayed (see ToString(String, String, String)).


ToString Method (isShowZT)

ToString Method (isShowZT)
Namespaces ► ZedGraph ► PointPair4 ► ToString(Boolean)
Format this PointPair4 value using the default format. Example: "( 12.345, -16.876 )". The two double values are formatted with the "g" format type.
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    bool isShowZT
)
Public Function ToString ( _
    isShowZT As Boolean _
) As String
public:
String^ ToString (
    bool isShowZT
)
Parameters
isShowZT (Boolean)
true to show the third "Z" and fourth "T" value coordinates
Return Value
A string representation of the PointPair4


ToString Method (format, isShowZT)

ToString Method (format, isShowZT)
Namespaces ► ZedGraph ► PointPair4 ► ToString(String, Boolean)
Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". If is true, then the third "Z" coordinate is also shown.
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string format,
    bool isShowZT
)
Public Function ToString ( _
    format As String, _
    isShowZT As Boolean _
) As String
public:
String^ ToString (
    String^ format,
    bool isShowZT
)
Parameters
format (String)
A format string that will be used to format each of the two double type values (see ToString()()).
isShowZT (Boolean)
true to show the third "Z" or low dependent value coordinate
Return Value
A string representation of the PointPair


ToString Method (formatX, formatY, formatZ, formatT)

ToString Method (formatX, formatY, formatZ, formatT)
Namespaces ► ZedGraph ► PointPair4 ► ToString(String, String, String, String)
Format this PointPair value using different general format strings for the X, Y, and Z values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )".
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string formatX,
    string formatY,
    string formatZ,
    string formatT
)
Public Function ToString ( _
    formatX As String, _
    formatY As String, _
    formatZ As String, _
    formatT As String _
) As String
public:
String^ ToString (
    String^ formatX,
    String^ formatY,
    String^ formatZ,
    String^ formatT
)
Parameters
formatX (String)
A format string that will be used to format the X double type value (see ToString()()).
formatY (String)
A format string that will be used to format the Y double type value (see ToString()()).
formatZ (String)
A format string that will be used to format the Z double type value (see ToString()()).
formatT (String)
A format string that will be used to format the T double type value (see ToString()()).
Return Value
A string representation of the PointPair


PointPairBase Class

PointPairBase Class
Namespaces ► ZedGraph ► PointPairBase
This is a base class that provides base-level functionality for a data point consisting of an (X,Y) pair of double values.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PointPairBase : ISerializable
<SerializableAttribute> _
Public Class PointPairBase _
    Implements ISerializable
[SerializableAttribute]
public ref class PointPairBase : ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PointPairBasePointPairBaseNew()() | Default Constructor
 | PointPairBasePointPairBaseNew(Double, Double) | Creates a point pair with the specified X and Y.
 | PointPairBasePointPairBaseNew(PointF) | Creates a point pair from the specified PointF struct.
 | PointPairBasePointPairBaseNew(PointPairBase) | The PointPairBase copy constructor.
 | DefaultFormat | The default format to be used for displaying point values via the ToString()() method.
 | Equals(Object) | Compare two PointPairBase objects for equality. To be equal, X and Y must be exactly the same between the two objects. (Overrides Object.Equals(Object).)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Return the HashCode from the base class. (Overrides Object.GetHashCode()().)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Implicit(PointPairBase) | Implicit conversion from PointPair to PointF. Note that this conversion can result in data loss, since the data are being cast from a type double (64 bit) to a float (32 bit).
 | IsInvalid | Readonly value that determines if either the X or the Y coordinate in this PointPair is an invalid (not plotable) value. It is considered invalid if it is missing (equal to System.Double.Max), Infinity, or NaN.
 | IsMissing | Readonly value that determines if either the X or the Y coordinate in this PointPair is a missing value.
 | IsValueInvalid(Double) | static method to determine if the specified point value is invalid.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Missing | Missing values are represented internally using MaxValue.
 | schema | Current schema value that defines the version of the serialized file
 | ToString()() | Format this PointPair value using the default format. Example: "( 12.345, -16.876 )". The two double values are formatted with the "g" format type. (Overrides Object.ToString()().)
 | ToString(String) | Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )".
 | ToString(String, String) | Format this PointPair value using different general format strings for the X and Y values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". The Z value is not displayed (see ToString(String, String, String)).
 | X | This PointPair's X coordinate
 | Y | This PointPair's Y coordinate
Remarks
This class is typically a base class for actual PointPair type implementations.
Inheritance Hierarchy
Object
 | PointPairBase
 |  | PointPair


PointPairBase Constructor

PointPairBase Constructor
Namespaces ► ZedGraph ► PointPairBase ► PointPairBasePointPairBaseNew()()
Members
Icon | Member | Description
 | PointPairBasePointPairBaseNew()() | Default Constructor
 | PointPairBasePointPairBaseNew(Double, Double) | Creates a point pair with the specified X and Y.
 | PointPairBasePointPairBaseNew(PointF) | Creates a point pair from the specified PointF struct.
 | PointPairBasePointPairBaseNew(PointPairBase) | The PointPairBase copy constructor.


PointPairBase Constructor

PointPairBase Constructor
Namespaces ► ZedGraph ► PointPairBase ► PointPairBasePointPairBaseNew()()
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public PointPairBase()
Public Sub New
public:
PointPairBase ()


PointPairBase Constructor (x, y)

PointPairBase Constructor (x, y)
Namespaces ► ZedGraph ► PointPairBase ► PointPairBasePointPairBaseNew(Double, Double)
Creates a point pair with the specified X and Y.
Declaration Syntax
C# Visual Basic Visual C++
public PointPairBase(
    double x,
    double y
)
Public Sub New ( _
    x As Double, _
    y As Double _
)
public:
PointPairBase (
    double x,
    double y
)
Parameters
x (Double)
This pair's x coordinate.
y (Double)
This pair's y coordinate.


PointPairBase Constructor (pt)

PointPairBase Constructor (pt)
Namespaces ► ZedGraph ► PointPairBase ► PointPairBasePointPairBaseNew(PointF)
Creates a point pair from the specified PointF struct.
Declaration Syntax
C# Visual Basic Visual C++
public PointPairBase(
    PointF pt
)
Public Sub New ( _
    pt As PointF _
)
public:
PointPairBase (
    PointF pt
)
Parameters
pt (PointF)
The PointF struct from which to get the new PointPair values.


PointPairBase Constructor (rhs)

PointPairBase Constructor (rhs)
Namespaces ► ZedGraph ► PointPairBase ► PointPairBasePointPairBaseNew(PointPairBase)
The PointPairBase copy constructor.
Declaration Syntax
C# Visual Basic Visual C++
public PointPairBase(
    PointPairBase rhs
)
Public Sub New ( _
    rhs As PointPairBase _
)
public:
PointPairBase (
    PointPairBase^ rhs
)
Parameters
rhs (PointPairBase)
The basis for the copy.


DefaultFormat Field

DefaultFormat Field
Namespaces ► ZedGraph ► PointPairBase ► DefaultFormat
The default format to be used for displaying point values via the ToString()() method.
Declaration Syntax
C# Visual Basic Visual C++
public const string DefaultFormat
Public Const DefaultFormat As String
public:
literal String^ DefaultFormat


Equals Method (obj)

Equals Method (obj)
Namespaces ► ZedGraph ► PointPairBase ► Equals(Object)
Compare two PointPairBase objects for equality. To be equal, X and Y must be exactly the same between the two objects.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals (
    Object^ obj
) override
Parameters
obj (Object)
The PointPairBase object to be compared with.
Return Value
true if the PointPairBase objects are equal, false otherwise


GetHashCode Method

GetHashCode Method
Namespaces ► ZedGraph ► PointPairBase ► GetHashCode()()
Return the HashCode from the base class.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode () override
Return Value


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► PointPairBase ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


Implicit Operator

Implicit Operator
Namespaces ► ZedGraph ► PointPairBase ► Implicit(PointPairBase)
Implicit conversion from PointPair to PointF. Note that this conversion can result in data loss, since the data are being cast from a type double (64 bit) to a float (32 bit).
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator PointF (
    PointPairBase pair
)
Public Shared Widening Operator CType ( _
    pair As PointPairBase _
) As PointF
static implicit operator PointF  (
    PointPairBase^ pair
)
Parameters
pair (PointPairBase)
The PointPair struct on which to operate
Return Value
A PointF struct equivalent to the PointPair


IsInvalid Property

IsInvalid Property
Namespaces ► ZedGraph ► PointPairBase ► IsInvalid
Readonly value that determines if either the X or the Y coordinate in this PointPair is an invalid (not plotable) value. It is considered invalid if it is missing (equal to System.Double.Max), Infinity, or NaN.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInvalid{ get;}
Public ReadOnly Property IsInvalid As Boolean
public:
property bool IsInvalid {
    bool get ();
}
Return Value
true if either value is invalid


IsMissing Property

IsMissing Property
Namespaces ► ZedGraph ► PointPairBase ► IsMissing
Readonly value that determines if either the X or the Y coordinate in this PointPair is a missing value.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsMissing{ get;}
Public ReadOnly Property IsMissing As Boolean
public:
property bool IsMissing {
    bool get ();
}
Return Value
true if either value is missing


IsValueInvalid Method (value)

IsValueInvalid Method (value)
Namespaces ► ZedGraph ► PointPairBase ► IsValueInvalid(Double)
static method to determine if the specified point value is invalid.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsValueInvalid(
    double value
)
Public Shared Function IsValueInvalid ( _
    value As Double _
) As Boolean
public:
static bool IsValueInvalid (
    double value
)
Parameters
value (Double)
The value to be checked for validity.
Return Value
true if the value is invalid, false otherwise
Remarks
The value is considered invalid if it is Missing, PositiveInfinity, NegativeInfinity or NaN.


Missing Field

Missing Field
Namespaces ► ZedGraph ► PointPairBase ► Missing
Missing values are represented internally using MaxValue.
Declaration Syntax
C# Visual Basic Visual C++
public const double Missing
Public Const Missing As Double
public:
literal double Missing


schema Field

schema Field
Namespaces ► ZedGraph ► PointPairBase ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


ToString Method

ToString Method
Namespaces ► ZedGraph ► PointPairBase ► ToString()()
Members
Icon | Member | Description
 | ToString()() | Format this PointPair value using the default format. Example: "( 12.345, -16.876 )". The two double values are formatted with the "g" format type. (Overrides Object.ToString()().)
 | ToString(String) | Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )".
 | ToString(String, String) | Format this PointPair value using different general format strings for the X and Y values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". The Z value is not displayed (see ToString(String, String, String)).


ToString Method

ToString Method
Namespaces ► ZedGraph ► PointPairBase ► ToString()()
Format this PointPair value using the default format. Example: "( 12.345, -16.876 )". The two double values are formatted with the "g" format type.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
A string representation of the PointPair


ToString Method (format)

ToString Method (format)
Namespaces ► ZedGraph ► PointPairBase ► ToString(String)
Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )".
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string format
)
Public Function ToString ( _
    format As String _
) As String
public:
String^ ToString (
    String^ format
)
Parameters
format (String)
A format string that will be used to format each of the two double type values (see ToString()()).
Return Value
A string representation of the PointPair


ToString Method (formatX, formatY)

ToString Method (formatX, formatY)
Namespaces ► ZedGraph ► PointPairBase ► ToString(String, String)
Format this PointPair value using different general format strings for the X and Y values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". The Z value is not displayed (see ToString(String, String, String)).
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string formatX,
    string formatY
)
Public Function ToString ( _
    formatX As String, _
    formatY As String _
) As String
public:
String^ ToString (
    String^ formatX,
    String^ formatY
)
Parameters
formatX (String)
A format string that will be used to format the X double type value (see ToString()()).
formatY (String)
A format string that will be used to format the Y double type value (see ToString()()).
Return Value
A string representation of the PointPair


X Field

X Field
Namespaces ► ZedGraph ► PointPairBase ► X
This PointPair's X coordinate
Declaration Syntax
C# Visual Basic Visual C++
public double X
Public X As Double
public:
double X


Y Field

Y Field
Namespaces ► ZedGraph ► PointPairBase ► Y
This PointPair's Y coordinate
Declaration Syntax
C# Visual Basic Visual C++
public double Y
Public Y As Double
public:
double Y


PointPairCV Class

PointPairCV Class
Namespaces ► ZedGraph ► PointPairCV
A simple instance that stores a data point (X, Y, Z). This differs from a regular PointPair in that it maps the ColorValue property to an independent value. That is, ColorValue and Z are not related (as they are in the PointPair).
Declaration Syntax
C# Visual Basic Visual C++
public class PointPairCV : PointPair
Public Class PointPairCV _
    Inherits PointPair
public ref class PointPairCV : public PointPair
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PointPairCVPointPairCVNew(Double, Double, Double) | Creates a point pair with the specified X, Y, and base value.
 | Clone()() | Typesafe, deep-copy clone method. (Inherited from PointPair.)
 | ColorValue | The ColorValue property. This is used with the GradientByColorValue option. (Overrides PointPair.ColorValue.)
 | Equals(Object) | Compare two PointPair objects for equality. To be equal, X, Y, and Z must be exactly the same between the two objects. (Inherited from PointPair.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Return the HashCode from the base class. (Inherited from PointPair.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides PointPair.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsInvalid | Readonly value that determines if either the X or the Y coordinate in this PointPair is an invalid (not plotable) value. It is considered invalid if it is missing (equal to System.Double.Max), Infinity, or NaN. (Inherited from PointPairBase.)
 | IsInvalid3D | Readonly value that determines if either the X, Y, or Z coordinate in this PointPair is an invalid (not plotable) value. It is considered invalid if it is missing (equal to System.Double.Max), Infinity, or NaN. (Inherited from PointPair.)
 | IsMissing | Readonly value that determines if either the X or the Y coordinate in this PointPair is a missing value. (Inherited from PointPairBase.)
 | LowValue | The "low" value for this point (lower dependent-axis value). This is really just an alias for Z. (Inherited from PointPair.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | schema3 | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()() (Inherited from PointPair.)
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the PointPair. ZedGraph never modifies this value, but if it is a String type, it may be displayed in a ToolTip within the ZedGraphControl object. (Inherited from PointPair.)
 | ToString(Boolean) | Format this PointPair value using the default format. Example: "( 12.345, -16.876 )". The two double values are formatted with the "g" format type. (Inherited from PointPair.)
 | ToString(String, Boolean) | Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". If is true, then the third "Z" coordinate is also shown. (Inherited from PointPair.)
 | ToString(String, String, String) | Format this PointPair value using different general format strings for the X, Y, and Z values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". (Inherited from PointPair.)
 | ToString(String) | Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". (Inherited from PointPairBase.)
 | ToString(String, String) | Format this PointPair value using different general format strings for the X and Y values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". The Z value is not displayed (see ToString(String, String, String)). (Inherited from PointPairBase.)
 | X | This PointPair's X coordinate (Inherited from PointPairBase.)
 | Y | This PointPair's Y coordinate (Inherited from PointPairBase.)
 | Z | This PointPair's Z coordinate. Also used for the lower value (dependent axis) for HiLowBarItem and ErrorBarItem charts. (Inherited from PointPair.)
Inheritance Hierarchy
Object
 | PointPairBase
 |  | PointPair
 |  |  | PointPairCV


PointPairCV Constructor (x, y, z)

PointPairCV Constructor (x, y, z)
Namespaces ► ZedGraph ► PointPairCV ► PointPairCVPointPairCVNew(Double, Double, Double)
Creates a point pair with the specified X, Y, and base value.
Declaration Syntax
C# Visual Basic Visual C++
public PointPairCV(
    double x,
    double y,
    double z
)
Public Sub New ( _
    x As Double, _
    y As Double, _
    z As Double _
)
public:
PointPairCV (
    double x,
    double y,
    double z
)
Parameters
x (Double)
This pair's x coordinate.
y (Double)
This pair's y coordinate.
z (Double)
This pair's z or lower dependent coordinate.


ColorValue Property

ColorValue Property
Namespaces ► ZedGraph ► PointPairCV ► ColorValue
The ColorValue property. This is used with the GradientByColorValue option.
Declaration Syntax
C# Visual Basic Visual C++
public override double ColorValue{ get; set;}
Public Overrides Property ColorValue As Double
public:
virtual property double ColorValue {
    double get () override;
    void set (double value) override;
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► PointPairCV ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


schema3 Field

schema3 Field
Namespaces ► ZedGraph ► PointPairCV ► schema3
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema3
Public Const schema3 As Integer
public:
literal int schema3


PointPairList Class

PointPairList Class
Namespaces ► ZedGraph ► PointPairList
A collection class containing a list of PointPair objects that define the set of points to be displayed on the curve.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PointPairList : List<PointPair>, IPointListEdit,
    IPointList, ICloneable
<SerializableAttribute> _
Public Class PointPairList _
    Inherits List(Of PointPair) _
    Implements IPointListEdit, IPointList, ICloneable
[SerializableAttribute]
public ref class PointPairList : public List<PointPair^>,
    IPointListEdit, IPointList, ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PointPairListPointPairListNew()() | Default constructor for the collection class
 | PointPairListPointPairListNew(array<Double>[](), array<Double>[]()) | Constructor to initialize the PointPairList from two arrays of type double.
 | PointPairListPointPairListNew(IPointList) | Constructor to initialize the PointPairList from an IPointList
 | PointPairListPointPairListNew(array<Double>[](), array<Double>[](), array<Double>[]()) | Constructor to initialize the PointPairList from three arrays of type double.
 | PointPairListPointPairListNew(PointPairList) | The Copy Constructor
 | Add(PointPair) | Add a PointPair object to the collection at the end of the list.
 | Add(PointPairList) | Add a PointPairList object to the collection at the end of the list.
 | Add(array<Double>[](), array<Double>[]()) | Add a set of points to the PointPairList from two arrays of type double. If either array is null, then a set of ordinal values is automatically generated in its place (see Ordinal. If the arrays are of different size, then the larger array prevails and the smaller array is padded with Missing values.
 | Add(array<Double>[](), array<Double>[](), array<Double>[]()) | Add a set of points to the PointPairList from three arrays of type double. If the X or Y array is null, then a set of ordinal values is automatically generated in its place (see Ordinal. If the is null, then it is set to zero. If the arrays are of different size, then the larger array prevails and the smaller array is padded with Missing values.
 | Add(Double, Double) | Add a single point to the PointPairList from values of type double.
 | Add(Double, Double, String) | Add a single point to the PointPairList from values of type double.
 | Add(Double, Double, Double) | Add a single point to the PointPairList from values of type double.
 | Add(Double, Double, Double, String) | Add a single point to the PointPairList from values of type double.
 | AddRange(IEnumerable<(Of <T>)>) | Adds the elements of the specified collection to the end of the List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | AsReadOnly()() | Returns a read-only IList<(Of <T>)> wrapper for the current collection. (Inherited from List <(Of < PointPair >)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < PointPair >)>.)
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of < PointPair >)>.)
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < PointPair >)>.)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of < PointPair >)>.)
 | Clear()() | Removes all elements from the List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Contains(T) | Determines whether an element is in the List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | ConvertAll<(Of <TOutput>)>(Converter<(Of <T, TOutput>)>) | Converts the elements in the current List<(Of <T>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of < PointPair >)>.)
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of < PointPair >)>.)
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < PointPair >)>.)
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < PointPair >)>.)
 | Count | Gets the number of elements actually contained in the List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | Equals(Object) | Compare two PointPairList objects to see if they are equal. (Overrides Object.Equals(Object).)
 | Exists(Predicate<(Of <T>)>) | Determines whether the List<(Of <T>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < PointPair >)>.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | FindAll(Predicate<(Of <T>)>) | Retrieves the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < PointPair >)>.)
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < PointPair >)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < PointPair >)>.)
 | FindLast(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < PointPair >)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < PointPair >)>.)
 | ForEach(Action<(Of <T>)>) | Performs the specified action on each element of the List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | GetEnumerator()() | Returns an enumerator that iterates through the List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | GetHashCode()() | Return the HashCode from the base class. (Overrides Object.GetHashCode()().)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < PointPair >)>.)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < PointPair >)>.)
 | IndexOfTag(String) | Return the zero-based position index of the PointPair with the specified label Tag.
 | Insert(Int32, PointPair) | Add a PointPair object to the collection at the specified, zero-based, index location.
 | Insert(Int32, Double, Double) | Add a single point (from values of type double ) to the PointPairList at the specified, zero-based, index location.
 | Insert(Int32, Double, Double, Double) | Add a single point (from values of type double ) to the PointPairList at the specified, zero-based, index location.
 | InsertRange(Int32, IEnumerable<(Of <T>)>) | Inserts the elements of a collection into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < PointPair >)>.)
 | InterpolateX(Double) | Linearly interpolate the data to find an arbitraty Y value that corresponds to the specified X value.
 | InterpolateY(Double) | Linearly interpolate the data to find an arbitraty X value that corresponds to the specified Y value.
 | Item[([Int32])] | Gets or sets the element at the specified index. (Inherited from List <(Of < PointPair >)>.)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < PointPair >)>.)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < PointPair >)>.)
 | LinearRegression(IPointList, Int32) | Use linear regression to form a least squares fit of an existing IPointList instance.
 | LinearRegression(IPointList, Int32, Double, Double) | Use linear regression to form a least squares fit of an existing IPointList instance.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | RemoveAll(Predicate<(Of <T>)>) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < PointPair >)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of < PointPair >)>.)
 | SetX(array<Double>[]()) | Set the X values for this PointPairList from the specified array of double values.
 | SetY(array<Double>[]()) | Set the Y values for this PointPairList from the specified array of double values.
 | SetZ(array<Double>[]()) | Set the Z values for this PointPairList from the specified array of double values.
 | Sort()() | Sorts the list according to the point x values. Will not sort the list if the list is already sorted.
 | Sort(SortType) | Sorts the list according to the point values . Will not sort the list if the list is already sorted.
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < PointPair >)>.)
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < PointPair >)>.)
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | Sorted | true if the list is currently sorted.
 | SplineInterpolateX(Double, Double) | Use Cardinal Splines to Interpolate the data to find an arbitraty Y value that corresponds to the specified X value.
 | SumX(PointPairList) | Add the X values from the specified PointPairList object to this PointPairList. If has more values than this list, then the extra values will be ignored. If has less values, the missing values are assumed to be zero.
 | SumY(PointPairList) | Add the Y values from the specified PointPairList object to this PointPairList. If has more values than this list, then the extra values will be ignored. If has less values, the missing values are assumed to be zero.
 | ICollection<(Of <T>)>..::IsReadOnly | (Inherited from List <(Of < PointPair >)>.)
 | IEnumerable<(Of <T>)>..::GetEnumerator()() | (Inherited from List <(Of < PointPair >)>.)
 | ICollection..::CopyTo(Array, Int32) | (Inherited from List <(Of < PointPair >)>.)
 | ICollection..::IsSynchronized | (Inherited from List <(Of < PointPair >)>.)
 | ICollection..::SyncRoot | (Inherited from List <(Of < PointPair >)>.)
 | IEnumerable..::GetEnumerator()() | (Inherited from List <(Of < PointPair >)>.)
 | IList..::Add(Object) | (Inherited from List <(Of < PointPair >)>.)
 | IList..::Contains(Object) | (Inherited from List <(Of < PointPair >)>.)
 | IList..::IndexOf(Object) | (Inherited from List <(Of < PointPair >)>.)
 | IList..::Insert(Int32, Object) | (Inherited from List <(Of < PointPair >)>.)
 | IList..::IsFixedSize | (Inherited from List <(Of < PointPair >)>.)
 | IList..::IsReadOnly | (Inherited from List <(Of < PointPair >)>.)
 | IList..::Item[([Int32])] | (Inherited from List <(Of < PointPair >)>.)
 | IList..::Remove(Object) | (Inherited from List <(Of < PointPair >)>.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToArray()() | Copies the elements of the List<(Of <T>)> to a new array. (Inherited from List <(Of < PointPair >)>.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()() | Sets the capacity to the actual number of elements in the List<(Of <T>)>, if that number is less than a threshold value. (Inherited from List <(Of < PointPair >)>.)
 | TrueForAll(Predicate<(Of <T>)>) | Determines whether every element in the List<(Of <T>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of < PointPair >)>.)
Inheritance Hierarchy
Object
 | List <(Of < PointPair >)>
 |  | PointPairList
See Also
BasicArrayPointList
IPointList


PointPairList Constructor

PointPairList Constructor
Namespaces ► ZedGraph ► PointPairList ► PointPairListPointPairListNew()()
Members
Icon | Member | Description
 | PointPairListPointPairListNew()() | Default constructor for the collection class
 | PointPairListPointPairListNew(array<Double>[](), array<Double>[]()) | Constructor to initialize the PointPairList from two arrays of type double.
 | PointPairListPointPairListNew(IPointList) | Constructor to initialize the PointPairList from an IPointList
 | PointPairListPointPairListNew(array<Double>[](), array<Double>[](), array<Double>[]()) | Constructor to initialize the PointPairList from three arrays of type double.
 | PointPairListPointPairListNew(PointPairList) | The Copy Constructor


PointPairList Constructor

PointPairList Constructor
Namespaces ► ZedGraph ► PointPairList ► PointPairListPointPairListNew()()
Default constructor for the collection class
Declaration Syntax
C# Visual Basic Visual C++
public PointPairList()
Public Sub New
public:
PointPairList ()


PointPairList Constructor (x, y)

PointPairList Constructor (x, y)
Namespaces ► ZedGraph ► PointPairList ► PointPairListPointPairListNew(array<Double>[](), array<Double>[]())
Constructor to initialize the PointPairList from two arrays of type double.
Declaration Syntax
C# Visual Basic Visual C++
public PointPairList(
    double[] x,
    double[] y
)
Public Sub New ( _
    x As Double(), _
    y As Double() _
)
public:
PointPairList (
    array<double>^ x,
    array<double>^ y
)
Parameters
x (array< Double >[]())
y (array< Double >[]())


PointPairList Constructor (x, y, baseVal)

PointPairList Constructor (x, y, baseVal)
Namespaces ► ZedGraph ► PointPairList ► PointPairListPointPairListNew(array<Double>[](), array<Double>[](), array<Double>[]())
Constructor to initialize the PointPairList from three arrays of type double.
Declaration Syntax
C# Visual Basic Visual C++
public PointPairList(
    double[] x,
    double[] y,
    double[] baseVal
)
Public Sub New ( _
    x As Double(), _
    y As Double(), _
    baseVal As Double() _
)
public:
PointPairList (
    array<double>^ x,
    array<double>^ y,
    array<double>^ baseVal
)
Parameters
x (array< Double >[]())
y (array< Double >[]())
baseVal (array< Double >[]())


PointPairList Constructor (list)

PointPairList Constructor (list)
Namespaces ► ZedGraph ► PointPairList ► PointPairListPointPairListNew(IPointList)
Constructor to initialize the PointPairList from an IPointList
Declaration Syntax
C# Visual Basic Visual C++
public PointPairList(
    IPointList list
)
Public Sub New ( _
    list As IPointList _
)
public:
PointPairList (
    IPointList^ list
)
Parameters
list (IPointList)


PointPairList Constructor (rhs)

PointPairList Constructor (rhs)
Namespaces ► ZedGraph ► PointPairList ► PointPairListPointPairListNew(PointPairList)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public PointPairList(
    PointPairList rhs
)
Public Sub New ( _
    rhs As PointPairList _
)
public:
PointPairList (
    PointPairList^ rhs
)
Parameters
rhs (PointPairList)
The PointPairList from which to copy


Add Method

Add Method
Namespaces ► ZedGraph ► PointPairList ► Add()()
Members
Icon | Member | Description
 | Add(PointPair) | Add a PointPair object to the collection at the end of the list.
 | Add(PointPairList) | Add a PointPairList object to the collection at the end of the list.
 | Add(array<Double>[](), array<Double>[]()) | Add a set of points to the PointPairList from two arrays of type double. If either array is null, then a set of ordinal values is automatically generated in its place (see Ordinal. If the arrays are of different size, then the larger array prevails and the smaller array is padded with Missing values.
 | Add(array<Double>[](), array<Double>[](), array<Double>[]()) | Add a set of points to the PointPairList from three arrays of type double. If the X or Y array is null, then a set of ordinal values is automatically generated in its place (see Ordinal. If the is null, then it is set to zero. If the arrays are of different size, then the larger array prevails and the smaller array is padded with Missing values.
 | Add(Double, Double) | Add a single point to the PointPairList from values of type double.
 | Add(Double, Double, String) | Add a single point to the PointPairList from values of type double.
 | Add(Double, Double, Double) | Add a single point to the PointPairList from values of type double.
 | Add(Double, Double, Double, String) | Add a single point to the PointPairList from values of type double.


Add Method (x, y)

Add Method (x, y)
Namespaces ► ZedGraph ► PointPairList ► Add(Double, Double)
Add a single point to the PointPairList from values of type double.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    double x,
    double y
)
Public Sub Add ( _
    x As Double, _
    y As Double _
)
public:
virtual void Add (
    double x,
    double y
) sealed
Parameters
x (Double)
The X value
y (Double)
The Y value
Return Value
The zero-based ordinal index where the point was added in the list.


Add Method (x, y, z)

Add Method (x, y, z)
Namespaces ► ZedGraph ► PointPairList ► Add(Double, Double, Double)
Add a single point to the PointPairList from values of type double.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    double x,
    double y,
    double z
)
Public Sub Add ( _
    x As Double, _
    y As Double, _
    z As Double _
)
public:
void Add (
    double x,
    double y,
    double z
)
Parameters
x (Double)
The X value
y (Double)
The Y value
z (Double)
The Z or lower dependent axis value
Return Value
The zero-based ordinal index where the point was added in the list.


Add Method (x, y, z, tag)

Add Method (x, y, z, tag)
Namespaces ► ZedGraph ► PointPairList ► Add(Double, Double, Double, String)
Add a single point to the PointPairList from values of type double.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    double x,
    double y,
    double z,
    string tag
)
Public Sub Add ( _
    x As Double, _
    y As Double, _
    z As Double, _
    tag As String _
)
public:
void Add (
    double x,
    double y,
    double z,
    String^ tag
)
Parameters
x (Double)
The X value
y (Double)
The Y value
z (Double)
The Z or lower dependent axis value
tag (String)
The Tag value for the PointPair
Return Value
The zero-based ordinal index where the point was added in the list.


Add Method (x, y, tag)

Add Method (x, y, tag)
Namespaces ► ZedGraph ► PointPairList ► Add(Double, Double, String)
Add a single point to the PointPairList from values of type double.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    double x,
    double y,
    string tag
)
Public Sub Add ( _
    x As Double, _
    y As Double, _
    tag As String _
)
public:
void Add (
    double x,
    double y,
    String^ tag
)
Parameters
x (Double)
The X value
y (Double)
The Y value
tag (String)
The Tag value for the PointPair
Return Value
The zero-based ordinal index where the point was added in the list.


Add Method (x, y)

Add Method (x, y)
Namespaces ► ZedGraph ► PointPairList ► Add(array<Double>[](), array<Double>[]())
Add a set of points to the PointPairList from two arrays of type double. If either array is null, then a set of ordinal values is automatically generated in its place (see Ordinal. If the arrays are of different size, then the larger array prevails and the smaller array is padded with Missing values.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    double[] x,
    double[] y
)
Public Sub Add ( _
    x As Double(), _
    y As Double() _
)
public:
void Add (
    array<double>^ x,
    array<double>^ y
)
Parameters
x (array< Double >[]())
A double[] array of X values
y (array< Double >[]())
A double[] array of Y values
Return Value
The zero-based ordinal index where the last point was added in the list, or -1 if no points were added.


Add Method (x, y, z)

Add Method (x, y, z)
Namespaces ► ZedGraph ► PointPairList ► Add(array<Double>[](), array<Double>[](), array<Double>[]())
Add a set of points to the PointPairList from three arrays of type double. If the X or Y array is null, then a set of ordinal values is automatically generated in its place (see Ordinal. If the is null, then it is set to zero. If the arrays are of different size, then the larger array prevails and the smaller array is padded with Missing values.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    double[] x,
    double[] y,
    double[] z
)
Public Sub Add ( _
    x As Double(), _
    y As Double(), _
    z As Double() _
)
public:
void Add (
    array<double>^ x,
    array<double>^ y,
    array<double>^ z
)
Parameters
x (array< Double >[]())
A double[] array of X values
y (array< Double >[]())
A double[] array of Y values
z (array< Double >[]())
A double[] array of Z or lower-dependent axis values
Return Value
The zero-based ordinal index where the last point was added in the list, or -1 if no points were added.


Add Method (point)

Add Method (point)
Namespaces ► ZedGraph ► PointPairList ► Add(PointPair)
Add a PointPair object to the collection at the end of the list.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    PointPair point
)
Public Sub Add ( _
    point As PointPair _
)
public:
virtual void Add (
    PointPair^ point
) sealed
Parameters
point (PointPair)
The PointPair object to be added
Return Value
The zero-based ordinal index where the point was added in the list.


Add Method (pointList)

Add Method (pointList)
Namespaces ► ZedGraph ► PointPairList ► Add(PointPairList)
Add a PointPairList object to the collection at the end of the list.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    PointPairList pointList
)
Public Sub Add ( _
    pointList As PointPairList _
)
public:
void Add (
    PointPairList^ pointList
)
Parameters
pointList (PointPairList)
A reference to the PointPairList object to be added
Return Value
The zero-based ordinal index where the last point was added in the list, or -1 if no points were added.


Clone Method

Clone Method
Namespaces ► ZedGraph ► PointPairList ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public PointPairList Clone()
Public Function Clone As PointPairList
public:
PointPairList^ Clone ()
Return Value
A new, independent copy of this class


Equals Method (obj)

Equals Method (obj)
Namespaces ► ZedGraph ► PointPairList ► Equals(Object)
Compare two PointPairList objects to see if they are equal.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals (
    Object^ obj
) override
Parameters
obj (Object)
The PointPairList to be compared with for equality.
Return Value
true if the PointPairList objects are equal, false otherwise.
Remarks
Equality is based on equal count of PointPair items, and each individual PointPair must be equal (as per the Equals(Object) method.


GetHashCode Method

GetHashCode Method
Namespaces ► ZedGraph ► PointPairList ► GetHashCode()()
Return the HashCode from the base class.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode () override
Return Value


IndexOfTag Method (label)

IndexOfTag Method (label)
Namespaces ► ZedGraph ► PointPairList ► IndexOfTag(String)
Return the zero-based position index of the PointPair with the specified label Tag.
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOfTag(
    string label
)
Public Function IndexOfTag ( _
    label As String _
) As Integer
public:
int IndexOfTag (
    String^ label
)
Parameters
label (String)
The String label that is in the Tag attribute of the item to be found.
Return Value
The zero-based index of the specified PointPair, or -1 if the PointPair is not in the list
Remarks
The Tag object must be of type String for this method to find it.


Insert Method

Insert Method
Namespaces ► ZedGraph ► PointPairList ► Insert()()
Members
Icon | Member | Description
 | Insert(Int32, PointPair) | Add a PointPair object to the collection at the specified, zero-based, index location.
 | Insert(Int32, Double, Double) | Add a single point (from values of type double ) to the PointPairList at the specified, zero-based, index location.
 | Insert(Int32, Double, Double, Double) | Add a single point (from values of type double ) to the PointPairList at the specified, zero-based, index location.


Insert Method (index, x, y)

Insert Method (index, x, y)
Namespaces ► ZedGraph ► PointPairList ► Insert(Int32, Double, Double)
Add a single point (from values of type double ) to the PointPairList at the specified, zero-based, index location.
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    double x,
    double y
)
Public Sub Insert ( _
    index As Integer, _
    x As Double, _
    y As Double _
)
public:
void Insert (
    int index,
    double x,
    double y
)
Parameters
index (Int32)
The zero-based ordinal index where the point is to be added in the list.
x (Double)
The X value
y (Double)
The Y value


Insert Method (index, x, y, z)

Insert Method (index, x, y, z)
Namespaces ► ZedGraph ► PointPairList ► Insert(Int32, Double, Double, Double)
Add a single point (from values of type double ) to the PointPairList at the specified, zero-based, index location.
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    double x,
    double y,
    double z
)
Public Sub Insert ( _
    index As Integer, _
    x As Double, _
    y As Double, _
    z As Double _
)
public:
void Insert (
    int index,
    double x,
    double y,
    double z
)
Parameters
index (Int32)
The zero-based ordinal index where the point is to be added in the list.
x (Double)
The X value
y (Double)
The Y value
z (Double)
The Z or lower dependent axis value


Insert Method (index, point)

Insert Method (index, point)
Namespaces ► ZedGraph ► PointPairList ► Insert(Int32, PointPair)
Add a PointPair object to the collection at the specified, zero-based, index location.
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    PointPair point
)
Public Sub Insert ( _
    index As Integer, _
    point As PointPair _
)
public:
void Insert (
    int index,
    PointPair^ point
)
Parameters
index (Int32)
The zero-based ordinal index where the point is to be added in the list.
point (PointPair)
The PointPair object to be added.


InterpolateX Method (xTarget)

InterpolateX Method (xTarget)
Namespaces ► ZedGraph ► PointPairList ► InterpolateX(Double)
Linearly interpolate the data to find an arbitraty Y value that corresponds to the specified X value.
Declaration Syntax
C# Visual Basic Visual C++
public double InterpolateX(
    double xTarget
)
Public Function InterpolateX ( _
    xTarget As Double _
) As Double
public:
double InterpolateX (
    double xTarget
)
Parameters
xTarget (Double)
The target X value on which to interpolate
Return Value
The Y value that corresponds to the value.
Remarks
This method uses linear interpolation with a binary search algorithm. It therefore requires that the x data be monotonically increasing. Missing values are not allowed. This method will extrapolate outside the range of the PointPairList if necessary.


InterpolateY Method (yTarget)

InterpolateY Method (yTarget)
Namespaces ► ZedGraph ► PointPairList ► InterpolateY(Double)
Linearly interpolate the data to find an arbitraty X value that corresponds to the specified Y value.
Declaration Syntax
C# Visual Basic Visual C++
public double InterpolateY(
    double yTarget
)
Public Function InterpolateY ( _
    yTarget As Double _
) As Double
public:
double InterpolateY (
    double yTarget
)
Parameters
yTarget (Double)
The target Y value on which to interpolate
Return Value
The X value that corresponds to the value.
Remarks
This method uses linear interpolation with a binary search algorithm. It therefore requires that the Y data be monotonically increasing. Missing values are not allowed. This method will extrapolate outside the range of the PointPairList if necessary.


LinearRegression Method

LinearRegression Method
Namespaces ► ZedGraph ► PointPairList ► LinearRegression()()
Members
Icon | Member | Description
 | LinearRegression(IPointList, Int32) | Use linear regression to form a least squares fit of an existing IPointList instance.
 | LinearRegression(IPointList, Int32, Double, Double) | Use linear regression to form a least squares fit of an existing IPointList instance.


LinearRegression Method (points, pointCount)

LinearRegression Method (points, pointCount)
Namespaces ► ZedGraph ► PointPairList ► LinearRegression(IPointList, Int32)
Use linear regression to form a least squares fit of an existing IPointList instance.
Declaration Syntax
C# Visual Basic Visual C++
public PointPairList LinearRegression(
    IPointList points,
    int pointCount
)
Public Function LinearRegression ( _
    points As IPointList, _
    pointCount As Integer _
) As PointPairList
public:
PointPairList^ LinearRegression (
    IPointList^ points,
    int pointCount
)
Parameters
points (IPointList)
An IPointList instance containing the data to be regressed.
pointCount (Int32)
The number of desired points to be included in the resultant PointPairList.
Return Value
A new PointPairList containing the resultant data fit.
Remarks
The output PointPairList will cover the same X range of data as the original dataset.


LinearRegression Method (points, pointCount, minX, maxX)

LinearRegression Method (points, pointCount, minX, maxX)
Namespaces ► ZedGraph ► PointPairList ► LinearRegression(IPointList, Int32, Double, Double)
Use linear regression to form a least squares fit of an existing IPointList instance.
Declaration Syntax
C# Visual Basic Visual C++
public PointPairList LinearRegression(
    IPointList points,
    int pointCount,
    double minX,
    double maxX
)
Public Function LinearRegression ( _
    points As IPointList, _
    pointCount As Integer, _
    minX As Double, _
    maxX As Double _
) As PointPairList
public:
PointPairList^ LinearRegression (
    IPointList^ points,
    int pointCount,
    double minX,
    double maxX
)
Parameters
points (IPointList)
An IPointList instance containing the data to be regressed.
pointCount (Int32)
The number of desired points to be included in the resultant PointPairList.
minX (Double)
The minimum X value of the resultant PointPairList.
maxX (Double)
The maximum X value of the resultant PointPairList.
Return Value
A new PointPairList containing the resultant data fit.


SetX Method (x)

SetX Method (x)
Namespaces ► ZedGraph ► PointPairList ► SetX(array<Double>[]())
Set the X values for this PointPairList from the specified array of double values.
Declaration Syntax
C# Visual Basic Visual C++
public void SetX(
    double[] x
)
Public Sub SetX ( _
    x As Double() _
)
public:
void SetX (
    array<double>^ x
)
Parameters
x (array< Double >[]())
An array of double values that will replace the existing X values in the PointPairList.
Remarks
If has more values than this list, then the extra values will be ignored. If has less values, then the corresponding PointPairList values will not be changed. That is, if the PointPairList has 20 values and has 15 values, then the first 15 values of the PointPairList will be changed, and the last 5 values will not be changed.


SetY Method (y)

SetY Method (y)
Namespaces ► ZedGraph ► PointPairList ► SetY(array<Double>[]())
Set the Y values for this PointPairList from the specified array of double values.
Declaration Syntax
C# Visual Basic Visual C++
public void SetY(
    double[] y
)
Public Sub SetY ( _
    y As Double() _
)
public:
void SetY (
    array<double>^ y
)
Parameters
y (array< Double >[]())
An array of double values that will replace the existing Y values in the PointPairList.
Remarks
If has more values than this list, then the extra values will be ignored. If has less values, then the corresponding PointPairList values will not be changed. That is, if the PointPairList has 20 values and has 15 values, then the first 15 values of the PointPairList will be changed, and the last 5 values will not be changed.


SetZ Method (z)

SetZ Method (z)
Namespaces ► ZedGraph ► PointPairList ► SetZ(array<Double>[]())
Set the Z values for this PointPairList from the specified array of double values.
Declaration Syntax
C# Visual Basic Visual C++
public void SetZ(
    double[] z
)
Public Sub SetZ ( _
    z As Double() _
)
public:
void SetZ (
    array<double>^ z
)
Parameters
z (array< Double >[]())
An array of double values that will replace the existing Z values in the PointPairList.
Remarks
If has more values than this list, then the extra values will be ignored. If has less values, then the corresponding PointPairList values will not be changed. That is, if the PointPairList has 20 values and has 15 values, then the first 15 values of the PointPairList will be changed, and the last 5 values will not be changed.


Sort Method

Sort Method
Namespaces ► ZedGraph ► PointPairList ► Sort()()
Members
Icon | Member | Description
 | Sort()() | Sorts the list according to the point x values. Will not sort the list if the list is already sorted.
 | Sort(SortType) | Sorts the list according to the point values . Will not sort the list if the list is already sorted.
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer.
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer.
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>.


Sort Method

Sort Method
Namespaces ► ZedGraph ► PointPairList ► Sort()()
Sorts the list according to the point x values. Will not sort the list if the list is already sorted.
Declaration Syntax
C# Visual Basic Visual C++
public bool Sort()
Public Function Sort As Boolean
public:
bool Sort ()
Return Value
If the list was sorted before sort was called


Sort Method (type)

Sort Method (type)
Namespaces ► ZedGraph ► PointPairList ► Sort(SortType)
Sorts the list according to the point values . Will not sort the list if the list is already sorted.
Declaration Syntax
C# Visual Basic Visual C++
public bool Sort(
    SortType type
)
Public Function Sort ( _
    type As SortType _
) As Boolean
public:
bool Sort (
    SortType type
)
Parameters
type (SortType)
Return Value
If the list was sorted before sort was called


Sorted Property

Sorted Property
Namespaces ► ZedGraph ► PointPairList ► Sorted
true if the list is currently sorted.
Declaration Syntax
C# Visual Basic Visual C++
public bool Sorted{ get;}
Public ReadOnly Property Sorted As Boolean
public:
property bool Sorted {
    bool get ();
}
See Also
Sort()()


SplineInterpolateX Method (xTarget, tension)

SplineInterpolateX Method (xTarget, tension)
Namespaces ► ZedGraph ► PointPairList ► SplineInterpolateX(Double, Double)
Use Cardinal Splines to Interpolate the data to find an arbitraty Y value that corresponds to the specified X value.
Declaration Syntax
C# Visual Basic Visual C++
public double SplineInterpolateX(
    double xTarget,
    double tension
)
Public Function SplineInterpolateX ( _
    xTarget As Double, _
    tension As Double _
) As Double
public:
double SplineInterpolateX (
    double xTarget,
    double tension
)
Parameters
xTarget (Double)
The target X value on which to interpolate
tension (Double)
The tension setting that controls the curvature of the spline fit. Typical values are between 0 and 1, where 0 is a linear fit, and 1 is lots of "roundness". Values greater than 1 may give odd results.
Return Value
The Y value that corresponds to the value.
Remarks
This method uses cardinal spline interpolation with a binary search algorithm. It therefore requires that the x data be monotonically increasing. Missing values are not allowed. This method will not extrapolate outside the range of the PointPairList (it returns Missing if extrapolation would be required). WARNING: Cardinal spline interpolation can generate curves with non-unique X values for higher tension settings. That is, there may be multiple X values for the same Y value. This routine follows the path of the spline curve until it reaches the FIRST OCCURRENCE of the target X value. It does not check to see if other solutions are possible.


SumX Method (sumList)

SumX Method (sumList)
Namespaces ► ZedGraph ► PointPairList ► SumX(PointPairList)
Add the X values from the specified PointPairList object to this PointPairList. If has more values than this list, then the extra values will be ignored. If has less values, the missing values are assumed to be zero.
Declaration Syntax
C# Visual Basic Visual C++
public void SumX(
    PointPairList sumList
)
Public Sub SumX ( _
    sumList As PointPairList _
)
public:
void SumX (
    PointPairList^ sumList
)
Parameters
sumList (PointPairList)
A reference to the PointPairList object to be summed into the this PointPairList.


SumY Method (sumList)

SumY Method (sumList)
Namespaces ► ZedGraph ► PointPairList ► SumY(PointPairList)
Add the Y values from the specified PointPairList object to this PointPairList. If has more values than this list, then the extra values will be ignored. If has less values, the missing values are assumed to be zero.
Declaration Syntax
C# Visual Basic Visual C++
public void SumY(
    PointPairList sumList
)
Public Sub SumY ( _
    sumList As PointPairList _
)
public:
void SumY (
    PointPairList^ sumList
)
Parameters
sumList (PointPairList)
A reference to the PointPairList object to be summed into the this PointPairList.


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► PointPairList ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


PolyObj Class

PolyObj Class
Namespaces ► ZedGraph ► PolyObj
A class that represents a bordered and/or filled polygon object on the graph. A list of PolyObj objects is maintained by the GraphObjList collection class.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PolyObj : BoxObj, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class PolyObj _
    Inherits BoxObj _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class PolyObj : public BoxObj,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PolyObjPolyObjNew(array<PointD>[](), Color, Color) | A constructor that allows the position, border color, and solid fill color of the PolyObj to be pre-specified.
 | PolyObjPolyObjNew(array<PointD>[]()) | A constructor that allows the position of the PolyObj to be pre-specified. Other properties are defaulted.
 | PolyObjPolyObjNew()() | A default constructor that creates a PolyObj from an empty PointD array. Other properties are defaulted.
 | PolyObjPolyObjNew(array<PointD>[](), Color, Color, Color) | A constructor that allows the position, border color, and two-color gradient fill colors of the PolyObj to be pre-specified.
 | PolyObjPolyObjNew(PolyObj) | The Copy Constructor
 | Border | Gets or sets the Border object, which determines the properties of the border around this BoxObj (Inherited from BoxObj.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Draw(Graphics, PaneBase, Single) | Render this object to the specified Graphics device. (Overrides BoxObj.Draw(Graphics, PaneBase, Single).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Gets or sets the Fill data for this BoxObj. (Inherited from BoxObj.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCoords(PaneBase, Graphics, Single, String%, String%) | Determines the shape type and Coords values for this GraphObj (Inherited from BoxObj.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides BoxObj.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsClippedToChartRect | Gets or sets a value that determines whether or not the rendering of this GraphObj will be clipped to the Rect. (Inherited from GraphObj.)
 | IsClosedFigure | Gets or sets a value that determines if the polygon will be automatically closed. true to close the figure, false to leave it "open."
 | IsInFrontOfData | true if the ZOrder of this object is set to put it in front of the CurveItem data points. (Inherited from GraphObj.)
 | IsVisible | Gets or sets a value that determines if this GraphObj will be visible in the graph. true displays the item, false hides it. (Inherited from GraphObj.)
 | Link | Gets or sets the hyperlink information for this GraphObj. (Inherited from GraphObj.)
 | Location | The Location struct that describes the location for this GraphObj. (Inherited from GraphObj.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PointInBox(PointF, PaneBase, Graphics, Single) | Determine if the specified screen point lies inside the bounding box of this PolyObj. (Overrides BoxObj.PointInBox(PointF, PaneBase, Graphics, Single).)
 | Points | Gets or sets the PointD array that defines the polygon. This will be in units determined by CoordinateFrame.
 | schema3 | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the GraphObj. ZedGraph does not use this value for any purpose. (Inherited from GraphObj.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ZOrder | Gets or sets a value that determines the z-order "depth" of this item relative to other graphic objects. (Inherited from GraphObj.)
Inheritance Hierarchy
Object
 | GraphObj
 |  | BoxObj
 |  |  | PolyObj


PolyObj Constructor

PolyObj Constructor
Namespaces ► ZedGraph ► PolyObj ► PolyObjPolyObjNew()()
Constructors for the PolyObj object
Members
Icon | Member | Description
 | PolyObjPolyObjNew(array<PointD>[](), Color, Color) | A constructor that allows the position, border color, and solid fill color of the PolyObj to be pre-specified.
 | PolyObjPolyObjNew(array<PointD>[]()) | A constructor that allows the position of the PolyObj to be pre-specified. Other properties are defaulted.
 | PolyObjPolyObjNew()() | A default constructor that creates a PolyObj from an empty PointD array. Other properties are defaulted.
 | PolyObjPolyObjNew(array<PointD>[](), Color, Color, Color) | A constructor that allows the position, border color, and two-color gradient fill colors of the PolyObj to be pre-specified.
 | PolyObjPolyObjNew(PolyObj) | The Copy Constructor


PolyObj Constructor

PolyObj Constructor
Namespaces ► ZedGraph ► PolyObj ► PolyObjPolyObjNew()()
A default constructor that creates a PolyObj from an empty PointD array. Other properties are defaulted.
Declaration Syntax
C# Visual Basic Visual C++
public PolyObj()
Public Sub New
public:
PolyObj ()


PolyObj Constructor (points)

PolyObj Constructor (points)
Namespaces ► ZedGraph ► PolyObj ► PolyObjPolyObjNew(array<PointD>[]())
A constructor that allows the position of the PolyObj to be pre-specified. Other properties are defaulted.
Declaration Syntax
C# Visual Basic Visual C++
public PolyObj(
    PointD[] points
)
Public Sub New ( _
    points As PointD() _
)
public:
PolyObj (
    array<PointD>^ points
)
Parameters
points (array< PointD >[]())
The PointD array that defines the polygon. This will be in units determined by CoordinateFrame.


PolyObj Constructor (points, borderColor, fillColor)

PolyObj Constructor (points, borderColor, fillColor)
Namespaces ► ZedGraph ► PolyObj ► PolyObjPolyObjNew(array<PointD>[](), Color, Color)
A constructor that allows the position, border color, and solid fill color of the PolyObj to be pre-specified.
Declaration Syntax
C# Visual Basic Visual C++
public PolyObj(
    PointD[] points,
    Color borderColor,
    Color fillColor
)
Public Sub New ( _
    points As PointD(), _
    borderColor As Color, _
    fillColor As Color _
)
public:
PolyObj (
    array<PointD>^ points,
    Color borderColor,
    Color fillColor
)
Parameters
points (array< PointD >[]())
The PointD array that defines the polygon. This will be in units determined by CoordinateFrame.
borderColor (Color)
An arbitrary Color specification for the box border
fillColor (Color)
An arbitrary Color specification for the box fill (will be a solid color fill)


PolyObj Constructor (points, borderColor, fillColor1, fillColor2)

PolyObj Constructor (points, borderColor, fillColor1, fillColor2)
Namespaces ► ZedGraph ► PolyObj ► PolyObjPolyObjNew(array<PointD>[](), Color, Color, Color)
A constructor that allows the position, border color, and two-color gradient fill colors of the PolyObj to be pre-specified.
Declaration Syntax
C# Visual Basic Visual C++
public PolyObj(
    PointD[] points,
    Color borderColor,
    Color fillColor1,
    Color fillColor2
)
Public Sub New ( _
    points As PointD(), _
    borderColor As Color, _
    fillColor1 As Color, _
    fillColor2 As Color _
)
public:
PolyObj (
    array<PointD>^ points,
    Color borderColor,
    Color fillColor1,
    Color fillColor2
)
Parameters
points (array< PointD >[]())
The PointD array that defines the polygon. This will be in units determined by CoordinateFrame.
borderColor (Color)
An arbitrary Color specification for the box border
fillColor1 (Color)
An arbitrary Color specification for the start of the box gradient fill
fillColor2 (Color)
An arbitrary Color specification for the end of the box gradient fill


PolyObj Constructor (rhs)

PolyObj Constructor (rhs)
Namespaces ► ZedGraph ► PolyObj ► PolyObjPolyObjNew(PolyObj)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public PolyObj(
    PolyObj rhs
)
Public Sub New ( _
    rhs As PolyObj _
)
public:
PolyObj (
    PolyObj^ rhs
)
Parameters
rhs (PolyObj)
The PolyObj object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► PolyObj ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public PolyObj Clone()
Public Function Clone As PolyObj
public:
PolyObj^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, scaleFactor)

Draw Method (g, pane, scaleFactor)
Namespaces ► ZedGraph ► PolyObj ► Draw(Graphics, PaneBase, Single)
Render this object to the specified Graphics device.
Declaration Syntax
C# Visual Basic Visual C++
public override void Draw(
    Graphics g,
    PaneBase pane,
    float scaleFactor
)
Public Overrides Sub Draw ( _
    g As Graphics, _
    pane As PaneBase, _
    scaleFactor As Single _
)
public:
virtual void Draw (
    Graphics^ g,
    PaneBase^ pane,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Remarks
This method is normally only called by the Draw method of the parent GraphObjList collection object.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► PolyObj ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsClosedFigure Property

IsClosedFigure Property
Namespaces ► ZedGraph ► PolyObj ► IsClosedFigure
Gets or sets a value that determines if the polygon will be automatically closed. true to close the figure, false to leave it "open."
Declaration Syntax
C# Visual Basic Visual C++
public bool IsClosedFigure{ get; set;}
Public Property IsClosedFigure As Boolean
public:
property bool IsClosedFigure {
    bool get ();
    void set (bool value);
}
Remarks
This boolean determines whether or not the CloseFigure() method will be called to fully close the path of the polygon. This value defaults to true, and for any closed figure it should fine. If you want to draw a line that does not close into a shape, then you should set this value to false. For a figure that is naturally closed (e.g., the first point of the polygon is the same as the last point), leaving this value set to false may result in minor pixel artifacts due to rounding.


PointInBox Method (pt, pane, g, scaleFactor)

PointInBox Method (pt, pane, g, scaleFactor)
Namespaces ► ZedGraph ► PolyObj ► PointInBox(PointF, PaneBase, Graphics, Single)
Determine if the specified screen point lies inside the bounding box of this PolyObj.
Declaration Syntax
C# Visual Basic Visual C++
public override bool PointInBox(
    PointF pt,
    PaneBase pane,
    Graphics g,
    float scaleFactor
)
Public Overrides Function PointInBox ( _
    pt As PointF, _
    pane As PaneBase, _
    g As Graphics, _
    scaleFactor As Single _
) As Boolean
public:
virtual bool PointInBox (
    PointF pt,
    PaneBase^ pane,
    Graphics^ g,
    float scaleFactor
) override
Parameters
pt (PointF)
The screen point, in pixels
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
true if the point lies in the bounding box, false otherwise


Points Property

Points Property
Namespaces ► ZedGraph ► PolyObj ► Points
Gets or sets the PointD array that defines the polygon. This will be in units determined by CoordinateFrame.
Declaration Syntax
C# Visual Basic Visual C++
public PointD[] Points{ get; set;}
Public Property Points As PointD()
public:
property array<PointD>^ Points {
    array<PointD>^ get ();
    void set (array<PointD>^ value);
}


schema3 Field

schema3 Field
Namespaces ► ZedGraph ► PolyObj ► schema3
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema3
Public Const schema3 As Integer
public:
literal int schema3


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► PolyObj ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


RadarPointList Class

RadarPointList Class
Namespaces ► ZedGraph ► RadarPointList
A class containing a set of data values to be plotted as a RadarPlot. This class will effectively convert the data into PointPair objects by converting the polar coordinates to rectangular coordinates
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class RadarPointList : List<PointPair>, IPointListEdit,
    IPointList, ICloneable
<SerializableAttribute> _
Public Class RadarPointList _
    Inherits List(Of PointPair) _
    Implements IPointListEdit, IPointList, ICloneable
[SerializableAttribute]
public ref class RadarPointList : public List<PointPair^>,
    IPointListEdit, IPointList, ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RadarPointListRadarPointListNew()() | Default Constructor
 | RadarPointListRadarPointListNew(RadarPointList) | Copy Constructor
 | Add(Double, Double) | Add a single point to the RadarPointList from two values of type double.
 | Add(T) | Adds an object to the end of the List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | AddRange(IEnumerable<(Of <T>)>) | Adds the elements of the specified collection to the end of the List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | AsReadOnly()() | Returns a read-only IList<(Of <T>)> wrapper for the current collection. (Inherited from List <(Of < PointPair >)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < PointPair >)>.)
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of < PointPair >)>.)
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < PointPair >)>.)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of < PointPair >)>.)
 | Clear()() | Removes all elements from the List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | Clockwise | Indicates if points should be added in clockwise or counter-clockwise order
 | Clone()() | Typesafe, deep-copy clone method.
 | Contains(T) | Determines whether an element is in the List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | ConvertAll<(Of <TOutput>)>(Converter<(Of <T, TOutput>)>) | Converts the elements in the current List<(Of <T>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of < PointPair >)>.)
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of < PointPair >)>.)
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < PointPair >)>.)
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < PointPair >)>.)
 | Count | gets the number of points available in the list
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <T>)>) | Determines whether the List<(Of <T>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < PointPair >)>.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | FindAll(Predicate<(Of <T>)>) | Retrieves the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < PointPair >)>.)
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < PointPair >)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < PointPair >)>.)
 | FindLast(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < PointPair >)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < PointPair >)>.)
 | ForEach(Action<(Of <T>)>) | Performs the specified action on each element of the List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | GetEnumerator()() | Returns an enumerator that iterates through the List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < PointPair >)>.)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < PointPair >)>.)
 | Insert(Int32, T) | Inserts an element into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < PointPair >)>.)
 | InsertRange(Int32, IEnumerable<(Of <T>)>) | Inserts the elements of a collection into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < PointPair >)>.)
 | Item[([Int32])] | Indexer to access the specified PointPair object by its ordinal position in the list. This method does the calculations to convert the data from polar to rectangular coordinates.
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < PointPair >)>.)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < PointPair >)>.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | RemoveAll(Predicate<(Of <T>)>) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < PointPair >)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of < PointPair >)>.)
 | Rotation | Sets the angular rotation (starting angle) for the initial axis
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer. (Inherited from List <(Of < PointPair >)>.)
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < PointPair >)>.)
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < PointPair >)>.)
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>. (Inherited from List <(Of < PointPair >)>.)
 | ICollection<(Of <T>)>..::IsReadOnly | (Inherited from List <(Of < PointPair >)>.)
 | IEnumerable<(Of <T>)>..::GetEnumerator()() | (Inherited from List <(Of < PointPair >)>.)
 | ICollection..::CopyTo(Array, Int32) | (Inherited from List <(Of < PointPair >)>.)
 | ICollection..::IsSynchronized | (Inherited from List <(Of < PointPair >)>.)
 | ICollection..::SyncRoot | (Inherited from List <(Of < PointPair >)>.)
 | IEnumerable..::GetEnumerator()() | (Inherited from List <(Of < PointPair >)>.)
 | IList..::Add(Object) | (Inherited from List <(Of < PointPair >)>.)
 | IList..::Contains(Object) | (Inherited from List <(Of < PointPair >)>.)
 | IList..::IndexOf(Object) | (Inherited from List <(Of < PointPair >)>.)
 | IList..::Insert(Int32, Object) | (Inherited from List <(Of < PointPair >)>.)
 | IList..::IsFixedSize | (Inherited from List <(Of < PointPair >)>.)
 | IList..::IsReadOnly | (Inherited from List <(Of < PointPair >)>.)
 | IList..::Item[([Int32])] | (Inherited from List <(Of < PointPair >)>.)
 | IList..::Remove(Object) | (Inherited from List <(Of < PointPair >)>.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToArray()() | Copies the elements of the List<(Of <T>)> to a new array. (Inherited from List <(Of < PointPair >)>.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()() | Sets the capacity to the actual number of elements in the List<(Of <T>)>, if that number is less than a threshold value. (Inherited from List <(Of < PointPair >)>.)
 | TrueForAll(Predicate<(Of <T>)>) | Determines whether every element in the List<(Of <T>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of < PointPair >)>.)
Inheritance Hierarchy
Object
 | List <(Of < PointPair >)>
 |  | RadarPointList
See Also
BasicArrayPointList
IPointList
IPointListEdit


RadarPointList Constructor

RadarPointList Constructor
Namespaces ► ZedGraph ► RadarPointList ► RadarPointListRadarPointListNew()()
Members
Icon | Member | Description
 | RadarPointListRadarPointListNew()() | Default Constructor
 | RadarPointListRadarPointListNew(RadarPointList) | Copy Constructor


RadarPointList Constructor

RadarPointList Constructor
Namespaces ► ZedGraph ► RadarPointList ► RadarPointListRadarPointListNew()()
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public RadarPointList()
Public Sub New
public:
RadarPointList ()


RadarPointList Constructor (rhs)

RadarPointList Constructor (rhs)
Namespaces ► ZedGraph ► RadarPointList ► RadarPointListRadarPointListNew(RadarPointList)
Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public RadarPointList(
    RadarPointList rhs
)
Public Sub New ( _
    rhs As RadarPointList _
)
public:
RadarPointList (
    RadarPointList^ rhs
)
Parameters
rhs (RadarPointList)


Add Method (r, z)

Add Method (r, z)
Namespaces ► ZedGraph ► RadarPointList ► Add(Double, Double)
Add a single point to the RadarPointList from two values of type double.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    double r,
    double z
)
Public Sub Add ( _
    r As Double, _
    z As Double _
)
public:
virtual void Add (
    double r,
    double z
) sealed
Parameters
r (Double)
The radial coordinate value
z (Double)
The 'Z' coordinate value, which is not normally used for plotting, but can be used for GradientByZ type fills
Return Value
The zero-based ordinal index where the point was added in the list.


Clockwise Property

Clockwise Property
Namespaces ► ZedGraph ► RadarPointList ► Clockwise
Indicates if points should be added in clockwise or counter-clockwise order
Declaration Syntax
C# Visual Basic Visual C++
public bool Clockwise{ get; set;}
Public Property Clockwise As Boolean
public:
property bool Clockwise {
    bool get ();
    void set (bool value);
}


Clone Method

Clone Method
Namespaces ► ZedGraph ► RadarPointList ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public RadarPointList Clone()
Public Function Clone As RadarPointList
public:
RadarPointList^ Clone ()
Return Value
A new, independent copy of this class


Count Property

Count Property
Namespaces ► ZedGraph ► RadarPointList ► Count
gets the number of points available in the list
Declaration Syntax
C# Visual Basic Visual C++
public int Count{ get;}
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph ► RadarPointList ► Item[([Int32])]
Indexer to access the specified PointPair object by its ordinal position in the list. This method does the calculations to convert the data from polar to rectangular coordinates.
Declaration Syntax
C# Visual Basic Visual C++
public PointPair this[
    int index
]{ get; set;}
Public Default Property Item ( _
    index As Integer _
) As PointPair
public:
virtual property PointPair^ default[int index] {
    PointPair^ get (int index) sealed;
    void set (int index, PointPair^ value) sealed;
}
Parameters
index (Int32)
The ordinal position (zero-based) of the PointPair object to be accessed.
Value
A PointPair object reference.


Rotation Property

Rotation Property
Namespaces ► ZedGraph ► RadarPointList ► Rotation
Sets the angular rotation (starting angle) for the initial axis
Declaration Syntax
C# Visual Basic Visual C++
public double Rotation{ get; set;}
Public Property Rotation As Double
public:
property double Rotation {
    double get ();
    void set (double value);
}


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► RadarPointList ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


RenderModeType Enumeration

RenderModeType Enumeration
Namespaces ► ZedGraph ► RenderModeType
Enum for specifying the type of data to be returned by the ZedGraphWeb Render() method.
Declaration Syntax
C# Visual Basic Visual C++
public enum RenderModeType
Public Enumeration RenderModeType
public enum class RenderModeType
Members
Member | Description
ImageTag | Renders as an IMG tag referencing a local generated image. ContentType stays text.
RawImage | Renders the binary image. ContentType is changed accordingly.


RollingPointPairList Class

RollingPointPairList Class
Namespaces ► ZedGraph ► RollingPointPairList
A class that provides a rolling list of PointPair objects. This is essentially a first-in-first-out (FIFO) queue with a fixed capacity which allows 'rolling' (or oscilloscope like) graphs to be be animated without having the overhead of an ever-growing ArrayList. The queue is constructed with a fixed capacity and new points can be enqueued. When the capacity is reached the oldest (first in) PointPair is overwritten. However, when accessing via IPointList, the PointPair objects are seen in the order in which they were enqeued. RollingPointPairList supports data editing through the IPointListEdit interface. Colin Green with mods by John Champion $Date: 2007/02/18 05:51:54 $
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class RollingPointPairList : ISerializable,
    IPointListEdit, IPointList, ICloneable
<SerializableAttribute> _
Public Class RollingPointPairList _
    Implements ISerializable, IPointListEdit, IPointList, ICloneable
[SerializableAttribute]
public ref class RollingPointPairList : ISerializable,
    IPointListEdit, IPointList, ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RollingPointPairListRollingPointPairListNew(Int32) | Constructs an empty buffer with the specified capacity.
 | RollingPointPairListRollingPointPairListNew(Int32, Boolean) | Constructs an empty buffer with the specified capacity. Pre-allocates space for all PointPair's in the list if preLoad is true.
 | RollingPointPairListRollingPointPairListNew(IPointList) | Constructs a buffer with a copy of the items within the provided IPointList. The Capacity is set to the length of the provided list.
 | Add(PointPair) | Add a PointPair onto the head of the queue, overwriting old values if the buffer is full.
 | Add(IPointList) | Add an IPointList object to the head of the queue.
 | Add(Double, Double, Double, Object) | Add a set of values onto the head of the queue, overwriting old values if the buffer is full.
 | Add(Double, Double) | Add a set of values onto the head of the queue, overwriting old values if the buffer is full.
 | Add(Double, Double, Object) | Add a set of values onto the head of the queue, overwriting old values if the buffer is full.
 | Add(Double, Double, Double) | Add a set of values onto the head of the queue, overwriting old values if the buffer is full.
 | Add(array<Double>[](), array<Double>[]()) | Add a set of points to the RollingPointPairList from two arrays of type double. If either array is null, then a set of ordinal values is automatically generated in its place (see Ordinal). If the arrays are of different size, then the larger array prevails and the smaller array is padded with Missing values.
 | Add(array<Double>[](), array<Double>[](), array<Double>[]()) | Add a set of points to the RollingPointPairList from three arrays of type double. If the X or Y array is null, then a set of ordinal values is automatically generated in its place (see Ordinal. If the value is null, then it is set to zero. If the arrays are of different size, then the larger array prevails and the smaller array is padded with Missing values.
 | Capacity | Gets the capacity of the rolling buffer.
 | Clear()() | Clear the buffer of all PointPair objects. Note that the Capacity remains unchanged.
 | Clone()() | Typesafe, deep-copy clone method.
 | Count | Gets the count of items within the rolling buffer. Note that this may be less than the capacity.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsEmpty | Gets a bolean that indicates if the buffer is empty. Alternatively you can test Count==0.
 | Item[([Int32])] | Gets or sets the PointPair at the specified index in the buffer.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Peek()() | Peek at the PointPair item at the head of the queue.
 | Pop()() | Pop an item off the head of the queue.
 | Remove()() | Remove an old item from the tail of the queue.
 | RemoveAt(Int32) | Remove the PointPair at the specified index
 | schema | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RollingPointPairList


RollingPointPairList Constructor

RollingPointPairList Constructor
Namespaces ► ZedGraph ► RollingPointPairList ► RollingPointPairListRollingPointPairListNew()()
Members
Icon | Member | Description
 | RollingPointPairListRollingPointPairListNew(Int32) | Constructs an empty buffer with the specified capacity.
 | RollingPointPairListRollingPointPairListNew(Int32, Boolean) | Constructs an empty buffer with the specified capacity. Pre-allocates space for all PointPair's in the list if preLoad is true.
 | RollingPointPairListRollingPointPairListNew(IPointList) | Constructs a buffer with a copy of the items within the provided IPointList. The Capacity is set to the length of the provided list.


RollingPointPairList Constructor (capacity)

RollingPointPairList Constructor (capacity)
Namespaces ► ZedGraph ► RollingPointPairList ► RollingPointPairListRollingPointPairListNew(Int32)
Constructs an empty buffer with the specified capacity.
Declaration Syntax
C# Visual Basic Visual C++
public RollingPointPairList(
    int capacity
)
Public Sub New ( _
    capacity As Integer _
)
public:
RollingPointPairList (
    int capacity
)
Parameters
capacity (Int32)
Number of elements in the rolling list. This number cannot be changed once the RollingPointPairList is constructed.


RollingPointPairList Constructor (capacity, preLoad)

RollingPointPairList Constructor (capacity, preLoad)
Namespaces ► ZedGraph ► RollingPointPairList ► RollingPointPairListRollingPointPairListNew(Int32, Boolean)
Constructs an empty buffer with the specified capacity. Pre-allocates space for all PointPair's in the list if preLoad is true.
Declaration Syntax
C# Visual Basic Visual C++
public RollingPointPairList(
    int capacity,
    bool preLoad
)
Public Sub New ( _
    capacity As Integer, _
    preLoad As Boolean _
)
public:
RollingPointPairList (
    int capacity,
    bool preLoad
)
Parameters
capacity (Int32)
Number of elements in the rolling list. This number cannot be changed once the RollingPointPairList is constructed.
preLoad (Boolean)
true to pre-allocate all PointPair instances in the list, false otherwise. Note that in order to be memory efficient, the Add(Double, Double, Double) method should be used to add data. Avoid the Add(PointPair) method.
See Also
Add(Double, Double, Double)


RollingPointPairList Constructor (rhs)

RollingPointPairList Constructor (rhs)
Namespaces ► ZedGraph ► RollingPointPairList ► RollingPointPairListRollingPointPairListNew(IPointList)
Constructs a buffer with a copy of the items within the provided IPointList. The Capacity is set to the length of the provided list.
Declaration Syntax
C# Visual Basic Visual C++
public RollingPointPairList(
    IPointList rhs
)
Public Sub New ( _
    rhs As IPointList _
)
public:
RollingPointPairList (
    IPointList^ rhs
)
Parameters
rhs (IPointList)
The IPointList to be copied.


Add Method

Add Method
Namespaces ► ZedGraph ► RollingPointPairList ► Add()()
Members
Icon | Member | Description
 | Add(PointPair) | Add a PointPair onto the head of the queue, overwriting old values if the buffer is full.
 | Add(IPointList) | Add an IPointList object to the head of the queue.
 | Add(Double, Double, Double, Object) | Add a set of values onto the head of the queue, overwriting old values if the buffer is full.
 | Add(Double, Double) | Add a set of values onto the head of the queue, overwriting old values if the buffer is full.
 | Add(Double, Double, Object) | Add a set of values onto the head of the queue, overwriting old values if the buffer is full.
 | Add(Double, Double, Double) | Add a set of values onto the head of the queue, overwriting old values if the buffer is full.
 | Add(array<Double>[](), array<Double>[]()) | Add a set of points to the RollingPointPairList from two arrays of type double. If either array is null, then a set of ordinal values is automatically generated in its place (see Ordinal). If the arrays are of different size, then the larger array prevails and the smaller array is padded with Missing values.
 | Add(array<Double>[](), array<Double>[](), array<Double>[]()) | Add a set of points to the RollingPointPairList from three arrays of type double. If the X or Y array is null, then a set of ordinal values is automatically generated in its place (see Ordinal. If the value is null, then it is set to zero. If the arrays are of different size, then the larger array prevails and the smaller array is padded with Missing values.


Add Method (x, y)

Add Method (x, y)
Namespaces ► ZedGraph ► RollingPointPairList ► Add(Double, Double)
Add a set of values onto the head of the queue, overwriting old values if the buffer is full.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    double x,
    double y
)
Public Sub Add ( _
    x As Double, _
    y As Double _
)
public:
virtual void Add (
    double x,
    double y
) sealed
Parameters
x (Double)
The X value
y (Double)
The Y value
Remarks
This method is much more efficient that the Add(PointPair) method, since it does not require that a new PointPair instance be provided. If the buffer already contains a PointPair at the head position, then the x, y, z, and tag values will be copied into the existing PointPair. Otherwise, a new PointPair instance must be created. In this way, each PointPair position in the rolling list will only be allocated one time. To truly be memory efficient, the Remove()(), RemoveAt(Int32), and Pop()() methods should be avoided.


Add Method (x, y, z)

Add Method (x, y, z)
Namespaces ► ZedGraph ► RollingPointPairList ► Add(Double, Double, Double)
Add a set of values onto the head of the queue, overwriting old values if the buffer is full.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    double x,
    double y,
    double z
)
Public Sub Add ( _
    x As Double, _
    y As Double, _
    z As Double _
)
public:
void Add (
    double x,
    double y,
    double z
)
Parameters
x (Double)
The X value
y (Double)
The Y value
z (Double)
The Z value
Remarks
This method is much more efficient that the Add(PointPair) method, since it does not require that a new PointPair instance be provided. If the buffer already contains a PointPair at the head position, then the x, y, z, and tag values will be copied into the existing PointPair. Otherwise, a new PointPair instance must be created. In this way, each PointPair position in the rolling list will only be allocated one time. To truly be memory efficient, the Remove()(), RemoveAt(Int32), and Pop()() methods should be avoided.


Add Method (x, y, z, tag)

Add Method (x, y, z, tag)
Namespaces ► ZedGraph ► RollingPointPairList ► Add(Double, Double, Double, Object)
Add a set of values onto the head of the queue, overwriting old values if the buffer is full.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    double x,
    double y,
    double z,
    Object tag
)
Public Sub Add ( _
    x As Double, _
    y As Double, _
    z As Double, _
    tag As Object _
)
public:
void Add (
    double x,
    double y,
    double z,
    Object^ tag
)
Parameters
x (Double)
The X value
y (Double)
The Y value
z (Double)
The Z value
tag (Object)
The Tag value for the PointPair
Remarks
This method is much more efficient that the Add(PointPair) method, since it does not require that a new PointPair instance be provided. If the buffer already contains a PointPair at the head position, then the x, y, z, and tag values will be copied into the existing PointPair. Otherwise, a new PointPair instance must be created. In this way, each PointPair position in the rolling list will only be allocated one time. To truly be memory efficient, the Remove()(), RemoveAt(Int32), and Pop()() methods should be avoided. Also, the tag property for this method should be null, since it is a reference type.


Add Method (x, y, tag)

Add Method (x, y, tag)
Namespaces ► ZedGraph ► RollingPointPairList ► Add(Double, Double, Object)
Add a set of values onto the head of the queue, overwriting old values if the buffer is full.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    double x,
    double y,
    Object tag
)
Public Sub Add ( _
    x As Double, _
    y As Double, _
    tag As Object _
)
public:
void Add (
    double x,
    double y,
    Object^ tag
)
Parameters
x (Double)
The X value
y (Double)
The Y value
tag (Object)
The Tag value for the PointPair
Remarks
This method is much more efficient that the Add(PointPair) method, since it does not require that a new PointPair instance be provided. If the buffer already contains a PointPair at the head position, then the x, y, z, and tag values will be copied into the existing PointPair. Otherwise, a new PointPair instance must be created. In this way, each PointPair position in the rolling list will only be allocated one time. To truly be memory efficient, the Remove()(), RemoveAt(Int32), and Pop()() methods should be avoided. Also, the tag property for this method should be null, since it is a reference type.


Add Method (x, y)

Add Method (x, y)
Namespaces ► ZedGraph ► RollingPointPairList ► Add(array<Double>[](), array<Double>[]())
Add a set of points to the RollingPointPairList from two arrays of type double. If either array is null, then a set of ordinal values is automatically generated in its place (see Ordinal). If the arrays are of different size, then the larger array prevails and the smaller array is padded with Missing values.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    double[] x,
    double[] y
)
Public Sub Add ( _
    x As Double(), _
    y As Double() _
)
public:
void Add (
    array<double>^ x,
    array<double>^ y
)
Parameters
x (array< Double >[]())
A double[] array of X values
y (array< Double >[]())
A double[] array of Y values


Add Method (x, y, z)

Add Method (x, y, z)
Namespaces ► ZedGraph ► RollingPointPairList ► Add(array<Double>[](), array<Double>[](), array<Double>[]())
Add a set of points to the RollingPointPairList from three arrays of type double. If the X or Y array is null, then a set of ordinal values is automatically generated in its place (see Ordinal. If the value is null, then it is set to zero. If the arrays are of different size, then the larger array prevails and the smaller array is padded with Missing values.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    double[] x,
    double[] y,
    double[] z
)
Public Sub Add ( _
    x As Double(), _
    y As Double(), _
    z As Double() _
)
public:
void Add (
    array<double>^ x,
    array<double>^ y,
    array<double>^ z
)
Parameters
x (array< Double >[]())
A double[] array of X values
y (array< Double >[]())
A double[] array of Y values
z (array< Double >[]())
A double[] array of Z values


Add Method (pointList)

Add Method (pointList)
Namespaces ► ZedGraph ► RollingPointPairList ► Add(IPointList)
Add an IPointList object to the head of the queue.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    IPointList pointList
)
Public Sub Add ( _
    pointList As IPointList _
)
public:
void Add (
    IPointList^ pointList
)
Parameters
pointList (IPointList)
A reference to the IPointList object to be added


Add Method (item)

Add Method (item)
Namespaces ► ZedGraph ► RollingPointPairList ► Add(PointPair)
Add a PointPair onto the head of the queue, overwriting old values if the buffer is full.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    PointPair item
)
Public Sub Add ( _
    item As PointPair _
)
public:
virtual void Add (
    PointPair^ item
) sealed
Parameters
item (PointPair)
The PointPair to be added.


Capacity Property

Capacity Property
Namespaces ► ZedGraph ► RollingPointPairList ► Capacity
Gets the capacity of the rolling buffer.
Declaration Syntax
C# Visual Basic Visual C++
public int Capacity{ get;}
Public ReadOnly Property Capacity As Integer
public:
property int Capacity {
    int get ();
}


Clear Method

Clear Method
Namespaces ► ZedGraph ► RollingPointPairList ► Clear()()
Clear the buffer of all PointPair objects. Note that the Capacity remains unchanged.
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
virtual void Clear () sealed


Clone Method

Clone Method
Namespaces ► ZedGraph ► RollingPointPairList ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public RollingPointPairList Clone()
Public Function Clone As RollingPointPairList
public:
RollingPointPairList^ Clone ()
Return Value
A new, independent copy of this class


Count Property

Count Property
Namespaces ► ZedGraph ► RollingPointPairList ► Count
Gets the count of items within the rolling buffer. Note that this may be less than the capacity.
Declaration Syntax
C# Visual Basic Visual C++
public int Count{ get;}
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► RollingPointPairList ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsEmpty Property

IsEmpty Property
Namespaces ► ZedGraph ► RollingPointPairList ► IsEmpty
Gets a bolean that indicates if the buffer is empty. Alternatively you can test Count==0.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEmpty{ get;}
Public ReadOnly Property IsEmpty As Boolean
public:
property bool IsEmpty {
    bool get ();
}


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph ► RollingPointPairList ► Item[([Int32])]
Gets or sets the PointPair at the specified index in the buffer.
Declaration Syntax
C# Visual Basic Visual C++
public PointPair this[
    int index
]{ get; set;}
Public Default Property Item ( _
    index As Integer _
) As PointPair
public:
virtual property PointPair^ default[int index] {
    PointPair^ get (int index) sealed;
    void set (int index, PointPair^ value) sealed;
}
Parameters
index (Int32)
Remarks
Index must be within the current size of the buffer, e.g., the set method will not expand the buffer even if Capacity is available


Peek Method

Peek Method
Namespaces ► ZedGraph ► RollingPointPairList ► Peek()()
Peek at the PointPair item at the head of the queue.
Declaration Syntax
C# Visual Basic Visual C++
public PointPair Peek()
Public Function Peek As PointPair
public:
PointPair^ Peek ()
Return Value
The PointPair item at the head of the queue. Throws an InvalidOperationException if the buffer was empty.


Pop Method

Pop Method
Namespaces ► ZedGraph ► RollingPointPairList ► Pop()()
Pop an item off the head of the queue.
Declaration Syntax
C# Visual Basic Visual C++
public PointPair Pop()
Public Function Pop As PointPair
public:
PointPair^ Pop ()
Return Value
The popped item. Throws an exception if the buffer was empty.


Remove Method

Remove Method
Namespaces ► ZedGraph ► RollingPointPairList ► Remove()()
Remove an old item from the tail of the queue.
Declaration Syntax
C# Visual Basic Visual C++
public PointPair Remove()
Public Function Remove As PointPair
public:
PointPair^ Remove ()
Return Value
The removed item. Throws an InvalidOperationException if the buffer was empty. Check the buffer's length (Count) or the IsEmpty property to avoid exceptions.


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces ► ZedGraph ► RollingPointPairList ► RemoveAt(Int32)
Remove the PointPair at the specified index
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
virtual void RemoveAt (
    int index
) sealed
Parameters
index (Int32)
The ordinal position of the item to be removed. Throws an ArgumentOutOfRangeException if index is less than zero or greater than or equal to Count
Remarks
All items in the queue that lie after index will be shifted back by one, and the queue will be one item shorter.


schema Field

schema Field
Namespaces ► ZedGraph ► RollingPointPairList ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► RollingPointPairList ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Sample Class

Sample Class
Namespaces ► ZedGraph ► Sample
A simple storage class to maintain an individual sampling of data
Declaration Syntax
C# Visual Basic Visual C++
public class Sample
Public Class Sample
public ref class Sample
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SampleSampleNew()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | The position at sample time
 | Time | The time of the sample
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Velocity | The instantaneous velocity at sample time
Inheritance Hierarchy
Object
Sample


Sample Constructor

Sample Constructor
Namespaces ► ZedGraph ► Sample ► SampleSampleNew()()
Declaration Syntax
C# Visual Basic Visual C++
public Sample()
Public Sub New
public:
Sample ()


Position Property

Position Property
Namespaces ► ZedGraph ► Sample ► Position
The position at sample time
Declaration Syntax
C# Visual Basic Visual C++
public double Position{ get; set;}
Public Property Position As Double
public:
property double Position {
    double get ();
    void set (double value);
}


Time Property

Time Property
Namespaces ► ZedGraph ► Sample ► Time
The time of the sample
Declaration Syntax
C# Visual Basic Visual C++
public DateTime Time{ get; set;}
Public Property Time As DateTime
public:
property DateTime Time {
    DateTime get ();
    void set (DateTime value);
}


Velocity Property

Velocity Property
Namespaces ► ZedGraph ► Sample ► Velocity
The instantaneous velocity at sample time
Declaration Syntax
C# Visual Basic Visual C++
public double Velocity{ get; set;}
Public Property Velocity As Double
public:
property double Velocity {
    double get ();
    void set (double value);
}


SampleMultiPointList Class

SampleMultiPointList Class
Namespaces ► ZedGraph ► SampleMultiPointList
A sample class that holds an internal collection, and implements the IPointList interface so that it can be used by ZedGraph as curve data.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class SampleMultiPointList : IPointList,
    ICloneable
<SerializableAttribute> _
Public Class SampleMultiPointList _
    Implements IPointList, ICloneable
[SerializableAttribute]
public ref class SampleMultiPointList : IPointList,
    ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SampleMultiPointListSampleMultiPointListNew()() | Default constructor
 | SampleMultiPointListSampleMultiPointListNew(SampleMultiPointList) | The Copy Constructor. This method does NOT duplicate the data, it merely makes another "Window" into the same collection. You can make multiple copies and set the XData and/or YData properties to different values to plot different data, while maintaining only one copy of the original values.
 | Add(PerformanceData) | Adds the specified PerformanceData struct to the end of the collection.
 | Clone()() | Typesafe, deep-copy clone method.
 | Count | Gets the number of data points in the collection
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Insert(Int32, PerformanceData) | Insert the specified PerformanceData struct into the list at the specified ordinal location.
 | Item[([Int32])] | Indexer to access the data. This gets the appropriate data and converts to the PointPair struct that is compatible with ZedGraph. The actual data returned depends on the values of XData and YData.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveAt(Int32) | Remove the PerformanceData struct from the list at the specified ordinal location.
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | XData | Determines what X data will be returned by the indexer of this list.
 | YData | Determines what Y data will be returned by the indexer of this list.
Remarks
This particular class efficiently implements the data storage so that the class can be cloned without duplicating the data points. For example, you can create a SampleMultiPointList, populate it with values, and set XData = Time and YData = Distance. You can then clone this SampleMultiPointList to a new one, and set YData = Velocity. Each of these SampleMultiPointList's can then be used as an AddCurve(String, IPointList, Color) argument, thereby plotting a distance vs time curve and a velocity vs time curve. There will still be only one copy of the data in memory.
Inheritance Hierarchy
Object
SampleMultiPointList


SampleMultiPointList Constructor

SampleMultiPointList Constructor
Namespaces ► ZedGraph ► SampleMultiPointList ► SampleMultiPointListSampleMultiPointListNew()()
Members
Icon | Member | Description
 | SampleMultiPointListSampleMultiPointListNew()() | Default constructor
 | SampleMultiPointListSampleMultiPointListNew(SampleMultiPointList) | The Copy Constructor. This method does NOT duplicate the data, it merely makes another "Window" into the same collection. You can make multiple copies and set the XData and/or YData properties to different values to plot different data, while maintaining only one copy of the original values.


SampleMultiPointList Constructor

SampleMultiPointList Constructor
Namespaces ► ZedGraph ► SampleMultiPointList ► SampleMultiPointListSampleMultiPointListNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public SampleMultiPointList()
Public Sub New
public:
SampleMultiPointList ()


SampleMultiPointList Constructor (rhs)

SampleMultiPointList Constructor (rhs)
Namespaces ► ZedGraph ► SampleMultiPointList ► SampleMultiPointListSampleMultiPointListNew(SampleMultiPointList)
The Copy Constructor. This method does NOT duplicate the data, it merely makes another "Window" into the same collection. You can make multiple copies and set the XData and/or YData properties to different values to plot different data, while maintaining only one copy of the original values.
Declaration Syntax
C# Visual Basic Visual C++
public SampleMultiPointList(
    SampleMultiPointList rhs
)
Public Sub New ( _
    rhs As SampleMultiPointList _
)
public:
SampleMultiPointList (
    SampleMultiPointList^ rhs
)
Parameters
rhs (SampleMultiPointList)
The SampleMultiPointList from which to copy


Add Method (perfData)

Add Method (perfData)
Namespaces ► ZedGraph ► SampleMultiPointList ► Add(PerformanceData)
Adds the specified PerformanceData struct to the end of the collection.
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    PerformanceData perfData
)
Public Function Add ( _
    perfData As PerformanceData _
) As Integer
public:
int Add (
    PerformanceData^ perfData
)
Parameters
perfData (PerformanceData)
A PerformanceData struct to be added
Return Value
The ordinal position in the collection where the values were added


Clone Method

Clone Method
Namespaces ► ZedGraph ► SampleMultiPointList ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public SampleMultiPointList Clone()
Public Function Clone As SampleMultiPointList
public:
SampleMultiPointList^ Clone ()
Return Value
A new, independent copy of this class


Count Property

Count Property
Namespaces ► ZedGraph ► SampleMultiPointList ► Count
Gets the number of data points in the collection
Declaration Syntax
C# Visual Basic Visual C++
public int Count{ get;}
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}


Insert Method (index, perfData)

Insert Method (index, perfData)
Namespaces ► ZedGraph ► SampleMultiPointList ► Insert(Int32, PerformanceData)
Insert the specified PerformanceData struct into the list at the specified ordinal location.
Declaration Syntax
C# Visual Basic Visual C++
public void Insert(
    int index,
    PerformanceData perfData
)
Public Sub Insert ( _
    index As Integer, _
    perfData As PerformanceData _
)
public:
void Insert (
    int index,
    PerformanceData^ perfData
)
Parameters
index (Int32)
The ordinal location at which to insert
perfData (PerformanceData)
The PerformanceData struct to be inserted


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph ► SampleMultiPointList ► Item[([Int32])]
Indexer to access the data. This gets the appropriate data and converts to the PointPair struct that is compatible with ZedGraph. The actual data returned depends on the values of XData and YData.
Declaration Syntax
C# Visual Basic Visual C++
public PointPair this[
    int index
]{ get;}
Public ReadOnly Default Property Item ( _
    index As Integer _
) As PointPair
public:
virtual property PointPair^ default[int index] {
    PointPair^ get (int index) sealed;
}
Parameters
index (Int32)
The ordinal position of the desired point in the list
Return Value
A PointPair corresponding to the specified ordinal data position


RemoveAt Method (index)

RemoveAt Method (index)
Namespaces ► ZedGraph ► SampleMultiPointList ► RemoveAt(Int32)
Remove the PerformanceData struct from the list at the specified ordinal location.
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAt(
    int index
)
Public Sub RemoveAt ( _
    index As Integer _
)
public:
void RemoveAt (
    int index
)
Parameters
index (Int32)
The ordinal location of the PerformanceData struct to be removed


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► SampleMultiPointList ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


XData Field

XData Field
Namespaces ► ZedGraph ► SampleMultiPointList ► XData
Determines what X data will be returned by the indexer of this list.
Declaration Syntax
C# Visual Basic Visual C++
public PerfDataType XData
Public XData As PerfDataType
public:
PerfDataType XData


YData Field

YData Field
Namespaces ► ZedGraph ► SampleMultiPointList ► YData
Determines what Y data will be returned by the indexer of this list.
Declaration Syntax
C# Visual Basic Visual C++
public PerfDataType YData
Public YData As PerfDataType
public:
PerfDataType YData


SamplePointList Class

SamplePointList Class
Namespaces ► ZedGraph ► SamplePointList
A collection class to maintain a set of samples
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class SamplePointList : IPointList,
    ICloneable
<SerializableAttribute> _
Public Class SamplePointList _
    Implements IPointList, ICloneable
[SerializableAttribute]
public ref class SamplePointList : IPointList,
    ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SamplePointListSamplePointListNew()() | default constructor
 | SamplePointListSamplePointListNew(SamplePointList) | copy constructor -- this returns a copy of the structure, but it does not duplicate the data (it just keeps a reference to the original)
 | Add(Sample) | Append a sample to the collection
 | Clone()() | typesafe clone method
 | Count | Gets the number of samples in the collection
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(Sample, SampleType) | Get the specified data type from the specified sample
 | Item[([Int32])] | Indexer: get the Sample instance at the specified ordinal position in the list
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ICloneable..::Clone()() |
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | XType | Determines what data type gets plotted for the X values
 | YType | Determines what data type gets plotted for the Y values
Inheritance Hierarchy
Object
SamplePointList


SamplePointList Constructor

SamplePointList Constructor
Namespaces ► ZedGraph ► SamplePointList ► SamplePointListSamplePointListNew()()
Members
Icon | Member | Description
 | SamplePointListSamplePointListNew()() | default constructor
 | SamplePointListSamplePointListNew(SamplePointList) | copy constructor -- this returns a copy of the structure, but it does not duplicate the data (it just keeps a reference to the original)


SamplePointList Constructor

SamplePointList Constructor
Namespaces ► ZedGraph ► SamplePointList ► SamplePointListSamplePointListNew()()
default constructor
Declaration Syntax
C# Visual Basic Visual C++
public SamplePointList()
Public Sub New
public:
SamplePointList ()


SamplePointList Constructor (rhs)

SamplePointList Constructor (rhs)
Namespaces ► ZedGraph ► SamplePointList ► SamplePointListSamplePointListNew(SamplePointList)
copy constructor -- this returns a copy of the structure, but it does not duplicate the data (it just keeps a reference to the original)
Declaration Syntax
C# Visual Basic Visual C++
public SamplePointList(
    SamplePointList rhs
)
Public Sub New ( _
    rhs As SamplePointList _
)
public:
SamplePointList (
    SamplePointList^ rhs
)
Parameters
rhs (SamplePointList)
The SamplePointList to be copied


Add Method (sample)

Add Method (sample)
Namespaces ► ZedGraph ► SamplePointList ► Add(Sample)
Append a sample to the collection
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    Sample sample
)
Public Function Add ( _
    sample As Sample _
) As Integer
public:
int Add (
    Sample^ sample
)
Parameters
sample (Sample)
The sample to append
Return Value
The ordinal position at which the sample was added


Clone Method

Clone Method
Namespaces ► ZedGraph ► SamplePointList ► Clone()()
typesafe clone method
Declaration Syntax
C# Visual Basic Visual C++
public SamplePointList Clone()
Public Function Clone As SamplePointList
public:
SamplePointList^ Clone ()
Return Value
A new cloned SamplePointList. This returns a copy of the structure, but it does not duplicate the data (it just keeps a reference to the original)


Count Property

Count Property
Namespaces ► ZedGraph ► SamplePointList ► Count
Gets the number of samples in the collection
Declaration Syntax
C# Visual Basic Visual C++
public int Count{ get;}
Public ReadOnly Property Count As Integer
public:
virtual property int Count {
    int get () sealed;
}


GetValue Method (sample, type)

GetValue Method (sample, type)
Namespaces ► ZedGraph ► SamplePointList ► GetValue(Sample, SampleType)
Get the specified data type from the specified sample
Declaration Syntax
C# Visual Basic Visual C++
public double GetValue(
    Sample sample,
    SampleType type
)
Public Function GetValue ( _
    sample As Sample, _
    type As SampleType _
) As Double
public:
double GetValue (
    Sample^ sample,
    SampleType type
)
Parameters
sample (Sample)
The sample instance of interest
type (SampleType)
The data type to be extracted from the sample
Return Value
A double value representing the requested data


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph ► SamplePointList ► Item[([Int32])]
Indexer: get the Sample instance at the specified ordinal position in the list
Declaration Syntax
C# Visual Basic Visual C++
public PointPair this[
    int index
]{ get;}
Public ReadOnly Default Property Item ( _
    index As Integer _
) As PointPair
public:
virtual property PointPair^ default[int index] {
    PointPair^ get (int index) sealed;
}
Parameters
index (Int32)
The ordinal position in the list of samples
Return Value
Returns a PointPair instance containing the data specified by XType and YType


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► SamplePointList ► ICloneable..::Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone


XType Field

XType Field
Namespaces ► ZedGraph ► SamplePointList ► XType
Determines what data type gets plotted for the X values
Declaration Syntax
C# Visual Basic Visual C++
public SampleType XType
Public XType As SampleType
public:
SampleType XType


YType Field

YType Field
Namespaces ► ZedGraph ► SamplePointList ► YType
Determines what data type gets plotted for the Y values
Declaration Syntax
C# Visual Basic Visual C++
public SampleType YType
Public YType As SampleType
public:
SampleType YType


SampleType Enumeration

SampleType Enumeration
Namespaces ► ZedGraph ► SampleType
enumeration used to indicate which type of data will be plotted.
Declaration Syntax
C# Visual Basic Visual C++
public enum SampleType
Public Enumeration SampleType
public enum class SampleType
Members
Member | Description
Time | Designates the "Time" property will be used
Position | Designates the "Position" property will be used
VelocityInst | Designates the Instantaneous Velocity property will be used
TimeDiff | Designates the "Time since start" property will be used
VelocityAvg | Designates the Average Velocity property will be used


Scale Class

Scale Class
Namespaces ► ZedGraph ► Scale
The Scale class is an abstract base class that encompasses the properties and methods associated with a scale of data.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class Scale : ISerializable
<SerializableAttribute> _
Public MustInherit Class Scale _
    Implements ISerializable
[SerializableAttribute]
public ref class Scale abstract : ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ScaleScaleNew(Axis) | Basic constructor -- requires that the Scale object be intialized with a pre-existing owner Axis.
 | ScaleScaleNew(Scale, Axis) | Copy Constructor. Create a new Scale object based on the specified existing one.
 | Align | Controls the alignment of the Axis tic labels.
 | AlignH | Controls the alignment of the Axis tic labels.
 | BaseTic | Gets or sets the scale value at which the first major tic label will appear.
 | CalcMaxLabels(Graphics, GraphPane, Single) | Calculate the maximum number of labels that will fit on this axis.
 | Clone(Axis) | Create a new clone of the current item, with a new owner assignment
 | DeLinearize(Double) | Convert a value from its linear equivalent to its actual scale value for this type of scale.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exponent | Gets or sets the scale exponent value. This only applies to Exponent.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontSpec | Gets a reference to the FontSpec class used to render the scale values
 | Format | The format of the Axis tic labels.
 | FormatAuto | Determines whether or not the scale label format Format is determined automatically based on the range of data values.
 | GetClusterWidth(GraphPane) | Determine the width, in pixel units, of each bar cluster including the cluster gaps and bar gaps.
 | GetClusterWidth(Double) | Calculates the cluster width, in pixels, by transforming the specified clusterScaleWidth.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAnyOrdinal | Gets a value that indicates if this Scale is of any of the ordinal types in the AxisType enumeration.
 | IsDate | True if this scale is Date, false otherwise.
 | IsExponent | True if this scale is Exponent, false otherwise.
 | IsLabelsInside | Gets or sets a value that causes the axis scale labels and title to appear on the opposite side of the axis.
 | IsLog | True if this scale is Log, false otherwise.
 | IsOrdinal | True if this scale is Ordinal, false otherwise.
 | IsPreventLabelOverlap | Gets or sets a Boolean value that determines if ZedGraph will check to see if the Axis scale labels are close enough to overlap. If so, ZedGraph will adjust the step size to prevent overlap.
 | IsReverse | Determines if the scale values are reversed for this Axis
 | IsSkipCrossLabel | Gets or sets a value that causes the scale label that is located at the Cross value for this Axis to be hidden.
 | IsSkipFirstLabel | Gets or sets a value that causes the first scale label for this Axis to be hidden.
 | IsSkipLastLabel | Gets or sets a value that causes the last scale label for this Axis to be hidden.
 | IsText | True if this scale is Text, false otherwise.
 | IsUseTenPower | Determines if powers-of-ten notation will be used for the numeric value labels.
 | IsVisible | Gets or sets a property that determines whether or not the scale values will be shown.
 | LabelGap | The gap between the scale labels and the tics.
 | Linearize(Double) | Convert a value to its linear equivalent for this type of scale.
 | LocalTransform(Double) | Transform the coordinate value from user coordinates (scale value) to graphics device coordinates (pixels).
 | Mag | The magnitude multiplier for scale values.
 | MagAuto | Determines whether the Mag value will be set automatically based on the data, or manually by the user.
 | MajorStep | Gets or sets the scale step size for this Scale (the increment between labeled axis values).
 | MajorStepAuto | Gets or sets a value that determines whether or not the scale step size MajorStep is set automatically.
 | MajorUnit | Gets or sets the type of units used for the major step size (MajorStep).
 | MakeNewScale(Scale, AxisType) | A construction method that creates a new Scale object using the properties of an existing Scale object, but specifying a new AxisType.
 | Max | Gets or sets the maximum scale value for this Scale.
 | MaxAuto | Gets or sets a value that determines whether or not the maximum scale value Max is set automatically.
 | MaxGrace | Gets or sets the "grace" value applied to the maximum data range.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Min | Gets or sets the minimum scale value for this Scale.
 | MinAuto | Gets or sets a value that determines whether or not the minimum scale value Min is set automatically.
 | MinGrace | Gets or sets the "grace" value applied to the minimum data range.
 | MinorStep | Gets or sets the scale minor step size for this Scale (the spacing between minor tics).
 | MinorStepAuto | Gets or sets a value that determines whether or not the minor scale step size MinorStep is set automatically.
 | MinorUnit | Gets or sets the type of units used for the minor step size (MinorStep).
 | PickScale(GraphPane, Graphics, Single) | Select a reasonable scale given a range of data values.
 | ReverseTransform(Single) | Reverse transform the user coordinates (scale value) given a graphics device coordinate (pixels).
 | SafeExp(Double, Double) | Calculate an exponential in a safe manner to avoid math exceptions
 | SafeLog(Double) | Calculate a base 10 logarithm in a safe manner to avoid math exceptions
 | schema | Current schema value that defines the version of the serialized file
 | SetupScaleData(GraphPane, Axis) | Setup some temporary transform values in preparation for rendering the Axis.
 | TextLabels | The text labels for this Axis.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Transform(Double) | Transform the coordinate value from user coordinates (scale value) to graphics device coordinates (pixels).
 | Transform(Boolean, Int32, Double) | Transform the coordinate value from user coordinates (scale value) to graphics device coordinates (pixels).
 | Type | Get an AxisType enumeration that indicates the type of this scale.
Remarks
This class is inherited by the LinearScale, LogScale, OrdinalScale, TextScale, DateScale, ExponentScale, DateAsOrdinalScale, and LinearAsOrdinalScale classes to define specific characteristics for those types.
Inheritance Hierarchy
Object
Scale


Scale Constructor

Scale Constructor
Namespaces ► ZedGraph ► Scale ► ScaleScaleNew()()
Members
Icon | Member | Description
 | ScaleScaleNew(Axis) | Basic constructor -- requires that the Scale object be intialized with a pre-existing owner Axis.
 | ScaleScaleNew(Scale, Axis) | Copy Constructor. Create a new Scale object based on the specified existing one.


Scale Constructor (ownerAxis)

Scale Constructor (ownerAxis)
Namespaces ► ZedGraph ► Scale ► ScaleScaleNew(Axis)
Basic constructor -- requires that the Scale object be intialized with a pre-existing owner Axis.
Declaration Syntax
C# Visual Basic Visual C++
public Scale(
    Axis ownerAxis
)
Public Sub New ( _
    ownerAxis As Axis _
)
public:
Scale (
    Axis^ ownerAxis
)
Parameters
ownerAxis (Axis)
The Axis object that is the owner of this Scale instance.


Scale Constructor (rhs, owner)

Scale Constructor (rhs, owner)
Namespaces ► ZedGraph ► Scale ► ScaleScaleNew(Scale, Axis)
Copy Constructor. Create a new Scale object based on the specified existing one.
Declaration Syntax
C# Visual Basic Visual C++
public Scale(
    Scale rhs,
    Axis owner
)
Public Sub New ( _
    rhs As Scale, _
    owner As Axis _
)
public:
Scale (
    Scale^ rhs,
    Axis^ owner
)
Parameters
rhs (Scale)
The Scale object to be copied.
owner (Axis)
The Axis object that will own the new instance of Scale


Align Property

Align Property
Namespaces ► ZedGraph ► Scale ► Align
Controls the alignment of the Axis tic labels.
Declaration Syntax
C# Visual Basic Visual C++
public AlignP Align{ get; set;}
Public Property Align As AlignP
public:
property AlignP Align {
    AlignP get ();
    void set (AlignP value);
}
Remarks
This property controls whether the inside, center, or outside edges of the text labels are aligned.


AlignH Property

AlignH Property
Namespaces ► ZedGraph ► Scale ► AlignH
Controls the alignment of the Axis tic labels.
Declaration Syntax
C# Visual Basic Visual C++
public AlignH AlignH{ get; set;}
Public Property AlignH As AlignH
public:
property AlignH AlignH {
    AlignH get ();
    void set (AlignH value);
}
Remarks
This property controls whether the left, center, or right edges of the text labels are aligned.


BaseTic Property

BaseTic Property
Namespaces ► ZedGraph ► Scale ► BaseTic
Gets or sets the scale value at which the first major tic label will appear.
Declaration Syntax
C# Visual Basic Visual C++
public double BaseTic{ get; set;}
Public Property BaseTic As Double
public:
property double BaseTic {
    double get ();
    void set (double value);
}
Value
The value is defined in user scale units
Remarks
This property allows the scale labels to start at an irregular value. For example, on a scale range with Min = 0, Max = 1000, and MajorStep = 200, a BaseTic value of 50 would cause the scale labels to appear at values 50, 250, 450, 650, and 850. Note that the default value for this property is Missing, which means the value is not used. Setting this property to any value other than Missing will activate the effect. The value specified must coincide with the first major tic. That is, if BaseTic were set to 650 in the example above, then the major tics would only occur at 650 and 850. This setting may affect the minor tics, since the minor tics are always referenced to the BaseTic. That is, in the example above, if the MinorStep were set to 30 (making it a non-multiple of the major step), then the minor tics would occur at 20, 50 (so it lines up with the BaseTic), 80, 110, 140, etc.
See Also
Min
Max
MajorStep
MinorStep
Cross


CalcMaxLabels Method (g, pane, scaleFactor)

CalcMaxLabels Method (g, pane, scaleFactor)
Namespaces ► ZedGraph ► Scale ► CalcMaxLabels(Graphics, GraphPane, Single)
Calculate the maximum number of labels that will fit on this axis.
Declaration Syntax
C# Visual Basic Visual C++
public int CalcMaxLabels(
    Graphics g,
    GraphPane pane,
    float scaleFactor
)
Public Function CalcMaxLabels ( _
    g As Graphics, _
    pane As GraphPane, _
    scaleFactor As Single _
) As Integer
public:
int CalcMaxLabels (
    Graphics^ g,
    GraphPane^ pane,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object associated with this Axis
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Remarks
This method works for both X and Y direction axes, and it works for angled text (assuming that a bounding box is an appropriate measure). Technically, labels at 45 degree angles could fit better than the return value of this method since the bounding boxes can overlap without the labels actually overlapping.


Clone Method (owner)

Clone Method (owner)
Namespaces ► ZedGraph ► Scale ► Clone(Axis)
Create a new clone of the current item, with a new owner assignment
Declaration Syntax
C# Visual Basic Visual C++
public abstract Scale Clone(
    Axis owner
)
Public MustOverride Function Clone ( _
    owner As Axis _
) As Scale
public:
virtual Scale^ Clone (
    Axis^ owner
) abstract
Parameters
owner (Axis)
The new Axis instance that will be the owner of the new Scale
Return Value
A new Scale clone.


DeLinearize Method (val)

DeLinearize Method (val)
Namespaces ► ZedGraph ► Scale ► DeLinearize(Double)
Convert a value from its linear equivalent to its actual scale value for this type of scale.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double DeLinearize(
    double val
)
Public Overridable Function DeLinearize ( _
    val As Double _
) As Double
public:
virtual double DeLinearize (
    double val
)
Parameters
val (Double)
The value to be converted
Remarks
The default behavior is to just return the value unchanged. However, for Log and Exponent, it returns the anti-log or inverse-power equivalent.


Exponent Property

Exponent Property
Namespaces ► ZedGraph ► Scale ► Exponent
Gets or sets the scale exponent value. This only applies to Exponent.
Declaration Syntax
C# Visual Basic Visual C++
public double Exponent{ get; set;}
Public Property Exponent As Double
public:
property double Exponent {
    double get ();
    void set (double value);
}
See Also
Min
Max
MinorStep
MajorStepAuto
TargetXSteps
TargetYSteps
ZeroLever
MaxTextLabels


FontSpec Property

FontSpec Property
Namespaces ► ZedGraph ► Scale ► FontSpec
Gets a reference to the FontSpec class used to render the scale values
Declaration Syntax
C# Visual Basic Visual C++
public FontSpec FontSpec{ get; set;}
Public Property FontSpec As FontSpec
public:
property FontSpec^ FontSpec {
    FontSpec^ get ();
    void set (FontSpec^ value);
}
See Also
FontFamily
FontSize
FontColor
FontBold
FontUnderline
FontItalic


Format Property

Format Property
Namespaces ► ZedGraph ► Scale ► Format
The format of the Axis tic labels.
Declaration Syntax
C# Visual Basic Visual C++
public string Format{ get; set;}
Public Property Format As String
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}
Value
The format string conforms to the DateTimeFormatInfo for date formats, and NumberFormatInfo for numeric formats.
Remarks
This property may be a date format or a numeric format, depending on the setting of Scale.Type. This property may be set automatically by ZedGraph, depending on the state of FormatAuto.
See Also
Mag
FormatAuto
FontSpec


FormatAuto Property

FormatAuto Property
Namespaces ► ZedGraph ► Scale ► FormatAuto
Determines whether or not the scale label format Format is determined automatically based on the range of data values.
Declaration Syntax
C# Visual Basic Visual C++
public bool FormatAuto{ get; set;}
Public Property FormatAuto As Boolean
public:
property bool FormatAuto {
    bool get ();
    void set (bool value);
}
Value
true if Format will be set automatically, false if it is to be set manually by the user
Remarks
This value will be set to false if Format is manually changed.
See Also
Mag
Format
FontSpec


GetClusterWidth Method

GetClusterWidth Method
Namespaces ► ZedGraph ► Scale ► GetClusterWidth()()
Members
Icon | Member | Description
 | GetClusterWidth(GraphPane) | Determine the width, in pixel units, of each bar cluster including the cluster gaps and bar gaps.
 | GetClusterWidth(Double) | Calculates the cluster width, in pixels, by transforming the specified clusterScaleWidth.


GetClusterWidth Method (clusterScaleWidth)

GetClusterWidth Method (clusterScaleWidth)
Namespaces ► ZedGraph ► Scale ► GetClusterWidth(Double)
Calculates the cluster width, in pixels, by transforming the specified clusterScaleWidth.
Declaration Syntax
C# Visual Basic Visual C++
public float GetClusterWidth(
    double clusterScaleWidth
)
Public Function GetClusterWidth ( _
    clusterScaleWidth As Double _
) As Single
public:
float GetClusterWidth (
    double clusterScaleWidth
)
Parameters
clusterScaleWidth (Double)
The width in user scale units of each bar cluster
Return Value
The equivalent pixel size of the bar cluster


GetClusterWidth Method (pane)

GetClusterWidth Method (pane)
Namespaces ► ZedGraph ► Scale ► GetClusterWidth(GraphPane)
Determine the width, in pixel units, of each bar cluster including the cluster gaps and bar gaps.
Declaration Syntax
C# Visual Basic Visual C++
public float GetClusterWidth(
    GraphPane pane
)
Public Function GetClusterWidth ( _
    pane As GraphPane _
) As Single
public:
float GetClusterWidth (
    GraphPane^ pane
)
Parameters
pane (GraphPane)
A reference to the GraphPane object associated with this Axis
Return Value
The width of each bar cluster, in pixel units
Remarks
This method uses the ClusterScaleWidth for non-ordinal axes, or a cluster width of 1.0 for ordinal axes.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► Scale ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data
Remarks
You MUST set the _ownerAxis property after deserializing a BarSettings object.


IsAnyOrdinal Property

IsAnyOrdinal Property
Namespaces ► ZedGraph ► Scale ► IsAnyOrdinal
Gets a value that indicates if this Scale is of any of the ordinal types in the AxisType enumeration.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAnyOrdinal{ get;}
Public ReadOnly Property IsAnyOrdinal As Boolean
public:
property bool IsAnyOrdinal {
    bool get ();
}
See Also
Type


IsDate Property

IsDate Property
Namespaces ► ZedGraph ► Scale ► IsDate
True if this scale is Date, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDate{ get;}
Public ReadOnly Property IsDate As Boolean
public:
property bool IsDate {
    bool get ();
}


IsExponent Property

IsExponent Property
Namespaces ► ZedGraph ► Scale ► IsExponent
True if this scale is Exponent, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsExponent{ get;}
Public ReadOnly Property IsExponent As Boolean
public:
property bool IsExponent {
    bool get ();
}


IsLabelsInside Property

IsLabelsInside Property
Namespaces ► ZedGraph ► Scale ► IsLabelsInside
Gets or sets a value that causes the axis scale labels and title to appear on the opposite side of the axis.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLabelsInside{ get; set;}
Public Property IsLabelsInside As Boolean
public:
property bool IsLabelsInside {
    bool get ();
    void set (bool value);
}
Remarks
For example, setting this flag to true for the YAxis will shift the axis labels and title to the right side of the YAxis instead of the normal left-side location. Set this property to true for the XAxis, and set the Cross property for the XAxis to an arbitrarily large value (assuming IsReverse is false for the YAxis) in order to have the XAxis appear at the top of the Rect.
See Also
IsReverse
Cross


IsLog Property

IsLog Property
Namespaces ► ZedGraph ► Scale ► IsLog
True if this scale is Log, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLog{ get;}
Public ReadOnly Property IsLog As Boolean
public:
property bool IsLog {
    bool get ();
}


IsOrdinal Property

IsOrdinal Property
Namespaces ► ZedGraph ► Scale ► IsOrdinal
True if this scale is Ordinal, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOrdinal{ get;}
Public ReadOnly Property IsOrdinal As Boolean
public:
property bool IsOrdinal {
    bool get ();
}
Remarks
Note that this is only true for an actual OrdinalScale class. This property will be false for other ordinal types such as Text, LinearAsOrdinal, or DateAsOrdinal. Use the IsAnyOrdinal as a "catchall" for all ordinal type axes.


IsPreventLabelOverlap Property

IsPreventLabelOverlap Property
Namespaces ► ZedGraph ► Scale ► IsPreventLabelOverlap
Gets or sets a Boolean value that determines if ZedGraph will check to see if the Axis scale labels are close enough to overlap. If so, ZedGraph will adjust the step size to prevent overlap.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPreventLabelOverlap{ get; set;}
Public Property IsPreventLabelOverlap As Boolean
public:
property bool IsPreventLabelOverlap {
    bool get ();
    void set (bool value);
}
Value
boolean value; true to check for overlap, false otherwise
Remarks
The process of checking for overlap is done during the AxisChange()() method call, and affects the selection of the major step size (MajorStep).


IsReverse Property

IsReverse Property
Namespaces ► ZedGraph ► Scale ► IsReverse
Determines if the scale values are reversed for this Axis
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReverse{ get; set;}
Public Property IsReverse As Boolean
public:
property bool IsReverse {
    bool get ();
    void set (bool value);
}
Value
true for the X values to decrease to the right or the Y values to decrease upwards, false otherwise
See Also
IsReverse


IsSkipCrossLabel Property

IsSkipCrossLabel Property
Namespaces ► ZedGraph ► Scale ► IsSkipCrossLabel
Gets or sets a value that causes the scale label that is located at the Cross value for this Axis to be hidden.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSkipCrossLabel{ get; set;}
Public Property IsSkipCrossLabel As Boolean
public:
property bool IsSkipCrossLabel {
    bool get ();
    void set (bool value);
}
Remarks
For axes that have an active Cross setting (e.g., CrossAuto is false), the scale label at the Cross value is overlapped by opposing axes. Use this property to hide the scale label to avoid the overlap.


IsSkipFirstLabel Property

IsSkipFirstLabel Property
Namespaces ► ZedGraph ► Scale ► IsSkipFirstLabel
Gets or sets a value that causes the first scale label for this Axis to be hidden.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSkipFirstLabel{ get; set;}
Public Property IsSkipFirstLabel As Boolean
public:
property bool IsSkipFirstLabel {
    bool get ();
    void set (bool value);
}
Remarks
Often, for axis that have an active Cross setting (e.g., CrossAuto is false), the first and/or last scale label are overlapped by opposing axes. Use this property to hide the first scale label to avoid the overlap. Note that setting this value to true will hide any scale label that appears within EdgeTolerance of the beginning of the Axis.


IsSkipLastLabel Property

IsSkipLastLabel Property
Namespaces ► ZedGraph ► Scale ► IsSkipLastLabel
Gets or sets a value that causes the last scale label for this Axis to be hidden.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSkipLastLabel{ get; set;}
Public Property IsSkipLastLabel As Boolean
public:
property bool IsSkipLastLabel {
    bool get ();
    void set (bool value);
}
Remarks
Often, for axis that have an active Cross setting (e.g., CrossAuto is false), the first and/or last scale label are overlapped by opposing axes. Use this property to hide the last scale label to avoid the overlap. Note that setting this value to true will hide any scale label that appears within EdgeTolerance of the end of the Axis.


IsText Property

IsText Property
Namespaces ► ZedGraph ► Scale ► IsText
True if this scale is Text, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsText{ get;}
Public ReadOnly Property IsText As Boolean
public:
property bool IsText {
    bool get ();
}


IsUseTenPower Property

IsUseTenPower Property
Namespaces ► ZedGraph ► Scale ► IsUseTenPower
Determines if powers-of-ten notation will be used for the numeric value labels.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUseTenPower{ get; set;}
Public Property IsUseTenPower As Boolean
public:
property bool IsUseTenPower {
    bool get ();
    void set (bool value);
}
Value
boolean value; true to show the title as a power of ten, false to show a regular numeric value (e.g., "0.01", "10", "1000")
Remarks
The powers-of-ten notation is just the text "10" followed by a superscripted value indicating the magnitude. This mode is only valid for log scales (see IsLog and Type).


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph ► Scale ► IsVisible
Gets or sets a property that determines whether or not the scale values will be shown.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
Value
true to show the scale values, false otherwise
See Also
IsVisible


LabelGap Property

LabelGap Property
Namespaces ► ZedGraph ► Scale ► LabelGap
The gap between the scale labels and the tics.
Declaration Syntax
C# Visual Basic Visual C++
public float LabelGap{ get; set;}
Public Property LabelGap As Single
public:
property float LabelGap {
    float get ();
    void set (float value);
}


Linearize Method (val)

Linearize Method (val)
Namespaces ► ZedGraph ► Scale ► Linearize(Double)
Convert a value to its linear equivalent for this type of scale.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Linearize(
    double val
)
Public Overridable Function Linearize ( _
    val As Double _
) As Double
public:
virtual double Linearize (
    double val
)
Parameters
val (Double)
The value to be converted
Remarks
The default behavior is to just return the value unchanged. However, for Log and Exponent, it returns the log or power equivalent.


LocalTransform Method (x)

LocalTransform Method (x)
Namespaces ► ZedGraph ► Scale ► LocalTransform(Double)
Transform the coordinate value from user coordinates (scale value) to graphics device coordinates (pixels).
Declaration Syntax
C# Visual Basic Visual C++
public float LocalTransform(
    double x
)
Public Function LocalTransform ( _
    x As Double _
) As Single
public:
float LocalTransform (
    double x
)
Parameters
x (Double)
The coordinate value, in linearized user scale units, to be transformed
Return Value
the coordinate value transformed to screen coordinates for use in calling the Draw(Graphics, GraphPane, Single, Single) method
Remarks
Assumes that the origin has been set to the "left" of this axis, facing from the label side. Note that the left side corresponds to the scale minimum for the X and Y2 axes, but it is the scale maximum for the Y axis. This method takes into account the scale range (Min and Max), logarithmic state (IsLog), scale reverse state (IsReverse) and axis type (XAxis, YAxis, or Y2Axis). Note that the Rect must be valid, and SetupScaleData(GraphPane, Axis) must be called for the current configuration before using this method.


Mag Property

Mag Property
Namespaces ► ZedGraph ► Scale ► Mag
The magnitude multiplier for scale values.
Declaration Syntax
C# Visual Basic Visual C++
public int Mag{ get; set;}
Public Property Mag As Integer
public:
property int Mag {
    int get ();
    void set (int value);
}
Value
The magnitude multiplier (power of 10) for the scale value labels
Remarks
This is used to limit the size of the displayed value labels. For example, if the value is really 2000000, then the graph will display 2000 with a 10^3 magnitude multiplier. This value can be determined automatically depending on the state of MagAuto. If this value is set manually by the user, then MagAuto will also be set to false.
See Also
IsOmitMag
Title
Format
FontSpec


MagAuto Property

MagAuto Property
Namespaces ► ZedGraph ► Scale ► MagAuto
Determines whether the Mag value will be set automatically based on the data, or manually by the user.
Declaration Syntax
C# Visual Basic Visual C++
public bool MagAuto{ get; set;}
Public Property MagAuto As Boolean
public:
property bool MagAuto {
    bool get ();
    void set (bool value);
}
Value
true to have Mag set automatically, false otherwise
Remarks
If the user manually sets the Mag value, then this flag will be set to false.
See Also
IsOmitMag
Title
Mag


MajorStep Property

MajorStep Property
Namespaces ► ZedGraph ► Scale ► MajorStep
Gets or sets the scale step size for this Scale (the increment between labeled axis values).
Declaration Syntax
C# Visual Basic Visual C++
public double MajorStep{ get; set;}
Public Property MajorStep As Double
public:
property double MajorStep {
    double get ();
    void set (double value);
}
Value
The value is defined in user scale units
Remarks
This value can be set automatically based on the state of MajorStepAuto. If this value is set manually, then MajorStepAuto will also be set to false. This value is ignored for Log axes. For Date axes, this value is defined in units of MajorUnit.
See Also
Min
Max
MinorStep
MajorStepAuto
TargetXSteps
TargetYSteps
ZeroLever
MaxTextLabels


MajorStepAuto Property

MajorStepAuto Property
Namespaces ► ZedGraph ► Scale ► MajorStepAuto
Gets or sets a value that determines whether or not the scale step size MajorStep is set automatically.
Declaration Syntax
C# Visual Basic Visual C++
public bool MajorStepAuto{ get; set;}
Public Property MajorStepAuto As Boolean
public:
property bool MajorStepAuto {
    bool get ();
    void set (bool value);
}
Value
true for automatic mode, false for manual mode
Remarks
This value will be set to false if MajorStep is manually changed.
See Also
MajorStep


MajorUnit Property

MajorUnit Property
Namespaces ► ZedGraph ► Scale ► MajorUnit
Gets or sets the type of units used for the major step size (MajorStep).
Declaration Syntax
C# Visual Basic Visual C++
public DateUnit MajorUnit{ get; set;}
Public Property MajorUnit As DateUnit
public:
property DateUnit MajorUnit {
    DateUnit get ();
    void set (DateUnit value);
}
Value
The value is a DateUnit enum type
Remarks
This unit type only applies to Date-Time axes (Date = true). The axis is set to date type with the Type property. The unit types are defined as DateUnit.
See Also
Min
Max
MajorStep
MinorStep
MajorStepAuto


MakeNewScale Method (oldScale, type)

MakeNewScale Method (oldScale, type)
Namespaces ► ZedGraph ► Scale ► MakeNewScale(Scale, AxisType)
A construction method that creates a new Scale object using the properties of an existing Scale object, but specifying a new AxisType.
Declaration Syntax
C# Visual Basic Visual C++
public Scale MakeNewScale(
    Scale oldScale,
    AxisType type
)
Public Function MakeNewScale ( _
    oldScale As Scale, _
    type As AxisType _
) As Scale
public:
Scale^ MakeNewScale (
    Scale^ oldScale,
    AxisType type
)
Parameters
oldScale (Scale)
The existing Scale object from which to copy the field data.
type (AxisType)
An AxisType representing the type of derived type of new Scale object to create.
Return Value
The new Scale object.
Remarks
This constructor is used to change the type of an existing Axis. By specifying the old Scale object, you are giving a set of properties (which encompasses all fields associated with the scale, since the derived types have no fields) to be used in creating a new Scale object, only this time having the newly specified object type.


Max Property

Max Property
Namespaces ► ZedGraph ► Scale ► Max
Gets or sets the maximum scale value for this Scale.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Max{ get; set;}
Public Overridable Property Max As Double
public:
virtual property double Max {
    double get ();
    void set (double value);
}
Value
The value is defined in user scale units for Log and Linear axes. For Text and Ordinal axes, this value is an ordinal starting with 1.0. For Date axes, this value is in XL Date format (see XDate, which is the number of days since the reference date of January 1, 1900.
Remarks
This value can be set automatically based on the state of MaxAuto. If this value is set manually, then MaxAuto will also be set to false.
See Also
Min
MajorStep
MinorStep
MaxAuto


MaxAuto Property

MaxAuto Property
Namespaces ► ZedGraph ► Scale ► MaxAuto
Gets or sets a value that determines whether or not the maximum scale value Max is set automatically.
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxAuto{ get; set;}
Public Property MaxAuto As Boolean
public:
property bool MaxAuto {
    bool get ();
    void set (bool value);
}
Value
true for automatic mode, false for manual mode
Remarks
This value will be set to false if Max is manually changed.
See Also
Max


MaxGrace Property

MaxGrace Property
Namespaces ► ZedGraph ► Scale ► MaxGrace
Gets or sets the "grace" value applied to the maximum data range.
Declaration Syntax
C# Visual Basic Visual C++
public double MaxGrace{ get; set;}
Public Property MaxGrace As Double
public:
property double MaxGrace {
    double get ();
    void set (double value);
}
Remarks
This values determines how much extra space is left after the last data value. This value is expressed as a fraction of the total data range. For example, assume the data range is from 4.0 to 16.0, leaving a range of 12.0. If MaxGrace is set to 0.1, then 10% of the range, or 1.2 will be added to the maximum data value. The scale will then be ranged to cover at least 4.0 to 17.2.
See Also
Max
MaxGrace
MinGrace


Min Property

Min Property
Namespaces ► ZedGraph ► Scale ► Min
Gets or sets the minimum scale value for this Scale.
Declaration Syntax
C# Visual Basic Visual C++
public virtual double Min{ get; set;}
Public Overridable Property Min As Double
public:
virtual property double Min {
    double get ();
    void set (double value);
}
Value
The value is defined in user scale units for Log and Linear axes. For Text and Ordinal axes, this value is an ordinal starting with 1.0. For Date axes, this value is in XL Date format (see XDate, which is the number of days since the reference date of January 1, 1900.
Remarks
This value can be set automatically based on the state of MinAuto. If this value is set manually, then MinAuto will also be set to false.
See Also
Max
MajorStep
MinorStep
MinAuto


MinAuto Property

MinAuto Property
Namespaces ► ZedGraph ► Scale ► MinAuto
Gets or sets a value that determines whether or not the minimum scale value Min is set automatically.
Declaration Syntax
C# Visual Basic Visual C++
public bool MinAuto{ get; set;}
Public Property MinAuto As Boolean
public:
property bool MinAuto {
    bool get ();
    void set (bool value);
}
Value
true for automatic mode, false for manual mode
Remarks
This value will be set to false if Min is manually changed.
See Also
Min


MinGrace Property

MinGrace Property
Namespaces ► ZedGraph ► Scale ► MinGrace
Gets or sets the "grace" value applied to the minimum data range.
Declaration Syntax
C# Visual Basic Visual C++
public double MinGrace{ get; set;}
Public Property MinGrace As Double
public:
property double MinGrace {
    double get ();
    void set (double value);
}
Remarks
This value is expressed as a fraction of the total data range. For example, assume the data range is from 4.0 to 16.0, leaving a range of 12.0. If MinGrace is set to 0.1, then 10% of the range, or 1.2 will be subtracted from the minimum data value. The scale will then be ranged to cover at least 2.8 to 16.0.
See Also
Min
MinGrace
MaxGrace


MinorStep Property

MinorStep Property
Namespaces ► ZedGraph ► Scale ► MinorStep
Gets or sets the scale minor step size for this Scale (the spacing between minor tics).
Declaration Syntax
C# Visual Basic Visual C++
public double MinorStep{ get; set;}
Public Property MinorStep As Double
public:
property double MinorStep {
    double get ();
    void set (double value);
}
Value
The value is defined in user scale units
Remarks
This value can be set automatically based on the state of MinorStepAuto. If this value is set manually, then MinorStepAuto will also be set to false. This value is ignored for Log and Text axes. For Date axes, this value is defined in units of MinorUnit.
See Also
Min
Max
MajorStep
MinorStepAuto


MinorStepAuto Property

MinorStepAuto Property
Namespaces ► ZedGraph ► Scale ► MinorStepAuto
Gets or sets a value that determines whether or not the minor scale step size MinorStep is set automatically.
Declaration Syntax
C# Visual Basic Visual C++
public bool MinorStepAuto{ get; set;}
Public Property MinorStepAuto As Boolean
public:
property bool MinorStepAuto {
    bool get ();
    void set (bool value);
}
Value
true for automatic mode, false for manual mode
Remarks
This value will be set to false if MinorStep is manually changed.
See Also
MinorStep


MinorUnit Property

MinorUnit Property
Namespaces ► ZedGraph ► Scale ► MinorUnit
Gets or sets the type of units used for the minor step size (MinorStep).
Declaration Syntax
C# Visual Basic Visual C++
public DateUnit MinorUnit{ get; set;}
Public Property MinorUnit As DateUnit
public:
property DateUnit MinorUnit {
    DateUnit get ();
    void set (DateUnit value);
}
Value
The value is a DateUnit enum type
Remarks
This unit type only applies to Date-Time axes (Date = true). The axis is set to date type with the Type property. The unit types are defined as DateUnit.
See Also
Min
Max
MajorStep
MinorStep
MinorStepAuto


PickScale Method (pane, g, scaleFactor)

PickScale Method (pane, g, scaleFactor)
Namespaces ► ZedGraph ► Scale ► PickScale(GraphPane, Graphics, Single)
Select a reasonable scale given a range of data values.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void PickScale(
    GraphPane pane,
    Graphics g,
    float scaleFactor
)
Public Overridable Sub PickScale ( _
    pane As GraphPane, _
    g As Graphics, _
    scaleFactor As Single _
)
public:
virtual void PickScale (
    GraphPane^ pane,
    Graphics^ g,
    float scaleFactor
)
Parameters
pane (GraphPane)
A reference to the GraphPane object associated with this Axis
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Remarks
The scale range is chosen based on increments of 1, 2, or 5 (because they are even divisors of 10). This routine honors the MinAuto, MaxAuto, and MajorStepAuto autorange settings as well as the IsLog setting. In the event that any of the autorange settings are false, the corresponding Min, Max, or MajorStep setting is explicitly honored, and the remaining autorange settings (if any) will be calculated to accomodate the non-autoranged values. The basic defaults for scale selection are defined using ZeroLever, TargetXSteps, and TargetYSteps from the Scale..::Default default class.

On Exit:

Min is set to scale minimum (if MinAuto = true)

Max is set to scale maximum (if MaxAuto = true)

MajorStep is set to scale step size (if MajorStepAuto = true)

MinorStep is set to scale minor step size (if MinorStepAuto = true)

Mag is set to a magnitude multiplier according to the data

Format is set to the display format for the values (this controls the number of decimal places, whether there are thousands separators, currency types, etc.)


ReverseTransform Method (pixVal)

ReverseTransform Method (pixVal)
Namespaces ► ZedGraph ► Scale ► ReverseTransform(Single)
Reverse transform the user coordinates (scale value) given a graphics device coordinate (pixels).
Declaration Syntax
C# Visual Basic Visual C++
public double ReverseTransform(
    float pixVal
)
Public Function ReverseTransform ( _
    pixVal As Single _
) As Double
public:
double ReverseTransform (
    float pixVal
)
Parameters
pixVal (Single)
The screen pixel value, in graphics device coordinates to be transformed
Return Value
The user scale value that corresponds to the screen pixel location
Remarks
This method takes into account the scale range (Min and Max), logarithmic state (IsLog), scale reverse state (IsReverse) and axis type (XAxis, YAxis, or Y2Axis). Note that the Rect must be valid, and SetupScaleData(GraphPane, Axis) must be called for the current configuration before using this method (this is called everytime the graph is drawn (i.e., Draw(Graphics) is called).


SafeExp Method (x, exponent)

SafeExp Method (x, exponent)
Namespaces ► ZedGraph ► Scale ► SafeExp(Double, Double)
Calculate an exponential in a safe manner to avoid math exceptions
Declaration Syntax
C# Visual Basic Visual C++
public static double SafeExp(
    double x,
    double exponent
)
Public Shared Function SafeExp ( _
    x As Double, _
    exponent As Double _
) As Double
public:
static double SafeExp (
    double x,
    double exponent
)
Parameters
x (Double)
The value for which the exponential is to be calculated
exponent (Double)
The exponent value to use for calculating the exponential.


SafeLog Method (x)

SafeLog Method (x)
Namespaces ► ZedGraph ► Scale ► SafeLog(Double)
Calculate a base 10 logarithm in a safe manner to avoid math exceptions
Declaration Syntax
C# Visual Basic Visual C++
public static double SafeLog(
    double x
)
Public Shared Function SafeLog ( _
    x As Double _
) As Double
public:
static double SafeLog (
    double x
)
Parameters
x (Double)
The value for which the logarithm is to be calculated
Return Value
The value of the logarithm, or 0 if the x argument was negative or zero


schema Field

schema Field
Namespaces ► ZedGraph ► Scale ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


SetupScaleData Method (pane, axis)

SetupScaleData Method (pane, axis)
Namespaces ► ZedGraph ► Scale ► SetupScaleData(GraphPane, Axis)
Setup some temporary transform values in preparation for rendering the Axis.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void SetupScaleData(
    GraphPane pane,
    Axis axis
)
Public Overridable Sub SetupScaleData ( _
    pane As GraphPane, _
    axis As Axis _
)
public:
virtual void SetupScaleData (
    GraphPane^ pane,
    Axis^ axis
)
Parameters
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
axis (Axis)
The parent Axis for this Scale
Remarks
This method is typically called by the parent GraphPane object as part of the Draw(Graphics) method. It is also called by GeneralTransform(Double, Double, CoordType) and ReverseTransform(PointF, Double%, Double%) methods to setup for coordinate transformations.


TextLabels Property

TextLabels Property
Namespaces ► ZedGraph ► Scale ► TextLabels
The text labels for this Axis.
Declaration Syntax
C# Visual Basic Visual C++
public string[] TextLabels{ get; set;}
Public Property TextLabels As String()
public:
property array<String^>^ TextLabels {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
Remarks
This property is only applicable if Type is set to Text.


Transform Method

Transform Method
Namespaces ► ZedGraph ► Scale ► Transform()()
Members
Icon | Member | Description
 | Transform(Double) | Transform the coordinate value from user coordinates (scale value) to graphics device coordinates (pixels).
 | Transform(Boolean, Int32, Double) | Transform the coordinate value from user coordinates (scale value) to graphics device coordinates (pixels).


Transform Method (isOverrideOrdinal, i, x)

Transform Method (isOverrideOrdinal, i, x)
Namespaces ► ZedGraph ► Scale ► Transform(Boolean, Int32, Double)
Transform the coordinate value from user coordinates (scale value) to graphics device coordinates (pixels).
Declaration Syntax
C# Visual Basic Visual C++
public float Transform(
    bool isOverrideOrdinal,
    int i,
    double x
)
Public Function Transform ( _
    isOverrideOrdinal As Boolean, _
    i As Integer, _
    x As Double _
) As Single
public:
float Transform (
    bool isOverrideOrdinal,
    int i,
    double x
)
Parameters
isOverrideOrdinal (Boolean)
true to force the axis to honor the data value, rather than replacing it with the ordinal value
i (Int32)
The ordinal value of this point, just in case this is an Ordinal axis
x (Double)
The coordinate value, in user scale units, to be transformed
Return Value
the coordinate value transformed to screen coordinates for use in calling the Graphics draw routines
Remarks
This method takes into account the scale range (Min and Max), logarithmic state (IsLog), scale reverse state (IsReverse) and axis type (XAxis, YAxis, or Y2Axis). Note that the Rect must be valid, and SetupScaleData(GraphPane, Axis) must be called for the current configuration before using this method (this is called everytime the graph is drawn (i.e., Draw(Graphics) is called).


Transform Method (x)

Transform Method (x)
Namespaces ► ZedGraph ► Scale ► Transform(Double)
Transform the coordinate value from user coordinates (scale value) to graphics device coordinates (pixels).
Declaration Syntax
C# Visual Basic Visual C++
public float Transform(
    double x
)
Public Function Transform ( _
    x As Double _
) As Single
public:
float Transform (
    double x
)
Parameters
x (Double)
The coordinate value, in user scale units, to be transformed
Return Value
the coordinate value transformed to screen coordinates for use in calling the Graphics draw routines
Remarks
This method takes into account the scale range (Min and Max), logarithmic state (IsLog), scale reverse state (IsReverse) and axis type (XAxis, YAxis, or Y2Axis). Note that the Rect must be valid, and SetupScaleData(GraphPane, Axis) must be called for the current configuration before using this method (this is called everytime the graph is drawn (i.e., Draw(Graphics) is called).


Type Property

Type Property
Namespaces ► ZedGraph ► Scale ► Type
Get an AxisType enumeration that indicates the type of this scale.
Declaration Syntax
C# Visual Basic Visual C++
public abstract AxisType Type{ get;}
Public MustOverride ReadOnly Property Type As AxisType
public:
virtual property AxisType Type {
    AxisType get () abstract;
}


Scale.Default Structure

Scale..::Default Structure
Namespaces ► ZedGraph ► Scale ► Scale..::Default
A simple struct that defines the default property values for the Scale class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Align | The default alignment of the Axis tic labels. This value controls whether the inside, center, or outside edges of the text labels are aligned.
 | AlignH | The default alignment of the Axis tic labels. This value controls whether the left, center, or right edges of the text labels are aligned.
 | EdgeTolerance | Determines the size of the band at the beginning and end of the axis that will have labels omitted if the axis is shifted due to a non-default location using the Cross property.
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | FillBrush | The default custom brush for filling in the scale text background (see Brush property).
 | FillColor | The default color for filling in the scale text background (see Color property).
 | FillType | The default fill mode for filling in the scale text background (see Type property).
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontBold | The default font bold mode for the Axis scale values font specification FontSpec (IsBold property). true for a bold typeface, false otherwise.
 | FontColor | The default font color for the Axis scale values font specification FontSpec (FontColor property).
 | FontFamily | The default font family for the Axis scale values font specification FontSpec (Family property).
 | FontItalic | The default font italic mode for the Axis scale values font specification FontSpec (IsItalic property). true for an italic typeface, false otherwise.
 | FontSize | The default font size for the Axis scale values font specification FontSpec (Size property). Units are in points (1/72 inch).
 | FontUnderline | The default font underline mode for the Axis scale values font specification FontSpec (IsUnderline property). true for an underlined typeface, false otherwise.
 | Format | The default setting for the Axis scale format string (Format property). For numeric values, this value is setting according to the Format(String, Object) format strings. For date type values, this value is set as per the ToString()() function.
 | FormatDayDay | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Day for MajorUnit and Day for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | FormatDayHour | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Day for MajorUnit and Hour for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | FormatHourHour | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Hour for MajorUnit and Hour for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | FormatHourMinute | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Hour for MajorUnit and Minute for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | FormatMillisecond | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Millisecond for MajorUnit and Millisecond for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | FormatMinuteMinute | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Minute for MajorUnit and Minute for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | FormatMinuteSecond | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Minute for MajorUnit and Second for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | FormatMonthMonth | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Month for MajorUnit and Month for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | FormatSecondSecond | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Second for MajorUnit and Second for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | FormatYearMonth | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Year for MajorUnit and Month for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | FormatYearYear | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Year for MajorUnit and Year for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsLabelsInside | The default value for IsLabelsInside, which determines whether or not the scale labels and title for the Axis will appear on the opposite side of the Axis that it normally appears.
 | IsReverse | The default reverse mode for the Axis scale (IsReverse property). true for a reversed scale (X decreasing to the left, Y/Y2 decreasing upwards), false otherwise.
 | IsVisible | The default value for IsVisible, which determines whether or not the scale values are displayed.
 | LabelGap | The default setting for the gap between the outside tics (or the axis edge if there are no outside tics) and the scale labels, expressed as a fraction of the major tic size.
 | MaxGrace | The default "grace" value applied to the maximum data range. This value is expressed as a fraction of the total data range. For example, assume the data range is from 4.0 to 16.0, leaving a range of 12.0. If MaxGrace is set to 0.1, then 10% of the range, or 1.2 will be added to the maximum data value. The scale will then be ranged to cover at least 4.0 to 17.2.
 | MaxTextLabels | The maximum number of text labels (major tics) that will be allowed on the plot by the automatic scaling logic. This value applies only to Text axes. If there are more than MaxTextLabels on the plot, then MajorStep will be increased to reduce the number of labels. That is, the step size might be increased to 2.0 to show only every other label.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinGrace | The default "grace" value applied to the minimum data range. This value is expressed as a fraction of the total data range. For example, assume the data range is from 4.0 to 16.0, leaving a range of 12.0. If MinGrace is set to 0.1, then 10% of the range, or 1.2 will be subtracted from the minimum data value. The scale will then be ranged to cover at least 2.8 to 16.0.
 | RangeDayDay | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Day and MinorUnit = Day. This value normally defaults to 10 days. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | RangeDayHour | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Day and MinorUnit = Hour. This value normally defaults to 3 days. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | RangeHourHour | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Hour and MinorUnit = Hour. This value normally defaults to 0.4167 days (10 hours). This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | RangeHourMinute | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Hour and MinorUnit = Minute. This value normally defaults to 0.125 days (3 hours). This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | RangeMinuteMinute | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Minute and MinorUnit = Minute. This value normally defaults to 6.94e-3 days (10 minutes). This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | RangeMinuteSecond | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Minute and MinorUnit = Second. This value normally defaults to 2.083e-3 days (3 minutes). This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | RangeMonthMonth | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Month and MinorUnit = Month. This value normally defaults to 90 days (3 months). This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | RangeSecondSecond | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Second and MinorUnit = Second. This value normally defaults to 3.472e-5 days (3 seconds). This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | RangeYearMonth | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Year and MinorUnit = Month. This value normally defaults to 365 days (1 year). This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | RangeYearYear | A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Year and MinorUnit = Year. This value normally defaults to 1825 days (5 years). This value is used by the CalcDateStepSize(Double, Double, Scale) method.
 | TargetMinorXSteps | The default target number of minor steps for automatically selecting the X axis scale minor step size (see PickScale(GraphPane, Graphics, Single)). This number is an initial target value for the number of minor steps on an axis. This value is maintained only in the Scale..::Default class, and cannot be changed after compilation.
 | TargetMinorYSteps | The default target number of minor steps for automatically selecting the Y or Y2 axis scale minor step size (see PickScale(GraphPane, Graphics, Single)). This number is an initial target value for the number of minor steps on an axis. This value is maintained only in the Scale..::Default class, and cannot be changed after compilation.
 | TargetXSteps | The default target number of steps for automatically selecting the X axis scale step size (see PickScale(GraphPane, Graphics, Single)). This number is an initial target value for the number of major steps on an axis. This value is maintained only in the Scale..::Default class, and cannot be changed after compilation.
 | TargetYSteps | The default target number of steps for automatically selecting the Y or Y2 axis scale step size (see PickScale(GraphPane, Graphics, Single)). This number is an initial target value for the number of major steps on an axis. This value is maintained only in the Scale..::Default class, and cannot be changed after compilation.
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | ZeroLever | The default "zero lever" for automatically selecting the axis scale range (see PickScale(GraphPane, Graphics, Single)). This number is used to determine when an axis scale range should be extended to include the zero value. This value is maintained only in the Scale..::Default class, and cannot be changed after compilation.


Align Field

Align Field
Namespaces ► ZedGraph ► Scale..::Default ► Align
The default alignment of the Axis tic labels. This value controls whether the inside, center, or outside edges of the text labels are aligned.
Declaration Syntax
C# Visual Basic Visual C++
public static AlignP Align
Public Shared Align As AlignP
public:
static AlignP Align
See Also
AlignP


AlignH Field

AlignH Field
Namespaces ► ZedGraph ► Scale..::Default ► AlignH
The default alignment of the Axis tic labels. This value controls whether the left, center, or right edges of the text labels are aligned.
Declaration Syntax
C# Visual Basic Visual C++
public static AlignH AlignH
Public Shared AlignH As AlignH
public:
static AlignH AlignH
See Also
AlignH


EdgeTolerance Field

EdgeTolerance Field
Namespaces ► ZedGraph ► Scale..::Default ► EdgeTolerance
Determines the size of the band at the beginning and end of the axis that will have labels omitted if the axis is shifted due to a non-default location using the Cross property.
Declaration Syntax
C# Visual Basic Visual C++
public static float EdgeTolerance
Public Shared EdgeTolerance As Single
public:
static float EdgeTolerance
Remarks
This parameter applies only when CrossAuto is false. It is scaled according to the size of the graph based on BaseDimension. When a non-default axis location is selected, the first and last labels on that axis will overlap the opposing axis frame. This parameter allows those labels to be omitted to avoid the overlap. Set this parameter to zero to turn off the effect.


FillBrush Field

FillBrush Field
Namespaces ► ZedGraph ► Scale..::Default ► FillBrush
The default custom brush for filling in the scale text background (see Brush property).
Declaration Syntax
C# Visual Basic Visual C++
public static Brush FillBrush
Public Shared FillBrush As Brush
public:
static Brush^ FillBrush


FillColor Field

FillColor Field
Namespaces ► ZedGraph ► Scale..::Default ► FillColor
The default color for filling in the scale text background (see Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color FillColor
Public Shared FillColor As Color
public:
static Color FillColor


FillType Field

FillType Field
Namespaces ► ZedGraph ► Scale..::Default ► FillType
The default fill mode for filling in the scale text background (see Type property).
Declaration Syntax
C# Visual Basic Visual C++
public static FillType FillType
Public Shared FillType As FillType
public:
static FillType FillType


FontBold Field

FontBold Field
Namespaces ► ZedGraph ► Scale..::Default ► FontBold
The default font bold mode for the Axis scale values font specification FontSpec (IsBold property). true for a bold typeface, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool FontBold
Public Shared FontBold As Boolean
public:
static bool FontBold


FontColor Field

FontColor Field
Namespaces ► ZedGraph ► Scale..::Default ► FontColor
The default font color for the Axis scale values font specification FontSpec (FontColor property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color FontColor
Public Shared FontColor As Color
public:
static Color FontColor


FontFamily Field

FontFamily Field
Namespaces ► ZedGraph ► Scale..::Default ► FontFamily
The default font family for the Axis scale values font specification FontSpec (Family property).
Declaration Syntax
C# Visual Basic Visual C++
public static string FontFamily
Public Shared FontFamily As String
public:
static String^ FontFamily


FontItalic Field

FontItalic Field
Namespaces ► ZedGraph ► Scale..::Default ► FontItalic
The default font italic mode for the Axis scale values font specification FontSpec (IsItalic property). true for an italic typeface, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool FontItalic
Public Shared FontItalic As Boolean
public:
static bool FontItalic


FontSize Field

FontSize Field
Namespaces ► ZedGraph ► Scale..::Default ► FontSize
The default font size for the Axis scale values font specification FontSpec (Size property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float FontSize
Public Shared FontSize As Single
public:
static float FontSize


FontUnderline Field

FontUnderline Field
Namespaces ► ZedGraph ► Scale..::Default ► FontUnderline
The default font underline mode for the Axis scale values font specification FontSpec (IsUnderline property). true for an underlined typeface, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool FontUnderline
Public Shared FontUnderline As Boolean
public:
static bool FontUnderline


Format Field

Format Field
Namespaces ► ZedGraph ► Scale..::Default ► Format
The default setting for the Axis scale format string (Format property). For numeric values, this value is setting according to the Format(String, Object) format strings. For date type values, this value is set as per the ToString()() function.
Declaration Syntax
C# Visual Basic Visual C++
public static string Format
Public Shared Format As String
public:
static String^ Format


FormatDayDay Field

FormatDayDay Field
Namespaces ► ZedGraph ► Scale..::Default ► FormatDayDay
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Day for MajorUnit and Day for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatDayDay
Public Shared FormatDayDay As String
public:
static String^ FormatDayDay
See Also
DateTimeFormatInfo


FormatDayHour Field

FormatDayHour Field
Namespaces ► ZedGraph ► Scale..::Default ► FormatDayHour
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Day for MajorUnit and Hour for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatDayHour
Public Shared FormatDayHour As String
public:
static String^ FormatDayHour
See Also
DateTimeFormatInfo


FormatHourHour Field

FormatHourHour Field
Namespaces ► ZedGraph ► Scale..::Default ► FormatHourHour
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Hour for MajorUnit and Hour for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatHourHour
Public Shared FormatHourHour As String
public:
static String^ FormatHourHour
See Also
DateTimeFormatInfo


FormatHourMinute Field

FormatHourMinute Field
Namespaces ► ZedGraph ► Scale..::Default ► FormatHourMinute
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Hour for MajorUnit and Minute for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatHourMinute
Public Shared FormatHourMinute As String
public:
static String^ FormatHourMinute
See Also
DateTimeFormatInfo


FormatMillisecond Field

FormatMillisecond Field
Namespaces ► ZedGraph ► Scale..::Default ► FormatMillisecond
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Millisecond for MajorUnit and Millisecond for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatMillisecond
Public Shared FormatMillisecond As String
public:
static String^ FormatMillisecond
See Also
DateTimeFormatInfo


FormatMinuteMinute Field

FormatMinuteMinute Field
Namespaces ► ZedGraph ► Scale..::Default ► FormatMinuteMinute
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Minute for MajorUnit and Minute for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatMinuteMinute
Public Shared FormatMinuteMinute As String
public:
static String^ FormatMinuteMinute
See Also
DateTimeFormatInfo


FormatMinuteSecond Field

FormatMinuteSecond Field
Namespaces ► ZedGraph ► Scale..::Default ► FormatMinuteSecond
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Minute for MajorUnit and Second for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatMinuteSecond
Public Shared FormatMinuteSecond As String
public:
static String^ FormatMinuteSecond
See Also
DateTimeFormatInfo


FormatMonthMonth Field

FormatMonthMonth Field
Namespaces ► ZedGraph ► Scale..::Default ► FormatMonthMonth
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Month for MajorUnit and Month for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatMonthMonth
Public Shared FormatMonthMonth As String
public:
static String^ FormatMonthMonth
See Also
DateTimeFormatInfo


FormatSecondSecond Field

FormatSecondSecond Field
Namespaces ► ZedGraph ► Scale..::Default ► FormatSecondSecond
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Second for MajorUnit and Second for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatSecondSecond
Public Shared FormatSecondSecond As String
public:
static String^ FormatSecondSecond
See Also
DateTimeFormatInfo


FormatYearMonth Field

FormatYearMonth Field
Namespaces ► ZedGraph ► Scale..::Default ► FormatYearMonth
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Year for MajorUnit and Month for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatYearMonth
Public Shared FormatYearMonth As String
public:
static String^ FormatYearMonth
See Also
DateTimeFormatInfo


FormatYearYear Field

FormatYearYear Field
Namespaces ► ZedGraph ► Scale..::Default ► FormatYearYear
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. This is the format used for the scale values when auto-ranging code selects a Format of Year for MajorUnit and Year for for MinorUnit. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static string FormatYearYear
Public Shared FormatYearYear As String
public:
static String^ FormatYearYear
See Also
DateTimeFormatInfo


IsLabelsInside Field

IsLabelsInside Field
Namespaces ► ZedGraph ► Scale..::Default ► IsLabelsInside
The default value for IsLabelsInside, which determines whether or not the scale labels and title for the Axis will appear on the opposite side of the Axis that it normally appears.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsLabelsInside
Public Shared IsLabelsInside As Boolean
public:
static bool IsLabelsInside


IsReverse Field

IsReverse Field
Namespaces ► ZedGraph ► Scale..::Default ► IsReverse
The default reverse mode for the Axis scale (IsReverse property). true for a reversed scale (X decreasing to the left, Y/Y2 decreasing upwards), false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsReverse
Public Shared IsReverse As Boolean
public:
static bool IsReverse


IsVisible Field

IsVisible Field
Namespaces ► ZedGraph ► Scale..::Default ► IsVisible
The default value for IsVisible, which determines whether or not the scale values are displayed.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsVisible
Public Shared IsVisible As Boolean
public:
static bool IsVisible


LabelGap Field

LabelGap Field
Namespaces ► ZedGraph ► Scale..::Default ► LabelGap
The default setting for the gap between the outside tics (or the axis edge if there are no outside tics) and the scale labels, expressed as a fraction of the major tic size.
Declaration Syntax
C# Visual Basic Visual C++
public static float LabelGap
Public Shared LabelGap As Single
public:
static float LabelGap


MaxGrace Field

MaxGrace Field
Namespaces ► ZedGraph ► Scale..::Default ► MaxGrace
The default "grace" value applied to the maximum data range. This value is expressed as a fraction of the total data range. For example, assume the data range is from 4.0 to 16.0, leaving a range of 12.0. If MaxGrace is set to 0.1, then 10% of the range, or 1.2 will be added to the maximum data value. The scale will then be ranged to cover at least 4.0 to 17.2.
Declaration Syntax
C# Visual Basic Visual C++
public static double MaxGrace
Public Shared MaxGrace As Double
public:
static double MaxGrace
See Also
MinGrace
MaxGrace


MaxTextLabels Field

MaxTextLabels Field
Namespaces ► ZedGraph ► Scale..::Default ► MaxTextLabels
The maximum number of text labels (major tics) that will be allowed on the plot by the automatic scaling logic. This value applies only to Text axes. If there are more than MaxTextLabels on the plot, then MajorStep will be increased to reduce the number of labels. That is, the step size might be increased to 2.0 to show only every other label.
Declaration Syntax
C# Visual Basic Visual C++
public static double MaxTextLabels
Public Shared MaxTextLabels As Double
public:
static double MaxTextLabels


MinGrace Field

MinGrace Field
Namespaces ► ZedGraph ► Scale..::Default ► MinGrace
The default "grace" value applied to the minimum data range. This value is expressed as a fraction of the total data range. For example, assume the data range is from 4.0 to 16.0, leaving a range of 12.0. If MinGrace is set to 0.1, then 10% of the range, or 1.2 will be subtracted from the minimum data value. The scale will then be ranged to cover at least 2.8 to 16.0.
Declaration Syntax
C# Visual Basic Visual C++
public static double MinGrace
Public Shared MinGrace As Double
public:
static double MinGrace
See Also
MinGrace


RangeDayDay Field

RangeDayDay Field
Namespaces ► ZedGraph ► Scale..::Default ► RangeDayDay
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Day and MinorUnit = Day. This value normally defaults to 10 days. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static double RangeDayDay
Public Shared RangeDayDay As Double
public:
static double RangeDayDay


RangeDayHour Field

RangeDayHour Field
Namespaces ► ZedGraph ► Scale..::Default ► RangeDayHour
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Day and MinorUnit = Hour. This value normally defaults to 3 days. This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static double RangeDayHour
Public Shared RangeDayHour As Double
public:
static double RangeDayHour


RangeHourHour Field

RangeHourHour Field
Namespaces ► ZedGraph ► Scale..::Default ► RangeHourHour
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Hour and MinorUnit = Hour. This value normally defaults to 0.4167 days (10 hours). This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static double RangeHourHour
Public Shared RangeHourHour As Double
public:
static double RangeHourHour


RangeHourMinute Field

RangeHourMinute Field
Namespaces ► ZedGraph ► Scale..::Default ► RangeHourMinute
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Hour and MinorUnit = Minute. This value normally defaults to 0.125 days (3 hours). This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static double RangeHourMinute
Public Shared RangeHourMinute As Double
public:
static double RangeHourMinute


RangeMinuteMinute Field

RangeMinuteMinute Field
Namespaces ► ZedGraph ► Scale..::Default ► RangeMinuteMinute
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Minute and MinorUnit = Minute. This value normally defaults to 6.94e-3 days (10 minutes). This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static double RangeMinuteMinute
Public Shared RangeMinuteMinute As Double
public:
static double RangeMinuteMinute


RangeMinuteSecond Field

RangeMinuteSecond Field
Namespaces ► ZedGraph ► Scale..::Default ► RangeMinuteSecond
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Minute and MinorUnit = Second. This value normally defaults to 2.083e-3 days (3 minutes). This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static double RangeMinuteSecond
Public Shared RangeMinuteSecond As Double
public:
static double RangeMinuteSecond


RangeMonthMonth Field

RangeMonthMonth Field
Namespaces ► ZedGraph ► Scale..::Default ► RangeMonthMonth
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Month and MinorUnit = Month. This value normally defaults to 90 days (3 months). This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static double RangeMonthMonth
Public Shared RangeMonthMonth As Double
public:
static double RangeMonthMonth


RangeSecondSecond Field

RangeSecondSecond Field
Namespaces ► ZedGraph ► Scale..::Default ► RangeSecondSecond
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Second and MinorUnit = Second. This value normally defaults to 3.472e-5 days (3 seconds). This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static double RangeSecondSecond
Public Shared RangeSecondSecond As Double
public:
static double RangeSecondSecond


RangeYearMonth Field

RangeYearMonth Field
Namespaces ► ZedGraph ► Scale..::Default ► RangeYearMonth
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Year and MinorUnit = Month. This value normally defaults to 365 days (1 year). This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static double RangeYearMonth
Public Shared RangeYearMonth As Double
public:
static double RangeYearMonth


RangeYearYear Field

RangeYearYear Field
Namespaces ► ZedGraph ► Scale..::Default ► RangeYearYear
A default setting for the Date auto-ranging code. This values applies only to Date-Time type axes. If the total span of data exceeds this number (in days), then the auto-range code will select MajorUnit = Year and MinorUnit = Year. This value normally defaults to 1825 days (5 years). This value is used by the CalcDateStepSize(Double, Double, Scale) method.
Declaration Syntax
C# Visual Basic Visual C++
public static double RangeYearYear
Public Shared RangeYearYear As Double
public:
static double RangeYearYear


TargetMinorXSteps Field

TargetMinorXSteps Field
Namespaces ► ZedGraph ► Scale..::Default ► TargetMinorXSteps
The default target number of minor steps for automatically selecting the X axis scale minor step size (see PickScale(GraphPane, Graphics, Single)). This number is an initial target value for the number of minor steps on an axis. This value is maintained only in the Scale..::Default class, and cannot be changed after compilation.
Declaration Syntax
C# Visual Basic Visual C++
public static double TargetMinorXSteps
Public Shared TargetMinorXSteps As Double
public:
static double TargetMinorXSteps


TargetMinorYSteps Field

TargetMinorYSteps Field
Namespaces ► ZedGraph ► Scale..::Default ► TargetMinorYSteps
The default target number of minor steps for automatically selecting the Y or Y2 axis scale minor step size (see PickScale(GraphPane, Graphics, Single)). This number is an initial target value for the number of minor steps on an axis. This value is maintained only in the Scale..::Default class, and cannot be changed after compilation.
Declaration Syntax
C# Visual Basic Visual C++
public static double TargetMinorYSteps
Public Shared TargetMinorYSteps As Double
public:
static double TargetMinorYSteps


TargetXSteps Field

TargetXSteps Field
Namespaces ► ZedGraph ► Scale..::Default ► TargetXSteps
The default target number of steps for automatically selecting the X axis scale step size (see PickScale(GraphPane, Graphics, Single)). This number is an initial target value for the number of major steps on an axis. This value is maintained only in the Scale..::Default class, and cannot be changed after compilation.
Declaration Syntax
C# Visual Basic Visual C++
public static double TargetXSteps
Public Shared TargetXSteps As Double
public:
static double TargetXSteps


TargetYSteps Field

TargetYSteps Field
Namespaces ► ZedGraph ► Scale..::Default ► TargetYSteps
The default target number of steps for automatically selecting the Y or Y2 axis scale step size (see PickScale(GraphPane, Graphics, Single)). This number is an initial target value for the number of major steps on an axis. This value is maintained only in the Scale..::Default class, and cannot be changed after compilation.
Declaration Syntax
C# Visual Basic Visual C++
public static double TargetYSteps
Public Shared TargetYSteps As Double
public:
static double TargetYSteps


ZeroLever Field

ZeroLever Field
Namespaces ► ZedGraph ► Scale..::Default ► ZeroLever
The default "zero lever" for automatically selecting the axis scale range (see PickScale(GraphPane, Graphics, Single)). This number is used to determine when an axis scale range should be extended to include the zero value. This value is maintained only in the Scale..::Default class, and cannot be changed after compilation.
Declaration Syntax
C# Visual Basic Visual C++
public static double ZeroLever
Public Shared ZeroLever As Double
public:
static double ZeroLever


ScaleState Class

ScaleState Class
Namespaces ► ZedGraph ► ScaleState
A class that captures an Axis scale range.
Declaration Syntax
C# Visual Basic Visual C++
public class ScaleState : ICloneable
Public Class ScaleState _
    Implements ICloneable
public ref class ScaleState : ICloneable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ScaleStateScaleStateNew(Axis) | Construct a ScaleState from the specified Axis
 | ScaleStateScaleStateNew(ScaleState) | The Copy Constructor
 | ApplyScale(Axis) | Copy the properties from this ScaleState out to the specified Axis.
 | Clone()() | Typesafe, deep-copy clone method.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsChanged(Axis) | Determine if the state contained in this ScaleState object is different from the state of the specified Axis.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
This structure is used by the ZoomState class to store Axis scale range settings in a collection for later retrieval. The class stores the Min, Max, MinorStep, and MajorStep properties, along with the corresponding auto-scale settings: MinAuto, MaxAuto, MinorStepAuto, and MajorStepAuto.
Inheritance Hierarchy
Object
ScaleState


ScaleState Constructor

ScaleState Constructor
Namespaces ► ZedGraph ► ScaleState ► ScaleStateScaleStateNew()()
Members
Icon | Member | Description
 | ScaleStateScaleStateNew(Axis) | Construct a ScaleState from the specified Axis
 | ScaleStateScaleStateNew(ScaleState) | The Copy Constructor


ScaleState Constructor (axis)

ScaleState Constructor (axis)
Namespaces ► ZedGraph ► ScaleState ► ScaleStateScaleStateNew(Axis)
Construct a ScaleState from the specified Axis
Declaration Syntax
C# Visual Basic Visual C++
public ScaleState(
    Axis axis
)
Public Sub New ( _
    axis As Axis _
)
public:
ScaleState (
    Axis^ axis
)
Parameters
axis (Axis)
The Axis from which to collect the scale range settings.


ScaleState Constructor (rhs)

ScaleState Constructor (rhs)
Namespaces ► ZedGraph ► ScaleState ► ScaleStateScaleStateNew(ScaleState)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ScaleState(
    ScaleState rhs
)
Public Sub New ( _
    rhs As ScaleState _
)
public:
ScaleState (
    ScaleState^ rhs
)
Parameters
rhs (ScaleState)
The ScaleState object from which to copy


ApplyScale Method (axis)

ApplyScale Method (axis)
Namespaces ► ZedGraph ► ScaleState ► ApplyScale(Axis)
Copy the properties from this ScaleState out to the specified Axis.
Declaration Syntax
C# Visual Basic Visual C++
public void ApplyScale(
    Axis axis
)
Public Sub ApplyScale ( _
    axis As Axis _
)
public:
void ApplyScale (
    Axis^ axis
)
Parameters
axis (Axis)
The Axis reference to which the properties should be copied


Clone Method

Clone Method
Namespaces ► ZedGraph ► ScaleState ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public ScaleState Clone()
Public Function Clone As ScaleState
public:
ScaleState^ Clone ()
Return Value
A new, independent copy of this class


IsChanged Method (axis)

IsChanged Method (axis)
Namespaces ► ZedGraph ► ScaleState ► IsChanged(Axis)
Determine if the state contained in this ScaleState object is different from the state of the specified Axis.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsChanged(
    Axis axis
)
Public Function IsChanged ( _
    axis As Axis _
) As Boolean
public:
bool IsChanged (
    Axis^ axis
)
Parameters
axis (Axis)
The Axis object with which to compare states.
Return Value
true if the states are different, false otherwise


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► ScaleState ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


ScaleStateList Class

ScaleStateList Class
Namespaces ► ZedGraph ► ScaleStateList
A collection class that maintains a list of ScaleState objects, corresponding to the list of Axis objects from YAxisList or Y2AxisList.
Declaration Syntax
C# Visual Basic Visual C++
public class ScaleStateList : List<ScaleState>, ICloneable
Public Class ScaleStateList _
    Inherits List(Of ScaleState) _
    Implements ICloneable
public ref class ScaleStateList : public List<ScaleState^>,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ScaleStateListScaleStateListNew(YAxisList) | Construct a new ScaleStateList automatically from an existing YAxisList.
 | ScaleStateListScaleStateListNew(Y2AxisList) | Construct a new ScaleStateList automatically from an existing Y2AxisList.
 | ScaleStateListScaleStateListNew(ScaleStateList) | The Copy Constructor
 | Add(T) | Adds an object to the end of the List<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | AddRange(IEnumerable<(Of <T>)>) | Adds the elements of the specified collection to the end of the List<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | ApplyScale(YAxisList) |
 | ApplyScale(Y2AxisList) |
 | AsReadOnly()() | Returns a read-only IList<(Of <T>)> wrapper for the current collection. (Inherited from List <(Of < ScaleState >)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < ScaleState >)>.)
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of < ScaleState >)>.)
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < ScaleState >)>.)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of < ScaleState >)>.)
 | Clear()() | Removes all elements from the List<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Contains(T) | Determines whether an element is in the List<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | ConvertAll<(Of <TOutput>)>(Converter<(Of <T, TOutput>)>) | Converts the elements in the current List<(Of <T>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of < ScaleState >)>.)
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of < ScaleState >)>.)
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < ScaleState >)>.)
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < ScaleState >)>.)
 | Count | Gets the number of elements actually contained in the List<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <T>)>) | Determines whether the List<(Of <T>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < ScaleState >)>.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | FindAll(Predicate<(Of <T>)>) | Retrieves the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < ScaleState >)>.)
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < ScaleState >)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < ScaleState >)>.)
 | FindLast(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < ScaleState >)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < ScaleState >)>.)
 | ForEach(Action<(Of <T>)>) | Performs the specified action on each element of the List<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | GetEnumerator()() | Returns an enumerator that iterates through the List<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < ScaleState >)>.)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < ScaleState >)>.)
 | Insert(Int32, T) | Inserts an element into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < ScaleState >)>.)
 | InsertRange(Int32, IEnumerable<(Of <T>)>) | Inserts the elements of a collection into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < ScaleState >)>.)
 | IsChanged(YAxisList) | Iterate through the list of ScaleState objects, comparing them to the state of the specified YAxisList Axis objects.
 | IsChanged(Y2AxisList) | Iterate through the list of ScaleState objects, comparing them to the state of the specified Y2AxisList Axis objects.
 | Item[([Int32])] | Gets or sets the element at the specified index. (Inherited from List <(Of < ScaleState >)>.)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < ScaleState >)>.)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < ScaleState >)>.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | RemoveAll(Predicate<(Of <T>)>) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < ScaleState >)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of < ScaleState >)>.)
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer. (Inherited from List <(Of < ScaleState >)>.)
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < ScaleState >)>.)
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < ScaleState >)>.)
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>. (Inherited from List <(Of < ScaleState >)>.)
 | ICollection<(Of <T>)>..::IsReadOnly | (Inherited from List <(Of < ScaleState >)>.)
 | IEnumerable<(Of <T>)>..::GetEnumerator()() | (Inherited from List <(Of < ScaleState >)>.)
 | ICollection..::CopyTo(Array, Int32) | (Inherited from List <(Of < ScaleState >)>.)
 | ICollection..::IsSynchronized | (Inherited from List <(Of < ScaleState >)>.)
 | ICollection..::SyncRoot | (Inherited from List <(Of < ScaleState >)>.)
 | IEnumerable..::GetEnumerator()() | (Inherited from List <(Of < ScaleState >)>.)
 | IList..::Add(Object) | (Inherited from List <(Of < ScaleState >)>.)
 | IList..::Contains(Object) | (Inherited from List <(Of < ScaleState >)>.)
 | IList..::IndexOf(Object) | (Inherited from List <(Of < ScaleState >)>.)
 | IList..::Insert(Int32, Object) | (Inherited from List <(Of < ScaleState >)>.)
 | IList..::IsFixedSize | (Inherited from List <(Of < ScaleState >)>.)
 | IList..::IsReadOnly | (Inherited from List <(Of < ScaleState >)>.)
 | IList..::Item[([Int32])] | (Inherited from List <(Of < ScaleState >)>.)
 | IList..::Remove(Object) | (Inherited from List <(Of < ScaleState >)>.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToArray()() | Copies the elements of the List<(Of <T>)> to a new array. (Inherited from List <(Of < ScaleState >)>.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()() | Sets the capacity to the actual number of elements in the List<(Of <T>)>, if that number is less than a threshold value. (Inherited from List <(Of < ScaleState >)>.)
 | TrueForAll(Predicate<(Of <T>)>) | Determines whether every element in the List<(Of <T>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of < ScaleState >)>.)
Inheritance Hierarchy
Object
 | List <(Of < ScaleState >)>
 |  | ScaleStateList


ScaleStateList Constructor

ScaleStateList Constructor
Namespaces ► ZedGraph ► ScaleStateList ► ScaleStateListScaleStateListNew()()
Members
Icon | Member | Description
 | ScaleStateListScaleStateListNew(YAxisList) | Construct a new ScaleStateList automatically from an existing YAxisList.
 | ScaleStateListScaleStateListNew(Y2AxisList) | Construct a new ScaleStateList automatically from an existing Y2AxisList.
 | ScaleStateListScaleStateListNew(ScaleStateList) | The Copy Constructor


ScaleStateList Constructor (rhs)

ScaleStateList Constructor (rhs)
Namespaces ► ZedGraph ► ScaleStateList ► ScaleStateListScaleStateListNew(ScaleStateList)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ScaleStateList(
    ScaleStateList rhs
)
Public Sub New ( _
    rhs As ScaleStateList _
)
public:
ScaleStateList (
    ScaleStateList^ rhs
)
Parameters
rhs (ScaleStateList)
The ScaleStateList object from which to copy


ScaleStateList Constructor (list)

ScaleStateList Constructor (list)
Namespaces ► ZedGraph ► ScaleStateList ► ScaleStateListScaleStateListNew(Y2AxisList)
Construct a new ScaleStateList automatically from an existing Y2AxisList.
Declaration Syntax
C# Visual Basic Visual C++
public ScaleStateList(
    Y2AxisList list
)
Public Sub New ( _
    list As Y2AxisList _
)
public:
ScaleStateList (
    Y2AxisList^ list
)
Parameters
list (Y2AxisList)
The Y2AxisList (a list of Y axes), from which to retrieve the state and create the ScaleState objects.


ScaleStateList Constructor (list)

ScaleStateList Constructor (list)
Namespaces ► ZedGraph ► ScaleStateList ► ScaleStateListScaleStateListNew(YAxisList)
Construct a new ScaleStateList automatically from an existing YAxisList.
Declaration Syntax
C# Visual Basic Visual C++
public ScaleStateList(
    YAxisList list
)
Public Sub New ( _
    list As YAxisList _
)
public:
ScaleStateList (
    YAxisList^ list
)
Parameters
list (YAxisList)
The YAxisList (a list of Y axes), from which to retrieve the state and create the ScaleState objects.


ApplyScale Method

ApplyScale Method
Namespaces ► ZedGraph ► ScaleStateList ► ApplyScale()()
Members
Icon | Member | Description
 | ApplyScale(YAxisList) |
 | ApplyScale(Y2AxisList) |


ApplyScale Method (list)

ApplyScale Method (list)
Namespaces ► ZedGraph ► ScaleStateList ► ApplyScale(Y2AxisList)
Declaration Syntax
C# Visual Basic Visual C++
public void ApplyScale(
    Y2AxisList list
)
Public Sub ApplyScale ( _
    list As Y2AxisList _
)
public:
void ApplyScale (
    Y2AxisList^ list
)
Parameters
list (Y2AxisList)


ApplyScale Method (list)

ApplyScale Method (list)
Namespaces ► ZedGraph ► ScaleStateList ► ApplyScale(YAxisList)
Declaration Syntax
C# Visual Basic Visual C++
public void ApplyScale(
    YAxisList list
)
Public Sub ApplyScale ( _
    list As YAxisList _
)
public:
void ApplyScale (
    YAxisList^ list
)
Parameters
list (YAxisList)


Clone Method

Clone Method
Namespaces ► ZedGraph ► ScaleStateList ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public ScaleStateList Clone()
Public Function Clone As ScaleStateList
public:
ScaleStateList^ Clone ()
Return Value
A new, independent copy of this class


IsChanged Method

IsChanged Method
Namespaces ► ZedGraph ► ScaleStateList ► IsChanged()()
Members
Icon | Member | Description
 | IsChanged(YAxisList) | Iterate through the list of ScaleState objects, comparing them to the state of the specified YAxisList Axis objects.
 | IsChanged(Y2AxisList) | Iterate through the list of ScaleState objects, comparing them to the state of the specified Y2AxisList Axis objects.


IsChanged Method (list)

IsChanged Method (list)
Namespaces ► ZedGraph ► ScaleStateList ► IsChanged(Y2AxisList)
Iterate through the list of ScaleState objects, comparing them to the state of the specified Y2AxisList Axis objects.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsChanged(
    Y2AxisList list
)
Public Function IsChanged ( _
    list As Y2AxisList _
) As Boolean
public:
bool IsChanged (
    Y2AxisList^ list
)
Parameters
list (Y2AxisList)
A Y2AxisList object specifying a list of Axis objects to be compared with this ScaleStateList.
Return Value
true if a difference is found, false otherwise


IsChanged Method (list)

IsChanged Method (list)
Namespaces ► ZedGraph ► ScaleStateList ► IsChanged(YAxisList)
Iterate through the list of ScaleState objects, comparing them to the state of the specified YAxisList Axis objects.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsChanged(
    YAxisList list
)
Public Function IsChanged ( _
    list As YAxisList _
) As Boolean
public:
bool IsChanged (
    YAxisList^ list
)
Parameters
list (YAxisList)
A YAxisList object specifying a list of Axis objects to be compared with this ScaleStateList.
Return Value
true if a difference is found, false otherwise


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► ScaleStateList ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


ScrollRange Structure

ScrollRange Structure
Namespaces ► ZedGraph ► ScrollRange
A simple struct to store minimum and maximum Double type values for the scroll range
Declaration Syntax
C# Visual Basic Visual C++
public struct ScrollRange
Public Structure ScrollRange
public value class ScrollRange
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ScrollRangeScrollRangeNew(Double, Double, Boolean) | Construct a ScrollRange object given the specified data values.
 | ScrollRangeScrollRangeNew(Boolean) | Sets the scroll range to default values of zero, and sets the IsScrollable property as specified.
 | ScrollRangeScrollRangeNew(ScrollRange) | The Copy Constructor
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsScrollable | Gets or sets a property that determines if the Axis corresponding to this ScrollRange object can be scrolled.
 | Max | The maximum axis value limit for the scroll bar.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Min | The minimum axis value limit for the scroll bar.
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


ScrollRange Constructor

ScrollRange Constructor
Namespaces ► ZedGraph ► ScrollRange ► ScrollRangeScrollRangeNew()()
Members
Icon | Member | Description
 | ScrollRangeScrollRangeNew(Double, Double, Boolean) | Construct a ScrollRange object given the specified data values.
 | ScrollRangeScrollRangeNew(Boolean) | Sets the scroll range to default values of zero, and sets the IsScrollable property as specified.
 | ScrollRangeScrollRangeNew(ScrollRange) | The Copy Constructor


ScrollRange Constructor (isScrollable)

ScrollRange Constructor (isScrollable)
Namespaces ► ZedGraph ► ScrollRange ► ScrollRangeScrollRangeNew(Boolean)
Sets the scroll range to default values of zero, and sets the IsScrollable property as specified.
Declaration Syntax
C# Visual Basic Visual C++
public ScrollRange(
    bool isScrollable
)
Public Sub New ( _
    isScrollable As Boolean _
)
public:
ScrollRange (
    bool isScrollable
)
Parameters
isScrollable (Boolean)
true to make this item scrollable, false otherwise


ScrollRange Constructor (min, max, isScrollable)

ScrollRange Constructor (min, max, isScrollable)
Namespaces ► ZedGraph ► ScrollRange ► ScrollRangeScrollRangeNew(Double, Double, Boolean)
Construct a ScrollRange object given the specified data values.
Declaration Syntax
C# Visual Basic Visual C++
public ScrollRange(
    double min,
    double max,
    bool isScrollable
)
Public Sub New ( _
    min As Double, _
    max As Double, _
    isScrollable As Boolean _
)
public:
ScrollRange (
    double min,
    double max,
    bool isScrollable
)
Parameters
min (Double)
The minimum axis value limit for the scroll bar
max (Double)
The maximum axis value limit for the scroll bar
isScrollable (Boolean)
true to make this item scrollable, false otherwise


ScrollRange Constructor (rhs)

ScrollRange Constructor (rhs)
Namespaces ► ZedGraph ► ScrollRange ► ScrollRangeScrollRangeNew(ScrollRange)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ScrollRange(
    ScrollRange rhs
)
Public Sub New ( _
    rhs As ScrollRange _
)
public:
ScrollRange (
    ScrollRange rhs
)
Parameters
rhs (ScrollRange)
The ScrollRange object from which to copy


IsScrollable Property

IsScrollable Property
Namespaces ► ZedGraph ► ScrollRange ► IsScrollable
Gets or sets a property that determines if the Axis corresponding to this ScrollRange object can be scrolled.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsScrollable{ get; set;}
Public Property IsScrollable As Boolean
public:
property bool IsScrollable {
    bool get ();
    void set (bool value);
}


Max Property

Max Property
Namespaces ► ZedGraph ► ScrollRange ► Max
The maximum axis value limit for the scroll bar.
Declaration Syntax
C# Visual Basic Visual C++
public double Max{ get; set;}
Public Property Max As Double
public:
property double Max {
    double get ();
    void set (double value);
}


Min Property

Min Property
Namespaces ► ZedGraph ► ScrollRange ► Min
The minimum axis value limit for the scroll bar.
Declaration Syntax
C# Visual Basic Visual C++
public double Min{ get; set;}
Public Property Min As Double
public:
property double Min {
    double get ();
    void set (double value);
}


ScrollRangeList Class

ScrollRangeList Class
Namespaces ► ZedGraph ► ScrollRangeList
A collection class containing a list of ScrollRange objects.
Declaration Syntax
C# Visual Basic Visual C++
public class ScrollRangeList : List<ScrollRange>, ICloneable
Public Class ScrollRangeList _
    Inherits List(Of ScrollRange) _
    Implements ICloneable
public ref class ScrollRangeList : public List<ScrollRange>,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ScrollRangeListScrollRangeListNew()() | Default constructor for the collection class.
 | ScrollRangeListScrollRangeListNew(ScrollRangeList) | The Copy Constructor
 | Add(T) | Adds an object to the end of the List<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | AddRange(IEnumerable<(Of <T>)>) | Adds the elements of the specified collection to the end of the List<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | AsReadOnly()() | Returns a read-only IList<(Of <T>)> wrapper for the current collection. (Inherited from List <(Of < ScrollRange >)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < ScrollRange >)>.)
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of < ScrollRange >)>.)
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < ScrollRange >)>.)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of < ScrollRange >)>.)
 | Clear()() | Removes all elements from the List<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Contains(T) | Determines whether an element is in the List<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | ConvertAll<(Of <TOutput>)>(Converter<(Of <T, TOutput>)>) | Converts the elements in the current List<(Of <T>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of < ScrollRange >)>.)
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of < ScrollRange >)>.)
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < ScrollRange >)>.)
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < ScrollRange >)>.)
 | Count | Gets the number of elements actually contained in the List<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <T>)>) | Determines whether the List<(Of <T>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < ScrollRange >)>.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | FindAll(Predicate<(Of <T>)>) | Retrieves the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < ScrollRange >)>.)
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < ScrollRange >)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < ScrollRange >)>.)
 | FindLast(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < ScrollRange >)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < ScrollRange >)>.)
 | ForEach(Action<(Of <T>)>) | Performs the specified action on each element of the List<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | GetEnumerator()() | Returns an enumerator that iterates through the List<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < ScrollRange >)>.)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < ScrollRange >)>.)
 | Insert(Int32, T) | Inserts an element into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < ScrollRange >)>.)
 | InsertRange(Int32, IEnumerable<(Of <T>)>) | Inserts the elements of a collection into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < ScrollRange >)>.)
 | Item[([Int32])] | Indexer to access the specified ScrollRange object by its ordinal position in the list.
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < ScrollRange >)>.)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < ScrollRange >)>.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | RemoveAll(Predicate<(Of <T>)>) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < ScrollRange >)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of < ScrollRange >)>.)
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer. (Inherited from List <(Of < ScrollRange >)>.)
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < ScrollRange >)>.)
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < ScrollRange >)>.)
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>. (Inherited from List <(Of < ScrollRange >)>.)
 | ICollection<(Of <T>)>..::IsReadOnly | (Inherited from List <(Of < ScrollRange >)>.)
 | IEnumerable<(Of <T>)>..::GetEnumerator()() | (Inherited from List <(Of < ScrollRange >)>.)
 | ICollection..::CopyTo(Array, Int32) | (Inherited from List <(Of < ScrollRange >)>.)
 | ICollection..::IsSynchronized | (Inherited from List <(Of < ScrollRange >)>.)
 | ICollection..::SyncRoot | (Inherited from List <(Of < ScrollRange >)>.)
 | IEnumerable..::GetEnumerator()() | (Inherited from List <(Of < ScrollRange >)>.)
 | IList..::Add(Object) | (Inherited from List <(Of < ScrollRange >)>.)
 | IList..::Contains(Object) | (Inherited from List <(Of < ScrollRange >)>.)
 | IList..::IndexOf(Object) | (Inherited from List <(Of < ScrollRange >)>.)
 | IList..::Insert(Int32, Object) | (Inherited from List <(Of < ScrollRange >)>.)
 | IList..::IsFixedSize | (Inherited from List <(Of < ScrollRange >)>.)
 | IList..::IsReadOnly | (Inherited from List <(Of < ScrollRange >)>.)
 | IList..::Item[([Int32])] | (Inherited from List <(Of < ScrollRange >)>.)
 | IList..::Remove(Object) | (Inherited from List <(Of < ScrollRange >)>.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToArray()() | Copies the elements of the List<(Of <T>)> to a new array. (Inherited from List <(Of < ScrollRange >)>.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()() | Sets the capacity to the actual number of elements in the List<(Of <T>)>, if that number is less than a threshold value. (Inherited from List <(Of < ScrollRange >)>.)
 | TrueForAll(Predicate<(Of <T>)>) | Determines whether every element in the List<(Of <T>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of < ScrollRange >)>.)
Inheritance Hierarchy
Object
 | List <(Of < ScrollRange >)>
 |  | ScrollRangeList


ScrollRangeList Constructor

ScrollRangeList Constructor
Namespaces ► ZedGraph ► ScrollRangeList ► ScrollRangeListScrollRangeListNew()()
Members
Icon | Member | Description
 | ScrollRangeListScrollRangeListNew()() | Default constructor for the collection class.
 | ScrollRangeListScrollRangeListNew(ScrollRangeList) | The Copy Constructor


ScrollRangeList Constructor

ScrollRangeList Constructor
Namespaces ► ZedGraph ► ScrollRangeList ► ScrollRangeListScrollRangeListNew()()
Default constructor for the collection class.
Declaration Syntax
C# Visual Basic Visual C++
public ScrollRangeList()
Public Sub New
public:
ScrollRangeList ()


ScrollRangeList Constructor (rhs)

ScrollRangeList Constructor (rhs)
Namespaces ► ZedGraph ► ScrollRangeList ► ScrollRangeListScrollRangeListNew(ScrollRangeList)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ScrollRangeList(
    ScrollRangeList rhs
)
Public Sub New ( _
    rhs As ScrollRangeList _
)
public:
ScrollRangeList (
    ScrollRangeList^ rhs
)
Parameters
rhs (ScrollRangeList)
The ScrollRangeList object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► ScrollRangeList ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public ScrollRangeList Clone()
Public Function Clone As ScrollRangeList
public:
ScrollRangeList^ Clone ()
Return Value
A new, independent copy of this class


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph ► ScrollRangeList ► Item[([Int32])]
Indexer to access the specified ScrollRange object by its ordinal position in the list.
Declaration Syntax
C# Visual Basic Visual C++
public ScrollRange this[
    int index
]{ get; set;}
Public Default Property Item ( _
    index As Integer _
) As ScrollRange
public:
property ScrollRange default[int index] {
    ScrollRange get (int index);
    void set (int index, ScrollRange value);
}
Parameters
index (Int32)
The ordinal position (zero-based) of the ScrollRange object to be accessed.
Value
A ScrollRange object instance


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► ScrollRangeList ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Selection Class

Selection Class
Namespaces ► ZedGraph ► Selection
Declaration Syntax
C# Visual Basic Visual C++
public class Selection : CurveList
Public Class Selection _
    Inherits CurveList
public ref class Selection : public CurveList
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SelectionSelectionNew()() |
 | Add(T) | Adds an object to the end of the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | AddRange(IEnumerable<(Of <T>)>) | Adds the elements of the specified collection to the end of the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | AddToSelection(MasterPane, CurveItem) | Add a CurveItem to the selection list.
 | AddToSelection(MasterPane, CurveList) | Add a list of CurveItem's to the selection list.
 | AsReadOnly()() | Returns a read-only IList<(Of <T>)> wrapper for the current collection. (Inherited from List <(Of < CurveItem >)>.)
 | Backward | Iterate backwards through the CurveList items. (Inherited from CurveList.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < CurveItem >)>.)
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of < CurveItem >)>.)
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < CurveItem >)>.)
 | Border | The Border type to be used for drawing "selected" PieItem, BarItem, HiLowBarItem, OHLCBarItem, and JapaneseCandleStickItem item types.
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of < CurveItem >)>.)
 | Clear()() | Removes all elements from the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | ClearSelection(MasterPane) | Clear the selection list and trigger a SelectionChangedEvent.
 | ClearSelection(MasterPane, Boolean) | Clear the selection list and optionally trigger a SelectionChangedEvent.
 | Clone()() | Typesafe, deep-copy clone method. (Inherited from CurveList.)
 | Contains(T) | Determines whether an element is in the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | ConvertAll<(Of <TOutput>)>(Converter<(Of <T, TOutput>)>) | Converts the elements in the current List<(Of <T>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of < CurveItem >)>.)
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of < CurveItem >)>.)
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < CurveItem >)>.)
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < CurveItem >)>.)
 | Count | Gets the number of elements actually contained in the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | Draw(Graphics, GraphPane, Single) | Render all the CurveItem objects in the list to the specified Graphics device by calling the Draw(Graphics, GraphPane, Int32, Single) member function of each CurveItem object. (Inherited from CurveList.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <T>)>) | Determines whether the List<(Of <T>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < CurveItem >)>.)
 | Fill | The Fill type to be used for drawing "selected" PieItem, BarItem, HiLowBarItem, and JapaneseCandleStickItem item types.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | FindAll(Predicate<(Of <T>)>) | Retrieves the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < CurveItem >)>.)
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < CurveItem >)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < CurveItem >)>.)
 | FindLast(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < CurveItem >)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < CurveItem >)>.)
 | ForEach(Action<(Of <T>)>) | Performs the specified action on each element of the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | Forward | Iterate forward through the CurveList items. (Inherited from CurveList.)
 | GetBarItemPos(GraphPane, BarItem) | Find the ordinal position of the specified BarItem within the CurveList. This position only counts types, ignoring all other types. (Inherited from CurveList.)
 | GetEnumerator()() | Returns an enumerator that iterates through the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetRange(Boolean, Boolean, GraphPane) | Go through each CurveItem object in the collection, calling the GetRange(Double%, Double%, Double%, Double%, Boolean, Boolean, GraphPane) member to determine the minimum and maximum values in the Points list of data value pairs. If the curves include a stack bar, handle within the current GetRange method. In the event that no data are available, a default range of min=0.0 and max=1.0 are returned. If the Y axis has a valid data range and the Y2 axis not, then the Y2 range will be a duplicate of the Y range. Vice-versa for the Y2 axis having valid data when the Y axis does not. If any CurveItem in the list has a missing PointPairList, a new empty one will be generated. (Inherited from CurveList.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasData()() | Determine if there is any data in any of the CurveItem objects for this graph. This method does not verify valid data, it only checks to see if NPts > 0. (Inherited from CurveList.)
 | IndexOf(String) | Return the zero-based position index of the CurveItem with the specified Label. (Inherited from CurveList.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < CurveItem >)>.)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < CurveItem >)>.)
 | IndexOfTag(String) | Return the zero-based position index of the CurveItem with the specified Tag. (Inherited from CurveList.)
 | Insert(Int32, T) | Inserts an element into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < CurveItem >)>.)
 | InsertRange(Int32, IEnumerable<(Of <T>)>) | Inserts the elements of a collection into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < CurveItem >)>.)
 | IsPieOnly | Read only property that determines if all items in the CurveList are Pies. (Inherited from CurveList.)
 | Item[([String])] | Indexer to access the specified CurveItem object by its Label string. (Inherited from CurveList.)
 | Item[([Int32])] | Gets or sets the element at the specified index. (Inherited from List <(Of < CurveItem >)>.)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < CurveItem >)>.)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < CurveItem >)>.)
 | Line | The Line type to be used for drawing "selected" LineItem and StickItem types
 | MaxPts | Read only value for the maximum number of points in any of the curves in the list. (Inherited from CurveList.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Move(Int32, Int32) | Move the position of the object at the specified index to the new relative position in the list. (Inherited from CurveList.)
 | NumBars | Read only property that returns the number of curves in the list that are of type Bar. (Inherited from CurveList.)
 | NumPies | Read only property that returns the number of pie slices in the list (class type is PieItem ). (Inherited from CurveList.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | RemoveAll(Predicate<(Of <T>)>) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < CurveItem >)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | RemoveFromSelection(MasterPane, CurveItem) | Remove the specified CurveItem from the selection list.
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of < CurveItem >)>.)
 | Select(MasterPane, CurveItem) | Place a CurveItem in the selection list, removing all other items.
 | Select(MasterPane, CurveList) | Place a list of CurveItem's in the selection list, removing all other items.
 | SelectionChangedEvent | Subscribe to this event to receive notice that the list of selected CurveItems has changed
 | Sort(SortType, Int32) | Sorts the list according to the point values at the specified index and for the specified axis. (Inherited from CurveList.)
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < CurveItem >)>.)
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < CurveItem >)>.)
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>. (Inherited from List <(Of < CurveItem >)>.)
 | Symbol | The Symbol type to be used for drawing "selected" LineItem and ErrorBarItem types.
 | ICollection<(Of <T>)>..::IsReadOnly | (Inherited from List <(Of < CurveItem >)>.)
 | IEnumerable<(Of <T>)>..::GetEnumerator()() | (Inherited from List <(Of < CurveItem >)>.)
 | ICollection..::CopyTo(Array, Int32) | (Inherited from List <(Of < CurveItem >)>.)
 | ICollection..::IsSynchronized | (Inherited from List <(Of < CurveItem >)>.)
 | ICollection..::SyncRoot | (Inherited from List <(Of < CurveItem >)>.)
 | IEnumerable..::GetEnumerator()() | (Inherited from List <(Of < CurveItem >)>.)
 | IList..::Add(Object) | (Inherited from List <(Of < CurveItem >)>.)
 | IList..::Contains(Object) | (Inherited from List <(Of < CurveItem >)>.)
 | IList..::IndexOf(Object) | (Inherited from List <(Of < CurveItem >)>.)
 | IList..::Insert(Int32, Object) | (Inherited from List <(Of < CurveItem >)>.)
 | IList..::IsFixedSize | (Inherited from List <(Of < CurveItem >)>.)
 | IList..::IsReadOnly | (Inherited from List <(Of < CurveItem >)>.)
 | IList..::Item[([Int32])] | (Inherited from List <(Of < CurveItem >)>.)
 | IList..::Remove(Object) | (Inherited from List <(Of < CurveItem >)>.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()() (Inherited from CurveList.)
 | ToArray()() | Copies the elements of the List<(Of <T>)> to a new array. (Inherited from List <(Of < CurveItem >)>.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()() | Sets the capacity to the actual number of elements in the List<(Of <T>)>, if that number is less than a threshold value. (Inherited from List <(Of < CurveItem >)>.)
 | TrueForAll(Predicate<(Of <T>)>) | Determines whether every element in the List<(Of <T>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of < CurveItem >)>.)
 | UpdateSelection(MasterPane) | Mark the CurveItem's that are included in the selection list by setting the IsSelected property to true.
Remarks
Inheritance Hierarchy
Object
 | List <(Of < CurveItem >)>
 |  | CurveList
 |  |  | Selection


Selection Constructor

Selection Constructor
Namespaces ► ZedGraph ► Selection ► SelectionSelectionNew()()
Declaration Syntax
C# Visual Basic Visual C++
public Selection()
Public Sub New
public:
Selection ()


AddToSelection Method

AddToSelection Method
Namespaces ► ZedGraph ► Selection ► AddToSelection()()
Members
Icon | Member | Description
 | AddToSelection(MasterPane, CurveItem) | Add a CurveItem to the selection list.
 | AddToSelection(MasterPane, CurveList) | Add a list of CurveItem's to the selection list.


AddToSelection Method (master, ci)

AddToSelection Method (master, ci)
Namespaces ► ZedGraph ► Selection ► AddToSelection(MasterPane, CurveItem)
Add a CurveItem to the selection list.
Declaration Syntax
C# Visual Basic Visual C++
public void AddToSelection(
    MasterPane master,
    CurveItem ci
)
Public Sub AddToSelection ( _
    master As MasterPane, _
    ci As CurveItem _
)
public:
void AddToSelection (
    MasterPane^ master,
    CurveItem^ ci
)
Parameters
master (MasterPane)
The MasterPane that is the "owner" of the CurveItem's.
ci (CurveItem)
The CurveItem to be added to the list.


AddToSelection Method (master, ciList)

AddToSelection Method (master, ciList)
Namespaces ► ZedGraph ► Selection ► AddToSelection(MasterPane, CurveList)
Add a list of CurveItem's to the selection list.
Declaration Syntax
C# Visual Basic Visual C++
public void AddToSelection(
    MasterPane master,
    CurveList ciList
)
Public Sub AddToSelection ( _
    master As MasterPane, _
    ciList As CurveList _
)
public:
void AddToSelection (
    MasterPane^ master,
    CurveList^ ciList
)
Parameters
master (MasterPane)
The MasterPane that is the "owner" of the CurveItem's.
ciList (CurveList)
The list of CurveItem's to be added to the list.


Border Field

Border Field
Namespaces ► ZedGraph ► Selection ► Border
The Border type to be used for drawing "selected" PieItem, BarItem, HiLowBarItem, OHLCBarItem, and JapaneseCandleStickItem item types.
Declaration Syntax
C# Visual Basic Visual C++
public static Border Border
Public Shared Border As Border
public:
static Border^ Border


ClearSelection Method

ClearSelection Method
Namespaces ► ZedGraph ► Selection ► ClearSelection()()
Members
Icon | Member | Description
 | ClearSelection(MasterPane) | Clear the selection list and trigger a SelectionChangedEvent.
 | ClearSelection(MasterPane, Boolean) | Clear the selection list and optionally trigger a SelectionChangedEvent.


ClearSelection Method (master)

ClearSelection Method (master)
Namespaces ► ZedGraph ► Selection ► ClearSelection(MasterPane)
Clear the selection list and trigger a SelectionChangedEvent.
Declaration Syntax
C# Visual Basic Visual C++
public void ClearSelection(
    MasterPane master
)
Public Sub ClearSelection ( _
    master As MasterPane _
)
public:
void ClearSelection (
    MasterPane^ master
)
Parameters
master (MasterPane)
The MasterPane that "owns" the selection list.


ClearSelection Method (master, sendEvent)

ClearSelection Method (master, sendEvent)
Namespaces ► ZedGraph ► Selection ► ClearSelection(MasterPane, Boolean)
Clear the selection list and optionally trigger a SelectionChangedEvent.
Declaration Syntax
C# Visual Basic Visual C++
public void ClearSelection(
    MasterPane master,
    bool sendEvent
)
Public Sub ClearSelection ( _
    master As MasterPane, _
    sendEvent As Boolean _
)
public:
void ClearSelection (
    MasterPane^ master,
    bool sendEvent
)
Parameters
master (MasterPane)
The MasterPane that "owns" the selection list.
sendEvent (Boolean)
true to trigger a SelectionChangedEvent, false otherwise.


Fill Field

Fill Field
Namespaces ► ZedGraph ► Selection ► Fill
The Fill type to be used for drawing "selected" PieItem, BarItem, HiLowBarItem, and JapaneseCandleStickItem item types.
Declaration Syntax
C# Visual Basic Visual C++
public static Fill Fill
Public Shared Fill As Fill
public:
static Fill^ Fill


Line Field

Line Field
Namespaces ► ZedGraph ► Selection ► Line
The Line type to be used for drawing "selected" LineItem and StickItem types
Declaration Syntax
C# Visual Basic Visual C++
public static Line Line
Public Shared Line As Line
public:
static Line^ Line


RemoveFromSelection Method (master, ci)

RemoveFromSelection Method (master, ci)
Namespaces ► ZedGraph ► Selection ► RemoveFromSelection(MasterPane, CurveItem)
Remove the specified CurveItem from the selection list.
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveFromSelection(
    MasterPane master,
    CurveItem ci
)
Public Sub RemoveFromSelection ( _
    master As MasterPane, _
    ci As CurveItem _
)
public:
void RemoveFromSelection (
    MasterPane^ master,
    CurveItem^ ci
)
Parameters
master (MasterPane)
The MasterPane that is the "owner" of the CurveItem's.
ci (CurveItem)
The CurveItem to be removed from the list.


Select Method

Select Method
Namespaces ► ZedGraph ► Selection ► Select()()
Members
Icon | Member | Description
 | Select(MasterPane, CurveItem) | Place a CurveItem in the selection list, removing all other items.
 | Select(MasterPane, CurveList) | Place a list of CurveItem's in the selection list, removing all other items.


Select Method (master, ci)

Select Method (master, ci)
Namespaces ► ZedGraph ► Selection ► Select(MasterPane, CurveItem)
Place a CurveItem in the selection list, removing all other items.
Declaration Syntax
C# Visual Basic Visual C++
public void Select(
    MasterPane master,
    CurveItem ci
)
Public Sub Select ( _
    master As MasterPane, _
    ci As CurveItem _
)
public:
void Select (
    MasterPane^ master,
    CurveItem^ ci
)
Parameters
master (MasterPane)
The MasterPane that is the "owner" of the CurveItem's.
ci (CurveItem)
The CurveItem to be added to the list.


Select Method (master, ciList)

Select Method (master, ciList)
Namespaces ► ZedGraph ► Selection ► Select(MasterPane, CurveList)
Place a list of CurveItem's in the selection list, removing all other items.
Declaration Syntax
C# Visual Basic Visual C++
public void Select(
    MasterPane master,
    CurveList ciList
)
Public Sub Select ( _
    master As MasterPane, _
    ciList As CurveList _
)
public:
void Select (
    MasterPane^ master,
    CurveList^ ciList
)
Parameters
master (MasterPane)
The MasterPane that is the "owner" of the CurveItem's.
ciList (CurveList)
The list of CurveItem to be added to the list.


SelectionChangedEvent Event

SelectionChangedEvent Event
Namespaces ► ZedGraph ► Selection ► SelectionChangedEvent
Subscribe to this event to receive notice that the list of selected CurveItems has changed
Declaration Syntax
C# Visual Basic Visual C++
public event EventHandler SelectionChangedEvent
Public Event SelectionChangedEvent As EventHandler
public:
 event EventHandler^ SelectionChangedEvent {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}


Symbol Field

Symbol Field
Namespaces ► ZedGraph ► Selection ► Symbol
The Symbol type to be used for drawing "selected" LineItem and ErrorBarItem types.
Declaration Syntax
C# Visual Basic Visual C++
public static Symbol Symbol
Public Shared Symbol As Symbol
public:
static Symbol^ Symbol


UpdateSelection Method (master)

UpdateSelection Method (master)
Namespaces ► ZedGraph ► Selection ► UpdateSelection(MasterPane)
Mark the CurveItem's that are included in the selection list by setting the IsSelected property to true.
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateSelection(
    MasterPane master
)
Public Sub UpdateSelection ( _
    master As MasterPane _
)
public:
void UpdateSelection (
    MasterPane^ master
)
Parameters
master (MasterPane)
The MasterPane that "owns" the selection list.


SortType Enumeration

SortType Enumeration
Namespaces ► ZedGraph ► SortType
Enumeration type that defines which set of data points - X or Y - is used Sort()() to perform the sort.
Declaration Syntax
C# Visual Basic Visual C++
public enum SortType
Public Enumeration SortType
public enum class SortType
Members
Member | Description
YValues | Use the Y values to sort the list.
XValues | Use the X values to sort the list.
See Also
Sort()()


StepType Enumeration

StepType Enumeration
Namespaces ► ZedGraph ► StepType
Enumeration type that defines how a curve is drawn. Curves can be drawn as ordinary lines by connecting the points directly, or in a stair-step fashion as a series of discrete, constant values. In a stair step plot, all lines segments are either horizontal or vertical. In a non-step (line) plot, the lines can be any angle.
Declaration Syntax
C# Visual Basic Visual C++
public enum StepType
Public Enumeration StepType
public enum class StepType
Members
Member | Description
ForwardStep | Draw the CurveItem as a stair-step in which each point defines the beginning (left side) of a new stair. This implies the points are defined at the beginning of an "event."
RearwardStep | Draw the CurveItem as a stair-step in which each point defines the end (right side) of a new stair. This implies the points are defined at the end of an "event."
NonStep | Draw the CurveItem as an ordinary line, in which the points are connected directly by line segments.
ForwardSegment | Draw the CurveItem as a segment in which each point defines the beginning (left side) of a new "stair." This implies the points are defined at the beginning of an "event." Note that ForwardSegment is different from ForwardStep in that it does not draw the vertical portion of the step.
RearwardSegment | Draw the CurveItem as a segment in which each point defines the end (right side) of a new "stair." This implies the points are defined at the end of an "event." Note that RearwardSegment is different from RearwardStep in that it does not draw the vertical portion of the step.
See Also
StepType


StickItem Class

StickItem Class
Namespaces ► ZedGraph ► StickItem
Encapsulates a curve type that is displayed as a series of vertical "sticks", one at each defined point.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class StickItem : LineItem, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class StickItem _
    Inherits LineItem _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class StickItem : public LineItem,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StickItemStickItemNew(String) | Create a new StickItem, specifying only the legend Label.
 | StickItemStickItemNew(String, array<Double>[](), array<Double>[](), Color, Single) | Create a new StickItem using the specified properties.
 | StickItemStickItemNew(String, array<Double>[](), array<Double>[](), Color) | Create a new StickItem using the specified properties.
 | StickItemStickItemNew(String, IPointList, Color) | Create a new StickItem using the specified properties.
 | StickItemStickItemNew(String, IPointList, Color, Single) | Create a new StickItem using the specified properties.
 | StickItemStickItemNew(StickItem) | The Copy Constructor
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve. (Inherited from CurveItem.)
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve. (Inherited from CurveItem.)
 | BaseAxis(GraphPane) | Returns a reference to the Axis object that is the "base" (independent axis) from which the values are drawn. (Inherited from CurveItem.)
 | Clear()() | Clears the points from this CurveItem. This is the same as CurveItem.Points.Clear(). (Inherited from CurveItem.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The Line/Symbol/Bar color (FillColor for the Bar). This is a common access to Line.Color, Border.Color, and Fill.Color properties for this curve. (Inherited from CurveItem.)
 | Draw(Graphics, GraphPane, Int32, Single) | Do all rendering associated with this LineItem to the specified Graphics device. This method is normally only called by the Draw method of the parent CurveList collection object. (Inherited from LineItem.)
 | DrawLegendKey(Graphics, GraphPane, RectangleF, Single) | Draw a legend key entry for this LineItem at the specified location (Inherited from LineItem.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBarWidth(GraphPane) | Calculate the width of each bar, depending on the actual bar type (Inherited from CurveItem.)
 | GetCoords(GraphPane, Int32, String%) | Determine the coords for the rectangle associated with a specified point for this CurveItem (Inherited from LineItem.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides LineItem.GetObjectData(SerializationInfo, StreamingContext).)
 | GetRange(Double%, Double%, Double%, Double%, Boolean, Boolean, GraphPane) | Go through the list of PointPair data values for this CurveItem and determine the minimum and maximum values in the data. (Inherited from CurveItem.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetXAxis(GraphPane) | Get the X Axis instance (either XAxis or X2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxis(GraphPane) | Get the Y Axis instance (either YAxis or Y2Axis) to which this CurveItem belongs. (Inherited from CurveItem.)
 | GetYAxisIndex(GraphPane) | Get the index of the Y Axis in the YAxis or Y2Axis list to which this CurveItem belongs. (Inherited from CurveItem.)
 | IsBar | Determines whether this CurveItem is a BarItem. This does not include HiLowBarItem's or ErrorBarItem's. (Inherited from CurveItem.)
 | IsLine | Determines whether this CurveItem is a LineItem. (Inherited from CurveItem.)
 | IsOverrideOrdinal | Gets or sets a value which allows you to override the normal ordinal axis behavior. (Inherited from CurveItem.)
 | IsPie | Determines whether this CurveItem is a PieItem. (Inherited from CurveItem.)
 | IsSelectable | Determines whether this CurveItem can be selected in the graph. (Inherited from CurveItem.)
 | IsSelected | Determines whether this CurveItem is selected on the graph. Note that this value changes the curve displayed color, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsVisible | Determines whether this CurveItem is visible on the graph. Note that this value turns the curve display on or off, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsVisible to false. (Inherited from CurveItem.)
 | IsX2Axis | Gets or sets a value that determines which X axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | IsY2Axis | Gets or sets a value that determines which Y axis this CurveItem is assigned to. (Inherited from CurveItem.)
 | Item[([Int32])] | An accessor for the PointPair datum for this CurveItem. Index is the ordinal reference (zero based) of the point. (Inherited from CurveItem.)
 | Label | A Label instance that represents the Legend entry for the this CurveItem object (Inherited from CurveItem.)
 | Line | Gets or sets the Line class instance defined for this LineItem. (Inherited from LineItem.)
 | Link | Gets or sets the hyperlink information for this CurveItem. (Inherited from CurveItem.)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this LineItem. This is mainly useful for differentiating a set of new LineItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator) (Inherited from LineItem.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NPts | Readonly property that gives the number of points that define this CurveItem object, which is the number of points in the Points data collection. (Inherited from CurveItem.)
 | Points | The IPointList of X,Y point sets that represent this CurveItem. (Inherited from CurveItem.)
 | RemovePoint(Int32) | Removes a single point from this CurveItem. (Inherited from CurveItem.)
 | schema3 | Current schema value that defines the version of the serialized file
 | Symbol | Gets or sets the Symbol class instance defined for this LineItem. (Inherited from LineItem.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the CurveItem. ZedGraph does not use this value for any purpose. (Inherited from CurveItem.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValueAxis(GraphPane) | Returns a reference to the Axis object that is the "value" (dependent axis) from which the points are drawn. (Inherited from CurveItem.)
 | YAxisIndex | Gets or sets the index number of the Y Axis to which this CurveItem belongs. (Inherited from CurveItem.)
Remarks
The sticks run from the zero value of the Y axis, to the Y point defined in each PointPair of the IPointList (see Points). The properties of the sticks are defined in the Line property. Normally, the Symbol is not visible. However, if you manually enable the Symbol using the IsVisible property, the symbols will be drawn at the "Z" value from each PointPair (see Z).
Inheritance Hierarchy
Object
 | CurveItem
 |  | LineItem
 |  |  | StickItem


StickItem Constructor

StickItem Constructor
Namespaces ► ZedGraph ► StickItem ► StickItemStickItemNew()()
Members
Icon | Member | Description
 | StickItemStickItemNew(String) | Create a new StickItem, specifying only the legend Label.
 | StickItemStickItemNew(String, array<Double>[](), array<Double>[](), Color, Single) | Create a new StickItem using the specified properties.
 | StickItemStickItemNew(String, array<Double>[](), array<Double>[](), Color) | Create a new StickItem using the specified properties.
 | StickItemStickItemNew(String, IPointList, Color) | Create a new StickItem using the specified properties.
 | StickItemStickItemNew(String, IPointList, Color, Single) | Create a new StickItem using the specified properties.
 | StickItemStickItemNew(StickItem) | The Copy Constructor


StickItem Constructor (label)

StickItem Constructor (label)
Namespaces ► ZedGraph ► StickItem ► StickItemStickItemNew(String)
Create a new StickItem, specifying only the legend Label.
Declaration Syntax
C# Visual Basic Visual C++
public StickItem(
    string label
)
Public Sub New ( _
    label As String _
)
public:
StickItem (
    String^ label
)
Parameters
label (String)
The label that will appear in the legend.


StickItem Constructor (label, x, y, color)

StickItem Constructor (label, x, y, color)
Namespaces ► ZedGraph ► StickItem ► StickItemStickItemNew(String, array<Double>[](), array<Double>[](), Color)
Create a new StickItem using the specified properties.
Declaration Syntax
C# Visual Basic Visual C++
public StickItem(
    string label,
    double[] x,
    double[] y,
    Color color
)
Public Sub New ( _
    label As String, _
    x As Double(), _
    y As Double(), _
    color As Color _
)
public:
StickItem (
    String^ label,
    array<double>^ x,
    array<double>^ y,
    Color color
)
Parameters
label (String)
The label that will appear in the legend.
x (array< Double >[]())
An array of double precision values that define the independent (X axis) values for this curve
y (array< Double >[]())
An array of double precision values that define the dependent (Y axis) values for this curve
color (Color)
A Color value that will be applied to the Line and Symbol properties.


StickItem Constructor (label, x, y, color, lineWidth)

StickItem Constructor (label, x, y, color, lineWidth)
Namespaces ► ZedGraph ► StickItem ► StickItemStickItemNew(String, array<Double>[](), array<Double>[](), Color, Single)
Create a new StickItem using the specified properties.
Declaration Syntax
C# Visual Basic Visual C++
public StickItem(
    string label,
    double[] x,
    double[] y,
    Color color,
    float lineWidth
)
Public Sub New ( _
    label As String, _
    x As Double(), _
    y As Double(), _
    color As Color, _
    lineWidth As Single _
)
public:
StickItem (
    String^ label,
    array<double>^ x,
    array<double>^ y,
    Color color,
    float lineWidth
)
Parameters
label (String)
The label that will appear in the legend.
x (array< Double >[]())
An array of double precision values that define the independent (X axis) values for this curve
y (array< Double >[]())
An array of double precision values that define the dependent (Y axis) values for this curve
color (Color)
A Color value that will be applied to the Line and Symbol properties.
lineWidth (Single)
The width (in points) to be used for the Line. This width is scaled based on CalcScaleFactor()(). Use a value of zero to hide the line (see IsVisible).


StickItem Constructor (label, points, color)

StickItem Constructor (label, points, color)
Namespaces ► ZedGraph ► StickItem ► StickItemStickItemNew(String, IPointList, Color)
Create a new StickItem using the specified properties.
Declaration Syntax
C# Visual Basic Visual C++
public StickItem(
    string label,
    IPointList points,
    Color color
)
Public Sub New ( _
    label As String, _
    points As IPointList, _
    color As Color _
)
public:
StickItem (
    String^ label,
    IPointList^ points,
    Color color
)
Parameters
label (String)
The label that will appear in the legend.
points (IPointList)
A IPointList of double precision value pairs that define the X and Y values for this curve
color (Color)
A Color value that will be applied to the Line and Symbol properties.


StickItem Constructor (label, points, color, lineWidth)

StickItem Constructor (label, points, color, lineWidth)
Namespaces ► ZedGraph ► StickItem ► StickItemStickItemNew(String, IPointList, Color, Single)
Create a new StickItem using the specified properties.
Declaration Syntax
C# Visual Basic Visual C++
public StickItem(
    string label,
    IPointList points,
    Color color,
    float lineWidth
)
Public Sub New ( _
    label As String, _
    points As IPointList, _
    color As Color, _
    lineWidth As Single _
)
public:
StickItem (
    String^ label,
    IPointList^ points,
    Color color,
    float lineWidth
)
Parameters
label (String)
The label that will appear in the legend.
points (IPointList)
A IPointList of double precision value pairs that define the X and Y values for this curve
color (Color)
A Color value that will be applied to the Line and Symbol properties.
lineWidth (Single)
The width (in points) to be used for the Line. This width is scaled based on CalcScaleFactor()(). Use a value of zero to hide the line (see IsVisible).


StickItem Constructor (rhs)

StickItem Constructor (rhs)
Namespaces ► ZedGraph ► StickItem ► StickItemStickItemNew(StickItem)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public StickItem(
    StickItem rhs
)
Public Sub New ( _
    rhs As StickItem _
)
public:
StickItem (
    StickItem^ rhs
)
Parameters
rhs (StickItem)
The StickItem object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► StickItem ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public StickItem Clone()
Public Function Clone As StickItem
public:
StickItem^ Clone ()
Return Value
A new, independent copy of this class


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► StickItem ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


schema3 Field

schema3 Field
Namespaces ► ZedGraph ► StickItem ► schema3
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema3
Public Const schema3 As Integer
public:
literal int schema3


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► StickItem ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


StockPointList Class

StockPointList Class
Namespaces ► ZedGraph ► StockPointList
A collection class containing a list of StockPt objects that define the set of points to be displayed on the curve.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class StockPointList : List<StockPt>, IPointListEdit,
    IPointList, ICloneable
<SerializableAttribute> _
Public Class StockPointList _
    Inherits List(Of StockPt) _
    Implements IPointListEdit, IPointList, ICloneable
[SerializableAttribute]
public ref class StockPointList : public List<StockPt^>,
    IPointListEdit, IPointList, ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StockPointListStockPointListNew()() | Default constructor for the collection class
 | StockPointListStockPointListNew(StockPointList) | The Copy Constructor
 | Add(StockPt) | Add a StockPt object to the collection at the end of the list.
 | Add(PointPair) | Add a PointPair object to the collection at the end of the list.
 | Add(Double, Double) | Add a StockPt object to the collection at the end of the list using the specified values. The unspecified values (low, open, close) are all set to Missing.
 | Add(Double, Double, Double, Double, Double, Double) | Add a single point to the PointPairList from values of type double.
 | AddRange(IEnumerable<(Of <T>)>) | Adds the elements of the specified collection to the end of the List<(Of <T>)>. (Inherited from List <(Of < StockPt >)>.)
 | AsReadOnly()() | Returns a read-only IList<(Of <T>)> wrapper for the current collection. (Inherited from List <(Of < StockPt >)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < StockPt >)>.)
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of < StockPt >)>.)
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < StockPt >)>.)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of < StockPt >)>.)
 | Clear()() | Removes all elements from the List<(Of <T>)>. (Inherited from List <(Of < StockPt >)>.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Contains(T) | Determines whether an element is in the List<(Of <T>)>. (Inherited from List <(Of < StockPt >)>.)
 | ConvertAll<(Of <TOutput>)>(Converter<(Of <T, TOutput>)>) | Converts the elements in the current List<(Of <T>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of < StockPt >)>.)
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of < StockPt >)>.)
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < StockPt >)>.)
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < StockPt >)>.)
 | Count | Gets the number of elements actually contained in the List<(Of <T>)>. (Inherited from List <(Of < StockPt >)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <T>)>) | Determines whether the List<(Of <T>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < StockPt >)>.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < StockPt >)>.)
 | FindAll(Predicate<(Of <T>)>) | Retrieves the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < StockPt >)>.)
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < StockPt >)>.)
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < StockPt >)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < StockPt >)>.)
 | FindLast(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < StockPt >)>.)
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < StockPt >)>.)
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < StockPt >)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < StockPt >)>.)
 | ForEach(Action<(Of <T>)>) | Performs the specified action on each element of the List<(Of <T>)>. (Inherited from List <(Of < StockPt >)>.)
 | GetAt(Int32) | Access the StockPt at the specified ordinal index.
 | GetEnumerator()() | Returns an enumerator that iterates through the List<(Of <T>)>. (Inherited from List <(Of < StockPt >)>.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <T>)>. (Inherited from List <(Of < StockPt >)>.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < StockPt >)>.)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < StockPt >)>.)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < StockPt >)>.)
 | Insert(Int32, T) | Inserts an element into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < StockPt >)>.)
 | InsertRange(Int32, IEnumerable<(Of <T>)>) | Inserts the elements of a collection into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < StockPt >)>.)
 | Item[([Int32])] | Indexer to access the specified StockPt object by its ordinal position in the list.
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < StockPt >)>.)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < StockPt >)>.)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < StockPt >)>.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <T>)>. (Inherited from List <(Of < StockPt >)>.)
 | RemoveAll(Predicate<(Of <T>)>) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < StockPt >)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <T>)>. (Inherited from List <(Of < StockPt >)>.)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <T>)>. (Inherited from List <(Of < StockPt >)>.)
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>. (Inherited from List <(Of < StockPt >)>.)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of < StockPt >)>.)
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer. (Inherited from List <(Of < StockPt >)>.)
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < StockPt >)>.)
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < StockPt >)>.)
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>. (Inherited from List <(Of < StockPt >)>.)
 | ICollection<(Of <T>)>..::IsReadOnly | (Inherited from List <(Of < StockPt >)>.)
 | IEnumerable<(Of <T>)>..::GetEnumerator()() | (Inherited from List <(Of < StockPt >)>.)
 | ICollection..::CopyTo(Array, Int32) | (Inherited from List <(Of < StockPt >)>.)
 | ICollection..::IsSynchronized | (Inherited from List <(Of < StockPt >)>.)
 | ICollection..::SyncRoot | (Inherited from List <(Of < StockPt >)>.)
 | IEnumerable..::GetEnumerator()() | (Inherited from List <(Of < StockPt >)>.)
 | IList..::Add(Object) | (Inherited from List <(Of < StockPt >)>.)
 | IList..::Contains(Object) | (Inherited from List <(Of < StockPt >)>.)
 | IList..::IndexOf(Object) | (Inherited from List <(Of < StockPt >)>.)
 | IList..::Insert(Int32, Object) | (Inherited from List <(Of < StockPt >)>.)
 | IList..::IsFixedSize | (Inherited from List <(Of < StockPt >)>.)
 | IList..::IsReadOnly | (Inherited from List <(Of < StockPt >)>.)
 | IList..::Item[([Int32])] | (Inherited from List <(Of < StockPt >)>.)
 | IList..::Remove(Object) | (Inherited from List <(Of < StockPt >)>.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToArray()() | Copies the elements of the List<(Of <T>)> to a new array. (Inherited from List <(Of < StockPt >)>.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()() | Sets the capacity to the actual number of elements in the List<(Of <T>)>, if that number is less than a threshold value. (Inherited from List <(Of < StockPt >)>.)
 | TrueForAll(Predicate<(Of <T>)>) | Determines whether every element in the List<(Of <T>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of < StockPt >)>.)
Inheritance Hierarchy
Object
 | List <(Of < StockPt >)>
 |  | StockPointList


StockPointList Constructor

StockPointList Constructor
Namespaces ► ZedGraph ► StockPointList ► StockPointListStockPointListNew()()
Members
Icon | Member | Description
 | StockPointListStockPointListNew()() | Default constructor for the collection class
 | StockPointListStockPointListNew(StockPointList) | The Copy Constructor


StockPointList Constructor

StockPointList Constructor
Namespaces ► ZedGraph ► StockPointList ► StockPointListStockPointListNew()()
Default constructor for the collection class
Declaration Syntax
C# Visual Basic Visual C++
public StockPointList()
Public Sub New
public:
StockPointList ()


StockPointList Constructor (rhs)

StockPointList Constructor (rhs)
Namespaces ► ZedGraph ► StockPointList ► StockPointListStockPointListNew(StockPointList)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public StockPointList(
    StockPointList rhs
)
Public Sub New ( _
    rhs As StockPointList _
)
public:
StockPointList (
    StockPointList^ rhs
)
Parameters
rhs (StockPointList)
The StockPointList from which to copy


Add Method

Add Method
Namespaces ► ZedGraph ► StockPointList ► Add()()
Members
Icon | Member | Description
 | Add(StockPt) | Add a StockPt object to the collection at the end of the list.
 | Add(PointPair) | Add a PointPair object to the collection at the end of the list.
 | Add(Double, Double) | Add a StockPt object to the collection at the end of the list using the specified values. The unspecified values (low, open, close) are all set to Missing.
 | Add(Double, Double, Double, Double, Double, Double) | Add a single point to the PointPairList from values of type double.


Add Method (date, high)

Add Method (date, high)
Namespaces ► ZedGraph ► StockPointList ► Add(Double, Double)
Add a StockPt object to the collection at the end of the list using the specified values. The unspecified values (low, open, close) are all set to Missing.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    double date,
    double high
)
Public Sub Add ( _
    date As Double, _
    high As Double _
)
public:
virtual void Add (
    double date,
    double high
) sealed
Parameters
date (Double)
An XDate value
high (Double)
The high value for the day
Return Value
The zero-based ordinal index where the point was added in the list.


Add Method (date, high, low, open, close, vol)

Add Method (date, high, low, open, close, vol)
Namespaces ► ZedGraph ► StockPointList ► Add(Double, Double, Double, Double, Double, Double)
Add a single point to the PointPairList from values of type double.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    double date,
    double high,
    double low,
    double open,
    double close,
    double vol
)
Public Sub Add ( _
    date As Double, _
    high As Double, _
    low As Double, _
    open As Double, _
    close As Double, _
    vol As Double _
)
public:
void Add (
    double date,
    double high,
    double low,
    double open,
    double close,
    double vol
)
Parameters
date (Double)
An XDate value
high (Double)
The high value for the day
low (Double)
The low value for the day
open (Double)
The opening value for the day
close (Double)
The closing value for the day
vol (Double)
The trading volume for the day
Return Value
The zero-based ordinal index where the point was added in the list.


Add Method (point)

Add Method (point)
Namespaces ► ZedGraph ► StockPointList ► Add(PointPair)
Add a PointPair object to the collection at the end of the list.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    PointPair point
)
Public Sub Add ( _
    point As PointPair _
)
public:
virtual void Add (
    PointPair^ point
) sealed
Parameters
point (PointPair)
The PointPair object to be added


Add Method (point)

Add Method (point)
Namespaces ► ZedGraph ► StockPointList ► Add(StockPt)
Add a StockPt object to the collection at the end of the list.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    StockPt point
)
Public Sub Add ( _
    point As StockPt _
)
public:
void Add (
    StockPt^ point
)
Parameters
point (StockPt)
The StockPt object to be added


Clone Method

Clone Method
Namespaces ► ZedGraph ► StockPointList ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public StockPointList Clone()
Public Function Clone As StockPointList
public:
StockPointList^ Clone ()
Return Value
A new, independent copy of this class


GetAt Method (index)

GetAt Method (index)
Namespaces ► ZedGraph ► StockPointList ► GetAt(Int32)
Access the StockPt at the specified ordinal index.
Declaration Syntax
C# Visual Basic Visual C++
public StockPt GetAt(
    int index
)
Public Function GetAt ( _
    index As Integer _
) As StockPt
public:
StockPt^ GetAt (
    int index
)
Parameters
index (Int32)
The ordinal position (zero-based) in the list
Return Value
The specified StockPt.
Remarks
To be compatible with the IPointList interface, the StockPointList must implement an index that returns a PointPair rather than a StockPt. This method will return the actual StockPt at the specified position.


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph ► StockPointList ► Item[([Int32])]
Indexer to access the specified StockPt object by its ordinal position in the list.
Declaration Syntax
C# Visual Basic Visual C++
public PointPair this[
    int index
]{ get; set;}
Public Default Property Item ( _
    index As Integer _
) As PointPair
public:
virtual property PointPair^ default[int index] {
    PointPair^ get (int index) sealed;
    void set (int index, PointPair^ value) sealed;
}
Parameters
index (Int32)
The ordinal position (zero-based) of the StockPt object to be accessed.
Value
A StockPt object reference.


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► StockPointList ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


StockPt Class

StockPt Class
Namespaces ► ZedGraph ► StockPt
The basic PointPair class holds three data values (X, Y, Z). This class extends the basic PointPair to contain five data values (X, Y, Z, Open, Close).
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class StockPt : PointPair, ISerializable
<SerializableAttribute> _
Public Class StockPt _
    Inherits PointPair _
    Implements ISerializable
[SerializableAttribute]
public ref class StockPt : public PointPair,
    ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StockPtStockPtNew()() | Default Constructor
 | StockPtStockPtNew(Double, Double, Double, Double, Double, Double) | Construct a new StockPt from the specified data values
 | StockPtStockPtNew(Double, Double, Double, Double, Double, Double, String) | Construct a new StockPt from the specified data values including a Tag property
 | StockPtStockPtNew(StockPt) | The StockPt copy constructor.
 | StockPtStockPtNew(PointPair) | The StockPt copy constructor.
 | Clone()() | Typesafe, deep-copy clone method. (Inherited from PointPair.)
 | Close | This closing value
 | ColorValue | The ColorValue property. This is used with the GradientByColorValue option. (Overrides PointPair.ColorValue.)
 | Date | Map the Date property to the X value
 | Equals(Object) | Compare two PointPair objects for equality. To be equal, X, Y, and Z must be exactly the same between the two objects. (Inherited from PointPair.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Return the HashCode from the base class. (Inherited from PointPair.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides PointPair.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | High | Map the high property to the Y value
 | IsInvalid | Readonly value that determines if either the X or the Y coordinate in this PointPair is an invalid (not plotable) value. It is considered invalid if it is missing (equal to System.Double.Max), Infinity, or NaN. (Inherited from PointPairBase.)
 | IsInvalid3D | Readonly value that determines if either the X, Y, or Z coordinate in this PointPair is an invalid (not plotable) value. It is considered invalid if it is missing (equal to System.Double.Max), Infinity, or NaN. (Inherited from PointPair.)
 | IsInvalid5D | Readonly value that determines if either the Date, Close, Open, High, or Low coordinate in this StockPt is an invalid (not plotable) value. It is considered invalid if it is missing (equal to System.Double.Max), Infinity, or NaN.
 | IsMissing | Readonly value that determines if either the X or the Y coordinate in this PointPair is a missing value. (Inherited from PointPairBase.)
 | Low | Map the low property to the Z value
 | LowValue | The "low" value for this point (lower dependent-axis value). This is really just an alias for Z. (Inherited from PointPair.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Open | This opening value
 | schema3 | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()() (Inherited from PointPair.)
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the PointPair. ZedGraph never modifies this value, but if it is a String type, it may be displayed in a ToolTip within the ZedGraphControl object. (Inherited from PointPair.)
 | ToString(Boolean) | Format this StockPt value using the default format. Example: "( 12.345, -16.876 )". The two double values are formatted with the "g" format type. (Overrides PointPair.ToString(Boolean).)
 | ToString(String, Boolean) | Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". If is true, then the third all coordinates are shown. (Overrides PointPair.ToString(String, Boolean).)
 | ToString(String, String, String) | Format this PointPair value using different general format strings for the X, Y, and Z values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". (Inherited from PointPair.)
 | ToString(String) | Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". (Inherited from PointPairBase.)
 | ToString(String, String) | Format this PointPair value using different general format strings for the X and Y values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". The Z value is not displayed (see ToString(String, String, String)). (Inherited from PointPairBase.)
 | Vol | This daily trading volume
 | X | This PointPair's X coordinate (Inherited from PointPairBase.)
 | Y | This PointPair's Y coordinate (Inherited from PointPairBase.)
 | Z | This PointPair's Z coordinate. Also used for the lower value (dependent axis) for HiLowBarItem and ErrorBarItem charts. (Inherited from PointPair.)
Remarks
The values are remapped to Date, High, Low, Open, and Close.
Inheritance Hierarchy
Object
 | PointPairBase
 |  | PointPair
 |  |  | StockPt


StockPt Constructor

StockPt Constructor
Namespaces ► ZedGraph ► StockPt ► StockPtStockPtNew()()
Members
Icon | Member | Description
 | StockPtStockPtNew()() | Default Constructor
 | StockPtStockPtNew(Double, Double, Double, Double, Double, Double) | Construct a new StockPt from the specified data values
 | StockPtStockPtNew(Double, Double, Double, Double, Double, Double, String) | Construct a new StockPt from the specified data values including a Tag property
 | StockPtStockPtNew(StockPt) | The StockPt copy constructor.
 | StockPtStockPtNew(PointPair) | The StockPt copy constructor.


StockPt Constructor

StockPt Constructor
Namespaces ► ZedGraph ► StockPt ► StockPtStockPtNew()()
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public StockPt()
Public Sub New
public:
StockPt ()


StockPt Constructor (date, high, low, open, close, vol)

StockPt Constructor (date, high, low, open, close, vol)
Namespaces ► ZedGraph ► StockPt ► StockPtStockPtNew(Double, Double, Double, Double, Double, Double)
Construct a new StockPt from the specified data values
Declaration Syntax
C# Visual Basic Visual C++
public StockPt(
    double date,
    double high,
    double low,
    double open,
    double close,
    double vol
)
Public Sub New ( _
    date As Double, _
    high As Double, _
    low As Double, _
    open As Double, _
    close As Double, _
    vol As Double _
)
public:
StockPt (
    double date,
    double high,
    double low,
    double open,
    double close,
    double vol
)
Parameters
date (Double)
The trading date (XDate)
high (Double)
The daily high stock price
low (Double)
The daily low stock price
open (Double)
The opening stock price
close (Double)
The closing stock price
vol (Double)
The daily trading volume


StockPt Constructor (date, high, low, open, close, vol, tag)

StockPt Constructor (date, high, low, open, close, vol, tag)
Namespaces ► ZedGraph ► StockPt ► StockPtStockPtNew(Double, Double, Double, Double, Double, Double, String)
Construct a new StockPt from the specified data values including a Tag property
Declaration Syntax
C# Visual Basic Visual C++
public StockPt(
    double date,
    double high,
    double low,
    double open,
    double close,
    double vol,
    string tag
)
Public Sub New ( _
    date As Double, _
    high As Double, _
    low As Double, _
    open As Double, _
    close As Double, _
    vol As Double, _
    tag As String _
)
public:
StockPt (
    double date,
    double high,
    double low,
    double open,
    double close,
    double vol,
    String^ tag
)
Parameters
date (Double)
The trading date (XDate)
high (Double)
The daily high stock price
low (Double)
The daily low stock price
open (Double)
The opening stock price
close (Double)
The closing stock price
vol (Double)
The daily trading volume
tag (String)
The user-defined Tag property.


StockPt Constructor (rhs)

StockPt Constructor (rhs)
Namespaces ► ZedGraph ► StockPt ► StockPtStockPtNew(PointPair)
The StockPt copy constructor.
Declaration Syntax
C# Visual Basic Visual C++
public StockPt(
    PointPair rhs
)
Public Sub New ( _
    rhs As PointPair _
)
public:
StockPt (
    PointPair^ rhs
)
Parameters
rhs (PointPair)
The basis for the copy.


StockPt Constructor (rhs)

StockPt Constructor (rhs)
Namespaces ► ZedGraph ► StockPt ► StockPtStockPtNew(StockPt)
The StockPt copy constructor.
Declaration Syntax
C# Visual Basic Visual C++
public StockPt(
    StockPt rhs
)
Public Sub New ( _
    rhs As StockPt _
)
public:
StockPt (
    StockPt^ rhs
)
Parameters
rhs (StockPt)
The basis for the copy.


Close Field

Close Field
Namespaces ► ZedGraph ► StockPt ► Close
This closing value
Declaration Syntax
C# Visual Basic Visual C++
public double Close
Public Close As Double
public:
double Close


ColorValue Property

ColorValue Property
Namespaces ► ZedGraph ► StockPt ► ColorValue
The ColorValue property. This is used with the GradientByColorValue option.
Declaration Syntax
C# Visual Basic Visual C++
public override double ColorValue{ get; set;}
Public Overrides Property ColorValue As Double
public:
virtual property double ColorValue {
    double get () override;
    void set (double value) override;
}


Date Property

Date Property
Namespaces ► ZedGraph ► StockPt ► Date
Map the Date property to the X value
Declaration Syntax
C# Visual Basic Visual C++
public double Date{ get; set;}
Public Property Date As Double
public:
property double Date {
    double get ();
    void set (double value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► StockPt ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


High Property

High Property
Namespaces ► ZedGraph ► StockPt ► High
Map the high property to the Y value
Declaration Syntax
C# Visual Basic Visual C++
public double High{ get; set;}
Public Property High As Double
public:
property double High {
    double get ();
    void set (double value);
}


IsInvalid5D Property

IsInvalid5D Property
Namespaces ► ZedGraph ► StockPt ► IsInvalid5D
Readonly value that determines if either the Date, Close, Open, High, or Low coordinate in this StockPt is an invalid (not plotable) value. It is considered invalid if it is missing (equal to System.Double.Max), Infinity, or NaN.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInvalid5D{ get;}
Public ReadOnly Property IsInvalid5D As Boolean
public:
property bool IsInvalid5D {
    bool get ();
}
Return Value
true if any value is invalid


Low Property

Low Property
Namespaces ► ZedGraph ► StockPt ► Low
Map the low property to the Z value
Declaration Syntax
C# Visual Basic Visual C++
public double Low{ get; set;}
Public Property Low As Double
public:
property double Low {
    double get ();
    void set (double value);
}


Open Field

Open Field
Namespaces ► ZedGraph ► StockPt ► Open
This opening value
Declaration Syntax
C# Visual Basic Visual C++
public double Open
Public Open As Double
public:
double Open


schema3 Field

schema3 Field
Namespaces ► ZedGraph ► StockPt ► schema3
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema3
Public Const schema3 As Integer
public:
literal int schema3


ToString Method

ToString Method
Namespaces ► ZedGraph ► StockPt ► ToString()()
Members
Icon | Member | Description
 | ToString(Boolean) | Format this StockPt value using the default format. Example: "( 12.345, -16.876 )". The two double values are formatted with the "g" format type. (Overrides PointPair.ToString(Boolean).)
 | ToString(String, Boolean) | Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". If is true, then the third all coordinates are shown. (Overrides PointPair.ToString(String, Boolean).)
 | ToString(String, String, String) | Format this PointPair value using different general format strings for the X, Y, and Z values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )".
 | ToString(String) | Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )".
 | ToString(String, String) | Format this PointPair value using different general format strings for the X and Y values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". The Z value is not displayed (see ToString(String, String, String)).


ToString Method (isShowAll)

ToString Method (isShowAll)
Namespaces ► ZedGraph ► StockPt ► ToString(Boolean)
Format this StockPt value using the default format. Example: "( 12.345, -16.876 )". The two double values are formatted with the "g" format type.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString(
    bool isShowAll
)
Public Overrides Function ToString ( _
    isShowAll As Boolean _
) As String
public:
virtual String^ ToString (
    bool isShowAll
) override
Parameters
isShowAll (Boolean)
true to show all the value coordinates
Return Value
A string representation of the StockPt.


ToString Method (format, isShowAll)

ToString Method (format, isShowAll)
Namespaces ► ZedGraph ► StockPt ► ToString(String, Boolean)
Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". If is true, then the third all coordinates are shown.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString(
    string format,
    bool isShowAll
)
Public Overrides Function ToString ( _
    format As String, _
    isShowAll As Boolean _
) As String
public:
virtual String^ ToString (
    String^ format,
    bool isShowAll
) override
Parameters
format (String)
A format string that will be used to format each of the two double type values (see ToString()()).
isShowAll (Boolean)
true to show all the value coordinates
Return Value
A string representation of the PointPair


Vol Field

Vol Field
Namespaces ► ZedGraph ► StockPt ► Vol
This daily trading volume
Declaration Syntax
C# Visual Basic Visual C++
public double Vol
Public Vol As Double
public:
double Vol


Symbol Class

Symbol Class
Namespaces ► ZedGraph ► Symbol
This class handles the drawing of the curve Symbol objects. The symbols are the small shapes that appear over each defined point along the curve.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Symbol : ICloneable, ISerializable
<SerializableAttribute> _
Public Class Symbol _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class Symbol : ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SymbolSymbolNew()() | Default constructor that sets all Symbol properties to default values as defined in the Symbol..::Default class.
 | SymbolSymbolNew(SymbolType, Color) | Default constructor that sets the SymbolType and Color as specified, and the remaining Symbol properties to default values as defined in the Symbol..::Default class.
 | SymbolSymbolNew(Symbol) | The Copy Constructor
 | Border | Gets or sets the Border data for this Symbol, which controls the border outline of the symbol.
 | Clone()() | Typesafe, deep-copy clone method.
 | Draw(Graphics, GraphPane, LineItem, Single, Boolean) | Draw this CurveItem to the specified Graphics device as a symbol at each defined point. The routine only draws the symbols; the lines are draw by the DrawCurve(Graphics, GraphPane, CurveItem, Single) method. This method is normally only called by the Draw method of the CurveItem object
 | DrawSymbol(Graphics, GraphPane, Int32, Int32, Single, Boolean, PointPair) | Draw the Symbol to the specified Graphics device at the specified location. This routine draws a single symbol.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Gets or sets the Fill data for this Symbol.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAntiAlias | Gets or sets a value that determines if the symbols are drawn using Anti-Aliasing capabilities from the Graphics class.
 | IsVisible | Gets or sets a property that shows or hides the Symbol.
 | MakePath(Graphics, Single) | Create a GraphicsPath struct for the current symbol based on the specified scaleFactor and assuming the symbol will be centered at position 0,0.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | schema | Current schema value that defines the version of the serialized file
 | Size | Gets or sets the size of the Symbol
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets or sets the type (shape) of the Symbol
Inheritance Hierarchy
Object
Symbol


Symbol Constructor

Symbol Constructor
Namespaces ► ZedGraph ► Symbol ► SymbolSymbolNew()()
Members
Icon | Member | Description
 | SymbolSymbolNew()() | Default constructor that sets all Symbol properties to default values as defined in the Symbol..::Default class.
 | SymbolSymbolNew(SymbolType, Color) | Default constructor that sets the SymbolType and Color as specified, and the remaining Symbol properties to default values as defined in the Symbol..::Default class.
 | SymbolSymbolNew(Symbol) | The Copy Constructor


Symbol Constructor

Symbol Constructor
Namespaces ► ZedGraph ► Symbol ► SymbolSymbolNew()()
Default constructor that sets all Symbol properties to default values as defined in the Symbol..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public Symbol()
Public Sub New
public:
Symbol ()


Symbol Constructor (rhs)

Symbol Constructor (rhs)
Namespaces ► ZedGraph ► Symbol ► SymbolSymbolNew(Symbol)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public Symbol(
    Symbol rhs
)
Public Sub New ( _
    rhs As Symbol _
)
public:
Symbol (
    Symbol^ rhs
)
Parameters
rhs (Symbol)
The Symbol object from which to copy


Symbol Constructor (type, color)

Symbol Constructor (type, color)
Namespaces ► ZedGraph ► Symbol ► SymbolSymbolNew(SymbolType, Color)
Default constructor that sets the SymbolType and Color as specified, and the remaining Symbol properties to default values as defined in the Symbol..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public Symbol(
    SymbolType type,
    Color color
)
Public Sub New ( _
    type As SymbolType, _
    color As Color _
)
public:
Symbol (
    SymbolType type,
    Color color
)
Parameters
type (SymbolType)
A SymbolType enum value indicating the shape of the symbol
color (Color)
A Color value indicating the color of the symbol


Border Property

Border Property
Namespaces ► ZedGraph ► Symbol ► Border
Gets or sets the Border data for this Symbol, which controls the border outline of the symbol.
Declaration Syntax
C# Visual Basic Visual C++
public Border Border{ get; set;}
Public Property Border As Border
public:
property Border^ Border {
    Border^ get ();
    void set (Border^ value);
}


Clone Method

Clone Method
Namespaces ► ZedGraph ► Symbol ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public Symbol Clone()
Public Function Clone As Symbol
public:
Symbol^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, curve, scaleFactor, isSelected)

Draw Method (g, pane, curve, scaleFactor, isSelected)
Namespaces ► ZedGraph ► Symbol ► Draw(Graphics, GraphPane, LineItem, Single, Boolean)
Draw this CurveItem to the specified Graphics device as a symbol at each defined point. The routine only draws the symbols; the lines are draw by the DrawCurve(Graphics, GraphPane, CurveItem, Single) method. This method is normally only called by the Draw method of the CurveItem object
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Graphics g,
    GraphPane pane,
    LineItem curve,
    float scaleFactor,
    bool isSelected
)
Public Sub Draw ( _
    g As Graphics, _
    pane As GraphPane, _
    curve As LineItem, _
    scaleFactor As Single, _
    isSelected As Boolean _
)
public:
void Draw (
    Graphics^ g,
    GraphPane^ pane,
    LineItem^ curve,
    float scaleFactor,
    bool isSelected
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
curve (LineItem)
A LineItem representing this curve.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
isSelected (Boolean)
Indicates that the Symbol should be drawn with attributes from the Selection class.


DrawSymbol Method (g, pane, x, y, scaleFactor, isSelected, dataValue)

DrawSymbol Method (g, pane, x, y, scaleFactor, isSelected, dataValue)
Namespaces ► ZedGraph ► Symbol ► DrawSymbol(Graphics, GraphPane, Int32, Int32, Single, Boolean, PointPair)
Draw the Symbol to the specified Graphics device at the specified location. This routine draws a single symbol.
Declaration Syntax
C# Visual Basic Visual C++
public void DrawSymbol(
    Graphics g,
    GraphPane pane,
    int x,
    int y,
    float scaleFactor,
    bool isSelected,
    PointPair dataValue
)
Public Sub DrawSymbol ( _
    g As Graphics, _
    pane As GraphPane, _
    x As Integer, _
    y As Integer, _
    scaleFactor As Single, _
    isSelected As Boolean, _
    dataValue As PointPair _
)
public:
void DrawSymbol (
    Graphics^ g,
    GraphPane^ pane,
    int x,
    int y,
    float scaleFactor,
    bool isSelected,
    PointPair^ dataValue
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
x (Int32)
The x position of the center of the symbol in pixel units
y (Int32)
The y position of the center of the symbol in pixel units
scaleFactor (Single)
The scaling factor for the features of the graph based on the BaseDimension. This scaling factor is calculated by the CalcScaleFactor()() method. The scale factor represents a linear multiple to be applied to font sizes, symbol sizes, etc.
isSelected (Boolean)
Indicates that the Symbol should be drawn with attributes from the Selection class.
dataValue (PointPair)
The data value to be used for a value-based color gradient. This is only applicable for GradientByX, GradientByY or GradientByZ.


Fill Property

Fill Property
Namespaces ► ZedGraph ► Symbol ► Fill
Gets or sets the Fill data for this Symbol.
Declaration Syntax
C# Visual Basic Visual C++
public Fill Fill{ get; set;}
Public Property Fill As Fill
public:
property Fill^ Fill {
    Fill^ get ();
    void set (Fill^ value);
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► Symbol ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


IsAntiAlias Property

IsAntiAlias Property
Namespaces ► ZedGraph ► Symbol ► IsAntiAlias
Gets or sets a value that determines if the symbols are drawn using Anti-Aliasing capabilities from the Graphics class.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAntiAlias{ get; set;}
Public Property IsAntiAlias As Boolean
public:
property bool IsAntiAlias {
    bool get ();
    void set (bool value);
}
Remarks
If this value is set to true, then the SmoothingMode property will be set to HighQuality only while this Symbol is drawn. A value of false will leave the value of SmoothingMode unchanged.


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph ► Symbol ► IsVisible
Gets or sets a property that shows or hides the Symbol.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
Value
true to show the symbol, false to hide it
See Also
IsVisible


MakePath Method (g, scaleFactor)

MakePath Method (g, scaleFactor)
Namespaces ► ZedGraph ► Symbol ► MakePath(Graphics, Single)
Create a GraphicsPath struct for the current symbol based on the specified scaleFactor and assuming the symbol will be centered at position 0,0.
Declaration Syntax
C# Visual Basic Visual C++
public GraphicsPath MakePath(
    Graphics g,
    float scaleFactor
)
Public Function MakePath ( _
    g As Graphics, _
    scaleFactor As Single _
) As GraphicsPath
public:
GraphicsPath^ MakePath (
    Graphics^ g,
    float scaleFactor
)
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
scaleFactor (Single)
The scaling factor for the features of the graph based on the BaseDimension. This scaling factor is calculated by the CalcScaleFactor()() method. The scale factor represents a linear multiple to be applied to font sizes, symbol sizes, etc.
Return Value
Returns the GraphicsPath for the current symbol


schema Field

schema Field
Namespaces ► ZedGraph ► Symbol ► schema
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema
Public Const schema As Integer
public:
literal int schema


Size Property

Size Property
Namespaces ► ZedGraph ► Symbol ► Size
Gets or sets the size of the Symbol
Declaration Syntax
C# Visual Basic Visual C++
public float Size{ get; set;}
Public Property Size As Single
public:
property float Size {
    float get ();
    void set (float value);
}
Value
Size in points (1/72 inch)
See Also
Size


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► Symbol ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Type Property

Type Property
Namespaces ► ZedGraph ► Symbol ► Type
Gets or sets the type (shape) of the Symbol
Declaration Syntax
C# Visual Basic Visual C++
public SymbolType Type{ get; set;}
Public Property Type As SymbolType
public:
property SymbolType Type {
    SymbolType get ();
    void set (SymbolType value);
}
Value
A SymbolType enum value indicating the shape
See Also
Type


Symbol.Default Structure

Symbol..::Default Structure
Namespaces ► ZedGraph ► Symbol ► Symbol..::Default
A simple struct that defines the default property values for the Symbol class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BorderColor | The default color for drawing symbols (Color property).
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | FillBrush | The default custom brush for filling in this Symbol (Brush property).
 | FillColor | The default color for filling in this Symbol (Color property).
 | FillType | The default fill mode for the curve (Type property).
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAntiAlias | The default value for the IsAntiAlias property.
 | IsBorderVisible | The default for drawing frames around symbols (IsVisible property). true to display symbol frames, false to hide them.
 | IsVisible | The default display mode for symbols (IsVisible property). true to display symbols, false to hide them.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PenWidth | The default pen width to be used for drawing curve symbols (Width property). Units are points.
 | Size | The default size for curve symbols (Size property), in units of points.
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | Type | The default symbol type for curves (Type property). This is defined as a SymbolType enumeration.


BorderColor Field

BorderColor Field
Namespaces ► ZedGraph ► Symbol..::Default ► BorderColor
The default color for drawing symbols (Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color BorderColor
Public Shared BorderColor As Color
public:
static Color BorderColor


FillBrush Field

FillBrush Field
Namespaces ► ZedGraph ► Symbol..::Default ► FillBrush
The default custom brush for filling in this Symbol (Brush property).
Declaration Syntax
C# Visual Basic Visual C++
public static Brush FillBrush
Public Shared FillBrush As Brush
public:
static Brush^ FillBrush


FillColor Field

FillColor Field
Namespaces ► ZedGraph ► Symbol..::Default ► FillColor
The default color for filling in this Symbol (Color property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color FillColor
Public Shared FillColor As Color
public:
static Color FillColor


FillType Field

FillType Field
Namespaces ► ZedGraph ► Symbol..::Default ► FillType
The default fill mode for the curve (Type property).
Declaration Syntax
C# Visual Basic Visual C++
public static FillType FillType
Public Shared FillType As FillType
public:
static FillType FillType


IsAntiAlias Field

IsAntiAlias Field
Namespaces ► ZedGraph ► Symbol..::Default ► IsAntiAlias
The default value for the IsAntiAlias property.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsAntiAlias
Public Shared IsAntiAlias As Boolean
public:
static bool IsAntiAlias


IsBorderVisible Field

IsBorderVisible Field
Namespaces ► ZedGraph ► Symbol..::Default ► IsBorderVisible
The default for drawing frames around symbols (IsVisible property). true to display symbol frames, false to hide them.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsBorderVisible
Public Shared IsBorderVisible As Boolean
public:
static bool IsBorderVisible


IsVisible Field

IsVisible Field
Namespaces ► ZedGraph ► Symbol..::Default ► IsVisible
The default display mode for symbols (IsVisible property). true to display symbols, false to hide them.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsVisible
Public Shared IsVisible As Boolean
public:
static bool IsVisible


PenWidth Field

PenWidth Field
Namespaces ► ZedGraph ► Symbol..::Default ► PenWidth
The default pen width to be used for drawing curve symbols (Width property). Units are points.
Declaration Syntax
C# Visual Basic Visual C++
public static float PenWidth
Public Shared PenWidth As Single
public:
static float PenWidth


Size Field

Size Field
Namespaces ► ZedGraph ► Symbol..::Default ► Size
The default size for curve symbols (Size property), in units of points.
Declaration Syntax
C# Visual Basic Visual C++
public static float Size
Public Shared Size As Single
public:
static float Size


Type Field

Type Field
Namespaces ► ZedGraph ► Symbol..::Default ► Type
The default symbol type for curves (Type property). This is defined as a SymbolType enumeration.
Declaration Syntax
C# Visual Basic Visual C++
public static SymbolType Type
Public Shared Type As SymbolType
public:
static SymbolType Type


SymbolType Enumeration

SymbolType Enumeration
Namespaces ► ZedGraph ► SymbolType
Enumeration type for the various symbol shapes that are available
Declaration Syntax
C# Visual Basic Visual C++
public enum SymbolType
Public Enumeration SymbolType
public enum class SymbolType
Members
Member | Description
Square | Square-shaped Symbol
Diamond | Rhombus-shaped Symbol
Triangle | Equilateral triangle Symbol
Circle | Uniform circle Symbol
XCross | "X" shaped Symbol. This symbol cannot be filled since it has no outline.
Plus | "+" shaped Symbol. This symbol cannot be filled since it has no outline.
Star | Asterisk-shaped Symbol. This symbol cannot be filled since it has no outline.
TriangleDown | Unilateral triangle Symbol, pointing down.
HDash | Horizontal dash Symbol. This symbol cannot be filled since it has no outline.
VDash | Vertical dash Symbol. This symbol cannot be filled since it has no outline.
Default | A Default symbol type (the symbol type will be obtained from Type.
None | No symbol is shown (this is equivalent to using IsVisible = false.
See Also
Fill


TextObj Class

TextObj Class
Namespaces ► ZedGraph ► TextObj
A class that represents a text object on the graph. A list of GraphObj objects is maintained by the GraphObjList collection class.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TextObj : GraphObj, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class TextObj _
    Inherits GraphObj _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class TextObj : public GraphObj,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TextObjTextObjNew(String, Double, Double) | Constructor that sets all TextObj properties to default values as defined in the TextObj..::Default class.
 | TextObjTextObjNew(String, Double, Double, CoordType) | Constructor that sets all TextObj properties to default values as defined in the TextObj..::Default class.
 | TextObjTextObjNew(String, Double, Double, CoordType, AlignH, AlignV) | Constructor that sets all TextObj properties to default values as defined in the TextObj..::Default class.
 | TextObjTextObjNew()() | Parameterless constructor that initializes a new TextObj.
 | TextObjTextObjNew(TextObj) | The Copy Constructor
 | Clone()() | Typesafe, deep-copy clone method.
 | Draw(Graphics, PaneBase, Single) | Render this TextObj object to the specified Graphics device This method is normally only called by the Draw method of the parent GraphObjList collection object. (Overrides GraphObj.Draw(Graphics, PaneBase, Single).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontSpec | Gets a reference to the FontSpec class used to render this TextObj
 | GetCoords(PaneBase, Graphics, Single, String%, String%) | Determines the shape type and Coords values for this GraphObj (Overrides GraphObj.GetCoords(PaneBase, Graphics, Single, String%, String%).)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides GraphObj.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsClippedToChartRect | Gets or sets a value that determines whether or not the rendering of this GraphObj will be clipped to the Rect. (Inherited from GraphObj.)
 | IsInFrontOfData | true if the ZOrder of this object is set to put it in front of the CurveItem data points. (Inherited from GraphObj.)
 | IsVisible | Gets or sets a value that determines if this GraphObj will be visible in the graph. true displays the item, false hides it. (Inherited from GraphObj.)
 | LayoutArea |
 | Link | Gets or sets the hyperlink information for this GraphObj. (Inherited from GraphObj.)
 | Location | The Location struct that describes the location for this GraphObj. (Inherited from GraphObj.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PointInBox(PointF, PaneBase, Graphics, Single) | Determine if the specified screen point lies inside the bounding box of this TextObj. This method takes into account rotation and alignment parameters of the text, as specified in the FontSpec. (Overrides GraphObj.PointInBox(PointF, PaneBase, Graphics, Single).)
 | schema2 | Current schema value that defines the version of the serialized file
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the GraphObj. ZedGraph does not use this value for any purpose. (Inherited from GraphObj.)
 | Text | The TextObj to be displayed. This text can be multi-line by including newline ('\n') characters between the lines.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ZOrder | Gets or sets a value that determines the z-order "depth" of this item relative to other graphic objects. (Inherited from GraphObj.)
Inheritance Hierarchy
Object
 | GraphObj
 |  | TextObj


TextObj Constructor

TextObj Constructor
Namespaces ► ZedGraph ► TextObj ► TextObjTextObjNew()()
Members
Icon | Member | Description
 | TextObjTextObjNew(String, Double, Double) | Constructor that sets all TextObj properties to default values as defined in the TextObj..::Default class.
 | TextObjTextObjNew(String, Double, Double, CoordType) | Constructor that sets all TextObj properties to default values as defined in the TextObj..::Default class.
 | TextObjTextObjNew(String, Double, Double, CoordType, AlignH, AlignV) | Constructor that sets all TextObj properties to default values as defined in the TextObj..::Default class.
 | TextObjTextObjNew()() | Parameterless constructor that initializes a new TextObj.
 | TextObjTextObjNew(TextObj) | The Copy Constructor


TextObj Constructor

TextObj Constructor
Namespaces ► ZedGraph ► TextObj ► TextObjTextObjNew()()
Parameterless constructor that initializes a new TextObj.
Declaration Syntax
C# Visual Basic Visual C++
public TextObj()
Public Sub New
public:
TextObj ()


TextObj Constructor (text, x, y)

TextObj Constructor (text, x, y)
Namespaces ► ZedGraph ► TextObj ► TextObjTextObjNew(String, Double, Double)
Constructor that sets all TextObj properties to default values as defined in the TextObj..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public TextObj(
    string text,
    double x,
    double y
)
Public Sub New ( _
    text As String, _
    x As Double, _
    y As Double _
)
public:
TextObj (
    String^ text,
    double x,
    double y
)
Parameters
text (String)
The text to be displayed.
x (Double)
The x position of the text. The units of this position are specified by the CoordinateFrame property. The text will be aligned to this position based on the AlignH property.
y (Double)
The y position of the text. The units of this position are specified by the CoordinateFrame property. The text will be aligned to this position based on the AlignV property.


TextObj Constructor (text, x, y, coordType)

TextObj Constructor (text, x, y, coordType)
Namespaces ► ZedGraph ► TextObj ► TextObjTextObjNew(String, Double, Double, CoordType)
Constructor that sets all TextObj properties to default values as defined in the TextObj..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public TextObj(
    string text,
    double x,
    double y,
    CoordType coordType
)
Public Sub New ( _
    text As String, _
    x As Double, _
    y As Double, _
    coordType As CoordType _
)
public:
TextObj (
    String^ text,
    double x,
    double y,
    CoordType coordType
)
Parameters
text (String)
The text to be displayed.
x (Double)
The x position of the text. The units of this position are specified by the CoordinateFrame property. The text will be aligned to this position based on the AlignH property.
y (Double)
The y position of the text. The units of this position are specified by the CoordinateFrame property. The text will be aligned to this position based on the AlignV property.
coordType (CoordType)
The CoordType enum value that indicates what type of coordinate system the x and y parameters are referenced to.


TextObj Constructor (text, x, y, coordType, alignH, alignV)

TextObj Constructor (text, x, y, coordType, alignH, alignV)
Namespaces ► ZedGraph ► TextObj ► TextObjTextObjNew(String, Double, Double, CoordType, AlignH, AlignV)
Constructor that sets all TextObj properties to default values as defined in the TextObj..::Default class.
Declaration Syntax
C# Visual Basic Visual C++
public TextObj(
    string text,
    double x,
    double y,
    CoordType coordType,
    AlignH alignH,
    AlignV alignV
)
Public Sub New ( _
    text As String, _
    x As Double, _
    y As Double, _
    coordType As CoordType, _
    alignH As AlignH, _
    alignV As AlignV _
)
public:
TextObj (
    String^ text,
    double x,
    double y,
    CoordType coordType,
    AlignH alignH,
    AlignV alignV
)
Parameters
text (String)
The text to be displayed.
x (Double)
The x position of the text. The units of this position are specified by the CoordinateFrame property. The text will be aligned to this position based on the AlignH property.
y (Double)
The y position of the text. The units of this position are specified by the CoordinateFrame property. The text will be aligned to this position based on the AlignV property.
coordType (CoordType)
The CoordType enum value that indicates what type of coordinate system the x and y parameters are referenced to.
alignH (AlignH)
The AlignH enum that specifies the horizontal alignment of the object with respect to the (x,y) location
alignV (AlignV)
The AlignV enum that specifies the vertical alignment of the object with respect to the (x,y) location


TextObj Constructor (rhs)

TextObj Constructor (rhs)
Namespaces ► ZedGraph ► TextObj ► TextObjTextObjNew(TextObj)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public TextObj(
    TextObj rhs
)
Public Sub New ( _
    rhs As TextObj _
)
public:
TextObj (
    TextObj^ rhs
)
Parameters
rhs (TextObj)
The TextObj object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► TextObj ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public TextObj Clone()
Public Function Clone As TextObj
public:
TextObj^ Clone ()
Return Value
A new, independent copy of this class


Draw Method (g, pane, scaleFactor)

Draw Method (g, pane, scaleFactor)
Namespaces ► ZedGraph ► TextObj ► Draw(Graphics, PaneBase, Single)
Render this TextObj object to the specified Graphics device This method is normally only called by the Draw method of the parent GraphObjList collection object.
Declaration Syntax
C# Visual Basic Visual C++
public override void Draw(
    Graphics g,
    PaneBase pane,
    float scaleFactor
)
Public Overrides Sub Draw ( _
    g As Graphics, _
    pane As PaneBase, _
    scaleFactor As Single _
)
public:
virtual void Draw (
    Graphics^ g,
    PaneBase^ pane,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


FontSpec Property

FontSpec Property
Namespaces ► ZedGraph ► TextObj ► FontSpec
Gets a reference to the FontSpec class used to render this TextObj
Declaration Syntax
C# Visual Basic Visual C++
public FontSpec FontSpec{ get; set;}
Public Property FontSpec As FontSpec
public:
property FontSpec^ FontSpec {
    FontSpec^ get ();
    void set (FontSpec^ value);
}
See Also
FontColor
FontBold
FontItalic
FontUnderline
FontFamily
FontSize


GetCoords Method (pane, g, scaleFactor, shape, coords)

GetCoords Method (pane, g, scaleFactor, shape, coords)
Namespaces ► ZedGraph ► TextObj ► GetCoords(PaneBase, Graphics, Single, String%, String%)
Determines the shape type and Coords values for this GraphObj
Declaration Syntax
C# Visual Basic Visual C++
public override void GetCoords(
    PaneBase pane,
    Graphics g,
    float scaleFactor,
    out string shape,
    out string coords
)
Public Overrides Sub GetCoords ( _
    pane As PaneBase, _
    g As Graphics, _
    scaleFactor As Single, _
    <OutAttribute> ByRef shape As String, _
    <OutAttribute> ByRef coords As String _
)
public:
virtual void GetCoords (
    PaneBase^ pane,
    Graphics^ g,
    float scaleFactor,
    [OutAttribute] String^% shape,
    [OutAttribute] String^% coords
) override
Parameters
pane (PaneBase)
g (Graphics)
scaleFactor (Single)
shape (String %)
coords (String %)


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► TextObj ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


LayoutArea Property

LayoutArea Property
Namespaces ► ZedGraph ► TextObj ► LayoutArea
Declaration Syntax
C# Visual Basic Visual C++
public SizeF LayoutArea{ get; set;}
Public Property LayoutArea As SizeF
public:
property SizeF LayoutArea {
    SizeF get ();
    void set (SizeF value);
}


PointInBox Method (pt, pane, g, scaleFactor)

PointInBox Method (pt, pane, g, scaleFactor)
Namespaces ► ZedGraph ► TextObj ► PointInBox(PointF, PaneBase, Graphics, Single)
Determine if the specified screen point lies inside the bounding box of this TextObj. This method takes into account rotation and alignment parameters of the text, as specified in the FontSpec.
Declaration Syntax
C# Visual Basic Visual C++
public override bool PointInBox(
    PointF pt,
    PaneBase pane,
    Graphics g,
    float scaleFactor
)
Public Overrides Function PointInBox ( _
    pt As PointF, _
    pane As PaneBase, _
    g As Graphics, _
    scaleFactor As Single _
) As Boolean
public:
virtual bool PointInBox (
    PointF pt,
    PaneBase^ pane,
    Graphics^ g,
    float scaleFactor
) override
Parameters
pt (PointF)
The screen point, in pixels
pane (PaneBase)
A reference to the PaneBase object that is the parent or owner of this object.
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.
Return Value
true if the point lies in the bounding box, false otherwise


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► TextObj ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► TextObj ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Text Property

Text Property
Namespaces ► ZedGraph ► TextObj ► Text
The TextObj to be displayed. This text can be multi-line by including newline ('\n') characters between the lines.
Declaration Syntax
C# Visual Basic Visual C++
public string Text{ get; set;}
Public Property Text As String
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}


TextObj.Default Structure

TextObj..::Default Structure
Namespaces ► ZedGraph ► TextObj ► TextObj..::Default
A simple struct that defines the default property values for the TextObj class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontBold | The default font bold mode for the TextObj text (IsBold property). true for a bold typeface, false otherwise.
 | FontColor | The default font color for the TextObj text (FontColor property).
 | FontFamily | The default font family for the TextObj text (Family property).
 | FontItalic | The default font italic mode for the TextObj text (IsItalic property). true for an italic typeface, false otherwise.
 | FontSize | The default font size for the TextObj text (Size property). Units are in points (1/72 inch).
 | FontUnderline | The default font underline mode for the TextObj text (IsUnderline property). true for an underlined typeface, false otherwise.
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


FontBold Field

FontBold Field
Namespaces ► ZedGraph ► TextObj..::Default ► FontBold
The default font bold mode for the TextObj text (IsBold property). true for a bold typeface, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool FontBold
Public Shared FontBold As Boolean
public:
static bool FontBold


FontColor Field

FontColor Field
Namespaces ► ZedGraph ► TextObj..::Default ► FontColor
The default font color for the TextObj text (FontColor property).
Declaration Syntax
C# Visual Basic Visual C++
public static Color FontColor
Public Shared FontColor As Color
public:
static Color FontColor


FontFamily Field

FontFamily Field
Namespaces ► ZedGraph ► TextObj..::Default ► FontFamily
The default font family for the TextObj text (Family property).
Declaration Syntax
C# Visual Basic Visual C++
public static string FontFamily
Public Shared FontFamily As String
public:
static String^ FontFamily


FontItalic Field

FontItalic Field
Namespaces ► ZedGraph ► TextObj..::Default ► FontItalic
The default font italic mode for the TextObj text (IsItalic property). true for an italic typeface, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool FontItalic
Public Shared FontItalic As Boolean
public:
static bool FontItalic


FontSize Field

FontSize Field
Namespaces ► ZedGraph ► TextObj..::Default ► FontSize
The default font size for the TextObj text (Size property). Units are in points (1/72 inch).
Declaration Syntax
C# Visual Basic Visual C++
public static float FontSize
Public Shared FontSize As Single
public:
static float FontSize


FontUnderline Field

FontUnderline Field
Namespaces ► ZedGraph ► TextObj..::Default ► FontUnderline
The default font underline mode for the TextObj text (IsUnderline property). true for an underlined typeface, false otherwise.
Declaration Syntax
C# Visual Basic Visual C++
public static bool FontUnderline
Public Shared FontUnderline As Boolean
public:
static bool FontUnderline


ValueHandler Class

ValueHandler Class
Namespaces ► ZedGraph ► ValueHandler
A class designed to simplify the process of getting the actual value for the various stacked and regular curve types
Declaration Syntax
C# Visual Basic Visual C++
public class ValueHandler
Public Class ValueHandler
public ref class ValueHandler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ValueHandlerValueHandlerNew(GraphPane, Boolean) | Basic constructor that saves a reference to the parent GraphPane object.
 | BarCenterValue(CurveItem, Single, Int32, Double, Int32) | Calculate the user scale position of the center of the specified bar, using the Axis as specified by Base. This method is used primarily by the FindNearestPoint(PointF, CurveItem%, Int32%) method in order to determine the bar "location," which is defined as the center of the top of the individual bar.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValues(CurveItem, Int32, Double%, Double%, Double%) | Get the user scale values associate with a particular point of a particular curve.
 | GetValues(GraphPane, CurveItem, Int32, Double%, Double%, Double%) | Get the user scale values associate with a particular point of a particular curve.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ValueHandler


ValueHandler Constructor (pane, initialize)

ValueHandler Constructor (pane, initialize)
Namespaces ► ZedGraph ► ValueHandler ► ValueHandlerValueHandlerNew(GraphPane, Boolean)
Basic constructor that saves a reference to the parent GraphPane object.
Declaration Syntax
C# Visual Basic Visual C++
public ValueHandler(
    GraphPane pane,
    bool initialize
)
Public Sub New ( _
    pane As GraphPane, _
    initialize As Boolean _
)
public:
ValueHandler (
    GraphPane^ pane,
    bool initialize
)
Parameters
pane (GraphPane)
The parent GraphPane object.
initialize (Boolean)
A Boolean flag to indicate whether or not the drawing variables should be initialized. Initialization is not required if this is part of a ZedGraph internal draw operation (i.e., its in the middle of a call to Draw(Graphics)). Otherwise, you should initialize to make sure the drawing variables are configured. true to do an initialization, false otherwise.


BarCenterValue Method (curve, barWidth, iCluster, val, iOrdinal)

BarCenterValue Method (curve, barWidth, iCluster, val, iOrdinal)
Namespaces ► ZedGraph ► ValueHandler ► BarCenterValue(CurveItem, Single, Int32, Double, Int32)
Calculate the user scale position of the center of the specified bar, using the Axis as specified by Base. This method is used primarily by the FindNearestPoint(PointF, CurveItem%, Int32%) method in order to determine the bar "location," which is defined as the center of the top of the individual bar.
Declaration Syntax
C# Visual Basic Visual C++
public double BarCenterValue(
    CurveItem curve,
    float barWidth,
    int iCluster,
    double val,
    int iOrdinal
)
Public Function BarCenterValue ( _
    curve As CurveItem, _
    barWidth As Single, _
    iCluster As Integer, _
    val As Double, _
    iOrdinal As Integer _
) As Double
public:
double BarCenterValue (
    CurveItem^ curve,
    float barWidth,
    int iCluster,
    double val,
    int iOrdinal
)
Parameters
curve (CurveItem)
The CurveItem representing the bar of interest.
barWidth (Single)
The width of each individual bar. This can be calculated using the GetBarWidth(GraphPane) method.
iCluster (Int32)
The cluster number for the bar of interest. This is the ordinal position of the current point. That is, if a particular CurveItem has 10 points, then a value of 3 would indicate the 4th point in the data array.
val (Double)
The actual independent axis value for the bar of interest.
iOrdinal (Int32)
The ordinal position of the CurveItem of interest. That is, the first bar series is 0, the second is 1, etc. Note that this applies only to the bars. If a graph includes both bars and lines, then count only the bars.
Return Value
A user scale value position of the center of the bar of interest.


GetValues Method

GetValues Method
Namespaces ► ZedGraph ► ValueHandler ► GetValues()()
Members
Icon | Member | Description
 | GetValues(CurveItem, Int32, Double%, Double%, Double%) | Get the user scale values associate with a particular point of a particular curve.
 | GetValues(GraphPane, CurveItem, Int32, Double%, Double%, Double%) | Get the user scale values associate with a particular point of a particular curve.


GetValues Method (curve, iPt, baseVal, lowVal, hiVal)

GetValues Method (curve, iPt, baseVal, lowVal, hiVal)
Namespaces ► ZedGraph ► ValueHandler ► GetValues(CurveItem, Int32, Double%, Double%, Double%)
Get the user scale values associate with a particular point of a particular curve.
Declaration Syntax
C# Visual Basic Visual C++
public bool GetValues(
    CurveItem curve,
    int iPt,
    out double baseVal,
    out double lowVal,
    out double hiVal
)
Public Function GetValues ( _
    curve As CurveItem, _
    iPt As Integer, _
    <OutAttribute> ByRef baseVal As Double, _
    <OutAttribute> ByRef lowVal As Double, _
    <OutAttribute> ByRef hiVal As Double _
) As Boolean
public:
bool GetValues (
    CurveItem^ curve,
    int iPt,
    [OutAttribute] double% baseVal,
    [OutAttribute] double% lowVal,
    [OutAttribute] double% hiVal
)
Parameters
curve (CurveItem)
A CurveItem object of interest.
iPt (Int32)
The zero-based point index for the point of interest.
baseVal (Double %)
A Double value representing the value for the independent axis.
lowVal (Double %)
A Double value representing the lower value for the dependent axis.
hiVal (Double %)
A Double value representing the upper value for the dependent axis.
Return Value
true if the data point is value, false for Missing, invalid, etc. data.
Remarks
The main purpose of this method is to handle stacked bars, in which case the stacked values are returned rather than the individual data values.


GetValues Method (pane, curve, iPt, baseVal, lowVal, hiVal)

GetValues Method (pane, curve, iPt, baseVal, lowVal, hiVal)
Namespaces ► ZedGraph ► ValueHandler ► GetValues(GraphPane, CurveItem, Int32, Double%, Double%, Double%)
Get the user scale values associate with a particular point of a particular curve.
Declaration Syntax
C# Visual Basic Visual C++
public static bool GetValues(
    GraphPane pane,
    CurveItem curve,
    int iPt,
    out double baseVal,
    out double lowVal,
    out double hiVal
)
Public Shared Function GetValues ( _
    pane As GraphPane, _
    curve As CurveItem, _
    iPt As Integer, _
    <OutAttribute> ByRef baseVal As Double, _
    <OutAttribute> ByRef lowVal As Double, _
    <OutAttribute> ByRef hiVal As Double _
) As Boolean
public:
static bool GetValues (
    GraphPane^ pane,
    CurveItem^ curve,
    int iPt,
    [OutAttribute] double% baseVal,
    [OutAttribute] double% lowVal,
    [OutAttribute] double% hiVal
)
Parameters
pane (GraphPane)
The parent GraphPane object.
curve (CurveItem)
A CurveItem object of interest.
iPt (Int32)
The zero-based point index for the point of interest.
baseVal (Double %)
A Double value representing the value for the independent axis.
lowVal (Double %)
A Double value representing the lower value for the dependent axis.
hiVal (Double %)
A Double value representing the upper value for the dependent axis.
Return Value
true if the data point is value, false for Missing, invalid, etc. data.
Remarks
The main purpose of this method is to handle stacked bars and lines, in which case the stacked values are returned rather than the individual data values. However, this method works generically for any curve type.


X2Axis Class

X2Axis Class
Namespaces ► ZedGraph ► X2Axis
X2Axis inherits from Axis, and defines the special characteristics of a horizontal axis, specifically located at the top of the Rect of the GraphPane object
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class X2Axis : Axis, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class X2Axis _
    Inherits Axis _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class X2Axis : public Axis,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | X2AxisX2AxisNew()() | Default constructor that sets all X2Axis properties to default values as defined in the X2Axis..::Default class
 | X2AxisX2AxisNew(String) | Default constructor that sets all X2Axis properties to default values as defined in the X2Axis..::Default class, except for the axis title
 | X2AxisX2AxisNew(X2Axis) | The Copy Constructor
 | AxisGap | The size of the gap between multiple axes (see YAxisList and Y2AxisList). (Inherited from Axis.)
 | CalcSpace(Graphics, GraphPane, Single, Single%) | Calculate the space required (pixels) for this Axis object. (Inherited from Axis.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The color to use for drawing this Axis. (Inherited from Axis.)
 | Cross | Gets or sets the scale value at which this axis should cross the "other" axis. (Inherited from Axis.)
 | CrossAuto | Gets or sets a value that determines whether or not the Cross value is set automatically. (Inherited from Axis.)
 | Draw(Graphics, GraphPane, Single, Single) | Do all rendering associated with this Axis to the specified Graphics device. (Inherited from Axis.)
 | DrawMinorTics(Graphics, GraphPane, Double, Single, Single, Single) | Draw the minor tic marks as required for this Axis. (Inherited from Axis.)
 | DrawTitle(Graphics, GraphPane, Single, Single) | Draw the title for this Axis. (Inherited from Axis.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCrossAxis(GraphPane) | Gets the "Cross" axis that corresponds to this axis. (Overrides Axis.GetCrossAxis(GraphPane).)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides Axis.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAxisSegmentVisible | Gets or sets a property that determines whether or not the axis segment (the line that represents the axis itself) is drawn. (Inherited from Axis.)
 | IsVisible | This property determines whether or not the Axis is shown. (Inherited from Axis.)
 | MajorGrid | Gets a reference to the MajorGrid class that contains the properties of the major grid. (Inherited from Axis.)
 | MajorTic | Gets a reference to the MajorTic class instance for this Axis. This class stores all the major tic settings. (Inherited from Axis.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinorGrid | Gets a reference to the MinorGrid class that contains the properties of the minor grid. (Inherited from Axis.)
 | MinorTic | Gets a reference to the MinorTic class instance for this Axis. This class stores all the minor tic settings. (Inherited from Axis.)
 | MinSpace | Gets or sets the minimum axis space allocation. (Inherited from Axis.)
 | ResetAutoScale(GraphPane, Graphics) | Restore the scale ranging to automatic mode, and recalculate the Axis scale ranges (Inherited from Axis.)
 | Scale | Gets the Scale instance associated with this Axis. (Inherited from Axis.)
 | ScaleFormatEvent | Subscribe to this event to handle custom formatting of the scale labels. (Inherited from Axis.)
 | ScaleTitleEvent | Allow customization of the title when the scale is very large Subscribe to this event to handle custom formatting of the scale axis label. (Inherited from Axis.)
 | schema2 | Current schema value that defines the version of the serialized file
 | SetMinSpaceBuffer(Graphics, GraphPane, Single, Boolean) | This method will set the MinSpace property for this Axis using the currently required space multiplied by a fraction (). (Inherited from Axis.)
 | SetTransformMatrix(Graphics, GraphPane, Single) | Setup the Transform Matrix to handle drawing of this X2Axis (Overrides Axis.SetTransformMatrix(Graphics, GraphPane, Single).)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the Axis. ZedGraph does not use this value for any purpose. (Inherited from Axis.)
 | Title | Gets or sets the Label class that contains the title of this Axis. (Inherited from Axis.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets or sets the AxisType for this Axis. (Inherited from Axis.)
Inheritance Hierarchy
Object
 | Axis
 |  | X2Axis


X2Axis Constructor

X2Axis Constructor
Namespaces ► ZedGraph ► X2Axis ► X2AxisX2AxisNew()()
Members
Icon | Member | Description
 | X2AxisX2AxisNew()() | Default constructor that sets all X2Axis properties to default values as defined in the X2Axis..::Default class
 | X2AxisX2AxisNew(String) | Default constructor that sets all X2Axis properties to default values as defined in the X2Axis..::Default class, except for the axis title
 | X2AxisX2AxisNew(X2Axis) | The Copy Constructor


X2Axis Constructor

X2Axis Constructor
Namespaces ► ZedGraph ► X2Axis ► X2AxisX2AxisNew()()
Default constructor that sets all X2Axis properties to default values as defined in the X2Axis..::Default class
Declaration Syntax
C# Visual Basic Visual C++
public X2Axis()
Public Sub New
public:
X2Axis ()


X2Axis Constructor (title)

X2Axis Constructor (title)
Namespaces ► ZedGraph ► X2Axis ► X2AxisX2AxisNew(String)
Default constructor that sets all X2Axis properties to default values as defined in the X2Axis..::Default class, except for the axis title
Declaration Syntax
C# Visual Basic Visual C++
public X2Axis(
    string title
)
Public Sub New ( _
    title As String _
)
public:
X2Axis (
    String^ title
)
Parameters
title (String)
The Title for this axis


X2Axis Constructor (rhs)

X2Axis Constructor (rhs)
Namespaces ► ZedGraph ► X2Axis ► X2AxisX2AxisNew(X2Axis)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public X2Axis(
    X2Axis rhs
)
Public Sub New ( _
    rhs As X2Axis _
)
public:
X2Axis (
    X2Axis^ rhs
)
Parameters
rhs (X2Axis)
The X2Axis object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► X2Axis ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public X2Axis Clone()
Public Function Clone As X2Axis
public:
X2Axis^ Clone ()
Return Value
A new, independent copy of this class


GetCrossAxis Method (pane)

GetCrossAxis Method (pane)
Namespaces ► ZedGraph ► X2Axis ► GetCrossAxis(GraphPane)
Gets the "Cross" axis that corresponds to this axis.
Declaration Syntax
C# Visual Basic Visual C++
public override Axis GetCrossAxis(
    GraphPane pane
)
Public Overrides Function GetCrossAxis ( _
    pane As GraphPane _
) As Axis
public:
virtual Axis^ GetCrossAxis (
    GraphPane^ pane
) override
Parameters
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
Remarks
The cross axis is the axis which determines the of this Axis when the Axis.Cross property is used. The cross axis for any XAxis or X2Axis is always the primary YAxis, and the cross axis for any YAxis or Y2Axis is always the primary XAxis.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► X2Axis ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► X2Axis ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


SetTransformMatrix Method (g, pane, scaleFactor)

SetTransformMatrix Method (g, pane, scaleFactor)
Namespaces ► ZedGraph ► X2Axis ► SetTransformMatrix(Graphics, GraphPane, Single)
Setup the Transform Matrix to handle drawing of this X2Axis
Declaration Syntax
C# Visual Basic Visual C++
public override void SetTransformMatrix(
    Graphics g,
    GraphPane pane,
    float scaleFactor
)
Public Overrides Sub SetTransformMatrix ( _
    g As Graphics, _
    pane As GraphPane, _
    scaleFactor As Single _
)
public:
virtual void SetTransformMatrix (
    Graphics^ g,
    GraphPane^ pane,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► X2Axis ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


X2Axis.Default Structure

X2Axis..::Default Structure
Namespaces ► ZedGraph ► X2Axis ► X2Axis..::Default
A simple struct that defines the default property values for the X2Axis class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible | The default display mode for the X2Axis (IsVisible property). true to display the scale values, title, tic marks, false to hide the axis entirely.
 | IsZeroLine | Determines if a line will be drawn at the zero value for the X2Axis, that is, a line that divides the negative values from positive values. IsZeroLine.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


IsVisible Field

IsVisible Field
Namespaces ► ZedGraph ► X2Axis..::Default ► IsVisible
The default display mode for the X2Axis (IsVisible property). true to display the scale values, title, tic marks, false to hide the axis entirely.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsVisible
Public Shared IsVisible As Boolean
public:
static bool IsVisible


IsZeroLine Field

IsZeroLine Field
Namespaces ► ZedGraph ► X2Axis..::Default ► IsZeroLine
Determines if a line will be drawn at the zero value for the X2Axis, that is, a line that divides the negative values from positive values. IsZeroLine.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsZeroLine
Public Shared IsZeroLine As Boolean
public:
static bool IsZeroLine
See Also
IsZeroLine


XAxis Class

XAxis Class
Namespaces ► ZedGraph ► XAxis
XAxis inherits from Axis, and defines the special characteristics of a horizontal axis, specifically located at the bottom of the Rect of the GraphPane object
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class XAxis : Axis, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class XAxis _
    Inherits Axis _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class XAxis : public Axis,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XAxisXAxisNew()() | Default constructor that sets all XAxis properties to default values as defined in the XAxis..::Default class
 | XAxisXAxisNew(String) | Default constructor that sets all XAxis properties to default values as defined in the XAxis..::Default class, except for the axis title
 | XAxisXAxisNew(XAxis) | The Copy Constructor
 | AxisGap | The size of the gap between multiple axes (see YAxisList and Y2AxisList). (Inherited from Axis.)
 | CalcSpace(Graphics, GraphPane, Single, Single%) | Calculate the space required (pixels) for this Axis object. (Inherited from Axis.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The color to use for drawing this Axis. (Inherited from Axis.)
 | Cross | Gets or sets the scale value at which this axis should cross the "other" axis. (Inherited from Axis.)
 | CrossAuto | Gets or sets a value that determines whether or not the Cross value is set automatically. (Inherited from Axis.)
 | Draw(Graphics, GraphPane, Single, Single) | Do all rendering associated with this Axis to the specified Graphics device. (Inherited from Axis.)
 | DrawMinorTics(Graphics, GraphPane, Double, Single, Single, Single) | Draw the minor tic marks as required for this Axis. (Inherited from Axis.)
 | DrawTitle(Graphics, GraphPane, Single, Single) | Draw the title for this Axis. (Inherited from Axis.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCrossAxis(GraphPane) | Gets the "Cross" axis that corresponds to this axis. (Overrides Axis.GetCrossAxis(GraphPane).)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides Axis.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAxisSegmentVisible | Gets or sets a property that determines whether or not the axis segment (the line that represents the axis itself) is drawn. (Inherited from Axis.)
 | IsVisible | This property determines whether or not the Axis is shown. (Inherited from Axis.)
 | MajorGrid | Gets a reference to the MajorGrid class that contains the properties of the major grid. (Inherited from Axis.)
 | MajorTic | Gets a reference to the MajorTic class instance for this Axis. This class stores all the major tic settings. (Inherited from Axis.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinorGrid | Gets a reference to the MinorGrid class that contains the properties of the minor grid. (Inherited from Axis.)
 | MinorTic | Gets a reference to the MinorTic class instance for this Axis. This class stores all the minor tic settings. (Inherited from Axis.)
 | MinSpace | Gets or sets the minimum axis space allocation. (Inherited from Axis.)
 | ResetAutoScale(GraphPane, Graphics) | Restore the scale ranging to automatic mode, and recalculate the Axis scale ranges (Inherited from Axis.)
 | Scale | Gets the Scale instance associated with this Axis. (Inherited from Axis.)
 | ScaleFormatEvent | Subscribe to this event to handle custom formatting of the scale labels. (Inherited from Axis.)
 | ScaleTitleEvent | Allow customization of the title when the scale is very large Subscribe to this event to handle custom formatting of the scale axis label. (Inherited from Axis.)
 | schema2 | Current schema value that defines the version of the serialized file
 | SetMinSpaceBuffer(Graphics, GraphPane, Single, Boolean) | This method will set the MinSpace property for this Axis using the currently required space multiplied by a fraction (). (Inherited from Axis.)
 | SetTransformMatrix(Graphics, GraphPane, Single) | Setup the Transform Matrix to handle drawing of this XAxis (Overrides Axis.SetTransformMatrix(Graphics, GraphPane, Single).)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the Axis. ZedGraph does not use this value for any purpose. (Inherited from Axis.)
 | Title | Gets or sets the Label class that contains the title of this Axis. (Inherited from Axis.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets or sets the AxisType for this Axis. (Inherited from Axis.)
Inheritance Hierarchy
Object
 | Axis
 |  | XAxis


XAxis Constructor

XAxis Constructor
Namespaces ► ZedGraph ► XAxis ► XAxisXAxisNew()()
Members
Icon | Member | Description
 | XAxisXAxisNew()() | Default constructor that sets all XAxis properties to default values as defined in the XAxis..::Default class
 | XAxisXAxisNew(String) | Default constructor that sets all XAxis properties to default values as defined in the XAxis..::Default class, except for the axis title
 | XAxisXAxisNew(XAxis) | The Copy Constructor


XAxis Constructor

XAxis Constructor
Namespaces ► ZedGraph ► XAxis ► XAxisXAxisNew()()
Default constructor that sets all XAxis properties to default values as defined in the XAxis..::Default class
Declaration Syntax
C# Visual Basic Visual C++
public XAxis()
Public Sub New
public:
XAxis ()


XAxis Constructor (title)

XAxis Constructor (title)
Namespaces ► ZedGraph ► XAxis ► XAxisXAxisNew(String)
Default constructor that sets all XAxis properties to default values as defined in the XAxis..::Default class, except for the axis title
Declaration Syntax
C# Visual Basic Visual C++
public XAxis(
    string title
)
Public Sub New ( _
    title As String _
)
public:
XAxis (
    String^ title
)
Parameters
title (String)
The Title for this axis


XAxis Constructor (rhs)

XAxis Constructor (rhs)
Namespaces ► ZedGraph ► XAxis ► XAxisXAxisNew(XAxis)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public XAxis(
    XAxis rhs
)
Public Sub New ( _
    rhs As XAxis _
)
public:
XAxis (
    XAxis^ rhs
)
Parameters
rhs (XAxis)
The XAxis object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► XAxis ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public XAxis Clone()
Public Function Clone As XAxis
public:
XAxis^ Clone ()
Return Value
A new, independent copy of this class


GetCrossAxis Method (pane)

GetCrossAxis Method (pane)
Namespaces ► ZedGraph ► XAxis ► GetCrossAxis(GraphPane)
Gets the "Cross" axis that corresponds to this axis.
Declaration Syntax
C# Visual Basic Visual C++
public override Axis GetCrossAxis(
    GraphPane pane
)
Public Overrides Function GetCrossAxis ( _
    pane As GraphPane _
) As Axis
public:
virtual Axis^ GetCrossAxis (
    GraphPane^ pane
) override
Parameters
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
Remarks
The cross axis is the axis which determines the of this Axis when the Axis.Cross property is used. The cross axis for any XAxis or X2Axis is always the primary YAxis, and the cross axis for any YAxis or Y2Axis is always the primary XAxis.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► XAxis ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► XAxis ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


SetTransformMatrix Method (g, pane, scaleFactor)

SetTransformMatrix Method (g, pane, scaleFactor)
Namespaces ► ZedGraph ► XAxis ► SetTransformMatrix(Graphics, GraphPane, Single)
Setup the Transform Matrix to handle drawing of this XAxis
Declaration Syntax
C# Visual Basic Visual C++
public override void SetTransformMatrix(
    Graphics g,
    GraphPane pane,
    float scaleFactor
)
Public Overrides Sub SetTransformMatrix ( _
    g As Graphics, _
    pane As GraphPane, _
    scaleFactor As Single _
)
public:
virtual void SetTransformMatrix (
    Graphics^ g,
    GraphPane^ pane,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► XAxis ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


XAxis.Default Structure

XAxis..::Default Structure
Namespaces ► ZedGraph ► XAxis ► XAxis..::Default
A simple struct that defines the default property values for the XAxis class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible | The default display mode for the XAxis (IsVisible property). true to display the scale values, title, tic marks, false to hide the axis entirely.
 | IsZeroLine | Determines if a line will be drawn at the zero value for the XAxis, that is, a line that divides the negative values from positive values. IsZeroLine.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


IsVisible Field

IsVisible Field
Namespaces ► ZedGraph ► XAxis..::Default ► IsVisible
The default display mode for the XAxis (IsVisible property). true to display the scale values, title, tic marks, false to hide the axis entirely.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsVisible
Public Shared IsVisible As Boolean
public:
static bool IsVisible


IsZeroLine Field

IsZeroLine Field
Namespaces ► ZedGraph ► XAxis..::Default ► IsZeroLine
Determines if a line will be drawn at the zero value for the XAxis, that is, a line that divides the negative values from positive values. IsZeroLine.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsZeroLine
Public Shared IsZeroLine As Boolean
public:
static bool IsZeroLine
See Also
IsZeroLine


XDate Structure

XDate Structure
Namespaces ► ZedGraph ► XDate
This struct encapsulates a date and time value, and handles associated calculations and conversions between various formats.
Declaration Syntax
C# Visual Basic Visual C++
public struct XDate
Public Structure XDate
public value class XDate
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XDateXDateNew(Double) | Construct a date class from an XL date value.
 | XDateXDateNew(DateTime) | Construct a date class from a DateTime struct.
 | XDateXDateNew(Int32, Int32, Int32) | Construct a date class from a calendar date (year, month, day). Assumes the time of day is 00:00 hrs
 | XDateXDateNew(Int32, Int32, Int32, Int32, Int32, Int32) | Construct a date class from a calendar date and time (year, month, day, hour, minute, second).
 | XDateXDateNew(Int32, Int32, Int32, Int32, Int32, Double) | Construct a date class from a calendar date and time (year, month, day, hour, minute, second), where seconds is a Double value (allowing fractional seconds).
 | XDateXDateNew(Int32, Int32, Int32, Int32, Int32, Int32, Int32) | Construct a date class from a calendar date and time (year, month, day, hour, minute, second, millisecond).
 | XDateXDateNew(XDate) | The Copy Constructor
 | AddDays(Double) | Add the specified number of days (can be fractional) to the current XDate instance.
 | AddHours(Double) | Add the specified number of hours (can be fractional) to the current XDate instance.
 | Addition(XDate, Double) | '+' operator overload. When a double value is added to an XDate, the result is a new XDate with the number of days added.
 | AddMilliseconds(Double) | Add the specified number of milliseconds (can be fractional) to the current XDate instance.
 | AddMinutes(Double) | Add the specified number of minutes (can be fractional) to the current XDate instance.
 | AddMonths(Double) | Add the specified number of Months (can be fractional) to the current XDate instance.
 | AddSeconds(Double) | Add the specified number of seconds (can be fractional) to the current XDate instance.
 | AddYears(Double) | Add the specified number of years (can be fractional) to the current XDate instance.
 | CalendarDateToJulianDay(Int32, Int32, Int32, Int32, Int32, Int32) | Calculate an Astronomical Julian Day number from the specified Calendar date (year, month, day, hour, minute, second), first normalizing all input data values
 | CalendarDateToJulianDay(Int32, Int32, Int32, Int32, Int32, Int32, Int32) | Calculate an Astronomical Julian Day number from the specified Calendar date (year, month, day, hour, minute, second), first normalizing all input data values
 | CalendarDateToXLDate(Int32, Int32, Int32, Int32, Int32, Int32, Int32) | Calculate an XL Date from the specified Calendar date (year, month, day, hour, minute, second), first normalizing all input data values.
 | CalendarDateToXLDate(Int32, Int32, Int32, Int32, Int32, Int32) | Calculate an XL Date from the specified Calendar date (year, month, day, hour, minute, second), first normalizing all input data values.
 | CalendarDateToXLDate(Int32, Int32, Int32, Int32, Int32, Double) | Calculate an XL Date from the specified Calendar date (year, month, day, hour, minute, second), first normalizing all input data values. The seconds value is a double type, allowing fractional seconds.
 | DateTime | Gets or sets the date value for this item in .Net DateTime format.
 | DateTimeToXLDate(DateTime) | Convert a .Net DateTime struct to an XL Format date
 | DecimalYear | Gets or sets the decimal year number (i.e., 1997.345) corresponding to this item.
 | DecimalYearToXLDate(Double) | Calculate a decimal year value (e.g., 1994.6523) corresponding to the specified XL date
 | Decrement(XDate) | '--' operator overload. Decrement the date by one day.
 | DefaultFormatStr | The default format string to be used in ToString()() when no format is provided
 | Equals(Object) | Tests whether obj is either an XDate structure or a double floating point value that is equal to the same date as this XDate struct instance. (Overrides ValueType.Equals(Object).)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDate(Int32%, Int32%, Int32%) | Get the calendar date (year, month, day) corresponding to this instance.
 | GetDate(Int32%, Int32%, Int32%, Int32%, Int32%, Int32%) | Get the calendar date (year, month, day, hour, minute, second) corresponding to this instance.
 | GetDayOfYear()() | Get the day of year value (241.345 means the 241st day of the year) corresponding to this instance.
 | GetHashCode()() | Returns the hash code for this XDate structure. In this case, the hash code is simply the equivalent hash code for the floating point double date value. (Overrides ValueType.GetHashCode()().)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HoursPerDay | The number of hours in a day
 | Implicit(XDate) | Implicit conversion from XDate to double (an XL Date).
 | Implicit(XDate) | Implicit conversion from XDate to float (an XL Date).
 | Implicit(Double) | Implicit conversion from double (an XL Date) to XDate.
 | Implicit(XDate) | Implicit conversion from XDate to DateTime.
 | Implicit(DateTime) | Implicit conversion from DateTime to XDate.
 | Increment(XDate) | '++' operator overload. Increment the date by one day.
 | IsValidDate | Returns true if this XDate struct is in the valid date range
 | JulDayMax | The maximum valid Julian Day, which corresponds to December 31st, 9999 A.D.
 | JulDayMin | The minimum valid Julian Day, which corresponds to January 1st, 4713 B.C.
 | JulianDay | Gets or sets the date value for this item in Julain day format. This is the Astronomical Julian Day number, so a value of 0.0 corresponds to noon GMT on January 1st, -4712. Thus, Julian Day number 2,400,000.0 corresponds to noon GMT on November 16, 1858.
 | JulianDayToCalendarDate(Double, Int32%, Int32%, Int32%, Int32%, Int32%, Int32%) | Calculate a Calendar date (year, month, day, hour, minute, second) corresponding to the Astronomical Julian Day number
 | JulianDayToCalendarDate(Double, Int32%, Int32%, Int32%, Int32%, Int32%, Double%) | Calculate a Calendar date (year, month, day, hour, minute, second) corresponding to the Astronomical Julian Day number
 | JulianDayToCalendarDate(Double, Int32%, Int32%, Int32%, Int32%, Int32%, Int32%, Double%) | Calculate a Calendar date (year, month, day, hour, minute, second) corresponding to the Astronomical Julian Day number
 | JulianDayToXLDate(Double) | Calculate an XL Date corresponding to the specified Astronomical Julian Day number
 | MakeValidDate(Double) | Take the specified date, and bound it to the valid date range for the XDate struct.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MillisecondsPerDay | The number of milliseconds in a day
 | MillisecondsPerSecond | The number of milliseconds in a second
 | MinutesPerDay | The number of minutes in a day
 | MinutesPerHour | The number of minutes in an hour
 | MonthsPerYear | The number of months in a year
 | SecondsPerDay | The number of seconds in a day
 | SecondsPerMinute | The number of seconds in a minute
 | SetDate(Int32, Int32, Int32) | Set the calendar date (year, month, day) of this instance.
 | SetDate(Int32, Int32, Int32, Int32, Int32, Int32) | Set the calendar date (year, month, day, hour, minute, second) of this instance.
 | Subtraction(XDate, XDate) | '-' operator overload. When two XDates are subtracted, the number of days between dates is returned.
 | Subtraction(XDate, Double) | '-' operator overload. When a double value is subtracted from an XDate, the result is a new XDate with the number of days subtracted.
 | ToString(Double) | Format this XDate value using the default format string (DefaultFormatStr).
 | ToString()() | Format this XDate value using the default format string (see cref="DefaultFormatStr"/>). (Overrides ValueType.ToString()().)
 | ToString(String) | Format this XL Date value using the specified format string. The format string is specified according to the DateTime class.
 | ToString(Double, String) | Format the specified XL Date value using the specified format string. The format string is specified according to the DateTime class.
 | XLDate | Gets or sets the date value for this item in MS Excel format.
 | XLDateToCalendarDate(Double, Int32%, Int32%, Int32%, Int32%, Int32%, Int32%) | Calculate a Calendar date (year, month, day, hour, minute, second) corresponding to the specified XL date
 | XLDateToCalendarDate(Double, Int32%, Int32%, Int32%, Int32%, Int32%, Int32%, Int32%) | Calculate a Calendar date (year, month, day, hour, minute, second) corresponding to the specified XL date
 | XLDateToCalendarDate(Double, Int32%, Int32%, Int32%, Int32%, Int32%, Double%) | Calculate a Calendar date (year, month, day, hour, minute, second) corresponding to the specified XL date
 | XLDateToDateTime(Double) | Convert an XL date format to a .Net DateTime struct
 | XLDateToDayOfWeek(Double) | Calculate a day-of-week value (e.g., Sun=0, Mon=1, Tue=2, etc.) corresponding to the specified XL date
 | XLDateToDayOfYear(Double) | Calculate a day-of-year value (e.g., 241.543 corresponds to the 241st day of the year) corresponding to the specified XL date
 | XLDateToDecimalYear(Double) | Calculate a decimal year value (e.g., 1994.6523) corresponding to the specified XL date
 | XLDateToJulianDay(Double) | Calculate an Astronomical Julian Day number corresponding to the specified XL date
 | XLDay1 | The Astronomical Julian Day number that corresponds to XL Date 0.0
 | XLDayMax | The maximum valid Excel Day, which corresponds to December 31st, 9999 A.D.
 | XLDayMin | The minimum valid Excel Day, which corresponds to January 1st, 4713 B.C.
Remarks
This format stored as a double value representing days since a reference date (XL date 0.0 is December 30, 1899 at 00:00 hrs). Negative values are permissible, and the range of valid dates is from noon on January 1st, 4713 B.C. forward. Internally, the date calculations are done using Astronomical Julian Day numbers. The Astronomical Julian Day number is defined as the number of days since noon on January 1st, 4713 B.C. (also referred to as 12:00 on January 1, -4712). NOTE: MS Excel actually has an error in the Serial Date calculations because it errantly assumes 1900 is a leap year. The XDate calculations do not have this same error. Therefore, XDate and Excel Date Serial values are 1 day different up until the date value of 60 (in Excel, this is February 29th, 1900, and in XDate, this is February 28th, 1900). At a value of 61 (March 1st, 1900) or greater, they agree with eachother.


XDate Constructor

XDate Constructor
Namespaces ► ZedGraph ► XDate ► XDateXDateNew()()
Members
Icon | Member | Description
 | XDateXDateNew(Double) | Construct a date class from an XL date value.
 | XDateXDateNew(DateTime) | Construct a date class from a DateTime struct.
 | XDateXDateNew(Int32, Int32, Int32) | Construct a date class from a calendar date (year, month, day). Assumes the time of day is 00:00 hrs
 | XDateXDateNew(Int32, Int32, Int32, Int32, Int32, Int32) | Construct a date class from a calendar date and time (year, month, day, hour, minute, second).
 | XDateXDateNew(Int32, Int32, Int32, Int32, Int32, Double) | Construct a date class from a calendar date and time (year, month, day, hour, minute, second), where seconds is a Double value (allowing fractional seconds).
 | XDateXDateNew(Int32, Int32, Int32, Int32, Int32, Int32, Int32) | Construct a date class from a calendar date and time (year, month, day, hour, minute, second, millisecond).
 | XDateXDateNew(XDate) | The Copy Constructor


XDate Constructor (dateTime)

XDate Constructor (dateTime)
Namespaces ► ZedGraph ► XDate ► XDateXDateNew(DateTime)
Construct a date class from a DateTime struct.
Declaration Syntax
C# Visual Basic Visual C++
public XDate(
    DateTime dateTime
)
Public Sub New ( _
    dateTime As DateTime _
)
public:
XDate (
    DateTime dateTime
)
Parameters
dateTime (DateTime)
A DateTime struct containing the initial date information.


XDate Constructor (xlDate)

XDate Constructor (xlDate)
Namespaces ► ZedGraph ► XDate ► XDateXDateNew(Double)
Construct a date class from an XL date value.
Declaration Syntax
C# Visual Basic Visual C++
public XDate(
    double xlDate
)
Public Sub New ( _
    xlDate As Double _
)
public:
XDate (
    double xlDate
)
Parameters
xlDate (Double)
An XL Date value in floating point double format


XDate Constructor (year, month, day)

XDate Constructor (year, month, day)
Namespaces ► ZedGraph ► XDate ► XDateXDateNew(Int32, Int32, Int32)
Construct a date class from a calendar date (year, month, day). Assumes the time of day is 00:00 hrs
Declaration Syntax
C# Visual Basic Visual C++
public XDate(
    int year,
    int month,
    int day
)
Public Sub New ( _
    year As Integer, _
    month As Integer, _
    day As Integer _
)
public:
XDate (
    int year,
    int month,
    int day
)
Parameters
year (Int32)
An integer value for the year, e.g., 1995.
month (Int32)
An integer value for the month of the year, e.g., 8 for August. It is permissible to have months outside of the 1-12 range, which will rollover to the previous or next year.
day (Int32)
An integer value for the day of the month, e.g., 23. It is permissible to have day numbers outside of the 1-31 range, which will rollover to the previous or next month and year.


XDate Constructor (year, month, day, hour, minute, second)

XDate Constructor (year, month, day, hour, minute, second)
Namespaces ► ZedGraph ► XDate ► XDateXDateNew(Int32, Int32, Int32, Int32, Int32, Double)
Construct a date class from a calendar date and time (year, month, day, hour, minute, second), where seconds is a Double value (allowing fractional seconds).
Declaration Syntax
C# Visual Basic Visual C++
public XDate(
    int year,
    int month,
    int day,
    int hour,
    int minute,
    double second
)
Public Sub New ( _
    year As Integer, _
    month As Integer, _
    day As Integer, _
    hour As Integer, _
    minute As Integer, _
    second As Double _
)
public:
XDate (
    int year,
    int month,
    int day,
    int hour,
    int minute,
    double second
)
Parameters
year (Int32)
An integer value for the year, e.g., 1995.
month (Int32)
An integer value for the month of the year, e.g., 8 for August. It is permissible to have months outside of the 1-12 range, which will rollover to the previous or next year.
day (Int32)
An integer value for the day of the month, e.g., 23. It is permissible to have day numbers outside of the 1-31 range, which will rollover to the previous or next month and year.
hour (Int32)
An integer value for the hour of the day, e.g. 15. It is permissible to have hour values outside the 0-23 range, which will rollover to the previous or next day.
minute (Int32)
An integer value for the minute, e.g. 45. It is permissible to have hour values outside the 0-59 range, which will rollover to the previous or next hour.
second (Double)
A double value for the second, e.g. 35.75. It is permissible to have second values outside the 0-59 range, which will rollover to the previous or next minute.


XDate Constructor (year, month, day, hour, minute, second)

XDate Constructor (year, month, day, hour, minute, second)
Namespaces ► ZedGraph ► XDate ► XDateXDateNew(Int32, Int32, Int32, Int32, Int32, Int32)
Construct a date class from a calendar date and time (year, month, day, hour, minute, second).
Declaration Syntax
C# Visual Basic Visual C++
public XDate(
    int year,
    int month,
    int day,
    int hour,
    int minute,
    int second
)
Public Sub New ( _
    year As Integer, _
    month As Integer, _
    day As Integer, _
    hour As Integer, _
    minute As Integer, _
    second As Integer _
)
public:
XDate (
    int year,
    int month,
    int day,
    int hour,
    int minute,
    int second
)
Parameters
year (Int32)
An integer value for the year, e.g., 1995.
month (Int32)
An integer value for the month of the year, e.g., 8 for August. It is permissible to have months outside of the 1-12 range, which will rollover to the previous or next year.
day (Int32)
An integer value for the day of the month, e.g., 23. It is permissible to have day numbers outside of the 1-31 range, which will rollover to the previous or next month and year.
hour (Int32)
An integer value for the hour of the day, e.g. 15. It is permissible to have hour values outside the 0-23 range, which will rollover to the previous or next day.
minute (Int32)
An integer value for the minute, e.g. 45. It is permissible to have hour values outside the 0-59 range, which will rollover to the previous or next hour.
second (Int32)
An integer value for the second, e.g. 35. It is permissible to have second values outside the 0-59 range, which will rollover to the previous or next minute.


XDate Constructor (year, month, day, hour, minute, second, millisecond)

XDate Constructor (year, month, day, hour, minute, second, millisecond)
Namespaces ► ZedGraph ► XDate ► XDateXDateNew(Int32, Int32, Int32, Int32, Int32, Int32, Int32)
Construct a date class from a calendar date and time (year, month, day, hour, minute, second, millisecond).
Declaration Syntax
C# Visual Basic Visual C++
public XDate(
    int year,
    int month,
    int day,
    int hour,
    int minute,
    int second,
    int millisecond
)
Public Sub New ( _
    year As Integer, _
    month As Integer, _
    day As Integer, _
    hour As Integer, _
    minute As Integer, _
    second As Integer, _
    millisecond As Integer _
)
public:
XDate (
    int year,
    int month,
    int day,
    int hour,
    int minute,
    int second,
    int millisecond
)
Parameters
year (Int32)
An integer value for the year, e.g., 1995.
month (Int32)
An integer value for the month of the year, e.g., 8 for August. It is permissible to have months outside of the 1-12 range, which will rollover to the previous or next year.
day (Int32)
An integer value for the day of the month, e.g., 23. It is permissible to have day numbers outside of the 1-31 range, which will rollover to the previous or next month and year.
hour (Int32)
An integer value for the hour of the day, e.g. 15. It is permissible to have hour values outside the 0-23 range, which will rollover to the previous or next day.
minute (Int32)
An integer value for the minute, e.g. 45. It is permissible to have hour values outside the 0-59 range, which will rollover to the previous or next hour.
second (Int32)
An integer value for the second, e.g. 35. It is permissible to have second values outside the 0-59 range, which will rollover to the previous or next minute.
millisecond (Int32)
An integer value for the millisecond, e.g. 632. It is permissible to have millisecond values outside the 0-999 range, which will rollover to the previous or next second.


XDate Constructor (rhs)

XDate Constructor (rhs)
Namespaces ► ZedGraph ► XDate ► XDateXDateNew(XDate)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public XDate(
    XDate rhs
)
Public Sub New ( _
    rhs As XDate _
)
public:
XDate (
    XDate rhs
)
Parameters
rhs (XDate)
The GraphPane object from which to copy


AddDays Method (dDays)

AddDays Method (dDays)
Namespaces ► ZedGraph ► XDate ► AddDays(Double)
Add the specified number of days (can be fractional) to the current XDate instance.
Declaration Syntax
C# Visual Basic Visual C++
public void AddDays(
    double dDays
)
Public Sub AddDays ( _
    dDays As Double _
)
public:
void AddDays (
    double dDays
)
Parameters
dDays (Double)
The incremental number of days (negative or positive) in floating point double format.


AddHours Method (dHours)

AddHours Method (dHours)
Namespaces ► ZedGraph ► XDate ► AddHours(Double)
Add the specified number of hours (can be fractional) to the current XDate instance.
Declaration Syntax
C# Visual Basic Visual C++
public void AddHours(
    double dHours
)
Public Sub AddHours ( _
    dHours As Double _
)
public:
void AddHours (
    double dHours
)
Parameters
dHours (Double)
The incremental number of hours (negative or positive) in floating point double format.


Addition Operator

Addition Operator
Namespaces ► ZedGraph ► XDate ► Addition(XDate, Double)
'+' operator overload. When a double value is added to an XDate, the result is a new XDate with the number of days added.
Declaration Syntax
C# Visual Basic Visual C++
public static XDate operator +(
    XDate lhs,
    double rhs
)
Public Shared Operator + ( _
    lhs As XDate, _
    rhs As Double _
) As XDate
public:
static XDate operator + (
    XDate lhs,
    double rhs
)
Parameters
lhs (XDate)
The left-hand-side of the '-' operator (an XDate class)
rhs (Double)
The right-hand-side of the '+' operator (a double value)
Return Value
An XDate with the rhs number of days added


AddMilliseconds Method (dMilliseconds)

AddMilliseconds Method (dMilliseconds)
Namespaces ► ZedGraph ► XDate ► AddMilliseconds(Double)
Add the specified number of milliseconds (can be fractional) to the current XDate instance.
Declaration Syntax
C# Visual Basic Visual C++
public void AddMilliseconds(
    double dMilliseconds
)
Public Sub AddMilliseconds ( _
    dMilliseconds As Double _
)
public:
void AddMilliseconds (
    double dMilliseconds
)
Parameters
dMilliseconds (Double)
The incremental number of milliseconds (negative or positive) in floating point double format.


AddMinutes Method (dMinutes)

AddMinutes Method (dMinutes)
Namespaces ► ZedGraph ► XDate ► AddMinutes(Double)
Add the specified number of minutes (can be fractional) to the current XDate instance.
Declaration Syntax
C# Visual Basic Visual C++
public void AddMinutes(
    double dMinutes
)
Public Sub AddMinutes ( _
    dMinutes As Double _
)
public:
void AddMinutes (
    double dMinutes
)
Parameters
dMinutes (Double)
The incremental number of minutes (negative or positive) in floating point double format.


AddMonths Method (dMonths)

AddMonths Method (dMonths)
Namespaces ► ZedGraph ► XDate ► AddMonths(Double)
Add the specified number of Months (can be fractional) to the current XDate instance.
Declaration Syntax
C# Visual Basic Visual C++
public void AddMonths(
    double dMonths
)
Public Sub AddMonths ( _
    dMonths As Double _
)
public:
void AddMonths (
    double dMonths
)
Parameters
dMonths (Double)
The incremental number of months (negative or positive) in floating point double format.


AddSeconds Method (dSeconds)

AddSeconds Method (dSeconds)
Namespaces ► ZedGraph ► XDate ► AddSeconds(Double)
Add the specified number of seconds (can be fractional) to the current XDate instance.
Declaration Syntax
C# Visual Basic Visual C++
public void AddSeconds(
    double dSeconds
)
Public Sub AddSeconds ( _
    dSeconds As Double _
)
public:
void AddSeconds (
    double dSeconds
)
Parameters
dSeconds (Double)
The incremental number of seconds (negative or positive) in floating point double format.


AddYears Method (dYears)

AddYears Method (dYears)
Namespaces ► ZedGraph ► XDate ► AddYears(Double)
Add the specified number of years (can be fractional) to the current XDate instance.
Declaration Syntax
C# Visual Basic Visual C++
public void AddYears(
    double dYears
)
Public Sub AddYears ( _
    dYears As Double _
)
public:
void AddYears (
    double dYears
)
Parameters
dYears (Double)
The incremental number of years (negative or positive) in floating point double format.


CalendarDateToJulianDay Method

CalendarDateToJulianDay Method
Namespaces ► ZedGraph ► XDate ► CalendarDateToJulianDay()()
Members
Icon | Member | Description
 | CalendarDateToJulianDay(Int32, Int32, Int32, Int32, Int32, Int32) | Calculate an Astronomical Julian Day number from the specified Calendar date (year, month, day, hour, minute, second), first normalizing all input data values
 | CalendarDateToJulianDay(Int32, Int32, Int32, Int32, Int32, Int32, Int32) | Calculate an Astronomical Julian Day number from the specified Calendar date (year, month, day, hour, minute, second), first normalizing all input data values


CalendarDateToJulianDay Method (year, month, day, hour, minute, second)

CalendarDateToJulianDay Method (year, month, day, hour, minute, second)
Namespaces ► ZedGraph ► XDate ► CalendarDateToJulianDay(Int32, Int32, Int32, Int32, Int32, Int32)
Calculate an Astronomical Julian Day number from the specified Calendar date (year, month, day, hour, minute, second), first normalizing all input data values
Declaration Syntax
C# Visual Basic Visual C++
public static double CalendarDateToJulianDay(
    int year,
    int month,
    int day,
    int hour,
    int minute,
    int second
)
Public Shared Function CalendarDateToJulianDay ( _
    year As Integer, _
    month As Integer, _
    day As Integer, _
    hour As Integer, _
    minute As Integer, _
    second As Integer _
) As Double
public:
static double CalendarDateToJulianDay (
    int year,
    int month,
    int day,
    int hour,
    int minute,
    int second
)
Parameters
year (Int32)
The integer year value (e.g., 1994).
month (Int32)
The integer month value (e.g., 7 for July).
day (Int32)
The integer day value (e.g., 19 for the 19th day of the month).
hour (Int32)
The integer hour value (e.g., 14 for 2:00 pm).
minute (Int32)
The integer minute value (e.g., 35 for 35 minutes past the hour).
second (Int32)
The integer second value (e.g., 42 for 42 seconds past the minute).
Return Value
The corresponding Astronomical Julian Day number, expressed in double floating point format


CalendarDateToJulianDay Method (year, month, day, hour, minute, second, millisecond)

CalendarDateToJulianDay Method (year, month, day, hour, minute, second, millisecond)
Namespaces ► ZedGraph ► XDate ► CalendarDateToJulianDay(Int32, Int32, Int32, Int32, Int32, Int32, Int32)
Calculate an Astronomical Julian Day number from the specified Calendar date (year, month, day, hour, minute, second), first normalizing all input data values
Declaration Syntax
C# Visual Basic Visual C++
public static double CalendarDateToJulianDay(
    int year,
    int month,
    int day,
    int hour,
    int minute,
    int second,
    int millisecond
)
Public Shared Function CalendarDateToJulianDay ( _
    year As Integer, _
    month As Integer, _
    day As Integer, _
    hour As Integer, _
    minute As Integer, _
    second As Integer, _
    millisecond As Integer _
) As Double
public:
static double CalendarDateToJulianDay (
    int year,
    int month,
    int day,
    int hour,
    int minute,
    int second,
    int millisecond
)
Parameters
year (Int32)
The integer year value (e.g., 1994).
month (Int32)
The integer month value (e.g., 7 for July).
day (Int32)
The integer day value (e.g., 19 for the 19th day of the month).
hour (Int32)
The integer hour value (e.g., 14 for 2:00 pm).
minute (Int32)
The integer minute value (e.g., 35 for 35 minutes past the hour).
second (Int32)
The integer second value (e.g., 42 for 42 seconds past the minute).
millisecond (Int32)
The integer second value (e.g., 325 for 325 milliseconds past the minute).
Return Value
The corresponding Astronomical Julian Day number, expressed in double floating point format


CalendarDateToXLDate Method

CalendarDateToXLDate Method
Namespaces ► ZedGraph ► XDate ► CalendarDateToXLDate()()
Members
Icon | Member | Description
 | CalendarDateToXLDate(Int32, Int32, Int32, Int32, Int32, Int32, Int32) | Calculate an XL Date from the specified Calendar date (year, month, day, hour, minute, second), first normalizing all input data values.
 | CalendarDateToXLDate(Int32, Int32, Int32, Int32, Int32, Int32) | Calculate an XL Date from the specified Calendar date (year, month, day, hour, minute, second), first normalizing all input data values.
 | CalendarDateToXLDate(Int32, Int32, Int32, Int32, Int32, Double) | Calculate an XL Date from the specified Calendar date (year, month, day, hour, minute, second), first normalizing all input data values. The seconds value is a double type, allowing fractional seconds.


CalendarDateToXLDate Method (year, month, day, hour, minute, second)

CalendarDateToXLDate Method (year, month, day, hour, minute, second)
Namespaces ► ZedGraph ► XDate ► CalendarDateToXLDate(Int32, Int32, Int32, Int32, Int32, Double)
Calculate an XL Date from the specified Calendar date (year, month, day, hour, minute, second), first normalizing all input data values. The seconds value is a double type, allowing fractional seconds.
Declaration Syntax
C# Visual Basic Visual C++
public static double CalendarDateToXLDate(
    int year,
    int month,
    int day,
    int hour,
    int minute,
    double second
)
Public Shared Function CalendarDateToXLDate ( _
    year As Integer, _
    month As Integer, _
    day As Integer, _
    hour As Integer, _
    minute As Integer, _
    second As Double _
) As Double
public:
static double CalendarDateToXLDate (
    int year,
    int month,
    int day,
    int hour,
    int minute,
    double second
)
Parameters
year (Int32)
The integer year value (e.g., 1994).
month (Int32)
The integer month value (e.g., 7 for July).
day (Int32)
The integer day value (e.g., 19 for the 19th day of the month).
hour (Int32)
The integer hour value (e.g., 14 for 2:00 pm).
minute (Int32)
The integer minute value (e.g., 35 for 35 minutes past the hour).
second (Double)
The double second value (e.g., 42.3 for 42.3 seconds past the minute).
Return Value
The corresponding XL date, expressed in double floating point format
Remarks
The Calendar date is always based on the Gregorian Calendar. Note that the Gregorian calendar is really only valid from October 15, 1582 forward. The countries that adopted the Gregorian calendar first did so on October 4, 1582, so that the next day was October 15, 1582. Prior to that time the Julian Calendar was used. However, Prior to March 1, 4 AD the treatment of leap years was inconsistent, and prior to 45 BC the Julian Calendar did not exist. The XDate struct projects only Gregorian dates backwards and does not deal with Julian calendar dates at all. The ToString(Double, String) method will just append a "(BC)" notation to the end of any dates prior to 1 AD, since the DateTime struct throws an exception when formatting earlier dates.


CalendarDateToXLDate Method (year, month, day, hour, minute, second)

CalendarDateToXLDate Method (year, month, day, hour, minute, second)
Namespaces ► ZedGraph ► XDate ► CalendarDateToXLDate(Int32, Int32, Int32, Int32, Int32, Int32)
Calculate an XL Date from the specified Calendar date (year, month, day, hour, minute, second), first normalizing all input data values.
Declaration Syntax
C# Visual Basic Visual C++
public static double CalendarDateToXLDate(
    int year,
    int month,
    int day,
    int hour,
    int minute,
    int second
)
Public Shared Function CalendarDateToXLDate ( _
    year As Integer, _
    month As Integer, _
    day As Integer, _
    hour As Integer, _
    minute As Integer, _
    second As Integer _
) As Double
public:
static double CalendarDateToXLDate (
    int year,
    int month,
    int day,
    int hour,
    int minute,
    int second
)
Parameters
year (Int32)
The integer year value (e.g., 1994).
month (Int32)
The integer month value (e.g., 7 for July).
day (Int32)
The integer day value (e.g., 19 for the 19th day of the month).
hour (Int32)
The integer hour value (e.g., 14 for 2:00 pm).
minute (Int32)
The integer minute value (e.g., 35 for 35 minutes past the hour).
second (Int32)
The integer second value (e.g., 42 for 42 seconds past the minute).
Return Value
The corresponding XL date, expressed in double floating point format
Remarks
The Calendar date is always based on the Gregorian Calendar. Note that the Gregorian calendar is really only valid from October 15, 1582 forward. The countries that adopted the Gregorian calendar first did so on October 4, 1582, so that the next day was October 15, 1582. Prior to that time the Julian Calendar was used. However, Prior to March 1, 4 AD the treatment of leap years was inconsistent, and prior to 45 BC the Julian Calendar did not exist. The XDate struct projects only Gregorian dates backwards and does not deal with Julian calendar dates at all. The ToString(Double, String) method will just append a "(BC)" notation to the end of any dates prior to 1 AD, since the DateTime struct throws an exception when formatting earlier dates.


CalendarDateToXLDate Method (year, month, day, hour, minute, second, millisecond)

CalendarDateToXLDate Method (year, month, day, hour, minute, second, millisecond)
Namespaces ► ZedGraph ► XDate ► CalendarDateToXLDate(Int32, Int32, Int32, Int32, Int32, Int32, Int32)
Calculate an XL Date from the specified Calendar date (year, month, day, hour, minute, second), first normalizing all input data values.
Declaration Syntax
C# Visual Basic Visual C++
public static double CalendarDateToXLDate(
    int year,
    int month,
    int day,
    int hour,
    int minute,
    int second,
    int millisecond
)
Public Shared Function CalendarDateToXLDate ( _
    year As Integer, _
    month As Integer, _
    day As Integer, _
    hour As Integer, _
    minute As Integer, _
    second As Integer, _
    millisecond As Integer _
) As Double
public:
static double CalendarDateToXLDate (
    int year,
    int month,
    int day,
    int hour,
    int minute,
    int second,
    int millisecond
)
Parameters
year (Int32)
The integer year value (e.g., 1994).
month (Int32)
The integer month value (e.g., 7 for July).
day (Int32)
The integer day value (e.g., 19 for the 19th day of the month).
hour (Int32)
The integer hour value (e.g., 14 for 2:00 pm).
minute (Int32)
The integer minute value (e.g., 35 for 35 minutes past the hour).
second (Int32)
The integer second value (e.g., 42 for 42 seconds past the minute).
millisecond (Int32)
The integer millisecond value (e.g., 374 for 374 milliseconds past the second).
Return Value
The corresponding XL date, expressed in double floating point format
Remarks
The Calendar date is always based on the Gregorian Calendar. Note that the Gregorian calendar is really only valid from October 15, 1582 forward. The countries that adopted the Gregorian calendar first did so on October 4, 1582, so that the next day was October 15, 1582. Prior to that time the Julian Calendar was used. However, Prior to March 1, 4 AD the treatment of leap years was inconsistent, and prior to 45 BC the Julian Calendar did not exist. The XDate struct projects only Gregorian dates backwards and does not deal with Julian calendar dates at all. The ToString(Double, String) method will just append a "(BC)" notation to the end of any dates prior to 1 AD, since the DateTime struct throws an exception when formatting earlier dates.


DateTime Property

DateTime Property
Namespaces ► ZedGraph ► XDate ► DateTime
Gets or sets the date value for this item in .Net DateTime format.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateTime{ get; set;}
Public Property DateTime As DateTime
public:
property DateTime DateTime {
    DateTime get ();
    void set (DateTime value);
}


DateTimeToXLDate Method (dt)

DateTimeToXLDate Method (dt)
Namespaces ► ZedGraph ► XDate ► DateTimeToXLDate(DateTime)
Convert a .Net DateTime struct to an XL Format date
Declaration Syntax
C# Visual Basic Visual C++
public static double DateTimeToXLDate(
    DateTime dt
)
Public Shared Function DateTimeToXLDate ( _
    dt As DateTime _
) As Double
public:
static double DateTimeToXLDate (
    DateTime dt
)
Parameters
dt (DateTime)
The date value in the form of a .Net DateTime struct
Return Value
The corresponding XL Date, expressed in double floating point format


DecimalYear Property

DecimalYear Property
Namespaces ► ZedGraph ► XDate ► DecimalYear
Gets or sets the decimal year number (i.e., 1997.345) corresponding to this item.
Declaration Syntax
C# Visual Basic Visual C++
public double DecimalYear{ get; set;}
Public Property DecimalYear As Double
public:
property double DecimalYear {
    double get ();
    void set (double value);
}


DecimalYearToXLDate Method (yearDec)

DecimalYearToXLDate Method (yearDec)
Namespaces ► ZedGraph ► XDate ► DecimalYearToXLDate(Double)
Calculate a decimal year value (e.g., 1994.6523) corresponding to the specified XL date
Declaration Syntax
C# Visual Basic Visual C++
public static double DecimalYearToXLDate(
    double yearDec
)
Public Shared Function DecimalYearToXLDate ( _
    yearDec As Double _
) As Double
public:
static double DecimalYearToXLDate (
    double yearDec
)
Parameters
yearDec (Double)
The decimal year value in floating point double format.
Return Value
The corresponding XL Date, expressed in double floating point format


Decrement Operator

Decrement Operator
Namespaces ► ZedGraph ► XDate ► Decrement(XDate)
'--' operator overload. Decrement the date by one day.
Declaration Syntax
C# Visual Basic Visual C++
public static XDate operator --(
    XDate xDate
)
Public Shared Operator -- ( _
    xDate As XDate _
) As XDate
public:
static XDate operator -- (
    XDate xDate
)
Parameters
xDate (XDate)
The XDate struct on which to operate
Return Value
An XDate one day prior to the specified date


DefaultFormatStr Field

DefaultFormatStr Field
Namespaces ► ZedGraph ► XDate ► DefaultFormatStr
The default format string to be used in ToString()() when no format is provided
Declaration Syntax
C# Visual Basic Visual C++
public const string DefaultFormatStr
Public Const DefaultFormatStr As String
public:
literal String^ DefaultFormatStr


Equals Method (obj)

Equals Method (obj)
Namespaces ► ZedGraph ► XDate ► Equals(Object)
Tests whether obj is either an XDate structure or a double floating point value that is equal to the same date as this XDate struct instance.
Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals (
    Object^ obj
) override
Parameters
obj (Object)
The object to compare for equality with this XDate instance. This object should be either a type XDate or type double.
Return Value
Returns true if obj is the same date as this instance; otherwise, false


GetDate Method

GetDate Method
Namespaces ► ZedGraph ► XDate ► GetDate()()
Members
Icon | Member | Description
 | GetDate(Int32%, Int32%, Int32%) | Get the calendar date (year, month, day) corresponding to this instance.
 | GetDate(Int32%, Int32%, Int32%, Int32%, Int32%, Int32%) | Get the calendar date (year, month, day, hour, minute, second) corresponding to this instance.


GetDate Method (year, month, day)

GetDate Method (year, month, day)
Namespaces ► ZedGraph ► XDate ► GetDate(Int32%, Int32%, Int32%)
Get the calendar date (year, month, day) corresponding to this instance.
Declaration Syntax
C# Visual Basic Visual C++
public void GetDate(
    out int year,
    out int month,
    out int day
)
Public Sub GetDate ( _
    <OutAttribute> ByRef year As Integer, _
    <OutAttribute> ByRef month As Integer, _
    <OutAttribute> ByRef day As Integer _
)
public:
void GetDate (
    [OutAttribute] int% year,
    [OutAttribute] int% month,
    [OutAttribute] int% day
)
Parameters
year (Int32 %)
An integer value for the year, e.g., 1995.
month (Int32 %)
An integer value for the month of the year, e.g., 8 for August.
day (Int32 %)
An integer value for the day of the month, e.g., 23.


GetDate Method (year, month, day, hour, minute, second)

GetDate Method (year, month, day, hour, minute, second)
Namespaces ► ZedGraph ► XDate ► GetDate(Int32%, Int32%, Int32%, Int32%, Int32%, Int32%)
Get the calendar date (year, month, day, hour, minute, second) corresponding to this instance.
Declaration Syntax
C# Visual Basic Visual C++
public void GetDate(
    out int year,
    out int month,
    out int day,
    out int hour,
    out int minute,
    out int second
)
Public Sub GetDate ( _
    <OutAttribute> ByRef year As Integer, _
    <OutAttribute> ByRef month As Integer, _
    <OutAttribute> ByRef day As Integer, _
    <OutAttribute> ByRef hour As Integer, _
    <OutAttribute> ByRef minute As Integer, _
    <OutAttribute> ByRef second As Integer _
)
public:
void GetDate (
    [OutAttribute] int% year,
    [OutAttribute] int% month,
    [OutAttribute] int% day,
    [OutAttribute] int% hour,
    [OutAttribute] int% minute,
    [OutAttribute] int% second
)
Parameters
year (Int32 %)
An integer value for the year, e.g., 1995.
month (Int32 %)
An integer value for the month of the year, e.g., 8 for August.
day (Int32 %)
An integer value for the day of the month, e.g., 23.
hour (Int32 %)
An integer value for the hour of the day, e.g. 15.
minute (Int32 %)
An integer value for the minute, e.g. 45.
second (Int32 %)
An integer value for the second, e.g. 35.


GetDayOfYear Method

GetDayOfYear Method
Namespaces ► ZedGraph ► XDate ► GetDayOfYear()()
Get the day of year value (241.345 means the 241st day of the year) corresponding to this instance.
Declaration Syntax
C# Visual Basic Visual C++
public double GetDayOfYear()
Public Function GetDayOfYear As Double
public:
double GetDayOfYear ()
Return Value
The day of the year in floating point double format.


GetHashCode Method

GetHashCode Method
Namespaces ► ZedGraph ► XDate ► GetHashCode()()
Returns the hash code for this XDate structure. In this case, the hash code is simply the equivalent hash code for the floating point double date value.
Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode () override
Return Value
An integer representing the hash code for this XDate value


HoursPerDay Field

HoursPerDay Field
Namespaces ► ZedGraph ► XDate ► HoursPerDay
The number of hours in a day
Declaration Syntax
C# Visual Basic Visual C++
public const double HoursPerDay
Public Const HoursPerDay As Double
public:
literal double HoursPerDay


Implicit Method

Implicit Method
Namespaces ► ZedGraph ► XDate ► Implicit()()
Members
Icon | Member | Description
 | Implicit(XDate) | Implicit conversion from XDate to double (an XL Date).
 | Implicit(XDate) | Implicit conversion from XDate to float (an XL Date).
 | Implicit(Double) | Implicit conversion from double (an XL Date) to XDate.
 | Implicit(XDate) | Implicit conversion from XDate to DateTime.
 | Implicit(DateTime) | Implicit conversion from DateTime to XDate.


Implicit Operator

Implicit Operator
Namespaces ► ZedGraph ► XDate ► Implicit(DateTime)
Implicit conversion from DateTime to XDate.
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator XDate (
    DateTime dt
)
Public Shared Widening Operator CType ( _
    dt As DateTime _
) As XDate
static implicit operator XDate  (
    DateTime dt
)
Parameters
dt (DateTime)
The DateTime struct on which to operate
Return Value
An XDate struct representing the specified DateTime value.


Implicit Operator

Implicit Operator
Namespaces ► ZedGraph ► XDate ► Implicit(Double)
Implicit conversion from double (an XL Date) to XDate.
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator XDate (
    double xlDate
)
Public Shared Widening Operator CType ( _
    xlDate As Double _
) As XDate
static implicit operator XDate  (
    double xlDate
)
Parameters
xlDate (Double)
The XDate struct on which to operate
Return Value
An XDate struct representing the specified xlDate value.


Implicit Operator

Implicit Operator
Namespaces ► ZedGraph ► XDate ► Implicit(XDate)
Implicit conversion from XDate to float (an XL Date).
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator float (
    XDate xDate
)
Public Shared Widening Operator CType ( _
    xDate As XDate _
) As Single
static implicit operator float  (
    XDate xDate
)
Parameters
xDate (XDate)
The XDate struct on which to operate
Return Value
A double floating point value representing the XL Date


Implicit Operator

Implicit Operator
Namespaces ► ZedGraph ► XDate ► Implicit(XDate)
Implicit conversion from XDate to DateTime.
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator DateTime (
    XDate xDate
)
Public Shared Widening Operator CType ( _
    xDate As XDate _
) As DateTime
static implicit operator DateTime  (
    XDate xDate
)
Parameters
xDate (XDate)
The XDate struct on which to operate
Return Value
A DateTime struct representing the specified xDate value.


Implicit Operator

Implicit Operator
Namespaces ► ZedGraph ► XDate ► Implicit(XDate)
Implicit conversion from XDate to double (an XL Date).
Declaration Syntax
C# Visual Basic Visual C++
public static implicit operator double (
    XDate xDate
)
Public Shared Widening Operator CType ( _
    xDate As XDate _
) As Double
static implicit operator double  (
    XDate xDate
)
Parameters
xDate (XDate)
The XDate struct on which to operate
Return Value
A double floating point value representing the XL Date


Increment Operator

Increment Operator
Namespaces ► ZedGraph ► XDate ► Increment(XDate)
'++' operator overload. Increment the date by one day.
Declaration Syntax
C# Visual Basic Visual C++
public static XDate operator ++(
    XDate xDate
)
Public Shared Operator ++ ( _
    xDate As XDate _
) As XDate
public:
static XDate operator ++ (
    XDate xDate
)
Parameters
xDate (XDate)
The XDate struct on which to operate
Return Value
An XDate one day later than the specified date


IsValidDate Property

IsValidDate Property
Namespaces ► ZedGraph ► XDate ► IsValidDate
Returns true if this XDate struct is in the valid date range
Declaration Syntax
C# Visual Basic Visual C++
public bool IsValidDate{ get;}
Public ReadOnly Property IsValidDate As Boolean
public:
property bool IsValidDate {
    bool get ();
}


JulDayMax Field

JulDayMax Field
Namespaces ► ZedGraph ► XDate ► JulDayMax
The maximum valid Julian Day, which corresponds to December 31st, 9999 A.D.
Declaration Syntax
C# Visual Basic Visual C++
public const double JulDayMax
Public Const JulDayMax As Double
public:
literal double JulDayMax


JulDayMin Field

JulDayMin Field
Namespaces ► ZedGraph ► XDate ► JulDayMin
The minimum valid Julian Day, which corresponds to January 1st, 4713 B.C.
Declaration Syntax
C# Visual Basic Visual C++
public const double JulDayMin
Public Const JulDayMin As Double
public:
literal double JulDayMin


JulianDay Property

JulianDay Property
Namespaces ► ZedGraph ► XDate ► JulianDay
Gets or sets the date value for this item in Julain day format. This is the Astronomical Julian Day number, so a value of 0.0 corresponds to noon GMT on January 1st, -4712. Thus, Julian Day number 2,400,000.0 corresponds to noon GMT on November 16, 1858.
Declaration Syntax
C# Visual Basic Visual C++
public double JulianDay{ get; set;}
Public Property JulianDay As Double
public:
property double JulianDay {
    double get ();
    void set (double value);
}


JulianDayToCalendarDate Method

JulianDayToCalendarDate Method
Namespaces ► ZedGraph ► XDate ► JulianDayToCalendarDate()()
Members
Icon | Member | Description
 | JulianDayToCalendarDate(Double, Int32%, Int32%, Int32%, Int32%, Int32%, Int32%) | Calculate a Calendar date (year, month, day, hour, minute, second) corresponding to the Astronomical Julian Day number
 | JulianDayToCalendarDate(Double, Int32%, Int32%, Int32%, Int32%, Int32%, Double%) | Calculate a Calendar date (year, month, day, hour, minute, second) corresponding to the Astronomical Julian Day number
 | JulianDayToCalendarDate(Double, Int32%, Int32%, Int32%, Int32%, Int32%, Int32%, Double%) | Calculate a Calendar date (year, month, day, hour, minute, second) corresponding to the Astronomical Julian Day number


JulianDayToCalendarDate Method (jDay, year, month, day, hour, minute, second)

JulianDayToCalendarDate Method (jDay, year, month, day, hour, minute, second)
Namespaces ► ZedGraph ► XDate ► JulianDayToCalendarDate(Double, Int32%, Int32%, Int32%, Int32%, Int32%, Double%)
Calculate a Calendar date (year, month, day, hour, minute, second) corresponding to the Astronomical Julian Day number
Declaration Syntax
C# Visual Basic Visual C++
public static void JulianDayToCalendarDate(
    double jDay,
    out int year,
    out int month,
    out int day,
    out int hour,
    out int minute,
    out double second
)
Public Shared Sub JulianDayToCalendarDate ( _
    jDay As Double, _
    <OutAttribute> ByRef year As Integer, _
    <OutAttribute> ByRef month As Integer, _
    <OutAttribute> ByRef day As Integer, _
    <OutAttribute> ByRef hour As Integer, _
    <OutAttribute> ByRef minute As Integer, _
    <OutAttribute> ByRef second As Double _
)
public:
static void JulianDayToCalendarDate (
    double jDay,
    [OutAttribute] int% year,
    [OutAttribute] int% month,
    [OutAttribute] int% day,
    [OutAttribute] int% hour,
    [OutAttribute] int% minute,
    [OutAttribute] double% second
)
Parameters
jDay (Double)
The Astronomical Julian Day number to be converted
year (Int32 %)
The integer year value (e.g., 1994).
month (Int32 %)
The integer month value (e.g., 7 for July).
day (Int32 %)
The integer day value (e.g., 19 for the 19th day of the month).
hour (Int32 %)
The integer hour value (e.g., 14 for 2:00 pm).
minute (Int32 %)
The integer minute value (e.g., 35 for 35 minutes past the hour).
second (Double %)
The double second value (e.g., 42.3 for 42.3 seconds past the minute).


JulianDayToCalendarDate Method (jDay, year, month, day, hour, minute, second)

JulianDayToCalendarDate Method (jDay, year, month, day, hour, minute, second)
Namespaces ► ZedGraph ► XDate ► JulianDayToCalendarDate(Double, Int32%, Int32%, Int32%, Int32%, Int32%, Int32%)
Calculate a Calendar date (year, month, day, hour, minute, second) corresponding to the Astronomical Julian Day number
Declaration Syntax
C# Visual Basic Visual C++
public static void JulianDayToCalendarDate(
    double jDay,
    out int year,
    out int month,
    out int day,
    out int hour,
    out int minute,
    out int second
)
Public Shared Sub JulianDayToCalendarDate ( _
    jDay As Double, _
    <OutAttribute> ByRef year As Integer, _
    <OutAttribute> ByRef month As Integer, _
    <OutAttribute> ByRef day As Integer, _
    <OutAttribute> ByRef hour As Integer, _
    <OutAttribute> ByRef minute As Integer, _
    <OutAttribute> ByRef second As Integer _
)
public:
static void JulianDayToCalendarDate (
    double jDay,
    [OutAttribute] int% year,
    [OutAttribute] int% month,
    [OutAttribute] int% day,
    [OutAttribute] int% hour,
    [OutAttribute] int% minute,
    [OutAttribute] int% second
)
Parameters
jDay (Double)
The Astronomical Julian Day number to be converted
year (Int32 %)
The integer year value (e.g., 1994).
month (Int32 %)
The integer month value (e.g., 7 for July).
day (Int32 %)
The integer day value (e.g., 19 for the 19th day of the month).
hour (Int32 %)
The integer hour value (e.g., 14 for 2:00 pm).
minute (Int32 %)
The integer minute value (e.g., 35 for 35 minutes past the hour).
second (Int32 %)
The integer second value (e.g., 42 for 42 seconds past the minute).


JulianDayToCalendarDate Method (jDay, year, month, day, hour, minute, second, millisecond)

JulianDayToCalendarDate Method (jDay, year, month, day, hour, minute, second, millisecond)
Namespaces ► ZedGraph ► XDate ► JulianDayToCalendarDate(Double, Int32%, Int32%, Int32%, Int32%, Int32%, Int32%, Double%)
Calculate a Calendar date (year, month, day, hour, minute, second) corresponding to the Astronomical Julian Day number
Declaration Syntax
C# Visual Basic Visual C++
public static void JulianDayToCalendarDate(
    double jDay,
    out int year,
    out int month,
    out int day,
    out int hour,
    out int minute,
    out int second,
    out double millisecond
)
Public Shared Sub JulianDayToCalendarDate ( _
    jDay As Double, _
    <OutAttribute> ByRef year As Integer, _
    <OutAttribute> ByRef month As Integer, _
    <OutAttribute> ByRef day As Integer, _
    <OutAttribute> ByRef hour As Integer, _
    <OutAttribute> ByRef minute As Integer, _
    <OutAttribute> ByRef second As Integer, _
    <OutAttribute> ByRef millisecond As Double _
)
public:
static void JulianDayToCalendarDate (
    double jDay,
    [OutAttribute] int% year,
    [OutAttribute] int% month,
    [OutAttribute] int% day,
    [OutAttribute] int% hour,
    [OutAttribute] int% minute,
    [OutAttribute] int% second,
    [OutAttribute] double% millisecond
)
Parameters
jDay (Double)
The Astronomical Julian Day number to be converted
year (Int32 %)
The integer year value (e.g., 1994).
month (Int32 %)
The integer month value (e.g., 7 for July).
day (Int32 %)
The integer day value (e.g., 19 for the 19th day of the month).
hour (Int32 %)
The integer hour value (e.g., 14 for 2:00 pm).
minute (Int32 %)
The integer minute value (e.g., 35 for 35 minutes past the hour).
second (Int32 %)
The integer second value (e.g., 42 for 42 seconds past the minute).
millisecond (Double %)
The Double millisecond value (e.g., 342.5 for 342.5 milliseconds past the second).


JulianDayToXLDate Method (jDay)

JulianDayToXLDate Method (jDay)
Namespaces ► ZedGraph ► XDate ► JulianDayToXLDate(Double)
Calculate an XL Date corresponding to the specified Astronomical Julian Day number
Declaration Syntax
C# Visual Basic Visual C++
public static double JulianDayToXLDate(
    double jDay
)
Public Shared Function JulianDayToXLDate ( _
    jDay As Double _
) As Double
public:
static double JulianDayToXLDate (
    double jDay
)
Parameters
jDay (Double)
The Astronomical Julian Day number in floating point double format.
Return Value
The corresponding XL Date, expressed in double floating point format


MakeValidDate Method (xlDate)

MakeValidDate Method (xlDate)
Namespaces ► ZedGraph ► XDate ► MakeValidDate(Double)
Take the specified date, and bound it to the valid date range for the XDate struct.
Declaration Syntax
C# Visual Basic Visual C++
public static double MakeValidDate(
    double xlDate
)
Public Shared Function MakeValidDate ( _
    xlDate As Double _
) As Double
public:
static double MakeValidDate (
    double xlDate
)
Parameters
xlDate (Double)
The date to be bounded
Return Value
An XLDate value that lies between the minimum and maximum valid date ranges (see XLDayMin and XLDayMax)


MillisecondsPerDay Field

MillisecondsPerDay Field
Namespaces ► ZedGraph ► XDate ► MillisecondsPerDay
The number of milliseconds in a day
Declaration Syntax
C# Visual Basic Visual C++
public const double MillisecondsPerDay
Public Const MillisecondsPerDay As Double
public:
literal double MillisecondsPerDay


MillisecondsPerSecond Field

MillisecondsPerSecond Field
Namespaces ► ZedGraph ► XDate ► MillisecondsPerSecond
The number of milliseconds in a second
Declaration Syntax
C# Visual Basic Visual C++
public const double MillisecondsPerSecond
Public Const MillisecondsPerSecond As Double
public:
literal double MillisecondsPerSecond


MinutesPerDay Field

MinutesPerDay Field
Namespaces ► ZedGraph ► XDate ► MinutesPerDay
The number of minutes in a day
Declaration Syntax
C# Visual Basic Visual C++
public const double MinutesPerDay
Public Const MinutesPerDay As Double
public:
literal double MinutesPerDay


MinutesPerHour Field

MinutesPerHour Field
Namespaces ► ZedGraph ► XDate ► MinutesPerHour
The number of minutes in an hour
Declaration Syntax
C# Visual Basic Visual C++
public const double MinutesPerHour
Public Const MinutesPerHour As Double
public:
literal double MinutesPerHour


MonthsPerYear Field

MonthsPerYear Field
Namespaces ► ZedGraph ► XDate ► MonthsPerYear
The number of months in a year
Declaration Syntax
C# Visual Basic Visual C++
public const double MonthsPerYear
Public Const MonthsPerYear As Double
public:
literal double MonthsPerYear


SecondsPerDay Field

SecondsPerDay Field
Namespaces ► ZedGraph ► XDate ► SecondsPerDay
The number of seconds in a day
Declaration Syntax
C# Visual Basic Visual C++
public const double SecondsPerDay
Public Const SecondsPerDay As Double
public:
literal double SecondsPerDay


SecondsPerMinute Field

SecondsPerMinute Field
Namespaces ► ZedGraph ► XDate ► SecondsPerMinute
The number of seconds in a minute
Declaration Syntax
C# Visual Basic Visual C++
public const double SecondsPerMinute
Public Const SecondsPerMinute As Double
public:
literal double SecondsPerMinute


SetDate Method

SetDate Method
Namespaces ► ZedGraph ► XDate ► SetDate()()
Members
Icon | Member | Description
 | SetDate(Int32, Int32, Int32) | Set the calendar date (year, month, day) of this instance.
 | SetDate(Int32, Int32, Int32, Int32, Int32, Int32) | Set the calendar date (year, month, day, hour, minute, second) of this instance.


SetDate Method (year, month, day)

SetDate Method (year, month, day)
Namespaces ► ZedGraph ► XDate ► SetDate(Int32, Int32, Int32)
Set the calendar date (year, month, day) of this instance.
Declaration Syntax
C# Visual Basic Visual C++
public void SetDate(
    int year,
    int month,
    int day
)
Public Sub SetDate ( _
    year As Integer, _
    month As Integer, _
    day As Integer _
)
public:
void SetDate (
    int year,
    int month,
    int day
)
Parameters
year (Int32)
An integer value for the year, e.g., 1995.
month (Int32)
An integer value for the month of the year, e.g., 8 for August.
day (Int32)
An integer value for the day of the month, e.g., 23.


SetDate Method (year, month, day, hour, minute, second)

SetDate Method (year, month, day, hour, minute, second)
Namespaces ► ZedGraph ► XDate ► SetDate(Int32, Int32, Int32, Int32, Int32, Int32)
Set the calendar date (year, month, day, hour, minute, second) of this instance.
Declaration Syntax
C# Visual Basic Visual C++
public void SetDate(
    int year,
    int month,
    int day,
    int hour,
    int minute,
    int second
)
Public Sub SetDate ( _
    year As Integer, _
    month As Integer, _
    day As Integer, _
    hour As Integer, _
    minute As Integer, _
    second As Integer _
)
public:
void SetDate (
    int year,
    int month,
    int day,
    int hour,
    int minute,
    int second
)
Parameters
year (Int32)
An integer value for the year, e.g., 1995.
month (Int32)
An integer value for the month of the year, e.g., 8 for August.
day (Int32)
An integer value for the day of the month, e.g., 23.
hour (Int32)
An integer value for the hour of the day, e.g. 15.
minute (Int32)
An integer value for the minute, e.g. 45.
second (Int32)
An integer value for the second, e.g. 35.


Subtraction Method

Subtraction Method
Namespaces ► ZedGraph ► XDate ► Subtraction()()
Members
Icon | Member | Description
 | Subtraction(XDate, XDate) | '-' operator overload. When two XDates are subtracted, the number of days between dates is returned.
 | Subtraction(XDate, Double) | '-' operator overload. When a double value is subtracted from an XDate, the result is a new XDate with the number of days subtracted.


Subtraction Operator

Subtraction Operator
Namespaces ► ZedGraph ► XDate ► Subtraction(XDate, Double)
'-' operator overload. When a double value is subtracted from an XDate, the result is a new XDate with the number of days subtracted.
Declaration Syntax
C# Visual Basic Visual C++
public static XDate operator -(
    XDate lhs,
    double rhs
)
Public Shared Operator - ( _
    lhs As XDate, _
    rhs As Double _
) As XDate
public:
static XDate operator - (
    XDate lhs,
    double rhs
)
Parameters
lhs (XDate)
The left-hand-side of the '-' operator (an XDate class)
rhs (Double)
The right-hand-side of the '-' operator (a double value)
Return Value
An XDate with the rhs number of days subtracted


Subtraction Operator

Subtraction Operator
Namespaces ► ZedGraph ► XDate ► Subtraction(XDate, XDate)
'-' operator overload. When two XDates are subtracted, the number of days between dates is returned.
Declaration Syntax
C# Visual Basic Visual C++
public static double operator -(
    XDate lhs,
    XDate rhs
)
Public Shared Operator - ( _
    lhs As XDate, _
    rhs As XDate _
) As Double
public:
static double operator - (
    XDate lhs,
    XDate rhs
)
Parameters
lhs (XDate)
The left-hand-side of the '-' operator (an XDate class)
rhs (XDate)
The right-hand-side of the '-' operator (an XDate class)
Return Value
The days between dates, expressed as a floating point double


ToString Method

ToString Method
Namespaces ► ZedGraph ► XDate ► ToString()()
Members
Icon | Member | Description
 | ToString(Double) | Format this XDate value using the default format string (DefaultFormatStr).
 | ToString()() | Format this XDate value using the default format string (see cref="DefaultFormatStr"/>). (Overrides ValueType.ToString()().)
 | ToString(String) | Format this XL Date value using the specified format string. The format string is specified according to the DateTime class.
 | ToString(Double, String) | Format the specified XL Date value using the specified format string. The format string is specified according to the DateTime class.


ToString Method

ToString Method
Namespaces ► ZedGraph ► XDate ► ToString()()
Format this XDate value using the default format string (see cref="DefaultFormatStr"/>).
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
A string representation of the date
Remarks
The formatting is done using the DateTime ToString(String) method in order to provide full localization capability. The DateTime struct is limited to dates from 1 AD onward. However, all calendar dates in XDate and DateTime are projected Gregorian calendar dates. Since the Gregorian calendar was not implemented until October 4, 1582 (or later in some countries), Gregorian dates prior to that time are really dates that would have been, had the Gregorian calendar existed. In order to avoid throwing an exception, for dates prior to 1 AD, the year will be converted to a positive year and the text "(BC)" is appended to the end of the formatted string. Under this mode, the year sequence is 2BC, 1BC, 1AD, 2AD, etc. There is no year zero.


ToString Method (xlDate)

ToString Method (xlDate)
Namespaces ► ZedGraph ► XDate ► ToString(Double)
Format this XDate value using the default format string (DefaultFormatStr).
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    double xlDate
)
Public Function ToString ( _
    xlDate As Double _
) As String
public:
String^ ToString (
    double xlDate
)
Parameters
xlDate (Double)
The XL date value to be formatted in floating point double format.
Return Value
A string representation of the date
Remarks
The formatting is done using the DateTime ToString(String) method in order to provide full localization capability. The DateTime struct is limited to dates from 1 AD onward. However, all calendar dates in XDate and DateTime are projected Gregorian calendar dates. Since the Gregorian calendar was not implemented until October 4, 1582 (or later in some countries), Gregorian dates prior to that time are really dates that would have been, had the Gregorian calendar existed. In order to avoid throwing an exception, for dates prior to 1 AD, the year will be converted to a positive year and the text "(BC)" is appended to the end of the formatted string. Under this mode, the year sequence is 2BC, 1BC, 1AD, 2AD, etc. There is no year zero.


ToString Method (xlDate, fmtStr)

ToString Method (xlDate, fmtStr)
Namespaces ► ZedGraph ► XDate ► ToString(Double, String)
Format the specified XL Date value using the specified format string. The format string is specified according to the DateTime class.
Declaration Syntax
C# Visual Basic Visual C++
public static string ToString(
    double xlDate,
    string fmtStr
)
Public Shared Function ToString ( _
    xlDate As Double, _
    fmtStr As String _
) As String
public:
static String^ ToString (
    double xlDate,
    String^ fmtStr
)
Parameters
xlDate (Double)
The XL date value to be formatted in floating point double format.
fmtStr (String)
The formatting string to be used for the date. See DateTimeFormatInfo for a list of the format types available.
Return Value
A string representation of the date
Remarks
The formatting is done using the DateTime ToString(String) method in order to provide full localization capability. The DateTime struct is limited to dates from 1 AD onward. However, all calendar dates in XDate and DateTime are projected Gregorian calendar dates. Since the Gregorian calendar was not implemented until October 4, 1582 (or later in some countries), Gregorian dates prior to that time are really dates that would have been, had the Gregorian calendar existed. In order to avoid throwing an exception, for dates prior to 1 AD, the year will be converted to a positive year and the text "(BC)" is appended to the end of the formatted string. Under this mode, the year sequence is 2BC, 1BC, 1AD, 2AD, etc. There is no year zero.


ToString Method (fmtStr)

ToString Method (fmtStr)
Namespaces ► ZedGraph ► XDate ► ToString(String)
Format this XL Date value using the specified format string. The format string is specified according to the DateTime class.
Declaration Syntax
C# Visual Basic Visual C++
public string ToString(
    string fmtStr
)
Public Function ToString ( _
    fmtStr As String _
) As String
public:
String^ ToString (
    String^ fmtStr
)
Parameters
fmtStr (String)
The formatting string to be used for the date. See DateTimeFormatInfo class for a list of the format types available.
Return Value
A string representation of the date
Remarks
The formatting is done using the DateTime ToString(String) method in order to provide full localization capability. The DateTime struct is limited to dates from 1 AD onward. However, all calendar dates in XDate and DateTime are projected Gregorian calendar dates. Since the Gregorian calendar was not implemented until October 4, 1582 (or later in some countries), Gregorian dates prior to that time are really dates that would have been, had the Gregorian calendar existed. In order to avoid throwing an exception, for dates prior to 1 AD, the year will be converted to a positive year and the text "(BC)" is appended to the end of the formatted string. Under this mode, the year sequence is 2BC, 1BC, 1AD, 2AD, etc. There is no year zero.


XLDate Property

XLDate Property
Namespaces ► ZedGraph ► XDate ► XLDate
Gets or sets the date value for this item in MS Excel format.
Declaration Syntax
C# Visual Basic Visual C++
public double XLDate{ get; set;}
Public Property XLDate As Double
public:
property double XLDate {
    double get ();
    void set (double value);
}


XLDateToCalendarDate Method

XLDateToCalendarDate Method
Namespaces ► ZedGraph ► XDate ► XLDateToCalendarDate()()
Members
Icon | Member | Description
 | XLDateToCalendarDate(Double, Int32%, Int32%, Int32%, Int32%, Int32%, Int32%) | Calculate a Calendar date (year, month, day, hour, minute, second) corresponding to the specified XL date
 | XLDateToCalendarDate(Double, Int32%, Int32%, Int32%, Int32%, Int32%, Int32%, Int32%) | Calculate a Calendar date (year, month, day, hour, minute, second) corresponding to the specified XL date
 | XLDateToCalendarDate(Double, Int32%, Int32%, Int32%, Int32%, Int32%, Double%) | Calculate a Calendar date (year, month, day, hour, minute, second) corresponding to the specified XL date


XLDateToCalendarDate Method (xlDate, year, month, day, hour, minute, second)

XLDateToCalendarDate Method (xlDate, year, month, day, hour, minute, second)
Namespaces ► ZedGraph ► XDate ► XLDateToCalendarDate(Double, Int32%, Int32%, Int32%, Int32%, Int32%, Double%)
Calculate a Calendar date (year, month, day, hour, minute, second) corresponding to the specified XL date
Declaration Syntax
C# Visual Basic Visual C++
public static void XLDateToCalendarDate(
    double xlDate,
    out int year,
    out int month,
    out int day,
    out int hour,
    out int minute,
    out double second
)
Public Shared Sub XLDateToCalendarDate ( _
    xlDate As Double, _
    <OutAttribute> ByRef year As Integer, _
    <OutAttribute> ByRef month As Integer, _
    <OutAttribute> ByRef day As Integer, _
    <OutAttribute> ByRef hour As Integer, _
    <OutAttribute> ByRef minute As Integer, _
    <OutAttribute> ByRef second As Double _
)
public:
static void XLDateToCalendarDate (
    double xlDate,
    [OutAttribute] int% year,
    [OutAttribute] int% month,
    [OutAttribute] int% day,
    [OutAttribute] int% hour,
    [OutAttribute] int% minute,
    [OutAttribute] double% second
)
Parameters
xlDate (Double)
The XL date value in floating point double format.
year (Int32 %)
The integer year value (e.g., 1994).
month (Int32 %)
The integer month value (e.g., 7 for July).
day (Int32 %)
The integer day value (e.g., 19 for the 19th day of the month).
hour (Int32 %)
The integer hour value (e.g., 14 for 2:00 pm).
minute (Int32 %)
The integer minute value (e.g., 35 for 35 minutes past the hour).
second (Double %)
The double second value (e.g., 42.3 for 42.3 seconds past the minute).


XLDateToCalendarDate Method (xlDate, year, month, day, hour, minute, second)

XLDateToCalendarDate Method (xlDate, year, month, day, hour, minute, second)
Namespaces ► ZedGraph ► XDate ► XLDateToCalendarDate(Double, Int32%, Int32%, Int32%, Int32%, Int32%, Int32%)
Calculate a Calendar date (year, month, day, hour, minute, second) corresponding to the specified XL date
Declaration Syntax
C# Visual Basic Visual C++
public static void XLDateToCalendarDate(
    double xlDate,
    out int year,
    out int month,
    out int day,
    out int hour,
    out int minute,
    out int second
)
Public Shared Sub XLDateToCalendarDate ( _
    xlDate As Double, _
    <OutAttribute> ByRef year As Integer, _
    <OutAttribute> ByRef month As Integer, _
    <OutAttribute> ByRef day As Integer, _
    <OutAttribute> ByRef hour As Integer, _
    <OutAttribute> ByRef minute As Integer, _
    <OutAttribute> ByRef second As Integer _
)
public:
static void XLDateToCalendarDate (
    double xlDate,
    [OutAttribute] int% year,
    [OutAttribute] int% month,
    [OutAttribute] int% day,
    [OutAttribute] int% hour,
    [OutAttribute] int% minute,
    [OutAttribute] int% second
)
Parameters
xlDate (Double)
The XL date value in floating point double format.
year (Int32 %)
The integer year value (e.g., 1994).
month (Int32 %)
The integer month value (e.g., 7 for July).
day (Int32 %)
The integer day value (e.g., 19 for the 19th day of the month).
hour (Int32 %)
The integer hour value (e.g., 14 for 2:00 pm).
minute (Int32 %)
The integer minute value (e.g., 35 for 35 minutes past the hour).
second (Int32 %)
The integer second value (e.g., 42 for 42 seconds past the minute).


XLDateToCalendarDate Method (xlDate, year, month, day, hour, minute, second, millisecond)

XLDateToCalendarDate Method (xlDate, year, month, day, hour, minute, second, millisecond)
Namespaces ► ZedGraph ► XDate ► XLDateToCalendarDate(Double, Int32%, Int32%, Int32%, Int32%, Int32%, Int32%, Int32%)
Calculate a Calendar date (year, month, day, hour, minute, second) corresponding to the specified XL date
Declaration Syntax
C# Visual Basic Visual C++
public static void XLDateToCalendarDate(
    double xlDate,
    out int year,
    out int month,
    out int day,
    out int hour,
    out int minute,
    out int second,
    out int millisecond
)
Public Shared Sub XLDateToCalendarDate ( _
    xlDate As Double, _
    <OutAttribute> ByRef year As Integer, _
    <OutAttribute> ByRef month As Integer, _
    <OutAttribute> ByRef day As Integer, _
    <OutAttribute> ByRef hour As Integer, _
    <OutAttribute> ByRef minute As Integer, _
    <OutAttribute> ByRef second As Integer, _
    <OutAttribute> ByRef millisecond As Integer _
)
public:
static void XLDateToCalendarDate (
    double xlDate,
    [OutAttribute] int% year,
    [OutAttribute] int% month,
    [OutAttribute] int% day,
    [OutAttribute] int% hour,
    [OutAttribute] int% minute,
    [OutAttribute] int% second,
    [OutAttribute] int% millisecond
)
Parameters
xlDate (Double)
The XL date value in floating point double format.
year (Int32 %)
The integer year value (e.g., 1994).
month (Int32 %)
The integer month value (e.g., 7 for July).
day (Int32 %)
The integer day value (e.g., 19 for the 19th day of the month).
hour (Int32 %)
The integer hour value (e.g., 14 for 2:00 pm).
minute (Int32 %)
The integer minute value (e.g., 35 for 35 minutes past the hour).
second (Int32 %)
The integer second value (e.g., 42 for 42 seconds past the minute).
millisecond (Int32 %)
The integer millisecond value (e.g., 325 for 325 milliseconds past the second).


XLDateToDateTime Method (xlDate)

XLDateToDateTime Method (xlDate)
Namespaces ► ZedGraph ► XDate ► XLDateToDateTime(Double)
Convert an XL date format to a .Net DateTime struct
Declaration Syntax
C# Visual Basic Visual C++
public static DateTime XLDateToDateTime(
    double xlDate
)
Public Shared Function XLDateToDateTime ( _
    xlDate As Double _
) As DateTime
public:
static DateTime XLDateToDateTime (
    double xlDate
)
Parameters
xlDate (Double)
The XL date value in floating point double format.
Return Value
The corresponding XL Date, expressed in double floating point format
Return Value
The corresponding date in the form of a .Net DateTime struct


XLDateToDayOfWeek Method (xlDate)

XLDateToDayOfWeek Method (xlDate)
Namespaces ► ZedGraph ► XDate ► XLDateToDayOfWeek(Double)
Calculate a day-of-week value (e.g., Sun=0, Mon=1, Tue=2, etc.) corresponding to the specified XL date
Declaration Syntax
C# Visual Basic Visual C++
public static int XLDateToDayOfWeek(
    double xlDate
)
Public Shared Function XLDateToDayOfWeek ( _
    xlDate As Double _
) As Integer
public:
static int XLDateToDayOfWeek (
    double xlDate
)
Parameters
xlDate (Double)
The XL date value in floating point double format.
Return Value
The corresponding day-of-week (DoW) value, expressed in integer format


XLDateToDayOfYear Method (xlDate)

XLDateToDayOfYear Method (xlDate)
Namespaces ► ZedGraph ► XDate ► XLDateToDayOfYear(Double)
Calculate a day-of-year value (e.g., 241.543 corresponds to the 241st day of the year) corresponding to the specified XL date
Declaration Syntax
C# Visual Basic Visual C++
public static double XLDateToDayOfYear(
    double xlDate
)
Public Shared Function XLDateToDayOfYear ( _
    xlDate As Double _
) As Double
public:
static double XLDateToDayOfYear (
    double xlDate
)
Parameters
xlDate (Double)
The XL date value in floating point double format.
Return Value
The corresponding day-of-year (DoY) value, expressed in double floating point format


XLDateToDecimalYear Method (xlDate)

XLDateToDecimalYear Method (xlDate)
Namespaces ► ZedGraph ► XDate ► XLDateToDecimalYear(Double)
Calculate a decimal year value (e.g., 1994.6523) corresponding to the specified XL date
Declaration Syntax
C# Visual Basic Visual C++
public static double XLDateToDecimalYear(
    double xlDate
)
Public Shared Function XLDateToDecimalYear ( _
    xlDate As Double _
) As Double
public:
static double XLDateToDecimalYear (
    double xlDate
)
Parameters
xlDate (Double)
The XL date value in floating point double format.
Return Value
The corresponding decimal year value, expressed in double floating point format


XLDateToJulianDay Method (xlDate)

XLDateToJulianDay Method (xlDate)
Namespaces ► ZedGraph ► XDate ► XLDateToJulianDay(Double)
Calculate an Astronomical Julian Day number corresponding to the specified XL date
Declaration Syntax
C# Visual Basic Visual C++
public static double XLDateToJulianDay(
    double xlDate
)
Public Shared Function XLDateToJulianDay ( _
    xlDate As Double _
) As Double
public:
static double XLDateToJulianDay (
    double xlDate
)
Parameters
xlDate (Double)
The XL date value in floating point double format.
Return Value
The corresponding Astronomical Julian Day number, expressed in double floating point format


XLDay1 Field

XLDay1 Field
Namespaces ► ZedGraph ► XDate ► XLDay1
The Astronomical Julian Day number that corresponds to XL Date 0.0
Declaration Syntax
C# Visual Basic Visual C++
public const double XLDay1
Public Const XLDay1 As Double
public:
literal double XLDay1


XLDayMax Field

XLDayMax Field
Namespaces ► ZedGraph ► XDate ► XLDayMax
The maximum valid Excel Day, which corresponds to December 31st, 9999 A.D.
Declaration Syntax
C# Visual Basic Visual C++
public const double XLDayMax
Public Const XLDayMax As Double
public:
literal double XLDayMax


XLDayMin Field

XLDayMin Field
Namespaces ► ZedGraph ► XDate ► XLDayMin
The minimum valid Excel Day, which corresponds to January 1st, 4713 B.C.
Declaration Syntax
C# Visual Basic Visual C++
public const double XLDayMin
Public Const XLDayMin As Double
public:
literal double XLDayMin


Y2Axis Class

Y2Axis Class
Namespaces ► ZedGraph ► Y2Axis
Y2Axis inherits from Axis, and defines the special characteristics of a vertical axis, specifically located on the right side of the Rect of the GraphPane object
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Y2Axis : Axis, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class Y2Axis _
    Inherits Axis _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class Y2Axis : public Axis,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Y2AxisY2AxisNew()() | Default constructor that sets all Y2Axis properties to default values as defined in the Y2Axis..::Default class
 | Y2AxisY2AxisNew(String) | Default constructor that sets all Y2Axis properties to default values as defined in the Y2Axis..::Default class, except for the axis title
 | Y2AxisY2AxisNew(Y2Axis) | The Copy Constructor
 | AxisGap | The size of the gap between multiple axes (see YAxisList and Y2AxisList). (Inherited from Axis.)
 | CalcSpace(Graphics, GraphPane, Single, Single%) | Calculate the space required (pixels) for this Axis object. (Inherited from Axis.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The color to use for drawing this Axis. (Inherited from Axis.)
 | Cross | Gets or sets the scale value at which this axis should cross the "other" axis. (Inherited from Axis.)
 | CrossAuto | Gets or sets a value that determines whether or not the Cross value is set automatically. (Inherited from Axis.)
 | Draw(Graphics, GraphPane, Single, Single) | Do all rendering associated with this Axis to the specified Graphics device. (Inherited from Axis.)
 | DrawMinorTics(Graphics, GraphPane, Double, Single, Single, Single) | Draw the minor tic marks as required for this Axis. (Inherited from Axis.)
 | DrawTitle(Graphics, GraphPane, Single, Single) | Draw the title for this Axis. (Inherited from Axis.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCrossAxis(GraphPane) | Gets the "Cross" axis that corresponds to this axis. (Overrides Axis.GetCrossAxis(GraphPane).)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides Axis.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAxisSegmentVisible | Gets or sets a property that determines whether or not the axis segment (the line that represents the axis itself) is drawn. (Inherited from Axis.)
 | IsVisible | This property determines whether or not the Axis is shown. (Inherited from Axis.)
 | MajorGrid | Gets a reference to the MajorGrid class that contains the properties of the major grid. (Inherited from Axis.)
 | MajorTic | Gets a reference to the MajorTic class instance for this Axis. This class stores all the major tic settings. (Inherited from Axis.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinorGrid | Gets a reference to the MinorGrid class that contains the properties of the minor grid. (Inherited from Axis.)
 | MinorTic | Gets a reference to the MinorTic class instance for this Axis. This class stores all the minor tic settings. (Inherited from Axis.)
 | MinSpace | Gets or sets the minimum axis space allocation. (Inherited from Axis.)
 | ResetAutoScale(GraphPane, Graphics) | Restore the scale ranging to automatic mode, and recalculate the Axis scale ranges (Inherited from Axis.)
 | Scale | Gets the Scale instance associated with this Axis. (Inherited from Axis.)
 | ScaleFormatEvent | Subscribe to this event to handle custom formatting of the scale labels. (Inherited from Axis.)
 | ScaleTitleEvent | Allow customization of the title when the scale is very large Subscribe to this event to handle custom formatting of the scale axis label. (Inherited from Axis.)
 | schema2 | Current schema value that defines the version of the serialized file
 | SetMinSpaceBuffer(Graphics, GraphPane, Single, Boolean) | This method will set the MinSpace property for this Axis using the currently required space multiplied by a fraction (). (Inherited from Axis.)
 | SetTransformMatrix(Graphics, GraphPane, Single) | Setup the Transform Matrix to handle drawing of this Y2Axis (Overrides Axis.SetTransformMatrix(Graphics, GraphPane, Single).)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the Axis. ZedGraph does not use this value for any purpose. (Inherited from Axis.)
 | Title | Gets or sets the Label class that contains the title of this Axis. (Inherited from Axis.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets or sets the AxisType for this Axis. (Inherited from Axis.)
Inheritance Hierarchy
Object
 | Axis
 |  | Y2Axis


Y2Axis Constructor

Y2Axis Constructor
Namespaces ► ZedGraph ► Y2Axis ► Y2AxisY2AxisNew()()
Members
Icon | Member | Description
 | Y2AxisY2AxisNew()() | Default constructor that sets all Y2Axis properties to default values as defined in the Y2Axis..::Default class
 | Y2AxisY2AxisNew(String) | Default constructor that sets all Y2Axis properties to default values as defined in the Y2Axis..::Default class, except for the axis title
 | Y2AxisY2AxisNew(Y2Axis) | The Copy Constructor


Y2Axis Constructor

Y2Axis Constructor
Namespaces ► ZedGraph ► Y2Axis ► Y2AxisY2AxisNew()()
Default constructor that sets all Y2Axis properties to default values as defined in the Y2Axis..::Default class
Declaration Syntax
C# Visual Basic Visual C++
public Y2Axis()
Public Sub New
public:
Y2Axis ()


Y2Axis Constructor (title)

Y2Axis Constructor (title)
Namespaces ► ZedGraph ► Y2Axis ► Y2AxisY2AxisNew(String)
Default constructor that sets all Y2Axis properties to default values as defined in the Y2Axis..::Default class, except for the axis title
Declaration Syntax
C# Visual Basic Visual C++
public Y2Axis(
    string title
)
Public Sub New ( _
    title As String _
)
public:
Y2Axis (
    String^ title
)
Parameters
title (String)
The Title for this axis


Y2Axis Constructor (rhs)

Y2Axis Constructor (rhs)
Namespaces ► ZedGraph ► Y2Axis ► Y2AxisY2AxisNew(Y2Axis)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public Y2Axis(
    Y2Axis rhs
)
Public Sub New ( _
    rhs As Y2Axis _
)
public:
Y2Axis (
    Y2Axis^ rhs
)
Parameters
rhs (Y2Axis)
The Y2Axis object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► Y2Axis ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public Y2Axis Clone()
Public Function Clone As Y2Axis
public:
Y2Axis^ Clone ()
Return Value
A new, independent copy of this class


GetCrossAxis Method (pane)

GetCrossAxis Method (pane)
Namespaces ► ZedGraph ► Y2Axis ► GetCrossAxis(GraphPane)
Gets the "Cross" axis that corresponds to this axis.
Declaration Syntax
C# Visual Basic Visual C++
public override Axis GetCrossAxis(
    GraphPane pane
)
Public Overrides Function GetCrossAxis ( _
    pane As GraphPane _
) As Axis
public:
virtual Axis^ GetCrossAxis (
    GraphPane^ pane
) override
Parameters
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
Remarks
The cross axis is the axis which determines the of this Axis when the Axis.Cross property is used. The cross axis for any XAxis or X2Axis is always the primary YAxis, and the cross axis for any YAxis or Y2Axis is always the primary XAxis.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► Y2Axis ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► Y2Axis ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


SetTransformMatrix Method (g, pane, scaleFactor)

SetTransformMatrix Method (g, pane, scaleFactor)
Namespaces ► ZedGraph ► Y2Axis ► SetTransformMatrix(Graphics, GraphPane, Single)
Setup the Transform Matrix to handle drawing of this Y2Axis
Declaration Syntax
C# Visual Basic Visual C++
public override void SetTransformMatrix(
    Graphics g,
    GraphPane pane,
    float scaleFactor
)
Public Overrides Sub SetTransformMatrix ( _
    g As Graphics, _
    pane As GraphPane, _
    scaleFactor As Single _
)
public:
virtual void SetTransformMatrix (
    Graphics^ g,
    GraphPane^ pane,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► Y2Axis ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Y2Axis.Default Structure

Y2Axis..::Default Structure
Namespaces ► ZedGraph ► Y2Axis ► Y2Axis..::Default
A simple subclass of the Y2Axis..::Default class that defines the default property values for the Y2Axis class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible | The default display mode for the Y2Axis (IsVisible property). true to display the scale values, title, tic marks, false to hide the axis entirely.
 | IsZeroLine | Determines if a line will be drawn at the zero value for the Y2Axis, that is, a line that divides the negative values from positive values. IsZeroLine.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


IsVisible Field

IsVisible Field
Namespaces ► ZedGraph ► Y2Axis..::Default ► IsVisible
The default display mode for the Y2Axis (IsVisible property). true to display the scale values, title, tic marks, false to hide the axis entirely.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsVisible
Public Shared IsVisible As Boolean
public:
static bool IsVisible


IsZeroLine Field

IsZeroLine Field
Namespaces ► ZedGraph ► Y2Axis..::Default ► IsZeroLine
Determines if a line will be drawn at the zero value for the Y2Axis, that is, a line that divides the negative values from positive values. IsZeroLine.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsZeroLine
Public Shared IsZeroLine As Boolean
public:
static bool IsZeroLine
See Also
IsZeroLine


Y2AxisList Class

Y2AxisList Class
Namespaces ► ZedGraph ► Y2AxisList
A collection class containing a list of YAxis objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Y2AxisList : List<Y2Axis>, ICloneable
<SerializableAttribute> _
Public Class Y2AxisList _
    Inherits List(Of Y2Axis) _
    Implements ICloneable
[SerializableAttribute]
public ref class Y2AxisList : public List<Y2Axis^>,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Y2AxisListY2AxisListNew()() | Default constructor for the collection class.
 | Y2AxisListY2AxisListNew(Y2AxisList) | The Copy Constructor
 | Add(String) | Create a new Y2Axis and add it to this list.
 | Add(T) | Adds an object to the end of the List<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | AddRange(IEnumerable<(Of <T>)>) | Adds the elements of the specified collection to the end of the List<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | AsReadOnly()() | Returns a read-only IList<(Of <T>)> wrapper for the current collection. (Inherited from List <(Of < Y2Axis >)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < Y2Axis >)>.)
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of < Y2Axis >)>.)
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < Y2Axis >)>.)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of < Y2Axis >)>.)
 | Clear()() | Removes all elements from the List<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Contains(T) | Determines whether an element is in the List<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | ConvertAll<(Of <TOutput>)>(Converter<(Of <T, TOutput>)>) | Converts the elements in the current List<(Of <T>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of < Y2Axis >)>.)
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of < Y2Axis >)>.)
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < Y2Axis >)>.)
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < Y2Axis >)>.)
 | Count | Gets the number of elements actually contained in the List<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <T>)>) | Determines whether the List<(Of <T>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < Y2Axis >)>.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | FindAll(Predicate<(Of <T>)>) | Retrieves the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < Y2Axis >)>.)
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < Y2Axis >)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < Y2Axis >)>.)
 | FindLast(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < Y2Axis >)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < Y2Axis >)>.)
 | ForEach(Action<(Of <T>)>) | Performs the specified action on each element of the List<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | GetEnumerator()() | Returns an enumerator that iterates through the List<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(String) | Return the zero-based position index of the Axis with the specified Title.
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < Y2Axis >)>.)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < Y2Axis >)>.)
 | IndexOfTag(String) | Return the zero-based position index of the Axis with the specified Tag.
 | Insert(Int32, T) | Inserts an element into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < Y2Axis >)>.)
 | InsertRange(Int32, IEnumerable<(Of <T>)>) | Inserts the elements of a collection into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < Y2Axis >)>.)
 | Item[([Int32])] | Indexer to access the specified Axis object by its ordinal position in the list.
 | Item[([String])] | Indexer to access the specified Axis object by its Title string.
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < Y2Axis >)>.)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < Y2Axis >)>.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | RemoveAll(Predicate<(Of <T>)>) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < Y2Axis >)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of < Y2Axis >)>.)
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer. (Inherited from List <(Of < Y2Axis >)>.)
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < Y2Axis >)>.)
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < Y2Axis >)>.)
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>. (Inherited from List <(Of < Y2Axis >)>.)
 | ICollection<(Of <T>)>..::IsReadOnly | (Inherited from List <(Of < Y2Axis >)>.)
 | IEnumerable<(Of <T>)>..::GetEnumerator()() | (Inherited from List <(Of < Y2Axis >)>.)
 | ICollection..::CopyTo(Array, Int32) | (Inherited from List <(Of < Y2Axis >)>.)
 | ICollection..::IsSynchronized | (Inherited from List <(Of < Y2Axis >)>.)
 | ICollection..::SyncRoot | (Inherited from List <(Of < Y2Axis >)>.)
 | IEnumerable..::GetEnumerator()() | (Inherited from List <(Of < Y2Axis >)>.)
 | IList..::Add(Object) | (Inherited from List <(Of < Y2Axis >)>.)
 | IList..::Contains(Object) | (Inherited from List <(Of < Y2Axis >)>.)
 | IList..::IndexOf(Object) | (Inherited from List <(Of < Y2Axis >)>.)
 | IList..::Insert(Int32, Object) | (Inherited from List <(Of < Y2Axis >)>.)
 | IList..::IsFixedSize | (Inherited from List <(Of < Y2Axis >)>.)
 | IList..::IsReadOnly | (Inherited from List <(Of < Y2Axis >)>.)
 | IList..::Item[([Int32])] | (Inherited from List <(Of < Y2Axis >)>.)
 | IList..::Remove(Object) | (Inherited from List <(Of < Y2Axis >)>.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToArray()() | Copies the elements of the List<(Of <T>)> to a new array. (Inherited from List <(Of < Y2Axis >)>.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()() | Sets the capacity to the actual number of elements in the List<(Of <T>)>, if that number is less than a threshold value. (Inherited from List <(Of < Y2Axis >)>.)
 | TrueForAll(Predicate<(Of <T>)>) | Determines whether every element in the List<(Of <T>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of < Y2Axis >)>.)
Inheritance Hierarchy
Object
 | List <(Of < Y2Axis >)>
 |  | Y2AxisList


Y2AxisList Constructor

Y2AxisList Constructor
Namespaces ► ZedGraph ► Y2AxisList ► Y2AxisListY2AxisListNew()()
Members
Icon | Member | Description
 | Y2AxisListY2AxisListNew()() | Default constructor for the collection class.
 | Y2AxisListY2AxisListNew(Y2AxisList) | The Copy Constructor


Y2AxisList Constructor

Y2AxisList Constructor
Namespaces ► ZedGraph ► Y2AxisList ► Y2AxisListY2AxisListNew()()
Default constructor for the collection class.
Declaration Syntax
C# Visual Basic Visual C++
public Y2AxisList()
Public Sub New
public:
Y2AxisList ()


Y2AxisList Constructor (rhs)

Y2AxisList Constructor (rhs)
Namespaces ► ZedGraph ► Y2AxisList ► Y2AxisListY2AxisListNew(Y2AxisList)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public Y2AxisList(
    Y2AxisList rhs
)
Public Sub New ( _
    rhs As Y2AxisList _
)
public:
Y2AxisList (
    Y2AxisList^ rhs
)
Parameters
rhs (Y2AxisList)
The Y2AxisList object from which to copy


Add Method (title)

Add Method (title)
Namespaces ► ZedGraph ► Y2AxisList ► Add(String)
Create a new Y2Axis and add it to this list.
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    string title
)
Public Function Add ( _
    title As String _
) As Integer
public:
int Add (
    String^ title
)
Parameters
title (String)
The title string for the new axis
Return Value
An integer representing the ordinal position of the new Y2Axis in this Y2AxisList. This is the value that you would set the YAxisIndex property of a given CurveItem to assign it to this new Y2Axis. Note that, for a Y2Axis, you would also need to set the IsY2Axis property to true.


Clone Method

Clone Method
Namespaces ► ZedGraph ► Y2AxisList ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public Y2AxisList Clone()
Public Function Clone As Y2AxisList
public:
Y2AxisList^ Clone ()
Return Value
A new, independent copy of this class


IndexOf Method (title)

IndexOf Method (title)
Namespaces ► ZedGraph ► Y2AxisList ► IndexOf(String)
Return the zero-based position index of the Axis with the specified Title.
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    string title
)
Public Function IndexOf ( _
    title As String _
) As Integer
public:
int IndexOf (
    String^ title
)
Parameters
title (String)
The String label that is in the Title attribute of the item to be found.
Return Value
The zero-based index of the specified Axis, or -1 if the Title was not found in the list
Remarks
The comparison of titles is not case sensitive, but it must include all characters including punctuation, spaces, etc.
See Also
IndexOfTag(String)


IndexOfTag Method (tagStr)

IndexOfTag Method (tagStr)
Namespaces ► ZedGraph ► Y2AxisList ► IndexOfTag(String)
Return the zero-based position index of the Axis with the specified Tag.
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOfTag(
    string tagStr
)
Public Function IndexOfTag ( _
    tagStr As String _
) As Integer
public:
int IndexOfTag (
    String^ tagStr
)
Parameters
tagStr (String)
The String tag that is in the Tag attribute of the item to be found.
Return Value
The zero-based index of the specified Axis, or -1 if the Tag string is not in the list
Remarks
In order for this method to work, the Tag property must be of type String.
See Also
IndexOf(String)


Item Property

Item Property
Namespaces ► ZedGraph ► Y2AxisList ► Item
Members
Icon | Member | Description
 | Item[([Int32])] | Indexer to access the specified Axis object by its ordinal position in the list.
 | Item[([String])] | Indexer to access the specified Axis object by its Title string.


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph ► Y2AxisList ► Item[([Int32])]
Indexer to access the specified Axis object by its ordinal position in the list.
Declaration Syntax
C# Visual Basic Visual C++
public Y2Axis this[
    int index
]{ get;}
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Y2Axis
public:
property Y2Axis^ default[int index] {
    Y2Axis^ get (int index);
}
Parameters
index (Int32)
The ordinal position (zero-based) of the YAxis object to be accessed.
Value
An Axis object reference.


Item Property (title)

Item Property (title)
Namespaces ► ZedGraph ► Y2AxisList ► Item[([String])]
Indexer to access the specified Axis object by its Title string.
Declaration Syntax
C# Visual Basic Visual C++
public Y2Axis this[
    string title
]{ get;}
Public ReadOnly Default Property Item ( _
    title As String _
) As Y2Axis
public:
property Y2Axis^ default[String^ title] {
    Y2Axis^ get (String^ title);
}
Parameters
title (String)
The string title of the YAxis object to be accessed.
Value
A Axis object reference.


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► Y2AxisList ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


YAxis Class

YAxis Class
Namespaces ► ZedGraph ► YAxis
YAxis inherits from Axis, and defines the special characteristics of a vertical axis, specifically located on the right side of the Rect of the GraphPane object
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class YAxis : Axis, ICloneable,
    ISerializable
<SerializableAttribute> _
Public Class YAxis _
    Inherits Axis _
    Implements ICloneable, ISerializable
[SerializableAttribute]
public ref class YAxis : public Axis,
    ICloneable, ISerializable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | YAxisYAxisNew()() | Default constructor that sets all YAxis properties to default values as defined in the YAxis..::Default class
 | YAxisYAxisNew(String) | Default constructor that sets all YAxis properties to default values as defined in the YAxis..::Default class, except for the axis title
 | YAxisYAxisNew(YAxis) | The Copy Constructor
 | AxisGap | The size of the gap between multiple axes (see YAxisList and Y2AxisList). (Inherited from Axis.)
 | CalcSpace(Graphics, GraphPane, Single, Single%) | Calculate the space required (pixels) for this Axis object. (Inherited from Axis.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Color | The color to use for drawing this Axis. (Inherited from Axis.)
 | Cross | Gets or sets the scale value at which this axis should cross the "other" axis. (Inherited from Axis.)
 | CrossAuto | Gets or sets a value that determines whether or not the Cross value is set automatically. (Inherited from Axis.)
 | Draw(Graphics, GraphPane, Single, Single) | Do all rendering associated with this Axis to the specified Graphics device. (Inherited from Axis.)
 | DrawMinorTics(Graphics, GraphPane, Double, Single, Single, Single) | Draw the minor tic marks as required for this Axis. (Inherited from Axis.)
 | DrawTitle(Graphics, GraphPane, Single, Single) | Draw the title for this Axis. (Inherited from Axis.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCrossAxis(GraphPane) | Gets the "Cross" axis that corresponds to this axis. (Overrides Axis.GetCrossAxis(GraphPane).)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a SerializationInfo instance with the data needed to serialize the target object (Overrides Axis.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAxisSegmentVisible | Gets or sets a property that determines whether or not the axis segment (the line that represents the axis itself) is drawn. (Inherited from Axis.)
 | IsVisible | This property determines whether or not the Axis is shown. (Inherited from Axis.)
 | MajorGrid | Gets a reference to the MajorGrid class that contains the properties of the major grid. (Inherited from Axis.)
 | MajorTic | Gets a reference to the MajorTic class instance for this Axis. This class stores all the major tic settings. (Inherited from Axis.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinorGrid | Gets a reference to the MinorGrid class that contains the properties of the minor grid. (Inherited from Axis.)
 | MinorTic | Gets a reference to the MinorTic class instance for this Axis. This class stores all the minor tic settings. (Inherited from Axis.)
 | MinSpace | Gets or sets the minimum axis space allocation. (Inherited from Axis.)
 | ResetAutoScale(GraphPane, Graphics) | Restore the scale ranging to automatic mode, and recalculate the Axis scale ranges (Inherited from Axis.)
 | Scale | Gets the Scale instance associated with this Axis. (Inherited from Axis.)
 | ScaleFormatEvent | Subscribe to this event to handle custom formatting of the scale labels. (Inherited from Axis.)
 | ScaleTitleEvent | Allow customization of the title when the scale is very large Subscribe to this event to handle custom formatting of the scale axis label. (Inherited from Axis.)
 | schema2 | Current schema value that defines the version of the serialized file
 | SetMinSpaceBuffer(Graphics, GraphPane, Single, Boolean) | This method will set the MinSpace property for this Axis using the currently required space multiplied by a fraction (). (Inherited from Axis.)
 | SetTransformMatrix(Graphics, GraphPane, Single) | Setup the Transform Matrix to handle drawing of this YAxis (Overrides Axis.SetTransformMatrix(Graphics, GraphPane, Single).)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | Tag | A tag object for use by the user. This can be used to store additional information associated with the Axis. ZedGraph does not use this value for any purpose. (Inherited from Axis.)
 | Title | Gets or sets the Label class that contains the title of this Axis. (Inherited from Axis.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets or sets the AxisType for this Axis. (Inherited from Axis.)
Inheritance Hierarchy
Object
 | Axis
 |  | YAxis


YAxis Constructor

YAxis Constructor
Namespaces ► ZedGraph ► YAxis ► YAxisYAxisNew()()
Members
Icon | Member | Description
 | YAxisYAxisNew()() | Default constructor that sets all YAxis properties to default values as defined in the YAxis..::Default class
 | YAxisYAxisNew(String) | Default constructor that sets all YAxis properties to default values as defined in the YAxis..::Default class, except for the axis title
 | YAxisYAxisNew(YAxis) | The Copy Constructor


YAxis Constructor

YAxis Constructor
Namespaces ► ZedGraph ► YAxis ► YAxisYAxisNew()()
Default constructor that sets all YAxis properties to default values as defined in the YAxis..::Default class
Declaration Syntax
C# Visual Basic Visual C++
public YAxis()
Public Sub New
public:
YAxis ()


YAxis Constructor (title)

YAxis Constructor (title)
Namespaces ► ZedGraph ► YAxis ► YAxisYAxisNew(String)
Default constructor that sets all YAxis properties to default values as defined in the YAxis..::Default class, except for the axis title
Declaration Syntax
C# Visual Basic Visual C++
public YAxis(
    string title
)
Public Sub New ( _
    title As String _
)
public:
YAxis (
    String^ title
)
Parameters
title (String)
The Title for this axis


YAxis Constructor (rhs)

YAxis Constructor (rhs)
Namespaces ► ZedGraph ► YAxis ► YAxisYAxisNew(YAxis)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public YAxis(
    YAxis rhs
)
Public Sub New ( _
    rhs As YAxis _
)
public:
YAxis (
    YAxis^ rhs
)
Parameters
rhs (YAxis)
The YAxis object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► YAxis ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public YAxis Clone()
Public Function Clone As YAxis
public:
YAxis^ Clone ()
Return Value
A new, independent copy of this class


GetCrossAxis Method (pane)

GetCrossAxis Method (pane)
Namespaces ► ZedGraph ► YAxis ► GetCrossAxis(GraphPane)
Gets the "Cross" axis that corresponds to this axis.
Declaration Syntax
C# Visual Basic Visual C++
public override Axis GetCrossAxis(
    GraphPane pane
)
Public Overrides Function GetCrossAxis ( _
    pane As GraphPane _
) As Axis
public:
virtual Axis^ GetCrossAxis (
    GraphPane^ pane
) override
Parameters
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
Remarks
The cross axis is the axis which determines the of this Axis when the Axis.Cross property is used. The cross axis for any XAxis or X2Axis is always the primary YAxis, and the cross axis for any YAxis or Y2Axis is always the primary XAxis.


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► ZedGraph ► YAxis ► GetObjectData(SerializationInfo, StreamingContext)
Populates a SerializationInfo instance with the data needed to serialize the target object
Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData (
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)
A SerializationInfo instance that defines the serialized data
context (StreamingContext)
A StreamingContext instance that contains the serialized data


schema2 Field

schema2 Field
Namespaces ► ZedGraph ► YAxis ► schema2
Current schema value that defines the version of the serialized file
Declaration Syntax
C# Visual Basic Visual C++
public const int schema2
Public Const schema2 As Integer
public:
literal int schema2


SetTransformMatrix Method (g, pane, scaleFactor)

SetTransformMatrix Method (g, pane, scaleFactor)
Namespaces ► ZedGraph ► YAxis ► SetTransformMatrix(Graphics, GraphPane, Single)
Setup the Transform Matrix to handle drawing of this YAxis
Declaration Syntax
C# Visual Basic Visual C++
public override void SetTransformMatrix(
    Graphics g,
    GraphPane pane,
    float scaleFactor
)
Public Overrides Sub SetTransformMatrix ( _
    g As Graphics, _
    pane As GraphPane, _
    scaleFactor As Single _
)
public:
virtual void SetTransformMatrix (
    Graphics^ g,
    GraphPane^ pane,
    float scaleFactor
) override
Parameters
g (Graphics)
A graphic device object to be drawn into. This is normally e.Graphics from the PaintEventArgs argument to the Paint() method.
pane (GraphPane)
A reference to the GraphPane object that is the parent or owner of this object.
scaleFactor (Single)
The scaling factor to be used for rendering objects. This is calculated and passed down by the parent GraphPane object using the CalcScaleFactor()() method, and is used to proportionally adjust font sizes, etc. according to the actual size of the graph.


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► YAxis ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


YAxis.Default Structure

YAxis..::Default Structure
Namespaces ► ZedGraph ► YAxis ► YAxis..::Default
A simple struct that defines the default property values for the YAxis class.
Declaration Syntax
C# Visual Basic Visual C++
public struct Default
Public Structure Default
public value class Default
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible | The default display mode for the YAxis (IsVisible property). true to display the scale values, title, tic marks, false to hide the axis entirely.
 | IsZeroLine | Determines if a line will be drawn at the zero value for the YAxis, that is, a line that divides the negative values from positive values. IsZeroLine.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


IsVisible Field

IsVisible Field
Namespaces ► ZedGraph ► YAxis..::Default ► IsVisible
The default display mode for the YAxis (IsVisible property). true to display the scale values, title, tic marks, false to hide the axis entirely.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsVisible
Public Shared IsVisible As Boolean
public:
static bool IsVisible


IsZeroLine Field

IsZeroLine Field
Namespaces ► ZedGraph ► YAxis..::Default ► IsZeroLine
Determines if a line will be drawn at the zero value for the YAxis, that is, a line that divides the negative values from positive values. IsZeroLine.
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsZeroLine
Public Shared IsZeroLine As Boolean
public:
static bool IsZeroLine
See Also
IsZeroLine


YAxisList Class

YAxisList Class
Namespaces ► ZedGraph ► YAxisList
A collection class containing a list of YAxis objects.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class YAxisList : List<YAxis>, ICloneable
<SerializableAttribute> _
Public Class YAxisList _
    Inherits List(Of YAxis) _
    Implements ICloneable
[SerializableAttribute]
public ref class YAxisList : public List<YAxis^>,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | YAxisListYAxisListNew()() | Default constructor for the collection class.
 | YAxisListYAxisListNew(YAxisList) | The Copy Constructor
 | Add(String) | Create a new YAxis and add it to this list.
 | Add(T) | Adds an object to the end of the List<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | AddRange(IEnumerable<(Of <T>)>) | Adds the elements of the specified collection to the end of the List<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | AsReadOnly()() | Returns a read-only IList<(Of <T>)> wrapper for the current collection. (Inherited from List <(Of < YAxis >)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < YAxis >)>.)
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of < YAxis >)>.)
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < YAxis >)>.)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of < YAxis >)>.)
 | Clear()() | Removes all elements from the List<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Contains(T) | Determines whether an element is in the List<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | ConvertAll<(Of <TOutput>)>(Converter<(Of <T, TOutput>)>) | Converts the elements in the current List<(Of <T>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of < YAxis >)>.)
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of < YAxis >)>.)
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < YAxis >)>.)
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < YAxis >)>.)
 | Count | Gets the number of elements actually contained in the List<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <T>)>) | Determines whether the List<(Of <T>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < YAxis >)>.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | FindAll(Predicate<(Of <T>)>) | Retrieves the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < YAxis >)>.)
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < YAxis >)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < YAxis >)>.)
 | FindLast(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < YAxis >)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < YAxis >)>.)
 | ForEach(Action<(Of <T>)>) | Performs the specified action on each element of the List<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | GetEnumerator()() | Returns an enumerator that iterates through the List<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(String) | Return the zero-based position index of the Axis with the specified Title.
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < YAxis >)>.)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < YAxis >)>.)
 | IndexOfTag(String) | Return the zero-based position index of the Axis with the specified Tag.
 | Insert(Int32, T) | Inserts an element into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < YAxis >)>.)
 | InsertRange(Int32, IEnumerable<(Of <T>)>) | Inserts the elements of a collection into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < YAxis >)>.)
 | Item[([Int32])] | Indexer to access the specified Axis object by its ordinal position in the list.
 | Item[([String])] | Indexer to access the specified Axis object by its Title string.
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < YAxis >)>.)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < YAxis >)>.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | RemoveAll(Predicate<(Of <T>)>) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < YAxis >)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of < YAxis >)>.)
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer. (Inherited from List <(Of < YAxis >)>.)
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < YAxis >)>.)
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < YAxis >)>.)
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>. (Inherited from List <(Of < YAxis >)>.)
 | ICollection<(Of <T>)>..::IsReadOnly | (Inherited from List <(Of < YAxis >)>.)
 | IEnumerable<(Of <T>)>..::GetEnumerator()() | (Inherited from List <(Of < YAxis >)>.)
 | ICollection..::CopyTo(Array, Int32) | (Inherited from List <(Of < YAxis >)>.)
 | ICollection..::IsSynchronized | (Inherited from List <(Of < YAxis >)>.)
 | ICollection..::SyncRoot | (Inherited from List <(Of < YAxis >)>.)
 | IEnumerable..::GetEnumerator()() | (Inherited from List <(Of < YAxis >)>.)
 | IList..::Add(Object) | (Inherited from List <(Of < YAxis >)>.)
 | IList..::Contains(Object) | (Inherited from List <(Of < YAxis >)>.)
 | IList..::IndexOf(Object) | (Inherited from List <(Of < YAxis >)>.)
 | IList..::Insert(Int32, Object) | (Inherited from List <(Of < YAxis >)>.)
 | IList..::IsFixedSize | (Inherited from List <(Of < YAxis >)>.)
 | IList..::IsReadOnly | (Inherited from List <(Of < YAxis >)>.)
 | IList..::Item[([Int32])] | (Inherited from List <(Of < YAxis >)>.)
 | IList..::Remove(Object) | (Inherited from List <(Of < YAxis >)>.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToArray()() | Copies the elements of the List<(Of <T>)> to a new array. (Inherited from List <(Of < YAxis >)>.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()() | Sets the capacity to the actual number of elements in the List<(Of <T>)>, if that number is less than a threshold value. (Inherited from List <(Of < YAxis >)>.)
 | TrueForAll(Predicate<(Of <T>)>) | Determines whether every element in the List<(Of <T>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of < YAxis >)>.)
Inheritance Hierarchy
Object
 | List <(Of < YAxis >)>
 |  | YAxisList


YAxisList Constructor

YAxisList Constructor
Namespaces ► ZedGraph ► YAxisList ► YAxisListYAxisListNew()()
Members
Icon | Member | Description
 | YAxisListYAxisListNew()() | Default constructor for the collection class.
 | YAxisListYAxisListNew(YAxisList) | The Copy Constructor


YAxisList Constructor

YAxisList Constructor
Namespaces ► ZedGraph ► YAxisList ► YAxisListYAxisListNew()()
Default constructor for the collection class.
Declaration Syntax
C# Visual Basic Visual C++
public YAxisList()
Public Sub New
public:
YAxisList ()


YAxisList Constructor (rhs)

YAxisList Constructor (rhs)
Namespaces ► ZedGraph ► YAxisList ► YAxisListYAxisListNew(YAxisList)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public YAxisList(
    YAxisList rhs
)
Public Sub New ( _
    rhs As YAxisList _
)
public:
YAxisList (
    YAxisList^ rhs
)
Parameters
rhs (YAxisList)
The YAxisList object from which to copy


Add Method (title)

Add Method (title)
Namespaces ► ZedGraph ► YAxisList ► Add(String)
Create a new YAxis and add it to this list.
Declaration Syntax
C# Visual Basic Visual C++
public int Add(
    string title
)
Public Function Add ( _
    title As String _
) As Integer
public:
int Add (
    String^ title
)
Parameters
title (String)
The title string for the new axis
Return Value
An integer representing the ordinal position of the new YAxis in this YAxisList. This is the value that you would set the YAxisIndex property of a given CurveItem to assign it to this new YAxis.


Clone Method

Clone Method
Namespaces ► ZedGraph ► YAxisList ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public YAxisList Clone()
Public Function Clone As YAxisList
public:
YAxisList^ Clone ()
Return Value
A new, independent copy of this class


IndexOf Method (title)

IndexOf Method (title)
Namespaces ► ZedGraph ► YAxisList ► IndexOf(String)
Return the zero-based position index of the Axis with the specified Title.
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOf(
    string title
)
Public Function IndexOf ( _
    title As String _
) As Integer
public:
int IndexOf (
    String^ title
)
Parameters
title (String)
The String label that is in the Title attribute of the item to be found.
Return Value
The zero-based index of the specified Axis, or -1 if the Title was not found in the list
Remarks
The comparison of titles is not case sensitive, but it must include all characters including punctuation, spaces, etc.
See Also
IndexOfTag(String)


IndexOfTag Method (tagStr)

IndexOfTag Method (tagStr)
Namespaces ► ZedGraph ► YAxisList ► IndexOfTag(String)
Return the zero-based position index of the Axis with the specified Tag.
Declaration Syntax
C# Visual Basic Visual C++
public int IndexOfTag(
    string tagStr
)
Public Function IndexOfTag ( _
    tagStr As String _
) As Integer
public:
int IndexOfTag (
    String^ tagStr
)
Parameters
tagStr (String)
The String tag that is in the Tag attribute of the item to be found.
Return Value
The zero-based index of the specified Axis, or -1 if the Tag string is not in the list
Remarks
In order for this method to work, the Tag property must be of type String.


Item Property

Item Property
Namespaces ► ZedGraph ► YAxisList ► Item
Members
Icon | Member | Description
 | Item[([Int32])] | Indexer to access the specified Axis object by its ordinal position in the list.
 | Item[([String])] | Indexer to access the specified Axis object by its Title string.


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph ► YAxisList ► Item[([Int32])]
Indexer to access the specified Axis object by its ordinal position in the list.
Declaration Syntax
C# Visual Basic Visual C++
public YAxis this[
    int index
]{ get;}
Public ReadOnly Default Property Item ( _
    index As Integer _
) As YAxis
public:
property YAxis^ default[int index] {
    YAxis^ get (int index);
}
Parameters
index (Int32)
The ordinal position (zero-based) of the YAxis object to be accessed.
Value
An Axis object reference.


Item Property (title)

Item Property (title)
Namespaces ► ZedGraph ► YAxisList ► Item[([String])]
Indexer to access the specified Axis object by its Title string.
Declaration Syntax
C# Visual Basic Visual C++
public YAxis this[
    string title
]{ get;}
Public ReadOnly Default Property Item ( _
    title As String _
) As YAxis
public:
property YAxis^ default[String^ title] {
    YAxis^ get (String^ title);
}
Parameters
title (String)
The string title of the YAxis object to be accessed.
Value
A Axis object reference.


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► YAxisList ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


ZedGraphControl Class

ZedGraphControl Class
Namespaces ► ZedGraph ► ZedGraphControl
The ZedGraphControl class provides a UserControl interface to the ZedGraph class library. This allows ZedGraph to be installed as a control in the Visual Studio toolbox. You can use the control by simply dragging it onto a form in the Visual Studio form editor. All graph attributes are accessible via the GraphPane property.
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphControl : UserControl
Public Class ZedGraphControl _
    Inherits UserControl
public ref class ZedGraphControl : public UserControl
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphControlZedGraphControlNew()() | Default Constructor
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
 | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
 | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
 | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
 | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
 | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
 | AdjustFormScrollbars(Boolean) | (Inherited from ContainerControl.)
 | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
 | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
 | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
 | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
 | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
 | AutoScroll | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries. (Inherited from ScrollableControl.)
 | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
 | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
 | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
 | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
 | AutoSize | (Inherited from UserControl.)
 | AutoSizeChanged | (Inherited from UserControl.)
 | AutoSizeMode | Gets or sets how the control will resize itself. (Inherited from UserControl.)
 | AutoValidate | Gets or sets how the control performs validation when the user changes focus to another control. (Inherited from UserControl.)
 | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from UserControl.)
 | AxisChange()() | This performs an axis change command on the graphPane.
 | BackColor | Gets or sets the background color for the control. (Inherited from Control.)
 | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
 | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
 | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
 | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
 | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
 | BeenDisposed | This checks if the control has been disposed. This is synonymous with the graph pane having been nulled or disposed. Therefore this is the same as ZedGraphControl.GraphPane == null.
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BeginInvoke(Delegate, array<Object>[]()) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
 | BindingContext | (Inherited from ContainerControl.)
 | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
 | BorderStyle | Gets or sets the border style of the tree view control. (Inherited from UserControl.)
 | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
 | BringToFront()() | Brings the control to the front of the z-order. (Inherited from Control.)
 | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
 | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
 | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
 | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
 | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
 | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
 | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
 | Click | Occurs when the control is clicked. (Inherited from Control.)
 | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
 | ClientSize | Gets or sets the height and width of the client area of the control. (Inherited from Control.)
 | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
 | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
 | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
 | Contains(Control) | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
 | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
 | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
 | ContextMenuBuilder | Subscribe to this event to be able to modify the ZedGraph context menu.
 | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
 | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
 | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
 | ControlAdded | Occurs when a new control is added to the Control..::ControlCollection. (Inherited from Control.)
 | ControlRemoved | Occurs when a control is removed from the Control..::ControlCollection. (Inherited from Control.)
 | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
 | Copy(Boolean) | Handler for the "Copy" context menu item. Copies the current image to a bitmap on the clipboard.
 | CreateAccessibilityInstance()() | Creates a new accessibility object for the control. (Inherited from Control.)
 | CreateControl()() | Forces the creation of the control, including the creation of the handle and any child controls. (Inherited from Control.)
 | CreateControlsInstance()() | Creates a new instance of the control collection for the control. (Inherited from Control.)
 | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
 | CreateGraphics()() | Creates the Graphics for the control. (Inherited from Control.)
 | CreateHandle()() | Creates a handle for the control. (Inherited from Control.)
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | CreateParams | (Inherited from UserControl.)
 | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
 | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
 | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
 | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
 | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
 | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Control.)
 | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
 | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
 | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
 | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
 | DefaultSize | (Inherited from UserControl.)
 | DefWndProc(Message%) | Sends the specified message to the default window procedure. (Inherited from Control.)
 | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
 | DestroyHandle()() | Destroys the handle associated with the control. (Inherited from Control.)
 | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
 | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from Component.)
 | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
 | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
 | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
 | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
 | DoDragDrop(Object, DragDropEffects) | Begins a drag-and-drop operation. (Inherited from Control.)
 | DoPageSetup()() | Display a PageSetupDialog to the user, allowing them to modify the print settings for this ZedGraphControl.
 | DoPrint()() | Display a PrintDialog to the user, allowing them to select a printer and print the MasterPane contained in this ZedGraphControl.
 | DoPrintPreview()() | Display a PrintPreviewDialog, allowing the user to preview and subsequently print the MasterPane contained in this ZedGraphControl.
 | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
 | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
 | DoubleClickEvent | Subscribe to this event to provide notification of Double Clicks on graph objects
 | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
 | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
 | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
 | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
 | DrawToBitmap(Bitmap, Rectangle) | Supports rendering to the specified bitmap. (Inherited from Control.)
 | EditButtons | Gets or sets a value that determines which Mouse button will be used to edit point data values
 | EditModifierKeys | Gets or sets a value that determines which modifier keys will be used to edit point data values
 | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
 | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
 | EndInvoke(IAsyncResult) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
 | Enter | Occurs when the control is entered. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
 | Finalize()() | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
 | FindForm()() | Retrieves the form that the control is on. (Inherited from Control.)
 | Focus()() | Sets input focus to the control. (Inherited from Control.)
 | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
 | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
 | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
 | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
 | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
 | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
 | GetAccessibilityObjectById(Int32) | Retrieves the specified AccessibleObject. (Inherited from Control.)
 | GetAutoSizeMode()() | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
 | GetContainerControl()() | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetImage()() | Gets the graph pane's current image. Bitmap
 | GetLifetimeService()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetNextControl(Control, Boolean) | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
 | GetPreferredSize(Size) | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
 | GetScaledBounds(Rectangle, SizeF, BoundsSpecified) | Retrieves the bounds within which the control is scaled. (Inherited from Control.)
 | GetScrollState(Int32) | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
 | GetService(Type) | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
 | GetStyle(ControlStyles) | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
 | GetTopLevel()() | Determines if the control is a top-level control. (Inherited from Control.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
 | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
 | GraphPane | Gets or sets the GraphPane property for the control
 | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
 | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
 | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
 | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
 | Height | Gets or sets the height of the control. (Inherited from Control.)
 | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
 | Hide()() | Conceals the control from the user. (Inherited from Control.)
 | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
 | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
 | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
 | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
 | InitializeLifetimeService()() | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | InitLayout()() | Called after the control has been added to another container. (Inherited from Control.)
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
 | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
 | Invoke(Delegate, array<Object>[]()) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
 | InvokeGotFocus(Control, EventArgs) | Raises the GotFocus event for the specified control. (Inherited from Control.)
 | InvokeLostFocus(Control, EventArgs) | Raises the LostFocus event for the specified control. (Inherited from Control.)
 | InvokeOnClick(Control, EventArgs) | Raises the Click event for the specified control. (Inherited from Control.)
 | InvokePaint(Control, PaintEventArgs) | Raises the Paint event for the specified control. (Inherited from Control.)
 | InvokePaintBackground(Control, PaintEventArgs) | Raises the PaintBackground event for the specified control. (Inherited from Control.)
 | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
 | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
 | IsAntiAlias | Gets or sets a value that determines if all drawing operations for this control will be forced to operate in Anti-alias mode. Note that if this value is set to "true", it overrides the setting for sub-objects. Otherwise, the sub-object settings (such as IsAntiAlias) will be honored.
 | IsAutoScrollRange | Gets or sets a value that controls whether or not the axis value range for the scroll bars will be set automatically.
 | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
 | IsEnableHEdit | Gets or sets a value that determines whether or not editing of point data is allowed in the horizontal direction.
 | IsEnableHPan | Gets or sets a value that determines whether or not panning is allowed for the control in the horizontal direction.
 | IsEnableHZoom | Gets or sets a value that determines whether or not zooming is allowed for the control in the horizontal direction.
 | IsEnableSelection | Gets or sets a value that determines whether or not selection is allowed for the control.
 | IsEnableVEdit | Gets or sets a value that determines whether or not editing of point data is allowed in the vertical direction.
 | IsEnableVPan | Gets or sets a value that determines whether or not panning is allowed for the control in the vertical direction.
 | IsEnableVZoom | Gets or sets a value that determines whether or not zooming is allowed for the control in the vertical direction.
 | IsEnableZoom | Gets or sets a value that determines whether or not zooming is allowed for the control.
 | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
 | IsInputChar(Char) | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
 | IsInputKey(Keys) | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
 | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
 | IsPrintFillPage | Gets or sets a value that determines whether or not the MasterPane Rect dimensions will be expanded to fill the available space when printing this ZedGraphControl.
 | IsPrintKeepAspectRatio | Gets or sets a value that determines whether or not the visible aspect ratio of the MasterPane Rect will be preserved when printing this ZedGraphControl.
 | IsPrintScaleAll | Gets or sets a value that determines whether the settings of IsFontsScaled and IsPenWidthScaled will be overridden to true during printing operations.
 | IsScrolling | Returns true if the user is currently scrolling via the scrollbar, or false if no scrolling is taking place.
 | IsScrollY2 | Gets or sets a value that determines if the vertical scroll bar will affect the Y2 axis.
 | IsShowContextMenu | Gets or sets a value that determines whether or not the context menu will be available.
 | IsShowCopyMessage | Gets or sets a value that determines whether or not a message box will be shown in response to a context menu "Copy" command.
 | IsShowCursorValues | Gets or sets a value that determines whether or not tooltips will be displayed showing the current scale values when the mouse is within the Rect.
 | IsShowHScrollBar | Gets or sets a value that determines if the horizontal scroll bar will be visible.
 | IsShowPointValues | Gets or sets a value that determines whether or not tooltips will be displayed when the mouse hovers over data values.
 | IsShowVScrollBar | Gets or sets a value that determines if the vertical scroll bar will be visible.
 | IsSynchronizeXAxes | Gets or sets a value that determines if the XAxis Scale ranges for all GraphPane objects in the MasterPane will be forced to match.
 | IsSynchronizeYAxes | Gets or sets a value that determines if the YAxis Scale ranges for all GraphPane objects in the MasterPane will be forced to match.
 | IsZoomOnMouseCenter | Gets or sets a boolean value that determines if zooming with the wheel mouse is centered on the mouse location, or centered on the existing graph.
 | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
 | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
 | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
 | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
 | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
 | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | LinkButtons | Gets or sets a value that determines which Mouse button will be used to click on linkable objects
 | LinkEvent | Subscribe to this event to be able to respond to mouse clicks within linked objects.
 | LinkModifierKeys | Gets or sets a value that determines which modifier keys will be used to click on linkable objects
 | Load | Occurs before the control becomes visible for the first time. (Inherited from UserControl.)
 | Location | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container. (Inherited from Control.)
 | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
 | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
 | Margin | Gets or sets the space between controls. (Inherited from Control.)
 | MarginChanged | Occurs when the control's margin changes. (Inherited from Control.)
 | MasterPane | Gets or sets the MasterPane property for the control
 | MaximumSize | Gets or sets the size that is the upper limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MinimumSize | Gets or sets the size that is the lower limit that GetPreferredSize(Size) can specify. (Inherited from Control.)
 | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
 | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
 | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
 | MouseDown | Hide the standard control MouseDown event so that the ZedGraphControl.MouseDownEvent can be used. This is so that the user must return true/false in order to indicate whether or not we should respond to the event.
 | MouseDownEvent | Subscribe to this event to provide notification of MouseDown clicks on graph objects
 | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
 | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
 | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
 | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
 | MouseMoveEvent | Subscribe to this event to provide notification of MouseMove events over graph objects
 | MouseUp | Hide the standard control MouseUp event so that the ZedGraphControl.MouseUpEvent can be used. This is so that the user must return true/false in order to indicate whether or not we should respond to the event.
 | MouseUpEvent | Subscribe to this event to provide notification of MouseUp clicks on graph objects
 | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
 | Move | Occurs when the control is moved. (Inherited from Control.)
 | Name | Gets or sets the name of the control. (Inherited from Control.)
 | NotifyInvalidate(Rectangle) | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
 | OnAutoSizeChanged(EventArgs) | Raises the AutoSizeChanged event. (Inherited from Control.)
 | OnAutoValidateChanged(EventArgs) | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
 | OnBackColorChanged(EventArgs) | Raises the BackColorChanged event. (Inherited from Control.)
 | OnBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event. (Inherited from Control.)
 | OnBackgroundImageLayoutChanged(EventArgs) | Raises the BackgroundImageLayoutChanged event. (Inherited from Control.)
 | OnBindingContextChanged(EventArgs) | Raises the BindingContextChanged event. (Inherited from Control.)
 | OnCausesValidationChanged(EventArgs) | Raises the CausesValidationChanged event. (Inherited from Control.)
 | OnChangeUICues(UICuesEventArgs) | Raises the ChangeUICues event. (Inherited from Control.)
 | OnClick(EventArgs) | Raises the Click event. (Inherited from Control.)
 | OnClientSizeChanged(EventArgs) | Raises the ClientSizeChanged event. (Inherited from Control.)
 | OnContextMenuChanged(EventArgs) | Raises the ContextMenuChanged event. (Inherited from Control.)
 | OnContextMenuStripChanged(EventArgs) | Raises the ContextMenuStripChanged event. (Inherited from Control.)
 | OnControlAdded(ControlEventArgs) | Raises the ControlAdded event. (Inherited from Control.)
 | OnControlRemoved(ControlEventArgs) | Raises the ControlRemoved event. (Inherited from Control.)
 | OnCreateControl()() | Raises the CreateControl event. (Inherited from UserControl.)
 | OnCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnDockChanged(EventArgs) | Raises the DockChanged event. (Inherited from Control.)
 | OnDoubleClick(EventArgs) | Raises the DoubleClick event. (Inherited from Control.)
 | OnDragDrop(DragEventArgs) | Raises the DragDrop event. (Inherited from Control.)
 | OnDragEnter(DragEventArgs) | Raises the DragEnter event. (Inherited from Control.)
 | OnDragLeave(EventArgs) | Raises the DragLeave event. (Inherited from Control.)
 | OnDragOver(DragEventArgs) | Raises the DragOver event. (Inherited from Control.)
 | OnEnabledChanged(EventArgs) | Raises the EnabledChanged event. (Inherited from Control.)
 | OnEnter(EventArgs) | Raises the Enter event. (Inherited from Control.)
 | OnFontChanged(EventArgs) | Raises the FontChanged event. (Inherited from ContainerControl.)
 | OnForeColorChanged(EventArgs) | Raises the ForeColorChanged event. (Inherited from Control.)
 | OnGiveFeedback(GiveFeedbackEventArgs) | Raises the GiveFeedback event. (Inherited from Control.)
 | OnGotFocus(EventArgs) | Raises the GotFocus event. (Inherited from Control.)
 | OnHandleCreated(EventArgs) | Raises the HandleCreated event. (Inherited from Control.)
 | OnHandleDestroyed(EventArgs) | Raises the HandleDestroyed event. (Inherited from Control.)
 | OnHelpRequested(HelpEventArgs) | Raises the HelpRequested event. (Inherited from Control.)
 | OnImeModeChanged(EventArgs) | Raises the ImeModeChanged event. (Inherited from Control.)
 | OnInvalidated(InvalidateEventArgs) | Raises the Invalidated event. (Inherited from Control.)
 | OnKeyDown(KeyEventArgs) | Raises the KeyDown event. (Inherited from Control.)
 | OnKeyPress(KeyPressEventArgs) | Raises the KeyPress event. (Inherited from Control.)
 | OnKeyUp(KeyEventArgs) | Raises the KeyUp event. (Inherited from Control.)
 | OnLayout(LayoutEventArgs) | (Inherited from ContainerControl.)
 | OnLeave(EventArgs) | Raises the Leave event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from UserControl.)
 | OnLocationChanged(EventArgs) | Raises the LocationChanged event. (Inherited from Control.)
 | OnLostFocus(EventArgs) | Raises the LostFocus event. (Inherited from Control.)
 | OnMarginChanged(EventArgs) | Raises the MarginChanged event. (Inherited from Control.)
 | OnMouseCaptureChanged(EventArgs) | Raises the MouseCaptureChanged event. (Inherited from Control.)
 | OnMouseClick(MouseEventArgs) | Raises the MouseClick event. (Inherited from Control.)
 | OnMouseDoubleClick(MouseEventArgs) | Raises the MouseDoubleClick event. (Inherited from Control.)
 | OnMouseDown(MouseEventArgs) | (Inherited from UserControl.)
 | OnMouseEnter(EventArgs) | Raises the MouseEnter event. (Inherited from Control.)
 | OnMouseHover(EventArgs) | Raises the MouseHover event. (Inherited from Control.)
 | OnMouseLeave(EventArgs) | Raises the MouseLeave event. (Inherited from Control.)
 | OnMouseMove(MouseEventArgs) | Raises the MouseMove event. (Inherited from Control.)
 | OnMouseUp(MouseEventArgs) | Raises the MouseUp event. (Inherited from Control.)
 | OnMouseWheel(MouseEventArgs) | Raises the MouseWheel event. (Inherited from ScrollableControl.)
 | OnMove(EventArgs) | Raises the Move event. (Inherited from Control.)
 | OnNotifyMessage(Message) | Notifies the control of Windows messages. (Inherited from Control.)
 | OnPaddingChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnPaintBackground(PaintEventArgs) | (Inherited from ScrollableControl.)
 | OnParentBackColorChanged(EventArgs) | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
 | OnParentBackgroundImageChanged(EventArgs) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
 | OnParentBindingContextChanged(EventArgs) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
 | OnParentChanged(EventArgs) | (Inherited from ContainerControl.)
 | OnParentCursorChanged(EventArgs) | Raises the CursorChanged event. (Inherited from Control.)
 | OnParentEnabledChanged(EventArgs) | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
 | OnParentFontChanged(EventArgs) | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
 | OnParentForeColorChanged(EventArgs) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
 | OnParentRightToLeftChanged(EventArgs) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
 | OnParentVisibleChanged(EventArgs) | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
 | OnPreviewKeyDown(PreviewKeyDownEventArgs) | Raises the PreviewKeyDown event. (Inherited from Control.)
 | OnPrint(PaintEventArgs) | Raises the Paint event. (Inherited from Control.)
 | OnQueryContinueDrag(QueryContinueDragEventArgs) | Raises the QueryContinueDrag event. (Inherited from Control.)
 | OnRegionChanged(EventArgs) | Raises the RegionChanged event. (Inherited from Control.)
 | OnResize(EventArgs) | (Inherited from UserControl.)
 | OnRightToLeftChanged(EventArgs) | (Inherited from ScrollableControl.)
 | OnScroll(ScrollEventArgs) | Raises the Scroll event. (Inherited from ScrollableControl.)
 | OnSizeChanged(EventArgs) | Raises the SizeChanged event. (Inherited from Control.)
 | OnStyleChanged(EventArgs) | Raises the StyleChanged event. (Inherited from Control.)
 | OnSystemColorsChanged(EventArgs) | Raises the SystemColorsChanged event. (Inherited from Control.)
 | OnTabIndexChanged(EventArgs) | Raises the TabIndexChanged event. (Inherited from Control.)
 | OnTabStopChanged(EventArgs) | Raises the TabStopChanged event. (Inherited from Control.)
 | OnTextChanged(EventArgs) | Raises the TextChanged event. (Inherited from Control.)
 | OnValidated(EventArgs) | Raises the Validated event. (Inherited from Control.)
 | OnValidating(CancelEventArgs) | Raises the Validating event. (Inherited from Control.)
 | OnVisibleChanged(EventArgs) | (Inherited from ScrollableControl.)
 | Padding | Gets or sets padding within the control. (Inherited from Control.)
 | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
 | Paint | Occurs when the control is redrawn. (Inherited from Control.)
 | PanButtons | Gets or sets a value that determines which mouse button will be used as a primary option to trigger a pan event.
 | PanButtons2 | Gets or sets a value that determines which mouse button will be used as the secondary option to trigger a pan event.
 | PanModifierKeys | Gets or sets a value that determines which modifier keys will be used as a primary option to trigger a pan event.
 | PanModifierKeys2 | Gets or sets a value that determines which modifier keys will be used as a secondary option to trigger a pan event.
 | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
 | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
 | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
 | PerformAutoScale()() | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
 | PerformLayout()() | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
 | PointDateFormat | Gets or sets the format for displaying tooltip values. This format is passed to ToString(String).
 | PointEditEvent | Subscribe to this event to receive notifcation and/or respond after a data point has been edited via IsEnableHEdit and IsEnableVEdit.
 | PointToClient(Point) | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
 | PointToScreen(Point) | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
 | PointValueEvent | Subscribe to this event to provide custom formatting for the tooltips
 | PointValueFormat | Gets or sets the format for displaying tooltip values. This format is passed to ToString(String).
 | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
 | PreProcessControlMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreProcessMessage(Message%) | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
 | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
 | PrintDocument | Gets or sets the PrintDocument instance that is used for all of the context menu printing functions.
 | ProcessCmdKey(Message%, Keys) | (Inherited from ContainerControl.)
 | ProcessDialogChar(Char) | (Inherited from ContainerControl.)
 | ProcessDialogKey(Keys) | (Inherited from ContainerControl.)
 | ProcessKeyEventArgs(Message%) | Processes a key message and generates the appropriate control events. (Inherited from Control.)
 | ProcessKeyMessage(Message%) | Processes a keyboard message. (Inherited from Control.)
 | ProcessKeyPreview(Message%) | Previews a keyboard message. (Inherited from Control.)
 | ProcessMnemonic(Char) | (Inherited from ContainerControl.)
 | ProcessTabKey(Boolean) | Selects the next available control and makes it the active control. (Inherited from ContainerControl.)
 | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
 | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
 | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
 | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
 | RaiseDragEvent(Object, DragEventArgs) | Raises the appropriate drag event. (Inherited from Control.)
 | RaiseKeyEvent(Object, KeyEventArgs) | Raises the appropriate key event. (Inherited from Control.)
 | RaiseMouseEvent(Object, MouseEventArgs) | Raises the appropriate mouse event. (Inherited from Control.)
 | RaisePaintEvent(Object, PaintEventArgs) | Raises the appropriate paint event. (Inherited from Control.)
 | RecreateHandle()() | Forces the re-creation of the handle for the control. (Inherited from Control.)
 | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
 | RectangleToClient(Rectangle) | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
 | RectangleToScreen(Rectangle) | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
 | Refresh()() | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
 | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
 | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
 | RenderRightToLeft | Obsolete. (Inherited from Control.)
 | ResetBackColor()() | (Inherited from Control.)
 | ResetBindings()() | (Inherited from Control.)
 | ResetCursor()() | (Inherited from Control.)
 | ResetFont()() | (Inherited from Control.)
 | ResetForeColor()() | (Inherited from Control.)
 | ResetImeMode()() | (Inherited from Control.)
 | ResetMouseEventArgs()() | Resets the control to handle the MouseLeave event. (Inherited from Control.)
 | ResetRightToLeft()() | (Inherited from Control.)
 | ResetText()() | Resets the Text property to its default value. (Inherited from Control.)
 | Resize | Occurs when the control is resized. (Inherited from Control.)
 | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
 | RestoreScale(GraphPane) | Handler for the "Set Scale to Default" context menu item. Sets the scale ranging to full auto mode for all axes.
 | ResumeLayout()() | Resumes usual layout logic. (Inherited from Control.)
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
 | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
 | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
 | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateContent(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateHorizontal(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
 | RtlTranslateLeftRight(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
 | SaveAs()() | Handler for the "Save Image As" context menu item. Copies the current image to the selected file in either the Emf (vector), or a variety of Bitmap formats.
 | SaveAsBitmap()() | Handler for the "Save Image As" context menu item. Copies the current image to the selected Bitmap file.
 | SaveAsEmf()() | Handler for the "Save Image As" context menu item. Copies the current image to the selected Emf format file.
 | SaveFileDialog | Gets or sets the SaveFileDialog instance that will be used by the "Save As..." context menu item.
 | Scale(Single) | Obsolete. (Inherited from Control.)
 | Scale(Single, Single) | Obsolete. (Inherited from Control.)
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
 | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
 | ScaleControl(SizeF, BoundsSpecified) | (Inherited from ScrollableControl.)
 | ScaleCore(Single, Single) | (Inherited from ScrollableControl.)
 | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
 | ScrollControlIntoView(Control) | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
 | ScrollDoneEvent | Subscribe to this event to be notified when the GraphPane is scrolled by the user using the scrollbars.
 | ScrollEvent | Subscribe to this event to be notified when the GraphPane is scrolled by the user using the scrollbars.
 | ScrollGrace | Set a "grace" value that leaves a buffer area around the data when IsAutoScrollRange is true.
 | ScrollMaxX | The maximum value for the X axis scroll range.
 | ScrollMaxY | The maximum value for the Y axis scroll range.
 | ScrollMaxY2 | The maximum value for the Y2 axis scroll range.
 | ScrollMinX | The minimum value for the X axis scroll range.
 | ScrollMinY | The minimum value for the Y axis scroll range.
 | ScrollMinY2 | The minimum value for the Y2 axis scroll range.
 | ScrollProgressEvent | Subscribe to this event to be notified when the GraphPane is scrolled by the user using the scrollbars.
 | ScrollToControl(Control) | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
 | Select(Boolean, Boolean) | (Inherited from ContainerControl.)
 | SelectAppendModifierKeys | Gets or sets a value that determines which Modifier keys will be used to append a CurveItem to the selection list.
 | SelectButtons | Gets or sets a value that determines which Mouse button will be used to select CurveItem's.
 | Selection | Readonly property that gets the list of selected CurveItems
 | SelectModifierKeys | Gets or sets a value that determines which Modifier keys will be used to select CurveItem's.
 | SelectNextControl(Control, Boolean, Boolean, Boolean, Boolean) | Activates the next control. (Inherited from Control.)
 | SendToBack()() | Sends the control to the back of the z-order. (Inherited from Control.)
 | SetAutoScrollMargin(Int32, Int32) | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
 | SetAutoSizeMode(AutoSizeMode) | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
 | SetBoundsCore(Int32, Int32, Int32, Int32, BoundsSpecified) | Performs the work of setting the specified bounds of this control. (Inherited from Control.)
 | SetClientSizeCore(Int32, Int32) | Sets the size of the client area of the control. (Inherited from Control.)
 | SetDisplayRectLocation(Int32, Int32) | Positions the display window to the specified value. (Inherited from ScrollableControl.)
 | SetScrollRangeFromData()() | Sets the value of the scroll range properties (see ScrollMinX, ScrollMaxX, YScrollRangeList, and Y2ScrollRangeList based on the actual range of the data for each corresponding Axis.
 | SetScrollState(Int32, Boolean) | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
 | SetStyle(ControlStyles, Boolean) | Sets the specified style bit to the specified value. (Inherited from Control.)
 | SetTopLevel(Boolean) | Sets the control as the top-level control. (Inherited from Control.)
 | SetVisibleCore(Boolean) | Sets the control to the specified visible state. (Inherited from Control.)
 | Show()() | Displays the control to the user. (Inherited from Control.)
 | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
 | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
 | Site | Gets or sets the site of the control. (Inherited from Control.)
 | Size | Gets or sets the height and width of the control. (Inherited from Control.)
 | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
 | SizeFromClientSize(Size) | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
 | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
 | SuspendLayout()() | Temporarily suspends the layout logic for the control. (Inherited from Control.)
 | IContainerControl..::ActivateControl(Control) | (Inherited from ContainerControl.)
 | IDropTarget..::OnDragDrop(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::OnDragEnter(DragEventArgs) | (Inherited from Control.)
 | IDropTarget..::OnDragLeave(EventArgs) | (Inherited from Control.)
 | IDropTarget..::OnDragOver(DragEventArgs) | (Inherited from Control.)
 | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
 | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Control.)
 | TabIndexChanged | Occurs when the TabIndex property value changes. (Inherited from Control.)
 | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Control.)
 | TabStopChanged | Occurs when the TabStop property value changes. (Inherited from Control.)
 | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
 | Text | (Inherited from UserControl.)
 | TextChanged | (Inherited from UserControl.)
 | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
 | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
 | ToString()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | Update()() | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
 | UpdateBounds()() | Updates the bounds of the control with the current size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
 | UpdateDefaultButton()() | When overridden by a derived class, updates which button is the default button. (Inherited from ContainerControl.)
 | UpdateStyles()() | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
 | UpdateZOrder()() | Updates the control in its parent's z-order. (Inherited from Control.)
 | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
 | Validate()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
 | ValidateChildren()() | (Inherited from UserControl.)
 | ValidateChildren(ValidationConstraints) | (Inherited from UserControl.)
 | Validated | Occurs when the control is finished validating. (Inherited from Control.)
 | Validating | Occurs when the control is validating. (Inherited from Control.)
 | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
 | Visible | Gets or sets a value indicating whether the control is displayed. (Inherited from Control.)
 | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
 | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
 | Width | Gets or sets the width of the control. (Inherited from Control.)
 | WindowTarget | (Inherited from Control.)
 | WndProc(Message%) | (Inherited from UserControl.)
 | Y2ScrollRangeList | Access the ScrollRangeList for the Y2 axes.
 | YScrollRangeList | Access the ScrollRangeList for the Y axes.
 | ZoomButtons | Gets or sets a value that determines which mouse button will be used as a primary option to trigger a zoom event.
 | ZoomButtons2 | Gets or sets a value that determines which mouse button will be used as the secondary option to trigger a zoom event.
 | ZoomEvent | Subscribe to this event to be notified when the GraphPane is zoomed or panned by the user, either via a mouse drag operation or by the context menu commands.
 | ZoomModifierKeys | Gets or sets a value that determines which modifier keys will be used as a primary option to trigger a zoom event.
 | ZoomModifierKeys2 | Gets or sets a value that determines which modifier keys will be used as a secondary option to trigger a zoom event.
 | ZoomOut(GraphPane) | Handler for the "UnZoom/UnPan" context menu item. Restores the scale ranges to the values before the last zoom, pan, or scroll operation.
 | ZoomOutAll(GraphPane) | Handler for the "Undo All Zoom/Pan" context menu item. Restores the scale ranges to the values before all zoom and pan operations
 | ZoomPane(GraphPane, Double, PointF, Boolean) | Zoom a specified pane in or out according to the specified zoom fraction.
 | ZoomStepFraction | Gets or sets the step size fraction for zooming with the mouse wheel. A value of 0.1 will result in a 10% zoom step for each mouse wheel movement.
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | Component
 |  |  | Control
 |  |  |  | ScrollableControl
 |  |  |  |  | ContainerControl
 |  |  |  |  |  | UserControl
 |  |  |  |  |  |  | ZedGraphControl


ZedGraphControl Constructor

ZedGraphControl Constructor
Namespaces ► ZedGraph ► ZedGraphControl ► ZedGraphControlZedGraphControlNew()()
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphControl()
Public Sub New
public:
ZedGraphControl ()


AxisChange Method

AxisChange Method
Namespaces ► ZedGraph ► ZedGraphControl ► AxisChange()()
This performs an axis change command on the graphPane.
Declaration Syntax
C# Visual Basic Visual C++
public virtual void AxisChange()
Public Overridable Sub AxisChange
public:
virtual void AxisChange ()
Remarks
This is the same as ZedGraphControl.GraphPane.AxisChange( ZedGraphControl.CreateGraphics() ), however, this method also calls SetScrollRangeFromData()() if IsAutoScrollRange is true.


BeenDisposed Property

BeenDisposed Property
Namespaces ► ZedGraph ► ZedGraphControl ► BeenDisposed
This checks if the control has been disposed. This is synonymous with the graph pane having been nulled or disposed. Therefore this is the same as ZedGraphControl.GraphPane == null.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public bool BeenDisposed{ get;}
<BindableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public ReadOnly Property BeenDisposed As Boolean
[BindableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
property bool BeenDisposed {
    bool get ();
}


ContextMenuBuilder Event

ContextMenuBuilder Event
Namespaces ► ZedGraph ► ZedGraphControl ► ContextMenuBuilder
Subscribe to this event to be able to modify the ZedGraph context menu.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public event ZedGraphControl.ZedGraphControl..::ContextMenuBuilderEventHandler ContextMenuBuilder
<BindableAttribute(True)> _
Public Event ContextMenuBuilder As ZedGraphControl..::ContextMenuBuilderEventHandler
[BindableAttribute(true)]
public:
 event ZedGraphControl..::ContextMenuBuilderEventHandler^ ContextMenuBuilder {
    void add (ZedGraphControl..::ContextMenuBuilderEventHandler^ value);
    void remove (ZedGraphControl..::ContextMenuBuilderEventHandler^ value);
}
Remarks
The context menu is built on the fly after a right mouse click. You can add menu items to this menu by simply modifying the parameter.


Copy Method (isShowMessage)

Copy Method (isShowMessage)
Namespaces ► ZedGraph ► ZedGraphControl ► Copy(Boolean)
Handler for the "Copy" context menu item. Copies the current image to a bitmap on the clipboard.
Declaration Syntax
C# Visual Basic Visual C++
public void Copy(
    bool isShowMessage
)
Public Sub Copy ( _
    isShowMessage As Boolean _
)
public:
void Copy (
    bool isShowMessage
)
Parameters
isShowMessage (Boolean)
boolean value that determines whether or not a prompt will be displayed. true to show a message of "Image Copied to ClipBoard".


DoPageSetup Method

DoPageSetup Method
Namespaces ► ZedGraph ► ZedGraphControl ► DoPageSetup()()
Display a PageSetupDialog to the user, allowing them to modify the print settings for this ZedGraphControl.
Declaration Syntax
C# Visual Basic Visual C++
public void DoPageSetup()
Public Sub DoPageSetup
public:
void DoPageSetup ()


DoPrint Method

DoPrint Method
Namespaces ► ZedGraph ► ZedGraphControl ► DoPrint()()
Display a PrintDialog to the user, allowing them to select a printer and print the MasterPane contained in this ZedGraphControl.
Declaration Syntax
C# Visual Basic Visual C++
public void DoPrint()
Public Sub DoPrint
public:
void DoPrint ()


DoPrintPreview Method

DoPrintPreview Method
Namespaces ► ZedGraph ► ZedGraphControl ► DoPrintPreview()()
Display a PrintPreviewDialog, allowing the user to preview and subsequently print the MasterPane contained in this ZedGraphControl.
Declaration Syntax
C# Visual Basic Visual C++
public void DoPrintPreview()
Public Sub DoPrintPreview
public:
void DoPrintPreview ()


DoubleClickEvent Event

DoubleClickEvent Event
Namespaces ► ZedGraph ► ZedGraphControl ► DoubleClickEvent
Subscribe to this event to provide notification of Double Clicks on graph objects
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public event ZedGraphControl.ZedGraphControl..::ZedMouseEventHandler DoubleClickEvent
<BindableAttribute(True)> _
Public Event DoubleClickEvent As ZedGraphControl..::ZedMouseEventHandler
[BindableAttribute(true)]
public:
 event ZedGraphControl..::ZedMouseEventHandler^ DoubleClickEvent {
    void add (ZedGraphControl..::ZedMouseEventHandler^ value);
    void remove (ZedGraphControl..::ZedMouseEventHandler^ value);
}
Remarks
This event provides for a notification when the mouse is double-clicked on an object within any GraphPane of the MasterPane associated with this ZedGraphControl. This event will use the FindNearestPaneObject(PointF, Graphics, GraphPane%, Object%, Int32%) method to determine which object was clicked. The boolean value that you return from this handler determines whether or not the ZedGraphControl will do any further handling of the DoubleClick event (see ZedGraphControl..::ZedMouseEventHandler). Return true if you have handled the DoubleClick event entirely, and you do not want the ZedGraphControl to do any further action. Return false if ZedGraph should go ahead and process the DoubleClick event.


EditButtons Property

EditButtons Property
Namespaces ► ZedGraph ► ZedGraphControl ► EditButtons
Gets or sets a value that determines which Mouse button will be used to edit point data values
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute()]
public MouseButtons EditButtons{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute()> _
Public Property EditButtons As MouseButtons
[BindableAttribute(true)]
[DefaultValueAttribute()]
public:
property MouseButtons EditButtons {
    MouseButtons get ();
    void set (MouseButtons value);
}
Remarks
This setting only applies if IsEnableHEdit and/or IsEnableVEdit are true.
See Also
EditModifierKeys


EditModifierKeys Property

EditModifierKeys Property
Namespaces ► ZedGraph ► ZedGraphControl ► EditModifierKeys
Gets or sets a value that determines which modifier keys will be used to edit point data values
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute()]
[BindableAttribute(true)]
public Keys EditModifierKeys{ get; set;}
<DefaultValueAttribute()> _
<BindableAttribute(True)> _
Public Property EditModifierKeys As Keys
[DefaultValueAttribute()]
[BindableAttribute(true)]
public:
property Keys EditModifierKeys {
    Keys get ();
    void set (Keys value);
}
Remarks
This setting only applies if IsEnableHEdit and/or IsEnableVEdit are true.
See Also
EditButtons


GetImage Method

GetImage Method
Namespaces ► ZedGraph ► ZedGraphControl ► GetImage()()
Gets the graph pane's current image. Bitmap
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BindableAttribute(false)]
[BrowsableAttribute(false)]
public Image GetImage()
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BindableAttribute(False)> _
<BrowsableAttribute(False)> _
Public Function GetImage As Image
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BindableAttribute(false)]
[BrowsableAttribute(false)]
public:
Image^ GetImage ()
Exceptions
Exception | Condition
ZedGraphException | When the control has been disposed before this call.
See Also
Bitmap


GraphPane Property

GraphPane Property
Namespaces ► ZedGraph ► ZedGraphControl ► GraphPane
Gets or sets the GraphPane property for the control
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(false)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public GraphPane GraphPane{ get; set;}
<BindableAttribute(False)> _
<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Property GraphPane As GraphPane
[BindableAttribute(false)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property GraphPane^ GraphPane {
    GraphPane^ get ();
    void set (GraphPane^ value);
}
Remarks
ZedGraphControl actually uses a MasterPane object to hold a list of GraphPane objects. This property really only accesses the first GraphPane in the list. If there is more than one GraphPane, use the MasterPane indexer property to access any of the GraphPane objects.


IsAntiAlias Property

IsAntiAlias Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsAntiAlias
Gets or sets a value that determines if all drawing operations for this control will be forced to operate in Anti-alias mode. Note that if this value is set to "true", it overrides the setting for sub-objects. Otherwise, the sub-object settings (such as IsAntiAlias) will be honored.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute(false)]
public bool IsAntiAlias{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute(False)> _
Public Property IsAntiAlias As Boolean
[BindableAttribute(true)]
[DefaultValueAttribute(false)]
public:
property bool IsAntiAlias {
    bool get ();
    void set (bool value);
}


IsAutoScrollRange Property

IsAutoScrollRange Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsAutoScrollRange
Gets or sets a value that controls whether or not the axis value range for the scroll bars will be set automatically.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute(false)]
public bool IsAutoScrollRange{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute(False)> _
Public Property IsAutoScrollRange As Boolean
[BindableAttribute(true)]
[DefaultValueAttribute(false)]
public:
property bool IsAutoScrollRange {
    bool get ();
    void set (bool value);
}
Remarks
If this value is set to true, then the range of the scroll bars will be set automatically to the actual range of the data as returned by GetRange(Boolean, Boolean, GraphPane) at the time that AxisChange()() was last called. Note that a value of true can override any setting of ScrollMinX, ScrollMaxX, ScrollMinY, ScrollMaxY, ScrollMinY2, and ScrollMaxY2. Note also that you must call AxisChange()() from the ZedGraphControl for this to work properly (e.g., don't call it directly from the GraphPane. Alternatively, you can call SetScrollRangeFromData()() at anytime to set the scroll bar range.
In most cases, you will probably want to disable IsBoundedRanges before activating this option.


IsEnableHEdit Property

IsEnableHEdit Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsEnableHEdit
Gets or sets a value that determines whether or not editing of point data is allowed in the horizontal direction.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute(false)]
public bool IsEnableHEdit{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute(False)> _
Public Property IsEnableHEdit As Boolean
[BindableAttribute(true)]
[DefaultValueAttribute(false)]
public:
property bool IsEnableHEdit {
    bool get ();
    void set (bool value);
}
Remarks
Editing is done by holding down the Alt key, and left-clicking on an individual point of a given CurveItem to drag it to a new location. The Mouse and Key combination for this mode are modifiable using EditButtons and EditModifierKeys.
See Also
EditButtons
EditModifierKeys
IsEnableVEdit


IsEnableHPan Property

IsEnableHPan Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsEnableHPan
Gets or sets a value that determines whether or not panning is allowed for the control in the horizontal direction.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute(true)]
public bool IsEnableHPan{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute(True)> _
Public Property IsEnableHPan As Boolean
[BindableAttribute(true)]
[DefaultValueAttribute(true)]
public:
property bool IsEnableHPan {
    bool get ();
    void set (bool value);
}
Remarks
Panning is done by clicking the middle mouse button (or holding down the shift key while clicking the left mouse button) inside the Rect and dragging the mouse around to shift the scale ranges as desired.
See Also
IsEnableVPan


IsEnableHZoom Property

IsEnableHZoom Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsEnableHZoom
Gets or sets a value that determines whether or not zooming is allowed for the control in the horizontal direction.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute(true)]
public bool IsEnableHZoom{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute(True)> _
Public Property IsEnableHZoom As Boolean
[BindableAttribute(true)]
[DefaultValueAttribute(true)]
public:
property bool IsEnableHZoom {
    bool get ();
    void set (bool value);
}
Remarks
Zooming is done by left-clicking inside the Rect to drag out a rectangle, indicating the new scale ranges that will be part of the graph.


IsEnableSelection Property

IsEnableSelection Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsEnableSelection
Gets or sets a value that determines whether or not selection is allowed for the control.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute(false)]
public bool IsEnableSelection{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute(False)> _
Public Property IsEnableSelection As Boolean
[BindableAttribute(true)]
[DefaultValueAttribute(false)]
public:
property bool IsEnableSelection {
    bool get ();
    void set (bool value);
}


IsEnableVEdit Property

IsEnableVEdit Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsEnableVEdit
Gets or sets a value that determines whether or not editing of point data is allowed in the vertical direction.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute(false)]
public bool IsEnableVEdit{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute(False)> _
Public Property IsEnableVEdit As Boolean
[BindableAttribute(true)]
[DefaultValueAttribute(false)]
public:
property bool IsEnableVEdit {
    bool get ();
    void set (bool value);
}
Remarks
Editing is done by holding down the Alt key, and left-clicking on an individual point of a given CurveItem to drag it to a new location. The Mouse and Key combination for this mode are modifiable using EditButtons and EditModifierKeys.


IsEnableVPan Property

IsEnableVPan Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsEnableVPan
Gets or sets a value that determines whether or not panning is allowed for the control in the vertical direction.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute(true)]
public bool IsEnableVPan{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute(True)> _
Public Property IsEnableVPan As Boolean
[BindableAttribute(true)]
[DefaultValueAttribute(true)]
public:
property bool IsEnableVPan {
    bool get ();
    void set (bool value);
}
Remarks
Panning is done by clicking the middle mouse button (or holding down the shift key while clicking the left mouse button) inside the Rect and dragging the mouse around to shift the scale ranges as desired.
See Also
IsEnableHPan


IsEnableVZoom Property

IsEnableVZoom Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsEnableVZoom
Gets or sets a value that determines whether or not zooming is allowed for the control in the vertical direction.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute(true)]
public bool IsEnableVZoom{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute(True)> _
Public Property IsEnableVZoom As Boolean
[BindableAttribute(true)]
[DefaultValueAttribute(true)]
public:
property bool IsEnableVZoom {
    bool get ();
    void set (bool value);
}
Remarks
Zooming is done by left-clicking inside the Rect to drag out a rectangle, indicating the new scale ranges that will be part of the graph.


IsEnableZoom Property

IsEnableZoom Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsEnableZoom
Gets or sets a value that determines whether or not zooming is allowed for the control.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute(true)]
[BindableAttribute(true)]
public bool IsEnableZoom{ set;}
<DefaultValueAttribute(True)> _
<BindableAttribute(True)> _
Public WriteOnly Property IsEnableZoom As Boolean
[DefaultValueAttribute(true)]
[BindableAttribute(true)]
public:
property bool IsEnableZoom {
    void set (bool value);
}
Remarks
Zooming is done by left-clicking inside the Rect to drag out a rectangle, indicating the new scale ranges that will be part of the graph.


IsPrintFillPage Property

IsPrintFillPage Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsPrintFillPage
Gets or sets a value that determines whether or not the MasterPane Rect dimensions will be expanded to fill the available space when printing this ZedGraphControl.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute(true)]
public bool IsPrintFillPage{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute(True)> _
Public Property IsPrintFillPage As Boolean
[BindableAttribute(true)]
[DefaultValueAttribute(true)]
public:
property bool IsPrintFillPage {
    bool get ();
    void set (bool value);
}
Remarks
If IsPrintKeepAspectRatio is also true, then the MasterPane Rect dimensions will be expanded to fit as large a space as possible while still honoring the visible aspect ratio.


IsPrintKeepAspectRatio Property

IsPrintKeepAspectRatio Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsPrintKeepAspectRatio
Gets or sets a value that determines whether or not the visible aspect ratio of the MasterPane Rect will be preserved when printing this ZedGraphControl.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute(true)]
public bool IsPrintKeepAspectRatio{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute(True)> _
Public Property IsPrintKeepAspectRatio As Boolean
[BindableAttribute(true)]
[DefaultValueAttribute(true)]
public:
property bool IsPrintKeepAspectRatio {
    bool get ();
    void set (bool value);
}


IsPrintScaleAll Property

IsPrintScaleAll Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsPrintScaleAll
Gets or sets a value that determines whether the settings of IsFontsScaled and IsPenWidthScaled will be overridden to true during printing operations.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute(true)]
[BindableAttribute(true)]
public bool IsPrintScaleAll{ get; set;}
<DefaultValueAttribute(True)> _
<BindableAttribute(True)> _
Public Property IsPrintScaleAll As Boolean
[DefaultValueAttribute(true)]
[BindableAttribute(true)]
public:
property bool IsPrintScaleAll {
    bool get ();
    void set (bool value);
}
Value
A value of true will cause both IsFontsScaled and IsPenWidthScaled to be temporarily set to true during printing operations.
Remarks
Printing involves pixel maps that are typically of a dramatically different dimension than on-screen pixel maps. Therefore, it becomes more important to scale the fonts and lines to give a printed image that looks like what is shown on-screen. The default setting for IsFontsScaled is true, but the default setting for IsPenWidthScaled is false.


IsScrolling Property

IsScrolling Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsScrolling
Returns true if the user is currently scrolling via the scrollbar, or false if no scrolling is taking place.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsScrolling{ get;}
Public ReadOnly Property IsScrolling As Boolean
public:
property bool IsScrolling {
    bool get ();
}
Remarks
This method just tests ScrollBar.Capture to see if the mouse has been captured by the scroll bar. If so, scrolling is active.


IsScrollY2 Property

IsScrollY2 Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsScrollY2
Gets or sets a value that determines if the vertical scroll bar will affect the Y2 axis.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute(false)]
[BindableAttribute(true)]
public bool IsScrollY2{ get; set;}
<DefaultValueAttribute(False)> _
<BindableAttribute(True)> _
Public Property IsScrollY2 As Boolean
[DefaultValueAttribute(false)]
[BindableAttribute(true)]
public:
property bool IsScrollY2 {
    bool get ();
    void set (bool value);
}
Remarks
The vertical scroll bar is automatically associated with the Y axis. With this value, you can choose to include or exclude the Y2 axis with the scrolling. Note that the Y2 axis scrolling is handled as a secondary. The vertical scroll bar position always reflects the status of the Y axis. This can cause the Y2 axis to "jump" when first scrolled if the ScrollMinY2 and ScrollMaxY2 values are not set to the same proportions as ScrollMinY and ScrollMaxY with respect to the actual Min and Max. Also note that this property is actually just an alias to the IsScrollable property of the first element of YScrollRangeList.
See Also
IsShowVScrollBar
ScrollMinY2
ScrollMaxY2
YScrollRangeList
Y2ScrollRangeList


IsShowContextMenu Property

IsShowContextMenu Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsShowContextMenu
Gets or sets a value that determines whether or not the context menu will be available.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute(true)]
public bool IsShowContextMenu{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute(True)> _
Public Property IsShowContextMenu As Boolean
[BindableAttribute(true)]
[DefaultValueAttribute(true)]
public:
property bool IsShowContextMenu {
    bool get ();
    void set (bool value);
}
Value
true to allow the context menu, false to disable it
Remarks
The context menu is a menu that appears when you right-click on the ZedGraphControl. It provides options for Zoom, Pan, AutoScale, Clipboard Copy, and toggle IsShowPointValues.


IsShowCopyMessage Property

IsShowCopyMessage Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsShowCopyMessage
Gets or sets a value that determines whether or not a message box will be shown in response to a context menu "Copy" command.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute(true)]
[BindableAttribute(true)]
public bool IsShowCopyMessage{ get; set;}
<DefaultValueAttribute(True)> _
<BindableAttribute(True)> _
Public Property IsShowCopyMessage As Boolean
[DefaultValueAttribute(true)]
[BindableAttribute(true)]
public:
property bool IsShowCopyMessage {
    bool get ();
    void set (bool value);
}
Remarks
Note that, if this property is set to false, the user will receive no indicative feedback in response to a Copy action.


IsShowCursorValues Property

IsShowCursorValues Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsShowCursorValues
Gets or sets a value that determines whether or not tooltips will be displayed showing the current scale values when the mouse is within the Rect.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute(false)]
[BindableAttribute(true)]
public bool IsShowCursorValues{ get; set;}
<DefaultValueAttribute(False)> _
<BindableAttribute(True)> _
Public Property IsShowCursorValues As Boolean
[DefaultValueAttribute(false)]
[BindableAttribute(true)]
public:
property bool IsShowCursorValues {
    bool get ();
    void set (bool value);
}
Remarks
The displayed values are taken from the current mouse position, and formatted according to PointValueFormat and/or PointDateFormat. If this value is set to true, it overrides the IsShowPointValues setting.


IsShowHScrollBar Property

IsShowHScrollBar Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsShowHScrollBar
Gets or sets a value that determines if the horizontal scroll bar will be visible.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute(false)]
[BindableAttribute(true)]
public bool IsShowHScrollBar{ get; set;}
<DefaultValueAttribute(False)> _
<BindableAttribute(True)> _
Public Property IsShowHScrollBar As Boolean
[DefaultValueAttribute(false)]
[BindableAttribute(true)]
public:
property bool IsShowHScrollBar {
    bool get ();
    void set (bool value);
}
Value
A boolean value. true to display a horizontal scrollbar, false otherwise.
Remarks
This scroll bar allows the display to be scrolled in the horizontal direction. Another option is display panning, in which the user can move the display around by clicking directly on it and dragging (see IsEnableHPan and IsEnableVPan). You can control the available range of scrolling with the ScrollMinX and ScrollMaxX properties. Note that the scroll range can be set automatically by IsAutoScrollRange.
In most cases, you will probably want to disable IsBoundedRanges before activating this option.


IsShowPointValues Property

IsShowPointValues Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsShowPointValues
Gets or sets a value that determines whether or not tooltips will be displayed when the mouse hovers over data values.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute(false)]
public bool IsShowPointValues{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute(False)> _
Public Property IsShowPointValues As Boolean
[BindableAttribute(true)]
[DefaultValueAttribute(false)]
public:
property bool IsShowPointValues {
    bool get ();
    void set (bool value);
}
Remarks
The displayed values are taken from Tag if it is a String type, or ToString()() otherwise (using the PointValueFormat as a format string). Additionally, the user can custom format the values using the PointValueEvent event. Note that IsShowPointValues may be overridden by IsShowCursorValues.


IsShowVScrollBar Property

IsShowVScrollBar Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsShowVScrollBar
Gets or sets a value that determines if the vertical scroll bar will be visible.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute(false)]
[BindableAttribute(true)]
public bool IsShowVScrollBar{ get; set;}
<DefaultValueAttribute(False)> _
<BindableAttribute(True)> _
Public Property IsShowVScrollBar As Boolean
[DefaultValueAttribute(false)]
[BindableAttribute(true)]
public:
property bool IsShowVScrollBar {
    bool get ();
    void set (bool value);
}
Value
A boolean value. true to display a vertical scrollbar, false otherwise.
Remarks
This scroll bar allows the display to be scrolled in the vertical direction. Another option is display panning, in which the user can move the display around by clicking directly on it and dragging (see IsEnableHPan and IsEnableVPan). You can control the available range of scrolling with the ScrollMinY and ScrollMaxY properties. Note that the vertical scroll bar only affects the YAxis; it has no impact on the Y2Axis. The panning options affect both the YAxis and Y2Axis. Note also that the scroll range can be set automatically by IsAutoScrollRange.
In most cases, you will probably want to disable IsBoundedRanges before activating this option.


IsSynchronizeXAxes Property

IsSynchronizeXAxes Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsSynchronizeXAxes
Gets or sets a value that determines if the XAxis Scale ranges for all GraphPane objects in the MasterPane will be forced to match.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute(false)]
public bool IsSynchronizeXAxes{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute(False)> _
Public Property IsSynchronizeXAxes As Boolean
[BindableAttribute(true)]
[DefaultValueAttribute(false)]
public:
property bool IsSynchronizeXAxes {
    bool get ();
    void set (bool value);
}
Remarks
If set to true (default is false), then all of the GraphPane objects in the MasterPane associated with this ZedGraphControl will be forced to have matching scale ranges for the x axis. That is, zoom, pan, and scroll operations will result in zoom/pan/scroll for all graphpanes simultaneously.


IsSynchronizeYAxes Property

IsSynchronizeYAxes Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsSynchronizeYAxes
Gets or sets a value that determines if the YAxis Scale ranges for all GraphPane objects in the MasterPane will be forced to match.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute(false)]
[BindableAttribute(true)]
public bool IsSynchronizeYAxes{ get; set;}
<DefaultValueAttribute(False)> _
<BindableAttribute(True)> _
Public Property IsSynchronizeYAxes As Boolean
[DefaultValueAttribute(false)]
[BindableAttribute(true)]
public:
property bool IsSynchronizeYAxes {
    bool get ();
    void set (bool value);
}
Remarks
If set to true (default is false), then all of the GraphPane objects in the MasterPane associated with this ZedGraphControl will be forced to have matching scale ranges for the y axis. That is, zoom, pan, and scroll operations will result in zoom/pan/scroll for all graphpanes simultaneously.


IsZoomOnMouseCenter Property

IsZoomOnMouseCenter Property
Namespaces ► ZedGraph ► ZedGraphControl ► IsZoomOnMouseCenter
Gets or sets a boolean value that determines if zooming with the wheel mouse is centered on the mouse location, or centered on the existing graph.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute(false)]
[BindableAttribute(true)]
public bool IsZoomOnMouseCenter{ get; set;}
<DefaultValueAttribute(False)> _
<BindableAttribute(True)> _
Public Property IsZoomOnMouseCenter As Boolean
[DefaultValueAttribute(false)]
[BindableAttribute(true)]
public:
property bool IsZoomOnMouseCenter {
    bool get ();
    void set (bool value);
}


LinkButtons Property

LinkButtons Property
Namespaces ► ZedGraph ► ZedGraphControl ► LinkButtons
Gets or sets a value that determines which Mouse button will be used to click on linkable objects
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute()]
[BindableAttribute(true)]
public MouseButtons LinkButtons{ get; set;}
<DefaultValueAttribute()> _
<BindableAttribute(True)> _
Public Property LinkButtons As MouseButtons
[DefaultValueAttribute()]
[BindableAttribute(true)]
public:
property MouseButtons LinkButtons {
    MouseButtons get ();
    void set (MouseButtons value);
}
See Also
LinkModifierKeys
LinkEvent


LinkEvent Event

LinkEvent Event
Namespaces ► ZedGraph ► ZedGraphControl ► LinkEvent
Subscribe to this event to be able to respond to mouse clicks within linked objects.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public event ZedGraphControl.ZedGraphControl..::LinkEventHandler LinkEvent
<BindableAttribute(True)> _
Public Event LinkEvent As ZedGraphControl..::LinkEventHandler
[BindableAttribute(true)]
public:
 event ZedGraphControl..::LinkEventHandler^ LinkEvent {
    void add (ZedGraphControl..::LinkEventHandler^ value);
    void remove (ZedGraphControl..::LinkEventHandler^ value);
}
Remarks
Linked objects are typically either GraphObj type objects or CurveItem type objects. These object types can include hyperlink information allowing for "drill-down" type operation.
See Also
ZedGraphControl..::LinkEventHandler
Link
CurveItem.Link
GraphObj.Link


LinkModifierKeys Property

LinkModifierKeys Property
Namespaces ► ZedGraph ► ZedGraphControl ► LinkModifierKeys
Gets or sets a value that determines which modifier keys will be used to click on linkable objects
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute()]
[BindableAttribute(true)]
public Keys LinkModifierKeys{ get; set;}
<DefaultValueAttribute()> _
<BindableAttribute(True)> _
Public Property LinkModifierKeys As Keys
[DefaultValueAttribute()]
[BindableAttribute(true)]
public:
property Keys LinkModifierKeys {
    Keys get ();
    void set (Keys value);
}
See Also
LinkButtons
LinkEvent


MasterPane Property

MasterPane Property
Namespaces ► ZedGraph ► ZedGraphControl ► MasterPane
Gets or sets the MasterPane property for the control
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(false)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public MasterPane MasterPane{ get; set;}
<BindableAttribute(False)> _
<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public Property MasterPane As MasterPane
[BindableAttribute(false)]
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
property MasterPane^ MasterPane {
    MasterPane^ get ();
    void set (MasterPane^ value);
}


MouseDown Event

MouseDown Event
Namespaces ► ZedGraph ► ZedGraphControl ► MouseDown
Hide the standard control MouseDown event so that the ZedGraphControl.MouseDownEvent can be used. This is so that the user must return true/false in order to indicate whether or not we should respond to the event.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(false)]
[BrowsableAttribute(false)]
public event MouseEventHandler MouseDown
<BindableAttribute(False)> _
<BrowsableAttribute(False)> _
Public Event MouseDown As MouseEventHandler
[BindableAttribute(false)]
[BrowsableAttribute(false)]
public:
 event MouseEventHandler^ MouseDown {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}


MouseDownEvent Event

MouseDownEvent Event
Namespaces ► ZedGraph ► ZedGraphControl ► MouseDownEvent
Subscribe to this event to provide notification of MouseDown clicks on graph objects
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public event ZedGraphControl.ZedGraphControl..::ZedMouseEventHandler MouseDownEvent
<BindableAttribute(True)> _
Public Event MouseDownEvent As ZedGraphControl..::ZedMouseEventHandler
[BindableAttribute(true)]
public:
 event ZedGraphControl..::ZedMouseEventHandler^ MouseDownEvent {
    void add (ZedGraphControl..::ZedMouseEventHandler^ value);
    void remove (ZedGraphControl..::ZedMouseEventHandler^ value);
}
Remarks
This event provides for a notification when the mouse is clicked on an object within any GraphPane of the MasterPane associated with this ZedGraphControl. This event will use the FindNearestPaneObject(PointF, Graphics, GraphPane%, Object%, Int32%) method to determine which object was clicked. The boolean value that you return from this handler determines whether or not the ZedGraphControl will do any further handling of the MouseDown event (see ZedGraphControl..::ZedMouseEventHandler). Return true if you have handled the MouseDown event entirely, and you do not want the ZedGraphControl to do any further action (e.g., starting a zoom operation). Return false if ZedGraph should go ahead and process the MouseDown event.


MouseMoveEvent Event

MouseMoveEvent Event
Namespaces ► ZedGraph ► ZedGraphControl ► MouseMoveEvent
Subscribe to this event to provide notification of MouseMove events over graph objects
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public event ZedGraphControl.ZedGraphControl..::ZedMouseEventHandler MouseMoveEvent
<BindableAttribute(True)> _
Public Event MouseMoveEvent As ZedGraphControl..::ZedMouseEventHandler
[BindableAttribute(true)]
public:
 event ZedGraphControl..::ZedMouseEventHandler^ MouseMoveEvent {
    void add (ZedGraphControl..::ZedMouseEventHandler^ value);
    void remove (ZedGraphControl..::ZedMouseEventHandler^ value);
}
Remarks
This event provides for a notification when the mouse is moving over on the control. The boolean value that you return from this handler determines whether or not the ZedGraphControl will do any further handling of the MouseMove event (see ZedGraphControl..::ZedMouseEventHandler). Return true if you have handled the MouseMove event entirely, and you do not want the ZedGraphControl to do any further action. Return false if ZedGraph should go ahead and process the MouseMove event.


MouseUp Event

MouseUp Event
Namespaces ► ZedGraph ► ZedGraphControl ► MouseUp
Hide the standard control MouseUp event so that the ZedGraphControl.MouseUpEvent can be used. This is so that the user must return true/false in order to indicate whether or not we should respond to the event.
Declaration Syntax
C# Visual Basic Visual C++
[BrowsableAttribute(false)]
[BindableAttribute(false)]
public event MouseEventHandler MouseUp
<BrowsableAttribute(False)> _
<BindableAttribute(False)> _
Public Event MouseUp As MouseEventHandler
[BrowsableAttribute(false)]
[BindableAttribute(false)]
public:
 event MouseEventHandler^ MouseUp {
    void add (MouseEventHandler^ value);
    void remove (MouseEventHandler^ value);
}


MouseUpEvent Event

MouseUpEvent Event
Namespaces ► ZedGraph ► ZedGraphControl ► MouseUpEvent
Subscribe to this event to provide notification of MouseUp clicks on graph objects
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public event ZedGraphControl.ZedGraphControl..::ZedMouseEventHandler MouseUpEvent
<BindableAttribute(True)> _
Public Event MouseUpEvent As ZedGraphControl..::ZedMouseEventHandler
[BindableAttribute(true)]
public:
 event ZedGraphControl..::ZedMouseEventHandler^ MouseUpEvent {
    void add (ZedGraphControl..::ZedMouseEventHandler^ value);
    void remove (ZedGraphControl..::ZedMouseEventHandler^ value);
}
Remarks
This event provides for a notification when the mouse is clicked on an object within any GraphPane of the MasterPane associated with this ZedGraphControl. This event will use the FindNearestPaneObject(PointF, Graphics, GraphPane%, Object%, Int32%) method to determine which object was clicked. The boolean value that you return from this handler determines whether or not the ZedGraphControl will do any further handling of the MouseUp event (see ZedGraphControl..::ZedMouseEventHandler). Return true if you have handled the MouseUp event entirely, and you do not want the ZedGraphControl to do any further action (e.g., starting a zoom operation). Return false if ZedGraph should go ahead and process the MouseUp event.


PanButtons Property

PanButtons Property
Namespaces ► ZedGraph ► ZedGraphControl ► PanButtons
Gets or sets a value that determines which mouse button will be used as a primary option to trigger a pan event.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute()]
public MouseButtons PanButtons{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute()> _
Public Property PanButtons As MouseButtons
[BindableAttribute(true)]
[DefaultValueAttribute()]
public:
property MouseButtons PanButtons {
    MouseButtons get ();
    void set (MouseButtons value);
}
Remarks
This value is combined with PanModifierKeys to determine the actual pan combination. A secondary pan button/key combination option is available via PanButtons2 and PanModifierKeys2. To not use this button/key combination, set the value of PanButtons to None.


PanButtons2 Property

PanButtons2 Property
Namespaces ► ZedGraph ► ZedGraphControl ► PanButtons2
Gets or sets a value that determines which mouse button will be used as the secondary option to trigger a pan event.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute()]
public MouseButtons PanButtons2{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute()> _
Public Property PanButtons2 As MouseButtons
[BindableAttribute(true)]
[DefaultValueAttribute()]
public:
property MouseButtons PanButtons2 {
    MouseButtons get ();
    void set (MouseButtons value);
}
Remarks
This value is combined with PanModifierKeys2 to determine the actual pan combination. The primary pan button/key combination option is available via PanButtons and PanModifierKeys. To not use this button/key combination, set the value of PanButtons2 to None.


PanModifierKeys Property

PanModifierKeys Property
Namespaces ► ZedGraph ► ZedGraphControl ► PanModifierKeys
Gets or sets a value that determines which modifier keys will be used as a primary option to trigger a pan event.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute()]
[BindableAttribute(true)]
public Keys PanModifierKeys{ get; set;}
<DefaultValueAttribute()> _
<BindableAttribute(True)> _
Public Property PanModifierKeys As Keys
[DefaultValueAttribute()]
[BindableAttribute(true)]
public:
property Keys PanModifierKeys {
    Keys get ();
    void set (Keys value);
}
Remarks
This value is combined with PanButtons to determine the actual pan combination. A secondary pan button/key combination option is available via PanButtons2 and PanModifierKeys2. To not use this button/key combination, set the value of PanButtons to None.


PanModifierKeys2 Property

PanModifierKeys2 Property
Namespaces ► ZedGraph ► ZedGraphControl ► PanModifierKeys2
Gets or sets a value that determines which modifier keys will be used as a secondary option to trigger a pan event.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute()]
public Keys PanModifierKeys2{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute()> _
Public Property PanModifierKeys2 As Keys
[BindableAttribute(true)]
[DefaultValueAttribute()]
public:
property Keys PanModifierKeys2 {
    Keys get ();
    void set (Keys value);
}
Remarks
This value is combined with PanButtons2 to determine the actual pan combination. A primary pan button/key combination option is available via PanButtons and PanModifierKeys. To not use this button/key combination, set the value of PanButtons2 to None.


PointDateFormat Property

PointDateFormat Property
Namespaces ► ZedGraph ► ZedGraphControl ► PointDateFormat
Gets or sets the format for displaying tooltip values. This format is passed to ToString(String).
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute("g")]
[BindableAttribute(true)]
public string PointDateFormat{ get; set;}
<DefaultValueAttribute("g")> _
<BindableAttribute(True)> _
Public Property PointDateFormat As String
[DefaultValueAttribute(L"g")]
[BindableAttribute(true)]
public:
property String^ PointDateFormat {
    String^ get ();
    void set (String^ value);
}
Remarks
Use the DateTimeFormatInfo type to determine the format strings.


PointEditEvent Event

PointEditEvent Event
Namespaces ► ZedGraph ► ZedGraphControl ► PointEditEvent
Subscribe to this event to receive notifcation and/or respond after a data point has been edited via IsEnableHEdit and IsEnableVEdit.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public event ZedGraphControl.ZedGraphControl..::PointEditHandler PointEditEvent
<BindableAttribute(True)> _
Public Event PointEditEvent As ZedGraphControl..::PointEditHandler
[BindableAttribute(true)]
public:
 event ZedGraphControl..::PointEditHandler^ PointEditEvent {
    void add (ZedGraphControl..::PointEditHandler^ value);
    void remove (ZedGraphControl..::PointEditHandler^ value);
}
Examples

To subscribe to this event, use the following in your Form_Load method:

CopyC#
zedGraphControl1.PointEditEvent +=
            new ZedGraphControl.PointEditHandler( MyPointEditHandler );

Add this method to your Form1.cs:

CopyC#
private string MyPointEditHandler( object sender, GraphPane pane, CurveItem curve, int iPt )
{
    PointPair pt = curve[iPt];
    return "This value is " + pt.Y.ToString("f2") + " gallons";
}


PointValueEvent Event

PointValueEvent Event
Namespaces ► ZedGraph ► ZedGraphControl ► PointValueEvent
Subscribe to this event to provide custom formatting for the tooltips
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public event ZedGraphControl.ZedGraphControl..::PointValueHandler PointValueEvent
<BindableAttribute(True)> _
Public Event PointValueEvent As ZedGraphControl..::PointValueHandler
[BindableAttribute(true)]
public:
 event ZedGraphControl..::PointValueHandler^ PointValueEvent {
    void add (ZedGraphControl..::PointValueHandler^ value);
    void remove (ZedGraphControl..::PointValueHandler^ value);
}
Examples

To subscribe to this event, use the following in your FormLoad method:

CopyC#
zedGraphControl1.PointValueEvent +=
            new ZedGraphControl.PointValueHandler( MyPointValueHandler );

Add this method to your Form1.cs:

CopyC#
private string MyPointValueHandler( object sender, GraphPane pane, CurveItem curve, int iPt )
{
#region
    PointPair pt = curve[iPt];
    return "This value is " + pt.Y.ToString("f2") + " gallons";
#endregion
}


PointValueFormat Property

PointValueFormat Property
Namespaces ► ZedGraph ► ZedGraphControl ► PointValueFormat
Gets or sets the format for displaying tooltip values. This format is passed to ToString(String).
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute("G")]
[BindableAttribute(true)]
public string PointValueFormat{ get; set;}
<DefaultValueAttribute("G")> _
<BindableAttribute(True)> _
Public Property PointValueFormat As String
[DefaultValueAttribute(L"G")]
[BindableAttribute(true)]
public:
property String^ PointValueFormat {
    String^ get ();
    void set (String^ value);
}
Remarks
Use the NumberFormatInfo type to determine the format strings.


PrintDocument Property

PrintDocument Property
Namespaces ► ZedGraph ► ZedGraphControl ► PrintDocument
Gets or sets the PrintDocument instance that is used for all of the context menu printing functions.
Declaration Syntax
C# Visual Basic Visual C++
public PrintDocument PrintDocument{ get; set;}
Public Property PrintDocument As PrintDocument
public:
property PrintDocument^ PrintDocument {
    PrintDocument^ get ();
    void set (PrintDocument^ value);
}


RestoreScale Method (primaryPane)

RestoreScale Method (primaryPane)
Namespaces ► ZedGraph ► ZedGraphControl ► RestoreScale(GraphPane)
Handler for the "Set Scale to Default" context menu item. Sets the scale ranging to full auto mode for all axes.
Declaration Syntax
C# Visual Basic Visual C++
public void RestoreScale(
    GraphPane primaryPane
)
Public Sub RestoreScale ( _
    primaryPane As GraphPane _
)
public:
void RestoreScale (
    GraphPane^ primaryPane
)
Parameters
primaryPane (GraphPane)
The GraphPane object which is to have the scale restored
Remarks
This method differs from the ZoomOutAll(GraphPane) method in that it sets the scales to full auto mode. The ZoomOutAll(GraphPane) method sets the scales to their initial setting prior to any user actions (which may or may not be full auto mode).


SaveAs Method

SaveAs Method
Namespaces ► ZedGraph ► ZedGraphControl ► SaveAs()()
Handler for the "Save Image As" context menu item. Copies the current image to the selected file in either the Emf (vector), or a variety of Bitmap formats.
Declaration Syntax
C# Visual Basic Visual C++
public void SaveAs()
Public Sub SaveAs
public:
void SaveAs ()
Remarks
Note that SaveAsBitmap()() and SaveAsEmf()() methods are provided which allow for Bitmap-only or Emf-only handling of the "Save As" context menu item.


SaveAsBitmap Method

SaveAsBitmap Method
Namespaces ► ZedGraph ► ZedGraphControl ► SaveAsBitmap()()
Handler for the "Save Image As" context menu item. Copies the current image to the selected Bitmap file.
Declaration Syntax
C# Visual Basic Visual C++
public void SaveAsBitmap()
Public Sub SaveAsBitmap
public:
void SaveAsBitmap ()
Remarks
Note that this handler saves as a bitmap only. The default handler is SaveAs()(), which allows for Bitmap or EMF formats


SaveAsEmf Method

SaveAsEmf Method
Namespaces ► ZedGraph ► ZedGraphControl ► SaveAsEmf()()
Handler for the "Save Image As" context menu item. Copies the current image to the selected Emf format file.
Declaration Syntax
C# Visual Basic Visual C++
public void SaveAsEmf()
Public Sub SaveAsEmf
public:
void SaveAsEmf ()
Remarks
Note that this handler saves as an Emf format only. The default handler is SaveAs()(), which allows for Bitmap or EMF formats.


SaveFileDialog Property

SaveFileDialog Property
Namespaces ► ZedGraph ► ZedGraphControl ► SaveFileDialog
Gets or sets the SaveFileDialog instance that will be used by the "Save As..." context menu item.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute(true)]
public SaveFileDialog SaveFileDialog{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute(True)> _
Public Property SaveFileDialog As SaveFileDialog
[BindableAttribute(true)]
[DefaultValueAttribute(true)]
public:
property SaveFileDialog^ SaveFileDialog {
    SaveFileDialog^ get ();
    void set (SaveFileDialog^ value);
}
Remarks
This provides the opportunity to modify the dialog, such as setting the InitialDirectory property.


ScrollDoneEvent Event

ScrollDoneEvent Event
Namespaces ► ZedGraph ► ZedGraphControl ► ScrollDoneEvent
Subscribe to this event to be notified when the GraphPane is scrolled by the user using the scrollbars.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public event ZedGraphControl.ZedGraphControl..::ScrollDoneHandler ScrollDoneEvent
<BindableAttribute(True)> _
Public Event ScrollDoneEvent As ZedGraphControl..::ScrollDoneHandler
[BindableAttribute(true)]
public:
 event ZedGraphControl..::ScrollDoneHandler^ ScrollDoneEvent {
    void add (ZedGraphControl..::ScrollDoneHandler^ value);
    void remove (ZedGraphControl..::ScrollDoneHandler^ value);
}


ScrollEvent Event

ScrollEvent Event
Namespaces ► ZedGraph ► ZedGraphControl ► ScrollEvent
Subscribe to this event to be notified when the GraphPane is scrolled by the user using the scrollbars.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public event ScrollEventHandler ScrollEvent
<BindableAttribute(True)> _
Public Event ScrollEvent As ScrollEventHandler
[BindableAttribute(true)]
public:
 event ScrollEventHandler^ ScrollEvent {
    void add (ScrollEventHandler^ value);
    void remove (ScrollEventHandler^ value);
}


ScrollGrace Property

ScrollGrace Property
Namespaces ► ZedGraph ► ZedGraphControl ► ScrollGrace
Set a "grace" value that leaves a buffer area around the data when IsAutoScrollRange is true.
Declaration Syntax
C# Visual Basic Visual C++
public double ScrollGrace{ get; set;}
Public Property ScrollGrace As Double
public:
property double ScrollGrace {
    double get ();
    void set (double value);
}
Remarks
This value represents a fraction of the total range around each axis. For example, if the axis ranges from 0 to 100, then a 0.05 value for ScrollGrace would set the scroll range to -5 to 105.


ScrollMaxX Property

ScrollMaxX Property
Namespaces ► ZedGraph ► ZedGraphControl ► ScrollMaxX
The maximum value for the X axis scroll range.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute()]
public double ScrollMaxX{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute()> _
Public Property ScrollMaxX As Double
[BindableAttribute(true)]
[DefaultValueAttribute()]
public:
property double ScrollMaxX {
    double get ();
    void set (double value);
}
Value
A double value indicating the maximum axis value
Remarks
Effectively, the maximum endpoint of the scroll range will cause the Max value to be set to ScrollMaxX. Note that this value applies only to the scroll bar settings. Axis panning (see IsEnableHPan) is not affected by this value. Note that this value can be overridden by IsAutoScrollRange and SetScrollRangeFromData()().


ScrollMaxY Property

ScrollMaxY Property
Namespaces ► ZedGraph ► ZedGraphControl ► ScrollMaxY
The maximum value for the Y axis scroll range.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute()]
public double ScrollMaxY{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute()> _
Public Property ScrollMaxY As Double
[BindableAttribute(true)]
[DefaultValueAttribute()]
public:
property double ScrollMaxY {
    double get ();
    void set (double value);
}
Value
A double value indicating the maximum axis value
Remarks
Effectively, the maximum endpoint of the scroll range will cause the Max value to be set to ScrollMaxY. Note that this value applies only to the scroll bar settings. Axis panning (see IsEnableVPan) is not affected by this value. Note that this value can be overridden by IsAutoScrollRange and SetScrollRangeFromData()(). Also note that this property is actually just an alias to the Max property of the first element of YScrollRangeList.
See Also
YScrollRangeList


ScrollMaxY2 Property

ScrollMaxY2 Property
Namespaces ► ZedGraph ► ZedGraphControl ► ScrollMaxY2
The maximum value for the Y2 axis scroll range.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute()]
[BindableAttribute(true)]
public double ScrollMaxY2{ get; set;}
<DefaultValueAttribute()> _
<BindableAttribute(True)> _
Public Property ScrollMaxY2 As Double
[DefaultValueAttribute()]
[BindableAttribute(true)]
public:
property double ScrollMaxY2 {
    double get ();
    void set (double value);
}
Value
A double value indicating the maximum axis value
Remarks
Effectively, the maximum endpoint of the scroll range will cause the Max value to be set to ScrollMaxY2. Note that this value applies only to the scroll bar settings. Axis panning (see IsEnableVPan) is not affected by this value. Note that this value can be overridden by IsAutoScrollRange and SetScrollRangeFromData()(). Also note that this property is actually just an alias to the Max property of the first element of Y2ScrollRangeList.
See Also
Y2ScrollRangeList


ScrollMinX Property

ScrollMinX Property
Namespaces ► ZedGraph ► ZedGraphControl ► ScrollMinX
The minimum value for the X axis scroll range.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute()]
public double ScrollMinX{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute()> _
Public Property ScrollMinX As Double
[BindableAttribute(true)]
[DefaultValueAttribute()]
public:
property double ScrollMinX {
    double get ();
    void set (double value);
}
Value
A double value indicating the minimum axis value
Remarks
Effectively, the minimum endpoint of the scroll range will cause the Min value to be set to ScrollMinX. Note that this value applies only to the scroll bar settings. Axis panning (see IsEnableHPan) is not affected by this value. Note that this value can be overridden by IsAutoScrollRange and SetScrollRangeFromData()().


ScrollMinY Property

ScrollMinY Property
Namespaces ► ZedGraph ► ZedGraphControl ► ScrollMinY
The minimum value for the Y axis scroll range.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute()]
public double ScrollMinY{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute()> _
Public Property ScrollMinY As Double
[BindableAttribute(true)]
[DefaultValueAttribute()]
public:
property double ScrollMinY {
    double get ();
    void set (double value);
}
Value
A double value indicating the minimum axis value
Remarks
Effectively, the minimum endpoint of the scroll range will cause the Min value to be set to ScrollMinY. Note that this value applies only to the scroll bar settings. Axis panning (see IsEnableVPan) is not affected by this value. Note that this value can be overridden by IsAutoScrollRange and SetScrollRangeFromData()(). Also note that this property is actually just an alias to the Min property of the first element of YScrollRangeList.
See Also
YScrollRangeList


ScrollMinY2 Property

ScrollMinY2 Property
Namespaces ► ZedGraph ► ZedGraphControl ► ScrollMinY2
The minimum value for the Y2 axis scroll range.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute()]
public double ScrollMinY2{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute()> _
Public Property ScrollMinY2 As Double
[BindableAttribute(true)]
[DefaultValueAttribute()]
public:
property double ScrollMinY2 {
    double get ();
    void set (double value);
}
Value
A double value indicating the minimum axis value
Remarks
Effectively, the minimum endpoint of the scroll range will cause the Min value to be set to ScrollMinY2. Note that this value applies only to the scroll bar settings. Axis panning (see IsEnableVPan) is not affected by this value. Note that this value can be overridden by IsAutoScrollRange and SetScrollRangeFromData()(). Also note that this property is actually just an alias to the Min property of the first element of Y2ScrollRangeList.
See Also
Y2ScrollRangeList


ScrollProgressEvent Event

ScrollProgressEvent Event
Namespaces ► ZedGraph ► ZedGraphControl ► ScrollProgressEvent
Subscribe to this event to be notified when the GraphPane is scrolled by the user using the scrollbars.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public event ZedGraphControl.ZedGraphControl..::ScrollProgressHandler ScrollProgressEvent
<BindableAttribute(True)> _
Public Event ScrollProgressEvent As ZedGraphControl..::ScrollProgressHandler
[BindableAttribute(true)]
public:
 event ZedGraphControl..::ScrollProgressHandler^ ScrollProgressEvent {
    void add (ZedGraphControl..::ScrollProgressHandler^ value);
    void remove (ZedGraphControl..::ScrollProgressHandler^ value);
}


SelectAppendModifierKeys Property

SelectAppendModifierKeys Property
Namespaces ► ZedGraph ► ZedGraphControl ► SelectAppendModifierKeys
Gets or sets a value that determines which Modifier keys will be used to append a CurveItem to the selection list.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute()]
[BindableAttribute(true)]
public Keys SelectAppendModifierKeys{ get;}
<DefaultValueAttribute()> _
<BindableAttribute(True)> _
Public ReadOnly Property SelectAppendModifierKeys As Keys
[DefaultValueAttribute()]
[BindableAttribute(true)]
public:
property Keys SelectAppendModifierKeys {
    Keys get ();
}


SelectButtons Property

SelectButtons Property
Namespaces ► ZedGraph ► ZedGraphControl ► SelectButtons
Gets or sets a value that determines which Mouse button will be used to select CurveItem's.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute()]
public MouseButtons SelectButtons{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute()> _
Public Property SelectButtons As MouseButtons
[BindableAttribute(true)]
[DefaultValueAttribute()]
public:
property MouseButtons SelectButtons {
    MouseButtons get ();
    void set (MouseButtons value);
}
Remarks
This setting only applies if IsEnableSelection is true.
See Also
SelectModifierKeys


Selection Property

Selection Property
Namespaces ► ZedGraph ► ZedGraphControl ► Selection
Readonly property that gets the list of selected CurveItems
Declaration Syntax
C# Visual Basic Visual C++
public Selection Selection{ get;}
Public ReadOnly Property Selection As Selection
public:
property Selection^ Selection {
    Selection^ get ();
}


SelectModifierKeys Property

SelectModifierKeys Property
Namespaces ► ZedGraph ► ZedGraphControl ► SelectModifierKeys
Gets or sets a value that determines which Modifier keys will be used to select CurveItem's.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute()]
public Keys SelectModifierKeys{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute()> _
Public Property SelectModifierKeys As Keys
[BindableAttribute(true)]
[DefaultValueAttribute()]
public:
property Keys SelectModifierKeys {
    Keys get ();
    void set (Keys value);
}
Remarks
This setting only applies if IsEnableSelection is true.
See Also
SelectButtons


SetScrollRangeFromData Method

SetScrollRangeFromData Method
Namespaces ► ZedGraph ► ZedGraphControl ► SetScrollRangeFromData()()
Sets the value of the scroll range properties (see ScrollMinX, ScrollMaxX, YScrollRangeList, and Y2ScrollRangeList based on the actual range of the data for each corresponding Axis.
Declaration Syntax
C# Visual Basic Visual C++
public void SetScrollRangeFromData()
Public Sub SetScrollRangeFromData
public:
void SetScrollRangeFromData ()
Remarks
This method is called automatically by AxisChange()() if IsAutoScrollRange is true. Note that this will not be called if you call AxisChange directly from the GraphPane. For example, zedGraphControl1.AxisChange() works properly, but zedGraphControl1.GraphPane.AxisChange() does not.


Y2ScrollRangeList Property

Y2ScrollRangeList Property
Namespaces ► ZedGraph ► ZedGraphControl ► Y2ScrollRangeList
Access the ScrollRangeList for the Y2 axes.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public ScrollRangeList Y2ScrollRangeList{ get;}
<BindableAttribute(True)> _
Public ReadOnly Property Y2ScrollRangeList As ScrollRangeList
[BindableAttribute(true)]
public:
property ScrollRangeList^ Y2ScrollRangeList {
    ScrollRangeList^ get ();
}
Remarks
This list maintains the user scale ranges for the scroll bars for each axis in the Y2AxisList. Each ordinal location in Y2ScrollRangeList corresponds to an equivalent ordinal location in Y2AxisList.
See Also
ScrollMinY2
ScrollMaxY2


YScrollRangeList Property

YScrollRangeList Property
Namespaces ► ZedGraph ► ZedGraphControl ► YScrollRangeList
Access the ScrollRangeList for the Y axes.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public ScrollRangeList YScrollRangeList{ get;}
<BindableAttribute(True)> _
Public ReadOnly Property YScrollRangeList As ScrollRangeList
[BindableAttribute(true)]
public:
property ScrollRangeList^ YScrollRangeList {
    ScrollRangeList^ get ();
}
Remarks
This list maintains the user scale ranges for the scroll bars for each axis in the YAxisList. Each ordinal location in YScrollRangeList corresponds to an equivalent ordinal location in YAxisList.
See Also
ScrollMinY
ScrollMaxY


ZoomButtons Property

ZoomButtons Property
Namespaces ► ZedGraph ► ZedGraphControl ► ZoomButtons
Gets or sets a value that determines which mouse button will be used as a primary option to trigger a zoom event.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute()]
public MouseButtons ZoomButtons{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute()> _
Public Property ZoomButtons As MouseButtons
[BindableAttribute(true)]
[DefaultValueAttribute()]
public:
property MouseButtons ZoomButtons {
    MouseButtons get ();
    void set (MouseButtons value);
}
Remarks
This value is combined with ZoomModifierKeys to determine the actual zoom combination. A secondary zoom button/key combination option is available via ZoomButtons2 and ZoomModifierKeys2. To not use this button/key combination, set the value of ZoomButtons to None.


ZoomButtons2 Property

ZoomButtons2 Property
Namespaces ► ZedGraph ► ZedGraphControl ► ZoomButtons2
Gets or sets a value that determines which mouse button will be used as the secondary option to trigger a zoom event.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute()]
public MouseButtons ZoomButtons2{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute()> _
Public Property ZoomButtons2 As MouseButtons
[BindableAttribute(true)]
[DefaultValueAttribute()]
public:
property MouseButtons ZoomButtons2 {
    MouseButtons get ();
    void set (MouseButtons value);
}
Remarks
This value is combined with ZoomModifierKeys2 to determine the actual zoom combination. The primary zoom button/key combination option is available via ZoomButtons and ZoomModifierKeys. To not use this button/key combination, set the value of ZoomButtons2 to None.


ZoomEvent Event

ZoomEvent Event
Namespaces ► ZedGraph ► ZedGraphControl ► ZoomEvent
Subscribe to this event to be notified when the GraphPane is zoomed or panned by the user, either via a mouse drag operation or by the context menu commands.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public event ZedGraphControl.ZedGraphControl..::ZoomEventHandler ZoomEvent
<BindableAttribute(True)> _
Public Event ZoomEvent As ZedGraphControl..::ZoomEventHandler
[BindableAttribute(true)]
public:
 event ZedGraphControl..::ZoomEventHandler^ ZoomEvent {
    void add (ZedGraphControl..::ZoomEventHandler^ value);
    void remove (ZedGraphControl..::ZoomEventHandler^ value);
}


ZoomModifierKeys Property

ZoomModifierKeys Property
Namespaces ► ZedGraph ► ZedGraphControl ► ZoomModifierKeys
Gets or sets a value that determines which modifier keys will be used as a primary option to trigger a zoom event.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute()]
public Keys ZoomModifierKeys{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute()> _
Public Property ZoomModifierKeys As Keys
[BindableAttribute(true)]
[DefaultValueAttribute()]
public:
property Keys ZoomModifierKeys {
    Keys get ();
    void set (Keys value);
}
Remarks
This value is combined with ZoomButtons to determine the actual zoom combination. A secondary zoom button/key combination option is available via ZoomButtons2 and ZoomModifierKeys2. To not use this button/key combination, set the value of ZoomButtons to None.


ZoomModifierKeys2 Property

ZoomModifierKeys2 Property
Namespaces ► ZedGraph ► ZedGraphControl ► ZoomModifierKeys2
Gets or sets a value that determines which modifier keys will be used as a secondary option to trigger a zoom event.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute()]
[BindableAttribute(true)]
public Keys ZoomModifierKeys2{ get; set;}
<DefaultValueAttribute()> _
<BindableAttribute(True)> _
Public Property ZoomModifierKeys2 As Keys
[DefaultValueAttribute()]
[BindableAttribute(true)]
public:
property Keys ZoomModifierKeys2 {
    Keys get ();
    void set (Keys value);
}
Remarks
This value is combined with ZoomButtons2 to determine the actual zoom combination. A primary zoom button/key combination option is available via ZoomButtons and ZoomModifierKeys. To not use this button/key combination, set the value of ZoomButtons2 to None.


ZoomOut Method (primaryPane)

ZoomOut Method (primaryPane)
Namespaces ► ZedGraph ► ZedGraphControl ► ZoomOut(GraphPane)
Handler for the "UnZoom/UnPan" context menu item. Restores the scale ranges to the values before the last zoom, pan, or scroll operation.
Declaration Syntax
C# Visual Basic Visual C++
public void ZoomOut(
    GraphPane primaryPane
)
Public Sub ZoomOut ( _
    primaryPane As GraphPane _
)
public:
void ZoomOut (
    GraphPane^ primaryPane
)
Parameters
primaryPane (GraphPane)
The primary GraphPane object which is to be zoomed out
Remarks
Triggers a ZoomEvent for any type of undo (including pan, scroll, zoom, and wheelzoom). This method will affect all the GraphPane objects in the MasterPane if IsSynchronizeXAxes or IsSynchronizeYAxes is true.


ZoomOutAll Method (primaryPane)

ZoomOutAll Method (primaryPane)
Namespaces ► ZedGraph ► ZedGraphControl ► ZoomOutAll(GraphPane)
Handler for the "Undo All Zoom/Pan" context menu item. Restores the scale ranges to the values before all zoom and pan operations
Declaration Syntax
C# Visual Basic Visual C++
public void ZoomOutAll(
    GraphPane primaryPane
)
Public Sub ZoomOutAll ( _
    primaryPane As GraphPane _
)
public:
void ZoomOutAll (
    GraphPane^ primaryPane
)
Parameters
primaryPane (GraphPane)
The GraphPane object which is to be zoomed out
Remarks
This method differs from the RestoreScale(GraphPane) method in that it sets the scales to their initial setting prior to any user actions. The RestoreScale(GraphPane) method sets the scales to full auto mode (regardless of what the initial setting may have been).


ZoomPane Method (pane, zoomFraction, centerPt, isZoomOnCenter)

ZoomPane Method (pane, zoomFraction, centerPt, isZoomOnCenter)
Namespaces ► ZedGraph ► ZedGraphControl ► ZoomPane(GraphPane, Double, PointF, Boolean)
Zoom a specified pane in or out according to the specified zoom fraction.
Declaration Syntax
C# Visual Basic Visual C++
public void ZoomPane(
    GraphPane pane,
    double zoomFraction,
    PointF centerPt,
    bool isZoomOnCenter
)
Public Sub ZoomPane ( _
    pane As GraphPane, _
    zoomFraction As Double, _
    centerPt As PointF, _
    isZoomOnCenter As Boolean _
)
public:
void ZoomPane (
    GraphPane^ pane,
    double zoomFraction,
    PointF centerPt,
    bool isZoomOnCenter
)
Parameters
pane (GraphPane)
The GraphPane instance to be zoomed.
zoomFraction (Double)
The fraction by which to zoom, less than 1 to zoom in, greater than 1 to zoom out. For example, 0.9 will zoom in such that the scale is 90% of what it was originally.
centerPt (PointF)
The screen position about which the zoom will be centered. This value is only used if is true.
isZoomOnCenter (Boolean)
true to cause the zoom to be centered on the point , false to center on the Rect.
Remarks
The zoom will occur on the XAxis, YAxis, and Y2Axis only if the corresponding flag, IsEnableHZoom or IsEnableVZoom, is true. Note that if there are multiple Y or Y2 axes, all of them will be zoomed.


ZoomStepFraction Property

ZoomStepFraction Property
Namespaces ► ZedGraph ► ZedGraphControl ► ZoomStepFraction
Gets or sets the step size fraction for zooming with the mouse wheel. A value of 0.1 will result in a 10% zoom step for each mouse wheel movement.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute()]
public double ZoomStepFraction{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute()> _
Public Property ZoomStepFraction As Double
[BindableAttribute(true)]
[DefaultValueAttribute()]
public:
property double ZoomStepFraction {
    double get ();
    void set (double value);
}


ZedGraphControl.ContextMenuBuilderEventHandler Delegate

ZedGraphControl..::ContextMenuBuilderEventHandler Delegate
Namespaces ► ZedGraph ► ZedGraphControl ► ZedGraphControl..::ContextMenuBuilderEventHandler
A delegate that allows subscribing methods to append or modify the context menu.
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ContextMenuBuilderEventHandler(
    ZedGraphControl sender,
    ContextMenuStrip menuStrip,
    Point mousePt,
    ZedGraphControl.ZedGraphControl..::ContextMenuObjectState objState
)
Public Delegate Sub ContextMenuBuilderEventHandler ( _
    sender As ZedGraphControl, _
    menuStrip As ContextMenuStrip, _
    mousePt As Point, _
    objState As ZedGraphControl..::ContextMenuObjectState _
)
public delegate void ContextMenuBuilderEventHandler (
    ZedGraphControl^ sender,
    ContextMenuStrip^ menuStrip,
    Point mousePt,
    ZedGraphControl..::ContextMenuObjectState objState
)
Parameters
sender (ZedGraphControl)
The source ZedGraphControl object
menuStrip (ContextMenuStrip)
A reference to the ContextMenuStrip object that contains the context menu.
mousePt (Point)
The point at which the mouse was clicked
objState (ZedGraphControl..::ContextMenuObjectState)
The current context menu state
See Also
ContextMenuBuilder


ZedGraphControl.ContextMenuObjectState Enumeration

ZedGraphControl..::ContextMenuObjectState Enumeration
Namespaces ► ZedGraph ► ZedGraphControl ► ZedGraphControl..::ContextMenuObjectState
Public enumeration that specifies the type of object present at the Context Menu's mouse location
Declaration Syntax
C# Visual Basic Visual C++
public enum ContextMenuObjectState
Public Enumeration ContextMenuObjectState
public enum class ContextMenuObjectState
Members
Member | Description
InactiveSelection | The object is an Inactive Curve Item at the Context Menu's mouse position
ActiveSelection | The object is an active Curve Item at the Context Menu's mouse position
Background | There is no selectable object present at the Context Menu's mouse position


ZedGraphControl.LinkEventHandler Delegate

ZedGraphControl..::LinkEventHandler Delegate
Namespaces ► ZedGraph ► ZedGraphControl ► ZedGraphControl..::LinkEventHandler
A delegate that allows notification of clicks on ZedGraph objects that have active links enabled
Declaration Syntax
C# Visual Basic Visual C++
public delegate bool LinkEventHandler(
    ZedGraphControl sender,
    GraphPane pane,
    Object source,
    Link link,
    int index
)
Public Delegate Function LinkEventHandler ( _
    sender As ZedGraphControl, _
    pane As GraphPane, _
    source As Object, _
    link As Link, _
    index As Integer _
) As Boolean
public delegate bool LinkEventHandler (
    ZedGraphControl^ sender,
    GraphPane^ pane,
    Object^ source,
    Link^ link,
    int index
)
Parameters
sender (ZedGraphControl)
The source ZedGraphControl object
pane (GraphPane)
The source GraphPane in which the click occurred.
source (Object)
The source object which was clicked. This is typically a type of CurveItem if a curve point was clicked, or a type of GraphObj if a graph object was clicked.
link (Link)
The Link object, belonging to source, that contains the link information
index (Int32)
An index value, typically used if a CurveItem was clicked, indicating the ordinal value of the actual point that was clicked.
Return Value
Return true if you have handled the LinkEvent entirely, and you do not want the ZedGraphControl to do any further action. Return false if ZedGraph should go ahead and process the LinkEvent.


ZedGraphControl.PointEditHandler Delegate

ZedGraphControl..::PointEditHandler Delegate
Namespaces ► ZedGraph ► ZedGraphControl ► ZedGraphControl..::PointEditHandler
A delegate that receives notification after a point-edit operation is completed.
Declaration Syntax
C# Visual Basic Visual C++
public delegate string PointEditHandler(
    ZedGraphControl sender,
    GraphPane pane,
    CurveItem curve,
    int iPt
)
Public Delegate Function PointEditHandler ( _
    sender As ZedGraphControl, _
    pane As GraphPane, _
    curve As CurveItem, _
    iPt As Integer _
) As String
public delegate String^ PointEditHandler (
    ZedGraphControl^ sender,
    GraphPane^ pane,
    CurveItem^ curve,
    int iPt
)
Parameters
sender (ZedGraphControl)
The source ZedGraphControl object
pane (GraphPane)
The GraphPane object that contains the point that has been edited
curve (CurveItem)
The CurveItem object that contains the point that has been edited
iPt (Int32)
The integer index of the edited PointPair within the IPointList of the selected CurveItem
See Also
PointValueEvent


ZedGraphControl.PointValueHandler Delegate

ZedGraphControl..::PointValueHandler Delegate
Namespaces ► ZedGraph ► ZedGraphControl ► ZedGraphControl..::PointValueHandler
A delegate that allows custom formatting of the point value tooltips
Declaration Syntax
C# Visual Basic Visual C++
public delegate string PointValueHandler(
    ZedGraphControl sender,
    GraphPane pane,
    CurveItem curve,
    int iPt
)
Public Delegate Function PointValueHandler ( _
    sender As ZedGraphControl, _
    pane As GraphPane, _
    curve As CurveItem, _
    iPt As Integer _
) As String
public delegate String^ PointValueHandler (
    ZedGraphControl^ sender,
    GraphPane^ pane,
    CurveItem^ curve,
    int iPt
)
Parameters
sender (ZedGraphControl)
The source ZedGraphControl object
pane (GraphPane)
The GraphPane object that contains the point value of interest
curve (CurveItem)
The CurveItem object that contains the point value of interest
iPt (Int32)
The integer index of the selected PointPair within the IPointList of the selected CurveItem
See Also
PointValueEvent


ZedGraphControl.ScrollDoneHandler Delegate

ZedGraphControl..::ScrollDoneHandler Delegate
Namespaces ► ZedGraph ► ZedGraphControl ► ZedGraphControl..::ScrollDoneHandler
A delegate that allows notification of scroll events.
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ScrollDoneHandler(
    ZedGraphControl sender,
    ScrollBar scrollBar,
    ZoomState oldState,
    ZoomState newState
)
Public Delegate Sub ScrollDoneHandler ( _
    sender As ZedGraphControl, _
    scrollBar As ScrollBar, _
    oldState As ZoomState, _
    newState As ZoomState _
)
public delegate void ScrollDoneHandler (
    ZedGraphControl^ sender,
    ScrollBar^ scrollBar,
    ZoomState^ oldState,
    ZoomState^ newState
)
Parameters
sender (ZedGraphControl)
The source ZedGraphControl object
scrollBar (ScrollBar)
The source ScrollBar object
oldState (ZoomState)
A ZoomState object that corresponds to the state of the GraphPane before the scroll event.
newState (ZoomState)
A ZoomState object that corresponds to the state of the GraphPane after the scroll event
See Also
ZoomEvent


ZedGraphControl.ScrollProgressHandler Delegate

ZedGraphControl..::ScrollProgressHandler Delegate
Namespaces ► ZedGraph ► ZedGraphControl ► ZedGraphControl..::ScrollProgressHandler
A delegate that allows notification of scroll events.
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ScrollProgressHandler(
    ZedGraphControl sender,
    ScrollBar scrollBar,
    ZoomState oldState,
    ZoomState newState
)
Public Delegate Sub ScrollProgressHandler ( _
    sender As ZedGraphControl, _
    scrollBar As ScrollBar, _
    oldState As ZoomState, _
    newState As ZoomState _
)
public delegate void ScrollProgressHandler (
    ZedGraphControl^ sender,
    ScrollBar^ scrollBar,
    ZoomState^ oldState,
    ZoomState^ newState
)
Parameters
sender (ZedGraphControl)
The source ZedGraphControl object
scrollBar (ScrollBar)
The source ScrollBar object
oldState (ZoomState)
A ZoomState object that corresponds to the state of the GraphPane before the scroll event.
newState (ZoomState)
A ZoomState object that corresponds to the state of the GraphPane after the scroll event
See Also
ZoomEvent


ZedGraphControl.ZedMouseEventHandler Delegate

ZedGraphControl..::ZedMouseEventHandler Delegate
Namespaces ► ZedGraph ► ZedGraphControl ► ZedGraphControl..::ZedMouseEventHandler
A delegate that allows notification of mouse events on Graph objects.
Declaration Syntax
C# Visual Basic Visual C++
public delegate bool ZedMouseEventHandler(
    ZedGraphControl sender,
    MouseEventArgs e
)
Public Delegate Function ZedMouseEventHandler ( _
    sender As ZedGraphControl, _
    e As MouseEventArgs _
) As Boolean
public delegate bool ZedMouseEventHandler (
    ZedGraphControl^ sender,
    MouseEventArgs^ e
)
Parameters
sender (ZedGraphControl)
The source ZedGraphControl object
e (MouseEventArgs)
A MouseEventArgs corresponding to this event
Return Value
Return true if you have handled the mouse event entirely, and you do not want the ZedGraphControl to do any further action (e.g., starting a zoom operation). Return false if ZedGraph should go ahead and process the mouse event.
See Also
MouseDownEvent


ZedGraphControl.ZoomEventHandler Delegate

ZedGraphControl..::ZoomEventHandler Delegate
Namespaces ► ZedGraph ► ZedGraphControl ► ZedGraphControl..::ZoomEventHandler
A delegate that allows notification of zoom and pan events.
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ZoomEventHandler(
    ZedGraphControl sender,
    ZoomState oldState,
    ZoomState newState
)
Public Delegate Sub ZoomEventHandler ( _
    sender As ZedGraphControl, _
    oldState As ZoomState, _
    newState As ZoomState _
)
public delegate void ZoomEventHandler (
    ZedGraphControl^ sender,
    ZoomState^ oldState,
    ZoomState^ newState
)
Parameters
sender (ZedGraphControl)
The source ZedGraphControl object
oldState (ZoomState)
A ZoomState object that corresponds to the state of the GraphPane before the zoom or pan event.
newState (ZoomState)
A ZoomState object that corresponds to the state of the GraphPane after the zoom or pan event
See Also
ZoomEvent


ZedGraphException Class

ZedGraphException Class
Namespaces ► ZedGraph ► ZedGraphException
An exception thrown by ZedGraph. A child class of ApplicationException.
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphException : ApplicationException
Public Class ZedGraphException _
    Inherits ApplicationException
public ref class ZedGraphException : public ApplicationException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphExceptionZedGraphExceptionNew(String, Exception) | Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.
 | ZedGraphExceptionZedGraphExceptionNew(String) | Initializes a new instance of the Exception class with a specified error message.
 | ZedGraphExceptionZedGraphExceptionNew()() | Initializes a new instance of the Exception class.
 | Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | ZedGraphException


ZedGraphException Constructor

ZedGraphException Constructor
Namespaces ► ZedGraph ► ZedGraphException ► ZedGraphExceptionZedGraphExceptionNew()()
Members
Icon | Member | Description
 | ZedGraphExceptionZedGraphExceptionNew(String, Exception) | Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.
 | ZedGraphExceptionZedGraphExceptionNew(String) | Initializes a new instance of the Exception class with a specified error message.
 | ZedGraphExceptionZedGraphExceptionNew()() | Initializes a new instance of the Exception class.


ZedGraphException Constructor

ZedGraphException Constructor
Namespaces ► ZedGraph ► ZedGraphException ► ZedGraphExceptionZedGraphExceptionNew()()
Initializes a new instance of the Exception class.
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphException()
Public Sub New
public:
ZedGraphException ()


ZedGraphException Constructor (message)

ZedGraphException Constructor (message)
Namespaces ► ZedGraph ► ZedGraphException ► ZedGraphExceptionZedGraphExceptionNew(String)
Initializes a new instance of the Exception class with a specified error message.
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphException(
    string message
)
Public Sub New ( _
    message As String _
)
public:
ZedGraphException (
    String^ message
)
Parameters
message (String)
The error message that explains the reason for the exception.


ZedGraphException Constructor (message, innerException)

ZedGraphException Constructor (message, innerException)
Namespaces ► ZedGraph ► ZedGraphException ► ZedGraphExceptionZedGraphExceptionNew(String, Exception)
Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphException(
    string message,
    Exception innerException
)
Public Sub New ( _
    message As String, _
    innerException As Exception _
)
public:
ZedGraphException (
    String^ message,
    Exception^ innerException
)
Parameters
message (String)
The error message that explains the reason for the exception.
innerException (Exception)
The exception that is the cause of the current exception. If the innerException parameter is not a null reference, the current exception is raised in a catch block that handles the inner exception.


ZoomState Class

ZoomState Class
Namespaces ► ZedGraph ► ZoomState
A class that captures all the scale range settings for a GraphPane.
Declaration Syntax
C# Visual Basic Visual C++
public class ZoomState : ICloneable
Public Class ZoomState _
    Implements ICloneable
public ref class ZoomState : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZoomStateZoomStateNew(GraphPane, ZoomState..::StateType) | Construct a ZoomState object from the scale ranges settings contained in the specified GraphPane.
 | ZoomStateZoomStateNew(ZoomState) | The Copy Constructor
 | ApplyState(GraphPane) | Copy the properties from this ZoomState out to the specified GraphPane.
 | Clone()() | Typesafe, deep-copy clone method.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsChanged(GraphPane) | Determine if the state contained in this ZoomState object is different from the state of the specified GraphPane.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type | Gets a ZoomState..::StateType value indicating the type of action (zoom or pan) saved by this ZoomState.
 | TypeString | Gets a string representing the type of adjustment that was made when this scale state was saved.
Remarks
This class is used to store scale ranges in order to allow zooming out to prior scale range states. ZoomState objects are maintained in the ZoomStateStack collection. The ZoomState object holds a ScaleState object for each of the three axes; the XAxis, the YAxis, and the Y2Axis.
Inheritance Hierarchy
Object
ZoomState


ZoomState Constructor

ZoomState Constructor
Namespaces ► ZedGraph ► ZoomState ► ZoomStateZoomStateNew()()
Members
Icon | Member | Description
 | ZoomStateZoomStateNew(GraphPane, ZoomState..::StateType) | Construct a ZoomState object from the scale ranges settings contained in the specified GraphPane.
 | ZoomStateZoomStateNew(ZoomState) | The Copy Constructor


ZoomState Constructor (pane, type)

ZoomState Constructor (pane, type)
Namespaces ► ZedGraph ► ZoomState ► ZoomStateZoomStateNew(GraphPane, ZoomState..::StateType)
Construct a ZoomState object from the scale ranges settings contained in the specified GraphPane.
Declaration Syntax
C# Visual Basic Visual C++
public ZoomState(
    GraphPane pane,
    ZoomState.ZoomState..::StateType type
)
Public Sub New ( _
    pane As GraphPane, _
    type As ZoomState..::StateType _
)
public:
ZoomState (
    GraphPane^ pane,
    ZoomState..::StateType type
)
Parameters
pane (GraphPane)
The GraphPane from which to obtain the scale range values.
type (ZoomState..::StateType)
A ZoomState..::StateType enumeration that indicates whether this saved state is from a pan or zoom.


ZoomState Constructor (rhs)

ZoomState Constructor (rhs)
Namespaces ► ZedGraph ► ZoomState ► ZoomStateZoomStateNew(ZoomState)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZoomState(
    ZoomState rhs
)
Public Sub New ( _
    rhs As ZoomState _
)
public:
ZoomState (
    ZoomState^ rhs
)
Parameters
rhs (ZoomState)
The ZoomState object from which to copy


ApplyState Method (pane)

ApplyState Method (pane)
Namespaces ► ZedGraph ► ZoomState ► ApplyState(GraphPane)
Copy the properties from this ZoomState out to the specified GraphPane.
Declaration Syntax
C# Visual Basic Visual C++
public void ApplyState(
    GraphPane pane
)
Public Sub ApplyState ( _
    pane As GraphPane _
)
public:
void ApplyState (
    GraphPane^ pane
)
Parameters
pane (GraphPane)
The GraphPane to which the scale range properties should be copied.


Clone Method

Clone Method
Namespaces ► ZedGraph ► ZoomState ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public ZoomState Clone()
Public Function Clone As ZoomState
public:
ZoomState^ Clone ()
Return Value
A new, independent copy of this class


IsChanged Method (pane)

IsChanged Method (pane)
Namespaces ► ZedGraph ► ZoomState ► IsChanged(GraphPane)
Determine if the state contained in this ZoomState object is different from the state of the specified GraphPane.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsChanged(
    GraphPane pane
)
Public Function IsChanged ( _
    pane As GraphPane _
) As Boolean
public:
bool IsChanged (
    GraphPane^ pane
)
Parameters
pane (GraphPane)
The GraphPane object with which to compare states.
Return Value
true if the states are different, false otherwise


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► ZoomState ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Type Property

Type Property
Namespaces ► ZedGraph ► ZoomState ► Type
Gets a ZoomState..::StateType value indicating the type of action (zoom or pan) saved by this ZoomState.
Declaration Syntax
C# Visual Basic Visual C++
public ZoomState.ZoomState..::StateType Type{ get;}
Public ReadOnly Property Type As ZoomState..::StateType
public:
property ZoomState..::StateType Type {
    ZoomState..::StateType get ();
}


TypeString Property

TypeString Property
Namespaces ► ZedGraph ► ZoomState ► TypeString
Gets a string representing the type of adjustment that was made when this scale state was saved.
Declaration Syntax
C# Visual Basic Visual C++
public string TypeString{ get;}
Public ReadOnly Property TypeString As String
public:
property String^ TypeString {
    String^ get ();
}
Value
A string representation for the state change type; typically "Pan", "Zoom", or "Scroll".


ZoomState.StateType Enumeration

ZoomState..::StateType Enumeration
Namespaces ► ZedGraph ► ZoomState ► ZoomState..::StateType
An enumeration that describes whether a given state is the result of a Pan or Zoom operation.
Declaration Syntax
C# Visual Basic Visual C++
public enum StateType
Public Enumeration StateType
public enum class StateType
Members
Member | Description
Zoom | Indicates the ZoomState object is from a Zoom operation
WheelZoom | Indicates the ZoomState object is from a Wheel Zoom operation
Pan | Indicates the ZoomState object is from a Pan operation
Scroll | Indicates the ZoomState object is from a Scroll operation


ZoomStateStack Class

ZoomStateStack Class
Namespaces ► ZedGraph ► ZoomStateStack
A LIFO stack of prior ZoomState objects, used to allow zooming out to prior states (of scale range settings).
Declaration Syntax
C# Visual Basic Visual C++
public class ZoomStateStack : List<ZoomState>, ICloneable
Public Class ZoomStateStack _
    Inherits List(Of ZoomState) _
    Implements ICloneable
public ref class ZoomStateStack : public List<ZoomState^>,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZoomStateStackZoomStateStackNew()() | Default Constructor
 | ZoomStateStackZoomStateStackNew(ZoomStateStack) | The Copy Constructor
 | Add(T) | Adds an object to the end of the List<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | AddRange(IEnumerable<(Of <T>)>) | Adds the elements of the specified collection to the end of the List<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | AsReadOnly()() | Returns a read-only IList<(Of <T>)> wrapper for the current collection. (Inherited from List <(Of < ZoomState >)>.)
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < ZoomState >)>.)
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of < ZoomState >)>.)
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of < ZoomState >)>.)
 | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of < ZoomState >)>.)
 | Clear()() | Removes all elements from the List<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | Clone()() | Typesafe, deep-copy clone method.
 | Contains(T) | Determines whether an element is in the List<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | ConvertAll<(Of <TOutput>)>(Converter<(Of <T, TOutput>)>) | Converts the elements in the current List<(Of <T>)> to another type, and returns a list containing the converted elements. (Inherited from List <(Of < ZoomState >)>.)
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of < ZoomState >)>.)
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < ZoomState >)>.)
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of < ZoomState >)>.)
 | Count | Gets the number of elements actually contained in the List<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <T>)>) | Determines whether the List<(Of <T>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < ZoomState >)>.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | FindAll(Predicate<(Of <T>)>) | Retrieves the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < ZoomState >)>.)
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < ZoomState >)>.)
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < ZoomState >)>.)
 | FindLast(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < ZoomState >)>.)
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < ZoomState >)>.)
 | ForEach(Action<(Of <T>)>) | Performs the specified action on each element of the List<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | GetEnumerator()() | Returns an enumerator that iterates through the List<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element. (Inherited from List <(Of < ZoomState >)>.)
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of < ZoomState >)>.)
 | Insert(Int32, T) | Inserts an element into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < ZoomState >)>.)
 | InsertRange(Int32, IEnumerable<(Of <T>)>) | Inserts the elements of a collection into the List<(Of <T>)> at the specified index. (Inherited from List <(Of < ZoomState >)>.)
 | IsEmpty | Public readonly property that indicates if the stack is empty
 | Item[([Int32])] | Gets or sets the element at the specified index. (Inherited from List <(Of < ZoomState >)>.)
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index. (Inherited from List <(Of < ZoomState >)>.)
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of < ZoomState >)>.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Pop(GraphPane) | Pop a ZoomState entry from the top of the stack, and apply the properties to the specified GraphPane object.
 | PopAll(GraphPane) | Pop the ZoomState entry from the bottom of the stack, and apply the properties to the specified GraphPane object. Clear the stack completely.
 | Push(GraphPane, ZoomState..::StateType) | Add the scale range information from the specified GraphPane object as a new ZoomState entry on the stack.
 | Push(ZoomState) | Add the scale range information from the specified ZoomState object as a new ZoomState entry on the stack.
 | Remove(T) | Removes the first occurrence of a specific object from the List<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | RemoveAll(Predicate<(Of <T>)>) | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of < ZoomState >)>.)
 | RemoveAt(Int32) | Removes the element at the specified index of the List<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | RemoveRange(Int32, Int32) | Removes a range of elements from the List<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of < ZoomState >)>.)
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer. (Inherited from List <(Of < ZoomState >)>.)
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < ZoomState >)>.)
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer. (Inherited from List <(Of < ZoomState >)>.)
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>. (Inherited from List <(Of < ZoomState >)>.)
 | ICollection<(Of <T>)>..::IsReadOnly | (Inherited from List <(Of < ZoomState >)>.)
 | IEnumerable<(Of <T>)>..::GetEnumerator()() | (Inherited from List <(Of < ZoomState >)>.)
 | ICollection..::CopyTo(Array, Int32) | (Inherited from List <(Of < ZoomState >)>.)
 | ICollection..::IsSynchronized | (Inherited from List <(Of < ZoomState >)>.)
 | ICollection..::SyncRoot | (Inherited from List <(Of < ZoomState >)>.)
 | IEnumerable..::GetEnumerator()() | (Inherited from List <(Of < ZoomState >)>.)
 | IList..::Add(Object) | (Inherited from List <(Of < ZoomState >)>.)
 | IList..::Contains(Object) | (Inherited from List <(Of < ZoomState >)>.)
 | IList..::IndexOf(Object) | (Inherited from List <(Of < ZoomState >)>.)
 | IList..::Insert(Int32, Object) | (Inherited from List <(Of < ZoomState >)>.)
 | IList..::IsFixedSize | (Inherited from List <(Of < ZoomState >)>.)
 | IList..::IsReadOnly | (Inherited from List <(Of < ZoomState >)>.)
 | IList..::Item[([Int32])] | (Inherited from List <(Of < ZoomState >)>.)
 | IList..::Remove(Object) | (Inherited from List <(Of < ZoomState >)>.)
 | ICloneable..::Clone()() | Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
 | ToArray()() | Copies the elements of the List<(Of <T>)> to a new array. (Inherited from List <(Of < ZoomState >)>.)
 | Top | Gets a reference to the ZoomState object at the top of the stack, without actually removing it from the stack.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrimExcess()() | Sets the capacity to the actual number of elements in the List<(Of <T>)>, if that number is less than a threshold value. (Inherited from List <(Of < ZoomState >)>.)
 | TrueForAll(Predicate<(Of <T>)>) | Determines whether every element in the List<(Of <T>)> matches the conditions defined by the specified predicate. (Inherited from List <(Of < ZoomState >)>.)
Inheritance Hierarchy
Object
 | List <(Of < ZoomState >)>
 |  | ZoomStateStack


ZoomStateStack Constructor

ZoomStateStack Constructor
Namespaces ► ZedGraph ► ZoomStateStack ► ZoomStateStackZoomStateStackNew()()
Members
Icon | Member | Description
 | ZoomStateStackZoomStateStackNew()() | Default Constructor
 | ZoomStateStackZoomStateStackNew(ZoomStateStack) | The Copy Constructor


ZoomStateStack Constructor

ZoomStateStack Constructor
Namespaces ► ZedGraph ► ZoomStateStack ► ZoomStateStackZoomStateStackNew()()
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZoomStateStack()
Public Sub New
public:
ZoomStateStack ()


ZoomStateStack Constructor (rhs)

ZoomStateStack Constructor (rhs)
Namespaces ► ZedGraph ► ZoomStateStack ► ZoomStateStackZoomStateStackNew(ZoomStateStack)
The Copy Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZoomStateStack(
    ZoomStateStack rhs
)
Public Sub New ( _
    rhs As ZoomStateStack _
)
public:
ZoomStateStack (
    ZoomStateStack^ rhs
)
Parameters
rhs (ZoomStateStack)
The ZoomStateStack object from which to copy


Clone Method

Clone Method
Namespaces ► ZedGraph ► ZoomStateStack ► Clone()()
Typesafe, deep-copy clone method.
Declaration Syntax
C# Visual Basic Visual C++
public ZoomStateStack Clone()
Public Function Clone As ZoomStateStack
public:
ZoomStateStack^ Clone ()
Return Value
A new, independent copy of this class


IsEmpty Property

IsEmpty Property
Namespaces ► ZedGraph ► ZoomStateStack ► IsEmpty
Public readonly property that indicates if the stack is empty
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEmpty{ get;}
Public ReadOnly Property IsEmpty As Boolean
public:
property bool IsEmpty {
    bool get ();
}
Value
true for an empty stack, false otherwise


Pop Method (pane)

Pop Method (pane)
Namespaces ► ZedGraph ► ZoomStateStack ► Pop(GraphPane)
Pop a ZoomState entry from the top of the stack, and apply the properties to the specified GraphPane object.
Declaration Syntax
C# Visual Basic Visual C++
public ZoomState Pop(
    GraphPane pane
)
Public Function Pop ( _
    pane As GraphPane _
) As ZoomState
public:
ZoomState^ Pop (
    GraphPane^ pane
)
Parameters
pane (GraphPane)
The GraphPane object to which the scale range information should be copied.
Return Value
The ZoomState object that was "popped" from the stack and applied to the specified GraphPane. null if no ZoomState was available (the stack was empty).


PopAll Method (pane)

PopAll Method (pane)
Namespaces ► ZedGraph ► ZoomStateStack ► PopAll(GraphPane)
Pop the ZoomState entry from the bottom of the stack, and apply the properties to the specified GraphPane object. Clear the stack completely.
Declaration Syntax
C# Visual Basic Visual C++
public ZoomState PopAll(
    GraphPane pane
)
Public Function PopAll ( _
    pane As GraphPane _
) As ZoomState
public:
ZoomState^ PopAll (
    GraphPane^ pane
)
Parameters
pane (GraphPane)
The GraphPane object to which the scale range information should be copied.
Return Value
The ZoomState object at the bottom of the stack that was applied to the specified GraphPane. null if no ZoomState was available (the stack was empty).


Push Method

Push Method
Namespaces ► ZedGraph ► ZoomStateStack ► Push()()
Members
Icon | Member | Description
 | Push(GraphPane, ZoomState..::StateType) | Add the scale range information from the specified GraphPane object as a new ZoomState entry on the stack.
 | Push(ZoomState) | Add the scale range information from the specified ZoomState object as a new ZoomState entry on the stack.


Push Method (pane, type)

Push Method (pane, type)
Namespaces ► ZedGraph ► ZoomStateStack ► Push(GraphPane, ZoomState..::StateType)
Add the scale range information from the specified GraphPane object as a new ZoomState entry on the stack.
Declaration Syntax
C# Visual Basic Visual C++
public ZoomState Push(
    GraphPane pane,
    ZoomState.ZoomState..::StateType type
)
Public Function Push ( _
    pane As GraphPane, _
    type As ZoomState..::StateType _
) As ZoomState
public:
ZoomState^ Push (
    GraphPane^ pane,
    ZoomState..::StateType type
)
Parameters
pane (GraphPane)
The GraphPane object from which the scale range information should be copied.
type (ZoomState..::StateType)
A ZoomState..::StateType enumeration that indicates whether this state is the result of a zoom or pan operation.
Return Value
The resultant ZoomState object that was pushed on the stack.


Push Method (state)

Push Method (state)
Namespaces ► ZedGraph ► ZoomStateStack ► Push(ZoomState)
Add the scale range information from the specified ZoomState object as a new ZoomState entry on the stack.
Declaration Syntax
C# Visual Basic Visual C++
public ZoomState Push(
    ZoomState state
)
Public Function Push ( _
    state As ZoomState _
) As ZoomState
public:
ZoomState^ Push (
    ZoomState^ state
)
Parameters
state (ZoomState)
The ZoomState object to be placed on the stack.
Return Value
The ZoomState object (same as the parameter).


System.ICloneable.Clone Method

System.ICloneable.Clone Method
Namespaces ► ZedGraph ► ZoomStateStack ► ICloneable..::Clone()()
Implement the ICloneable interface in a typesafe manner by just calling the typed version of Clone()()
Declaration Syntax
C# Visual Basic Visual C++
private Object ICloneable.Clone()
Private Function System.ICloneable.Clone As Object Implements ICloneable.Clone
private:
virtual Object^ System.ICloneable.Clone () sealed = ICloneable::Clone
Return Value
A deep copy of this object


Top Property

Top Property
Namespaces ► ZedGraph ► ZoomStateStack ► Top
Gets a reference to the ZoomState object at the top of the stack, without actually removing it from the stack.
Declaration Syntax
C# Visual Basic Visual C++
public ZoomState Top{ get;}
Public ReadOnly Property Top As ZoomState
public:
property ZoomState^ Top {
    ZoomState^ get ();
}
Value
A ZoomState object reference, or null if the stack is empty.


ZOrder Enumeration

ZOrder Enumeration
Namespaces ► ZedGraph ► ZOrder
Enumeration that specifies a Z-Order position for GraphObj objects.
Declaration Syntax
C# Visual Basic Visual C++
public enum ZOrder
Public Enumeration ZOrder
public enum class ZOrder
Members
Member | Description
H_BehindAll | Specifies that the GraphObj will be behind all other objects (including the PaneBase Title).
G_BehindChartFill | Specifies that the GraphObj will be behind the Rect background Fill (see Fill).
F_BehindGrid | Specifies that the GraphObj will be behind the grid lines.
E_BehindCurves | Specifies that the GraphObj will be behind the CurveItem objects.
D_BehindAxis | Specifies that the GraphObj will be behind the Axis objects.
C_BehindChartBorder | Specifies that the GraphObj will be behind the Chart border.
B_BehindLegend | Specifies that the GraphObj will be behind the Legend object.
A_InFront | Specifies that the GraphObj will be in front of all other objects, except for the other GraphObj objects that have the same ZOrder and are before this object in the GraphObjList.
Remarks
This enumeration allows you to set the layering of various graph features. Except for the GraphObj objects, other feature types all have a fixed depth as follows (front to back): Legend objects The border around Rect CurveItem objects The Axis features The background fill of the Rect The pane Title The background fill of the Rect You cannot place anything behind the Rect background fill, but ZOrder allows you to explicitly control the depth of GraphObj objects between all other object types. For items of equal ZOrder, such as multiple CurveItem's or GraphObj's having the same ZOrder value, the relative depth is controlled by the ordinal position in the list (either CurveList or GraphObjList). GraphObj objects can be placed in the GraphObjList of either a GraphPane or a MasterPane. For a GraphPane-based GraphObj, all ZOrder values are applicable. For a MasterPane-based GraphObj, any ZOrder value can be used, but there are really only three depths: H_BehindAll will place the item behind the pane title, A_InFront will place on top of all other graph features, any other value places the object above the pane title, but behind the GraphPane's.


ZedGraph.Web Namespace

ZedGraph.Web Namespace
Namespaces ► ZedGraph.Web
This namespace contains the web components, including the ZedGraphWeb control.
Declaration Syntax
C# Visual Basic Visual C++
namespace ZedGraph.Web
Namespace ZedGraph.Web
namespace ZedGraph.Web
Types
All Types Classes Structures Enumerations Delegates
Icon | Type | Description
 | GenericViewStateAssistant..::AssistNode | Internal child class instance node, identified by a code, its datatype, and the class instance.
 | GenericCollection | Provides array services in a web state engine environment. This collection can support 1:N datatypes as items provided they are based on the GenericItem class.
 | GenericCollectionEditor | Provides a few hints to the development editor on how to create child items in the collection. This class uses the schema defined inside the collection implementation.
 | GenericCollectionItemSchema | Identifies state management items by a unique code and its datatype. The code is defined in the implementation of a GenericCollection class constructor.
 | GenericItem | Generic state management item used in a state management aware collection. This class is intended to be subclasses with public property values added. Property values should be added in the full {get/set} format reading and writing the current state from the ViewState array.
 | GenericViewStateAssistant | Assists in managing viewstate sub-objects. The host of the assistant is responsible for managing an array within the statebag. This assistant helps deal with that by simply registering each hosted object with a unique code value. It also simplies the on demand creation of the sub object by creating the instance only when the getobject method is called.
 | TempFileDestructor | The ZedGraphWeb class which remove temporary file associated with this object. File is deleted when this object is removed from cache.
 | ZedGraphWeb | The ZedGraphWeb class provides a web control interface to the ZedGraph class library. This allows ZedGraph to be used from a web page with ASP.net. All graph attributes are accessible via the GraphPane property.
 | ZedGraphWebArrowObj | Baseclass for graph items in the web control GraphObj
 | ZedGraphWebAxis | Web control state management class for a Axis object
 | ZedGraphWebBarItem | Web control state management class for a BarItem class
 | ZedGraphWebBorder | Web control state management class for a Border object.
 | ZedGraphWebBorder2 | Todo: idem ZedGraphWebFill2
 | ZedGraphWebBoxObj | Baseclass for graph items in the web control GraphObj
 | ZedGraphWebControlEventHandler | A delegate to handle the rendering event for this control.
 | ZedGraphWebCurveCollection | Manages a collection of ZedGraphWebCurveItem objects that are state management aware.
 | ZedGraphWebCurveItem | Base class for curve items in the web control CurveItem
 | ZedGraphWebEllipseObj | Baseclass for graph items in the web control GraphObj
 | ZedGraphWebErrorBarItem | Web control state management class for a ErrorBarItem class
 | ZedGraphWebFill | Web control state management class for a Fill object.
 | ZedGraphWebFill2 | TODO: change the vsassist system so different default constructors or initializers can be called, or to be able to know if a the object is already initialized or not (new).
 | ZedGraphWebFontSpec | Web control state management class for a FontSpec object
 | ZedGraphWeb..::ZedGraphWebFormat | An enumeration type that defines the output image types supported by the ZedGraph Web control.
 | ZedGraphWebGraphObj | Baseclass for graph items in the web control GraphObj
 | ZedGraphWebGraphObjCollection | Manages a collection of ZedGraphWebGraphObj objects that are state management aware.
 | ZedGraphWebGrid | Proxy class to manage all properties associated with a grid
 | ZedGraphWebHiLowBarItem | Web control state management class for a HiLowBarItem class
 | ZedGraphWebImageObj | Baseclass for graph items in the web control GraphObj
 | ZedGraphWebLegend | Web control state management class for a Legend object
 | ZedGraphWebLineItem | Web control state management class for a LineItem class
 | ZedGraphWebLocation | Location class for a FontSpec object
 | ZedGraphWebPieItem | Web control state management class for a PieItem class
 | ZedGraphWebPointD | Point class for a FontSpec object
 | ZedGraphWebPointPair | A Web PointPair class
 | ZedGraphWebPointPairCollection | Manages a collection of ZedGraphWebPointPair objects that are state management aware.
 | ZedGraphWebRect | Rectangle class for margins
 | ZedGraphWebScale | Proxy class to manage all properties associated with a grid
 | ZedGraphWebSize | Size class for a FontSpec object
 | ZedGraphWebString | A Web String class
 | ZedGraphWebStringCollection | Manages a collection of ZedGraphWebGraphObj objects that are state management aware.
 | ZedGraphWebSymbol | Web control state management class for a Symbol object
 | ZedGraphWebTextObj | Baseclass for graph items in the web control GraphObj
 | ZedGraphWebTic | Proxy class to manage all properties associated with a grid
 | ZedGraphWebXAxis | Web control state management class for a XAxis object
 | ZedGraphWebY2Axis | Web control state management class for a Y2Axis object
 | ZedGraphWebYAxis | Web control state management class for a YAxis object


GenericCollection Class

GenericCollection Class
Namespaces ► ZedGraph.Web ► GenericCollection
Provides array services in a web state engine environment. This collection can support 1:N datatypes as items provided they are based on the GenericItem class.
Declaration Syntax
C# Visual Basic Visual C++
[EditorAttribute(typeof(GenericCollectionEditor), typeof(UITypeEditor))]
[DefaultPropertyAttribute("Item")]
public class GenericCollection : IStateManager,
    IList, ICollection, IEnumerable
<EditorAttribute(GetType(GenericCollectionEditor), GetType(UITypeEditor))> _
<DefaultPropertyAttribute("Item")> _
Public Class GenericCollection _
    Implements IStateManager, IList, ICollection, IEnumerable
[EditorAttribute(typeof(GenericCollectionEditor), typeof(UITypeEditor))]
[DefaultPropertyAttribute(L"Item")]
public ref class GenericCollection : IStateManager,
    IList, ICollection, IEnumerable
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Clear()() | Empty the array list and marks the viewstate.
 | CopyTo(Array, Int32) | CopyTo(Array, Int32)
 | Count | Count
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()() | GetEnumerator()()
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | IsSynchronized
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SyncRoot | SyncRoot
 | IList..::Add(Object) | Adds item based on the rules of ListAdd Add(Object) ListAdd(Object)
 | IList..::Clear()() | Clear()()
 | IList..::Contains(Object) | Contains(Object)
 | IList..::IndexOf(Object) | IndexOf(Object)
 | IList..::Insert(Int32, Object) | Inserts item according to the rules of ListInsert Insert(Int32, Object) ListInsert(Int32, Object)
 | IList..::IsFixedSize | IsFixedSize
 | IList..::IsReadOnly | IsReadOnly
 | IList..::Item[([Int32])] | Privately implement those members of IList that take or return the object type and expose equivalent public members that take or return an item instance instead. Also implement privately those members of IList that are not meaninful to expose in the public object model of this Collection.
 | IList..::Remove(Object) | Removes item based on ListRemove Remove(Object) ListRemove(Object)
 | IList..::RemoveAt(Int32) | Removes item based on RemoveAt RemoveAt(Int32) RemoveAt(Int32)
 | IStateManager..::IsTrackingViewState | IsTrackingViewState
 | IStateManager..::LoadViewState(Object) | Loads the view state. This involves reading each state item pair, verifying schema support for each datatype, creating each item instance, and loading the state into each newly created instance. LoadViewState(Object)
 | IStateManager..::SaveViewState()() | Saves the viewstate into a portable object format. This involves saving the state of each item in the list. SaveViewState()()
 | IStateManager..::TrackViewState()() | TrackViewState()()
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | GenericCollection
 |  | ZedGraphWebCurveCollection
 |  | ZedGraphWebGraphObjCollection
 |  | ZedGraphWebStringCollection
 |  | ZedGraphWebPointPairCollection

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Clear Method

Clear Method
Namespaces ► ZedGraph.Web ► GenericCollection ► Clear()()
Empty the array list and marks the viewstate.
Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
void Clear ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


CopyTo Method (array, index)

CopyTo Method (array, index)
Namespaces ► ZedGraph.Web ► GenericCollection ► CopyTo(Array, Int32)
CopyTo(Array, Int32)
Declaration Syntax
C# Visual Basic Visual C++
public void CopyTo(
    Array array,
    int index
)
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
public:
virtual void CopyTo (
    Array^ array,
    int index
) sealed
Parameters
array (Array)
index (Int32)

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Count Property

Count Property
Namespaces ► ZedGraph.Web ► GenericCollection ► Count
Count
Declaration Syntax
C# Visual Basic Visual C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public int Count{ get;}
<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property Count As Integer
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property int Count {
    int get () sealed;
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


GetEnumerator Method

GetEnumerator Method
Namespaces ► ZedGraph.Web ► GenericCollection ► GetEnumerator()()
GetEnumerator()()
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator () sealed
Return Value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsSynchronized Property

IsSynchronized Property
Namespaces ► ZedGraph.Web ► GenericCollection ► IsSynchronized
IsSynchronized
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public bool IsSynchronized{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
<BrowsableAttribute(False)> _
Public ReadOnly Property IsSynchronized As Boolean
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


SyncRoot Property

SyncRoot Property
Namespaces ► ZedGraph.Web ► GenericCollection ► SyncRoot
SyncRoot
Declaration Syntax
C# Visual Basic Visual C++
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Object SyncRoot{ get;}
<BrowsableAttribute(False)> _
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)> _
Public ReadOnly Property SyncRoot As Object
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


System.Collections.IList.Add Method (item)

System.Collections.IList.Add Method (item)
Namespaces ► ZedGraph.Web ► GenericCollection ► IList..::Add(Object)
Adds item based on the rules of ListAdd Add(Object) ListAdd(Object)
Declaration Syntax
C# Visual Basic Visual C++
private int IList.Add(
    Object item
)
Private Function System.Collections.IList.Add ( _
    item As Object _
) As Integer Implements IList.Add
private:
virtual int System.Collections.IList.Add (
    Object^ item
) sealed = IList::Add
Parameters
item (Object)
Return Value
See Also
ListAdd(Object)

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


System.Collections.IList.Clear Method

System.Collections.IList.Clear Method
Namespaces ► ZedGraph.Web ► GenericCollection ► IList..::Clear()()
Clear()()
Declaration Syntax
C# Visual Basic Visual C++
private void IList.Clear()
Private Sub System.Collections.IList.Clear Implements IList.Clear
private:
virtual void System.Collections.IList.Clear () sealed = IList::Clear

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


System.Collections.IList.Contains Method (item)

System.Collections.IList.Contains Method (item)
Namespaces ► ZedGraph.Web ► GenericCollection ► IList..::Contains(Object)
Contains(Object)
Declaration Syntax
C# Visual Basic Visual C++
private bool IList.Contains(
    Object item
)
Private Function System.Collections.IList.Contains ( _
    item As Object _
) As Boolean Implements IList.Contains
private:
virtual bool System.Collections.IList.Contains (
    Object^ item
) sealed = IList::Contains
Parameters
item (Object)
Return Value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


System.Collections.IList.IndexOf Method (item)

System.Collections.IList.IndexOf Method (item)
Namespaces ► ZedGraph.Web ► GenericCollection ► IList..::IndexOf(Object)
IndexOf(Object)
Declaration Syntax
C# Visual Basic Visual C++
private int IList.IndexOf(
    Object item
)
Private Function System.Collections.IList.IndexOf ( _
    item As Object _
) As Integer Implements IList.IndexOf
private:
virtual int System.Collections.IList.IndexOf (
    Object^ item
) sealed = IList::IndexOf
Parameters
item (Object)
Return Value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


System.Collections.IList.Insert Method (index, item)

System.Collections.IList.Insert Method (index, item)
Namespaces ► ZedGraph.Web ► GenericCollection ► IList..::Insert(Int32, Object)
Inserts item according to the rules of ListInsert Insert(Int32, Object) ListInsert(Int32, Object)
Declaration Syntax
C# Visual Basic Visual C++
private void IList.Insert(
    int index,
    Object item
)
Private Sub System.Collections.IList.Insert ( _
    index As Integer, _
    item As Object _
) Implements IList.Insert
private:
virtual void System.Collections.IList.Insert (
    int index,
    Object^ item
) sealed = IList::Insert
Parameters
index (Int32)
item (Object)
See Also
ListInsert(Int32, Object)

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


System.Collections.IList.IsFixedSize Property

System.Collections.IList.IsFixedSize Property
Namespaces ► ZedGraph.Web ► GenericCollection ► IList..::IsFixedSize
IsFixedSize
Declaration Syntax
C# Visual Basic Visual C++
private bool IList.IsFixedSize{ get;}
Private ReadOnly Property System.Collections.IList.IsFixedSize As Boolean Implements IList.IsFixedSize
private:
virtual property bool System.Collections.IList.IsFixedSize {
    bool get () sealed = IList::IsFixedSize::get;
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


System.Collections.IList.IsReadOnly Property

System.Collections.IList.IsReadOnly Property
Namespaces ► ZedGraph.Web ► GenericCollection ► IList..::IsReadOnly
IsReadOnly
Declaration Syntax
C# Visual Basic Visual C++
private bool IList.IsReadOnly{ get;}
Private ReadOnly Property System.Collections.IList.IsReadOnly As Boolean Implements IList.IsReadOnly
private:
virtual property bool System.Collections.IList.IsReadOnly {
    bool get () sealed = IList::IsReadOnly::get;
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


System.Collections.IList.Item Property (index)

System.Collections.IList.Item Property (index)
Namespaces ► ZedGraph.Web ► GenericCollection ► IList..::Item[([Int32])]
Privately implement those members of IList that take or return the object type and expose equivalent public members that take or return an item instance instead. Also implement privately those members of IList that are not meaninful to expose in the public object model of this Collection.
Declaration Syntax
C# Visual Basic Visual C++
private Object IList.Item[
    int index
]{ get; set;}
Private Property System.Collections.IList.Item ( _
    index As Integer _
) As Object Implements IList.Item
private:
virtual property Object^ System.Collections.IList.Item[int index] {
    Object^ get (int index) sealed = IList::Item::get;
    void set (int index, Object^ value) sealed = IList::Item::set;
}
Parameters
index (Int32)

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


System.Collections.IList.Remove Method (item)

System.Collections.IList.Remove Method (item)
Namespaces ► ZedGraph.Web ► GenericCollection ► IList..::Remove(Object)
Removes item based on ListRemove Remove(Object) ListRemove(Object)
Declaration Syntax
C# Visual Basic Visual C++
private void IList.Remove(
    Object item
)
Private Sub System.Collections.IList.Remove ( _
    item As Object _
) Implements IList.Remove
private:
virtual void System.Collections.IList.Remove (
    Object^ item
) sealed = IList::Remove
Parameters
item (Object)
See Also
ListRemove(Object)

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


System.Collections.IList.RemoveAt Method (index)

System.Collections.IList.RemoveAt Method (index)
Namespaces ► ZedGraph.Web ► GenericCollection ► IList..::RemoveAt(Int32)
Removes item based on RemoveAt RemoveAt(Int32) RemoveAt(Int32)
Declaration Syntax
C# Visual Basic Visual C++
private void IList.RemoveAt(
    int index
)
Private Sub System.Collections.IList.RemoveAt ( _
    index As Integer _
) Implements IList.RemoveAt
private:
virtual void System.Collections.IList.RemoveAt (
    int index
) sealed = IList::RemoveAt
Parameters
index (Int32)
See Also
RemoveAt(Int32)

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


System.Web.UI.IStateManager.IsTrackingViewState Property

System.Web.UI.IStateManager.IsTrackingViewState Property
Namespaces ► ZedGraph.Web ► GenericCollection ► IStateManager..::IsTrackingViewState
IsTrackingViewState
Declaration Syntax
C# Visual Basic Visual C++
private bool IStateManager.IsTrackingViewState{ get;}
Private ReadOnly Property System.Web.UI.IStateManager.IsTrackingViewState As Boolean Implements IStateManager.IsTrackingViewState
private:
virtual property bool System.Web.UI.IStateManager.IsTrackingViewState {
    bool get () sealed = IStateManager::IsTrackingViewState::get;
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


System.Web.UI.IStateManager.LoadViewState Method (savedState)

System.Web.UI.IStateManager.LoadViewState Method (savedState)
Namespaces ► ZedGraph.Web ► GenericCollection ► IStateManager..::LoadViewState(Object)
Loads the view state. This involves reading each state item pair, verifying schema support for each datatype, creating each item instance, and loading the state into each newly created instance. LoadViewState(Object)
Declaration Syntax
C# Visual Basic Visual C++
private void IStateManager.LoadViewState(
    Object savedState
)
Private Sub System.Web.UI.IStateManager.LoadViewState ( _
    savedState As Object _
) Implements IStateManager.LoadViewState
private:
virtual void System.Web.UI.IStateManager.LoadViewState (
    Object^ savedState
) sealed = IStateManager::LoadViewState
Parameters
savedState (Object)
state management object
See Also
LoadViewState(Object)

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


System.Web.UI.IStateManager.SaveViewState Method

System.Web.UI.IStateManager.SaveViewState Method
Namespaces ► ZedGraph.Web ► GenericCollection ► IStateManager..::SaveViewState()()
Saves the viewstate into a portable object format. This involves saving the state of each item in the list. SaveViewState()()
Declaration Syntax
C# Visual Basic Visual C++
private Object IStateManager.SaveViewState()
Private Function System.Web.UI.IStateManager.SaveViewState As Object Implements IStateManager.SaveViewState
private:
virtual Object^ System.Web.UI.IStateManager.SaveViewState () sealed = IStateManager::SaveViewState
Return Value
portable state object
See Also
SaveViewState()()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


System.Web.UI.IStateManager.TrackViewState Method

System.Web.UI.IStateManager.TrackViewState Method
Namespaces ► ZedGraph.Web ► GenericCollection ► IStateManager..::TrackViewState()()
TrackViewState()()
Declaration Syntax
C# Visual Basic Visual C++
private void IStateManager.TrackViewState()
Private Sub System.Web.UI.IStateManager.TrackViewState Implements IStateManager.TrackViewState
private:
virtual void System.Web.UI.IStateManager.TrackViewState () sealed = IStateManager::TrackViewState

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


GenericCollectionEditor Class

GenericCollectionEditor Class
Namespaces ► ZedGraph.Web ► GenericCollectionEditor
Provides a few hints to the development editor on how to create child items in the collection. This class uses the schema defined inside the collection implementation.
Declaration Syntax
C# Visual Basic Visual C++
public class GenericCollectionEditor : CollectionEditor
Public Class GenericCollectionEditor _
    Inherits CollectionEditor
public ref class GenericCollectionEditor : public CollectionEditor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GenericCollectionEditorGenericCollectionEditorNew(Type) | Default constructor based on CollectionEditor contructor
 | CancelChanges()() | Cancels changes to the collection. (Inherited from CollectionEditor.)
 | CanRemoveInstance(Object) | Indicates whether original members of the collection can be removed. (Inherited from CollectionEditor.)
 | CanSelectMultipleInstances()() | Indicates whether multiple collection items can be selected at once. (Inherited from CollectionEditor.)
 | CollectionItemType | Gets the data type of each item in the collection. (Inherited from CollectionEditor.)
 | CollectionType | Gets the data type of the collection object. (Inherited from CollectionEditor.)
 | Context | Gets a type descriptor that indicates the current context. (Inherited from CollectionEditor.)
 | CreateCollectionForm()() | Creates a new form to display and edit the current collection. (Inherited from CollectionEditor.)
 | CreateCollectionItemType()() | Gets the data type that this collection contains. (Inherited from CollectionEditor.)
 | CreateInstance(Type) | Creates a new instance of the specified collection item type. (Inherited from CollectionEditor.)
 | DestroyInstance(Object) | Destroys the specified instance of the object. (Inherited from CollectionEditor.)
 | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the value of the specified object using the specified service provider and context. (Inherited from CollectionEditor.)
 | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()() method. (Inherited from UITypeEditor.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDisplayText(Object) | Retrieves the display text for the given list item. (Inherited from CollectionEditor.)
 | GetEditStyle(ITypeDescriptorContext) | Gets the edit style used by the EditValue(ITypeDescriptorContext, IServiceProvider, Object) method. (Inherited from CollectionEditor.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetItems(Object) | Gets an array of objects containing the specified collection. (Inherited from CollectionEditor.)
 | GetObjectsFromInstance(Object) | Returns a list containing the given object (Inherited from CollectionEditor.)
 | GetPaintValueSupported()() | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
 | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
 | GetService(Type) | Gets the requested service, if it is available. (Inherited from CollectionEditor.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | HelpTopic | Gets the Help keyword to display the Help topic or topic list for when the editor's dialog box Help button or the F1 key is pressed. (Inherited from CollectionEditor.)
 | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewItemTypes | Gets the available types of items that can be created for this collection. (Inherited from CollectionEditor.)
 | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
 | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
 | SetItems(Object, array<Object>[]()) | Sets the specified array as the items of the collection. (Inherited from CollectionEditor.)
 | ShowHelp()() | Displays the default Help topic for the collection editor. (Inherited from CollectionEditor.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Examples
public class MyCollection : GenericCollection
{
    public MyCollection() : base()
    {
        Schema = new GenericCollectionItemSchema[1];
        Schema[0].code = 'b';
        Schema[1].type = typeof(MyItem);
    }
    public void Add(MyItem item)
    {
        if ( null != item ) ListAdd( item );
        else throw new ArgumentException("parameter cannot be null","item");
    }

    [NotifyParentProperty(true)]
    public ZedGraphWebCurveItem this [int index]
    {
        get { return (MyItem)ListGet(index); }
        set { ListInsert(index,value); }
    }
}
Inheritance Hierarchy
Object
 | UITypeEditor
 |  | CollectionEditor
 |  |  | GenericCollectionEditor

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


GenericCollectionEditor Constructor (type)

GenericCollectionEditor Constructor (type)
Namespaces ► ZedGraph.Web ► GenericCollectionEditor ► GenericCollectionEditorGenericCollectionEditorNew(Type)
Default constructor based on CollectionEditor contructor
Declaration Syntax
C# Visual Basic Visual C++
public GenericCollectionEditor(
    Type type
)
Public Sub New ( _
    type As Type _
)
public:
GenericCollectionEditor (
    Type^ type
)
Parameters
type (Type)
Datetype of the collection to manage

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


GenericCollectionItemSchema Structure

GenericCollectionItemSchema Structure
Namespaces ► ZedGraph.Web ► GenericCollectionItemSchema
Identifies state management items by a unique code and its datatype. The code is defined in the implementation of a GenericCollection class constructor.
Declaration Syntax
C# Visual Basic Visual C++
public struct GenericCollectionItemSchema
Public Structure GenericCollectionItemSchema
public value class GenericCollectionItemSchema
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GenericCollectionItemSchemaGenericCollectionItemSchemaNew(Char, Type) | Default constructor
 | code | The state item datatype character code
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | type | The state item datatype

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


GenericCollectionItemSchema Constructor (c, t)

GenericCollectionItemSchema Constructor (c, t)
Namespaces ► ZedGraph.Web ► GenericCollectionItemSchema ► GenericCollectionItemSchemaGenericCollectionItemSchemaNew(Char, Type)
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public GenericCollectionItemSchema(
    char c,
    Type t
)
Public Sub New ( _
    c As Char, _
    t As Type _
)
public:
GenericCollectionItemSchema (
    wchar_t c,
    Type^ t
)
Parameters
c (Char)
Single character code used to identify the state item datatype
t (Type)
Item datatype

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


code Field

code Field
Namespaces ► ZedGraph.Web ► GenericCollectionItemSchema ► code
The state item datatype character code
Declaration Syntax
C# Visual Basic Visual C++
public char code
Public code As Char
public:
wchar_t code

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


type Field

type Field
Namespaces ► ZedGraph.Web ► GenericCollectionItemSchema ► type
The state item datatype
Declaration Syntax
C# Visual Basic Visual C++
public Type type
Public type As Type
public:
Type^ type

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


GenericItem Class

GenericItem Class
Namespaces ► ZedGraph.Web ► GenericItem
Generic state management item used in a state management aware collection. This class is intended to be subclasses with public property values added. Property values should be added in the full {get/set} format reading and writing the current state from the ViewState array.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public class GenericItem : IStateManager
<BindableAttribute(True)> _
<TypeConverterAttribute(GetType(ExpandableObjectConverter))> _
Public Class GenericItem _
    Implements IStateManager
[BindableAttribute(true)]
[TypeConverterAttribute(typeof(ExpandableObjectConverter))]
public ref class GenericItem : IStateManager
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GenericItemGenericItemNew()() | Default constructor that does nothing
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property.
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Examples
public class MyItem : GenericItem
{
    [NotifyParentProperty(true)]
    public bool IsVisible
    {
        get
        {
            object x = ViewState["IsVisible"];
            return (null == x) ? true : (bool)x;
        }
        set { ViewState["IsLegendLabelVisible"] = value; }
    }
}
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebCurveItem
 |  | ZedGraphWebBorder
 |  | ZedGraphWebFill
 |  | ZedGraphWebSymbol
 |  | ZedGraphWebGraphObj
 |  | ZedGraphWebPointPair
 |  | ZedGraphWebString
 |  | ZedGraphWebAxis
 |  | ZedGraphWebGrid
 |  | ZedGraphWebTic
 |  | ZedGraphWebScale
 |  | ZedGraphWebLegend
 |  | ZedGraphWebFontSpec
 |  | ZedGraphWebRect
 |  | ZedGraphWebSize
 |  | ZedGraphWebPointD
 |  | ZedGraphWebLocation

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


GenericItem Constructor

GenericItem Constructor
Namespaces ► ZedGraph.Web ► GenericItem ► GenericItemGenericItemNew()()
Default constructor that does nothing
Declaration Syntax
C# Visual Basic Visual C++
public GenericItem()
Public Sub New
public:
GenericItem ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


System.Web.UI.IStateManager.IsTrackingViewState Property

System.Web.UI.IStateManager.IsTrackingViewState Property
Namespaces ► ZedGraph.Web ► GenericItem ► IStateManager..::IsTrackingViewState
Implementation of the IStateManager.IsTrackingViewState property.
Declaration Syntax
C# Visual Basic Visual C++
private bool IStateManager.IsTrackingViewState{ get;}
Private ReadOnly Property System.Web.UI.IStateManager.IsTrackingViewState As Boolean Implements IStateManager.IsTrackingViewState
private:
virtual property bool System.Web.UI.IStateManager.IsTrackingViewState {
    bool get () sealed = IStateManager::IsTrackingViewState::get;
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


System.Web.UI.IStateManager.LoadViewState Method (savedState)

System.Web.UI.IStateManager.LoadViewState Method (savedState)
Namespaces ► ZedGraph.Web ► GenericItem ► IStateManager..::LoadViewState(Object)
Implementation of the IStateManager.LoadViewState method
Declaration Syntax
C# Visual Basic Visual C++
private void IStateManager.LoadViewState(
    Object savedState
)
Private Sub System.Web.UI.IStateManager.LoadViewState ( _
    savedState As Object _
) Implements IStateManager.LoadViewState
private:
virtual void System.Web.UI.IStateManager.LoadViewState (
    Object^ savedState
) sealed = IStateManager::LoadViewState
Parameters
savedState (Object)
object containing asp.net page viewstate

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


System.Web.UI.IStateManager.SaveViewState Method

System.Web.UI.IStateManager.SaveViewState Method
Namespaces ► ZedGraph.Web ► GenericItem ► IStateManager..::SaveViewState()()
Implementation of the IStateManager.SaveViewState method
Declaration Syntax
C# Visual Basic Visual C++
private Object IStateManager.SaveViewState()
Private Function System.Web.UI.IStateManager.SaveViewState As Object Implements IStateManager.SaveViewState
private:
virtual Object^ System.Web.UI.IStateManager.SaveViewState () sealed = IStateManager::SaveViewState
Return Value
object containing classes viewstate

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


System.Web.UI.IStateManager.TrackViewState Method

System.Web.UI.IStateManager.TrackViewState Method
Namespaces ► ZedGraph.Web ► GenericItem ► IStateManager..::TrackViewState()()
Implementation of the IStateManager.TrackViewState method
Declaration Syntax
C# Visual Basic Visual C++
private void IStateManager.TrackViewState()
Private Sub System.Web.UI.IStateManager.TrackViewState Implements IStateManager.TrackViewState
private:
virtual void System.Web.UI.IStateManager.TrackViewState () sealed = IStateManager::TrackViewState

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


GenericViewStateAssistant Class

GenericViewStateAssistant Class
Namespaces ► ZedGraph.Web ► GenericViewStateAssistant
Assists in managing viewstate sub-objects. The host of the assistant is responsible for managing an array within the statebag. This assistant helps deal with that by simply registering each hosted object with a unique code value. It also simplies the on demand creation of the sub object by creating the instance only when the getobject method is called.
Declaration Syntax
C# Visual Basic Visual C++
public class GenericViewStateAssistant
Public Class GenericViewStateAssistant
public ref class GenericViewStateAssistant
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GenericViewStateAssistantGenericViewStateAssistantNew()() | Default constructor
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValue(Char, Boolean) | Retrieves instance based on the registered code and datatype. If the value is null, the datatype is used to create a new instance that is cached in the assistant node.
 | LoadViewState(Object, Boolean) | Loads the viewstate from the provided statebag into each of the registered objects hosted in the assistants collection.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Register(Char, Type) | Registers a code with a datatype in the assistance. Once registered the datatype will be available for retrievable using the same code value.
 | SaveViewState(Object) | Returns the current viewstate of every object hosted in the assistants collection.
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrackViewState()() | Triggers the assistant to begin tracking viewstate changes
Inheritance Hierarchy
Object
GenericViewStateAssistant

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


GenericViewStateAssistant Constructor

GenericViewStateAssistant Constructor
Namespaces ► ZedGraph.Web ► GenericViewStateAssistant ► GenericViewStateAssistantGenericViewStateAssistantNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public GenericViewStateAssistant()
Public Sub New
public:
GenericViewStateAssistant ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


GetValue Method (code, IsTrackingViewState)

GetValue Method (code, IsTrackingViewState)
Namespaces ► ZedGraph.Web ► GenericViewStateAssistant ► GetValue(Char, Boolean)
Retrieves instance based on the registered code and datatype. If the value is null, the datatype is used to create a new instance that is cached in the assistant node.
Declaration Syntax
C# Visual Basic Visual C++
public Object GetValue(
    char code,
    bool IsTrackingViewState
)
Public Function GetValue ( _
    code As Char, _
    IsTrackingViewState As Boolean _
) As Object
public:
Object^ GetValue (
    wchar_t code,
    bool IsTrackingViewState
)
Parameters
code (Char)
code to search on
IsTrackingViewState (Boolean)
Indicates if the parent is currently tracking viewstate
Return Value
class instance

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


LoadViewState Method (savedState, IsTrackingViewState)

LoadViewState Method (savedState, IsTrackingViewState)
Namespaces ► ZedGraph.Web ► GenericViewStateAssistant ► LoadViewState(Object, Boolean)
Loads the viewstate from the provided statebag into each of the registered objects hosted in the assistants collection.
Declaration Syntax
C# Visual Basic Visual C++
public Object LoadViewState(
    Object savedState,
    bool IsTrackingViewState
)
Public Function LoadViewState ( _
    savedState As Object, _
    IsTrackingViewState As Boolean _
) As Object
public:
Object^ LoadViewState (
    Object^ savedState,
    bool IsTrackingViewState
)
Parameters
savedState (Object)
statebag provided by parent
IsTrackingViewState (Boolean)
indicates if the parent is currently tracking viewstate changes
Return Value
The parents individual statebag

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Register Method (code, type)

Register Method (code, type)
Namespaces ► ZedGraph.Web ► GenericViewStateAssistant ► Register(Char, Type)
Registers a code with a datatype in the assistance. Once registered the datatype will be available for retrievable using the same code value.
Declaration Syntax
C# Visual Basic Visual C++
public void Register(
    char code,
    Type type
)
Public Sub Register ( _
    code As Char, _
    type As Type _
)
public:
void Register (
    wchar_t code,
    Type^ type
)
Parameters
code (Char)
Type identifier
type (Type)
Object type being hosted

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


SaveViewState Method (BaseState)

SaveViewState Method (BaseState)
Namespaces ► ZedGraph.Web ► GenericViewStateAssistant ► SaveViewState(Object)
Returns the current viewstate of every object hosted in the assistants collection.
Declaration Syntax
C# Visual Basic Visual C++
public Object SaveViewState(
    Object BaseState
)
Public Function SaveViewState ( _
    BaseState As Object _
) As Object
public:
Object^ SaveViewState (
    Object^ BaseState
)
Parameters
BaseState (Object)
parents viewstate bag
Return Value
Combined saved viewstate for the parent and all hosted objects in the assistant collection

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


TrackViewState Method

TrackViewState Method
Namespaces ► ZedGraph.Web ► GenericViewStateAssistant ► TrackViewState()()
Triggers the assistant to begin tracking viewstate changes
Declaration Syntax
C# Visual Basic Visual C++
public void TrackViewState()
Public Sub TrackViewState
public:
void TrackViewState ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


GenericViewStateAssistant.AssistNode Class

GenericViewStateAssistant..::AssistNode Class
Namespaces ► ZedGraph.Web ► GenericViewStateAssistant ► GenericViewStateAssistant..::AssistNode
Internal child class instance node, identified by a code, its datatype, and the class instance.
Declaration Syntax
C# Visual Basic Visual C++
protected class AssistNode
Protected Class AssistNode
protected ref class AssistNode
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GenericViewStateAssistant..::AssistNodeGenericViewStateAssistant..::AssistNodeNew(Char, Type) | Creates an assistant node given a character key and the hosted class type.
 | Code | Code to uniquely identify this node entry
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Key | Object type identifying hosted value type.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | Object instance based on Key definition. May be null
Inheritance Hierarchy
Object
GenericViewStateAssistant..::AssistNode

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


GenericViewStateAssistant.AssistNode Constructor (code, type)

GenericViewStateAssistant..::AssistNode Constructor (code, type)
Namespaces ► ZedGraph.Web ► GenericViewStateAssistant..::AssistNode ► GenericViewStateAssistant..::AssistNodeGenericViewStateAssistant..::AssistNodeNew(Char, Type)
Creates an assistant node given a character key and the hosted class type.
Declaration Syntax
C# Visual Basic Visual C++
public AssistNode(
    char code,
    Type type
)
Public Sub New ( _
    code As Char, _
    type As Type _
)
public:
AssistNode (
    wchar_t code,
    Type^ type
)
Parameters
code (Char)
Identifier code
type (Type)
Class data type hosted by the node

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Code Field

Code Field
Namespaces ► ZedGraph.Web ► GenericViewStateAssistant..::AssistNode ► Code
Code to uniquely identify this node entry
Declaration Syntax
C# Visual Basic Visual C++
public char Code
Public Code As Char
public:
wchar_t Code

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Key Field

Key Field
Namespaces ► ZedGraph.Web ► GenericViewStateAssistant..::AssistNode ► Key
Object type identifying hosted value type.
Declaration Syntax
C# Visual Basic Visual C++
public Type Key
Public Key As Type
public:
Type^ Key

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Value Field

Value Field
Namespaces ► ZedGraph.Web ► GenericViewStateAssistant..::AssistNode ► Value
Object instance based on Key definition. May be null
Declaration Syntax
C# Visual Basic Visual C++
public Object Value
Public Value As Object
public:
Object^ Value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


TempFileDestructor Class

TempFileDestructor Class
Namespaces ► ZedGraph.Web ► TempFileDestructor
The ZedGraphWeb class which remove temporary file associated with this object. File is deleted when this object is removed from cache.
Declaration Syntax
C# Visual Basic Visual C++
public class TempFileDestructor
Public Class TempFileDestructor
public ref class TempFileDestructor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TempFileDestructorTempFileDestructorNew(String) | Constructor
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemovedCallback(String, Object, CacheItemRemovedReason) | Called when object removed from cache
 | ToString()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TempFileDestructor

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


TempFileDestructor Constructor (fileName)

TempFileDestructor Constructor (fileName)
Namespaces ► ZedGraph.Web ► TempFileDestructor ► TempFileDestructorTempFileDestructorNew(String)
Constructor
Declaration Syntax
C# Visual Basic Visual C++
public TempFileDestructor(
    string fileName
)
Public Sub New ( _
    fileName As String _
)
public:
TempFileDestructor (
    String^ fileName
)
Parameters
fileName (String)

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


RemovedCallback Method (k, v, r)

RemovedCallback Method (k, v, r)
Namespaces ► ZedGraph.Web ► TempFileDestructor ► RemovedCallback(String, Object, CacheItemRemovedReason)
Called when object removed from cache
Declaration Syntax
C# Visual Basic Visual C++
public void RemovedCallback(
    string k,
    Object v,
    CacheItemRemovedReason r
)
Public Sub RemovedCallback ( _
    k As String, _
    v As Object, _
    r As CacheItemRemovedReason _
)
public:
void RemovedCallback (
    String^ k,
    Object^ v,
    CacheItemRemovedReason r
)
Parameters
k (String)
v (Object)
r (CacheItemRemovedReason)

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWeb Class

ZedGraphWeb Class
Namespaces ► ZedGraph.Web ► ZedGraphWeb
The ZedGraphWeb class provides a web control interface to the ZedGraph class library. This allows ZedGraph to be used from a web page with ASP.net. All graph attributes are accessible via the GraphPane property.
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWeb : Control, INamingContainer,
    IDisposable
Public Class ZedGraphWeb _
    Inherits Control _
    Implements INamingContainer, IDisposable
public ref class ZedGraphWeb : public Control,
    INamingContainer, IDisposable
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebZedGraphWebNew()() | Default constructor.
 | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
 | AddedControl(Control, Int32) | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
 | AddParsedSubObject(Object) | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
 | ApplyStyleSheetSkin(Page) | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
 | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
 | AxisChanged | Gets or sets a boolean flag value that, if true, will cause the AxisChange()() method to be called when CreateGraph(Stream, ImageFormat) is called.
 | BarBase | Proxy property that gets or sets the value of Base.
 | BarType | Proxy property that gets or sets the value of the Type.
 | BaseDimension | Proxy property that gets or sets the value of the BaseDimension.
 | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
 | BuildProfileTree(String, Boolean) | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
 | CacheDuration | Optional setting that determines how long the cached image will remain valid. A zero value disables caching.
 | CacheSuffix | Optional cache file suffix that can be used to modify the output cache file name to make it unique.
 | ChartBorder | Proxy property that gets the value of the Border.
 | ChartFill | Proxy property that gets the value of the Fill.
 | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
 | ClearChildControlState()() | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
 | ClearChildState()() | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
 | ClearChildViewState()() | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
 | ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
 | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
 | Context | Gets the HttpContext object associated with the server control for the current Web request. (Inherited from Control.)
 | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
 | CreateChildControls()() | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
 | CreateControlCollection()() | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
 | CreateGraph(Stream, ImageFormat) | Method to create a GraphPane class for the control.
 | CurveList | Proxy property that gets the value of the CurveList.
 | DataBind()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
 | DataBindChildren()() | Binds a data source to the server control's child controls. (Inherited from Control.)
 | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
 | DataMember | The String name of the data member that contains the data to be bound to the graph.
 | DataSource | The object reference that points to a data source from which to bind curve data.
 | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
 | Dispose()() | Free up resources associated with the FileStream (Overrides Control.Dispose()().)
 | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
 | Draw(Boolean) | Draws graph on HttpResponse object
 | Draw(Stream) | Draws graph on stream object
 | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from Control.)
 | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from Control.)
 | EnsureChildControls()() | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
 | EnsureID()() | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter. (Inherited from Control.)
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method. (Inherited from Control.)
 | Focus()() | Sets input focus to a control. (Inherited from Control.)
 | FontSpec | Proxy property that gets the value of the Title FontSpec.
 | GetDesignModeState()() | Gets design-time data for a control. (Inherited from Control.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetService(Type) |
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | GraphObjList | Proxy property that gets the value of the GraphObjList.
 | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
 | HasControls()() | Determines if the server control contains any child controls. (Inherited from Control.)
 | HasEvents()() | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
 | Height | Proxy property that gets or sets the height of the Rect.
 | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from Control.)
 | IdSeparator | Gets the character used to separate control identifiers. (Inherited from Control.)
 | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
 | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
 | IsFontsScaled | Proxy property that gets or sets the value of IsFontsScaled.
 | IsIgnoreInitial | Proxy property that gets or sets the value of IsIgnoreInitial.
 | IsIgnoreMissing | Proxy property that gets or sets the value of IsIgnoreMissing.
 | IsImageMap | Proxy property that gets or sets the value of IsImageMap.
 | IsLiteralContent()() | Determines if the server control holds only literal content. (Inherited from Control.)
 | IsPenWidthScaled | Proxy property that gets or sets the value of IsPenWidthScaled.
 | IsShowTitle | Proxy property that gets or sets the value of IsVisible, which determines if the Title is visible.
 | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
 | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
 | Legend | Proxy property that gets the value of the Legend.
 | LineType | Proxy property that gets or sets the value of the LineType.
 | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
 | LoadControlState(Object) | Restores control-state information from a previous page request that was saved by the SaveControlState()() method. (Inherited from Control.)
 | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
 | MakeImageMap(MasterPane, HtmlTextWriter) | Generate an ImageMap as Html tags
 | MapPathSecure(String) | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
 | Margins | Proxy property that gets the value of the GraphPane Margin properties (Left, Right, Top and Bottom).
 | MasterPaneBorder | Proxy property that gets the value of the Border.
 | MasterPaneFill | Proxy property that gets the value of the Fill.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinBarGap | Proxy property that gets or sets the value of the MinBarGap.
 | MinClusterGap | Proxy property that gets or sets the value of the MinClusterGap.
 | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
 | OnBubbleEvent(Object, EventArgs) | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
 | OnDataBinding(EventArgs) | Raises the DataBinding event. (Inherited from Control.)
 | OnInit(EventArgs) | Raises the Init event. (Inherited from Control.)
 | OnLoad(EventArgs) | Raises the Load event. (Inherited from Control.)
 | OnUnload(EventArgs) | Raises the Unload event. (Inherited from Control.)
 | OpenFile(String) | Gets a Stream used to read a file. (Inherited from Control.)
 | OutputFormat | Proxy property that gets or sets the value that determines the output format for the control, in the form of a ZedGraphWeb..::ZedGraphWebFormat enumeration. This is typically Gif, Jpeg, Png, or Icon.
 | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
 | PaneBorder | Proxy property that gets the value of the Border.
 | PaneFill | Proxy property that gets the value of the Fill.
 | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
 | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
 | RaiseBubbleEvent(Object, EventArgs) | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
 | RemovedControl(Control) | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
 | RenderChildren(HtmlTextWriter) | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
 | RenderDemo(Graphics, GraphPane) | Renders the demo graph with one call.
 | RenderedImagePath | What to return ? A raw image or an IMG tag referencing a generated image ?
 | RenderGraph | Sets the rendering event handler.
 | RenderMode | What to return ? A raw image or an IMG tag referencing a generated image ?
 | ResolveAdapter()() | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
 | ResolveClientUrl(String) | Gets a URL that can be used by the browser. (Inherited from Control.)
 | ResolveUrl(String) | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
 | SaveControlState()() | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
 | SetDesignModeState(IDictionary) | Sets design-time data for a control. (Inherited from Control.)
 | SetRenderMethodDelegate(RenderMethod) | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
 | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
 | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
 | IControlBuilderAccessor..::ControlBuilder | (Inherited from Control.)
 | IControlDesignerAccessor..::GetDesignModeState()() | (Inherited from Control.)
 | IControlDesignerAccessor..::SetDesignModeState(IDictionary) | (Inherited from Control.)
 | IControlDesignerAccessor..::SetOwnerControl(Control) | (Inherited from Control.)
 | IControlDesignerAccessor..::UserData | (Inherited from Control.)
 | IDataBindingsAccessor..::DataBindings | (Inherited from Control.)
 | IDataBindingsAccessor..::HasDataBindings | (Inherited from Control.)
 | IExpressionsAccessor..::Expressions | (Inherited from Control.)
 | IExpressionsAccessor..::HasExpressions | (Inherited from Control.)
 | IParserAccessor..::AddParsedSubObject(Object) | (Inherited from Control.)
 | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
 | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
 | Title | Proxy property that gets or sets the Title of the GraphPane.
 | TmpImageDuration | Gets or sets a value that determines the duration (in hours) of a temporary file generated by control in mode "ImageTag"
 | ToString()() | Override the ToString()() method to do nothing. (Overrides Object.ToString()().)
 | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
 | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
 | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
 | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
 | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from Control.)
 | Width | Proxy property that gets or sets the width of the Rect.
 | XAxis | Proxy property that gets the value of the XAxis.
 | Y2Axis | Proxy property that gets the value of the Y2Axis.
 | YAxis | Proxy property that gets the value of the YAxis.
Inheritance Hierarchy
Object
 | Control
 |  | ZedGraphWeb

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWeb Constructor

ZedGraphWeb Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► ZedGraphWebZedGraphWebNew()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWeb()
Public Sub New
public:
ZedGraphWeb ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


AxisChanged Property

AxisChanged Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► AxisChanged
Gets or sets a boolean flag value that, if true, will cause the AxisChange()() method to be called when CreateGraph(Stream, ImageFormat) is called.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute("true")]
public bool AxisChanged{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute("true")> _
Public Property AxisChanged As Boolean
[BindableAttribute(true)]
[DefaultValueAttribute(L"true")]
public:
property bool AxisChanged {
    bool get ();
    void set (bool value);
}
Value
A boolean value, true to call AxisChange()(), false otherwise

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


BarBase Property

BarBase Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► BarBase
Proxy property that gets or sets the value of Base.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public BarBase BarBase{ get; set;}
<BindableAttribute(True)> _
Public Property BarBase As BarBase
[BindableAttribute(true)]
public:
property BarBase BarBase {
    BarBase get ();
    void set (BarBase value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


BarType Property

BarType Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► BarType
Proxy property that gets or sets the value of the Type.
Declaration Syntax
C# Visual Basic Visual C++
public BarType BarType{ get; set;}
Public Property BarType As BarType
public:
property BarType BarType {
    BarType get ();
    void set (BarType value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


BaseDimension Property

BaseDimension Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► BaseDimension
Proxy property that gets or sets the value of the BaseDimension.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public float BaseDimension{ get; set;}
<BindableAttribute(True)> _
Public Property BaseDimension As Single
[BindableAttribute(true)]
public:
property float BaseDimension {
    float get ();
    void set (float value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


CacheDuration Property

CacheDuration Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► CacheDuration
Optional setting that determines how long the cached image will remain valid. A zero value disables caching.
Declaration Syntax
C# Visual Basic Visual C++
public int CacheDuration{ get; set;}
Public Property CacheDuration As Integer
public:
property int CacheDuration {
    int get ();
    void set (int value);
}
Value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


CacheSuffix Property

CacheSuffix Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► CacheSuffix
Optional cache file suffix that can be used to modify the output cache file name to make it unique.
Declaration Syntax
C# Visual Basic Visual C++
public string CacheSuffix{ get; set;}
Public Property CacheSuffix As String
public:
property String^ CacheSuffix {
    String^ get ();
    void set (String^ value);
}
Value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ChartBorder Property

ChartBorder Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► ChartBorder
Proxy property that gets the value of the Border.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebBorder ChartBorder{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property ChartBorder As ZedGraphWebBorder
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebBorder^ ChartBorder {
    ZedGraphWebBorder^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ChartFill Property

ChartFill Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► ChartFill
Proxy property that gets the value of the Fill.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebFill ChartFill{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property ChartFill As ZedGraphWebFill
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebFill^ ChartFill {
    ZedGraphWebFill^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


CreateGraph Method (OutputStream, Format)

CreateGraph Method (OutputStream, Format)
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► CreateGraph(Stream, ImageFormat)
Method to create a GraphPane class for the control.
Declaration Syntax
C# Visual Basic Visual C++
public MasterPane CreateGraph(
    Stream OutputStream,
    ImageFormat Format
)
Public Function CreateGraph ( _
    OutputStream As Stream, _
    Format As ImageFormat _
) As MasterPane
public:
MasterPane^ CreateGraph (
    Stream^ OutputStream,
    ImageFormat^ Format
)
Parameters
OutputStream (Stream)
A Stream in which to output the ZedGraph Image.
Format (ImageFormat)
The ImageFormat()() type to be output.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


CurveList Property

CurveList Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► CurveList
Proxy property that gets the value of the CurveList.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebCurveCollection CurveList{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property CurveList As ZedGraphWebCurveCollection
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebCurveCollection^ CurveList {
    ZedGraphWebCurveCollection^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


DataMember Property

DataMember Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► DataMember
The String name of the data member that contains the data to be bound to the graph.
Declaration Syntax
C# Visual Basic Visual C++
public string DataMember{ get; set;}
Public Property DataMember As String
public:
property String^ DataMember {
    String^ get ();
    void set (String^ value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


DataSource Property

DataSource Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► DataSource
The object reference that points to a data source from which to bind curve data.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[BrowsableAttribute(true)]
public Object DataSource{ get; set;}
<BindableAttribute(True)> _
<BrowsableAttribute(True)> _
Public Property DataSource As Object
[BindableAttribute(true)]
[BrowsableAttribute(true)]
public:
property Object^ DataSource {
    Object^ get ();
    void set (Object^ value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Dispose Method

Dispose Method
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► Dispose()()
Free up resources associated with the FileStream
Declaration Syntax
C# Visual Basic Visual C++
public override void Dispose()
Public Overrides Sub Dispose
public:
virtual void Dispose () override

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Draw Method

Draw Method
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► Draw()()
Members
Icon | Member | Description
 | Draw(Boolean) | Draws graph on HttpResponse object
 | Draw(Stream) | Draws graph on stream object

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Draw Method (end)

Draw Method (end)
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► Draw(Boolean)
Draws graph on HttpResponse object
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    bool end
)
Public Sub Draw ( _
    end As Boolean _
)
public:
void Draw (
    bool end
)
Parameters
end (Boolean)

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Draw Method (stream)

Draw Method (stream)
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► Draw(Stream)
Draws graph on stream object
Declaration Syntax
C# Visual Basic Visual C++
public void Draw(
    Stream stream
)
Public Sub Draw ( _
    stream As Stream _
)
public:
void Draw (
    Stream^ stream
)
Parameters
stream (Stream)

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


FontSpec Property

FontSpec Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► FontSpec
Proxy property that gets the value of the Title FontSpec.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebFontSpec FontSpec{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property FontSpec As ZedGraphWebFontSpec
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebFontSpec^ FontSpec {
    ZedGraphWebFontSpec^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


GetService Method (serviceType)

GetService Method (serviceType)
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► GetService(Type)
Declaration Syntax
C# Visual Basic Visual C++
public Object GetService(
    Type serviceType
)
Public Function GetService ( _
    serviceType As Type _
) As Object
public:
Object^ GetService (
    Type^ serviceType
)
Parameters
serviceType (Type)
Return Value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


GraphObjList Property

GraphObjList Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► GraphObjList
Proxy property that gets the value of the GraphObjList.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebGraphObjCollection GraphObjList{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property GraphObjList As ZedGraphWebGraphObjCollection
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebGraphObjCollection^ GraphObjList {
    ZedGraphWebGraphObjCollection^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Height Property

Height Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► Height
Proxy property that gets or sets the height of the Rect.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute()]
public int Height{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute()> _
Public Property Height As Integer
[BindableAttribute(true)]
[DefaultValueAttribute()]
public:
property int Height {
    int get ();
    void set (int value);
}
Value
The height in output device pixels

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsFontsScaled Property

IsFontsScaled Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► IsFontsScaled
Proxy property that gets or sets the value of IsFontsScaled.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public bool IsFontsScaled{ get; set;}
<BindableAttribute(True)> _
Public Property IsFontsScaled As Boolean
[BindableAttribute(true)]
public:
property bool IsFontsScaled {
    bool get ();
    void set (bool value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsIgnoreInitial Property

IsIgnoreInitial Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► IsIgnoreInitial
Proxy property that gets or sets the value of IsIgnoreInitial.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public bool IsIgnoreInitial{ get; set;}
<BindableAttribute(True)> _
Public Property IsIgnoreInitial As Boolean
[BindableAttribute(true)]
public:
property bool IsIgnoreInitial {
    bool get ();
    void set (bool value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsIgnoreMissing Property

IsIgnoreMissing Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► IsIgnoreMissing
Proxy property that gets or sets the value of IsIgnoreMissing.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public bool IsIgnoreMissing{ get; set;}
<BindableAttribute(True)> _
Public Property IsIgnoreMissing As Boolean
[BindableAttribute(true)]
public:
property bool IsIgnoreMissing {
    bool get ();
    void set (bool value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsImageMap Property

IsImageMap Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► IsImageMap
Proxy property that gets or sets the value of IsImageMap.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public bool IsImageMap{ get; set;}
<BindableAttribute(True)> _
Public Property IsImageMap As Boolean
[BindableAttribute(true)]
public:
property bool IsImageMap {
    bool get ();
    void set (bool value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsPenWidthScaled Property

IsPenWidthScaled Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► IsPenWidthScaled
Proxy property that gets or sets the value of IsPenWidthScaled.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public bool IsPenWidthScaled{ get; set;}
<BindableAttribute(True)> _
Public Property IsPenWidthScaled As Boolean
[BindableAttribute(true)]
public:
property bool IsPenWidthScaled {
    bool get ();
    void set (bool value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsShowTitle Property

IsShowTitle Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► IsShowTitle
Proxy property that gets or sets the value of IsVisible, which determines if the Title is visible.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public bool IsShowTitle{ get; set;}
<BindableAttribute(True)> _
Public Property IsShowTitle As Boolean
[BindableAttribute(true)]
public:
property bool IsShowTitle {
    bool get ();
    void set (bool value);
}
Value
true to show the pane title, false otherwise

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Legend Property

Legend Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► Legend
Proxy property that gets the value of the Legend.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebLegend Legend{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Legend As ZedGraphWebLegend
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebLegend^ Legend {
    ZedGraphWebLegend^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


LineType Property

LineType Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► LineType
Proxy property that gets or sets the value of the LineType.
Declaration Syntax
C# Visual Basic Visual C++
public LineType LineType{ get; set;}
Public Property LineType As LineType
public:
property LineType LineType {
    LineType get ();
    void set (LineType value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MakeImageMap Method (masterPane, output)

MakeImageMap Method (masterPane, output)
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► MakeImageMap(MasterPane, HtmlTextWriter)
Generate an ImageMap as Html tags
Declaration Syntax
C# Visual Basic Visual C++
public void MakeImageMap(
    MasterPane masterPane,
    HtmlTextWriter output
)
Public Sub MakeImageMap ( _
    masterPane As MasterPane, _
    output As HtmlTextWriter _
)
public:
void MakeImageMap (
    MasterPane^ masterPane,
    HtmlTextWriter^ output
)
Parameters
masterPane (MasterPane)
The source MasterPane to be image mapped.
output (HtmlTextWriter)
An HtmlTextWriter instance in which the html tags will be written for the image map.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Margins Property

Margins Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► Margins
Proxy property that gets the value of the GraphPane Margin properties (Left, Right, Top and Bottom).
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebRect Margins{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Margins As ZedGraphWebRect
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebRect^ Margins {
    ZedGraphWebRect^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MasterPaneBorder Property

MasterPaneBorder Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► MasterPaneBorder
Proxy property that gets the value of the Border.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebBorder2 MasterPaneBorder{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property MasterPaneBorder As ZedGraphWebBorder2
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebBorder2^ MasterPaneBorder {
    ZedGraphWebBorder2^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MasterPaneFill Property

MasterPaneFill Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► MasterPaneFill
Proxy property that gets the value of the Fill.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebFill2 MasterPaneFill{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property MasterPaneFill As ZedGraphWebFill2
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebFill2^ MasterPaneFill {
    ZedGraphWebFill2^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MinBarGap Property

MinBarGap Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► MinBarGap
Proxy property that gets or sets the value of the MinBarGap.
Declaration Syntax
C# Visual Basic Visual C++
public float MinBarGap{ get; set;}
Public Property MinBarGap As Single
public:
property float MinBarGap {
    float get ();
    void set (float value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MinClusterGap Property

MinClusterGap Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► MinClusterGap
Proxy property that gets or sets the value of the MinClusterGap.
Declaration Syntax
C# Visual Basic Visual C++
public float MinClusterGap{ get; set;}
Public Property MinClusterGap As Single
public:
property float MinClusterGap {
    float get ();
    void set (float value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


OutputFormat Property

OutputFormat Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► OutputFormat
Proxy property that gets or sets the value that determines the output format for the control, in the form of a ZedGraphWeb..::ZedGraphWebFormat enumeration. This is typically Gif, Jpeg, Png, or Icon.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
[DefaultValueAttribute()]
public ZedGraphWeb.ZedGraphWeb..::ZedGraphWebFormat OutputFormat{ get; set;}
<BindableAttribute(True)> _
<DefaultValueAttribute()> _
Public Property OutputFormat As ZedGraphWeb..::ZedGraphWebFormat
[BindableAttribute(true)]
[DefaultValueAttribute()]
public:
property ZedGraphWeb..::ZedGraphWebFormat OutputFormat {
    ZedGraphWeb..::ZedGraphWebFormat get ();
    void set (ZedGraphWeb..::ZedGraphWebFormat value);
}
Value
A ZedGraphWeb..::ZedGraphWebFormat enumeration.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


PaneBorder Property

PaneBorder Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► PaneBorder
Proxy property that gets the value of the Border.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebBorder PaneBorder{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property PaneBorder As ZedGraphWebBorder
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebBorder^ PaneBorder {
    ZedGraphWebBorder^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


PaneFill Property

PaneFill Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► PaneFill
Proxy property that gets the value of the Fill.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebFill PaneFill{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property PaneFill As ZedGraphWebFill
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebFill^ PaneFill {
    ZedGraphWebFill^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


RenderDemo Method (g, pane)

RenderDemo Method (g, pane)
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► RenderDemo(Graphics, GraphPane)
Renders the demo graph with one call.
Declaration Syntax
C# Visual Basic Visual C++
public static void RenderDemo(
    Graphics g,
    GraphPane pane
)
Public Shared Sub RenderDemo ( _
    g As Graphics, _
    pane As GraphPane _
)
public:
static void RenderDemo (
    Graphics^ g,
    GraphPane^ pane
)
Parameters
g (Graphics)
A Graphics object for which the drawing will be done.
pane (GraphPane)
A reference to the GraphPane

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


RenderedImagePath Property

RenderedImagePath Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► RenderedImagePath
What to return ? A raw image or an IMG tag referencing a generated image ?
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute("~/ZedGraphImages/")]
public string RenderedImagePath{ get; set;}
<DefaultValueAttribute("~/ZedGraphImages/")> _
Public Property RenderedImagePath As String
[DefaultValueAttribute(L"~/ZedGraphImages/")]
public:
property String^ RenderedImagePath {
    String^ get ();
    void set (String^ value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


RenderGraph Event

RenderGraph Event
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► RenderGraph
Sets the rendering event handler.
Declaration Syntax
C# Visual Basic Visual C++
public event ZedGraphWebControlEventHandler RenderGraph
Public Event RenderGraph As ZedGraphWebControlEventHandler
public:
 event ZedGraphWebControlEventHandler^ RenderGraph {
    void add (ZedGraphWebControlEventHandler^ value);
    void remove (ZedGraphWebControlEventHandler^ value);
}
Value
An event type for the RenderGraph event

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


RenderMode Property

RenderMode Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► RenderMode
What to return ? A raw image or an IMG tag referencing a generated image ?
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute()]
public RenderModeType RenderMode{ get; set;}
<DefaultValueAttribute()> _
Public Property RenderMode As RenderModeType
[DefaultValueAttribute()]
public:
property RenderModeType RenderMode {
    RenderModeType get ();
    void set (RenderModeType value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Title Property

Title Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► Title
Proxy property that gets or sets the Title of the GraphPane.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute("")]
[BindableAttribute(true)]
public string Title{ get; set;}
<DefaultValueAttribute("")> _
<BindableAttribute(True)> _
Public Property Title As String
[DefaultValueAttribute(L"")]
[BindableAttribute(true)]
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
Value
A title String

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


TmpImageDuration Property

TmpImageDuration Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► TmpImageDuration
Gets or sets a value that determines the duration (in hours) of a temporary file generated by control in mode "ImageTag"
Declaration Syntax
C# Visual Basic Visual C++
public double TmpImageDuration{ get; set;}
Public Property TmpImageDuration As Double
public:
property double TmpImageDuration {
    double get ();
    void set (double value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► ToString()()
Override the ToString()() method to do nothing.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
An empty string

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Width Property

Width Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► Width
Proxy property that gets or sets the width of the Rect.
Declaration Syntax
C# Visual Basic Visual C++
[DefaultValueAttribute()]
[BindableAttribute(true)]
public int Width{ get; set;}
<DefaultValueAttribute()> _
<BindableAttribute(True)> _
Public Property Width As Integer
[DefaultValueAttribute()]
[BindableAttribute(true)]
public:
property int Width {
    int get ();
    void set (int value);
}
Value
The width in output device pixels

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


XAxis Property

XAxis Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► XAxis
Proxy property that gets the value of the XAxis.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebXAxis XAxis{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property XAxis As ZedGraphWebXAxis
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebXAxis^ XAxis {
    ZedGraphWebXAxis^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Y2Axis Property

Y2Axis Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► Y2Axis
Proxy property that gets the value of the Y2Axis.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebY2Axis Y2Axis{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Y2Axis As ZedGraphWebY2Axis
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebY2Axis^ Y2Axis {
    ZedGraphWebY2Axis^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


YAxis Property

YAxis Property
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► YAxis
Proxy property that gets the value of the YAxis.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebYAxis YAxis{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property YAxis As ZedGraphWebYAxis
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebYAxis^ YAxis {
    ZedGraphWebYAxis^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWeb.ZedGraphWebFormat Enumeration

ZedGraphWeb..::ZedGraphWebFormat Enumeration
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► ZedGraphWeb..::ZedGraphWebFormat
An enumeration type that defines the output image types supported by the ZedGraph Web control.
Declaration Syntax
C# Visual Basic Visual C++
public enum ZedGraphWebFormat
Public Enumeration ZedGraphWebFormat
public enum class ZedGraphWebFormat
Members
Member | Description
Gif | The Gif bitmap format (CompuServe)
Jpeg | The JPEG format
Icon | A windows Icon format
Png | The portable network graphics format

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebArrowObj Class

ZedGraphWebArrowObj Class
Namespaces ► ZedGraph.Web ► ZedGraphWebArrowObj
Baseclass for graph items in the web control GraphObj
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebArrowObj : ZedGraphWebGraphObj
Public Class ZedGraphWebArrowObj _
    Inherits ZedGraphWebGraphObj
public ref class ZedGraphWebArrowObj : public ZedGraphWebGraphObj
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebArrowObjZedGraphWebArrowObjNew()() | Default constructor
 | Color | Proxy property that gets or sets the value of Color.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsArrowHead | Proxy property that gets or sets the value of IsArrowHead.
 | IsVisible | Proxy property that gets or sets the value of IsVisible (Inherited from ZedGraphWebGraphObj.)
 | Location | Proxy property that gets or sets the value of Location (Inherited from ZedGraphWebGraphObj.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PenWidth | Proxy property that gets or sets the value of Width.
 | Size | Proxy property that gets or sets the value of Size.
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Identifies curve item by the labels value (Overrides ZedGraphWebGraphObj.ToString()().)
 | ZOrder | Proxy property that gets or sets the value of ZOrder (Inherited from ZedGraphWebGraphObj.)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebGraphObj
 |  |  | ZedGraphWebArrowObj
See Also
GraphObj

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebArrowObj Constructor

ZedGraphWebArrowObj Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebArrowObj ► ZedGraphWebArrowObjZedGraphWebArrowObjNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebArrowObj()
Public Sub New
public:
ZedGraphWebArrowObj ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Color Property

Color Property
Namespaces ► ZedGraph.Web ► ZedGraphWebArrowObj ► Color
Proxy property that gets or sets the value of Color.
Declaration Syntax
C# Visual Basic Visual C++
public Color Color{ get; set;}
Public Property Color As Color
public:
property Color Color {
    Color get ();
    void set (Color value);
}
Remarks
The Color value used to draw the ArrowObj.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsArrowHead Property

IsArrowHead Property
Namespaces ► ZedGraph.Web ► ZedGraphWebArrowObj ► IsArrowHead
Proxy property that gets or sets the value of IsArrowHead.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsArrowHead{ get; set;}
Public Property IsArrowHead As Boolean
public:
property bool IsArrowHead {
    bool get ();
    void set (bool value);
}
Remarks
Determines whether or not an arrowhead will be draw. If false, only a line segment will be drawn.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


PenWidth Property

PenWidth Property
Namespaces ► ZedGraph.Web ► ZedGraphWebArrowObj ► PenWidth
Proxy property that gets or sets the value of Width.
Declaration Syntax
C# Visual Basic Visual C++
public float PenWidth{ get; set;}
Public Property PenWidth As Single
public:
property float PenWidth {
    float get ();
    void set (float value);
}
Remarks
The width of the pen, expressed in points (1/72nd inch), used to draw the arrow line segment.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Size Property

Size Property
Namespaces ► ZedGraph.Web ► ZedGraphWebArrowObj ► Size
Proxy property that gets or sets the value of Size.
Declaration Syntax
C# Visual Basic Visual C++
public float Size{ get; set;}
Public Property Size As Single
public:
property float Size {
    float get ();
    void set (float value);
}
Remarks
The size of the arrowhead, expressed in points (1/72nd inch).

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebArrowObj ► ToString()()
Identifies curve item by the labels value
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebAxis Class

ZedGraphWebAxis Class
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis
Web control state management class for a Axis object
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebAxis : GenericItem
Public Class ZedGraphWebAxis _
    Inherits GenericItem
public ref class ZedGraphWebAxis : public GenericItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebAxisZedGraphWebAxisNew()() | Default constructor
 | AxisColor | Proxy property that gets or sets the value of Color.
 | Cross | Proxy property that gets or sets the value of Cross.
 | CrossAuto | Proxy property that gets or sets the value of CrossAuto.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontSpec | Proxy property that gets or sets the value of Title FontSpec.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsOmitMag | Proxy property that gets or sets the value of IsOmitMag.
 | IsPreventLabelOverlap | Proxy property that gets or sets the value of IsPreventLabelOverlap.
 | IsShowTitle | Proxy property that gets or sets the value of Title IsVisible.
 | IsTicsBetweenLabels | Proxy property that gets or sets the value of IsBetweenLabels.
 | IsUseTenPower | Proxy property that gets or sets the value of IsUseTenPower.
 | IsVisible | Proxy property that gets or sets the value of IsVisible.
 | IsZeroLine | Proxy property that gets or sets the value of IsZeroLine.
 | MajorGrid | Proxy property to get or set the values for the GraphPane major grid.
 | MajorTic | Proxy property to get or set the values for the GraphPane major tics.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinorGrid | Proxy property to get or set the values for the GraphPane minor grid.
 | MinorTic | Proxy property to get or set the values for the GraphPane minor tics.
 | MinSpace | Proxy property that gets or sets the value of MinSpace.
 | Scale | Proxy property to get or set the values for the axis scale.
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | Title | Proxy property that gets or sets the value of Title.
 | ToString()() | Identifies Axis by the Title value (Overrides Object.ToString()().)
 | Type | Proxy property that gets or sets the value of Type.
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebAxis
 |  |  | ZedGraphWebXAxis
 |  |  | ZedGraphWebYAxis
 |  |  | ZedGraphWebY2Axis

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebAxis Constructor

ZedGraphWebAxis Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► ZedGraphWebAxisZedGraphWebAxisNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebAxis()
Public Sub New
public:
ZedGraphWebAxis ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


AxisColor Property

AxisColor Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► AxisColor
Proxy property that gets or sets the value of Color.
Declaration Syntax
C# Visual Basic Visual C++
public Color AxisColor{ get; set;}
Public Property AxisColor As Color
public:
property Color AxisColor {
    Color get ();
    void set (Color value);
}
Remarks
This affects only the grid lines, since the Title and Scale both have their own color specification.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Cross Property

Cross Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► Cross
Proxy property that gets or sets the value of Cross.
Declaration Syntax
C# Visual Basic Visual C++
public double Cross{ get; set;}
Public Property Cross As Double
public:
property double Cross {
    double get ();
    void set (double value);
}
Value
The value is defined in user scale units
Remarks
This property allows the axis to be shifted away from its default location. For example, for a graph with an X range from -100 to +100, the Y Axis can be located at the X=0 value rather than the left edge of the ChartRect. This value can be set automatically based on the state of CrossAuto. If this value is set manually, then CrossAuto will also be set to false. The "other" axis is the axis the handles the second dimension for the graph. For the XAxis, the "other" axis is the YAxis. For the YAxis or Y2Axis, the "other" axis is the XAxis.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


CrossAuto Property

CrossAuto Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► CrossAuto
Proxy property that gets or sets the value of CrossAuto.
Declaration Syntax
C# Visual Basic Visual C++
public bool CrossAuto{ get; set;}
Public Property CrossAuto As Boolean
public:
property bool CrossAuto {
    bool get ();
    void set (bool value);
}
Remarks
Determines whether or not the axis intersection point Cross is set automatically.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


FontSpec Property

FontSpec Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► FontSpec
Proxy property that gets or sets the value of Title FontSpec.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebFontSpec FontSpec{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property FontSpec As ZedGraphWebFontSpec
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebFontSpec^ FontSpec {
    ZedGraphWebFontSpec^ get ();
}
Remarks
Gets a reference to the FontSpec class used to render the Title

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsOmitMag Property

IsOmitMag Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► IsOmitMag
Proxy property that gets or sets the value of IsOmitMag.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOmitMag{ get; set;}
Public Property IsOmitMag As Boolean
public:
property bool IsOmitMag {
    bool get ();
    void set (bool value);
}
Remarks
This property controls whether or not the magnitude factor (power of 10) for this scale will be included in the label. For large scale values, a "magnitude" value (power of 10) is automatically used for scaling the graph. This magnitude value is automatically appended to the end of the Axis Title (e.g., "(10^4)") to indicate that a magnitude is in use. This property controls whether or not the magnitude is included in the title. Note that it only affects the axis title; a magnitude value may still be used even if it is not shown in the title.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsPreventLabelOverlap Property

IsPreventLabelOverlap Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► IsPreventLabelOverlap
Proxy property that gets or sets the value of IsPreventLabelOverlap.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsPreventLabelOverlap{ get; set;}
Public Property IsPreventLabelOverlap As Boolean
public:
property bool IsPreventLabelOverlap {
    bool get ();
    void set (bool value);
}
Remarks
This Boolean value determines if ZedGraph will check to see if the Axis scale labels are close enough to overlap. If so, ZedGraph will adjust the step size to prevent overlap.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsShowTitle Property

IsShowTitle Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► IsShowTitle
Proxy property that gets or sets the value of Title IsVisible.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsShowTitle{ get; set;}
Public Property IsShowTitle As Boolean
public:
property bool IsShowTitle {
    bool get ();
    void set (bool value);
}
Remarks
Determines whether or not the Axis Title will be displayed.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsTicsBetweenLabels Property

IsTicsBetweenLabels Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► IsTicsBetweenLabels
Proxy property that gets or sets the value of IsBetweenLabels.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTicsBetweenLabels{ get; set;}
Public Property IsTicsBetweenLabels As Boolean
public:
property bool IsTicsBetweenLabels {
    bool get ();
    void set (bool value);
}
Remarks
This property determines whether or not the major tics will be drawn inbetween the labels, rather than right at the labels. Note that this setting is only applicable if Type = Text.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsUseTenPower Property

IsUseTenPower Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► IsUseTenPower
Proxy property that gets or sets the value of IsUseTenPower.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUseTenPower{ get; set;}
Public Property IsUseTenPower As Boolean
public:
property bool IsUseTenPower {
    bool get ();
    void set (bool value);
}
Remarks
Determines if powers-of-ten notation will be used for the numeric value labels.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► IsVisible
Proxy property that gets or sets the value of IsVisible.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
Remarks
Determines whether or not the Axis is shown.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsZeroLine Property

IsZeroLine Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► IsZeroLine
Proxy property that gets or sets the value of IsZeroLine.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsZeroLine{ get; set;}
Public Property IsZeroLine As Boolean
public:
property bool IsZeroLine {
    bool get ();
    void set (bool value);
}
Remarks
This boolean value determines if a line will be drawn at the zero value for the axis.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MajorGrid Property

MajorGrid Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► MajorGrid
Proxy property to get or set the values for the GraphPane major grid.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebGrid MajorGrid{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property MajorGrid As ZedGraphWebGrid
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebGrid^ MajorGrid {
    ZedGraphWebGrid^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MajorTic Property

MajorTic Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► MajorTic
Proxy property to get or set the values for the GraphPane major tics.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebTic MajorTic{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property MajorTic As ZedGraphWebTic
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebTic^ MajorTic {
    ZedGraphWebTic^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MinorGrid Property

MinorGrid Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► MinorGrid
Proxy property to get or set the values for the GraphPane minor grid.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebGrid MinorGrid{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property MinorGrid As ZedGraphWebGrid
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebGrid^ MinorGrid {
    ZedGraphWebGrid^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MinorTic Property

MinorTic Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► MinorTic
Proxy property to get or set the values for the GraphPane minor tics.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebTic MinorTic{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property MinorTic As ZedGraphWebTic
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebTic^ MinorTic {
    ZedGraphWebTic^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MinSpace Property

MinSpace Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► MinSpace
Proxy property that gets or sets the value of MinSpace.
Declaration Syntax
C# Visual Basic Visual C++
public float MinSpace{ get; set;}
Public Property MinSpace As Single
public:
property float MinSpace {
    float get ();
    void set (float value);
}
Remarks
This is the minimum axis space allocation. This term, expressed in points (1/72 inch) and scaled according to CalcScaleFactor()() for the GraphPane, determines the minimum amount of space an axis must have between the Rect and the Rect. This minimum space applies whether IsVisible is true or false.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Scale Property

Scale Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► Scale
Proxy property to get or set the values for the axis scale.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebScale Scale{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Scale As ZedGraphWebScale
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebScale^ Scale {
    ZedGraphWebScale^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Title Property

Title Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► Title
Proxy property that gets or sets the value of Title.
Declaration Syntax
C# Visual Basic Visual C++
public string Title{ get; set;}
Public Property Title As String
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}
Remarks
The title normally shows the basis and dimensions of the scale range, such as "Time (Years)". The title is only shown if the IsVisible property is set to true. If the Title text is empty, then no title is shown, and no space is "reserved" for the title on the graph.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► ToString()()
Identifies Axis by the Title value
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
A string containing "Axis: title", where 'title' is the Title property of the Axis

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Type Property

Type Property
Namespaces ► ZedGraph.Web ► ZedGraphWebAxis ► Type
Proxy property that gets or sets the value of Type.
Declaration Syntax
C# Visual Basic Visual C++
public AxisType Type{ get; set;}
Public Property Type As AxisType
public:
property AxisType Type {
    AxisType get ();
    void set (AxisType value);
}
Remarks
Determines the AxisType for this Axis. The type can be either Linear, Log, Date, or Text.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebBarItem Class

ZedGraphWebBarItem Class
Namespaces ► ZedGraph.Web ► ZedGraphWebBarItem
Web control state management class for a BarItem class
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebBarItem : ZedGraphWebCurveItem
Public Class ZedGraphWebBarItem _
    Inherits ZedGraphWebCurveItem
public ref class ZedGraphWebBarItem : public ZedGraphWebCurveItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebBarItemZedGraphWebBarItemNew()() | Default Constructor
 | Border | Proxy property that gets or sets the ZedGraphWebBorder object for this BarItem.
 | Color | Proxy property that gets or sets the value of Color. (Inherited from ZedGraphWebCurveItem.)
 | CreateInPane(GraphPane, PointPairList) | Creates a new CurveItem using the PointPairList and add it the the given pane. (Overrides ZedGraphWebCurveItem.CreateInPane(GraphPane, PointPairList).)
 | DataMember | The String name of the data member that contains the data to be bound to this CurveItem. (Inherited from ZedGraphWebCurveItem.)
 | DataSource | The object reference that points to a data source from which to bind curve data. (Inherited from ZedGraphWebCurveItem.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Proxy property that gets or sets the ZedGraphWebFill object for this BarItem.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsLegendLabelVisible | Proxy property that gets or sets the value of Label.IsVisible. (Inherited from ZedGraphWebCurveItem.)
 | IsVisible | Proxy property that gets or sets the value of IsVisible. (Inherited from ZedGraphWebCurveItem.)
 | IsY2Axis | Proxy property that gets or sets the value of IsY2Axis. (Inherited from ZedGraphWebCurveItem.)
 | Label | Proxy property that gets or sets the value of Label. (Inherited from ZedGraphWebCurveItem.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Points | Proxy property that gets the value of the Points. (Inherited from ZedGraphWebCurveItem.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Identifies BarItem by the labels value (Overrides ZedGraphWebCurveItem.ToString()().)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebCurveItem
 |  |  | ZedGraphWebBarItem

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebBarItem Constructor

ZedGraphWebBarItem Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebBarItem ► ZedGraphWebBarItemZedGraphWebBarItemNew()()
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebBarItem()
Public Sub New
public:
ZedGraphWebBarItem ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Border Property

Border Property
Namespaces ► ZedGraph.Web ► ZedGraphWebBarItem ► Border
Proxy property that gets or sets the ZedGraphWebBorder object for this BarItem.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebBorder Border{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Border As ZedGraphWebBorder
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebBorder^ Border {
    ZedGraphWebBorder^ get ();
}
See Also
Border

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


CreateInPane Method (pane, points)

CreateInPane Method (pane, points)
Namespaces ► ZedGraph.Web ► ZedGraphWebBarItem ► CreateInPane(GraphPane, PointPairList)
Creates a new CurveItem using the PointPairList and add it the the given pane.
Declaration Syntax
C# Visual Basic Visual C++
public override CurveItem CreateInPane(
    GraphPane pane,
    PointPairList points
)
Public Overrides Function CreateInPane ( _
    pane As GraphPane, _
    points As PointPairList _
) As CurveItem
public:
virtual CurveItem^ CreateInPane (
    GraphPane^ pane,
    PointPairList^ points
) override
Parameters
pane (GraphPane)
the GraphPane object to which to add the new curve
points (PointPairList)
a PointPairList collection defining the points for this curve
Return Value
the newly created CurveItem added to the given GraphPane
Remarks
This method must be overriden by childs

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Fill Property

Fill Property
Namespaces ► ZedGraph.Web ► ZedGraphWebBarItem ► Fill
Proxy property that gets or sets the ZedGraphWebFill object for this BarItem.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebFill Fill{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Fill As ZedGraphWebFill
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebFill^ Fill {
    ZedGraphWebFill^ get ();
}
See Also
Fill

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebBarItem ► ToString()()
Identifies BarItem by the labels value
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
A string containing "BarItem: label", where 'label' is the Label property of the CurveItem

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebBorder Class

ZedGraphWebBorder Class
Namespaces ► ZedGraph.Web ► ZedGraphWebBorder
Web control state management class for a Border object.
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebBorder : GenericItem
Public Class ZedGraphWebBorder _
    Inherits GenericItem
public ref class ZedGraphWebBorder : public GenericItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebBorderZedGraphWebBorderNew()() |
 | Color | Proxy property that gets or sets the value of Color.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | InflateFactor | Proxy property that gets or sets the value of InflateFactor.
 | IsVisible | Proxy property that gets or sets the value of IsVisible.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Override ToString function (Overrides Object.ToString()().)
 | Width | Proxy property that gets or sets the value of Width.
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebBorder
 |  |  | ZedGraphWebBorder2

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebBorder Constructor

ZedGraphWebBorder Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebBorder ► ZedGraphWebBorderZedGraphWebBorderNew()()
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebBorder()
Public Sub New
public:
ZedGraphWebBorder ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Color Property

Color Property
Namespaces ► ZedGraph.Web ► ZedGraphWebBorder ► Color
Proxy property that gets or sets the value of Color.
Declaration Syntax
C# Visual Basic Visual C++
public Color Color{ get; set;}
Public Property Color As Color
public:
property Color Color {
    Color get ();
    void set (Color value);
}
Remarks
Determines the Color of the Pen used to draw this Border.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


InflateFactor Property

InflateFactor Property
Namespaces ► ZedGraph.Web ► ZedGraphWebBorder ► InflateFactor
Proxy property that gets or sets the value of InflateFactor.
Declaration Syntax
C# Visual Basic Visual C++
public float InflateFactor{ get; set;}
Public Property InflateFactor As Single
public:
property float InflateFactor {
    float get ();
    void set (float value);
}
Remarks
Gets or sets the amount of inflation to be done on the rectangle before rendering.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph.Web ► ZedGraphWebBorder ► IsVisible
Proxy property that gets or sets the value of IsVisible.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
Remarks
Determines whether or not the Border will be drawn. true to draw the Border, false otherwise.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebBorder ► ToString()()
Override ToString function
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
Always returns "Border"

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Width Property

Width Property
Namespaces ► ZedGraph.Web ► ZedGraphWebBorder ► Width
Proxy property that gets or sets the value of Width.
Declaration Syntax
C# Visual Basic Visual C++
public float Width{ get; set;}
Public Property Width As Single
public:
property float Width {
    float get ();
    void set (float value);
}
Remarks
Gets or sets the width, in points (1/72 inch), of the Pen used to draw this Border.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebBorder2 Class

ZedGraphWebBorder2 Class
Namespaces ► ZedGraph.Web ► ZedGraphWebBorder2
Todo: idem ZedGraphWebFill2
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebBorder2 : ZedGraphWebBorder
Public Class ZedGraphWebBorder2 _
    Inherits ZedGraphWebBorder
public ref class ZedGraphWebBorder2 : public ZedGraphWebBorder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebBorder2ZedGraphWebBorder2New()() | Default constructor
 | Color | Proxy property that gets or sets the value of Color. (Inherited from ZedGraphWebBorder.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | InflateFactor | Proxy property that gets or sets the value of InflateFactor. (Inherited from ZedGraphWebBorder.)
 | IsVisible | Proxy property that gets or sets the value of IsVisible. (Inherited from ZedGraphWebBorder.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Override ToString function (Inherited from ZedGraphWebBorder.)
 | Width | Proxy property that gets or sets the value of Width. (Inherited from ZedGraphWebBorder.)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebBorder
 |  |  | ZedGraphWebBorder2

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebBorder2 Constructor

ZedGraphWebBorder2 Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebBorder2 ► ZedGraphWebBorder2ZedGraphWebBorder2New()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebBorder2()
Public Sub New
public:
ZedGraphWebBorder2 ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebBoxObj Class

ZedGraphWebBoxObj Class
Namespaces ► ZedGraph.Web ► ZedGraphWebBoxObj
Baseclass for graph items in the web control GraphObj
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebBoxObj : ZedGraphWebGraphObj
Public Class ZedGraphWebBoxObj _
    Inherits ZedGraphWebGraphObj
public ref class ZedGraphWebBoxObj : public ZedGraphWebGraphObj
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebBoxObjZedGraphWebBoxObjNew()() | Default constructor
 | Border | Proxy property that gets or sets the ZedGraphWebBorder object for this BarItem.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Proxy property that gets or sets the ZedGraphWebFill object for this BarItem.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible | Proxy property that gets or sets the value of IsVisible (Inherited from ZedGraphWebGraphObj.)
 | Location | Proxy property that gets or sets the value of Location (Inherited from ZedGraphWebGraphObj.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Identifies curve item by the labels value (Overrides ZedGraphWebGraphObj.ToString()().)
 | ZOrder | Proxy property that gets or sets the value of ZOrder (Inherited from ZedGraphWebGraphObj.)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebGraphObj
 |  |  | ZedGraphWebBoxObj
See Also
GraphObj

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebBoxObj Constructor

ZedGraphWebBoxObj Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebBoxObj ► ZedGraphWebBoxObjZedGraphWebBoxObjNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebBoxObj()
Public Sub New
public:
ZedGraphWebBoxObj ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Border Property

Border Property
Namespaces ► ZedGraph.Web ► ZedGraphWebBoxObj ► Border
Proxy property that gets or sets the ZedGraphWebBorder object for this BarItem.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebBorder Border{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Border As ZedGraphWebBorder
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebBorder^ Border {
    ZedGraphWebBorder^ get ();
}
See Also
Border

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Fill Property

Fill Property
Namespaces ► ZedGraph.Web ► ZedGraphWebBoxObj ► Fill
Proxy property that gets or sets the ZedGraphWebFill object for this BarItem.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebFill Fill{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Fill As ZedGraphWebFill
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebFill^ Fill {
    ZedGraphWebFill^ get ();
}
See Also
Fill

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebBoxObj ► ToString()()
Identifies curve item by the labels value
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebControlEventHandler Delegate

ZedGraphWebControlEventHandler Delegate
Namespaces ► ZedGraph.Web ► ZedGraphWebControlEventHandler
A delegate to handle the rendering event for this control.
Declaration Syntax
C# Visual Basic Visual C++
public delegate void ZedGraphWebControlEventHandler(
    ZedGraphWeb webObject,
    Graphics g,
    MasterPane pane
)
Public Delegate Sub ZedGraphWebControlEventHandler ( _
    webObject As ZedGraphWeb, _
    g As Graphics, _
    pane As MasterPane _
)
public delegate void ZedGraphWebControlEventHandler (
    ZedGraphWeb^ webObject,
    Graphics^ g,
    MasterPane^ pane
)
Parameters
webObject (ZedGraphWeb)
A reference to this ZedGraphWeb object
g (Graphics)
A Graphics object for which the drawing will be done.
pane (MasterPane)
A reference to the GraphPane class to be rendered.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebCurveCollection Class

ZedGraphWebCurveCollection Class
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveCollection
Manages a collection of ZedGraphWebCurveItem objects that are state management aware.
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebCurveCollection : GenericCollection
Public Class ZedGraphWebCurveCollection _
    Inherits GenericCollection
public ref class ZedGraphWebCurveCollection : public GenericCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebCurveCollectionZedGraphWebCurveCollectionNew()() | Default constructor
 | Add(ZedGraphWebCurveItem) | Add a ZedGraphWebCurveItem to this collection.
 | Clear()() | Empty the array list and marks the viewstate. (Inherited from GenericCollection.)
 | CopyTo(Array, Int32) | CopyTo(Array, Int32) (Inherited from GenericCollection.)
 | Count | Count (Inherited from GenericCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()() | GetEnumerator()() (Inherited from GenericCollection.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | IsSynchronized (Inherited from GenericCollection.)
 | Item[([Int32])] | Indexer to access the specified ZedGraphWebCurveItem object by its ordinal position in the list.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SyncRoot | SyncRoot (Inherited from GenericCollection.)
 | IList..::Add(Object) | Adds item based on the rules of ListAdd Add(Object) ListAdd(Object) (Inherited from GenericCollection.)
 | IList..::Clear()() | Clear()() (Inherited from GenericCollection.)
 | IList..::Contains(Object) | Contains(Object) (Inherited from GenericCollection.)
 | IList..::IndexOf(Object) | IndexOf(Object) (Inherited from GenericCollection.)
 | IList..::Insert(Int32, Object) | Inserts item according to the rules of ListInsert Insert(Int32, Object) ListInsert(Int32, Object) (Inherited from GenericCollection.)
 | IList..::IsFixedSize | IsFixedSize (Inherited from GenericCollection.)
 | IList..::IsReadOnly | IsReadOnly (Inherited from GenericCollection.)
 | IList..::Item[([Int32])] | Privately implement those members of IList that take or return the object type and expose equivalent public members that take or return an item instance instead. Also implement privately those members of IList that are not meaninful to expose in the public object model of this Collection. (Inherited from GenericCollection.)
 | IList..::Remove(Object) | Removes item based on ListRemove Remove(Object) ListRemove(Object) (Inherited from GenericCollection.)
 | IList..::RemoveAt(Int32) | Removes item based on RemoveAt RemoveAt(Int32) RemoveAt(Int32) (Inherited from GenericCollection.)
 | IStateManager..::IsTrackingViewState | IsTrackingViewState (Inherited from GenericCollection.)
 | IStateManager..::LoadViewState(Object) | Loads the view state. This involves reading each state item pair, verifying schema support for each datatype, creating each item instance, and loading the state into each newly created instance. LoadViewState(Object) (Inherited from GenericCollection.)
 | IStateManager..::SaveViewState()() | Saves the viewstate into a portable object format. This involves saving the state of each item in the list. SaveViewState()() (Inherited from GenericCollection.)
 | IStateManager..::TrackViewState()() | TrackViewState()() (Inherited from GenericCollection.)
 | ToString()() | Override the ToString() method. (Overrides Object.ToString()().)
Inheritance Hierarchy
Object
 | GenericCollection
 |  | ZedGraphWebCurveCollection

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebCurveCollection Constructor

ZedGraphWebCurveCollection Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveCollection ► ZedGraphWebCurveCollectionZedGraphWebCurveCollectionNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebCurveCollection()
Public Sub New
public:
ZedGraphWebCurveCollection ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Add Method (item)

Add Method (item)
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveCollection ► Add(ZedGraphWebCurveItem)
Add a ZedGraphWebCurveItem to this collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    ZedGraphWebCurveItem item
)
Public Sub Add ( _
    item As ZedGraphWebCurveItem _
)
public:
void Add (
    ZedGraphWebCurveItem^ item
)
Parameters
item (ZedGraphWebCurveItem)
The ZedGraphWebCurveItem to be added.
See Also
CurveItem

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveCollection ► Item[([Int32])]
Indexer to access the specified ZedGraphWebCurveItem object by its ordinal position in the list.
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebCurveItem this[
    int index
]{ get; set;}
Public Default Property Item ( _
    index As Integer _
) As ZedGraphWebCurveItem
public:
property ZedGraphWebCurveItem^ default[int index] {
    ZedGraphWebCurveItem^ get (int index);
    void set (int index, ZedGraphWebCurveItem^ value);
}
Parameters
index (Int32)
The ordinal position (zero-based) of the ZedGraphWebCurveItem object to be accessed.
Value
A ZedGraphWebCurveItem object reference.
See Also
CurveItem

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveCollection ► ToString()()
Override the ToString() method.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
Always returns String.Empty

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebCurveItem Class

ZedGraphWebCurveItem Class
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveItem
Base class for curve items in the web control CurveItem
Declaration Syntax
C# Visual Basic Visual C++
[DefaultPropertyAttribute("Label")]
public abstract class ZedGraphWebCurveItem : GenericItem
<DefaultPropertyAttribute("Label")> _
Public MustInherit Class ZedGraphWebCurveItem _
    Inherits GenericItem
[DefaultPropertyAttribute(L"Label")]
public ref class ZedGraphWebCurveItem abstract : public GenericItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebCurveItemZedGraphWebCurveItemNew()() | Default constructor
 | ZedGraphWebCurveItemZedGraphWebCurveItemNew(String) | Constructor that accepts a default label value
 | Color | Proxy property that gets or sets the value of Color.
 | CreateInPane(GraphPane, PointPairList) | Creates a new CurveItem using the PointPairList and add it the the given pane.
 | DataMember | The String name of the data member that contains the data to be bound to this CurveItem.
 | DataSource | The object reference that points to a data source from which to bind curve data.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsLegendLabelVisible | Proxy property that gets or sets the value of Label.IsVisible.
 | IsVisible | Proxy property that gets or sets the value of IsVisible.
 | IsY2Axis | Proxy property that gets or sets the value of IsY2Axis.
 | Label | Proxy property that gets or sets the value of Label.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Points | Proxy property that gets the value of the Points.
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Identifies curve item by the labels value (Overrides Object.ToString()().)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebCurveItem
 |  |  | ZedGraphWebBarItem
 |  |  | ZedGraphWebErrorBarItem
 |  |  | ZedGraphWebHiLowBarItem
 |  |  | ZedGraphWebLineItem
 |  |  | ZedGraphWebPieItem
See Also
CurveItem

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebCurveItem Constructor

ZedGraphWebCurveItem Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveItem ► ZedGraphWebCurveItemZedGraphWebCurveItemNew()()
Members
Icon | Member | Description
 | ZedGraphWebCurveItemZedGraphWebCurveItemNew()() | Default constructor
 | ZedGraphWebCurveItemZedGraphWebCurveItemNew(String) | Constructor that accepts a default label value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebCurveItem Constructor

ZedGraphWebCurveItem Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveItem ► ZedGraphWebCurveItemZedGraphWebCurveItemNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebCurveItem()
Public Sub New
public:
ZedGraphWebCurveItem ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebCurveItem Constructor (label)

ZedGraphWebCurveItem Constructor (label)
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveItem ► ZedGraphWebCurveItemZedGraphWebCurveItemNew(String)
Constructor that accepts a default label value
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebCurveItem(
    string label
)
Public Sub New ( _
    label As String _
)
public:
ZedGraphWebCurveItem (
    String^ label
)
Parameters
label (String)
Curve item label

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Color Property

Color Property
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveItem ► Color
Proxy property that gets or sets the value of Color.
Declaration Syntax
C# Visual Basic Visual C++
public Color Color{ get; set;}
Public Property Color As Color
public:
property Color Color {
    Color get ();
    void set (Color value);
}
Remarks
The Line/Symbol/Bar color (FillColor for the Bar). This is a common access to Line.Color, Border.Color, and Color properties for this curve
See Also
Color

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


CreateInPane Method (pane, points)

CreateInPane Method (pane, points)
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveItem ► CreateInPane(GraphPane, PointPairList)
Creates a new CurveItem using the PointPairList and add it the the given pane.
Declaration Syntax
C# Visual Basic Visual C++
public abstract CurveItem CreateInPane(
    GraphPane pane,
    PointPairList points
)
Public MustOverride Function CreateInPane ( _
    pane As GraphPane, _
    points As PointPairList _
) As CurveItem
public:
virtual CurveItem^ CreateInPane (
    GraphPane^ pane,
    PointPairList^ points
) abstract
Parameters
pane (GraphPane)
the GraphPane object to which to add the new curve
points (PointPairList)
a PointPairList collection defining the points for this curve
Return Value
the newly created CurveItem added to the given GraphPane
Remarks
This method must be overriden by childs

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


DataMember Property

DataMember Property
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveItem ► DataMember
The String name of the data member that contains the data to be bound to this CurveItem.
Declaration Syntax
C# Visual Basic Visual C++
public string DataMember{ get; set;}
Public Property DataMember As String
public:
property String^ DataMember {
    String^ get ();
    void set (String^ value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


DataSource Property

DataSource Property
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveItem ► DataSource
The object reference that points to a data source from which to bind curve data.
Declaration Syntax
C# Visual Basic Visual C++
[BindableAttribute(true)]
public Object DataSource{ get; set;}
<BindableAttribute(True)> _
Public Property DataSource As Object
[BindableAttribute(true)]
public:
property Object^ DataSource {
    Object^ get ();
    void set (Object^ value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsLegendLabelVisible Property

IsLegendLabelVisible Property
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveItem ► IsLegendLabelVisible
Proxy property that gets or sets the value of Label.IsVisible.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLegendLabelVisible{ get; set;}
Public Property IsLegendLabelVisible As Boolean
public:
property bool IsLegendLabelVisible {
    bool get ();
    void set (bool value);
}
Remarks
Determines whether the label for this CurveItem is visible in the legend. Note that this value turns the legend entry display on or off, but it does not affect the display of the curve on the graph. To hide the curve, you have to set IsVisible to false.
See Also
Label.IsVisible
IsVisible
Label.IsVisible

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveItem ► IsVisible
Proxy property that gets or sets the value of IsVisible.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
Remarks
Determines whether the CurveItem is visible on the graph. Note that this value turns the curve display on or off, but it does not affect the display of the legend entry. To hide the legend entry, you have to set IsLegendLabelVisible to false.
See Also
CurveItem.IsVisible
Label.IsVisible

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsY2Axis Property

IsY2Axis Property
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveItem ► IsY2Axis
Proxy property that gets or sets the value of IsY2Axis.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsY2Axis{ get; set;}
Public Property IsY2Axis As Boolean
public:
property bool IsY2Axis {
    bool get ();
    void set (bool value);
}
Remarks
Determines which Y axis this CurveItem is assigned to. The YAxis is on the left side of the graph and the Y2Axis is on the right side. Assignment to an axis determines the scale that is used to draw the curve on the graph.
See Also
IsY2Axis

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Label Property

Label Property
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveItem ► Label
Proxy property that gets or sets the value of Label.
Declaration Syntax
C# Visual Basic Visual C++
public string Label{ get; set;}
Public Property Label As String
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}
Remarks
A text string that represents the Legend entry for the the CurveItem object.
See Also
Label

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Points Property

Points Property
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveItem ► Points
Proxy property that gets the value of the Points.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebPointPairCollection Points{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Points As ZedGraphWebPointPairCollection
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebPointPairCollection^ Points {
    ZedGraphWebPointPairCollection^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebCurveItem ► ToString()()
Identifies curve item by the labels value
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
A string containing "CurveItem: label", where 'label' is the Label property of the CurveItem

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebEllipseObj Class

ZedGraphWebEllipseObj Class
Namespaces ► ZedGraph.Web ► ZedGraphWebEllipseObj
Baseclass for graph items in the web control GraphObj
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebEllipseObj : ZedGraphWebGraphObj
Public Class ZedGraphWebEllipseObj _
    Inherits ZedGraphWebGraphObj
public ref class ZedGraphWebEllipseObj : public ZedGraphWebGraphObj
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebEllipseObjZedGraphWebEllipseObjNew()() | Default constructor
 | Border | Proxy property that gets or sets the ZedGraphWebBorder object for this BarItem.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Proxy property that gets or sets the ZedGraphWebFill object for this BarItem.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible | Proxy property that gets or sets the value of IsVisible (Inherited from ZedGraphWebGraphObj.)
 | Location | Proxy property that gets or sets the value of Location (Inherited from ZedGraphWebGraphObj.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Identifies curve item by the labels value (Overrides ZedGraphWebGraphObj.ToString()().)
 | ZOrder | Proxy property that gets or sets the value of ZOrder (Inherited from ZedGraphWebGraphObj.)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebGraphObj
 |  |  | ZedGraphWebEllipseObj
See Also
GraphObj

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebEllipseObj Constructor

ZedGraphWebEllipseObj Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebEllipseObj ► ZedGraphWebEllipseObjZedGraphWebEllipseObjNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebEllipseObj()
Public Sub New
public:
ZedGraphWebEllipseObj ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Border Property

Border Property
Namespaces ► ZedGraph.Web ► ZedGraphWebEllipseObj ► Border
Proxy property that gets or sets the ZedGraphWebBorder object for this BarItem.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebBorder Border{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Border As ZedGraphWebBorder
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebBorder^ Border {
    ZedGraphWebBorder^ get ();
}
See Also
Border

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Fill Property

Fill Property
Namespaces ► ZedGraph.Web ► ZedGraphWebEllipseObj ► Fill
Proxy property that gets or sets the ZedGraphWebFill object for this BarItem.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebFill Fill{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Fill As ZedGraphWebFill
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebFill^ Fill {
    ZedGraphWebFill^ get ();
}
See Also
Fill

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebEllipseObj ► ToString()()
Identifies curve item by the labels value
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebErrorBarItem Class

ZedGraphWebErrorBarItem Class
Namespaces ► ZedGraph.Web ► ZedGraphWebErrorBarItem
Web control state management class for a ErrorBarItem class
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebErrorBarItem : ZedGraphWebCurveItem
Public Class ZedGraphWebErrorBarItem _
    Inherits ZedGraphWebCurveItem
public ref class ZedGraphWebErrorBarItem : public ZedGraphWebCurveItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebErrorBarItemZedGraphWebErrorBarItemNew()() | Default Constructor
 | Color | Proxy property that gets or sets the value of Color. (Inherited from ZedGraphWebCurveItem.)
 | CreateInPane(GraphPane, PointPairList) | Creates a new CurveItem using the PointPairList and add it the the given pane. (Overrides ZedGraphWebCurveItem.CreateInPane(GraphPane, PointPairList).)
 | DataMember | The String name of the data member that contains the data to be bound to this CurveItem. (Inherited from ZedGraphWebCurveItem.)
 | DataSource | The object reference that points to a data source from which to bind curve data. (Inherited from ZedGraphWebCurveItem.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsLegendLabelVisible | Proxy property that gets or sets the value of Label.IsVisible. (Inherited from ZedGraphWebCurveItem.)
 | IsVisible | Proxy property that gets or sets the value of IsVisible. (Inherited from ZedGraphWebCurveItem.)
 | IsY2Axis | Proxy property that gets or sets the value of IsY2Axis. (Inherited from ZedGraphWebCurveItem.)
 | Label | Proxy property that gets or sets the value of Label. (Inherited from ZedGraphWebCurveItem.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PenWidth | Proxy property that gets or sets the value of PenWidth.
 | Points | Proxy property that gets the value of the Points. (Inherited from ZedGraphWebCurveItem.)
 | Symbol | Proxy property that gets or sets the ZedGraphWebSymbol object for this ErrorBarItem.
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Identifies ErrorBarItem by the labels value (Overrides ZedGraphWebCurveItem.ToString()().)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebCurveItem
 |  |  | ZedGraphWebErrorBarItem

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebErrorBarItem Constructor

ZedGraphWebErrorBarItem Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebErrorBarItem ► ZedGraphWebErrorBarItemZedGraphWebErrorBarItemNew()()
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebErrorBarItem()
Public Sub New
public:
ZedGraphWebErrorBarItem ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


CreateInPane Method (pane, points)

CreateInPane Method (pane, points)
Namespaces ► ZedGraph.Web ► ZedGraphWebErrorBarItem ► CreateInPane(GraphPane, PointPairList)
Creates a new CurveItem using the PointPairList and add it the the given pane.
Declaration Syntax
C# Visual Basic Visual C++
public override CurveItem CreateInPane(
    GraphPane pane,
    PointPairList points
)
Public Overrides Function CreateInPane ( _
    pane As GraphPane, _
    points As PointPairList _
) As CurveItem
public:
virtual CurveItem^ CreateInPane (
    GraphPane^ pane,
    PointPairList^ points
) override
Parameters
pane (GraphPane)
the GraphPane object to which to add the new curve
points (PointPairList)
a PointPairList collection defining the points for this curve
Return Value
the newly created CurveItem added to the given GraphPane
Remarks
This method must be overriden by childs

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


PenWidth Property

PenWidth Property
Namespaces ► ZedGraph.Web ► ZedGraphWebErrorBarItem ► PenWidth
Proxy property that gets or sets the value of PenWidth.
Declaration Syntax
C# Visual Basic Visual C++
public float PenWidth{ get; set;}
Public Property PenWidth As Single
public:
property float PenWidth {
    float get ();
    void set (float value);
}
Remarks
The pen width to be used for drawing error bars Units are points. This property only controls the pen width for the vertical line. The pen width for the symbol outline is controlled separately by the Symbol property.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Symbol Property

Symbol Property
Namespaces ► ZedGraph.Web ► ZedGraphWebErrorBarItem ► Symbol
Proxy property that gets or sets the ZedGraphWebSymbol object for this ErrorBarItem.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebSymbol Symbol{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Symbol As ZedGraphWebSymbol
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebSymbol^ Symbol {
    ZedGraphWebSymbol^ get ();
}
See Also
Symbol

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebErrorBarItem ► ToString()()
Identifies ErrorBarItem by the labels value
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
A string containing "ErrorBarItem: label", where 'label' is the Label property of the CurveItem

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebFill Class

ZedGraphWebFill Class
Namespaces ► ZedGraph.Web ► ZedGraphWebFill
Web control state management class for a Fill object.
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebFill : GenericItem
Public Class ZedGraphWebFill _
    Inherits GenericItem
public ref class ZedGraphWebFill : public GenericItem
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebFillZedGraphWebFillNew()() |
 | AlignH | Proxy property that gets or sets the value of AlignH.
 | AlignV | Proxy property that gets or sets the value of AlignV.
 | Brush | The Brush object associated with this Fill object. Not accessible via webcontrol properties.
 | Color | Proxy property that gets or sets the value of Color.
 | ColorOpacity | Opacity of Color, range from 0 to 100. 100 is opaque, 0 is invisible.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsScaled | Proxy property that gets or sets the value of IsScaled.
 | IsVisible | Proxy property that gets or sets the value of IsVisible.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RangeMax | Proxy property that gets or sets the value of RangeMax.
 | RangeMin | Proxy property that gets or sets the value of RangeMin.
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Override ToString() function (Overrides Object.ToString()().)
 | Type | Proxy property that gets or sets the value of Type.
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebFill
 |  |  | ZedGraphWebFill2

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebFill Constructor

ZedGraphWebFill Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebFill ► ZedGraphWebFillZedGraphWebFillNew()()
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebFill()
Public Sub New
public:
ZedGraphWebFill ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


AlignH Property

AlignH Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFill ► AlignH
Proxy property that gets or sets the value of AlignH.
Declaration Syntax
C# Visual Basic Visual C++
public AlignH AlignH{ get; set;}
Public Property AlignH As AlignH
public:
property AlignH AlignH {
    AlignH get ();
    void set (AlignH value);
}
Remarks
Determines how the brush will be aligned with the filled object in the horizontal direction. This value is a AlignH enumeration. This field only applies if IsScaled is false.
See Also
AlignV

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


AlignV Property

AlignV Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFill ► AlignV
Proxy property that gets or sets the value of AlignV.
Declaration Syntax
C# Visual Basic Visual C++
public AlignV AlignV{ get; set;}
Public Property AlignV As AlignV
public:
property AlignV AlignV {
    AlignV get ();
    void set (AlignV value);
}
Remarks
Determines how the brush will be aligned with the filled object in the vertical direction. This value is a AlignV enumeration. This field only applies if IsScaled is false.
See Also
AlignH

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Brush Field

Brush Field
Namespaces ► ZedGraph.Web ► ZedGraphWebFill ► Brush
The Brush object associated with this Fill object. Not accessible via webcontrol properties.
Declaration Syntax
C# Visual Basic Visual C++
[BrowsableAttribute(false)]
public Brush Brush
<BrowsableAttribute(False)> _
Public Brush As Brush
[BrowsableAttribute(false)]
public:
Brush^ Brush

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Color Property

Color Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFill ► Color
Proxy property that gets or sets the value of Color.
Declaration Syntax
C# Visual Basic Visual C++
public Color Color{ get; set;}
Public Property Color As Color
public:
property Color Color {
    Color get ();
    void set (Color value);
}
Remarks
The fill color. This property is used as a single color to make a solid fill (Type is Solid), or it can be used in combination with White to make a LinearGradientBrush when Type is Brush and Brush is null.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ColorOpacity Property

ColorOpacity Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFill ► ColorOpacity
Opacity of Color, range from 0 to 100. 100 is opaque, 0 is invisible.
Declaration Syntax
C# Visual Basic Visual C++
public float ColorOpacity{ get; set;}
Public Property ColorOpacity As Single
public:
property float ColorOpacity {
    float get ();
    void set (float value);
}
Remarks
To be replaced by a best color designer which enables the selection of a transparency level.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsScaled Property

IsScaled Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFill ► IsScaled
Proxy property that gets or sets the value of IsScaled.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsScaled{ get; set;}
Public Property IsScaled As Boolean
public:
property bool IsScaled {
    bool get ();
    void set (bool value);
}
Remarks
Determines if the brush will be scaled to the bounding box of the filled object. If this value is false, then the brush will only be aligned with the filled object based on the AlignH and AlignV properties.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFill ► IsVisible
Proxy property that gets or sets the value of IsVisible.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
Remarks
This property determines the type of color fill. Returns true if the Type property is either Solid or Brush. If set to true, this property will automatically set the Type to Brush. If set to false, this property will automatically set the Type to None. In order to get a regular solid-color fill, you have to manually set Type to Solid.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


RangeMax Property

RangeMax Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFill ► RangeMax
Proxy property that gets or sets the value of RangeMax.
Declaration Syntax
C# Visual Basic Visual C++
public double RangeMax{ get; set;}
Public Property RangeMax As Double
public:
property double RangeMax {
    double get ();
    void set (double value);
}
Value
A double value, in user scale unit
Remarks
The maximum user-scale value for the gradient-by-value determination. This defines the user-scale value for the end of the gradient.
See Also
GradientByX
GradientByY
GradientByZ
IsGradientValueType

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


RangeMin Property

RangeMin Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFill ► RangeMin
Proxy property that gets or sets the value of RangeMin.
Declaration Syntax
C# Visual Basic Visual C++
public double RangeMin{ get; set;}
Public Property RangeMin As Double
public:
property double RangeMin {
    double get ();
    void set (double value);
}
Value
A double value, in user scale unit
Remarks
The minimum user-scale value for the gradient-by-value determination. This defines the user-scale value for the start of the gradient.
See Also
GradientByX
GradientByY
GradientByZ
IsGradientValueType

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebFill ► ToString()()
Override ToString() function
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
Always returns "Fill"

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Type Property

Type Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFill ► Type
Proxy property that gets or sets the value of Type.
Declaration Syntax
C# Visual Basic Visual C++
public FillType Type{ get; set;}
Public Property Type As FillType
public:
property FillType Type {
    FillType get ();
    void set (FillType value);
}
Remarks
Determines the type of fill, which can be either solid color (Solid) or a custom brush (Brush). See Type for more information.
See Also
Color

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebFill2 Class

ZedGraphWebFill2 Class
Namespaces ► ZedGraph.Web ► ZedGraphWebFill2
TODO: change the vsassist system so different default constructors or initializers can be called, or to be able to know if a the object is already initialized or not (new).
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebFill2 : ZedGraphWebFill
Public Class ZedGraphWebFill2 _
    Inherits ZedGraphWebFill
public ref class ZedGraphWebFill2 : public ZedGraphWebFill
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebFill2ZedGraphWebFill2New()() | Default Constructor
 | AlignH | Proxy property that gets or sets the value of AlignH. (Inherited from ZedGraphWebFill.)
 | AlignV | Proxy property that gets or sets the value of AlignV. (Inherited from ZedGraphWebFill.)
 | Brush | The Brush object associated with this Fill object. Not accessible via webcontrol properties. (Inherited from ZedGraphWebFill.)
 | Color | Proxy property that gets or sets the value of Color. (Inherited from ZedGraphWebFill.)
 | ColorOpacity | Opacity of Color, range from 0 to 100. 100 is opaque, 0 is invisible. (Inherited from ZedGraphWebFill.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsScaled | Proxy property that gets or sets the value of IsScaled. (Inherited from ZedGraphWebFill.)
 | IsVisible | Proxy property that gets or sets the value of IsVisible. (Inherited from ZedGraphWebFill.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RangeMax | Proxy property that gets or sets the value of RangeMax. (Inherited from ZedGraphWebFill.)
 | RangeMin | Proxy property that gets or sets the value of RangeMin. (Inherited from ZedGraphWebFill.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Override ToString() function (Inherited from ZedGraphWebFill.)
 | Type | Proxy property that gets or sets the value of Type. (Inherited from ZedGraphWebFill.)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebFill
 |  |  | ZedGraphWebFill2

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebFill2 Constructor

ZedGraphWebFill2 Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebFill2 ► ZedGraphWebFill2ZedGraphWebFill2New()()
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebFill2()
Public Sub New
public:
ZedGraphWebFill2 ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebFontSpec Class

ZedGraphWebFontSpec Class
Namespaces ► ZedGraph.Web ► ZedGraphWebFontSpec
Web control state management class for a FontSpec object
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebFontSpec : GenericItem
Public Class ZedGraphWebFontSpec _
    Inherits GenericItem
public ref class ZedGraphWebFontSpec : public GenericItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebFontSpecZedGraphWebFontSpecNew()() | Default constructor
 | Angle | Proxy property that gets or sets the value of Angle.
 | Border | Proxy property that gets or sets the ZedGraphWebBorder object for this FontSpec.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Family | Proxy property that gets or sets the value of Family.
 | Fill | Proxy property that gets or sets the ZedGraphWebFill object for this FontSpec.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontColor | Proxy property that gets or sets the value of FontColor.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsBold | Proxy property that gets or sets the value of IsBold.
 | IsItalic | Proxy property that gets or sets the value of IsItalic.
 | IsUnderline | Proxy property that gets or sets the value of IsUnderline.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Size | Proxy property that gets or sets the value of Size.
 | StringAlignment | Proxy property that gets or sets the value of StringAlignment.
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Identifies fontspec instance (Overrides Object.ToString()().)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebFontSpec

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebFontSpec Constructor

ZedGraphWebFontSpec Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebFontSpec ► ZedGraphWebFontSpecZedGraphWebFontSpecNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebFontSpec()
Public Sub New
public:
ZedGraphWebFontSpec ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Angle Property

Angle Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFontSpec ► Angle
Proxy property that gets or sets the value of Angle.
Declaration Syntax
C# Visual Basic Visual C++
public float Angle{ get; set;}
Public Property Angle As Single
public:
property float Angle {
    float get ();
    void set (float value);
}
Value
The angle of the font, measured in anti-clockwise degrees from horizontal. Negative values are permitted.
Remarks
The angle at which this FontSpec object is drawn.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Border Property

Border Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFontSpec ► Border
Proxy property that gets or sets the ZedGraphWebBorder object for this FontSpec.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebBorder Border{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Border As ZedGraphWebBorder
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebBorder^ Border {
    ZedGraphWebBorder^ get ();
}
See Also
Border

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Family Property

Family Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFontSpec ► Family
Proxy property that gets or sets the value of Family.
Declaration Syntax
C# Visual Basic Visual C++
public string Family{ get; set;}
Public Property Family As String
public:
property String^ Family {
    String^ get ();
    void set (String^ value);
}
Value
A text string with the font family name, e.g., "Arial"
Remarks
The font family name for this FontSpec.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Fill Property

Fill Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFontSpec ► Fill
Proxy property that gets or sets the ZedGraphWebFill object for this FontSpec.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebFill Fill{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Fill As ZedGraphWebFill
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebFill^ Fill {
    ZedGraphWebFill^ get ();
}
See Also
Fill

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


FontColor Property

FontColor Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFontSpec ► FontColor
Proxy property that gets or sets the value of FontColor.
Declaration Syntax
C# Visual Basic Visual C++
public Color FontColor{ get; set;}
Public Property FontColor As Color
public:
property Color FontColor {
    Color get ();
    void set (Color value);
}
Value
A system Color reference.
Remarks
The color of the font characters for this FontSpec. Note that the border and background colors are set using the Color and Color properties, respectively.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsBold Property

IsBold Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFontSpec ► IsBold
Proxy property that gets or sets the value of IsBold.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsBold{ get; set;}
Public Property IsBold As Boolean
public:
property bool IsBold {
    bool get ();
    void set (bool value);
}
Value
A boolean value, true for bold, false for normal
Remarks
Determines whether this FontSpec is drawn with bold typeface.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsItalic Property

IsItalic Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFontSpec ► IsItalic
Proxy property that gets or sets the value of IsItalic.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsItalic{ get; set;}
Public Property IsItalic As Boolean
public:
property bool IsItalic {
    bool get ();
    void set (bool value);
}
Value
A boolean value, true for italic, false for normal
Remarks
Determines whether this FontSpec is drawn with an italic typeface.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsUnderline Property

IsUnderline Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFontSpec ► IsUnderline
Proxy property that gets or sets the value of IsUnderline.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsUnderline{ get; set;}
Public Property IsUnderline As Boolean
public:
property bool IsUnderline {
    bool get ();
    void set (bool value);
}
Value
A boolean value, true for underline, false for normal
Remarks
Determines whether this FontSpec is drawn with an underline typeface.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Size Property

Size Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFontSpec ► Size
Proxy property that gets or sets the value of Size.
Declaration Syntax
C# Visual Basic Visual C++
public float Size{ get; set;}
Public Property Size As Single
public:
property float Size {
    float get ();
    void set (float value);
}
Value
The size of the font, measured in points (1/72 inch).
Remarks
The size of the font for this FontSpec object.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


StringAlignment Property

StringAlignment Property
Namespaces ► ZedGraph.Web ► ZedGraphWebFontSpec ► StringAlignment
Proxy property that gets or sets the value of StringAlignment.
Declaration Syntax
C# Visual Basic Visual C++
public StringAlignment StringAlignment{ get; set;}
Public Property StringAlignment As StringAlignment
public:
property StringAlignment StringAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}
Value
A StringAlignment enumeration.
Remarks
Determines the alignment with which this FontSpec object is drawn. This alignment really only affects multi-line strings.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebFontSpec ► ToString()()
Identifies fontspec instance
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
Always returns the string "FontSpec".

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebGraphObj Class

ZedGraphWebGraphObj Class
Namespaces ► ZedGraph.Web ► ZedGraphWebGraphObj
Baseclass for graph items in the web control GraphObj
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebGraphObj : GenericItem
Public Class ZedGraphWebGraphObj _
    Inherits GenericItem
public ref class ZedGraphWebGraphObj : public GenericItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebGraphObjZedGraphWebGraphObjNew()() | Default constructor
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible | Proxy property that gets or sets the value of IsVisible
 | Location | Proxy property that gets or sets the value of Location
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Override the ToString() method. (Overrides Object.ToString()().)
 | ZOrder | Proxy property that gets or sets the value of ZOrder
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebGraphObj
 |  |  | ZedGraphWebTextObj
 |  |  | ZedGraphWebArrowObj
 |  |  | ZedGraphWebImageObj
 |  |  | ZedGraphWebBoxObj
 |  |  | ZedGraphWebEllipseObj
See Also
GraphObj

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebGraphObj Constructor

ZedGraphWebGraphObj Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebGraphObj ► ZedGraphWebGraphObjZedGraphWebGraphObjNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebGraphObj()
Public Sub New
public:
ZedGraphWebGraphObj ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph.Web ► ZedGraphWebGraphObj ► IsVisible
Proxy property that gets or sets the value of IsVisible
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Location Property

Location Property
Namespaces ► ZedGraph.Web ► ZedGraphWebGraphObj ► Location
Proxy property that gets or sets the value of Location
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebLocation Location{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Location As ZedGraphWebLocation
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebLocation^ Location {
    ZedGraphWebLocation^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebGraphObj ► ToString()()
Override the ToString() method.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
Always returns the string "GraphObj".

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZOrder Property

ZOrder Property
Namespaces ► ZedGraph.Web ► ZedGraphWebGraphObj ► ZOrder
Proxy property that gets or sets the value of ZOrder
Declaration Syntax
C# Visual Basic Visual C++
public ZOrder ZOrder{ get; set;}
Public Property ZOrder As ZOrder
public:
property ZOrder ZOrder {
    ZOrder get ();
    void set (ZOrder value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebGraphObjCollection Class

ZedGraphWebGraphObjCollection Class
Namespaces ► ZedGraph.Web ► ZedGraphWebGraphObjCollection
Manages a collection of ZedGraphWebGraphObj objects that are state management aware.
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebGraphObjCollection : GenericCollection
Public Class ZedGraphWebGraphObjCollection _
    Inherits GenericCollection
public ref class ZedGraphWebGraphObjCollection : public GenericCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebGraphObjCollectionZedGraphWebGraphObjCollectionNew()() | Default Constructor
 | Add(ZedGraphWebGraphObj) | Add a ZedGraphWebGraphObj to this collection.
 | Clear()() | Empty the array list and marks the viewstate. (Inherited from GenericCollection.)
 | CopyTo(Array, Int32) | CopyTo(Array, Int32) (Inherited from GenericCollection.)
 | Count | Count (Inherited from GenericCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()() | GetEnumerator()() (Inherited from GenericCollection.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | IsSynchronized (Inherited from GenericCollection.)
 | Item[([Int32])] | Indexer to access the specified ZedGraphWebGraphObj object by its ordinal position in the list.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SyncRoot | SyncRoot (Inherited from GenericCollection.)
 | IList..::Add(Object) | Adds item based on the rules of ListAdd Add(Object) ListAdd(Object) (Inherited from GenericCollection.)
 | IList..::Clear()() | Clear()() (Inherited from GenericCollection.)
 | IList..::Contains(Object) | Contains(Object) (Inherited from GenericCollection.)
 | IList..::IndexOf(Object) | IndexOf(Object) (Inherited from GenericCollection.)
 | IList..::Insert(Int32, Object) | Inserts item according to the rules of ListInsert Insert(Int32, Object) ListInsert(Int32, Object) (Inherited from GenericCollection.)
 | IList..::IsFixedSize | IsFixedSize (Inherited from GenericCollection.)
 | IList..::IsReadOnly | IsReadOnly (Inherited from GenericCollection.)
 | IList..::Item[([Int32])] | Privately implement those members of IList that take or return the object type and expose equivalent public members that take or return an item instance instead. Also implement privately those members of IList that are not meaninful to expose in the public object model of this Collection. (Inherited from GenericCollection.)
 | IList..::Remove(Object) | Removes item based on ListRemove Remove(Object) ListRemove(Object) (Inherited from GenericCollection.)
 | IList..::RemoveAt(Int32) | Removes item based on RemoveAt RemoveAt(Int32) RemoveAt(Int32) (Inherited from GenericCollection.)
 | IStateManager..::IsTrackingViewState | IsTrackingViewState (Inherited from GenericCollection.)
 | IStateManager..::LoadViewState(Object) | Loads the view state. This involves reading each state item pair, verifying schema support for each datatype, creating each item instance, and loading the state into each newly created instance. LoadViewState(Object) (Inherited from GenericCollection.)
 | IStateManager..::SaveViewState()() | Saves the viewstate into a portable object format. This involves saving the state of each item in the list. SaveViewState()() (Inherited from GenericCollection.)
 | IStateManager..::TrackViewState()() | TrackViewState()() (Inherited from GenericCollection.)
 | ToString()() | Override the ToString() method. (Overrides Object.ToString()().)
Inheritance Hierarchy
Object
 | GenericCollection
 |  | ZedGraphWebGraphObjCollection

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebGraphObjCollection Constructor

ZedGraphWebGraphObjCollection Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebGraphObjCollection ► ZedGraphWebGraphObjCollectionZedGraphWebGraphObjCollectionNew()()
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebGraphObjCollection()
Public Sub New
public:
ZedGraphWebGraphObjCollection ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Add Method (item)

Add Method (item)
Namespaces ► ZedGraph.Web ► ZedGraphWebGraphObjCollection ► Add(ZedGraphWebGraphObj)
Add a ZedGraphWebGraphObj to this collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    ZedGraphWebGraphObj item
)
Public Sub Add ( _
    item As ZedGraphWebGraphObj _
)
public:
void Add (
    ZedGraphWebGraphObj^ item
)
Parameters
item (ZedGraphWebGraphObj)
The ZedGraphWebGraphObj to be added.
See Also
GraphObj

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph.Web ► ZedGraphWebGraphObjCollection ► Item[([Int32])]
Indexer to access the specified ZedGraphWebGraphObj object by its ordinal position in the list.
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebGraphObj this[
    int index
]{ get; set;}
Public Default Property Item ( _
    index As Integer _
) As ZedGraphWebGraphObj
public:
property ZedGraphWebGraphObj^ default[int index] {
    ZedGraphWebGraphObj^ get (int index);
    void set (int index, ZedGraphWebGraphObj^ value);
}
Parameters
index (Int32)
The ordinal position (zero-based) of the ZedGraphWebGraphObj object to be accessed.
Value
A ZedGraphWebGraphObj object reference.
See Also
GraphObj

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebGraphObjCollection ► ToString()()
Override the ToString() method.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
Always returns String.Empty

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebGrid Class

ZedGraphWebGrid Class
Namespaces ► ZedGraph.Web ► ZedGraphWebGrid
Proxy class to manage all properties associated with a grid
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebGrid : GenericItem
Public Class ZedGraphWebGrid _
    Inherits GenericItem
public ref class ZedGraphWebGrid : public GenericItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebGridZedGraphWebGridNew()() | Default constructor
 | Color | Proxy property that gets or sets the value of Color.
 | DashOff | Proxy property that gets or sets the value of DashOff.
 | DashOn | Proxy property that gets or sets the value of DashOn.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible | Proxy property that gets or sets the value of IsVisible.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PenWidth | Proxy property that gets or sets the value of PenWidth.
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Returns a string description of the class (Overrides Object.ToString()().)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebGrid

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebGrid Constructor

ZedGraphWebGrid Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebGrid ► ZedGraphWebGridZedGraphWebGridNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebGrid()
Public Sub New
public:
ZedGraphWebGrid ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Color Property

Color Property
Namespaces ► ZedGraph.Web ► ZedGraphWebGrid ► Color
Proxy property that gets or sets the value of Color.
Declaration Syntax
C# Visual Basic Visual C++
public Color Color{ get; set;}
Public Property Color As Color
public:
property Color Color {
    Color get ();
    void set (Color value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


DashOff Property

DashOff Property
Namespaces ► ZedGraph.Web ► ZedGraphWebGrid ► DashOff
Proxy property that gets or sets the value of DashOff.
Declaration Syntax
C# Visual Basic Visual C++
public float DashOff{ get; set;}
Public Property DashOff As Single
public:
property float DashOff {
    float get ();
    void set (float value);
}
Remarks
This is the distance, in points (1/72 inch), of the spaces between the dash segments that make up the dashed grid lines.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


DashOn Property

DashOn Property
Namespaces ► ZedGraph.Web ► ZedGraphWebGrid ► DashOn
Proxy property that gets or sets the value of DashOn.
Declaration Syntax
C# Visual Basic Visual C++
public float DashOn{ get; set;}
Public Property DashOn As Single
public:
property float DashOn {
    float get ();
    void set (float value);
}
Remarks
This is the distance, in points (1/72 inch), of the dash segments that make up the dashed grid lines.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph.Web ► ZedGraphWebGrid ► IsVisible
Proxy property that gets or sets the value of IsVisible.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
Remarks
This property determines if the major Axis gridlines (at each labeled value) will be visible.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


PenWidth Property

PenWidth Property
Namespaces ► ZedGraph.Web ► ZedGraphWebGrid ► PenWidth
Proxy property that gets or sets the value of PenWidth.
Declaration Syntax
C# Visual Basic Visual C++
public float PenWidth{ get; set;}
Public Property PenWidth As Single
public:
property float PenWidth {
    float get ();
    void set (float value);
}
Remarks
The pen width used for drawing the grid lines, expressed in points (1/72nd inch).

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebGrid ► ToString()()
Returns a string description of the class
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebHiLowBarItem Class

ZedGraphWebHiLowBarItem Class
Namespaces ► ZedGraph.Web ► ZedGraphWebHiLowBarItem
Web control state management class for a HiLowBarItem class
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebHiLowBarItem : ZedGraphWebCurveItem
Public Class ZedGraphWebHiLowBarItem _
    Inherits ZedGraphWebCurveItem
public ref class ZedGraphWebHiLowBarItem : public ZedGraphWebCurveItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebHiLowBarItemZedGraphWebHiLowBarItemNew()() | Default constructor
 | Border | Proxy property that gets or sets the ZedGraphWebBorder object for this HiLowBarItem.
 | Color | Proxy property that gets or sets the value of Color. (Inherited from ZedGraphWebCurveItem.)
 | CreateInPane(GraphPane, PointPairList) | Creates a new CurveItem using the PointPairList and add it the the given pane. (Overrides ZedGraphWebCurveItem.CreateInPane(GraphPane, PointPairList).)
 | DataMember | The String name of the data member that contains the data to be bound to this CurveItem. (Inherited from ZedGraphWebCurveItem.)
 | DataSource | The object reference that points to a data source from which to bind curve data. (Inherited from ZedGraphWebCurveItem.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Proxy property that gets or sets the ZedGraphWebFill object for this HiLowBarItem.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsLegendLabelVisible | Proxy property that gets or sets the value of Label.IsVisible. (Inherited from ZedGraphWebCurveItem.)
 | IsMaximumWidth | Proxy property that gets or sets the value of IsAutoSize.
 | IsVisible | Proxy property that gets or sets the value of IsVisible. (Inherited from ZedGraphWebCurveItem.)
 | IsY2Axis | Proxy property that gets or sets the value of IsY2Axis. (Inherited from ZedGraphWebCurveItem.)
 | Label | Proxy property that gets or sets the value of Label. (Inherited from ZedGraphWebCurveItem.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Points | Proxy property that gets the value of the Points. (Inherited from ZedGraphWebCurveItem.)
 | Size | Proxy property that gets or sets the value of Size.
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Identifies HiLowBarItem by the labels value (Overrides ZedGraphWebCurveItem.ToString()().)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebCurveItem
 |  |  | ZedGraphWebHiLowBarItem

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebHiLowBarItem Constructor

ZedGraphWebHiLowBarItem Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebHiLowBarItem ► ZedGraphWebHiLowBarItemZedGraphWebHiLowBarItemNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebHiLowBarItem()
Public Sub New
public:
ZedGraphWebHiLowBarItem ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Border Property

Border Property
Namespaces ► ZedGraph.Web ► ZedGraphWebHiLowBarItem ► Border
Proxy property that gets or sets the ZedGraphWebBorder object for this HiLowBarItem.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebBorder Border{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Border As ZedGraphWebBorder
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebBorder^ Border {
    ZedGraphWebBorder^ get ();
}
See Also
Border

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


CreateInPane Method (pane, points)

CreateInPane Method (pane, points)
Namespaces ► ZedGraph.Web ► ZedGraphWebHiLowBarItem ► CreateInPane(GraphPane, PointPairList)
Creates a new CurveItem using the PointPairList and add it the the given pane.
Declaration Syntax
C# Visual Basic Visual C++
public override CurveItem CreateInPane(
    GraphPane pane,
    PointPairList points
)
Public Overrides Function CreateInPane ( _
    pane As GraphPane, _
    points As PointPairList _
) As CurveItem
public:
virtual CurveItem^ CreateInPane (
    GraphPane^ pane,
    PointPairList^ points
) override
Parameters
pane (GraphPane)
the GraphPane object to which to add the new curve
points (PointPairList)
a PointPairList collection defining the points for this curve
Return Value
the newly created CurveItem added to the given GraphPane
Remarks
This method must be overriden by childs

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Fill Property

Fill Property
Namespaces ► ZedGraph.Web ► ZedGraphWebHiLowBarItem ► Fill
Proxy property that gets or sets the ZedGraphWebFill object for this HiLowBarItem.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebFill Fill{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Fill As ZedGraphWebFill
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebFill^ Fill {
    ZedGraphWebFill^ get ();
}
See Also
Fill

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsMaximumWidth Property

IsMaximumWidth Property
Namespaces ► ZedGraph.Web ► ZedGraphWebHiLowBarItem ► IsMaximumWidth
Proxy property that gets or sets the value of IsAutoSize.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsMaximumWidth{ get; set;}
Public Property IsMaximumWidth As Boolean
public:
property bool IsMaximumWidth {
    bool get ();
    void set (bool value);
}
Value
If true, then the value of Size is ignored. If this value is true, then MinClusterGap will be used to determine the total space between each bar.
Remarks
Determines whether the bar width will be based on the Size value, or it will be based on available space similar to BarItem objects.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Size Property

Size Property
Namespaces ► ZedGraph.Web ► ZedGraphWebHiLowBarItem ► Size
Proxy property that gets or sets the value of Size.
Declaration Syntax
C# Visual Basic Visual C++
public float Size{ get; set;}
Public Property Size As Single
public:
property float Size {
    float get ();
    void set (float value);
}
Value
Size in points (1/72 inch)
Remarks
The size of the bars can be set by this value, which is then scaled according to the scaleFactor (see CalcScaleFactor()()). Alternatively, if IsAutoSize is true, the bar width will be set according to the maximum available cluster width less the cluster gap (see GetClusterWidth()() and MinClusterGap). That is, if IsAutoSize is true, then the value of Size will be ignored.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebHiLowBarItem ► ToString()()
Identifies HiLowBarItem by the labels value
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
A string containing "HiLowBarItem: label", where 'label' is the Label property of the CurveItem

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebImageObj Class

ZedGraphWebImageObj Class
Namespaces ► ZedGraph.Web ► ZedGraphWebImageObj
Baseclass for graph items in the web control GraphObj
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebImageObj : ZedGraphWebGraphObj
Public Class ZedGraphWebImageObj _
    Inherits ZedGraphWebGraphObj
public ref class ZedGraphWebImageObj : public ZedGraphWebGraphObj
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebImageObjZedGraphWebImageObjNew()() | Default constructor
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | ImageUrl | The String url reference from which to get the Image data for this ImageObj.
 | IsScaled | Proxy property that gets or sets the value of IsScaled.
 | IsVisible | Proxy property that gets or sets the value of IsVisible (Inherited from ZedGraphWebGraphObj.)
 | Location | Proxy property that gets or sets the value of Location (Inherited from ZedGraphWebGraphObj.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Identifies curve item by the labels value (Overrides ZedGraphWebGraphObj.ToString()().)
 | ZOrder | Proxy property that gets or sets the value of ZOrder (Inherited from ZedGraphWebGraphObj.)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebGraphObj
 |  |  | ZedGraphWebImageObj
See Also
GraphObj

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebImageObj Constructor

ZedGraphWebImageObj Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebImageObj ► ZedGraphWebImageObjZedGraphWebImageObjNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebImageObj()
Public Sub New
public:
ZedGraphWebImageObj ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ImageUrl Property

ImageUrl Property
Namespaces ► ZedGraph.Web ► ZedGraphWebImageObj ► ImageUrl
The String url reference from which to get the Image data for this ImageObj.
Declaration Syntax
C# Visual Basic Visual C++
public string ImageUrl{ get; set;}
Public Property ImageUrl As String
public:
property String^ ImageUrl {
    String^ get ();
    void set (String^ value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsScaled Property

IsScaled Property
Namespaces ► ZedGraph.Web ► ZedGraphWebImageObj ► IsScaled
Proxy property that gets or sets the value of IsScaled.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsScaled{ get; set;}
Public Property IsScaled As Boolean
public:
property bool IsScaled {
    bool get ();
    void set (bool value);
}
Value
true to scale the image, false to draw the image unscaled, but clipped to the destination rectangle
Remarks
Determines if the image will be scaled to the output rectangle (see Location).

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebImageObj ► ToString()()
Identifies curve item by the labels value
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebLegend Class

ZedGraphWebLegend Class
Namespaces ► ZedGraph.Web ► ZedGraphWebLegend
Web control state management class for a Legend object
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebLegend : GenericItem
Public Class ZedGraphWebLegend _
    Inherits GenericItem
public ref class ZedGraphWebLegend : public GenericItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebLegendZedGraphWebLegendNew()() | Default constructor
 | Border | Proxy property that gets the value of Border
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Proxy property that gets the value of Fill
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontSpec | Proxy property that gets the value of FontSpec
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsHStack | Proxy property that gets or sets the value of IsHStack
 | IsReverse | Proxy property that gets or sets the value of IsReverse
 | IsVisible | Proxy property that gets or sets the value of IsVisible.
 | Location | Proxy property that gets the value of Location
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Position | Proxy property that gets or sets the value of Position.
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Identifies legend instance (Overrides Object.ToString()().)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebLegend

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebLegend Constructor

ZedGraphWebLegend Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebLegend ► ZedGraphWebLegendZedGraphWebLegendNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebLegend()
Public Sub New
public:
ZedGraphWebLegend ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Border Property

Border Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLegend ► Border
Proxy property that gets the value of Border
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebBorder Border{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Border As ZedGraphWebBorder
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebBorder^ Border {
    ZedGraphWebBorder^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Fill Property

Fill Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLegend ► Fill
Proxy property that gets the value of Fill
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebFill Fill{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Fill As ZedGraphWebFill
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebFill^ Fill {
    ZedGraphWebFill^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


FontSpec Property

FontSpec Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLegend ► FontSpec
Proxy property that gets the value of FontSpec
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebFontSpec FontSpec{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property FontSpec As ZedGraphWebFontSpec
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebFontSpec^ FontSpec {
    ZedGraphWebFontSpec^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsHStack Property

IsHStack Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLegend ► IsHStack
Proxy property that gets or sets the value of IsHStack
Declaration Syntax
C# Visual Basic Visual C++
public bool IsHStack{ get; set;}
Public Property IsHStack As Boolean
public:
property bool IsHStack {
    bool get ();
    void set (bool value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsReverse Property

IsReverse Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLegend ► IsReverse
Proxy property that gets or sets the value of IsReverse
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReverse{ get; set;}
Public Property IsReverse As Boolean
public:
property bool IsReverse {
    bool get ();
    void set (bool value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLegend ► IsVisible
Proxy property that gets or sets the value of IsVisible.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
Value
true to show the Legend, false to hide it
Remarks
This property shows or hides the Legend entirely.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Location Property

Location Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLegend ► Location
Proxy property that gets the value of Location
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebLocation Location{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Location As ZedGraphWebLocation
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebLocation^ Location {
    ZedGraphWebLocation^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Position Property

Position Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLegend ► Position
Proxy property that gets or sets the value of Position.
Declaration Syntax
C# Visual Basic Visual C++
public LegendPos Position{ get; set;}
Public Property Position As LegendPos
public:
property LegendPos Position {
    LegendPos get ();
    void set (LegendPos value);
}
Remarks
Sets or gets the location of the Legend on the GraphPane using the LegendPos enum type

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebLegend ► ToString()()
Identifies legend instance
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
Always returns the string "Legend".

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebLineItem Class

ZedGraphWebLineItem Class
Namespaces ► ZedGraph.Web ► ZedGraphWebLineItem
Web control state management class for a LineItem class
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebLineItem : ZedGraphWebCurveItem
Public Class ZedGraphWebLineItem _
    Inherits ZedGraphWebCurveItem
public ref class ZedGraphWebLineItem : public ZedGraphWebCurveItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebLineItemZedGraphWebLineItemNew()() | Default constructor
 | Color | Proxy property that gets or sets the value of Color. (Inherited from ZedGraphWebCurveItem.)
 | CreateInPane(GraphPane, PointPairList) | Creates a new CurveItem using the PointPairList and add it the the given pane. (Overrides ZedGraphWebCurveItem.CreateInPane(GraphPane, PointPairList).)
 | DataMember | The String name of the data member that contains the data to be bound to this CurveItem. (Inherited from ZedGraphWebCurveItem.)
 | DataSource | The object reference that points to a data source from which to bind curve data. (Inherited from ZedGraphWebCurveItem.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Proxy property that gets or sets the ZedGraphWebFill object for this LineItem.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsLegendLabelVisible | Proxy property that gets or sets the value of Label.IsVisible. (Inherited from ZedGraphWebCurveItem.)
 | IsSmooth | Proxy property that gets or sets the value of IsSmooth.
 | IsVisible | Proxy property that gets or sets the value of IsVisible. (Inherited from ZedGraphWebCurveItem.)
 | IsY2Axis | Proxy property that gets or sets the value of IsY2Axis. (Inherited from ZedGraphWebCurveItem.)
 | Label | Proxy property that gets or sets the value of Label. (Inherited from ZedGraphWebCurveItem.)
 | LineStyle | Proxy property that gets or sets the value of Style.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Points | Proxy property that gets the value of the Points. (Inherited from ZedGraphWebCurveItem.)
 | SmoothTension | Proxy property that gets or sets the value of SmoothTension.
 | StepType | Proxy property that gets or sets the value of StepType.
 | Symbol | Proxy property that gets or sets the ZedGraphWebSymbol object for this LineItem.
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Identifies LineItem by the labels value (Overrides ZedGraphWebCurveItem.ToString()().)
 | Width | Proxy property that gets or sets the value of Width.
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebCurveItem
 |  |  | ZedGraphWebLineItem

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebLineItem Constructor

ZedGraphWebLineItem Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebLineItem ► ZedGraphWebLineItemZedGraphWebLineItemNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebLineItem()
Public Sub New
public:
ZedGraphWebLineItem ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


CreateInPane Method (pane, points)

CreateInPane Method (pane, points)
Namespaces ► ZedGraph.Web ► ZedGraphWebLineItem ► CreateInPane(GraphPane, PointPairList)
Creates a new CurveItem using the PointPairList and add it the the given pane.
Declaration Syntax
C# Visual Basic Visual C++
public override CurveItem CreateInPane(
    GraphPane pane,
    PointPairList points
)
Public Overrides Function CreateInPane ( _
    pane As GraphPane, _
    points As PointPairList _
) As CurveItem
public:
virtual CurveItem^ CreateInPane (
    GraphPane^ pane,
    PointPairList^ points
) override
Parameters
pane (GraphPane)
the GraphPane object to which to add the new curve
points (PointPairList)
a PointPairList collection defining the points for this curve
Return Value
the newly created CurveItem added to the given GraphPane
Remarks
This method must be overriden by childs

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Fill Property

Fill Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLineItem ► Fill
Proxy property that gets or sets the ZedGraphWebFill object for this LineItem.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebFill Fill{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Fill As ZedGraphWebFill
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebFill^ Fill {
    ZedGraphWebFill^ get ();
}
See Also
Fill

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsSmooth Property

IsSmooth Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLineItem ► IsSmooth
Proxy property that gets or sets the value of IsSmooth.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSmooth{ get; set;}
Public Property IsSmooth As Boolean
public:
property bool IsSmooth {
    bool get ();
    void set (bool value);
}
Remarks
Gets or sets a property that determines if this Line will be drawn smooth. The "smoothness" is controlled by the SmoothTension property.
See Also
IsSmooth

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


LineStyle Property

LineStyle Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLineItem ► LineStyle
Proxy property that gets or sets the value of Style.
Declaration Syntax
C# Visual Basic Visual C++
public DashStyle LineStyle{ get; set;}
Public Property LineStyle As DashStyle
public:
property DashStyle LineStyle {
    DashStyle get ();
    void set (DashStyle value);
}
Remarks
The style of the Line, defined as a DashStyle enum. This allows the line to be solid, dashed, or dotted.
See Also
Style

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


SmoothTension Property

SmoothTension Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLineItem ► SmoothTension
Proxy property that gets or sets the value of SmoothTension.
Declaration Syntax
C# Visual Basic Visual C++
public float SmoothTension{ get; set;}
Public Property SmoothTension As Single
public:
property float SmoothTension {
    float get ();
    void set (float value);
}
Value
A floating point value indicating the level of smoothing. 0.0F for no smoothing, 1.0F for lots of smoothing, >1.0 for odd smoothing.
Remarks
Gets or sets a property that determines the smoothing tension for this Line. This property is only used if IsSmooth is true. A tension value 0.0 will just draw ordinary line segments like an unsmoothed line. A tension value of 1.0 will be smooth. Values greater than 1.0 will generally give odd results.
See Also
IsSmooth

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


StepType Property

StepType Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLineItem ► StepType
Proxy property that gets or sets the value of StepType.
Declaration Syntax
C# Visual Basic Visual C++
public StepType StepType{ get; set;}
Public Property StepType As StepType
public:
property StepType StepType {
    StepType get ();
    void set (StepType value);
}
Remarks
Determines if the LineItem will be drawn by directly connecting the points from the Points data collection, or if the curve will be a "stair-step" in which the points are connected by a series of horizontal and vertical lines that represent discrete, constant values. Note that the values can be forward oriented ForwardStep (StepType) or rearward oriented RearwardStep. That is, the points are defined at the beginning or end of the constant value for which they apply, respectively. The StepType property is ignored for lines that have IsSmooth set to true.
See Also
StepType

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Symbol Property

Symbol Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLineItem ► Symbol
Proxy property that gets or sets the ZedGraphWebSymbol object for this LineItem.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebSymbol Symbol{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Symbol As ZedGraphWebSymbol
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebSymbol^ Symbol {
    ZedGraphWebSymbol^ get ();
}
See Also
Symbol

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebLineItem ► ToString()()
Identifies LineItem by the labels value
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
A string containing "LineItem: label", where 'label' is the Label property of the CurveItem

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Width Property

Width Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLineItem ► Width
Proxy property that gets or sets the value of Width.
Declaration Syntax
C# Visual Basic Visual C++
public float Width{ get; set;}
Public Property Width As Single
public:
property float Width {
    float get ();
    void set (float value);
}
Remarks
The pen width used to draw the Line, in points (1/72 inch)
See Also
Width

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebLocation Class

ZedGraphWebLocation Class
Namespaces ► ZedGraph.Web ► ZedGraphWebLocation
Location class for a FontSpec object
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebLocation : GenericItem
Public Class ZedGraphWebLocation _
    Inherits GenericItem
public ref class ZedGraphWebLocation : public GenericItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebLocationZedGraphWebLocationNew()() | Default constructor
 | AlignH | Proxy property that gets or sets the value of AlignH
 | AlignV | Proxy property that gets or sets the value of AlignV
 | BottomRight | Proxy property that gets the value of BottomRight
 | CoordinateFrame | Proxy property that gets or sets the value of CoordinateFrame
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Height | Proxy property that gets or sets the value of Height
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | TopLeft | Proxy property that gets the value of TopLeft
 | ToString()() | Identifies location instance (Overrides Object.ToString()().)
 | Width | Proxy property that gets or sets the value of Width
 | X | Proxy property that gets or sets the value of X
 | Y | Proxy property that gets or sets the value of Y
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebLocation

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebLocation Constructor

ZedGraphWebLocation Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebLocation ► ZedGraphWebLocationZedGraphWebLocationNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebLocation()
Public Sub New
public:
ZedGraphWebLocation ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


AlignH Property

AlignH Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLocation ► AlignH
Proxy property that gets or sets the value of AlignH
Declaration Syntax
C# Visual Basic Visual C++
public AlignH AlignH{ get; set;}
Public Property AlignH As AlignH
public:
property AlignH AlignH {
    AlignH get ();
    void set (AlignH value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


AlignV Property

AlignV Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLocation ► AlignV
Proxy property that gets or sets the value of AlignV
Declaration Syntax
C# Visual Basic Visual C++
public AlignV AlignV{ get; set;}
Public Property AlignV As AlignV
public:
property AlignV AlignV {
    AlignV get ();
    void set (AlignV value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


BottomRight Property

BottomRight Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLocation ► BottomRight
Proxy property that gets the value of BottomRight
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebPointD BottomRight{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property BottomRight As ZedGraphWebPointD
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebPointD^ BottomRight {
    ZedGraphWebPointD^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


CoordinateFrame Property

CoordinateFrame Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLocation ► CoordinateFrame
Proxy property that gets or sets the value of CoordinateFrame
Declaration Syntax
C# Visual Basic Visual C++
public CoordType CoordinateFrame{ get; set;}
Public Property CoordinateFrame As CoordType
public:
property CoordType CoordinateFrame {
    CoordType get ();
    void set (CoordType value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Height Property

Height Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLocation ► Height
Proxy property that gets or sets the value of Height
Declaration Syntax
C# Visual Basic Visual C++
public float Height{ get; set;}
Public Property Height As Single
public:
property float Height {
    float get ();
    void set (float value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


TopLeft Property

TopLeft Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLocation ► TopLeft
Proxy property that gets the value of TopLeft
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebPointD TopLeft{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property TopLeft As ZedGraphWebPointD
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebPointD^ TopLeft {
    ZedGraphWebPointD^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebLocation ► ToString()()
Identifies location instance
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Width Property

Width Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLocation ► Width
Proxy property that gets or sets the value of Width
Declaration Syntax
C# Visual Basic Visual C++
public float Width{ get; set;}
Public Property Width As Single
public:
property float Width {
    float get ();
    void set (float value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


X Property

X Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLocation ► X
Proxy property that gets or sets the value of X
Declaration Syntax
C# Visual Basic Visual C++
public float X{ get; set;}
Public Property X As Single
public:
property float X {
    float get ();
    void set (float value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Y Property

Y Property
Namespaces ► ZedGraph.Web ► ZedGraphWebLocation ► Y
Proxy property that gets or sets the value of Y
Declaration Syntax
C# Visual Basic Visual C++
public float Y{ get; set;}
Public Property Y As Single
public:
property float Y {
    float get ();
    void set (float value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebPieItem Class

ZedGraphWebPieItem Class
Namespaces ► ZedGraph.Web ► ZedGraphWebPieItem
Web control state management class for a PieItem class
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebPieItem : ZedGraphWebCurveItem
Public Class ZedGraphWebPieItem _
    Inherits ZedGraphWebCurveItem
public ref class ZedGraphWebPieItem : public ZedGraphWebCurveItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebPieItemZedGraphWebPieItemNew()() | Default Constructor
 | Border | Proxy property that gets or sets the ZedGraphWebBorder object for this PieItem.
 | Color | Proxy property that gets or sets the value of Color. (Inherited from ZedGraphWebCurveItem.)
 | CreateInPane(GraphPane, PointPairList) | Creates a new CurveItem using the PointPairList and add it the the given pane. (Overrides ZedGraphWebCurveItem.CreateInPane(GraphPane, PointPairList).)
 | DataMember | The String name of the data member that contains the data to be bound to this CurveItem. (Inherited from ZedGraphWebCurveItem.)
 | DataSource | The object reference that points to a data source from which to bind curve data. (Inherited from ZedGraphWebCurveItem.)
 | Displacement | Proxy property that gets or sets the value of Displacement.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsLegendLabelVisible | Proxy property that gets or sets the value of Label.IsVisible. (Inherited from ZedGraphWebCurveItem.)
 | IsVisible | Proxy property that gets or sets the value of IsVisible. (Inherited from ZedGraphWebCurveItem.)
 | IsY2Axis | Proxy property that gets or sets the value of IsY2Axis. (Inherited from ZedGraphWebCurveItem.)
 | Label | Proxy property that gets or sets the value of Label. (Inherited from ZedGraphWebCurveItem.)
 | LabelDetail | Proxy property that gets or sets the value of LabelDetail.
 | LabelType | Proxy property that gets or sets the value of LabelType.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PercentDecimalDigits | Proxy property that gets or sets the value of PercentDecimalDigits.
 | Points | Proxy property that gets the value of the Points. (Inherited from ZedGraphWebCurveItem.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Identifies PieItem by the labels value (Overrides ZedGraphWebCurveItem.ToString()().)
 | Value | Proxy property that gets or sets the value of Value.
 | ValueDecimalDigits | Proxy property that gets or sets the value of ValueDecimalDigits.
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebCurveItem
 |  |  | ZedGraphWebPieItem

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebPieItem Constructor

ZedGraphWebPieItem Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebPieItem ► ZedGraphWebPieItemZedGraphWebPieItemNew()()
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebPieItem()
Public Sub New
public:
ZedGraphWebPieItem ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Border Property

Border Property
Namespaces ► ZedGraph.Web ► ZedGraphWebPieItem ► Border
Proxy property that gets or sets the ZedGraphWebBorder object for this PieItem.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebBorder Border{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Border As ZedGraphWebBorder
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebBorder^ Border {
    ZedGraphWebBorder^ get ();
}
See Also
Border

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


CreateInPane Method (pane, points)

CreateInPane Method (pane, points)
Namespaces ► ZedGraph.Web ► ZedGraphWebPieItem ► CreateInPane(GraphPane, PointPairList)
Creates a new CurveItem using the PointPairList and add it the the given pane.
Declaration Syntax
C# Visual Basic Visual C++
public override CurveItem CreateInPane(
    GraphPane pane,
    PointPairList points
)
Public Overrides Function CreateInPane ( _
    pane As GraphPane, _
    points As PointPairList _
) As CurveItem
public:
virtual CurveItem^ CreateInPane (
    GraphPane^ pane,
    PointPairList^ points
) override
Parameters
pane (GraphPane)
the GraphPane object to which to add the new curve
points (PointPairList)
a PointPairList collection defining the points for this curve
Return Value
the newly created CurveItem added to the given GraphPane
Remarks
This method must be overriden by childs

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Displacement Property

Displacement Property
Namespaces ► ZedGraph.Web ► ZedGraphWebPieItem ► Displacement
Proxy property that gets or sets the value of Displacement.
Declaration Syntax
C# Visual Basic Visual C++
public double Displacement{ get; set;}
Public Property Displacement As Double
public:
property double Displacement {
    double get ();
    void set (double value);
}
Remarks
Gets or sets the a value which determines the amount, if any, of this PieItem displacement.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


LabelDetail Property

LabelDetail Property
Namespaces ► ZedGraph.Web ► ZedGraphWebPieItem ► LabelDetail
Proxy property that gets or sets the value of LabelDetail.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebTextObj LabelDetail{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property LabelDetail As ZedGraphWebTextObj
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebTextObj^ LabelDetail {
    ZedGraphWebTextObj^ get ();
}
Remarks
Gets or sets the TextObj to be used for displaying this PieItem's label.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


LabelType Property

LabelType Property
Namespaces ► ZedGraph.Web ► ZedGraphWebPieItem ► LabelType
Proxy property that gets or sets the value of LabelType.
Declaration Syntax
C# Visual Basic Visual C++
public PieLabelType LabelType{ get; set;}
Public Property LabelType As PieLabelType
public:
property PieLabelType LabelType {
    PieLabelType get ();
    void set (PieLabelType value);
}
Remarks
Gets or sets the PieLabelType to be used in displaying PieItem labels.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


PercentDecimalDigits Property

PercentDecimalDigits Property
Namespaces ► ZedGraph.Web ► ZedGraphWebPieItem ► PercentDecimalDigits
Proxy property that gets or sets the value of PercentDecimalDigits.
Declaration Syntax
C# Visual Basic Visual C++
public int PercentDecimalDigits{ get; set;}
Public Property PercentDecimalDigits As Integer
public:
property int PercentDecimalDigits {
    int get ();
    void set (int value);
}
Remarks
Gets or sets the number of decimal digits to be displayed in a PieItem percent label.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebPieItem ► ToString()()
Identifies PieItem by the labels value
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
A string containing "PieItem: label", where 'label' is the Label property of the CurveItem

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Value Property

Value Property
Namespaces ► ZedGraph.Web ► ZedGraphWebPieItem ► Value
Proxy property that gets or sets the value of Value.
Declaration Syntax
C# Visual Basic Visual C++
public double Value{ get; set;}
Public Property Value As Double
public:
property double Value {
    double get ();
    void set (double value);
}
Remarks
Gets or sets the value of this PieItem. Minimum value is 0.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ValueDecimalDigits Property

ValueDecimalDigits Property
Namespaces ► ZedGraph.Web ► ZedGraphWebPieItem ► ValueDecimalDigits
Proxy property that gets or sets the value of ValueDecimalDigits.
Declaration Syntax
C# Visual Basic Visual C++
public int ValueDecimalDigits{ get; set;}
Public Property ValueDecimalDigits As Integer
public:
property int ValueDecimalDigits {
    int get ();
    void set (int value);
}
Remarks
Gets or sets the number of decimal digits to be displayed in a PieItem value label.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebPointD Class

ZedGraphWebPointD Class
Namespaces ► ZedGraph.Web ► ZedGraphWebPointD
Point class for a FontSpec object
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebPointD : GenericItem
Public Class ZedGraphWebPointD _
    Inherits GenericItem
public ref class ZedGraphWebPointD : public GenericItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebPointDZedGraphWebPointDNew()() | Default constructor
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Identifies fontspec instance (Overrides Object.ToString()().)
 | X | Proxy property that gets or sets the value of X
 | Y | Proxy property that gets or sets the value of Y
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebPointD

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebPointD Constructor

ZedGraphWebPointD Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebPointD ► ZedGraphWebPointDZedGraphWebPointDNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebPointD()
Public Sub New
public:
ZedGraphWebPointD ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebPointD ► ToString()()
Identifies fontspec instance
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


X Property

X Property
Namespaces ► ZedGraph.Web ► ZedGraphWebPointD ► X
Proxy property that gets or sets the value of X
Declaration Syntax
C# Visual Basic Visual C++
public double X{ get; set;}
Public Property X As Double
public:
property double X {
    double get ();
    void set (double value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Y Property

Y Property
Namespaces ► ZedGraph.Web ► ZedGraphWebPointD ► Y
Proxy property that gets or sets the value of Y
Declaration Syntax
C# Visual Basic Visual C++
public double Y{ get; set;}
Public Property Y As Double
public:
property double Y {
    double get ();
    void set (double value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebPointPair Class

ZedGraphWebPointPair Class
Namespaces ► ZedGraph.Web ► ZedGraphWebPointPair
A Web PointPair class
Declaration Syntax
C# Visual Basic Visual C++
[DefaultPropertyAttribute("Value")]
public class ZedGraphWebPointPair : GenericItem
<DefaultPropertyAttribute("Value")> _
Public Class ZedGraphWebPointPair _
    Inherits GenericItem
[DefaultPropertyAttribute(L"Value")]
public ref class ZedGraphWebPointPair : public GenericItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebPointPairZedGraphWebPointPairNew()() | Default constructor
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Identifies PointPair instance (Overrides Object.ToString()().)
 | X | Proxy property that gets or sets the value of X
 | Y | Proxy property that gets or sets the value of Y
 | Z | Proxy property that gets or sets the value of Z
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebPointPair

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebPointPair Constructor

ZedGraphWebPointPair Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebPointPair ► ZedGraphWebPointPairZedGraphWebPointPairNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebPointPair()
Public Sub New
public:
ZedGraphWebPointPair ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebPointPair ► ToString()()
Identifies PointPair instance
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


X Property

X Property
Namespaces ► ZedGraph.Web ► ZedGraphWebPointPair ► X
Proxy property that gets or sets the value of X
Declaration Syntax
C# Visual Basic Visual C++
public double X{ get; set;}
Public Property X As Double
public:
property double X {
    double get ();
    void set (double value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Y Property

Y Property
Namespaces ► ZedGraph.Web ► ZedGraphWebPointPair ► Y
Proxy property that gets or sets the value of Y
Declaration Syntax
C# Visual Basic Visual C++
public double Y{ get; set;}
Public Property Y As Double
public:
property double Y {
    double get ();
    void set (double value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Z Property

Z Property
Namespaces ► ZedGraph.Web ► ZedGraphWebPointPair ► Z
Proxy property that gets or sets the value of Z
Declaration Syntax
C# Visual Basic Visual C++
public double Z{ get; set;}
Public Property Z As Double
public:
property double Z {
    double get ();
    void set (double value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebPointPairCollection Class

ZedGraphWebPointPairCollection Class
Namespaces ► ZedGraph.Web ► ZedGraphWebPointPairCollection
Manages a collection of ZedGraphWebPointPair objects that are state management aware.
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebPointPairCollection : GenericCollection
Public Class ZedGraphWebPointPairCollection _
    Inherits GenericCollection
public ref class ZedGraphWebPointPairCollection : public GenericCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebPointPairCollectionZedGraphWebPointPairCollectionNew()() | Default Constructor
 | Add(ZedGraphWebPointPair) | Add a ZedGraphWebPointPair to this collection.
 | Clear()() | Empty the array list and marks the viewstate. (Inherited from GenericCollection.)
 | CopyTo(Array, Int32) | CopyTo(Array, Int32) (Inherited from GenericCollection.)
 | Count | Count (Inherited from GenericCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()() | GetEnumerator()() (Inherited from GenericCollection.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | IsSynchronized (Inherited from GenericCollection.)
 | Item[([Int32])] | Indexer to access the specified ZedGraphWebPointPair object by its ordinal position in the list.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SyncRoot | SyncRoot (Inherited from GenericCollection.)
 | IList..::Add(Object) | Adds item based on the rules of ListAdd Add(Object) ListAdd(Object) (Inherited from GenericCollection.)
 | IList..::Clear()() | Clear()() (Inherited from GenericCollection.)
 | IList..::Contains(Object) | Contains(Object) (Inherited from GenericCollection.)
 | IList..::IndexOf(Object) | IndexOf(Object) (Inherited from GenericCollection.)
 | IList..::Insert(Int32, Object) | Inserts item according to the rules of ListInsert Insert(Int32, Object) ListInsert(Int32, Object) (Inherited from GenericCollection.)
 | IList..::IsFixedSize | IsFixedSize (Inherited from GenericCollection.)
 | IList..::IsReadOnly | IsReadOnly (Inherited from GenericCollection.)
 | IList..::Item[([Int32])] | Privately implement those members of IList that take or return the object type and expose equivalent public members that take or return an item instance instead. Also implement privately those members of IList that are not meaninful to expose in the public object model of this Collection. (Inherited from GenericCollection.)
 | IList..::Remove(Object) | Removes item based on ListRemove Remove(Object) ListRemove(Object) (Inherited from GenericCollection.)
 | IList..::RemoveAt(Int32) | Removes item based on RemoveAt RemoveAt(Int32) RemoveAt(Int32) (Inherited from GenericCollection.)
 | IStateManager..::IsTrackingViewState | IsTrackingViewState (Inherited from GenericCollection.)
 | IStateManager..::LoadViewState(Object) | Loads the view state. This involves reading each state item pair, verifying schema support for each datatype, creating each item instance, and loading the state into each newly created instance. LoadViewState(Object) (Inherited from GenericCollection.)
 | IStateManager..::SaveViewState()() | Saves the viewstate into a portable object format. This involves saving the state of each item in the list. SaveViewState()() (Inherited from GenericCollection.)
 | IStateManager..::TrackViewState()() | TrackViewState()() (Inherited from GenericCollection.)
 | ToString()() | Override the ToString() method. (Overrides Object.ToString()().)
Inheritance Hierarchy
Object
 | GenericCollection
 |  | ZedGraphWebPointPairCollection

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebPointPairCollection Constructor

ZedGraphWebPointPairCollection Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebPointPairCollection ► ZedGraphWebPointPairCollectionZedGraphWebPointPairCollectionNew()()
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebPointPairCollection()
Public Sub New
public:
ZedGraphWebPointPairCollection ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Add Method (item)

Add Method (item)
Namespaces ► ZedGraph.Web ► ZedGraphWebPointPairCollection ► Add(ZedGraphWebPointPair)
Add a ZedGraphWebPointPair to this collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    ZedGraphWebPointPair item
)
Public Sub Add ( _
    item As ZedGraphWebPointPair _
)
public:
void Add (
    ZedGraphWebPointPair^ item
)
Parameters
item (ZedGraphWebPointPair)
The ZedGraphWebPointPair to be added.
See Also
PointPair

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph.Web ► ZedGraphWebPointPairCollection ► Item[([Int32])]
Indexer to access the specified ZedGraphWebPointPair object by its ordinal position in the list.
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebPointPair this[
    int index
]{ get; set;}
Public Default Property Item ( _
    index As Integer _
) As ZedGraphWebPointPair
public:
property ZedGraphWebPointPair^ default[int index] {
    ZedGraphWebPointPair^ get (int index);
    void set (int index, ZedGraphWebPointPair^ value);
}
Parameters
index (Int32)
The ordinal position (zero-based) of the ZedGraphWebPointPair object to be accessed.
Value
A ZedGraphWebPointPair object reference.
See Also
PointPair

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebPointPairCollection ► ToString()()
Override the ToString() method.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
Always returns String.Empty

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebRect Class

ZedGraphWebRect Class
Namespaces ► ZedGraph.Web ► ZedGraphWebRect
Rectangle class for margins
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebRect : GenericItem
Public Class ZedGraphWebRect _
    Inherits GenericItem
public ref class ZedGraphWebRect : public GenericItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebRectZedGraphWebRectNew()() | Default constructor
 | Bottom |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Left |
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Right |
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | Top |
 | ToString()() | Override ToString (Overrides Object.ToString()().)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebRect

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebRect Constructor

ZedGraphWebRect Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebRect ► ZedGraphWebRectZedGraphWebRectNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebRect()
Public Sub New
public:
ZedGraphWebRect ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Bottom Property

Bottom Property
Namespaces ► ZedGraph.Web ► ZedGraphWebRect ► Bottom
Declaration Syntax
C# Visual Basic Visual C++
public float Bottom{ get; set;}
Public Property Bottom As Single
public:
property float Bottom {
    float get ();
    void set (float value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Left Property

Left Property
Namespaces ► ZedGraph.Web ► ZedGraphWebRect ► Left
Declaration Syntax
C# Visual Basic Visual C++
public float Left{ get; set;}
Public Property Left As Single
public:
property float Left {
    float get ();
    void set (float value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Right Property

Right Property
Namespaces ► ZedGraph.Web ► ZedGraphWebRect ► Right
Declaration Syntax
C# Visual Basic Visual C++
public float Right{ get; set;}
Public Property Right As Single
public:
property float Right {
    float get ();
    void set (float value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Top Property

Top Property
Namespaces ► ZedGraph.Web ► ZedGraphWebRect ► Top
Declaration Syntax
C# Visual Basic Visual C++
public float Top{ get; set;}
Public Property Top As Single
public:
property float Top {
    float get ();
    void set (float value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebRect ► ToString()()
Override ToString
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebScale Class

ZedGraphWebScale Class
Namespaces ► ZedGraph.Web ► ZedGraphWebScale
Proxy class to manage all properties associated with a grid
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebScale : GenericItem
Public Class ZedGraphWebScale _
    Inherits GenericItem
public ref class ZedGraphWebScale : public GenericItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebScaleZedGraphWebScaleNew()() | Default constructor
 | Align | Proxy property that gets or sets the value of Align.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontSpec | Proxy property that gets or sets the value of FontSpec.
 | Format | Proxy property that gets or sets the value of Format.
 | FormatAuto | Proxy property that gets or sets the value of FormatAuto.
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsReverse | Proxy property that gets or sets the value of IsReverse.
 | Mag | Proxy property that gets or sets the value of Mag.
 | MagAuto | Proxy property that gets or sets the value of MagAuto.
 | MajorStep | Proxy property that gets or sets the value of MajorStepAuto.
 | MajorStepAuto | Proxy property that gets or sets the value of MajorStepAuto.
 | MajorUnit | Proxy property to handle the units for the MajorStep property.
 | Max | Proxy property that gets or sets the value of Max.
 | MaxAuto | Proxy property that gets or sets the value of MaxAuto.
 | MaxGrace | Proxy property that gets or sets the value of MaxGrace.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Min | Proxy property that gets or sets the value of Min.
 | MinAuto | Proxy property that gets or sets the value of MinAuto.
 | MinGrace | Proxy property that gets or sets the value of MinGrace.
 | MinorStep | Proxy property that gets or sets the value of MinorStep.
 | MinorStepAuto | Proxy property that gets or sets the value of MinorStepAuto.
 | MinorUnit | Proxy property to handle the units for the MinorStep property.
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Returns a string description of the class (Overrides Object.ToString()().)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebScale

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebScale Constructor

ZedGraphWebScale Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► ZedGraphWebScaleZedGraphWebScaleNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebScale()
Public Sub New
public:
ZedGraphWebScale ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Align Property

Align Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► Align
Proxy property that gets or sets the value of Align.
Declaration Syntax
C# Visual Basic Visual C++
public AlignP Align{ get; set;}
Public Property Align As AlignP
public:
property AlignP Align {
    AlignP get ();
    void set (AlignP value);
}
Remarks
Controls the alignment of the Axis tic labels.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


FontSpec Property

FontSpec Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► FontSpec
Proxy property that gets or sets the value of FontSpec.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebFontSpec FontSpec{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property FontSpec As ZedGraphWebFontSpec
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebFontSpec^ FontSpec {
    ZedGraphWebFontSpec^ get ();
}
Remarks
Gets a reference to the FontSpec class used to render the scale values.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Format Property

Format Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► Format
Proxy property that gets or sets the value of Format.
Declaration Syntax
C# Visual Basic Visual C++
public string Format{ get; set;}
Public Property Format As String
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}
Remarks
The format of the Axis tic labels. This property is only used if the Type is set to Date. This property may be set automatically by ZedGraph, depending on the state of FormatAuto.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


FormatAuto Property

FormatAuto Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► FormatAuto
Proxy property that gets or sets the value of FormatAuto.
Declaration Syntax
C# Visual Basic Visual C++
public bool FormatAuto{ get; set;}
Public Property FormatAuto As Boolean
public:
property bool FormatAuto {
    bool get ();
    void set (bool value);
}
Remarks
Determines whether or not the scale label format Format is determined automatically based on the range of data values.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsReverse Property

IsReverse Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► IsReverse
Proxy property that gets or sets the value of IsReverse.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsReverse{ get; set;}
Public Property IsReverse As Boolean
public:
property bool IsReverse {
    bool get ();
    void set (bool value);
}
Remarks
Determines if the scale values are reversed for this Axis.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Mag Property

Mag Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► Mag
Proxy property that gets or sets the value of Mag.
Declaration Syntax
C# Visual Basic Visual C++
public int Mag{ get; set;}
Public Property Mag As Integer
public:
property int Mag {
    int get ();
    void set (int value);
}
Remarks
The magnitude multiplier for scale values. This is used to limit the size of the displayed value labels. For example, if the value is really 2000000, then the graph will display 2000 with a 10^3 magnitude multiplier. This value can be determined automatically depending on the state of MagAuto. If this value is set manually by the user, then MagAuto will also be set to false.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MagAuto Property

MagAuto Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► MagAuto
Proxy property that gets or sets the value of MagAuto.
Declaration Syntax
C# Visual Basic Visual C++
public bool MagAuto{ get; set;}
Public Property MagAuto As Boolean
public:
property bool MagAuto {
    bool get ();
    void set (bool value);
}
Remarks
Determines whether the Mag value will be set automatically based on the data, or manually by the user. If the user manually sets the Mag value, then this flag will be set to false.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MajorStep Property

MajorStep Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► MajorStep
Proxy property that gets or sets the value of MajorStepAuto.
Declaration Syntax
C# Visual Basic Visual C++
public double MajorStep{ get; set;}
Public Property MajorStep As Double
public:
property double MajorStep {
    double get ();
    void set (double value);
}
Remarks
Determines whether or not the scale major step size value MajorStep is set automatically.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MajorStepAuto Property

MajorStepAuto Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► MajorStepAuto
Proxy property that gets or sets the value of MajorStepAuto.
Declaration Syntax
C# Visual Basic Visual C++
public bool MajorStepAuto{ get; set;}
Public Property MajorStepAuto As Boolean
public:
property bool MajorStepAuto {
    bool get ();
    void set (bool value);
}
Remarks
Determines whether or not the scale major step size value MajorStep is set automatically.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MajorUnit Property

MajorUnit Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► MajorUnit
Proxy property to handle the units for the MajorStep property.
Declaration Syntax
C# Visual Basic Visual C++
public DateUnit MajorUnit{ get; set;}
Public Property MajorUnit As DateUnit
public:
property DateUnit MajorUnit {
    DateUnit get ();
    void set (DateUnit value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Max Property

Max Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► Max
Proxy property that gets or sets the value of Max.
Declaration Syntax
C# Visual Basic Visual C++
public double Max{ get; set;}
Public Property Max As Double
public:
property double Max {
    double get ();
    void set (double value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MaxAuto Property

MaxAuto Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► MaxAuto
Proxy property that gets or sets the value of MaxAuto.
Declaration Syntax
C# Visual Basic Visual C++
public bool MaxAuto{ get; set;}
Public Property MaxAuto As Boolean
public:
property bool MaxAuto {
    bool get ();
    void set (bool value);
}
Remarks
Determines whether or not the maximum scale value Max is set automatically.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MaxGrace Property

MaxGrace Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► MaxGrace
Proxy property that gets or sets the value of MaxGrace.
Declaration Syntax
C# Visual Basic Visual C++
public double MaxGrace{ get; set;}
Public Property MaxGrace As Double
public:
property double MaxGrace {
    double get ();
    void set (double value);
}
Remarks
This is the "grace" value applied to the maximum data range. This value is expressed as a fraction of the total data range. For example, assume the data range is from 4.0 to 16.0, leaving a range of 12.0. If MaxGrace is set to 0.1, then 10% of the range, or 1.2 will be added to the maximum data value. The scale will then be ranged to cover at least 4.0 to 17.2.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Min Property

Min Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► Min
Proxy property that gets or sets the value of Min.
Declaration Syntax
C# Visual Basic Visual C++
public double Min{ get; set;}
Public Property Min As Double
public:
property double Min {
    double get ();
    void set (double value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MinAuto Property

MinAuto Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► MinAuto
Proxy property that gets or sets the value of MinAuto.
Declaration Syntax
C# Visual Basic Visual C++
public bool MinAuto{ get; set;}
Public Property MinAuto As Boolean
public:
property bool MinAuto {
    bool get ();
    void set (bool value);
}
Remarks
Determines whether or not the minimum scale value Min is set automatically.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MinGrace Property

MinGrace Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► MinGrace
Proxy property that gets or sets the value of MinGrace.
Declaration Syntax
C# Visual Basic Visual C++
public double MinGrace{ get; set;}
Public Property MinGrace As Double
public:
property double MinGrace {
    double get ();
    void set (double value);
}
Remarks
This is the "grace" value applied to the minimum data range. This value is expressed as a fraction of the total data range. For example, assume the data range is from 4.0 to 16.0, leaving a range of 12.0. If MinGrace is set to 0.1, then 10% of the range, or 1.2 will be subtracted from the minimum data value. The scale will then be ranged to cover at least 2.8 to 16.0.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MinorStep Property

MinorStep Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► MinorStep
Proxy property that gets or sets the value of MinorStep.
Declaration Syntax
C# Visual Basic Visual C++
public double MinorStep{ get; set;}
Public Property MinorStep As Double
public:
property double MinorStep {
    double get ();
    void set (double value);
}
Remarks
Determines the minor step size value for the scale is set automatically.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MinorStepAuto Property

MinorStepAuto Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► MinorStepAuto
Proxy property that gets or sets the value of MinorStepAuto.
Declaration Syntax
C# Visual Basic Visual C++
public bool MinorStepAuto{ get; set;}
Public Property MinorStepAuto As Boolean
public:
property bool MinorStepAuto {
    bool get ();
    void set (bool value);
}
Remarks
Determines whether or not the scale minor step size value MinorStep is set automatically.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


MinorUnit Property

MinorUnit Property
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► MinorUnit
Proxy property to handle the units for the MinorStep property.
Declaration Syntax
C# Visual Basic Visual C++
public DateUnit MinorUnit{ get; set;}
Public Property MinorUnit As DateUnit
public:
property DateUnit MinorUnit {
    DateUnit get ();
    void set (DateUnit value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebScale ► ToString()()
Returns a string description of the class
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebSize Class

ZedGraphWebSize Class
Namespaces ► ZedGraph.Web ► ZedGraphWebSize
Size class for a FontSpec object
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebSize : GenericItem
Public Class ZedGraphWebSize _
    Inherits GenericItem
public ref class ZedGraphWebSize : public GenericItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebSizeZedGraphWebSizeNew()() | Default constructor
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | Height | Proxy property that gets or sets the value of Height
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Identifies fontspec instance (Overrides Object.ToString()().)
 | Width | Proxy property that gets or sets the value of Width
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebSize

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebSize Constructor

ZedGraphWebSize Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebSize ► ZedGraphWebSizeZedGraphWebSizeNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebSize()
Public Sub New
public:
ZedGraphWebSize ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Height Property

Height Property
Namespaces ► ZedGraph.Web ► ZedGraphWebSize ► Height
Proxy property that gets or sets the value of Height
Declaration Syntax
C# Visual Basic Visual C++
public float Height{ get; set;}
Public Property Height As Single
public:
property float Height {
    float get ();
    void set (float value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebSize ► ToString()()
Identifies fontspec instance
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Width Property

Width Property
Namespaces ► ZedGraph.Web ► ZedGraphWebSize ► Width
Proxy property that gets or sets the value of Width
Declaration Syntax
C# Visual Basic Visual C++
public float Width{ get; set;}
Public Property Width As Single
public:
property float Width {
    float get ();
    void set (float value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebString Class

ZedGraphWebString Class
Namespaces ► ZedGraph.Web ► ZedGraphWebString
A Web String class
Declaration Syntax
C# Visual Basic Visual C++
[DefaultPropertyAttribute("Value")]
public class ZedGraphWebString : GenericItem
<DefaultPropertyAttribute("Value")> _
Public Class ZedGraphWebString _
    Inherits GenericItem
[DefaultPropertyAttribute(L"Value")]
public ref class ZedGraphWebString : public GenericItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebStringZedGraphWebStringNew()() | Default constructor
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Identifies fontspec instance (Overrides Object.ToString()().)
 | Value | Proxy property that gets or sets the value of Height
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebString

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebString Constructor

ZedGraphWebString Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebString ► ZedGraphWebStringZedGraphWebStringNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebString()
Public Sub New
public:
ZedGraphWebString ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebString ► ToString()()
Identifies fontspec instance
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Value Property

Value Property
Namespaces ► ZedGraph.Web ► ZedGraphWebString ► Value
Proxy property that gets or sets the value of Height
Declaration Syntax
C# Visual Basic Visual C++
public string Value{ get; set;}
Public Property Value As String
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebStringCollection Class

ZedGraphWebStringCollection Class
Namespaces ► ZedGraph.Web ► ZedGraphWebStringCollection
Manages a collection of ZedGraphWebGraphObj objects that are state management aware.
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebStringCollection : GenericCollection
Public Class ZedGraphWebStringCollection _
    Inherits GenericCollection
public ref class ZedGraphWebStringCollection : public GenericCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebStringCollectionZedGraphWebStringCollectionNew()() | Default Constructor
 | Add(ZedGraphWebString) | Add a ZedGraphWebString to the collection.
 | Clear()() | Empty the array list and marks the viewstate. (Inherited from GenericCollection.)
 | CopyTo(Array, Int32) | CopyTo(Array, Int32) (Inherited from GenericCollection.)
 | Count | Count (Inherited from GenericCollection.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()() | GetEnumerator()() (Inherited from GenericCollection.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsSynchronized | IsSynchronized (Inherited from GenericCollection.)
 | Item[([Int32])] | Indexer to access the specified String object by its ordinal position in the list.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SyncRoot | SyncRoot (Inherited from GenericCollection.)
 | IList..::Add(Object) | Adds item based on the rules of ListAdd Add(Object) ListAdd(Object) (Inherited from GenericCollection.)
 | IList..::Clear()() | Clear()() (Inherited from GenericCollection.)
 | IList..::Contains(Object) | Contains(Object) (Inherited from GenericCollection.)
 | IList..::IndexOf(Object) | IndexOf(Object) (Inherited from GenericCollection.)
 | IList..::Insert(Int32, Object) | Inserts item according to the rules of ListInsert Insert(Int32, Object) ListInsert(Int32, Object) (Inherited from GenericCollection.)
 | IList..::IsFixedSize | IsFixedSize (Inherited from GenericCollection.)
 | IList..::IsReadOnly | IsReadOnly (Inherited from GenericCollection.)
 | IList..::Item[([Int32])] | Privately implement those members of IList that take or return the object type and expose equivalent public members that take or return an item instance instead. Also implement privately those members of IList that are not meaninful to expose in the public object model of this Collection. (Inherited from GenericCollection.)
 | IList..::Remove(Object) | Removes item based on ListRemove Remove(Object) ListRemove(Object) (Inherited from GenericCollection.)
 | IList..::RemoveAt(Int32) | Removes item based on RemoveAt RemoveAt(Int32) RemoveAt(Int32) (Inherited from GenericCollection.)
 | IStateManager..::IsTrackingViewState | IsTrackingViewState (Inherited from GenericCollection.)
 | IStateManager..::LoadViewState(Object) | Loads the view state. This involves reading each state item pair, verifying schema support for each datatype, creating each item instance, and loading the state into each newly created instance. LoadViewState(Object) (Inherited from GenericCollection.)
 | IStateManager..::SaveViewState()() | Saves the viewstate into a portable object format. This involves saving the state of each item in the list. SaveViewState()() (Inherited from GenericCollection.)
 | IStateManager..::TrackViewState()() | TrackViewState()() (Inherited from GenericCollection.)
 | ToString()() | Override the ToString() method. (Overrides Object.ToString()().)
Inheritance Hierarchy
Object
 | GenericCollection
 |  | ZedGraphWebStringCollection

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebStringCollection Constructor

ZedGraphWebStringCollection Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebStringCollection ► ZedGraphWebStringCollectionZedGraphWebStringCollectionNew()()
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebStringCollection()
Public Sub New
public:
ZedGraphWebStringCollection ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Add Method (item)

Add Method (item)
Namespaces ► ZedGraph.Web ► ZedGraphWebStringCollection ► Add(ZedGraphWebString)
Add a ZedGraphWebString to the collection.
Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    ZedGraphWebString item
)
Public Sub Add ( _
    item As ZedGraphWebString _
)
public:
void Add (
    ZedGraphWebString^ item
)
Parameters
item (ZedGraphWebString)
The ZedGraphWebString object to be added

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Item Property (index)

Item Property (index)
Namespaces ► ZedGraph.Web ► ZedGraphWebStringCollection ► Item[([Int32])]
Indexer to access the specified String object by its ordinal position in the list.
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebString this[
    int index
]{ get; set;}
Public Default Property Item ( _
    index As Integer _
) As ZedGraphWebString
public:
property ZedGraphWebString^ default[int index] {
    ZedGraphWebString^ get (int index);
    void set (int index, ZedGraphWebString^ value);
}
Parameters
index (Int32)
The ordinal position (zero-based) of the String object to be accessed.
Value
A String object reference.
See Also
String

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebStringCollection ► ToString()()
Override the ToString() method.
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
Always returns String.Empty

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebSymbol Class

ZedGraphWebSymbol Class
Namespaces ► ZedGraph.Web ► ZedGraphWebSymbol
Web control state management class for a Symbol object
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebSymbol : GenericItem
Public Class ZedGraphWebSymbol _
    Inherits GenericItem
public ref class ZedGraphWebSymbol : public GenericItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebSymbolZedGraphWebSymbolNew()() | Default Constructor
 | Border | Proxy property that gets or sets the ZedGraphWebBorder object for this Symbol.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Fill | Proxy property that gets or sets the ZedGraphWebFill object for this Symbol.
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible | Proxy property that gets or sets the value of IsVisible.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Size | Proxy property that gets or sets the value of Size.
 | SymbolType | Proxy property that gets or sets the value of Type.
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Override ToString() function (Overrides Object.ToString()().)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebSymbol

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebSymbol Constructor

ZedGraphWebSymbol Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebSymbol ► ZedGraphWebSymbolZedGraphWebSymbolNew()()
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebSymbol()
Public Sub New
public:
ZedGraphWebSymbol ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Border Property

Border Property
Namespaces ► ZedGraph.Web ► ZedGraphWebSymbol ► Border
Proxy property that gets or sets the ZedGraphWebBorder object for this Symbol.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebBorder Border{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Border As ZedGraphWebBorder
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebBorder^ Border {
    ZedGraphWebBorder^ get ();
}
See Also
Border

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Fill Property

Fill Property
Namespaces ► ZedGraph.Web ► ZedGraphWebSymbol ► Fill
Proxy property that gets or sets the ZedGraphWebFill object for this Symbol.
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebFill Fill{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property Fill As ZedGraphWebFill
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebFill^ Fill {
    ZedGraphWebFill^ get ();
}
See Also
Fill

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsVisible Property

IsVisible Property
Namespaces ► ZedGraph.Web ► ZedGraphWebSymbol ► IsVisible
Proxy property that gets or sets the value of IsVisible.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsVisible{ get; set;}
Public Property IsVisible As Boolean
public:
property bool IsVisible {
    bool get ();
    void set (bool value);
}
Remarks
Gets or sets a property that shows or hides the Symbol.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Size Property

Size Property
Namespaces ► ZedGraph.Web ► ZedGraphWebSymbol ► Size
Proxy property that gets or sets the value of Size.
Declaration Syntax
C# Visual Basic Visual C++
public float Size{ get; set;}
Public Property Size As Single
public:
property float Size {
    float get ();
    void set (float value);
}
Remarks
Gets or sets the size of the Symbol in points (1/72nd inch).

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


SymbolType Property

SymbolType Property
Namespaces ► ZedGraph.Web ► ZedGraphWebSymbol ► SymbolType
Proxy property that gets or sets the value of Type.
Declaration Syntax
C# Visual Basic Visual C++
public SymbolType SymbolType{ get; set;}
Public Property SymbolType As SymbolType
public:
property SymbolType SymbolType {
    SymbolType get ();
    void set (SymbolType value);
}
Remarks
Gets or sets the type (shape) of the Symbol using a SymbolType enumeration.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebSymbol ► ToString()()
Override ToString() function
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
Always returns "Symbol"

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebTextObj Class

ZedGraphWebTextObj Class
Namespaces ► ZedGraph.Web ► ZedGraphWebTextObj
Baseclass for graph items in the web control GraphObj
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebTextObj : ZedGraphWebGraphObj
Public Class ZedGraphWebTextObj _
    Inherits ZedGraphWebGraphObj
public ref class ZedGraphWebTextObj : public ZedGraphWebGraphObj
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebTextObjZedGraphWebTextObjNew()() | Default constructor
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontSpec | Proxy property that gets the value of FontSpec
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsVisible | Proxy property that gets or sets the value of IsVisible (Inherited from ZedGraphWebGraphObj.)
 | LayoutArea | Proxy property that gets the value of LayoutArea
 | Location | Proxy property that gets or sets the value of Location (Inherited from ZedGraphWebGraphObj.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | Text | Proxy property that gets or sets the value of Text
 | ToString()() | Identifies curve item by the labels value (Overrides ZedGraphWebGraphObj.ToString()().)
 | ZOrder | Proxy property that gets or sets the value of ZOrder (Inherited from ZedGraphWebGraphObj.)
Remarks
A TextObj uses only: FontSpec Location .CoordinateFrame (CoordType) .X (between 0 and 1 for fraction CoordTypes) 0=left, 1=right .Y (between 0 and 1 for fraction CoordTypes) 0=top, 1=bottom .AlignH .AlignV .layoutArea
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebGraphObj
 |  |  | ZedGraphWebTextObj
See Also
GraphObj

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebTextObj Constructor

ZedGraphWebTextObj Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebTextObj ► ZedGraphWebTextObjZedGraphWebTextObjNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebTextObj()
Public Sub New
public:
ZedGraphWebTextObj ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


FontSpec Property

FontSpec Property
Namespaces ► ZedGraph.Web ► ZedGraphWebTextObj ► FontSpec
Proxy property that gets the value of FontSpec
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebFontSpec FontSpec{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property FontSpec As ZedGraphWebFontSpec
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebFontSpec^ FontSpec {
    ZedGraphWebFontSpec^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


LayoutArea Property

LayoutArea Property
Namespaces ► ZedGraph.Web ► ZedGraphWebTextObj ► LayoutArea
Proxy property that gets the value of LayoutArea
Declaration Syntax
C# Visual Basic Visual C++
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ZedGraphWebSize LayoutArea{ get;}
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)> _
Public ReadOnly Property LayoutArea As ZedGraphWebSize
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
public:
property ZedGraphWebSize^ LayoutArea {
    ZedGraphWebSize^ get ();
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Text Property

Text Property
Namespaces ► ZedGraph.Web ► ZedGraphWebTextObj ► Text
Proxy property that gets or sets the value of Text
Declaration Syntax
C# Visual Basic Visual C++
public string Text{ get; set;}
Public Property Text As String
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebTextObj ► ToString()()
Identifies curve item by the labels value
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebTic Class

ZedGraphWebTic Class
Namespaces ► ZedGraph.Web ► ZedGraphWebTic
Proxy class to manage all properties associated with a grid
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebTic : GenericItem
Public Class ZedGraphWebTic _
    Inherits GenericItem
public ref class ZedGraphWebTic : public GenericItem
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebTicZedGraphWebTicNew()() | Default constructor
 | Color | Proxy property that gets or sets the color of the tics.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsInside | Proxy property that gets or sets the value of IsInside.
 | IsOpposite | Proxy property that gets or sets the value of IsOpposite.
 | IsOutside | Proxy property that gets or sets the value of IsOutside.
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PenWidth | Proxy property that gets or sets the value of PenWidth.
 | Size | Proxy property that gets or sets the size of the tics.
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | ToString()() | Returns a string description of the class (Overrides Object.ToString()().)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebTic

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebTic Constructor

ZedGraphWebTic Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebTic ► ZedGraphWebTicZedGraphWebTicNew()()
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebTic()
Public Sub New
public:
ZedGraphWebTic ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Color Property

Color Property
Namespaces ► ZedGraph.Web ► ZedGraphWebTic ► Color
Proxy property that gets or sets the color of the tics.
Declaration Syntax
C# Visual Basic Visual C++
public Color Color{ get; set;}
Public Property Color As Color
public:
property Color Color {
    Color get ();
    void set (Color value);
}

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsInside Property

IsInside Property
Namespaces ► ZedGraph.Web ► ZedGraphWebTic ► IsInside
Proxy property that gets or sets the value of IsInside.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsInside{ get; set;}
Public Property IsInside As Boolean
public:
property bool IsInside {
    bool get ();
    void set (bool value);
}
Remarks
This value determines whether or not the major inside tic marks are shown. These are the tic marks on the inside of the Axis border. The major tic spacing is controlled by MajorStep.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsOpposite Property

IsOpposite Property
Namespaces ► ZedGraph.Web ► ZedGraphWebTic ► IsOpposite
Proxy property that gets or sets the value of IsOpposite.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOpposite{ get; set;}
Public Property IsOpposite As Boolean
public:
property bool IsOpposite {
    bool get ();
    void set (bool value);
}
Remarks
This value determines whether or not the major opposite tic marks are shown. These are the tic marks on the inside of the Axis border on the opposite side from the axis. The major tic spacing is controlled by MajorStep.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


IsOutside Property

IsOutside Property
Namespaces ► ZedGraph.Web ► ZedGraphWebTic ► IsOutside
Proxy property that gets or sets the value of IsOutside.
Declaration Syntax
C# Visual Basic Visual C++
public bool IsOutside{ get; set;}
Public Property IsOutside As Boolean
public:
property bool IsOutside {
    bool get ();
    void set (bool value);
}
Remarks
Determines whether or not the Axis major tics (where the scale labels are located) will be displayed.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


PenWidth Property

PenWidth Property
Namespaces ► ZedGraph.Web ► ZedGraphWebTic ► PenWidth
Proxy property that gets or sets the value of PenWidth.
Declaration Syntax
C# Visual Basic Visual C++
public float PenWidth{ get; set;}
Public Property PenWidth As Single
public:
property float PenWidth {
    float get ();
    void set (float value);
}
Remarks
This property determines the pen width to be used when drawing the tic marks for this Axis. The pen width is expressed in points (1/72nd inch).

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Size Property

Size Property
Namespaces ► ZedGraph.Web ► ZedGraphWebTic ► Size
Proxy property that gets or sets the size of the tics.
Declaration Syntax
C# Visual Basic Visual C++
public float Size{ get; set;}
Public Property Size As Single
public:
property float Size {
    float get ();
    void set (float value);
}
Remarks
The length of the Axis tic marks, expressed in points (1/72nd inch).

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebTic ► ToString()()
Returns a string description of the class
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebXAxis Class

ZedGraphWebXAxis Class
Namespaces ► ZedGraph.Web ► ZedGraphWebXAxis
Web control state management class for a XAxis object
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebXAxis : ZedGraphWebAxis
Public Class ZedGraphWebXAxis _
    Inherits ZedGraphWebAxis
public ref class ZedGraphWebXAxis : public ZedGraphWebAxis
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebXAxisZedGraphWebXAxisNew()() | Default constructor.
 | AxisColor | Proxy property that gets or sets the value of Color. (Inherited from ZedGraphWebAxis.)
 | Cross | Proxy property that gets or sets the value of Cross. (Inherited from ZedGraphWebAxis.)
 | CrossAuto | Proxy property that gets or sets the value of CrossAuto. (Inherited from ZedGraphWebAxis.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontSpec | Proxy property that gets or sets the value of Title FontSpec. (Inherited from ZedGraphWebAxis.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsOmitMag | Proxy property that gets or sets the value of IsOmitMag. (Inherited from ZedGraphWebAxis.)
 | IsPreventLabelOverlap | Proxy property that gets or sets the value of IsPreventLabelOverlap. (Inherited from ZedGraphWebAxis.)
 | IsShowTitle | Proxy property that gets or sets the value of Title IsVisible. (Inherited from ZedGraphWebAxis.)
 | IsTicsBetweenLabels | Proxy property that gets or sets the value of IsBetweenLabels. (Inherited from ZedGraphWebAxis.)
 | IsUseTenPower | Proxy property that gets or sets the value of IsUseTenPower. (Inherited from ZedGraphWebAxis.)
 | IsVisible | Proxy property that gets or sets the value of IsVisible. (Inherited from ZedGraphWebAxis.)
 | IsZeroLine | Proxy property that gets or sets the value of IsZeroLine. (Inherited from ZedGraphWebAxis.)
 | MajorGrid | Proxy property to get or set the values for the GraphPane major grid. (Inherited from ZedGraphWebAxis.)
 | MajorTic | Proxy property to get or set the values for the GraphPane major tics. (Inherited from ZedGraphWebAxis.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinorGrid | Proxy property to get or set the values for the GraphPane minor grid. (Inherited from ZedGraphWebAxis.)
 | MinorTic | Proxy property to get or set the values for the GraphPane minor tics. (Inherited from ZedGraphWebAxis.)
 | MinSpace | Proxy property that gets or sets the value of MinSpace. (Inherited from ZedGraphWebAxis.)
 | Scale | Proxy property to get or set the values for the axis scale. (Inherited from ZedGraphWebAxis.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | Title | Proxy property that gets or sets the value of Title. (Inherited from ZedGraphWebAxis.)
 | ToString()() | Identifies XAxis by the Title value (Overrides ZedGraphWebAxis.ToString()().)
 | Type | Proxy property that gets or sets the value of Type. (Inherited from ZedGraphWebAxis.)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebAxis
 |  |  | ZedGraphWebXAxis

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebXAxis Constructor

ZedGraphWebXAxis Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebXAxis ► ZedGraphWebXAxisZedGraphWebXAxisNew()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebXAxis()
Public Sub New
public:
ZedGraphWebXAxis ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebXAxis ► ToString()()
Identifies XAxis by the Title value
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
A string containing "XAxis: title", where 'title' is the Title property of the XAxis

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebY2Axis Class

ZedGraphWebY2Axis Class
Namespaces ► ZedGraph.Web ► ZedGraphWebY2Axis
Web control state management class for a Y2Axis object
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebY2Axis : ZedGraphWebAxis
Public Class ZedGraphWebY2Axis _
    Inherits ZedGraphWebAxis
public ref class ZedGraphWebY2Axis : public ZedGraphWebAxis
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebY2AxisZedGraphWebY2AxisNew()() | Default constructor.
 | AxisColor | Proxy property that gets or sets the value of Color. (Inherited from ZedGraphWebAxis.)
 | Cross | Proxy property that gets or sets the value of Cross. (Inherited from ZedGraphWebAxis.)
 | CrossAuto | Proxy property that gets or sets the value of CrossAuto. (Inherited from ZedGraphWebAxis.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontSpec | Proxy property that gets or sets the value of Title FontSpec. (Inherited from ZedGraphWebAxis.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsOmitMag | Proxy property that gets or sets the value of IsOmitMag. (Inherited from ZedGraphWebAxis.)
 | IsPreventLabelOverlap | Proxy property that gets or sets the value of IsPreventLabelOverlap. (Inherited from ZedGraphWebAxis.)
 | IsShowTitle | Proxy property that gets or sets the value of Title IsVisible. (Inherited from ZedGraphWebAxis.)
 | IsTicsBetweenLabels | Proxy property that gets or sets the value of IsBetweenLabels. (Inherited from ZedGraphWebAxis.)
 | IsUseTenPower | Proxy property that gets or sets the value of IsUseTenPower. (Inherited from ZedGraphWebAxis.)
 | IsVisible | Proxy property that gets or sets the value of IsVisible. (Inherited from ZedGraphWebAxis.)
 | IsZeroLine | Proxy property that gets or sets the value of IsZeroLine. (Inherited from ZedGraphWebAxis.)
 | MajorGrid | Proxy property to get or set the values for the GraphPane major grid. (Inherited from ZedGraphWebAxis.)
 | MajorTic | Proxy property to get or set the values for the GraphPane major tics. (Inherited from ZedGraphWebAxis.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinorGrid | Proxy property to get or set the values for the GraphPane minor grid. (Inherited from ZedGraphWebAxis.)
 | MinorTic | Proxy property to get or set the values for the GraphPane minor tics. (Inherited from ZedGraphWebAxis.)
 | MinSpace | Proxy property that gets or sets the value of MinSpace. (Inherited from ZedGraphWebAxis.)
 | Scale | Proxy property to get or set the values for the axis scale. (Inherited from ZedGraphWebAxis.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | Title | Proxy property that gets or sets the value of Title. (Inherited from ZedGraphWebAxis.)
 | ToString()() | Identifies Y2Axis by the Title value (Overrides ZedGraphWebAxis.ToString()().)
 | Type | Proxy property that gets or sets the value of Type. (Inherited from ZedGraphWebAxis.)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebAxis
 |  |  | ZedGraphWebY2Axis

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebY2Axis Constructor

ZedGraphWebY2Axis Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebY2Axis ► ZedGraphWebY2AxisZedGraphWebY2AxisNew()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebY2Axis()
Public Sub New
public:
ZedGraphWebY2Axis ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebY2Axis ► ToString()()
Identifies Y2Axis by the Title value
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
A string containing "Y2Axis: title", where 'title' is the Title property of the Y2Axis

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebYAxis Class

ZedGraphWebYAxis Class
Namespaces ► ZedGraph.Web ► ZedGraphWebYAxis
Web control state management class for a YAxis object
Declaration Syntax
C# Visual Basic Visual C++
public class ZedGraphWebYAxis : ZedGraphWebAxis
Public Class ZedGraphWebYAxis _
    Inherits ZedGraphWebAxis
public ref class ZedGraphWebYAxis : public ZedGraphWebAxis
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ZedGraphWebYAxisZedGraphWebYAxisNew()() | Default constructor.
 | AxisColor | Proxy property that gets or sets the value of Color. (Inherited from ZedGraphWebAxis.)
 | Cross | Proxy property that gets or sets the value of Cross. (Inherited from ZedGraphWebAxis.)
 | CrossAuto | Proxy property that gets or sets the value of CrossAuto. (Inherited from ZedGraphWebAxis.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FontSpec | Proxy property that gets or sets the value of Title FontSpec. (Inherited from ZedGraphWebAxis.)
 | GetHashCode()() | Serves as a hash function for a particular type. GetHashCode()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
 | GetType()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsOmitMag | Proxy property that gets or sets the value of IsOmitMag. (Inherited from ZedGraphWebAxis.)
 | IsPreventLabelOverlap | Proxy property that gets or sets the value of IsPreventLabelOverlap. (Inherited from ZedGraphWebAxis.)
 | IsShowTitle | Proxy property that gets or sets the value of Title IsVisible. (Inherited from ZedGraphWebAxis.)
 | IsTicsBetweenLabels | Proxy property that gets or sets the value of IsBetweenLabels. (Inherited from ZedGraphWebAxis.)
 | IsUseTenPower | Proxy property that gets or sets the value of IsUseTenPower. (Inherited from ZedGraphWebAxis.)
 | IsVisible | Proxy property that gets or sets the value of IsVisible. (Inherited from ZedGraphWebAxis.)
 | IsZeroLine | Proxy property that gets or sets the value of IsZeroLine. (Inherited from ZedGraphWebAxis.)
 | MajorGrid | Proxy property to get or set the values for the GraphPane major grid. (Inherited from ZedGraphWebAxis.)
 | MajorTic | Proxy property to get or set the values for the GraphPane major tics. (Inherited from ZedGraphWebAxis.)
 | MemberwiseClone()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinorGrid | Proxy property to get or set the values for the GraphPane minor grid. (Inherited from ZedGraphWebAxis.)
 | MinorTic | Proxy property to get or set the values for the GraphPane minor tics. (Inherited from ZedGraphWebAxis.)
 | MinSpace | Proxy property that gets or sets the value of MinSpace. (Inherited from ZedGraphWebAxis.)
 | Scale | Proxy property to get or set the values for the axis scale. (Inherited from ZedGraphWebAxis.)
 | IStateManager..::IsTrackingViewState | Implementation of the IStateManager.IsTrackingViewState property. (Inherited from GenericItem.)
 | IStateManager..::LoadViewState(Object) | Implementation of the IStateManager.LoadViewState method (Inherited from GenericItem.)
 | IStateManager..::SaveViewState()() | Implementation of the IStateManager.SaveViewState method (Inherited from GenericItem.)
 | IStateManager..::TrackViewState()() | Implementation of the IStateManager.TrackViewState method (Inherited from GenericItem.)
 | Title | Proxy property that gets or sets the value of Title. (Inherited from ZedGraphWebAxis.)
 | ToString()() | Identifies YAxis by the Title value (Overrides ZedGraphWebAxis.ToString()().)
 | Type | Proxy property that gets or sets the value of Type. (Inherited from ZedGraphWebAxis.)
Inheritance Hierarchy
Object
 | GenericItem
 |  | ZedGraphWebAxis
 |  |  | ZedGraphWebYAxis

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ZedGraphWebYAxis Constructor

ZedGraphWebYAxis Constructor
Namespaces ► ZedGraph.Web ► ZedGraphWebYAxis ► ZedGraphWebYAxisZedGraphWebYAxisNew()()
Default constructor.
Declaration Syntax
C# Visual Basic Visual C++
public ZedGraphWebYAxis()
Public Sub New
public:
ZedGraphWebYAxis ()

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


ToString Method

ToString Method
Namespaces ► ZedGraph.Web ► ZedGraphWebYAxis ► ToString()()
Identifies YAxis by the Title value
Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString () override
Return Value
A string containing "YAxis: title", where 'title' is the Title property of the YAxis

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


AddPoint Method

AddPoint Method
Namespaces ► ZedGraph ► BarItem ► AddPoint()()
Members
Icon | Member | Description
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve.
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve.


MakeUnique Method

MakeUnique Method
Namespaces ► ZedGraph ► BarItem ► MakeUnique()()
Members
Icon | Member | Description
 | MakeUnique()() | Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator)


GetPen Method

GetPen Method
Namespaces ► ZedGraph ► Border ► GetPen()()
Members
Icon | Member | Description
 | GetPen(PaneBase, Single) | Create a Pen object based on the properties of this LineBase.
 | GetPen(PaneBase, Single, PointPair) | Create a Pen object based on the properties of this LineBase.


BinarySearch Method

BinarySearch Method
Namespaces ► ZedGraph ► CurveList ► BinarySearch()()
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element.
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.


CopyTo Method

CopyTo Method
Namespaces ► ZedGraph ► CurveList ► CopyTo()()
Members
Icon | Member | Description
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array.
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.


FindIndex Method

FindIndex Method
Namespaces ► ZedGraph ► CurveList ► FindIndex()()
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


FindLastIndex Method

FindLastIndex Method
Namespaces ► ZedGraph ► CurveList ► FindLastIndex()()
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


GetRange Method

GetRange Method
Namespaces ► ZedGraph ► CurveList ► GetRange()()
Members
Icon | Member | Description
 | GetRange(Boolean, Boolean, GraphPane) | Go through each CurveItem object in the collection, calling the GetRange(Double%, Double%, Double%, Double%, Boolean, Boolean, GraphPane) member to determine the minimum and maximum values in the Points list of data value pairs. If the curves include a stack bar, handle within the current GetRange method. In the event that no data are available, a default range of min=0.0 and max=1.0 are returned. If the Y axis has a valid data range and the Y2 axis not, then the Y2 range will be a duplicate of the Y range. Vice-versa for the Y2 axis having valid data when the Y axis does not. If any CurveItem in the list has a missing PointPairList, a new empty one will be generated.
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <T>)>.


IndexOf Method

IndexOf Method
Namespaces ► ZedGraph ► CurveList ► IndexOf()()
Members
Icon | Member | Description
 | IndexOf(String) | Return the zero-based position index of the CurveItem with the specified Label.
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


Item Property

Item Property
Namespaces ► ZedGraph ► CurveList ► Item
Members
Icon | Member | Description
 | Item[([String])] | Indexer to access the specified CurveItem object by its Label string.
 | Item[([Int32])] | Gets or sets the element at the specified index.


LastIndexOf Method

LastIndexOf Method
Namespaces ► ZedGraph ► CurveList ► LastIndexOf()()
Members
Icon | Member | Description
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


Reverse Method

Reverse Method
Namespaces ► ZedGraph ► CurveList ► Reverse()()
Members
Icon | Member | Description
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>.
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.


Sort Method

Sort Method
Namespaces ► ZedGraph ► CurveList ► Sort()()
Members
Icon | Member | Description
 | Sort(SortType, Int32) | Sorts the list according to the point values at the specified index and for the specified axis.
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer.
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer.
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>.


AddPoint Method

AddPoint Method
Namespaces ► ZedGraph ► ErrorBarItem ► AddPoint()()
Members
Icon | Member | Description
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve.
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve.


MakeUnique Method

MakeUnique Method
Namespaces ► ZedGraph ► ErrorBarItem ► MakeUnique()()
Members
Icon | Member | Description
 | MakeUnique()() | Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator)


AddPoint Method

AddPoint Method
Namespaces ► ZedGraph ► GasGaugeNeedle ► AddPoint()()
Members
Icon | Member | Description
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve.
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve.


MakeUnique Method

MakeUnique Method
Namespaces ► ZedGraph ► GasGaugeNeedle ► MakeUnique()()
Members
Icon | Member | Description
 | MakeUnique()() | Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator)


AddPoint Method

AddPoint Method
Namespaces ► ZedGraph ► GasGaugeRegion ► AddPoint()()
Members
Icon | Member | Description
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve.
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve.


MakeUnique Method

MakeUnique Method
Namespaces ► ZedGraph ► GasGaugeRegion ► MakeUnique()()
Members
Icon | Member | Description
 | MakeUnique()() | Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator)


BinarySearch Method

BinarySearch Method
Namespaces ► ZedGraph ► GraphObjList ► BinarySearch()()
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element.
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.


CopyTo Method

CopyTo Method
Namespaces ► ZedGraph ► GraphObjList ► CopyTo()()
Members
Icon | Member | Description
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array.
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.


FindIndex Method

FindIndex Method
Namespaces ► ZedGraph ► GraphObjList ► FindIndex()()
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


FindLastIndex Method

FindLastIndex Method
Namespaces ► ZedGraph ► GraphObjList ► FindLastIndex()()
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


IndexOf Method

IndexOf Method
Namespaces ► ZedGraph ► GraphObjList ► IndexOf()()
Members
Icon | Member | Description
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


Item Property

Item Property
Namespaces ► ZedGraph ► GraphObjList ► Item
Members
Icon | Member | Description
 | Item[([String])] | Indexer to access the specified GraphObj object by its Tag. Note that the Tag must be a String type for this method to work.
 | Item[([Int32])] | Gets or sets the element at the specified index.


LastIndexOf Method

LastIndexOf Method
Namespaces ► ZedGraph ► GraphObjList ► LastIndexOf()()
Members
Icon | Member | Description
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


Reverse Method

Reverse Method
Namespaces ► ZedGraph ► GraphObjList ► Reverse()()
Members
Icon | Member | Description
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>.
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.


Sort Method

Sort Method
Namespaces ► ZedGraph ► GraphObjList ► Sort()()
Members
Icon | Member | Description
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer.
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer.
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer.
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>.


GetImage Method

GetImage Method
Namespaces ► ZedGraph ► GraphPane ► GetImage()()
Members
Icon | Member | Description
 | GetImage()() | Build a Bitmap object containing the graphical rendering of all the GraphPane objects in this list.
 | GetImage(Int32, Int32, Single) | Gets an image for the current GraphPane, scaled to the specified size and resolution.


Draw Method

Draw Method
Namespaces ► ZedGraph ► HiLowBar ► Draw()()
Members
Icon | Member | Description
 | Draw(Graphics, GraphPane, Single, Single, Single, Single, Single, Boolean, Boolean, PointPair) | Draw the Bar to the specified Graphics device at the specified location. This routine draws a single bar.
 | Draw(Graphics, GraphPane, RectangleF, Single, Boolean, Boolean, PointPair) | Draw the Bar to the specified Graphics device at the specified location. This routine draws a single bar.


AddPoint Method

AddPoint Method
Namespaces ► ZedGraph ► HiLowBarItem ► AddPoint()()
Members
Icon | Member | Description
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve.
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve.


MakeUnique Method

MakeUnique Method
Namespaces ► ZedGraph ► HiLowBarItem ► MakeUnique()()
Members
Icon | Member | Description
 | MakeUnique()() | Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator)


Item Property

Item Property
Namespaces ► ZedGraph ► IPointListEdit ► Item
Members
Icon | Member | Description
 | Item[([Int32])] | Indexer to access a data point by its ordinal position in the collection.
 | Item[([Int32])] | Indexer to access a data point by its ordinal position in the collection.


GetPen Method

GetPen Method
Namespaces ► ZedGraph ► JapaneseCandleStick ► GetPen()()
Members
Icon | Member | Description
 | GetPen(PaneBase, Single) | Create a Pen object based on the properties of this LineBase.
 | GetPen(PaneBase, Single, PointPair) | Create a Pen object based on the properties of this LineBase.


AddPoint Method

AddPoint Method
Namespaces ► ZedGraph ► JapaneseCandleStickItem ► AddPoint()()
Members
Icon | Member | Description
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve.
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve.


MakeUnique Method

MakeUnique Method
Namespaces ► ZedGraph ► JapaneseCandleStickItem ► MakeUnique()()
Members
Icon | Member | Description
 | MakeUnique()() | Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator)


GetPen Method

GetPen Method
Namespaces ► ZedGraph ► Line ► GetPen()()
Members
Icon | Member | Description
 | GetPen(PaneBase, Single) | Create a Pen object based on the properties of this LineBase.
 | GetPen(PaneBase, Single, PointPair) | Create a Pen object based on the properties of this LineBase.


AddPoint Method

AddPoint Method
Namespaces ► ZedGraph ► LineItem ► AddPoint()()
Members
Icon | Member | Description
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve.
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve.


GetImage Method

GetImage Method
Namespaces ► ZedGraph ► MasterPane ► GetImage()()
Members
Icon | Member | Description
 | GetImage()() | Build a Bitmap object containing the graphical rendering of all the GraphPane objects in this list.
 | GetImage(Int32, Int32, Single) | Gets an image for the current GraphPane, scaled to the specified size and resolution.


BinarySearch Method

BinarySearch Method
Namespaces ► ZedGraph ► NoDupePointList ► BinarySearch()()
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element.
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.


CopyTo Method

CopyTo Method
Namespaces ► ZedGraph ► NoDupePointList ► CopyTo()()
Members
Icon | Member | Description
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array.
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.


FindIndex Method

FindIndex Method
Namespaces ► ZedGraph ► NoDupePointList ► FindIndex()()
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


FindLastIndex Method

FindLastIndex Method
Namespaces ► ZedGraph ► NoDupePointList ► FindLastIndex()()
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


IndexOf Method

IndexOf Method
Namespaces ► ZedGraph ► NoDupePointList ► IndexOf()()
Members
Icon | Member | Description
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


LastIndexOf Method

LastIndexOf Method
Namespaces ► ZedGraph ► NoDupePointList ► LastIndexOf()()
Members
Icon | Member | Description
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


Reverse Method

Reverse Method
Namespaces ► ZedGraph ► NoDupePointList ► Reverse()()
Members
Icon | Member | Description
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>.
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.


Sort Method

Sort Method
Namespaces ► ZedGraph ► NoDupePointList ► Sort()()
Members
Icon | Member | Description
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer.
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer.
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer.
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>.


GetPen Method

GetPen Method
Namespaces ► ZedGraph ► OHLCBar ► GetPen()()
Members
Icon | Member | Description
 | GetPen(PaneBase, Single) | Create a Pen object based on the properties of this LineBase.
 | GetPen(PaneBase, Single, PointPair) | Create a Pen object based on the properties of this LineBase.


AddPoint Method

AddPoint Method
Namespaces ► ZedGraph ► OHLCBarItem ► AddPoint()()
Members
Icon | Member | Description
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve.
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve.


MakeUnique Method

MakeUnique Method
Namespaces ► ZedGraph ► OHLCBarItem ► MakeUnique()()
Members
Icon | Member | Description
 | MakeUnique()() | Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator)


BinarySearch Method

BinarySearch Method
Namespaces ► ZedGraph ► PaneList ► BinarySearch()()
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element.
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.


CopyTo Method

CopyTo Method
Namespaces ► ZedGraph ► PaneList ► CopyTo()()
Members
Icon | Member | Description
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array.
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.


FindIndex Method

FindIndex Method
Namespaces ► ZedGraph ► PaneList ► FindIndex()()
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


FindLastIndex Method

FindLastIndex Method
Namespaces ► ZedGraph ► PaneList ► FindLastIndex()()
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


IndexOf Method

IndexOf Method
Namespaces ► ZedGraph ► PaneList ► IndexOf()()
Members
Icon | Member | Description
 | IndexOf(String) | Return the zero-based position index of the GraphPane with the specified Title.
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


Item Property

Item Property
Namespaces ► ZedGraph ► PaneList ► Item
Members
Icon | Member | Description
 | Item[([String])] | Indexer to access the specified GraphPane object by its Title string.
 | Item[([Int32])] | Gets or sets the element at the specified index.


LastIndexOf Method

LastIndexOf Method
Namespaces ► ZedGraph ► PaneList ► LastIndexOf()()
Members
Icon | Member | Description
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


Reverse Method

Reverse Method
Namespaces ► ZedGraph ► PaneList ► Reverse()()
Members
Icon | Member | Description
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>.
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.


Sort Method

Sort Method
Namespaces ► ZedGraph ► PaneList ► Sort()()
Members
Icon | Member | Description
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer.
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer.
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer.
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>.


AddPoint Method

AddPoint Method
Namespaces ► ZedGraph ► PieItem ► AddPoint()()
Members
Icon | Member | Description
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve.
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve.


MakeUnique Method

MakeUnique Method
Namespaces ► ZedGraph ► PieItem ► MakeUnique()()
Members
Icon | Member | Description
 | MakeUnique()() | Loads some pseudo unique colors/symbols into this CurveItem. This is the same as MakeUnique(ColorSymbolRotator.StaticInstance). StaticInstance ColorSymbolRotator MakeUnique(ColorSymbolRotator)
 | MakeUnique(ColorSymbolRotator) | Loads some pseudo unique colors/symbols into this CurveItem. This is mainly useful for differentiating a set of new CurveItems without having to pick your own colors/symbols. MakeUnique(ColorSymbolRotator)


ToString Method

ToString Method
Namespaces ► ZedGraph ► PointPairCV ► ToString()()
Members
Icon | Member | Description
 | ToString(Boolean) | Format this PointPair value using the default format. Example: "( 12.345, -16.876 )". The two double values are formatted with the "g" format type.
 | ToString(String, Boolean) | Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". If is true, then the third "Z" coordinate is also shown.
 | ToString(String, String, String) | Format this PointPair value using different general format strings for the X, Y, and Z values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )".
 | ToString(String) | Format this PointPair value using a general format string. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )".
 | ToString(String, String) | Format this PointPair value using different general format strings for the X and Y values. Example: a format string of "e2" would give "( 1.23e+001, -1.69e+001 )". The Z value is not displayed (see ToString(String, String, String)).


BinarySearch Method

BinarySearch Method
Namespaces ► ZedGraph ► PointPairList ► BinarySearch()()
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element.
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.


CopyTo Method

CopyTo Method
Namespaces ► ZedGraph ► PointPairList ► CopyTo()()
Members
Icon | Member | Description
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array.
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.


FindIndex Method

FindIndex Method
Namespaces ► ZedGraph ► PointPairList ► FindIndex()()
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


FindLastIndex Method

FindLastIndex Method
Namespaces ► ZedGraph ► PointPairList ► FindLastIndex()()
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


IndexOf Method

IndexOf Method
Namespaces ► ZedGraph ► PointPairList ► IndexOf()()
Members
Icon | Member | Description
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


LastIndexOf Method

LastIndexOf Method
Namespaces ► ZedGraph ► PointPairList ► LastIndexOf()()
Members
Icon | Member | Description
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


Reverse Method

Reverse Method
Namespaces ► ZedGraph ► PointPairList ► Reverse()()
Members
Icon | Member | Description
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>.
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.


Add Method

Add Method
Namespaces ► ZedGraph ► RadarPointList ► Add()()
Members
Icon | Member | Description
 | Add(Double, Double) | Add a single point to the RadarPointList from two values of type double.
 | Add(T) | Adds an object to the end of the List<(Of <T>)>.


BinarySearch Method

BinarySearch Method
Namespaces ► ZedGraph ► RadarPointList ► BinarySearch()()
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element.
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.


CopyTo Method

CopyTo Method
Namespaces ► ZedGraph ► RadarPointList ► CopyTo()()
Members
Icon | Member | Description
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array.
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.


FindIndex Method

FindIndex Method
Namespaces ► ZedGraph ► RadarPointList ► FindIndex()()
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


FindLastIndex Method

FindLastIndex Method
Namespaces ► ZedGraph ► RadarPointList ► FindLastIndex()()
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


IndexOf Method

IndexOf Method
Namespaces ► ZedGraph ► RadarPointList ► IndexOf()()
Members
Icon | Member | Description
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


LastIndexOf Method

LastIndexOf Method
Namespaces ► ZedGraph ► RadarPointList ► LastIndexOf()()
Members
Icon | Member | Description
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


Reverse Method

Reverse Method
Namespaces ► ZedGraph ► RadarPointList ► Reverse()()
Members
Icon | Member | Description
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>.
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.


Sort Method

Sort Method
Namespaces ► ZedGraph ► RadarPointList ► Sort()()
Members
Icon | Member | Description
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer.
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer.
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer.
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>.


BinarySearch Method

BinarySearch Method
Namespaces ► ZedGraph ► ScaleStateList ► BinarySearch()()
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element.
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.


CopyTo Method

CopyTo Method
Namespaces ► ZedGraph ► ScaleStateList ► CopyTo()()
Members
Icon | Member | Description
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array.
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.


FindIndex Method

FindIndex Method
Namespaces ► ZedGraph ► ScaleStateList ► FindIndex()()
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


FindLastIndex Method

FindLastIndex Method
Namespaces ► ZedGraph ► ScaleStateList ► FindLastIndex()()
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


IndexOf Method

IndexOf Method
Namespaces ► ZedGraph ► ScaleStateList ► IndexOf()()
Members
Icon | Member | Description
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


LastIndexOf Method

LastIndexOf Method
Namespaces ► ZedGraph ► ScaleStateList ► LastIndexOf()()
Members
Icon | Member | Description
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


Reverse Method

Reverse Method
Namespaces ► ZedGraph ► ScaleStateList ► Reverse()()
Members
Icon | Member | Description
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>.
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.


Sort Method

Sort Method
Namespaces ► ZedGraph ► ScaleStateList ► Sort()()
Members
Icon | Member | Description
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer.
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer.
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer.
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>.


BinarySearch Method

BinarySearch Method
Namespaces ► ZedGraph ► ScrollRangeList ► BinarySearch()()
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element.
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.


CopyTo Method

CopyTo Method
Namespaces ► ZedGraph ► ScrollRangeList ► CopyTo()()
Members
Icon | Member | Description
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array.
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.


FindIndex Method

FindIndex Method
Namespaces ► ZedGraph ► ScrollRangeList ► FindIndex()()
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


FindLastIndex Method

FindLastIndex Method
Namespaces ► ZedGraph ► ScrollRangeList ► FindLastIndex()()
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


IndexOf Method

IndexOf Method
Namespaces ► ZedGraph ► ScrollRangeList ► IndexOf()()
Members
Icon | Member | Description
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


LastIndexOf Method

LastIndexOf Method
Namespaces ► ZedGraph ► ScrollRangeList ► LastIndexOf()()
Members
Icon | Member | Description
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


Reverse Method

Reverse Method
Namespaces ► ZedGraph ► ScrollRangeList ► Reverse()()
Members
Icon | Member | Description
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>.
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.


Sort Method

Sort Method
Namespaces ► ZedGraph ► ScrollRangeList ► Sort()()
Members
Icon | Member | Description
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer.
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer.
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer.
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>.


BinarySearch Method

BinarySearch Method
Namespaces ► ZedGraph ► Selection ► BinarySearch()()
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element.
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.


CopyTo Method

CopyTo Method
Namespaces ► ZedGraph ► Selection ► CopyTo()()
Members
Icon | Member | Description
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array.
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.


FindIndex Method

FindIndex Method
Namespaces ► ZedGraph ► Selection ► FindIndex()()
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


FindLastIndex Method

FindLastIndex Method
Namespaces ► ZedGraph ► Selection ► FindLastIndex()()
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


GetRange Method

GetRange Method
Namespaces ► ZedGraph ► Selection ► GetRange()()
Members
Icon | Member | Description
 | GetRange(Boolean, Boolean, GraphPane) | Go through each CurveItem object in the collection, calling the GetRange(Double%, Double%, Double%, Double%, Boolean, Boolean, GraphPane) member to determine the minimum and maximum values in the Points list of data value pairs. If the curves include a stack bar, handle within the current GetRange method. In the event that no data are available, a default range of min=0.0 and max=1.0 are returned. If the Y axis has a valid data range and the Y2 axis not, then the Y2 range will be a duplicate of the Y range. Vice-versa for the Y2 axis having valid data when the Y axis does not. If any CurveItem in the list has a missing PointPairList, a new empty one will be generated.
 | GetRange(Int32, Int32) | Creates a shallow copy of a range of elements in the source List<(Of <T>)>.


IndexOf Method

IndexOf Method
Namespaces ► ZedGraph ► Selection ► IndexOf()()
Members
Icon | Member | Description
 | IndexOf(String) | Return the zero-based position index of the CurveItem with the specified Label.
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


Item Property

Item Property
Namespaces ► ZedGraph ► Selection ► Item
Members
Icon | Member | Description
 | Item[([String])] | Indexer to access the specified CurveItem object by its Label string.
 | Item[([Int32])] | Gets or sets the element at the specified index.


LastIndexOf Method

LastIndexOf Method
Namespaces ► ZedGraph ► Selection ► LastIndexOf()()
Members
Icon | Member | Description
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


Reverse Method

Reverse Method
Namespaces ► ZedGraph ► Selection ► Reverse()()
Members
Icon | Member | Description
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>.
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.


Sort Method

Sort Method
Namespaces ► ZedGraph ► Selection ► Sort()()
Members
Icon | Member | Description
 | Sort(SortType, Int32) | Sorts the list according to the point values at the specified index and for the specified axis.
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer.
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer.
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>.


AddPoint Method

AddPoint Method
Namespaces ► ZedGraph ► StickItem ► AddPoint()()
Members
Icon | Member | Description
 | AddPoint(Double, Double) | Add a single x,y coordinate point to the end of the points collection for this curve.
 | AddPoint(PointPair) | Add a PointPair object to the end of the points collection for this curve.


BinarySearch Method

BinarySearch Method
Namespaces ► ZedGraph ► StockPointList ► BinarySearch()()
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element.
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.


CopyTo Method

CopyTo Method
Namespaces ► ZedGraph ► StockPointList ► CopyTo()()
Members
Icon | Member | Description
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array.
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.


FindIndex Method

FindIndex Method
Namespaces ► ZedGraph ► StockPointList ► FindIndex()()
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


FindLastIndex Method

FindLastIndex Method
Namespaces ► ZedGraph ► StockPointList ► FindLastIndex()()
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


IndexOf Method

IndexOf Method
Namespaces ► ZedGraph ► StockPointList ► IndexOf()()
Members
Icon | Member | Description
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


LastIndexOf Method

LastIndexOf Method
Namespaces ► ZedGraph ► StockPointList ► LastIndexOf()()
Members
Icon | Member | Description
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


Reverse Method

Reverse Method
Namespaces ► ZedGraph ► StockPointList ► Reverse()()
Members
Icon | Member | Description
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>.
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.


Sort Method

Sort Method
Namespaces ► ZedGraph ► StockPointList ► Sort()()
Members
Icon | Member | Description
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer.
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer.
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer.
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>.


EditValue Method

EditValue Method
Namespaces ► ZedGraph.Web ► GenericCollectionEditor ► EditValue()()
Members
Icon | Member | Description
 | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the value of the specified object using the specified service provider and context. (Overrides UITypeEditor.EditValue(ITypeDescriptorContext, IServiceProvider, Object).)
 | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle()() method.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


GetPaintValueSupported Method

GetPaintValueSupported Method
Namespaces ► ZedGraph.Web ► GenericCollectionEditor ► GetPaintValueSupported()()
Members
Icon | Member | Description
 | GetPaintValueSupported()() | Indicates whether this editor supports painting a representation of an object's value.
 | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


PaintValue Method

PaintValue Method
Namespaces ► ZedGraph.Web ► GenericCollectionEditor ► PaintValue()()
Members
Icon | Member | Description
 | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas.
 | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


DataBind Method

DataBind Method
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► DataBind()()
Members
Icon | Member | Description
 | DataBind()() | Binds a data source to the invoked server control and all its child controls.
 | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


FindControl Method

FindControl Method
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► FindControl()()
Members
Icon | Member | Description
 | FindControl(String) | Searches the current naming container for a server control with the specified id parameter.
 | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()() method.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


RenderControl Method

RenderControl Method
Namespaces ► ZedGraph.Web ► ZedGraphWeb ► RenderControl()()
Members
Icon | Member | Description
 | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled.
 | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object.

Copyright © 2007 John Champion

Assembly: ZedGraph.Web (Module: ZedGraph.Web) Version: 5.1.0.623


Add Method

Add Method
Namespaces ► ZedGraph ► Y2AxisList ► Add()()
Members
Icon | Member | Description
 | Add(String) | Create a new Y2Axis and add it to this list.
 | Add(T) | Adds an object to the end of the List<(Of <T>)>.


BinarySearch Method

BinarySearch Method
Namespaces ► ZedGraph ► Y2AxisList ► BinarySearch()()
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element.
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.


CopyTo Method

CopyTo Method
Namespaces ► ZedGraph ► Y2AxisList ► CopyTo()()
Members
Icon | Member | Description
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array.
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.


FindIndex Method

FindIndex Method
Namespaces ► ZedGraph ► Y2AxisList ► FindIndex()()
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


FindLastIndex Method

FindLastIndex Method
Namespaces ► ZedGraph ► Y2AxisList ► FindLastIndex()()
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


IndexOf Method

IndexOf Method
Namespaces ► ZedGraph ► Y2AxisList ► IndexOf()()
Members
Icon | Member | Description
 | IndexOf(String) | Return the zero-based position index of the Axis with the specified Title.
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


LastIndexOf Method

LastIndexOf Method
Namespaces ► ZedGraph ► Y2AxisList ► LastIndexOf()()
Members
Icon | Member | Description
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


Reverse Method

Reverse Method
Namespaces ► ZedGraph ► Y2AxisList ► Reverse()()
Members
Icon | Member | Description
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>.
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.


Sort Method

Sort Method
Namespaces ► ZedGraph ► Y2AxisList ► Sort()()
Members
Icon | Member | Description
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer.
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer.
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer.
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>.


Add Method

Add Method
Namespaces ► ZedGraph ► YAxisList ► Add()()
Members
Icon | Member | Description
 | Add(String) | Create a new YAxis and add it to this list.
 | Add(T) | Adds an object to the end of the List<(Of <T>)>.


BinarySearch Method

BinarySearch Method
Namespaces ► ZedGraph ► YAxisList ► BinarySearch()()
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element.
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.


CopyTo Method

CopyTo Method
Namespaces ► ZedGraph ► YAxisList ► CopyTo()()
Members
Icon | Member | Description
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array.
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.


FindIndex Method

FindIndex Method
Namespaces ► ZedGraph ► YAxisList ► FindIndex()()
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


FindLastIndex Method

FindLastIndex Method
Namespaces ► ZedGraph ► YAxisList ► FindLastIndex()()
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


IndexOf Method

IndexOf Method
Namespaces ► ZedGraph ► YAxisList ► IndexOf()()
Members
Icon | Member | Description
 | IndexOf(String) | Return the zero-based position index of the Axis with the specified Title.
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


LastIndexOf Method

LastIndexOf Method
Namespaces ► ZedGraph ► YAxisList ► LastIndexOf()()
Members
Icon | Member | Description
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


Reverse Method

Reverse Method
Namespaces ► ZedGraph ► YAxisList ► Reverse()()
Members
Icon | Member | Description
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>.
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.


Sort Method

Sort Method
Namespaces ► ZedGraph ► YAxisList ► Sort()()
Members
Icon | Member | Description
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer.
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer.
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer.
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>.


AccessibilityNotifyClients Method

AccessibilityNotifyClients Method
Namespaces ► ZedGraph ► ZedGraphControl ► AccessibilityNotifyClients()()
Members
Icon | Member | Description
 | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
 | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .


BeginInvoke Method

BeginInvoke Method
Namespaces ► ZedGraph ► ZedGraphControl ► BeginInvoke()()
Members
Icon | Member | Description
 | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
 | BeginInvoke(Delegate, array<Object>[]()) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on.


GetChildAtPoint Method

GetChildAtPoint Method
Namespaces ► ZedGraph ► ZedGraphControl ► GetChildAtPoint()()
Members
Icon | Member | Description
 | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
 | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates.


Invalidate Method

Invalidate Method
Namespaces ► ZedGraph ► ZedGraphControl ► Invalidate()()
Members
Icon | Member | Description
 | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.
 | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
 | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control.


Invoke Method

Invoke Method
Namespaces ► ZedGraph ► ZedGraphControl ► Invoke()()
Members
Icon | Member | Description
 | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle.
 | Invoke(Delegate, array<Object>[]()) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments.


PerformLayout Method

PerformLayout Method
Namespaces ► ZedGraph ► ZedGraphControl ► PerformLayout()()
Members
Icon | Member | Description
 | PerformLayout()() | Forces the control to apply layout logic to all its child controls.
 | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls.


ResumeLayout Method

ResumeLayout Method
Namespaces ► ZedGraph ► ZedGraphControl ► ResumeLayout()()
Members
Icon | Member | Description
 | ResumeLayout()() | Resumes usual layout logic.
 | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests.


RtlTranslateAlignment Method

RtlTranslateAlignment Method
Namespaces ► ZedGraph ► ZedGraphControl ► RtlTranslateAlignment()()
Members
Icon | Member | Description
 | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
 | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
 | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.


Scale Method

Scale Method
Namespaces ► ZedGraph ► ZedGraphControl ► Scale()()
Members
Icon | Member | Description
 | Scale(Single) | Obsolete.
 | Scale(Single, Single) | Obsolete.
 | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor.


SetBounds Method

SetBounds Method
Namespaces ► ZedGraph ► ZedGraphControl ► SetBounds()()
Members
Icon | Member | Description
 | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size.
 | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size.


UpdateBounds Method

UpdateBounds Method
Namespaces ► ZedGraph ► ZedGraphControl ► UpdateBounds()()
Members
Icon | Member | Description
 | UpdateBounds()() | Updates the bounds of the control with the current size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location.
 | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size.


Validate Method

Validate Method
Namespaces ► ZedGraph ► ZedGraphControl ► Validate()()
Members
Icon | Member | Description
 | Validate()() | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order.
 | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on.


ValidateChildren Method

ValidateChildren Method
Namespaces ► ZedGraph ► ZedGraphControl ► ValidateChildren()()
Members
Icon | Member | Description
 | ValidateChildren()() | (Overrides ContainerControl.ValidateChildren()().)
 | ValidateChildren(ValidationConstraints) | (Overrides ContainerControl.ValidateChildren(ValidationConstraints).)


BinarySearch Method

BinarySearch Method
Namespaces ► ZedGraph ► ZoomStateStack ► BinarySearch()()
Members
Icon | Member | Description
 | BinarySearch(Int32, Int32, T, IComparer<(Of <T>)>) | Searches a range of elements in the sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.
 | BinarySearch(T) | Searches the entire sorted List<(Of <T>)> for an element using the default comparer and returns the zero-based index of the element.
 | BinarySearch(T, IComparer<(Of <T>)>) | Searches the entire sorted List<(Of <T>)> for an element using the specified comparer and returns the zero-based index of the element.


CopyTo Method

CopyTo Method
Namespaces ► ZedGraph ► ZoomStateStack ► CopyTo()()
Members
Icon | Member | Description
 | CopyTo(array<T>[]()) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the beginning of the target array.
 | CopyTo(Int32, array<T>[](), Int32, Int32) | Copies a range of elements from the List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.
 | CopyTo(array<T>[](), Int32) | Copies the entire List<(Of <T>)> to a compatible one-dimensional array, starting at the specified index of the target array.


FindIndex Method

FindIndex Method
Namespaces ► ZedGraph ► ZoomStateStack ► FindIndex()()
Members
Icon | Member | Description
 | FindIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | FindIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | FindIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


FindLastIndex Method

FindLastIndex Method
Namespaces ► ZedGraph ► ZoomStateStack ► FindLastIndex()()
Members
Icon | Member | Description
 | FindLastIndex(Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | FindLastIndex(Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | FindLastIndex(Int32, Int32, Predicate<(Of <T>)>) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


IndexOf Method

IndexOf Method
Namespaces ► ZedGraph ► ZoomStateStack ► IndexOf()()
Members
Icon | Member | Description
 | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <T>)>.
 | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that extends from the specified index to the last element.
 | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <T>)> that starts at the specified index and contains the specified number of elements.


LastIndexOf Method

LastIndexOf Method
Namespaces ► ZedGraph ► ZoomStateStack ► LastIndexOf()()
Members
Icon | Member | Description
 | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <T>)>.
 | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that extends from the first element to the specified index.
 | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <T>)> that contains the specified number of elements and ends at the specified index.


Reverse Method

Reverse Method
Namespaces ► ZedGraph ► ZoomStateStack ► Reverse()()
Members
Icon | Member | Description
 | Reverse()() | Reverses the order of the elements in the entire List<(Of <T>)>.
 | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.


Sort Method

Sort Method
Namespaces ► ZedGraph ► ZoomStateStack ► Sort()()
Members
Icon | Member | Description
 | Sort()() | Sorts the elements in the entire List<(Of <T>)> using the default comparer.
 | Sort(IComparer<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified comparer.
 | Sort(Int32, Int32, IComparer<(Of <T>)>) | Sorts the elements in a range of elements in List<(Of <T>)> using the specified comparer.
 | Sort(Comparison<(Of <T>)>) | Sorts the elements in the entire List<(Of <T>)> using the specified Comparison<(Of <T>)>.